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Welcome to Desktop Video!

We hope you share our dream for the television industry to become a truly 
creative industry by allowing anyone to have access to the highest quality video.

Previously high end television and post production required investment in millions 
of dollars of hardware, however with Blackmagic video hardware, even 10 bit 
uncompressed is now easily affordable. We hope you get years of use from your 
new UltraStudio, DeckLink or Intensity and have fun working with some of the 
world’s hottest television and design software!

This instruction manual should contain all the information you’ll need on 
installing your Blackmagic video hardware. If you're installing a PCI Express 
card, it’s always a good idea to ask a technical assistant for help if you have not 
installed hardware cards into computers before. As Blackmagic video hardware 
uses uncompressed video and the data rates are quite high, you’ll need fast disk 
storage and a high-end computer.

We think it should take you approximately 10 minutes to complete installation.  
Before you install Blackmagic video hardware, please check our website at 
www.blackmagicdesign.com and click the support page to download the 
latest updates to this manual and Desktop Video driver software. Lastly, please 
register your Blackmagic video hardware when downloading software updates. 
We would love to keep you updated on new software updates and new 
features. Perhaps you can even send us your latest show reel of work completed 
on your Blackmagic video hardware and any suggestions for improvements to 
the software. We are constantly working on new features and improvements, so 
we would love to hear from you!

Grant Petty
CEO Blackmagic Design

http://www.blackmagicdesign.com
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Introducing Desktop Video
Blackmagic Design's Desktop Video software includes drivers, plug-ins and applications for your UltraStudio, 
DeckLink or Intensity. You can use Desktop Video software by itself or else work directly within video software 
from companies including Adobe, Apple and Avid.

This manual takes you through the computer system requirements, how to install your video hardware and 
software, and how to use it with software from Blackmagic Design, Adobe, Apple and Avid. Connection 
diagrams and reference information for developers can be found at the back of the manual.

Your Computer's System Requirements
UltraStudio, DeckLink and Intensity are all designed to work with the highest quality uncompressed video. 
This high quality is exciting but also very demanding for your computer and disk storage. We recommend 
the following minimum computer system configurations.

All platforms require a minimum of 4 GB of RAM for SD, HD, 2K and Ultra HD 4K video. PCIe x1 lane cards 
should work in any slot. PCIe x4 lane cards require a x4 lane or faster PCI Express slot.

Mac OS X
Desktop Video software runs on the latest Lion and Mountain Lion versions of Mac OS X.

An Intel-based Mac Pro computer is required if your Blackmagic video hardware connects to the computer 
via a PCI Express slot.

An Intel-based Mac computer with a Thunderbolt™ port and cable are required if your Blackmagic video 
hardware connects to the computer via Thunderbolt.

Windows
Desktop Video runs exclusively on 64-bit versions of Windows, with the latest service pack installed. Both 
Windows 7 and Windows 8 are supported.

An Intel-based PC with a Thunderbolt port and cable are required if your Blackmagic video hardware 
connects to the computer via Thunderbolt.

A USB 3.0 port using a Renesas chipset is required if your Blackmagic video hardware connects to the 
computer via USB 3.0.

Linux
Desktop Video runs on 32-bit and 64-bit x86 computers running Linux 2.6.23 or higher. Please refer to the 
release notes for the latest list of supported Linux distributions, package formats and software dependencies.
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How to Install your Blackmagic video hardware
This section guides you through how to install your Blackmagic video hardware into your computer.

Installing a card with a fiber optic module can be a little fiddly so we also include some tips on how to do  
it easily.

If your Blackmagic video hardware connects via USB 3.0, go straight to the USB 3.0 section.  
Blackmagic's USB 3.0 video products require a compatible Windows PC so you won't find instructions for 
Mac or Linux.

If your Blackmagic video hardware connects via Thunderbolt, go straight to the Thunderbolt section. 
Thunderbolt ports are found on the latest Mac OS X and Windows computers.

Installing a Blackmagic PCIe card
Please review the Adding PCI Express Cards section in your computer user manual for information on how 
to safely install PCI Express cards, including your DeckLink or Intensity card.

Step 1. Remove the power plug from the back of your computer and ensure that you are statically 
discharged by using an anti-static strap.

Step 2. Remove the side cover or chassis cover of your computer to gain access to the PCIe slots. 

Step 3. Remove your Blackmagic PCIe card from the protective static bag, making sure you don’t touch 
the gold connectors on the base of the card. These precautions should be taken when handling 
any PCI card. If you have a DeckLink Optical Fiber card, the fiber optic module needs to be 
temporarily removed to allow the card to be maneuvered into its slot.

Step 4. The product box or website should tell you if your Blackmagic PCIe card requires a x1, x4 or x8 
lane PCIe slot. Locate a slot in your computer which is this speed or faster.

Step 5. Remove the metal port access cover from the desired PCIe slot.

Step 6. Insert your Blackmagic PCIe card and ensure that it clicks firmly into place.

Step 7. If your Blackmagic PCIe card includes an HDMI bracket, insert the bracket into a spare PCIe slot. 
If your computer doesn't have a spare PCIe slot but does have a single-width graphics card, you 
should be able to insert the HDMI bracket into the spare port usually reserved for a double-width 
graphics card. 

Step 8. Secure the card and HDMI bracket with the screws, bracket or clamp. 

Step 9. If you have installed an HDMI bracket, loop the included HDMI cables around any other installed 

Install any model of Blackmagic PCIe card in a spare slot as 
shown in the above picture. Some cards include an HDMI 
bracket, which installs in any spare port, and connects to the rear 
of the card with the supplied HDMI cables.
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cards and plug them into the rear of the DeckLink card. 

Step 10. If you have a DeckLink Optical Fiber card, reinsert the fiber optic module into the card.

Step 11. Replace the cover of your computer and connect the breakout cable if one is supplied with your 
model of Blackmagic card.

Step 12. Reconnect the power and start up the computer.

Before connecting Blackmagic Design USB 3.0 hardware to your computer
Before using your Blackmagic video hardware, it is essential to run the latest USB 3.0 drivers and firmware for 
your USB 3.0 equipped motherboard. Currently the Renesas USB 3.0 host controller uPD720200 is used by 
all motherboards recommended by Blackmagic Design, and requires the installation of the latest Renesas 
Electronics USB 3.0 drivers and firmware. These updates can be found on the websites of motherboard and 
computer manufacturers as well as via third party driver websites.

Connecting Blackmagic video hardware to your Windows USB 3.0 computer
Step 1. If your Blackmagic video hardware includes an external power supply, connect it to the unit and 

switch on the power.

Step 2. Connect a SuperSpeed USB 3.0 cable between the unit and a dedicated USB 3.0 port on your 
computer.

Step 3. If Desktop Video software has previously been installed and offers to update the internal software, 
click Update and follow any onscreen instructions.

Step 4. Connect the breakout cable, if one is supplied with your model of Blackmagic video hardware, 
and plug the connectors into your video equipment.

Connecting Blackmagic video hardware to your computer with Thunderbolt
Step 1. If your Blackmagic video hardware includes an external power supply, connect it to the unit and 

switch on the power.

Step 2. Connect a Thunderbolt cable between the unit and a Thunderbolt port on your computer, or to 
a Thunderbolt disk array which is attached to your computer.

Step 3. If Desktop Video software has previously been installed and offers to update the internal software, 
click Update and follow any onscreen instructions.

Step 4. Connect the breakout cable, if one is supplied with your model of Blackmagic video hardware, 
and plug the connectors in to your video equipment.

Connect the breakout cable if one is supplied with your model of 
Blackmagic card. Some card models also include a HDMI bracket 
as pictured above.

USB 3.0 and Thunderbolt™ products connect to your computer 
with a single USB 3.0 or Thunderbolt cable.
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Install the Blackmagic Design Software

After installing your hardware, the next step is to install the Blackmagic Design Desktop Video software. 
Please jump to the installation instructions for Mac OS X, Windows and Linux in this section. 

Installing Blackmagic Desktop Video Drivers on Mac OS X
Before installing any software you will need administrator privileges.

Step 1. Ensure you have the very latest driver. Visit www.blackmagicdesign.com/support

Step 2. Open the “Desktop Video Installer” folder from the disc or downloaded disk image and launch 
the “Desktop Video Installer” installer.

Step 3. Click Continue, Agree and Install buttons and the software will be installed on your system.

Step 4. Now restart your computer to enable the new software drivers.

Plugins and Applications that are installed
The Desktop Video software installs the following components:

 � Blackmagic Desktop Video drivers
 � Blackmagic Design system preference
 � Blackmagic Design LiveKey
 � Blackmagic Media Express
 � Blackmagic Multibridge Utility
 � Blackmagic QuickTime™ codecs
 � Blackmagic Disk Speed Test
 � Adobe® Premiere Pro, After Effects, Photoshop presets and plug-ins
 � Apple Final Cut Pro™ 7 Easy Setups, presets and enablers
 � Apple Final Cut Pro™ X plug-ins
 � Avid Media Composer 6.x plug-ins

Automatic Updates
After your Mac has restarted, the software will check the Blackmagic video hardware to see what internal 
software the hardware contains. If the internal software version does not match the driver version, Desktop 
Video will offer to update the internal software. This is automatic and all you need to do is click OK to start 
the update. After the internal software has updated, restart your Mac to complete the process.

Follow install prompts.

Select Destination.

http://www.blackmagicdesign.com/support
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Installing Blackmagic Desktop Video Drivers on Windows
Step 1. Ensure you have the very latest driver. Visit www.blackmagicdesign.com/support

Step 2. Open the “Desktop Video” folder and launch the “Desktop Video” installer.

Step 3. The drivers will now be installed on your system. An alert will appear: “Do you want to allow the 
following program to install software on this computer?” Click Yes to continue.

Step 4. You will see a dialog bubble saying “found new hardware” and the hardware wizard will appear. 
Select “install automatically” and the system will find the required Desktop Video drivers. You will 
then receive another dialog bubble saying “your new hardware is ready for use.”

Step 5. Now restart your computer to enable the new software drivers.

Plugins and applications that are installed
The Desktop Video software installer installs the following components:

 � Blackmagic Desktop Video drivers
 � Blackmagic Design Control Panel
 � Blackmagic Design LiveKey
 � Blackmagic Media Express
 � Blackmagic Multibridge Utility
 � Blackmagic AVI and QuickTime™ codecs
 � Blackmagic Disk Speed Test
 � Adobe® Premiere Pro, After Effects, Photoshop presets and plug-ins
 � Avid Media Composer 6.x plug-ins
 � eyeon Fusion plug-ins

Automatic updates
After your computer has restarted, the software will check the Blackmagic video hardware to see what 
internal software the hardware contains. If the internal software version does not match the driver version, 
Desktop Video will offer to update the internal software. This is automatic and all you need to do is click OK 
to start the update. After the internal software has updated, restart your computer to complete the process.

Restart your PC!

Click “Yes”.

Desktop Video Setup Wizard

http://www.blackmagicdesign.com/support
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Installing Blackmagic Desktop Video Drivers on Linux
Step 1. Download the latest Desktop Video software for Linux from www.blackmagicdesign.com/support

Step 2. Open the “Desktop Video” folder and locate and open the “Desktop Video” package for your 
Linux distribution. Refer to the ReadMe file for the latest list of Linux distributions for which can be 
installed from a graphical user interface.

Step 3. Click the "Install" button and wait for the progress bar to complete.

Step 4. If there are messages about missing dependencies, ensure they are installed first and then rerun 
the Desktop Video installer.

Step 5. When finished, the installer will return to the same screen.

Step 6. Restart the computer to enable the drivers or type the following command:

 # modprobe blackmagic

If you cannot find a native Desktop Video package for your Linux distribution, or if you prefer to install from 
a command line, refer to the ReadMe file for detailed installation instructions.

If you encounter any errors during the installation, refer to the ReadMe file for help.

Plugins and Applications that are installed
Desktop Video software installs the following components:

 � Blackmagic Desktop Video drivers
 � Blackmagic Design Control Panel
 � Blackmagic Media Express
 � Blackmagic AVI codecs

Desktop Video software ready to be installed from the  
Ubuntu Software Center

http://www.blackmagicdesign.com/support
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Updates
After your computer has restarted, the drivers will check the Blackmagic video hardware to see what internal 
software the hardware contains. If the internal software version does not match the driver version, Desktop 
Video will prompt you to update. Type the following command in terminal to find out the card ID of any 
cards that need updating:

# BlackmagicFirmwareUpdater status

A message similar to the following will appear:

/dev/blackmagic/card0 [DeckLink HD Extreme 3] UPDATED

/dev/blackmagic/card1 [DeckLink HD Extreme 3] NEEDS_UPDATE

Note the ID of the card that needs to be updated and then update the firmware by typing:

# BlackmagicFirmwareUpdater update <card_id> (1 in this case)
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Using Blackmagic System Preferences
Blackmagic system preferences provide a central location so you don't need to configure the same settings 
in each video application that you use, for example down conversion.

 � On Mac OS X, open the System Preferences and look in the “Other” category to locate the 
Blackmagic Design icon. Click the Blackmagic Design icon to gain access to the settings.

 � On Windows 7 and Windows 8, open the Control Panel and click on the “Hardware and Sound” 
category to reveal the Blackmagic Design Control Panel. Click the Blackmagic Design Control 
Panel to gain access to the settings.

 � On Linux, go to "Applications" and then "Sound and Video" to locate the Blackmagic Control 
Panel. Double-click on the Blackmagic Control Panel to gain access to the settings. All features can 
be controlled by your own software using the Blackmagic SDK.

Different Blackmagic video hardware models have different features. Only those system preferences 
supported by your hardware model will be active and available to change.

The following section takes you through the Blackmagic system preferences you might see when using 
Blackmagic video hardware.

Blackmagic Design system preferences in Mac OS X Blackmagic Design Control Panel in Windows Blackmagic Design Control Panel in Ubuntu Linux
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Video and Audio Output connections
All of the video and audio outputs of Blackmagic video hardware are active all of the time. On some models 
you can choose between component analog video, S-Video or composite analog video.

The SDI, Optical Fiber SDI, HDMI and component analog video outputs support HD and SD video. S-Video 
and composite analog video do not support high definition video. S-video may require the use of an 
inexpensive S-video adapter cable.

Switchable Audio Output
Some models have switchable audio outputs. You can choose to output:

 � 4 analog and 2 AES/EBU audio channels, or
 � 2 analog and 6 AES/EBU audio channels

Video and Audio Input connections
Your Blackmagic video hardware may support some or all of the following combinations:

 � SDI Video & SDI Audio
 � SDI Video & AES/EBU Audio
 � SDI Video & Analog XLR Audio
 � Optical SDI Video & Optical SDI Audio
 � HDMI Video & HDMI Audio
 � HDMI Video & AES/EBU Audio
 � HDMI Video & Analog XLR Audio

 � Component Video & AES/EBU Audio
 � Component Video & Analog XLR Audio
 � Composite & AES/EBU Audio
 � Composite & Analog XLR Audio
 � S-Video & AES/EBU Audio
 � S-Video & Analog XLR Audio

Video and Audio output connections.

Video and Audio input connections.
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NTSC setup
The NTSC composite video used in the USA, and some other countries, uses 7.5 IRE setup. If you’re working 
in Japan and countries that don’t use this setup, leave this set to 0 IRE setup. PAL and high definition 
standards do not use this setup.

Output 4:4:4 color mode
While most users work with 4:2:2 video, you will need to Select 4:4:4 on video output if you wish to play out 
4:4:4 video, otherwise the video will show weird pink and green colors. 1080p50/60 video will always be 
output as 4:2:2.

When 4:4:4 video output is enabled, the following features are not available:

 � simultaneous HD and down converted SD video output
 � down converted analog video output.

Single Link/Dual Link switch
When working with high bandwidth video formats such as 1080p60 or any 4:4:4 format, choose between 
single link 3G-SDI and dual link HD-SDI.

When working in Ultra HD 4K formats, choose between single link 6G-SDI and dual link 3G-SDI.

Progressive HD1080 video playback switch
Choose between 1080PsF and 1080p on playback.

NTSC Setup.

Output 4:4:4 color mode

Single Link/Dual Link switch

Progressive HD1080 video playback switch
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Remove Field Jitter
When interlaced video is paused on old CRT monitors, eliminate field flicker by only displaying a single field. 
We do not recommend using this option with modern flat screens.

Set default video standard
On Mac OS X, if you want to use broadcast monitoring with Final Cut Pro X, set the video standard in these 
preferences so that it matches your Final Cut Pro X project. This setting is exclusively used by Final Cut Pro 
X. If you also have the extended desktop feature enabled, setting the default video standard will also set the 
video standard for the extended desktop at startup time.

On Windows, if you want to capture video with any program that supports WDM (Windows Driver Model), 
you'll need to set the default video standard so it matches the video you want to capture. If your program 
supports WDM, you will usually find "Blackmagic WDM Capture" listed as a video source option in the 
program's video capture preferences. Setting the video standard within the preferences of the WDM 
program will work with most WDM programs. However if any problems are encountered with capturing 
video, try using the Blackmagic Design Control Panel to set the default video standard instead.

Frame output switch
If you have switched out of a video application and video is no longer being played, this setting determines 
whether your Blackmagic video hardware will output black or the last played frame of video or an extended 
desktop.

If you are adjusting LUTs on some Blackmagic models, set this option to Last Played Frame so you can 
observe the effect of any adjustment to LUTs.

The extended desktop feature is supported on some Blackmagic models. Enabling or disabling the feature 
requires a restart of the computer. It's important that you set the extended desktop to the same standard 
as your video capture and playback, or you will get slower switching between capture and playback modes, 
as the monitors need to re-lock.

HDMI monitoring formats in 3D mode
When monitoring 3D stereoscopic video, select a format which is supported by your HDMI display: Frame 
Packing, Side by Side, Line by Line, Top and Bottom, Left Eye or Right Eye.

Reference Output Timing
A reference signal may also be known as genlock, black burst, house sync or tri-sync. If you have reference 
connected but your picture is rolling, adjust the "Set reference output timing" until the picture locks and is 
no longer rolling on the Blackmagic video output.

HDMI 3D monitoring formats

Set the default video standard to match your 
Final Cut Pro X project or to capture with your 
WDM program

Frame output switch

Genlock timing adjustment.
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Up/Down/Cross Conversion
The Desktop Video drivers can be used to downconvert high definition to NTSC or PAL video in real time 
during capture or playback. They also provide upconversion on capture. Select the desired option from the 
output or input processing menus.

Some Blackmagic video hardware models support simultaneous down conversion on output such as HD & 
SD or 2K & SD. Simultaneous down conversion introduces a 2 frame delay on the SD-SDI output. To ensure 
accuracy, adjust the playback/timecode offset options when performing an insert or assemble edit to tape with  
Final Cut Pro, Premiere Pro or Blackmagic Media Express.

Analog video outputs are also down converted so you can always see video on an S-Video or composite 
analog monitor. Component analog video can be switched between HD or SD output. Choose to  
Enable Conversion on Analog Output, if you wish to view component analog standard definition video 
output, when simultaneous down conversion is enabled.

Output HD 23.98PsF at HD 59.94i (Windows only)
23.98 fps is a common film frame rate but support for this frame rate in SDI and analog monitors is rare. 
Enabling this option will apply 3:2 pulldown processing so that HD 23.98 PsF video is output as HD 59.94i. 
Almost all HD monitors support HD 59.94i.

VITC Reader A Frame - Reverse 3:2 Pulldown
This option decodes the VITC and uses it to correctly locate the A-frame when performing reverse 3:2 
pulldown while capturing video at 23.98fps. Carefully set the correct A-frame VITC reference to match the 
timecode on tape. Selecting the wrong A-frame will generate incorrect presentation of fields and frames.

HDTV Up/Down Converter output processing.

Output HD 23.98PsF at HD 59.94i

Set the A-Frame VITC Reference when performing 3:2 pulldown.
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Preserving Blanking Data or VANC
This feature lets you use up to 3 video lines at the top of a captured movie file to store any 3 lines from 
vertical blanking. This allows 3 line timecode, VITC (vertical interval test signals) subtitle info or any other 
VANC data to be preserved during capture. These lines are then inserted back into the video blanking when 
the file is played back.

To preserve VANC data, select the VANC and 3:2 Pulldown tab and tick the On check box for video line 1, 2 
or 3 depending on how many blanking lines you want to capture.

Video file line 1 needs to be enabled for lines 2 and 3 to work.

Because these lines can be passed to the application, a developer could write software to read the VANC 
data and use it for various purposes, e.g. 3-line timecode and audio chasing, or other uses.

An example of VANC data is 3-line timecode, which uses lines 18, 19, and 20 in NTSC or lines 19, 20 and 
21 in PAL. 3-line timecode, as used in AATON™ equipped telecine suites, featuring audio timecode and 
keycode information along with the normal timecode numbers.

Video Levels
The video processing amplifier (Video Proc Amp) is used to adjust analog video and chroma levels and 
ideally should always be used in conjunction with a waveform monitor. The option to Calibrate Analog 
Video In is only available if the Set Input option in the Settings tab is set to analog video input.

By default, Blackmagic products use SMPTE component analog levels as almost all analog video monitors 
and modern video equipment use SMPTE levels. Enable the checkbox "Use Betacam YUV Levels" if working 
with Sony Betacam SP decks. If in doubt, try a test capture and you should see a very noticeable brightness 
shift if you choose the wrong levels.

Audio Levels
The audio processing amplifier (Audio Proc Amp) is used to raise or lower audio signals. Analog audio 
channels can be adjusted independently from each other. AES/EBU audio channels are raised or lowered 
together.

Professional analog audio levels and XLR audio connectors are standard on UltraStudio and DeckLink 
models. If you need to connect to consumer audio equipment with analog RCA inputs, enable the option 
to Use HiFi Audio Levels and use an inexpensive XLR to RCA adapter for each audio connection. Intensity 
models always have this option enabled as they exclusively use HiFi audio levels and RCA connections for 
analog audio.

VANC preferences.

Video levels
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It's a good idea to run a quick test to ensure you can capture and play back video before you need to use 
your Blackmagic video hardware for anything important:

 � Connect a video monitor or TV to the video output of your Blackmagic video hardware. An HDMI 
TV is very convenient for this test as both video and audio can be monitored without needing 
external audio connections.

 � Connect a video source to the video input of your Blackmagic video hardware, especially a camera 
or deck. DVD players shouldn't be used for this test as they typically have copy protection on their 
HDMI and analog outputs so you won't be able to capture from them even if you're using home-
made DVD's.

 � Use the Blackmagic system preferences to set your video and audio connections for input and 
output. See the previous "Using Blackmagic System Preferences" section for details.

 � Locate Blackmagic Media Express and open it:
 - on Mac OS X, look in the Applications folder.
 - on Windows 7, go to the Start menu and choose Programs>Blackmagic Design>Media  

   Express on Windows 8, go to the Start page and click on the Blackmagic Media Express tile.
 - on Linux, go to Applications and look in the Sound and Video folder.

Video Playback test using Blackmagic Media Express
Import a test clip in to Media Express. If you see a message that the selected video format is not compatible 
with the current project, click "Don't save" to discard the current project and create a new project for  
the test clip.

Double-click the test clip and you should see the video on the monitor connected to the output of your 
Blackmagic video hardware. Audio output can also be monitored.

Video Capture test using Blackmagic Media Express
 � Go to Media Express>Preferences on Mac OS X or Edit>Preferences on Windows or Linux.
 � Select a project format which matches your video source and choose a capture file format.
 � Set the storage location for your captured video and audio and choose whether to stop capture 

or playback if dropped frames are detected. Choose a compressed capture file format so you can 
capture to any disk.

 � Close the Preferences and click on the Log and Capture tab. You should immediately see your 
video source in the video preview pane of Media Express.

 � Click Capture to perform the capture test. Click Capture again to finish the test. Double-click on 
the captured clip in the Media List to play it back on screen and on the outputs of your Blackmagic 
video hardware.

Camera Outputs

HDTV

Click the "Capture" button to commence recording

Connect a video monitor and source to your Blackmagic video 
hardware



Using your Favorite Editing Software18

Adobe After Effects CC

“Output Module Settings” rendering options

“Video Preview” preferences

Adobe After Effects CC

How to use Blackmagic as a preview output frame buffer
To allow your Adobe After Effects composition to be displayed in real-time through your Blackmagic video 
hardware, go to Preferences > Video Preview.  Select Blackmagic Video Output and the appropriate Output 
Mode. This lets you view your Adobe After Effects compositions in the correct video colorspace on your 
broadcast monitor as you work. You will always see the correct color and interlace when working, and you 
don’t have to wait until your composition is rendered to see what it looks like when output as video.

If you want to listen to audio through your Blackmagic hardware, go to System Preferences in  
Mac OS X or Control Panel on Windows and set Blackmagic Audio as your default sound output device. 
In After Effects, go to Preferences>Audio Hardware and make sure your audio output is now set to  
System Default Input/Output on Mac OS X or Blackmagic Audio on Windows.

Rendering
When you have completed your composition, you will need to render to a pixel format supported by your 
Blackmagic video hardware. You can render to a DPX image sequence or any of the following supported 
codecs:

Other codecs including ProRes and DVCPRO HD will be available if Final Cut Pro is installed on the same 
computer.

Other codecs including DVCPRO HD and DVCPRO50 will be available if Premiere Pro is installed on the 
same computer.

 � Blackmagic RGB 10 bit (uncompressed)
 � Apple Uncompressed YUV 10 bit 4:2:2
 � Apple Uncompressed YUV 8 bit 4:2:2

 � Apple Photo - JPEG (compressed)
 � Apple DV - NTSC (compressed)
 � Apple DV - PAL (compressed)

 � Blackmagic 10 bit 4:4:4 (uncompressed)
 � Blackmagic 10 bit 4:2:2 (uncompressed)
 � Blackmagic HD 8 bit 4:2:2 (uncompressed)

 � Blackmagic SD 8 bit 4:2:2 (uncompressed)
 � Blackmagic 8 bit MJPEG (compressed)

AVI codecs on Windows

 � Blackmagic RGB 10 bit (uncompressed)
 � Blackmagic 10 bit (uncompressed)
 � Blackmagic 8 bit (uncompressed)

 � Apple Photo-JPEG (compressed)
 � Apple DV - NTSC (compressed)
 � Apple DV - PAL (compressed)

QuickTime codecs on Windows

QuickTime codecs on Mac OS X
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Adobe Photoshop CC

How to grab and output video frames

Import an image into Photoshop
Step 1. From Photoshop select File > Import > Blackmagic Image Capture

Step 2. Select the “Video Input Format” and the “Image Bit Depth” and then click Capture Image

Export an image from Photoshop
Step 1. Select File > Export > Blackmagic Image Export 

Step 2. Select Video Output Format and then click Output Image

Once you have set the options in the “Import” or “Export” windows, each subsequent Import and 
Export will not display the window, so you can grab and output frames much faster. However if you 
would like to change your import or export formats, hold the Option [Mac] or Ctrl [Win] key, when 
selecting import or export.

Image Capture

Image Export

Adobe Photoshop CC
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Adobe Premiere Pro CC

Setting up a Blackmagic Design project
Step 1. Launch Premiere Pro.

Step 2. Create a New Project and click on the Scratch Disks tab.

Step 3. Set the desired Location and Name for your project at the bottom of this window.

Step 4. Set the locations for your captured video, captured audio, video previews and audio previews.

Step 5. Click on the General tab and  review the Video Rendering and Playback settings. If your graphics 
card is supported by Premiere Pro's Mercury Playback Engine, the Renderer option will be 
available and you should switch it to "Mercury Playback Engine GPU Acceleration".

Step 6. Set the Capture Format to Blackmagic Capture and click on the Settings [Mac] or Properties [Win] 
button to reveal the Blackmagic Capture Settings for your project. The Video Standard can be set 
to NTSC, PAL, HD720, HD1080 or 2K. The Video Format can be uncompressed or compressed. 
Now click OK.

Step 7. The New Sequence window will appear. To preserve maximum video quality, you'll need to create 
a full resolution uncompressed sequence. To do so, click the discovery triangle next to "Blackmagic 
Design" select a preset to match the video standard and choose from uncompressed 8 bit YUV, 
10 bit YUV or 10 bit RGB. If you don't have the storage space or disk speed for uncompressed 
video, choose a JPEG sequence preset for a full resolution, open-standard codec.

 Premiere Pro also includes a variety of sequence presets for compressed and RAW camera 
formats. Any clips you drop in to a resulting sequence will be rendered in the compressed or RAW 
camera format. For example any clips dropped into a DVCPRO HD sequence will be rendered in 
the compressed DVCPRO HD format even if they are uncompressed clips.

 When you have selected the desired sequence preset, give the sequence a name and click OK.

Audio
Blackmagic audio hardware needs to be selected each time a new project is created. Go to Preferences > 
Audio Hardware and set the Default Device to Blackmagic Audio.

Now go to Preferences > Audio Output Mapping and set "Map Output for" to "Blackmagic Audio". 
Configure the mix of the multi-channel audio as desired.

New Sequence

Audio Output Mapping

Adobe Premiere Pro CC
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Device Control
Many Blackmagic Design capture and playback models feature RS-422 device control for controlling decks. 
Blackmagic Device Control needs to be selected each time a new project is created. Go to Preferences > 
Device Control and select "Blackmagic Device Control".

The Options button is disabled as the settings are automatically detected and configured when you choose 
Blackmagic Device Control.

Playback
Playback settings need to be selected each time a new project is created by going to Preferences > Playback.

The default player is Adobe Player but the Audio Device needs to be switched to "Blackmagic Playback".

Under "Video Device," enable the checkbox for "Blackmagic Playback" and ensure the other checkboxes 
are cleared. If working with other video applications such as After Effects, you'll usually want to enable the 
option to "Disable video output when in the background." Click OK to close out of the Preferences.

As a quick test to make sure everything is connected correctly, use the Premiere Pro test media (Bars and 
Tone or Universal Counter Leader). Drag your test media from within the Premiere Pro project and drop it 
on to the timeline. You should now see the image on both your computer desktop and the output of your 
Blackmagic video hardware. If you can’t see any video on your Blackmagic output, check the connections 
again and ensure you have the correct output settings configured in the Blackmagic Design system 
preference. SDI, HDMI and analog outputs are always active.

Capture
To capture choose: File > Capture [F5]

To immediately capture, or to capture from a non-controllable device, click the red record button [G].

If you wish to log the clip using RS-422 deck control, enter the desired In and Out points using either the Set 
In and Set Out buttons, or manually by typing the timecode and clicking Log Clip. The empty clip will now 
appear in the Project window. Repeat this until you have logged all of the clips you wish to batch capture.

To change the capture format, click on the Settings tab and then the Edit button. Ensure the Capture Format 
is set to Blackmagic Capture, click on the Settings [Mac] or Properties [Win] button and then change the 
Blackmagic Capture Settings as desired.

Playback

Capture
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Batch Capture
If you wish to batch capture using RS-422 deck control, select the clips you wish to capture by drag-selecting 
or shift-clicking each clip. Then choose: File > Batch Capture [F6]. To set handles on the clips, enable the 
option to Capture with handles and type the number of additional frames you require at the start and end 
of each clip.

Export to Tape 
To export to tape via RS-422 deck control, select the sequence you require and then choose File >  
Export > Tape

Insert editing requires unbroken timecode over the full length of the project which is to be laid to tape.

In assemble mode the tape needs only to be “blacked” until a point just beyond the start time of the 
project. As assemble editing erases the tape ahead of the record heads, it should not be used where other 
projects already exist on the tape after the out point of your edit.

When editing to tape, the software waits at the first frame of your project for the deck to drop into record 
at the predetermined timecode. Should you find that either the first frame of your program is repeated or 
lost, during the edit to tape procedure, you will need to adjust the playback offset to bring the deck and 
computer in sync. You should only need to do this once with any combination of deck and computer and 
the correct setting will be retained.

Now, simply enter the desired in point and offsets if required, and click OK [Mac] or Export [Win].

Export to Tape
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Apple Final Cut Pro 7

Select a Blackmagic Easy Setup

Apple Final Cut Pro 7
“Easy Setups” for Final Cut Pro 7 are automatically installed if Final Cut Pro is installed before the Desktop 
Video software. Blackmagic video hardware is fully compatible with Apple’s RT Extreme™ real time effects.

Setting up
Step 1. Launch Final Cut Pro 7 and the Easy Setup window will appear.

Step 2. Click on the popup menu and select the desired Blackmagic Easy Setup. For each video format 
(NTSC, PAL, HDTV and 2K) you will find a range of Blackmagic compressed and uncompressed 
file formats you can choose.

Step 3. Click on the popup menu named Primary Scratch Disk and select your disk array from the popup 
menu.

Step 4. Click OK and the Final Cut Pro interface will appear.

Playback
As a quick test to make sure everything is connected correctly, use the Blackmagic test media (bars and 
tone) which can be found on the installer CD or disk image. Find a test clip which matches the format of 
your project, e.g. NTSC 8 bit, and copy it to your disk array. Import this clip into your Final Cut Pro project 
and drop it into the timeline. You should now see the image on both your computer desktop and your 
Blackmagic output.

If you can’t see any video on your Blackmagic output, check the connections again and ensure you have the 
correct output settings configured within Final Cut Pro by going to the View > Video Devices In the same 
menu, make sure “External Video” is set to “All Frames”.

Capture from Non-Controllable devices
Many video sources including all kinds of modern cameras and disk recorders, as well as old cameras and 
VHS tape players, do not have any device control. For this reason, after selecting a Blackmagic Easy Setup, 
Final Cut Pro will sometimes warn that device control has been set to “non-controllable device”. This is as 
expected. Click OK and then create a project with these settings.

To capture video from a non-controllable device, choose File > Log & Capture. (Command + 8). Press play 
on your video source and then press the Now button in the Log and Capture window. Final Cut Pro will 
show you a preview of the video you are capturing. Press the ‘esc’ key at the top left of your keyboard to 
stop capturing. 
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Capture from controllable devices with UltraStudio and DeckLink
To capture with RS-422 deck control, choose File > Log & Capture. (Command + 8)

Your video deck will respond in the same way as a clip in the timeline, via the “<spacebar>”, “j”, “k” and 
“l” keys.

To immediately capture, click the Capture Now button. 

To log the clip, enter the desired “in” and “out” points using either the “i” and “o” keys on your keyboard, 
or manually by typing in the timecode and clicking Log Clip. The clip will appear in your browser with a 
diagonal red line indicating that it’s “offline”. Repeat this until you have logged all of the clips you wish to 
capture in a batch.

Batch Capture with UltraStudio and DeckLink
Select the clips you wish to capture by drag selecting or shift-click. Select File > Batch Capture or click on 
the Batch button in the “Logging” tab of the “Log & Capture“ window. (Control + C)

Enable the “Add Handles” box if you wish to capture additional frames (“handles”) before and after the 
“In” and “Out” points of a clip.

Recording to Tape with UltraStudio and DeckLink
Once you have captured your clips, edited them and applied any effects, you will want to record the 
completed project to tape.

One easy method is to select File > Print to Video (Control + M).

If you want to perform precise insert and assemble edits onto a timecode striped tape, select File > Edit  
to Tape.

Naming a clip in the Log and Capture window

Batch Capture
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Apple Final Cut Pro X

Apple Final Cut Pro X
If you want to use Final Cut Pro X to play back video on an external video monitor or TV, you can use the 
broadcast monitoring feature of Final Cut Pro X 10.0.4 and newer to output your video through Blackmagic 
video hardware. You can also use as many as two computer monitors for the Final Cut Pro X interface.

Setting up Final Cut Pro X
Step 1. Ensure you are running Final Cut Pro X 10.0.4 or newer with the latest version of Mac OS X Lion or 

Mountain Lion.

Step 2. Open the System Preferences and click on Blackmagic Design. Go to the setting, "Set default 
video standard as" and then set the same standard that you will use in your Final Cut Pro X 
project, e.g. HD 1080i59.94. The standard should be the same as the video format of your clips.

Step 3. Launch Final Cut Pro X and create a new project.

Step 4. Type a name and choose a location for the new project.

Step 5. Set the Video Properties to Custom and then set the format, resolution and frame rate to match 
the default video standard set in the Blackmagic Design Desktop Video system preferences.

Step 6. Set the Audio and Render Properties to Custom. Set the audio channels to Stereo or else you can 
choose Surround for 6 audio channels. Set the audio sample rate to the television rate of 48kHz. 
Set the render format to the same format as your video clips. Final Cut Pro X defaults to using 
ProRes compression but you can switch this to Uncompressed 10-bit 4:2:2 for an uncompressed 
workflow. Click OK to complete the creation of your new project.

Step 7. Go to the Final Cut Pro menu, choose Preferences and then click the Playback tab. Ensure the A/V 
Output menu has selected "Blackmagic" and the same video standard as your project and then 
close the Preferences.

Step 8. Go to the Window menu and select A/V Output to enable video output via your Blackmagic 
video hardware.

If you also wish to monitor audio via your Blackmagic video hardware, open the System Preferences,  
click the Sound icon, click the Output tab and then select "Blackmagic Audio" for the sound output.

Step 6. Set the Audio and Render Properties to Custom.

Step2. Set the default video standard in the System Preferences 
to match your Final Cut Pro X project.
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Playback
Step 1. Import some clips in to your new project.

Step 2. You can now use the Final Cut Pro X timeline on your computer monitor and view the video 
preview on the monitor or TV connected to the output of your Blackmagic Design video hardware.

Capturing Video and Audio
You can use Blackmagic Media Express to capture video and audio with your Blackmagic Design video 
hardware. Once you have captured the clips, you can import them in to Final Cut Pro X for editing.

When capturing clips with Media Express, make sure you choose one of the video formats which is also 
supported by Final Cut Pro X, i.e.: Apple ProRes 4444, Apple ProRes 422 (HQ), Apple ProRes 422 or 
Uncompressed 10-bit 4:2:2.

Editing to Tape
Once you have completed a project in Final Cut Pro X, you can render the project to a movie file and then 
use Blackmagic Media Express to master the movie to tape with your Blackmagic Design video hardware.

Step 1. Select your clips from the timeline in Final Cut Pro X.

Step 2. Go to the Share menu and choose Export Movie.

Step 3. In the Export Movie window, leave Export on "Current Settings" and also set Include to "Video 
and Audio". Click "Next".

Step 4. Open Media Express and import the clip that was exported from Final Cut Pro X.

Step 5. Refer to the Blackmagic Media Express section of this manual for "Editing video and audio files 
to tape".

Step 3. In the Export Movie window, leave Export on "Current 
Settings" and also set Include to "Video and Audio".
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Avid Media Composer

Avid Media Composer 6
Avid Media Composer captures and plays back standard definition and high definition video and audio 
with Blackmagic video hardware, and also supports RS-422 deck control. Blackmagic plug-ins for Media 
Composer are automatically installed if Media Composer is installed before the Desktop Video software.

You can use the Blackmagic Design system preferences to select your video and audio connections 
including SDI, analog and HDMI, as well as other settings such as up, down and cross conversion, reference 
clocking and HD progressive frame type. If only using a single computer monitor with Media Composer, 
disable the Extended Desktop feature by setting "When not playing video, send" to "Black" and then 
restart the computer. This will avoid the software interface extending on to your video monitor.

Setting up
Step 1. Launch Media Composer and the Select Project dialog box will appear.

Step 2. Choose  your preferred User Profile if you have previously created one.

Step 3. Select the folder in which you want to create the project: Private, Shared or External.

Step 4. Click the New Project button.

Step 5. Type a project name and set the project options including Format, Color Space and Stereoscopic. 
Click OK. Once the project has been created, the frame rate and raster cannot be changed.  
The color space and stereoscopic settings can be changed later in the Format tab of the project. 

Step 6. Double-click the project name in the Select Project dialog box. The Media Composer interface 
will appear along with the project window for your new project. You have completed setting up 
your project.

Playback
As a quick test to make sure everything is connected correctly, go to the Media Composer Editing Guide 
and follow the section entitled "Importing Color Bars and Other Test Patterns". Double-click the imported 
file to play it in a pop-up monitor. You should now see the image on both your computer monitor and your 
Blackmagic output.

If you can’t see any video on your Blackmagic output, check the connections again and ensure you have the 
correct output settings configured within the Blackmagic Design system preferences by choosing Tools > 
Hardware Setup from within Media Composer.

If using a single computer monitor with Media Composer, open 
the Blackmagic Design system preferences and choose to send 
Black when not playing video.

Step 5. Type a project name and set the project options.
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Capture from Non-Controllable devices
Many video sources including all kinds of modern cameras and disk recorders, as well as old cameras and 
VHS tape players, do not have any device control. To capture video without deck control:

Step 1. Choose Tools > Capture to open the Capture Tool.

Step 2. Click the Toggle Source button so that the button's icon of a deck shows a red circle-slash symbol. 
This symbol indicates that deck control has been disabled.

Step 3. Set the Video and Audio input menus to "Blackmagic".

Step 4. Select the video source track (V) and the audio source tracks (A1, A2, ...) you wish to capture.

Step 5. Use the Bin menu to select a Target Bin from the list of open bins.

Step 6. From the Res (resolution) menu, choose which compressed or uncompressed codec you wish 
to use for your captured clips. For maximum quality uncompressed video, choose "1:1" for 8-bit 
video capture or "1:1 10b" for 10-bit video capture.

Step 7. Select the disk storage for your captured video and audio. Use the Single/Dual Drive Mode 
button to determine if video and audio will be stored together on a single drive or video on one 
drive and audio on another drive. Select the target drive(s) for your captured media from the 
Target Drives menu(s).

Step 8. Click the "Tape Name?" button at the bottom of the window to open the Select Tape dialog box.  
Select the desired tape, or add a new one, and then click OK.

Step 9. Ensure your video and audio source is ready or playing and then click the Capture button or press 
the F4 key. The Capture button will flash red while recording. Click the Capture button again or 
press the Escape button on your keyboard to end the capture.Step 2. Set up the Capture Tool to capture video without deck 

control by clicking the Toggle Source button.
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Capture from Controllable devices with UltraStudio and DeckLink
If you have a deck which connects via RS-422, you will need to configure the deck settings before performing 
a capture with deck control:

Step 1. From your project window, click the Settings tab and double-click on Deck Configuration.

Step 2. In the Deck Configuration dialog box, click Add Channel and then set the Channel Type to Direct 
and the Port to RS-422 Deck Control. Click OK and choose "No" when asked, "Do you want to 
autoconfigure the channel now?"

Step 3. Click Add Deck and then select your brand and model of deck from the Device menus and also 
set the desired preroll. Click OK and then Apply.

Step 4. Under the Settings tab, double-click on Deck Preferences.

Step 5. If you plan to make assemble edits to tape, enable the option to "Allow assemble edit & crash 
record for digital cut". If this option is left unchecked, you will only be able to perform insert edits.

Step 6. Enable the option to "Relax coincidence point detection" and set other settings as needed.  
Click OK. You have completed setting up the RS-422 connection to your deck.

To test the RS-422 connection, ensure an RS-422 serial cable is connected between your Blackmagic video 
hardware and the deck. The Remote/Local switch must be set to Remote on the deck so you can use the 
transport controls in Media Composer. Open the Capture Tool and use the standard j, k, l shortcut keys to 
shuttle backwards, pause and shuttle forwards on the deck. If a deck name appears in italics in the Deck 
Selection menu, or "NO DECK" is displayed, click the menu and select Check Decks one or more times, 
until the deck is listed without italics, to reestablish deck control.

To capture with deck control on-the-fly:

Step 1. Choose Tools > Capture to open the Capture Tool.

Step 2. The Capture/Log Mode button should show the CAP icon. If this button displays a LOG icon, click 
the button to switch to capture mode and the CAP icon should appear.

Step 3. The Toggle Source button should show the icon of a deck. If a red circle-slash symbol is present, 
click the button to enable deck control and make the red symbol disappear.

Step 4. Configure video and audio input, video and audio source tracks, target bin, res, target drive and 
tape name the same way as in "Capture from non-controllable devices".

Step 5. Use the Deck Controller Window in the Capture Tool to cue the tape and start playing.

Step 6. Click the Capture button or press the F4 key. The Capture button will flash red while recording. 
Click the Capture button again or press the Escape button on your keyboard to end the capture.

Step 6. In the Deck Preferences, enable the option to "Relax 
coincidence point detection".

Set the CAP and Toggle Source buttons to use deck control. Use 
the Deck Controller Window to cue the tape and start playing.
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Batch Capture with UltraStudio and DeckLink
To log clips for batch capture:

Step 1. Choose Tools > Capture to open the Capture Tool.

Step 2. Click on the Capture/Log Mode button so it displays the LOG icon.

Step 3. Configure video and audio input, video and audio source tracks, target bin, res, target drive and 
tape name the same way as in "Capture from non-controllable devices".

Step 4. Use the Deck Controller Window, or use the standard j, k, l shortcut keys, to shuttle backwards, 
pause and shuttle forwards on the deck and locate the video you want to capture.

Step 5. Click the Mark IN/OUT button, to the left of the LOG button. The icon will alternate between IN 
and OUT so you only have to click the one button to mark all your in and out points.  This can be 
more convenient that using the separate Mark IN and Mark OUT buttons in the Deck Controller 
Window. Alternatively use the "i" and "o" keys on the keyboard to mark in and out points.

Step 6. When you have finished logging in and out points, open the logging bin, select the clips you want 
to capture.

Step 7. Choose Clip > Batch Capture, select the desired options in the resulting dialog box and click OK.

Recording to Tape with UltraStudio and DeckLink
Once you have captured your clips, dragged them in to the timeline, edited them and applied and rendered 
any effects, you will want to record the completed project to tape.

Step 1. Double-click on a sequence, in your project bin, to open it into the Timeline window.

Step 2. Choose Output > Digital Cut to open the Digital Cut Tool.

Step 3. Set Output Mode to Real-Time, Bit Depth to 10-bit, and Deck Control to Remote.

Step 4. From the Edit Menu, choose to Insert Edit or Assemble Edit for precise edits onto a timecode 
striped tape. Alternatively choose Crash Record for an easy way to record. If Insert Edit is the 
only option, go to the Settings tab in your project, double-click on Deck Preferences and enable 
"Allow assemble edit & crash record for digital cut".

Step 5. If a deck name appears in italics in the Deck Selection menu, or "NO DECK" is displayed,  
click the menu and select Check Decks one or more times, until the deck is listed without italics, 
to reestablish deck control.

Step 6. Press the Play Digital Cut button (red triangle icon) to record your sequence to tape.

Step 5. Click on the Mark IN/OUT button or use the "i" and "o" 
keys on the keyboard to mark in and out points.

The Digital Cut Tool is used for recording to tape.
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Autodesk Smoke

Autodesk Smoke
Autodesk Smoke is a powerful all in one software solution that brings together editing, compositing 
and 3D effects into one workspace. Autodesk Smoke captures and plays back standard definition and 
high definition video and audio with Blackmagic video hardware, and also supports RS-422 deck control. 
Before installing Autodesk Smoke, make sure that both the Blackmagic Design drivers and your video 
device are properly installed. You will need either a standalone or a network licence to be able to install  
Smoke on your system.

If you want to use Smoke to play back video on an external video monitor or TV, you can use the broadcast 
monitoring feature to output your video through Blackmagic video hardware.

Installation
Step 1. Launch Smoke and the Project and User Settings window will appear. Choose your Project and 

User if you have previously created them. Otherwise, create a new project and/or user.

Step 2. Now set the project settings to match your delivery settings, i.e., 1080HD. Most of these settings, 
such as the frame rate and resolution, can be changed later during your session.

Step 3. Choose your intermediate format, such as ProRes 422 or even Uncompressed for your project 
generated media. Remember to choose a format that your storage can candle.

Step 4. Click on the Proxy Settings tab and choose whether you want to create proxies of all your media, 
which creates a low resolution version of each clip, allowing you to work quickly. This setting is off 
by default as it will eat up a lot of disk space.

Step 5. Click the Create button.

Setting Up Your Hardware
It’s a good idea to check the following when you are preparing for a VTR session:

Step 1. Connect the outputs of your VTR to the inputs of your Blackmagic Design capture and playback 
device. Connect the outputs of your Blackmagic Design capture and playback device to the 
inputs of your VTR.

Step 2. Connect an RS-422 deck control cable from the serial port on your VTR to the remote control port 
of your Blackmagic Design capture and playback device. 

Step 3. Set your VTR to remote. 

Step 4. Connect a sync generator to the sync input of the VTR to ensure frame-accurate capture. If you 
have a separate audio device, an audio sync signal must be connected to it as well.

Type a project name and set the project options.
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Setting up Autodesk Smoke to recognize your VTR
Before starting Autodesk Smoke, you must use a utility called Smoke Setup to select the model of the VTR(s) 
in your facility and its appropriate timing settings.

Step 1. Go to Applications>Autodesk>Smoke>Utilities and open Smoke Setup.

Step 2. In the General tab, make sure that Video Device and Audio Device are set to your VTR model.

Step 3. In the VTR tab, enable the VTR model and the timings you want to use with Autodesk Smoke. 
Enable the rows with live NTSC or live PAL to enable crash-record or live output.

Step 4. Click Apply and close Smoke Setup.

Capture from Controllable devices with UltraStudio and DeckLink
Autodesk Smoke can be configured to capture from controllable VTRs with RS-422 deck control.

Step 1. Select a folder in the Media Library where you want the captured clip to be created.

Step 2. Select File>Capture from VTR. The VTR Capture module appears.

Step 3. Cue the tape to the start frame of the clip you want to capture.

Step 4. Select the video and audio channels you wish to record. The buttons will turn red to let you know 
which tracks are enabled.

Step 5. Enter In and Out points in the In and Out fields. 

Step 6. Click Capture to start the capture. The timecode field will turn green to indicate that capture is in 
progress.

Step 7. End the capture at any time by clicking anywhere over the Preview window. The clip will 
automatically be saved to the location that you selected before entering the VTR Input module.

Select the Blackmagic Design capture and playback device in the 
Smoke Setup utility

Select timing settings for your VTR using the VTR tab in the 
Smoke Setup utility

Video and audio tracks turn red when enabled for capture from 
your VTR.
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Recording to Tape with UltraStudio and DeckLink
Load a clip into the VTR Output module and set the In and Out points for the output clip. If needed, you can 
also enable the options to offset the start frame for output and to apply a letterbox overlay.

Step 1. Select File>Output to VTR.

Step 2. Choose the clip(s) to output from the Media Library. You can also select a folder if you wish to 
output its contents in one session. The VTR Output module appears.

Step 3. Select the VTR in the Device Name box. The preview window displays the video from the tape in 
the selected VTR.

Step 4. Make sure that the correct video track and audio channel buttons are enabled so that the 
corresponding video track and audio channels are output to tape.

Step 5. Enable or disable All Audio in the Clip Output menu. When All Audio is enabled, every audio 
channel will be converted to the format on your tape, not just the ones you enabled.

Step 6. Click preview to watch the clip before outputting.

Step 7. To output the selected clip starting at any frame other than the first one, enter the start timecode 
in the Start Offset field.

Step 8. Set the In and Out points for clip output.

Step 9. To output the clip to the VTR, select Insert from the Output box. The clips with Status selected 
will be output to tape. During output, the status of each clip will be updated to Pending, Output,  
and then Done.

Step 10. Cue to the In timecode and then select Play to check that the transfer was successful.

Step 11. When you are finished, click EXIT Output Clip to close the module.

Step 3. Your VTR should be selectable in the drop down list.

Clips you have selected to output appear in a list with their 
current status. 

Set your In and Out points, then select Insert from the Output 
dropdown menu. 
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Crash-Record and Live Output
Autodesk Smoke allows you to capture a live video signal or crash-record a clip by using a tablet pen or a 
mouse to start and stop the clip input or output process. When you choose this form of capture, Autodesk 
Smoke checks the available space on your Autodesk Media Storage device to determine the available 
space, which varies depending on your preferred intermediate format.

Also, if you are using a device that does not support remote control via RS-422, such as a camera, VCR, or 
any other device, use the Live NTSC or PAL option to capture, and the Live Video option to output clips.

To crash-record a live video signal:
Step 1. Choose a folder from the Media Library where you would like the captured clip to be created.

Step 2. Select File>Capture from VTR. The VTR Capture module appears.

Step 3. From the VTR Device box, select Live NTSC or Live PAL. The incoming live video signal appears 
in the preview window.

Step 4. Select the Start On Pen mode. End the capture by using Stop On Pen or Stop On Frames. 
Traditionally, Autodesk Smoke was operated with a tablet and pen, hence the Start On Pen 
terminology.

When Stop On Pen is selected for capture stop mode, the out point and the duration timecode fields will be 
updated to show the longest possible clip that can be recorded on your Autodesk Media Storage device. 
The capture will either end when you click anywhere on the screen or when your storage fills up.

Step 5. Enter the clip name and enable the video tracks and audio channels that you want to capture.

Step 6. Make sure you are receiving the live video signal.

Step 7. Press Play on the video device.

Step 8. Select Process to begin capturing.

Step 9. Click anywhere on the screen to end capturing in Stop On Pen mode. 

Enable the rows with live NTSC or live PAL to enable crash-record 
or live output.
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To output a live video signal:
Step 1. Select File>Output to VTR.

Step 2. Select the clip(s) to output from the Media Library. You can also select a folder to output its 
contents. The VTR Output module appears.

Step 3. From the VTR Device box, select Live NTSC or Live PAL.

The Start Mode box is unavailable. With Live Video output, you must use Start On Pen mode. You can use 
Stop On Pen or Stop On Frames to end the output.

Step 4. Set output options. For example, enter the clip name and enable the video tracks and audio 
channels that you want to capture. 

Step 5. On the device receiving the signal, start the recording, or take any action required to enable the 
reception of the signal from Autodesk Smoke.

Step 6. Select Process to begin the output on Autodesk Smoke.

Step 7. Click anywhere on the screen to end the output in Stop On Pen mode.

Use Start On Pen mode when outputting live video.

Select Live PAL or Live NTSC when outputting a live video signal.
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What is Media Express?
Blackmagic Media Express software is included with every UltraStudio, DeckLink and Intensity as well as 
every ATEM Switcher, Blackmagic Camera, H.264 Pro Recorder, Teranex Processor and Universal Videohub.  
Depending on your hardware model and platform, Media Express 3 lets you batch capture and play back 2D 
and dual stream stereoscopic 3D in DPX, ProRes, uncompressed YUV and RGB, DVCPRO 50, DVCPRO HD and 
MJPEG files.

Media Express 3 also supports CMX EDL import, frame accurate deck control via RS-422, and will even insert and 
assemble to tape! Media Express is fast, accurate, easy to use and works on Mac OS X, Windows and Linux. You 
can even grab still frames directly from your deck and save them as perfect digital quality still images.

Media Express 3 is a great tool when you don’t need the complexity of NLE software but simply want to capture, 
play back and output clips to tape, especially when working with video compositing software.

The User Interface
Media Express can easily be scaled for different sizes of monitors or even small notebook screens.  
When you open Media Express, you'll notice the log and capture, playback and edit to tape views are color-
coded so you will know at a glance which mode is being used.

Media List
The left "media list" always displays the scratch, any bins you have created and also any media you have 
imported, captured or logged for capture. Media can be displayed in Timecode List view or Thumbnail 
view and you can even filter media by favorites. The Search field makes it easy to find media by name or 
by attributes captured in the media metadata. The project name and format are shown in the bottom-left 
corner of the Media Express window.

The top-right pane always displays the video preview. Timecode is displayed at the top of the video preview 
pane and NO REMOTE will be indicated if no RS-422 device control is connected.
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Log and Capture
Click on the red Log and Capture tab. The video preview pane shows the source video from your camera 
or deck. Here you can enter metadata for the clips you will capture including name, description, reel 
number, favorite and more. You can capture with or without device control, log clips with in and out points,  
and batch capture. Double-clicking a captured clip in the media list will automatically switch Media Express 
to Playback view.

Playback
In the green Playback view, the video preview pane shows the video of the clip being played. Click the 
favorites button to add to your favorites in the media list.

Edit to Tape
After clicking the blue Edit to Tape tab, select clips from the media list to be mastered to tape using RS-422 
device control. Set the In/Out points for your edit and choose between Assemble or Insert edit. You can 
even preview before mastering to tape. The video preview pane shows the clips being sent to tape.
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Capturing Video and Audio files

Setting Up a Project
Before capturing any clips in Media Express, you will need to select the settings for your project. 

Step 1. Go to Media Express>Preferences or Edit>Preferences on Windows or Linux. The project formats 
listed will vary depending upon whether your Blackmagic video hardware supports features such 
as Ultra HD 4K video or stereoscopic 3D video.

Step 2. Select from a range of professional compressed and uncompressed capture file formats or even a 
DPX image sequence in the Capture File Format drop down menu. Video will be captured in the 
chosen format and saved to a QuickTime movie.

Step 3. Set the storage location for your captured video and audio. 

Step 4. Choose whether to stop capture or playback if dropped frames are detected.

Standard definition projects are set to the 4:3 aspect ratio unless you enable the Anamorphic SD 16:9 
checkbox. 

Usually video applications stop playing video if you send them to the background. If you want Media Express 
to keep playing video, even if you open another application in the foreground, enable the checkbox to 
"Continue playback when in the background".

The final options relate to tape decks with RS-422 deck control.

Your tape deck requires a pre-roll of a few seconds before performing an edit so the tape speed is stable by 
the time it is used for an edit.

Timecode offsets can also be set to calibrate the timecode to the video.
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Capture
Capturing video is easy and all you need to do is connect a video source, set the Media Express preferences 
and press the Capture button.

Step 1. Start by connecting your video source to an input of your Blackmagic video hardware and check 
that the Blackmagic system preferences are set to the same video input, e.g. SDI, HDMI or analog.

Step 2. Open Media Express and set its preferences to the project video format and capture file format. 
The project video format must be set correctly otherwise you will not see your video in the preview 
pane.

Step 3. Click the red Log and Capture tab and enter a description for your video into the Description field 
of the logging information area.

Step 4. Click the "+" button next to the Description to add it to the automatic Name field. Click the "+" 
button next to any of the other fields that you wish to add to the Name field.

 � You can increment the value in each of these fields by clicking on the corresponding clapper  
 board icon. Alternatively you can type directly into any field to customize its name and number.

 � The text in the automatic Name field will be applied to the clip(s) which are about to   
 be captured.

 � Click the "star" icon next to the Name field if you want to log the clip as a favorite.
 � Click the "!" icon next to the Name field if you wish a clip name confirmation prompt to   

 appear before every capture. This will provide you with the chance to change the clip name.

Step 5. Set the desired number of audio channels to be captured.

Step 6. Click the “Capture” button to start recording. To end capture, click the “Capture” button again to 
automatically keep the clip. Alternatively, press esc if you want to be prompted to delete or save 
the clip. The captured clips will be added to the Media List.

Logging clips
Ensure an RS-422 serial cable is connected between your Blackmagic video hardware and the deck.  
The Remote/Local switch must be set to Remote on the deck so you can use the transport controls in Media 
Express. Use the standard j, k, l shortcut keys to shuttle backwards, pause and shuttle forwards on the deck.

Click the Mark In button to mark the In point, or use the shortcut key i.

Click the Mark Out button to mark the Out point, or use the shortcut key o.

Click the Log Clip button to log the clip, or use the shortcut key p. The entry should now appear in the 
Media List with a red X in its icon to indicate the media is offline.

Set the desired number of audio channels to be captured

Enter a description for your video

Click the "Capture" button to commence recording
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Batch Capture
After logging a clip, you can click the Clip button if you just want to capture a single clip.

If you want to capture multiple clips, continue logging all the clips that you wish to batch capture.

When logging is completed, select the logged clips in the Media List and:

 � click the Batch button, or
 � right-click on the selection and select ‘Batch Capture’, or
 � go to the File menu and choose Batch Capture.

Media Express will cue the tape and precisely capture the clip from the In to the Out timecode points, 
including any handles specified in the Media Express preferences.

DPX Capture
If you want to capture a DPX image sequence rather than a movie file, open the Media Express preferences 
and set the Capture File Format to DPX 10-Bit RGB. You will need a fast disk array to cope with the 
uncompressed, 10-bit RGB format.

 � Create a DPX project by setting the capture file format to DPX.
 � Capture.

When the capture has been completed, a single thumbnail will appear in the Media List representing the 
entire frame sequence. The sequence of DPX frames will be stored in its own folder in your disk storage. 
Audio will be stored in a .wav file in the same folder.

By default, DPX captures are assumed to be from YUV sources. If you need to capture from an RGB source, 
disable the "Capture to DPX from a YUV source" option otherwise your DPX files will show weird pink and 
green colors.

If you want the DPX frame numbers to be based on the timecode of the captured video, rather than just 
starting from zero, enable the option to "Use absolute frame numbering when capturing DPX".

If you aren't performing long DPX captures, you may wish to reduce the number of zeroes in the frame 
numbers by changing the option, "When capturing DPX files, use (2-8) digit numbers in the frame count.

DPX capture preferences
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3D Capture
When Media Express is used with a Blackmagic video hardware model that supports dual-stream 3D,  
you can create left and right eye 3D video clips by capturing 2 streams of HD-SDI video simultaneously.

 � Create a 3D project which matches the frame rate of your dual stream 3D video source.
 � Ensure you have 2 discrete HD-SDI video inputs to the Blackmagic video hardware.
 � Capture.

When capturing and logging dual stream 3D in Media Express, the clip name will be applied to the left 
eye video. The right eye video will be appended with ‘_right’ text. For example, if you name the stereo clip 
“Clip 1”, the left eye clip will be called “Clip 1.mov” and the right eye clip will be called “Clip 1_right.mov”.

The Media List presents an eye-catching indication that the captured clip is a 3D clip:

 � In Thumbnail view, the left and right eye clips are connected by a 3D indicator and presented as 
a single, large icon.

 � In Timecode List view, the left and right eye clips are listed on two lines and linked together by a 
3D indicator.

Select a project video format with "3D" in its name to capture 
dual-stream stereoscopic 3D video clips

In Thumbnail view, the left and right eye clips are connected by a 
3D indicator and presented as a single, large icon.

In Timecode List view, the left and right eye clips are listed on two 
lines and linked together by a 3D indicator.
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Playing back Video and Audio Files

Importing clips
You can play back your video and audio files after importing media into Media Express in any of  
the following ways:

 � Double-click an empty area of the Media List.
 � Right-click an empty area of the Media List and select Import Clip from the contextual menu.
 � Go to the File menu, select Import and then Media Files.

Select the video and audio clip(s) you wish to import from the Open Video Clip dialog box. The clips will 
appear in the Scratch area of the Media List. If you have created your own bins in the Media List, you can 
drag the clips into the desired bin.

If you want to import media directly to a bin, right-click within the desired bin and select Import Clip from 
the contextual menu.

If the files being imported do not match the frame rate and size of existing clips in the Media List, you will 
be prompted to create a new project and to save the current project.

Media Express also supports the import of multichannel audio-only files recorded at 48kHz in the 
uncompressed WAVE (.wav) and AIFF (.aif) formats.

Another way to import media is to use an XML file which has been exported from Final Cut Pro. Go to the 
File menu, select Import and then Final Cut Pro XML. Open the desired XML and all the bins and media 
from the Final Cut Pro project will appear in the Media List.

Media Express also supports the import of CMX EDL files to batch capture clips using EDL files from 
other video software. Go to the File menu, select Import and then CMX EDL. Select the EDL and open it.  
The logging information will appear in the Media List. Select the logged clips and perform a batch capture 
to import the clips from your deck.

Playing back single and multiple clips
To play back a single clip, double-click the clip in the Media List. Alternatively select the clip in the Media List 
and press the space bar on your keyboard or the play button in the transport controls.

To play back multiple clips, select the clips in the Media List and then press the space bar on your keyboard 
or the play button in the transport controls.

Your video will play back in the video preview pane of Media Express and on all the video outputs of your 
Blackmagic video hardware. During playback, the audio channels being monitored can be switched on or 
off via the track enable/disable buttons.

There are three ways to import clips in to Media Express

You can use the transport controls to play, stop, jump to the next 
or previous clip and loop playback of your clips.
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Browsing Media
In the Media List, you can view your clips in Thumbnail view or Timecode List view by clicking on the desired 
view button at the top-right of the Media List.

Thumbnail view
Thumbnails are the most intuitive way to display your clips. To get information for a clip, hover your mouse 
over the clip's thumbnail and then click on the popup info icon which will appear at the bottom-right of the 
thumbnail. Click the info bubble to hide it.

List view
You can view your clips in Timecode List view by clicking on the Timecode List button at the top-right 
of the Media List. Use the horizontal scroll bar at the bottom of the Media List to view all the columns of 
information for your clips including: in and out points, video format, audio channels, field dominance and 
logging information.

Creating and using bins
To create a bin for your clips, right click an empty spot in the Media List and select "Create Bin". Type in a 
name for the new bin.

You can move clips from the Scratch, or from one bin to another, by dragging the clip icons to the desired 
bin.  If you want a clip to appear in more than one bin, import the same clip again by right-clicking on the 
bin and choosing "Import Clip".

By default, logged clips appear in the Scratch. If you want to log clips and have them appear in a new bin, 
right-click the new bin and choose "Select As Log Bin".

In the Media List, choose to view your clips in Timecode List view 
or Thumbnail view. Click the Favorites button to only show your 
favorite clips. Type in the Search field to find your favorite clips.

Click the popup info icon on a thumbnail to view its info bubble.
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Creating and using favorites
In the Log and Capture tab, click the "star" icon next to the Name field if you want to log a clip as a favorite.

In the Playback tab, clicking the "star" icon will make the clip a favorite if it is selected in the Media List. Click 
the "star" icon again to deselect it as a favorite.

Clips marked as favorites will show a yellow star in their icon in Timecode List view and Thumbnail view.

Once you have marked clips as favorites, click on the gray, Favorites, star button at the top of the Media 
list and it will turn yellow. All clips in your Media List will be hidden except for those marked as favorites.  
This is similar to creating a playlist and makes it easy to only play back your favorite clips and even master 
them to tape.

Linking an audio clip to a video clip
To link an audio clip to a video clip which appears in the Media List:

 � select a video clip which contains no audio channels.
 � right-click on the video clip and select ‘Link Audio File’ from the contextual menu.

The Media List presents a highly visible indication that the video and audio clips are linked. You can now play 
back the combined clip or master it to tape.

Deleting clips and bins
To delete clips, select the unwanted clips and press the forward delete button on your keyboard. This will 
only delete the clips from the Media List and they will safely remain on your disk storage.

To delete bins, right-click within a bin and choose "Delete Bin". This action will delete the bin and any clips it 
contained. This will only delete the clips from the Media List and they will safely remain on your disk storage.

In the Log and Capture tab, click the "star" icon next to the 
Name field if you want to log the clip as a favorite.

Click the Favorites button at the top of the Media List to only 
show your favorite clips. Type in the Search field to find clips.

Clips marked as favorites are easily identified by the yellow star in 
their icon.
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Creating a 3D clip
To add a stereoscopic 3D clip to the Media List:

 � select a 3D project video format that is the same frame rate as your 3D media
 � import the ‘left eye’ file into the Media List
 � right-click on the ‘left eye’ file and select ‘Set Right Eye Clip’ from the contextual menu. If the right eye 

clip was previously captured by Media Express, the right eye video will be appended with ‘_right’ text.  
For example, if the left eye clip is named “Clip 1.mov”, the right eye clip will be called  
“Clip 1_right.mov”.

The Media List presents a highly visible indication that the imported clip is a 3D clip. The left and right 
eye clips will be displayed side by side in the Video Preview window to indicate you are working with a 3D  
video project.

If you find the left and right eyes of a 3D stereo clip have been loaded the wrong way around:

 � right-click the 3D clip in the Media List
 � select ‘Swap Eyes’ from the contextual menu

Searching the Media List
Clips can easily be found in a project by typing the name of your clips in the Search field at the top of the 
Media List. When used in conjunction with the favorites feature, the search will be confined to your favorite 
clips so you will see a shorter list of found clips.

Select a 3D project video format

The Media List presents a highly visible indication that the 
imported clip is a 3D clip.

Type in the Search field to find clips.

The Media List presents a highly visible indication that the  
video and audio clips are linked.
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Editing Video and Audio Files to Tape
Mastering your clips to a deck is easy. While we usually talk about mastering or editing to "tape", it doesn't 
matter if your deck uses tapes or disks. To master your clips:

 � Select the clips you want to send to tape.
 � Click the blue Edit to Tape tab.
 � Set the In point and type of edit.
 � Master to tape.

Selecting clips to master
From the Media List, select the clips you wish to master to tape. You can even insert multichannel audio-only 
clips to replace the master audio track on a master tape. If you only want to send your favorite clips to tape, 
click the favorite (star) icon at the top of the Media List to show your favorites and hide all other clips. Then 
select the favorite clips you wish to send to tape.

Insert and Assemble to tape
Click the blue Edit to Tape tab. If "No Remote" appears in the video preview pane, check that an RS-422 
serial cable is connected between your Blackmagic video hardware and the deck. The Remote/Local switch 
needs to be set to Remote on the deck so you can use the transport controls in Media Express.

Enter the In point of the tape by entering timecode into the In point field, or by cueing the tape to the 
desired point via the transport control and then clicking the Mark In button, or use the shortcut key i.

If no Out point is entered, Media Express will set the duration of the edit to the total length of the clips in 
the Media List. If an out point is defined, Media Express will stop recording once the Out point timecode is 
reached, even if some clips have not been output.

The Assemble and Insert buttons are mutually exclusive and only one mode can be selected at a time.  
Choose to master to tape using Assemble or Insert edit. Then press the Master button.

The Preview and Master buttons are also mutually exclusive. Preview mode mimics the edit process but 
does not record to tape. This mode lets you check the edit point is correct. Preview edit operations should 
always be checked on monitors connected directly to the output of the deck. This lets you view the video 
already on tape and the new video. 

If Record Inhibit is enabled either on the deck or on the tape, Media Express will display a dialog box,  
that Record Inhibit is enabled when you click the Master button. Check the deck and tape. Disable Record 
Inhibit before trying again.

Before mastering, the video and audio channels to be put to tape can be selected on or off via the track 
enable/disable buttons. Deselect the video channel if you only want to output audio to tape.

Click the favorite (star) icon at the top of the Media List to only 
show your favorites

This picture shows that 2 clips have been selected to be sent  
to tape

Set the desired number of audio channels to be mastered
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What is Blackmagic Design Disk Speed Test?
Blackmagic Disk Speed Test is a beautiful and fun to use application that measures the read and write 
performance of storage media in video frame sizes. The use of video frame sizes provides accurate 
measurement of how the disk storage will perform with video related applications. 

If you have ever wondered whether your hard drive is suitable for playback (“read”) of a particular video 
format, you can use Disk Speed Test to find out. With its easy to understand layout, it is now simple to 
understand what performance you can get out of your media drives with a single click of the Start button! 
Disk Speed Test will even show you how many streams of video your storage is capable of handling!

Disk Speed Test is included free with any Blackmagic Design product installation on Mac OS X and Windows 
and can also be downloaded from our website free of charge.

Disk Speed Test takes the guess work out of configuring your storage system for optimal performance for 
any job you will be doing.

Disk Speed Test settings are accessed by clicking on the Settings button, just above the Start button.  
On Mac OS X, the same settings are also available from the Menu Bar at the top of your computer display.

Select Target Drive
Click Select Target Drive to choose the storage volume you wish to test. Ensure you have Read and Write 
permissions for the selected volume as Disk Speed Test will write a temporary file to it. This file will be 
automatically deleted when you quit Disk Speed Test.

Save Screenshot
After testing your disk storage, click Save Screenshot to save a screenshot of the results to a chosen location. 

Stress
Lower stress settings may be chosen if you want to demonstrate the speed of disk storage quickly. The  
1 GB option would be a good choice on a trade show booth to rapidly show the read and write performance 
of a disk array even though the results might not be quite as accurate as when the 5 GB option is selected.

Disk Speed Test limits each write operation to a maximum of 8 seconds and each read operation to a 
maximum of 8 seconds so you do not have to wait long to obtain results.

Disk Speed Test Help
Click Disk Speed Test Help to launch the PDF manual for Disk Speed Test. 

About Disk Speed Test
About Disk Speed Test displays which version of the Disk Speed Test you are running.

Settings menu



Blackmagic Disk Speed Test51

How Fast? 

This panel shows results 
in frames per second (fps)

Settings 

Click this button to 
access the settings before 
running a disk speed test

Will it Work? 

This panel shows which 
video formats can be 
supported by your disk 
storage

START

Click this button once to 
start the disk speed test. 
Click again to stop the test
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Start
Once you have chosen the desired settings, click the Start button to commence the disk speed test.  
Disk Speed Test will write a temporary file to the selected target drive. When the file has finished writing, 
or when 8 seconds has elapsed, Disk Speed Test will stop writing and start reading back the temporary file 
from the drive.

Disk Speed Test will continue writing and reading the nominated size of stress file until you stop the test by 
clicking the Start button again.

Will it Work?
The “Will it Work?” panel can help to identify video formats where the Read performance might be 
significantly different to the Write performance. These differences might mean that you can capture a video 
format but not play it back in real time or else you can play back a video format but not capture it in real time.

The “Will it Work?” panel shows common video formats and instantly displays a check mark or cross to show 
if the disk performance will be adequate for the desired video format. We suggest you allow Disk Speed 
Test to perform several test cycles to help reveal any video formats for which the disk storage performance 
might be marginal. If you observe a check mark and a cross switching between each other for a video 
format, this would indicate that the disk storage cannot reliably support the video format.

The “How Fast?” results panel shows the frame rates your drive can achieve in frames per second and 
should be read in conjunction with the “Will it Work?” panel. If the “Will it Work?” panel shows a green 
check mark for 2K 1556@25fps in 10 Bit YUV 4:2:2, but the “How Fast?” panel shows that a maximum of 
25fps will be supported, the disk storage performance is too marginal to be reliable.

How Fast?
After each Read or Write test, the results will be displayed in the “How Fast?” panel. The “How Fast?” 
results panel also enables you to see how many streams of video can be supported by your disk storage. If 
the result for “HD 1080” is 70, you can run up to 70 frames of HD 1080 video per second. 

This storage speed is capable of supporting the following video formats:

 � 2 simultaneous streams of 1080i50 video at 25 fps per stream
 � 1 stream of 1080p50 video at 50 fps per stream
 � 1 stream of 1080p59.94 video at 59.94 fps per stream

Disk Speed Test interface during a test
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Getting Help
The fastest way to obtain help is to go to the Blackmagic Design online support pages and check the latest 
support material available for your Blackmagic Design video hardware.

Blackmagic Design online support pages
The latest manual, software and support notes can be found at the Blackmagic Support Center at  
www.blackmagicdesign.com/support.

Contacting Blackmagic Design support
If you can't find the help you need in our support material, please use the "Send request" button, on 
the support page for your hardware model, to email a support request. Alternatively call your nearest 
Blackmagic Design support office at www.blackmagicdesign.com/company.

Checking the version currently installed
To check which version of Desktop Video software is installed on your computer, open the Blackmagic 
Design Desktop Video system preferences. The version number appears prominently in the title bar.

 � On Mac OS X, open the System Preferences and look in the “Other” category to locate the 
Blackmagic Design icon. Click the Blackmagic Design icon to reveal the version number.

 � On Windows 7 and Windows 8, open the Control Panel and click on the “Hardware and Sound” 
category to reveal the Blackmagic Design Control Panel. Click the Blackmagic Design Control 
Panel to reveal the version number.

 � On Linux, go to "Applications" and then "Sound and Video" to locate the Blackmagic Control 
Panel. Open the control panel to reveal the version number.

How to get the latest updates
After checking the version of Desktop Video installed on your computer, please visit the Blackmagic Support 
Center at www.blackmagicdesign.com/support to check for the latest updates. While it is usually a good 
idea to run the latest updates, it is a wise practice to avoid updating any software if you are in the middle of 
an important project.

http://www.blackmagicdesign.com/support
http://www.blackmagicdesign.com/company
http://www.blackmagicdesign.com/support
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Developing custom software using Blackmagic Design hardware
The DeckLink SDK is available to developers who wish to programmatically control Blackmagic video 
hardware with their own custom software. The DeckLink SDK supports the UltraStudio, DeckLink, Multibridge 
and Intensity families of products.

The DeckLink SDK provides both low-level control of hardware and high-level interfaces to allow developers 
to easily perform common tasks. The DeckLink SDK supports technologies including:

 � Apple QuickTime
 � Microsoft DirectShow
 � Apple Core Media
 � DeckLink API

Downloading the free Blackmagic Design SDK
The DeckLink SDK is free and can be downloaded from

http://www.blackmagicdesign.com/support/sdks/

Joining the Blackmagic Design developer list
The Blackmagic Developer mailing list is designed for technical questions regarding technologies used by 
Blackmagic Design, eg QuickTime, Core Media, DirectShow, codecs, APIs, SDKs, etc. The free mailing list 
is a forum where developers can discuss ideas and problems with other developers. Any subscriber may 
reply and the Blackmagic Design engineers may also respond when appropriate. You can subscribe to the 
mailing list at: http://lists.blackmagicdesign.com/mailman/listinfo/bmd-developer

In some cases, we might request a brief outline of the software you are developing if it is not immediately 
obvious from your domain name that your organization develops video software. Please don't take offence 
as we're simply trying to keep the list free of spam and viruses as well as end-user customers asking  
non-development questions, employment agents or sales people trying to promote products on the list. 
The list is just for developers.

Contacting Blackmagic Design developer assistance
You can also contact us via developer@blackmagicdesign.com if you have any developer related questions 
or wish to ask questions off the list.

http://www.blackmagicdesign.com/support/sdks/
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Frame Structure
 � Transmitted at 23.98, 24 or 25 frames per second as a Progressive Segmented Frame. 
 � Active video is 2048 pixels wide by 1556 lines deep. 
 � Total lines per frame : 1650
 � Active words per line are 1535. One word consists of a 10-bit sample for each of the four data 

streams, i.e. a total of 40 bits. See the diagram named Blackmagic 2K Format - Data Stream Format.
 � Total active lines : 1556
 � Total words per line : 1875 for 23.98/24Hz and 1800 for 25Hz.
 � Fields per frame : 2, 825 lines each
 � Active lines located on lines 16-793 (field 1) and 841-1618 (field 2).

Transport Structure
 � Based on SMPTE 372M Dual Link mapping and SMPTE 425M-B support for mapping SMPTE 

372M into a single 3 Gb/s link.
 � Timing reference signals, line number and line CRC insertion is the same as above.
 � Optional ancillary data is inserted into both virtual interfaces.
 � At present, only audio data is included: as per standard HD audio insertion (SMPTE S299M) the 

audio data packets are carried on data stream two and audio control packets are carried on data 
stream one.

 � During active video, 10-bit Red, Green and Blue data is sent in the following sequence:
 Data stream 1: Green_1, Green_2, Green_3, Green_5...Green_2047

 Data stream 2: Blue_1, Blue_2, Green_4, Blue_5...Green_2048.

 Data stream 3: Red_1, Blue_3, Blue_4, Red_5...Blue_2048.

 Data stream 4: Red_2, Red_3, Red_4, Red_6...Red_2048.

The diagram, Vertical Timing Reference, shows the vertical timing details with line numbers and Field, 
Vertical and Horizontal bits for the Timing Reference Signal codes. 

The diagram, Data Stream Format, shows the data stream formats around the optional ancillary data section 
of the horizontal line. Note that each active pixel takes up three samples.

Blackmagic 2K Format – Overview
The latest Blackmagic Design products use the new 
3G-SDI video, which allows twice the data rate of 
traditional HD-SDI video. We thought it would be 
a really nice idea to add 2K film support, via this new  
3G-SDI technology, so we could simplify feature film 
workflows. With the popularity of Blackmagic Design 
editing systems worldwide, now thousands of people 
can benefit from a feature film workflow revolution.

This information includes everything product developers 
need to know for building native 2K SDI equipment. Of 
course, all Blackmagic products can be updated, so if 
the television industry adopts an alternative SDI-based 
film standard, we can add support for that too!
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FIELD 1 ACTIVE

F 1 0 0 0 0 0 0 0 0 0 0 0

V 1 1 1 1 1 1 0 0 0 0 1 1

LINE # 1650 1 2 … 14 15 16 … 792 793 … 825

Blackmagic 2K Format – Vertical Timing Reference 

FIELD 2 ACTIVE

F 0 1 1 1 1 1 1 1 1 1 1 1

V 1 1 1 1 1 1 0 0 0 0 1 1

LINE # 825 826 827 … 839 840 841 … 1617 1618 … 1650
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DeckLink 4K Extreme  
Breakout Cable

2
3

4
5

6
7

8
9

10
11

12
13

14
15

2

3

4

5

6

7

8

9

10

11

12

13

14

15

2. Deck Control

3. R-Y In

SD/HD/3G-SDI Out Ch B 
Downconverted HD, external key out

SD/HD/3G/6G-SDI Out Ch A

SD/HD/3G/6G-SDI In Ch A

4. Y In

5. B-Y In

6. Ref In

7. R-Y Out

8. Y Out

9. B-Y Out

10. AES/EBU Out

11. AES/EBU In

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

HD/3G-SDI In Ch B

HDMI Output

HDMI Input

DeckLink 4K Extreme
SDI inputs and outputs support 3G-SDI and 6G-SDI.
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HD/SD-SDI Output

HD/SD-SDI Input

Reference In

HD/SD-SDI Output
DeckLink SDI 2

DeckLink SDI 1

HD/SD-SDI Input

DeckLink Duo
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DeckLink HD Extreme 3D+
All SDI inputs and outputs support 3G-SDI and 2K.

DeckLink HD Extreme 3  
Breakout Cable

2
3

4
5

6
7

8
9

10
11

12
13

14
15

2

3

4

5

6

7

8

9

10

11

12

13

14

15

2. Deck Control

3. R-Y In

SD/HD-SDI Out Ch B 
Downconverted HD, external key out

SD/HD-SDI Out Ch A

SD/HD-SDI In Ch A

4. Y In

5. B-Y In

6. Ref In

7. R-Y Out

8. Y Out

9. B-Y Out

10. AES/EBU Out

11. AES/EBU In

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

HD-SDI In Ch B

HDMI Output

HDMI Input
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DeckLink HD Extreme 3D+. Connecting to S-Video
This example shows the DeckLink HD Extreme 3 Breakout Cable connecting to S-video adapter 
cables.

DeckLink HD Extreme 3  
Breakout Cable

2

3

4

5

6

7

8

9

10

11

12

13

14

15
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DeckLink Mini Monitor

HDMI Output 

SDI Output 
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HDMI Input 

SDI Input 

DeckLink Mini Recorder
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Optical Fiber 
HD/SD-SDI In & Out

Deck Control RS-422

HD/SD-SDI Output (to deck)

HD/SD-SDI Input (from deck)

Reference In

DeckLink Optical Fiber
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DeckLink Quad
DeckLink Quad uses DIN 1.0/2.3 rather than larger BNC type connectors.

HD/SD-SDI Out 

HD/SD-SDI Out 

HD/SD-SDI In 

HD/SD-SDI In 

HD/SD-SDI In 

HD/SD-SDI Out 

HD/SD-SDI Out 

HD/SD-SDI In 

Ref In 

DeckLink SDI 4

DeckLink SDI 3

DeckLink SDI 2

DeckLink SDI 1
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DeckLink SDI

Deck Control RS-422

HD/SD-SDI Output (to deck) 

HD/SD-SDI Input (from deck) 

Ref In
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DeckLink Studio 2

HDMI Output

HDMI Input

DeckLink Studio 
Breakout Cable

HD/SD-SDI Output 

HD/SD-SDI Input 

19

18

17

16

15

14

13

12

11

10

09

08

07

06

05

04

03

02

20

21

22

23

24

2. RS-422 Deck Control

3. R-Y Out

4. Y Out

5. B-Y Out

6. Ref In

7. R-Y In

8. Y In

9. B-Y In

10. AES / EBU Out CH1&2

11. AES / EBU In CH1&2

12. Analog Audio Out 1

16. Analog Audio In 3

14. Analog Audio In 1

18. Analog Audio Out 3 or AES/EBU CH3&4 Out

20. Composite In

22. S-Video In

13. Analog Audio Out 2

17. Analog Audio In 4

15. Analog Audio In 2

19. Analog Audio Out 4 or AES/EBU CH5&6 Out

21. Composite Out

23. S-Video Out

24. Standard Definition SDI Out
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Intensity Extreme

3. R-Y Out

4. Y Out

5. B-Y Out

7. R-Y In

8. Y In

9. B-Y In

10. AES/SPDIF Out

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

3

4

5

7

8

9

10

12

13

14

15

Intensity  
Breakout Cable

HDMI 4:2:2
Output

HDMI 4:2:2
Input

Analog video output

Analog video input

Analog audio output

Analog audio input

Digital audio output

Thunderbolt™
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Intensity Pro

3. R-Y Out

4. Y Out

5. B-Y Out

7. R-Y In

8. Y In

9. B-Y In

10. AES/SPDIF Out

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

3

4

5

7

8

9

10

12

13

14

15

Intensity  
Breakout Cable

HDMI 4:2:2 Output

HDMI 4:2:2 Input

Analog video output

Analog video input

Analog audio output

Analog audio input

Digital audio output
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Intensity Breakout Cable: Component Analog Video
Intensity Pro and Intensity Extreme include an Intensity Breakout Cable with many analog 
connections. The high quality component analog video RCA connectors on the Intensity 
Breakout Cable can be used for component capture and playback, in high definition or standard 
definition, as illustrated below.

3

4

5

7

8

9

10

12

13

14

15

Component Output

Component Input

Intensity  
Breakout Cable
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Intensity Breakout Cable: S-Video Analog Video
Intensity Pro and Intensity Extreme include an Intensity Breakout Cable with many analog 
connections. The high quality analog video RCA connectors on the Intensity Breakout Cable 
can be used for S-Video capture and playback using a simple S-Video to dual RCA adapter 
cable (not included), as illustrated below. S-Video supports standard definition video.

3

4

5

7

8

9

10

12

13

14

15

Intensity  
Breakout Cable

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 

S-Video Output

S-Video Input
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Intensity Breakout Cable: Composite Analog Video
Intensity Pro and Intensity Extreme include an Intensity Breakout Cable with many analog 
connections. The high quality analog video RCA connectors on the Intensity Breakout Cable 
can be used for NTSC/PAL capture and playback of composite video. Simply connect consumer 
RCA cables to the Intensity Breakout Cable as illustrated below. Composite video supports 
standard definition video.

Intensity  
Breakout Cable

3

4

5

7

8

9

10

12

13

14

15

Composite Output

Composite Input
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Component analog video

HDMI

USB 3.0 port

Composite analog video

Left & Right 
analog audio

S-Video

Intensity Shuttle for USB 3.0
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Component analog video

HDMI

Thunderbolt™ port

Composite analog video

Left & Right 
analog audio

S-Video

Intensity Shuttle for Thunderbolt™
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UltraStudio 3D

HDMI 
In

+12 volt power 
supply connection

HDMI 
Out

SD/HD-SDI  
In Ch A

SD/HD-SDI  
Out Ch A

SD/HD-SDI  
In Ch B

Thunderbolt™

SD/HD-SDI 
Out Ch B 

UltraStudio 3D Breakout Cable
2

3
4

5
6

7
8

9
10

11
12

13
14

15

2

3

4

5

6

7

8

9

10

11

12

13

14

15

2. Deck Control

3. R-Y In

4. Y In

5. B-Y In

6. Ref In

7. R-Y Out

8. Y Out

9. B-Y Out

10. AES/EBU Out

11. AES/EBU In

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

Downconverted HD,  
external key out
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UltraStudio 4K
SDI input A and SDI output A support 6G-SDI.

Remote In/Out B-Y In B-Y Out AES/EBU In

Y In Y Out

Illuminated 
Input Selection 

Buttons
LCD Preview and 

Status Screen

Thunderbolt™

AES/EBU 
Out

USB HDMI  
In/Out

Audio In

REF In R-Y In R-Y Out

REMOTE IN/OUT

PUSH

HDMI IN HDMI OUT

REF IN NTSC/PAL IN Y IN B-Y IN R-Y IN NTSC/PAL OUT Y OUT B-Y OUT R-Y OUT

OUT BOUT ALOOP BLOOP A

SD/HD/3G-SDI

IN BIN A

AES IN

AES OUT

STEREO IN TIMECODE IN TIMECODE OUT AUDIO IN 1 AUDIO IN 2 AUDIO OUT 1 AUDIO OUT 2

L

R

PUSHPUSH

SDI

VIDEO

HDMI

ANLG

AUDIO

EMBED

AES

ANLG

UltraStudio 4K

REMOTE IN/OUT

PUSH

HDMI IN HDMI OUT

REF IN NTSC/PAL IN Y IN B-Y IN R-Y IN NTSC/PAL OUT Y OUT B-Y OUT R-Y OUT

OUT BOUT ALOOP BLOOP A

SD/HD/3G-SDI

IN BIN A

AES IN

AES OUT

STEREO IN TIMECODE IN TIMECODE OUT AUDIO IN 1 AUDIO IN 2 AUDIO OUT 1 AUDIO OUT 2

L

R

PUSHPUSH

SDI

VIDEO

HDMI

ANLG

AUDIO

EMBED

AES

ANLG

UltraStudio 4K

Power 
Connection

Timecode 
In/Out

Stereo
L/R

In Loop Out

SD/HD/3G/6G-SDI In/Out

NTSC/PAL OutNTSC/PAL In

Analog
Audio In

Analog
Audio Out
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UltraStudio Express and Professional Breakout Cable
The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.

HDMI 
In

HDMI 
Out

SDI In SDI Out

Thunderbolt™

2
3

4
5

6
7

8
9

10
11

12
13

14
15

2

3

4

5

6

7

8

9

10

11

12

13

14

15

2. Deck Control

3. R-Y Out

4. Y Out

5. B-Y Out

6. Ref In

7. R-Y In

8. Y In

9. B-Y In

10. AES/EBU Out

11. AES/EBU In

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

UltraStudio Express  
Professional Breakout Cable
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UltraStudio Express and Consumer Breakout Cable
The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.

HDMI 
In

HDMI 
Out

SDI In SDI Out

Thunderbolt™

3

4

5

7

8

9

10

12

13

14

15

3. R-Y Out

4. Y Out

5. B-Y Out

7. R-Y In

8. Y In

9. B-Y In

10. AES/EBU Out

12. Audio Out Left

13. Audio Out Right

14. Audio In Left

15. Audio In Right

UltraStudio Express  
Consumer Breakout Cable



Connection Reference Guide79

UltraStudio Express - connecting to S-Video
This example shows the UltraStudio Express Consumer Breakout Cable connecting to S-video 
adapter cables. The Professional Breakout Cable can also be used with S-video adapter cables. 
The numbering on the cables is the same on both the Consumer and Professional Breakout Cables 
so it’s easy to use either cable for S-video.

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 

UltraStudio Express  
Consumer Breakout Cable

3

4

5

7

8

9

10

12

13

14

15
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UltraStudio Mini Monitor

SDI OUT

HDMI OUT

SDI Output Thunderbolt™

HDMI Output
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UltraStudio Mini Recorder

SDI IN

HDMI IN

SDI Input Thunderbolt™

HDMI Input
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3G/HD/SD-SDI Output USB 3.0

3G/HD/SD-SDI Input 

Breakout cable 
connector

Power

19

18

17

16

15

14

13

12

11

10

9

8

7

6

5

4

3

2

20

21

22

23

24

2. RS-422 Deck Control

3. R-Y Out

4. Y Out

5. B-Y Out

6. Ref In

7. R-Y In

8. Y In

9. B-Y In

10. AES / EBU Out CH1&2

11. AES / EBU In CH1&2

12. Analog Audio Out 1

16. Analog Audio In 3

14. Analog Audio In 1

18. Analog Audio Out 3 or AES/EBU CH3&4 Out

20. Composite In

22. S-Video In

13. Analog Audio Out 2

17. Analog Audio In 4

15. Analog Audio In 2

19. Analog Audio Out 4 or AES/EBU CH5&6 Out

21. Composite Out

23. S-Video Out

24. Standard Definition SDI Out

HDMI Input HDMI Output

UltraStudio Pro Breakout Cable

UltraStudio Pro
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UltraStudio SDI

HD/SD-SDI 
Input and Output 

USB 3.0HDMI
Output

Ref
In

Deck Control  
RS-422
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Caution: Risk of Electric Shock
On the UltraStudio 4K enclosure you will see a yellow warning label marked ‘Caution: Risk of Electric Shock’. 
This is intended to warn users that there may be the presence of uninsulated “dangerous” voltage within 
the UltraStudio 4K enclosure which may be of sufficient magnitude to constitute a risk of electric shock to 
the user. Blackmagic Design advises you not to open the UltraStudio 4K unit, but rather contact your nearest 
Blackmagic Design service center should assistance be required.

Achtung: Stromschlaggefahr
Auf dem UltraStudio 4K-Gehäuse befindet sich ein gelbes Warnetikett mit der Aufschrift 'Caution:  
Risk of Electric Shock’. Dieses warnt den Benutzer vor einer möglichen, nicht isolierten, "gefährlichen" 
Spannung innerhalb des UltraStudio 4K-Gehäuses, die einen Elektroschock verursachen kann. Blackmagic 
Design empfiehlt das Gehäuse des UltraStudio 4K nicht selbst zu öffnen, sondern bei Hilfebedarf das 
nächstgelegene Blackmagic Design Servicecenter zu kontaktieren.

Attention: Risque de choc électrique
Sur le boîtier du UltraStudio 4K, vous verrez une étiquette d’avertissement de couleur jaune sur laquelle est 
inscrit « Attention : Risque de choc électrique ». Cette mise en garde est destinée à avertir les utilisateurs 
de la présence possible d’une tension « dangereuse » non isolée à l’intérieur du boîtier du UltraStudio 4K, 
laquelle tension pouvant avoir une amplitude suffisante pour constituer un risque de choc électrique à 
l’utilisateur. Blackmagic Design vous déconseille donc d’ouvrir l’unité UltraStudio 4K, et vous recommande 
de contacter votre centre de service Blackmagic Design le plus proche en cas de nécessité.

Caution label

Warnetikett

Avertissement
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Limited Warranty
Blackmagic Design warrants that UltraStudio, DeckLink and Multibridge family products will be free from 
defects in materials and workmanship for a period of 36 months from the date of purchase excluding 
connectors, cables, cooling fans, fiber optic modules, fuses, keyboards and batteries which will be free from 
defects in materials and workmanship for a period of 12 months from the date of purchase. Blackmagic 
Design warrants that Intensity family products will be free from defects in materials and workmanship for 
a period of 12 months from the date of purchase. If a product proves to be defective during this warranty 
period, Blackmagic Design, at its option, either will repair the defective product without charge for parts 
and labor, or will provide a replacement in exchange for the defective product.

In order to obtain service under this warranty, you the Customer, must notify Blackmagic Design of the 
defect before the expiration of the warranty period and make suitable arrangements for the performance 
of service. The Customer shall be responsible for packaging and shipping the defective product to a 
designated service center nominated by Blackmagic Design, with shipping charges pre paid. Customer 
shall be responsible for paying all shipping changes, insurance, duties, taxes, and any other charges for 
products returned to us for any reason. 

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or 
inadequate maintenance and care. Blackmagic Design shall not be obligated to furnish service under 
this warranty: a) to repair damage resulting from attempts by personnel other than Blackmagic Design 
representatives to install, repair or service the product, b) to repair damage resulting from improper 
use or connection to incompatible equipment, c) to repair any damage or malfunction caused by the 
use of non Blackmagic Design parts or supplies, or d) to service a product that has been modified or 
integrated with other products when the effect of such a modification or integration increases the time or 
difficulty of servicing the product. THIS WARRANTY IS GIVEN BY BLACKMAGIC DESIGN IN LIEU OF ANY 
OTHER WARRANTIES, EXPRESS OR IMPLIED. BLACKMAGIC DESIGN AND ITS VENDORS DISCLAIM 
ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
BLACKMAGIC DESIGN’S RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS IS THE 
WHOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR ANY INDIRECT, SPECIAL, 
INCIDENTAL OR CONSEQUENTIAL DAMAGES IRRESPECTIVE OF WHETHER BLACKMAGIC DESIGN 
OR THE VENDOR HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES. BLACKMAGIC 
DESIGN IS NOT LIABLE FOR ANY ILLEGAL USE OF EQUIPMENT BY CUSTOMER. BLACKMAGIC IS 
NOT LIABLE FOR ANY DAMAGES RESULTING FROM USE OF THIS  PRODUCT. USER OPERATES THIS 
PRODUCT AT OWN RISK. 

© Copyright 2013 Blackmagic Design. All rights reserved. ‘Blackmagic Design’, ‘DeckLink’, ‘HDLink’, ‘Workgroup Videohub’, ‘ Videohub’, 
‘DeckLink’, ‘Intensity’ and ‘Leading the creative video revolution’ are registered trademarks in the US and other countries. All other company and 
product names may be trade marks of their respective companies with which they are associated.

Thunderbolt and the Thunderbolt logo are trademarks of Intel Corporation in the U.S. and/or other countries.


