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Purpose

This guide provides all the information that you need to use Hyperion
Essbase Spreadsheet Add-in for Lotus 1-2-3 for Windows. It explains the
features and options and discusses the concepts, processes, procedures,
formats, tasks, and examples that you need to use the software.

Hyperion Essbase is an online analytical processing (OLAP) solution that
satisfies the complex calculation requirements of financial, accounting, and
marketing professionals. Hyperion Essbase operates in a client-server
computing environment on a local area network (LAN). In this environment,
multiple users can use their desktop computers to retrieve and analyze
centralized data.

You can create reports from the data residing on Hyperion Essbase OLAP
Server in several ways:
v Generate database reports through a spreadsheet interface, called Hyperion

Essbase Spreadsheet Add-in, as explained in this guide.
v Use Hyperion Essbase Application Manager Report Writer to create a report

script and run a report. For more information, see the Hyperion Essbase
Database Administrator’s Guide.

v Use Hyperion Essbase Application Programming Interface (API) to create
and run database reports. For more information, see the Hyperion Essbase
online API Reference.

v Use reporting tools, such as Hyperion Reporting for Hyperion Essbase.

Audience

This guide is for Hyperion Essbase end users who are responsible for some or
all of the following tasks:
v Starting Hyperion Essbase and connecting and disconnecting from

Hyperion Essbase databases
v Retrieving data from a database into a worksheet
v Drilling down, drilling up, and navigating through a worksheet to analyze

and arrange data from multiple viewpoints
v Working with linked reporting objects and linked partitions
v Updating data on the Hyperion Essbase server
v Using the worksheet to load and calculate data in the database
v Creating multiple sheets from data
v Working with currency conversions
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Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Hyperion Essbase
Spreadsheet Add-in. This document contains the following information:
v “Introducing Release 6” on page ix provides information on migrating from

previous versions of Hyperion Essbase to Release 6 and lists all new
features and enhancements.

v “Chapter 1. Introducing Hyperion Essbase” on page 1 introduces you to
basic concepts of retrieving and manipulating data through the spreadsheet
interface.

v “Chapter 2. A Basic Hyperion EssbaseTutorial” on page 11 provides a
step-by-step tutorial of basic data navigation, ad hoc retrieval, and
reporting techniques.

v “Chapter 3. An Advanced Hyperion Essbase Tutorial” on page 83 describes
advanced reporting and retrieval techniques for users that need special
reports or formatted data views.

v “Chapter 4. Using Hyperion Integration Server Drill-Through” on page 159
provides a brief overview of the Hyperion Integration Server Drill-Through
product.

v The Indexcontains a list of terms and their page numbers. Select or look up
an index entry to view the page to which the entry refers.

Note: The Hyperion Essbase Spreadsheet Add-in online help provides a
comprehensive section on Hyperion Essbase Spreadsheet Toolkit. This
section enables you to customize and automate your use of Hyperion
Essbase by using Lotus 1-2-3 macros and Visual Basic for Applications
(VBA) functions. For more information on the Hyperion Essbase
Spreadsheet Add-in online help, see Chapter 2, “Accessing Online
Help.”

The Spreadsheet Add-in User’s Guide for 1-2-3 is provided in the
\essbase\docs\client directory in .pdf format for online viewing and
printing in Adobe® Acrobat Reader® (Release 4 or higher). The .pdffile is
named Essexcel.pdfEss123w.pdf. You can download Adobe Acrobat Reader
from the Hyperion Essbase CD-ROM or from http://www.adobe.com. On the
Hyperion Essbase CD-ROM, the Acrobat Reader executable file is located in
the Adobe directory under the appropriate platform and language-version
subdirectories. To install Adobe Acrobat Reader, launch the executable file,
follow the prompts, and provide the information requested.

Sample Databases and Files
This book provides tutorial steps that are based on sample databases and files
that are provided with the Hyperion Essbase server software. You use the
Sample Basic database for most tasks in “Chapter 2. A Basic Hyperion
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EssbaseTutorial” on page 11 and “Chapter 3. An Advanced Hyperion Essbase
Tutorial” on page 83. You use a sample Hyperion Essbase Currency
Conversion application for the section on currency conversion. See “Chapter 3.
An Advanced Hyperion Essbase Tutorial” on page 83. For information on the
Sample Basic database, see “Chapter 2. A Basic Hyperion EssbaseTutorial” on
page 11.

In addition to these sample applications and databases, you also use several
sample Lotus 1-2-3 files in the advanced tutorial in “Chapter 3. An Advanced
Hyperion Essbase Tutorial” on page 83. The individual at your organization
who installs the server is responsible for making these applications, databases,
and files available to you. Contact the Hyperion Essbase system administrator
for more information.

Online Help

To access online help, click the Help button in any Hyperion Essbase dialog
box or select Essbase Help from the Essbase menu.

To print an online help topic, display the topic and select File > Print, or
right-click and select Print from the pop-up menu.

Conventions

The following table shows the conventions that are used in this document:
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Item Meaning

=> Arrows indicate the beginning of a procedure, which consists of one
or more sequential steps.

Brackets [ ] In examples, brackets indicates that the enclosed elements are
optional.

Bold Bold text indicates words or characters that you type exactly as they
appear on the page. Bold in procedural steps highlight major interface
elements.

CAPITAL LETTERS Capital letters denote file names, functions, DOS commands, and
various IDs. For example, the text might refer to the GDC.INI file.

Example text Text shown in this font indicates that the material shown is an
example for your use.

Ctrl + 0 Keystroke combinations indicate that you should press the keys
simultaneously (yet still somewhat sequentially) as shown.

Italics Italic text indicates a variable field in command syntax. Substitute
your own values in place of the variable shown in italics. Titles of
other books are also in italics. And italics indicate important terms
and special emphasis.

Ellipses (...) Use of an ellipses indicates an omission of irrelevant material, which
is typically used in an example to show only the relevant material.

Mouse orientation This document provides examples and procedures using a
right-handed mouse. If you are using a left-handed mouse, adjust the
procedures accordingly.

Menu commands Menu commands are presented in the following format:Menu name >
Menu command > Extended menu command For example: File > Desktop
> Accounts

n, x The variable n indicates that you must supply a generic number; the
variable x indicates that you must supply a generic letter.
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Introducing Release 6

This chapter provides compatibility information for Hyperion Essbase Release
6 and previous releases of Hyperion Essbase, including migration information
and new feature descriptions and enhancements. It contains the following
sections:
v “Migrating to Release 6”
v “What’s New in Release 6”

Migrating to Release 6

As you migrate (upgrade) from previous releases of Hyperion Essbase to
Release 6, keep in mind that Release 6 of Hyperion Essbase Spreadsheet
Add-in is designed to work with Release 6 of Hyperion Essbase OLAP Server.
If the Hyperion Essbase system administrator upgrades the Hyperion Essbase
server to Release 6, Release 5.x of Hyperion Essbase Spreadsheet Add-in
works on only a limited basis. Upgrade to Hyperion Essbase Spreadsheet
Add-in to Release 6 as soon as possible.

Read the Hyperion Essbase Start Here booklet and the Hyperion Essbase
Installation Guide for detailed information about migrating from previous
releases of Hyperion Essbase.

What’s New in Release 6

Hyperion Essbase Release 6 provides a number of enhancements and new
features for Hyperion Essbase Spreadsheet Add-in.

View attributes in reports by typing the name of the attribute directly into the
worksheet by using member selection, or by using Hyperion Essbase Query
Designer. You can also apply styles to attributes to identify the attributes in
the worksheet.

Hyperion Essbase Query Designer (EQD) replaces Retrieval Wizard. You use
EQD to create queries for reports. This new component enables you to do the
following functions:
v Design a layout for the report
v Select members (including attributes) for the report
v Perform member filtering
v Perform data filtering
v Perform data sorting

© Copyright IBM Corp. 1998, 2000 ix



New client platforms, Microsoft Excel 2000 and Lotus 1-2-3 Millennium
Releases 9 and 9.1, are supported.
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Chapter 1. Introducing Hyperion Essbase

Hyperion Essbase is multidimensional database software that is optimized for
planning, analysis, and management reporting applications. Hyperion Essbase
uniquely blends an innovative technical design with an open, client-server
architecture. Hyperion Essbase enables you to extend your decision support
systems beyond ad hoc queries and reports on historical performance to
dynamic, operational systems that combine historical analysis and future
planning. By consolidating and staging historical and projected data for
detailed analysis, you gain perspectives about your business that enable you
to take appropriate actions.

Hyperion Essbase provides both power and flexibility.Thus, it can be used for
a broad range of online analytical processing (OLAP) applications including
the following:
v Budgeting
v Forecasting and seasonal planning
v Financial consolidations and reporting
v Customer and product profitability analysis
v Price, volume, and mix analysis
v Executive information systems (EIS)

Hyperion Essbase enables you and others in your organization to share,
access, update, and analyze enterprise data from any perspective and at any
level of detail without learning new tools, query languages, or programming
skills.

Typical Users of Hyperion Essbase

Hyperion Essbase is designed for use in many different applications. Financial
analysts have found Hyperion Essbase to be invaluable in budget analysis,
currency conversion, and consolidation. Cost accountants apply the powerful
capabilities of Hyperion Essbase to evaluate allocation and elimination
scenarios. Product managers and analysts use Hyperion Essbase to plan and
analyze multiple product lines and distribution channels. Hyperion Essbase
can also be used as a repository database for spreadsheet data. Anyone who
uses a spreadsheet is a potential user of Hyperion Essbase.

Because Hyperion Essbase is applicable to such a broad variety of
environments, individuals using it at your organization may fill one or more
roles in implementing and running applications. This guide refers to specific
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roles by three titles. However, in actuality, a role may be performed by one
person or by several people working collaboratively.
v Hyperion Essbase system administrator. The Hyperion Essbase system

administrator typically has experience in networking, installing software
packages, and administering system functions. In addition to installing the
Hyperion Essbase software, the Hyperion Essbase system administrator
may also set up Hyperion Essbase user accounts, set up the security system,
and maintain Hyperion Essbase OLAP Server.

v Application designer. The application designer sets up the Hyperion Essbase
database, creates the database outline, and develops calculation and report
scripts. The responsibilities of the Hyperion Essbase system administrator
and the application designer may overlap in some areas. The application
designer has probably developed spreadsheet or database applications and
understands the operational problems and the tools being employed to
solve them.

v User. The user interacts with Hyperion Essbase databases through
spreadsheets, using Microsoft Excel for Windows or Lotus 1-2-3. Users are
typically analysts and managers who use spreadsheet programs as their
primary tool for viewing and analyzing data.

Components of the Client-Server Environment

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of a local area
network (LAN). The PC workstation acts as a client by requesting data from
the server. The server processes the request and returns the desired result to
the client.

Hyperion Essbase is built as a client-server system. System performance and
multiuser capabilities are greatly enhanced in the Hyperion Essbase
client-server environment.

The Server
Hyperion Essbase OLAP Server is a multidimensional database that supports
analysis of an unlimited number of data dimensions and an unlimited number
of members within these dimensions. Developed using a true client-server
architecture, all data, the database outline, the calculations, and the data
security controls reside on the Hyperion Essbase server.

The Hyperion Essbase server operates on Windows 95, Windows 98, Windows
NT, and UNIX operating systems.

Hyperion Essbase Spreadsheet Add-in
Hyperion Essbase Spreadsheet Add-in is a software program that merges
seamlessly with Microsoft Excel and Lotus 1-2-3. After Hyperion Essbase is
installed, a special menu is added to Lotus 1-2-3. The menu provides
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enhanced commands such as Connect, Pivot, Drill-down, and Calculate. Users
can access and analyze data on the Hyperion Essbase server by using simple
mouse clicks and drag-and-drop operations. Hyperion Essbase Spreadsheet
Add-in enables multiple users to access and update data on the Hyperion
Essbase server simultaneously.

The Network
Hyperion Essbase runs on PC-based LANs that support the Named Pipes or
TCP/IP protocol.

Note: Supported network environments and technical requirements are
discussed in detail in the Hyperion Essbase Installation Guide, which is
included with the Hyperion Essbase OLAP Server package.

Hyperion Essbase Application Products

Several optional products, designed to extend and enhance the scope of OLAP
applications, can be addressed using the Hyperion Essbase server. The
following sections describe these products.

Hyperion Essbase Spreadsheet Toolkit
Hyperion Essbase Spreadsheet Toolkit includes over 20 macro and Visual
Basic for Applications (VBA) functions that enable you to build customized
Microsoft Excel and Lotus 1-2-3 applications. The applications incorporate
Hyperion Essbase commands. Commands such as EssCascade, EssConnect,
and EssDisconnect provide all of the functionality of their corresponding
Hyperion Essbase menu commands. For more information, see the Hyperion
Essbase Spreadsheet Add-in online help.

Hyperion Essbase Partitioning Option
Hyperion Essbase Partitioning option enables you to define areas of data that
are shared or linked between data models. Partitioning can affect the
performance and scalability of Hyperion Essbase applications. Partitioning
provides more effective response to organizational demands, reduced
calculation time, increased reliability and availability, and incorporation of
detail and dimensionality. For more information, see “Accessing Linked
Partitions” on page 143 on page 204.

Hyperion Essbase Structured Query Language Interface
Hyperion Essbase SQL Interface enables access to PC and structured query
language (SQL) relational databases by making the Hyperion Essbase server
operate as an open database connectivity client. Using Hyperion Essbase SQL
Interface, data can be moved easily from these diverse corporate data sources
into the Hyperion Essbase server for user access and analysis. For more
information, see the Hyperion Essbase SQL Interface Guide.
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Hyperion Essbase Application Programming Interface
Hyperion Essbase Application Programming Interface (API) enables
application developers to create custom applications quickly by using
standard tools while taking advantage of the robust data storage, retrieval,
and manipulation capabilities of Hyperion Essbase. Hyperion Essbase API
supports Visual Basic and C. For more information, see the online API
Reference.

Hyperion Essbase Currency Conversion
Hyperion Essbase Currency Conversion translates, analyzes, and reports on
foreign financial data. Any exchange rate scenario can be modeled, and you
can even perform ad hoc currency conversions of data directly from the
spreadsheet. The Currency Conversion product is compliant with Financial
Accounting Standards Board 52 (FASB52). For more information, see “Working
with Currency Conversions” on page 153.

Hyperion Integration Server
Hyperion Integration Server works with Hyperion Essbase and Microsoft
Excel and Lotus 1-2-3. Hyperion Integration Server is a suite of tools and data
integration services that serve as a bridge between relational data sources and
Hyperion Essbase OLAP Server. Hyperion Integration Server Drill-Through is
one of the tools of Hyperion Integration Server. Using Drill-Through, you can
view and customize spreadsheet reports that display data retrieved from
relational databases. For more information, see “Chapter 4. Using Hyperion
Integration Server Drill-Through” on page 159

Hyperion Objects
Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in
Hyperion Essbase servers. You can combine objects with other controls in a
visual design environment to construct new programs.

Hyperion Web Gateway
Hyperion Web Gateway is a multithreaded server application that enables
high-speed, interactive, read/write access to Hyperion Essbase for OLAP
applications over the World Wide Web. Combining Hyperion Essbase with
Hyperion Web Gateway provides a comprehensive Web-based solution that
delivers sophisticated management reporting, provides ad hoc
multidimensional analysis, and enables development of comprehensive
operational OLAP applications, including planning, budgeting, and
forecasting over intranets or the Internet.
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The Multidimensional Database

The Hyperion Essbase multidimensional database stores and organizes data. It
is optimized to handle applications that have large amounts of numeric data
and are consolidation-intensive or computation-intensive. In addition, the
database organizes data in a way that reflects how the user wants to view the
data.

Definition of Multidimensional
A dimension is a perspective or view of a specific dataset. A different view of
the same data is an alternate dimension. A system that supports simultaneous,
alternate views of datasets is multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on
(see Figure 1). Each dimension contains additional categories that have various
relationships one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:

A Hyperion Essbase application contains an unlimited number of dimensions,
so you can analyze large amounts of data from multiple viewpoints. The
following illustration shows four views of multidimensional data. You can
retrieve and analyze the data with the Hyperion Essbase Spreadsheet Add-in
software:

Figure 1. Multiple Views from a Five-Dimensional Database
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Database Outlines

Understanding the database outline is the key to understanding Hyperion
Essbase. To define a multidimensional database, you design its database
outline. The database outline contains the database organization (structure),
the database members, and the database rules, as shown in Figure 3:

Note: The application designer or Hyperion Essbase system administrator
usually creates the database outline. For more information on creating
the database outline, see the Hyperion Essbase Database Administrator’s
Guide.

The components of the database outline are the following:
v Dimensions
v Members
v Attributes
v Formulas
v Aliases
v Consolidations

Refer to the following sections for descriptions of the outline components.

Figure 3. Hyperion Essbase Database Outline
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Dimensions
Dimensions are the most basic categorical definitions of data within the
database outline. You need at least two dimensions to make any meaningful
reference to data; for example, a time dimension and an accounts dimension.
Other dimensions may categorize products, markets, and scenarios. Using
dimensional organization, you can define any consolidation structure or any
slice of data that is relevant to the application. Hyperion Essbase supports an
unlimited number of dimensions.

Members
Membersare the names of the elements within a dimension. A dimension can
contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Hyperion Essbase use the following terms to
describe members.
v Parents. A parent is a member with a consolidation branch below it. For

example, in the illustration below, Qtr1 is a parent member because there is
a branch containing monthly members below it.

v Children. A child is a member with a parent above it. For example, Jan, Feb,
and Mar are children of the parent Qtr1.

v Siblings. A sibling is a child member of the same parent and on the same
branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not
a sibling of Jan, Feb, or Mar, however, because it has a different parent,
Qtr2.

v Descendants. A descendant is a member at any level below a parent. For
example, each member that falls in the Year branch is a descendant of Year.
The following members are all descendants of Year: Qtr1, Jan, Feb, Mar;
Qtr2, Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

Figure 4. Relationships Among Database Members
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v Ancestors. An ancestor is a member of a branch above a member. For
example, Qtr2 and Year are ancestors of Apr.

v Generations. The term generation describes the branch number of a member.
Generations count from the root of the tree (generation 1, which is the
dimension name) toward the leaf node.

v Levels. The term level describes the branch number of a member. Levels
count from the leaf node (level 0) toward the root (the dimension name).

Attributes
Attributes describe characteristics of data, such as the size and color of
products. Through attributes, you can group and analyze members of
dimensions based on their characteristics. Attribute dimensions must be
associated with base dimensions. For more information, see the Hyperion
Essbase Database Administrator’s Guide.

Formulas
Each database member can have one or more formulas associated with it in
the database outline. For example, the Variance members of the Scenario
dimension, as shown in Figure 3 on page 7, contain formulas. Formulas can be
simple or complex. For more information, see the Hyperion Essbase Database
Administrator’s Guide.

Aliases
Hyperion Essbase supports alternative names, or aliases, for database
members. Aliases are useful when various labels are used for the same
member in various worksheets. One worksheet, for example, may refer to
Cost_of_Goods_Sold as COGS. Aliases also can be used for reporting in
alternative languages or for more formal output name sets, such as account
numbers.

Consolidations
Consolidations in Hyperion Essbase applications are defined by member
branches. The database outline determines consolidation paths. The
determination is based on the location of members within a dimension.
Indentation of one member below another indicates a consolidation
relationship. Indentingmembers is important for the drill-down capabilities in
Hyperion Essbase Hyperion Essbase Spreadsheet Add-in. As you navigate
your way through data, you can drill down through levels of consolidations.
The database outline is the roadmap that determines the levels of data
navigation.

Chapter 1. Introducing Hyperion Essbase 9
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Chapter 2. A Basic Hyperion EssbaseTutorial

When you add Hyperion Essbase Spreadsheet Add-in to Lotus 1-2-3, most
Lotus 1-2-3 operations remain unchanged; Hyperion Essbase Spreadsheet
Add-in simply adds a new menu, a Hyperion Essbase toolbar, and mouse
shortcuts with which you can access Hyperion Essbase OLAP Server.

The tasks described in this tutorial are basic tasks. That is, these are tasks that
you probably use often when working with Hyperion Essbase. “Chapter 3. An
Advanced Hyperion Essbase Tutorial” on page 83 describes more advanced
tasks.

This tutorial chapter contains the following sections:
v “Getting Acquainted with Hyperion Essbase Spreadsheet Add-in” on

page 12
v “Preparing to Begin the Tutorial” on page 16
v “Retrieving Data” on page 21
v “Pivoting, Retaining, and Suppressing Data” on page 33
v “Formatting the Worksheet” on page 46
v “Creating Queries Using Hyperion Essbase Query Designer” on page 57
v “Deleting Queries” on page 68
v “Viewing Messages and Confirmations” on page 68
v “Accessing Help” on page 69
v “Selecting Members” on page 72
v “Saving and Disconnecting” on page 80
v “Moving on to Advanced Tasks” on page 81

Note: Each tutorial task builds upon the previous task. Therefore, tasks must
be completed in succession.

The examples used in this tutorial are based on the sample database (called
Sample Basic) that is included with the Hyperion Essbase installation. Contact
the Hyperion Essbase system administrator for information about accessing
the Sample Basic database or about accessing other databases on the Hyperion
Essbase server.

© Copyright IBM Corp. 1998, 2000 11



Getting Acquainted with Hyperion Essbase Spreadsheet Add-in

This section provides the following information to help you get acquainted
with Hyperion Essbase Spreadsheet Add-in:
v “Adding Hyperion Essbase Spreadsheet Add-in”
v “Starting Hyperion Essbase Spreadsheet Add-in” on page 13
v “Accessing Online Help” on page 14
v “Enabling Mouse Actions” on page 14

Adding Hyperion Essbase Spreadsheet Add-in
If you manually update your environment settings or if you have removed
Hyperion Essbase Spreadsheet Add-in from the Lotus 1-2-3, you must use the
Lotus 1-2-3 facility to add Hyperion Essbase Spreadsheet Add-in into Lotus
1-2-3. The facility adds the Hyperion Essbase menu to the Lotus 1-2-3 menu
bar and points Lotus 1-2-3 to the Hyperion Essbase Spreadsheet Add-in file in
the \essbase\bin directory. This file is on the hard drive of your PC, if that is
where you installed Hyperion Essbase Spreadsheet Add-in, or on the network
drive if that is where you set up your PC operating environment to run
Hyperion Essbase Spreadsheet Add-in.

To add Hyperion Essbase Spreadsheet Add-in to Lotus 1-2-3:
1. In Lotus 1-2-3, select File > Add-Ins > Manage Add-Ins.

Lotus 1-2-3 displays the Manage Add-ins dialog box.
2. Click Register and select the file ESS123.12A in the \essbase\bindirectory

where you installed Hyperion Essbase Spreadsheet Add-in on your PC
hard drive (if you installed the Add-in software there), or in the bin
directory where the Hyperion Essbase system administrator installed the
Hyperion Essbase Spreadsheet Add-in on a network drive (if you set up
the PC operating environment to run the Add-in software there).

3. Click Open and select the ESS123.12A add-in file. Make sure there is a
check mark next to the add-in file.

4. Click Done to close the Manage Add-ins dialog box and start the Hyperion
Essbase Spreadsheet Add-in.
The Hyperion Essbase startup screen is displayed.

Figure 5. Manage Add-ins Dialog Box
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If you do not see the Hyperion Essbase startup screen or if your system
does not list the Hyperion Essbase Spreadsheet Add-In menu options, see
the Hyperion Essbase Installation Guide for troubleshooting information.

Starting Hyperion Essbase Spreadsheet Add-in
Because Hyperion Essbase Spreadsheet Add-in software for Lotus 1-2-3

is implemented as an Lotus 1-2-3 add-in, you must start Lotus 1-2-3 from
Windows to use Hyperion Essbase Spreadsheet Add-in software.

You must open a worksheet before attempting to connect to the Hyperion
Essbase server. An attempt to connect to the Hyperion Essbase server without
opening a worksheet results in an error message.

To begin a Hyperion Essbase session:
1. Start Lotus 1-2-3.

After the Lotus 1-2-3 startup screen disappears, the Hyperion Essbase
startup screen is displayed.
The Hyperion Essbase menu should be displayed in the Lotus 1-2-3 menu
bar. If you do not see the Hyperion Essbase menu, you may need to use
the Lotus 1-2-3 add-in facility to add Hyperion Essbase Spreadsheet
Add-in into Lotus 1-2-3. For more information, see “Adding Hyperion
Essbase Spreadsheet Add-in” on page 12.

2. From the Lotus 1-2-3 menu bar, select Essbase to open the menu.

Figure 6. The Essbase Menu
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Note: If the Lotus 1-2-3 status bar is not displayed, you can display it by
selecting View > Show Status Bar.

Accessing Online Help
Hyperion Essbase Spreadsheet Add-in includes a context-sensitive online help
system. You access the Hyperion Essbase Spreadsheet Add-in online help in
one of three ways. Which way you choose depends on the type of information
that you need,
v Access the entire online help system for browsing or searching for

information. To access the entire help system, select Essbase > Essbase Help.
After you access online help, you can browse or search through the system
to view general information on Hyperion Essbase Spreadsheet Add-in,
Essbase command descriptions, procedural information for completing
tasks, Spreadsheet Toolkit macros, and Visual Basic for Applications (VBA)
function descriptions.

v Access context-specific information from dialog boxes in Hyperion Essbase
Spreadsheet Add-in. Each dialog box in Hyperion Essbase Spreadsheet
Add-in features a Help button that accesses online help topics that are
specific to the particular dialog box. The buttons enable you to find the
information you need without having to search through the entire help
system.

Note: The Hyperion Essbase Spreadsheet Add-in online help also provides
a comprehensive section on Hyperion Essbase Spreadsheet Toolkit,
which enables you to customize and automate your use of Hyperion
Essbase by using Lotus 1-2-3 macros .

v Access information on a specific Hyperion Essbase Query Designer function.
Access What’s This? Help in the Hyperion Essbase Query Designer dialog
box, and then click an item in the dialog box to access information on that
item.

Enabling Mouse Actions
The following terms are used throughout this guide to describe mouse
operations:
v Primary mouse button and secondary mouse button describe the buttons on a

two- or three-button mouse. Usually, right-handed users configure the left
mouse button as the primary button and the right mouse button as the
secondary mouse button. The primary mouse button is the one that you use
to start Windows applications, such as Lotus 1-2-3; the secondary mouse

Figure 7. EQD Help Button
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button is used for auxiliary operations. The term click refers to use of the
primary mouse button. The term right-click refers to use of the secondary
mouse button.

v Select chooses the object that is under the cursor when you press and
release the primary mouse button. You can select a worksheet cell, for
example, by moving the cursor to the cell and pressing and releasing the
primary mouse button.

v Click (that is, both click and right-click) describes a quick press-and-release
action on a command object. You can click a button, for example, to execute
a command.

v Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example,
to start a Windows application.

v Drag describes a press, hold, and move action. You place the cursor on an
object, press a mouse button, hold the mouse button and move the object,
and release the mouse button when you reach your goal. For example, you
can highlight a range of cells in Lotus 1-2-3 worksheet by dragging the
cursor over the cells.

Note: Hyperion Essbase uses a drag operation called a pivot. A pivot
requires use of the secondary mouse button. To execute a pivot, you
must press and hold the secondary, rather than the primary, mouse
button while dragging the selection.

Hyperion Essbase offers enhanced mouse actions in Lotus 1-2-3. You can use
the mouse to do any of the following:
v Retrieve data
v Drill down and drill up on database members
v Pivot (move or transpose) data rows and columns
v Access linked reporting objects
v Access linked partitions

To enable double-clicking to retrieve, drill down, and drill up on Hyperion
Essbase data:
1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Global tab.
3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up
to less detailed data (secondary mouse button). When the double-clicking
option is enabled, the Lotus 1-2-3 in-cell editing feature is overridden.
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4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the
Hyperion Essbase Spreadsheet Add-in online help.

Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:
v “Setting Hyperion Essbase Options”
v “Following Guidelines During the Tutorial” on page 20
v “Reviewing the Sample Basic Database” on page 21

Setting Hyperion Essbase Options
Before you begin the tutorial steps, make sure that the worksheet options are
set to the initial settings as illustrated in Figures 2-6 through 2-9. If the option
settings are different, the illustrations presented in this chapter may not match
the worksheet view.

Note: For information about each option in the Essbase Options dialog box,
see the Hyperion Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.

Figure 8. Essbase Options Dialog Box—Global Tab
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3. Select the appropriate check boxes and option buttons so that your
display of the Display tab matches the following illustration:

4. Select the Zoom tab.
5. Select the appropriate check boxes and option buttons so that your

display of the Zoom tab matches the following illustration:

Figure 9. Initial Settings for Display Options
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6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display of the Mode tab matches the following illustration:

Figure 10. Initial Settings for Zoom Options
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Note: If you are already connected to a Hyperion Essbase database, the
Essbase Options dialog box also displays a Style tab. You can skip
this tab for now.

8. Select the Global tab.
9. Select the appropriate check boxes and option buttons so that your

display of the Global tab matches the following illustration:

Figure 11. Initial Settings for Mode Options
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Note: You should have already selected the appropriate boxes for Mouse
Actions, as described in “Enabling Mouse Actions” on page 14.

10. Click OK to save the settings for this session and close the Essbase
Options dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:
v Tasks that should not be performed as part of the tutorial are displayed in

gray boxes. These tasks are included only for your future reference. You can
find more information on these tasks in the Hyperion Essbase Spreadsheet
Add-in online help.

v You must be connected to the Sample Basic database during the tutorial. If
you are not connected to this database, the illustrations presented in this
chapter will not match the worksheet view.

v You can access many Hyperion Essbase commands in any one of these
ways:
– By selecting the command from the Hyperion Essbase menu
– By clicking the appropriate button on the Hyperion Essbase toolbar
– For the Zoom In and Zoom Out commands, by double-clicking either the

primary mouse or the secondary mouse button

Figure 12. Initial Settings for Global Options
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v You must set the options in the Hyperion Essbase Options dialog box as
described in “Setting Hyperion Essbase Options” on page 16. If the option
settings are different, the illustrations presented in this chapter may not
match the worksheet view.

v After you change a worksheet option in the Hyperion Essbase Options
dialog box, you must perform a retrieval or a drill-down operation to have
the new setting take effect.

v Be sure to follow each step in the tutorial. Each tutorial task builds upon
the previous task. Do not skip the final steps at the end of sections, because
these steps are often necessary to prepare you for the next tutorial task.

v If you make a mistake during the tutorial, you can select Essbase >
FlashBack to return to the previous worksheet view.

v The values in the Sample Basic database that represent ratios or percentages
are calculated to a very high level of precision (for example, 55.26162826).
In Lotus 1-2-3, you can apply a cell format to control the number of decimal
places that are displayed in data values. For more information, see the
Lotus1-2-3 documentation.

v The numeric values that are shown in the illustrations used throughout this
tutorial may not match the values stored in your database. The values
shown in these illustrations reflect a freshly loaded database.

v Some worksheet columns have been adjusted for clarity in the illustrations.
You do not need to change the width of columns in the worksheet to follow
the tutorial steps. The Adjust Columns option in the Hyperion Essbase
Options dialog box (Display Tab) adjusts columns for you.

Reviewing the Sample Basic Database
The Sample Basic database that you use for the tutorial is based on a
hypothetical company in the beverage industry. The major products of the
company are various kinds of sodas. These products are sold in U.S. markets,
which are categorized by state and region. Financial data for the company is
collected monthly and is summarized by quarter and by year. The company
uses Hyperion Essbase to calculate financial and accounting data, such as
sales, cost of goods sold, and payroll. The company tracks both actual and
budget data, as well as the variance and percent variance between the two.

Retrieving Data

Now that you are more familiar with the Hyperion Essbase environment, you
can connect to the Hyperion Essbase server and start using Hyperion Essbase
and Hyperion Essbase Spreadsheet Add-in. The following section guides you
through a typical Hyperion Essbase session where you connect to a database
and retrieve data in various ways.

This section outlines the following basic retrieval tasks:
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v “Connecting to a Database”
v “Changing a Password” on page 24
v “Retrieving Data from a Database” on page 24
v “Canceling a Data Retrieval Request” on page 26
v “Restoring the Previous Database View” on page 26
v “Drilling Down to More Detail” on page 27
v “Drilling Up to Less Detail” on page 30
v “Customizing Drill-Down and Drill-Up Behavior” on page 31

Note: Make sure that you followed the steps in “Setting Hyperion Essbase
Options” on page 16. If the settings in the Hyperion Essbase Options
dialog box are different from the settings previously illustrated, the
worksheet view will differ from the illustrations shown in this chapter.

Remember that you can perform common data retrieval tasks by doing any of
the following:
v Selecting commands from the Essbase menu on the Lotus1-2-3 menu bar
v Clicking the appropriate buttons on the Hyperion Essbase toolbar
v Double-clicking the primary or the secondary mouse button in the

appropriate cell (for Retrieve, Zoom In, and Zoom Out commands)

Connecting to a Database
To access Hyperion Essbase data, you must first connect to a database on the
server. This tutorial assumes that you have the appropriate privileges to
connect to a server, an application, and a database.
1. Select Essbase > Connect

Hyperion Essbase displays the Essbase System Login dialog box.
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Note: To complete the steps that follow, you need to know the name of
the Hyperion Essbase server, your username, and your password. If
you do not have this information, contact the Hyperion Essbase
system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want does not appear in the list, you can type in the
name of the server you want to access.)

3. Press Tab to move to the Username text box; type your username in the
text box.

4. Press Tab to move to the Password text box; type your password in the
text box.

Note: You can change your password when you are connected to a server.
To change your password, see “Changing a Password” on page 24.

5. To connect to the server, click OK.
Hyperion Essbase displays a list of available application/database pairs in
the Application/Databaselist box. A Hyperion Essbase server allows
simultaneous access to multiple applications. An application can contain
multiple databases. Only the databases to which you have security access
are shown in the list.
For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Hyperion Essbase installation, it is
shown in the list. If Sample Basic is not shown in the
Application/Database list box, ask the Hyperion Essbase system
administrator to install it.

Figure 13. Essbase System Login Dialog Box
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6. In the Application/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.

If the application is not already running, Hyperion Essbase automatically
starts it. There may be a brief pause as the application loads. The time
required to start an application depends on the number of databases, the sizes
of the databases, and the sizes of the indexes of the databases contained
within the application.

Changing a Password
You can change your password only if you are connected to a server.

Note: Remember, tasks that you should not perform as part of the tutorial are
shown in gray boxes.

To change your password:

1. In the Essbase System Login dialog box, select the Change Password button.

2. In the Change Password dialog box in the New Passwordtext box, type your new password.

3. In the Confirm Password text box, type the password again.

4. The passwords must be identical.

5. Click OK to change your password.

6. Click OK again to close the Essbase System Login dialog box.

Retrieving Data from a Database
Each time you retrieve information from a Hyperion Essbase server, the
following actions occur:
v Hyperion Essbase Spreadsheet Add-in requests data from the server.
v The server processes the request and prepares the data.

Figure 14. Available Application and Database Pairs
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v The server transmits the data to Hyperion Essbase Spreadsheet Add-in.
v Lotus 1-2-3 receives the data from Hyperion Essbase and organizes it in a

worksheet.

To help you monitor these operations, Hyperion Essbase uses three custom
cursors.

Table 1. Hyperion Essbase Custom Cursor

This cursor: Is displayed when:

Hyperion Essbase requests information from the server.

The server is processing the request.

The server returns the data.

Note: Small retrieval actions display the cursors very quickly; you may not
notice changes in the direction of the arrow when retrieving small
amounts of data.

To retrieve data into an empty worksheet:
1. Open a new worksheet by selecting File > New or by clicking the

button.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on
page 22.

2. Select Essbase > Retrieve.
Hyperion Essbase retrieves data into the Lotus 1-2-3 worksheet.

Figure 15. Initial Data Retrieval from Sample Basic
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Because you clicked the Enable Double-Clicking box in the Essbase
Options dialog box (Global Tab), you can double-click in an empty cell to
retrieve data. You can also click the Retrieve button on the Hyperion
Essbase toolbar.

When you retrieve data into an empty worksheet, Hyperion Essbase returns
data from the top levels of each database dimension. The top level is used as
a starting point to navigate, or drill down, into levels of detailed data. In the
Sample Basic database, the following five dimensions are retrieved: Measures,
Product, Market, Scenario, and Year.

For the remainder of tasks in this tutorial, you can retrieve data by
double-clicking in a data cell, selecting Essbase > Retrieve, or by clicking the
Retrieve button on the Hyperion Essbase toolbar.

Canceling a Data Retrieval Request
Occasionally, you may want to cancel a retrieval request. For instance, you
may want to stop a request if a retrieval is taking longer than expected or if
you mistakenly double-click.

Because Hyperion Essbase returns data so quickly to the worksheet, you may
not be able to cancel a retrieval before the retrieval is complete. The cancel
feature is most useful when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.

Note: You can cancel a retrieval only while Hyperion Essbase is processing in
Hyperion Essbase Spreadsheet Add-in. You cannot cancel a retrieval
when Hyperion Essbase is processing from the server.

Restoring the Previous Database View
The FlashBack command restores the previous database view. A database view
is simply what you see in the worksheet after a retrieval or navigation
operation. FlashBack is similar to the Lotus 1-2-3 Edit > Undocommand,
which reverses the last action. The FlashBack command uses the memory of
your machine to store the current view before processing a Hyperion Essbase
retrieval request. You can use FlashBack to undo only the most recent
operation. FlashBack cannot undo multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are
presented. If you make a mistake or find yourself out of step with the tutorial,
you can use the FlashBack command from the Essbase menu or toolbar to
undo the last command and return to the previous database view. If you want
to start the tutorial over from the beginning, select the entire worksheet and
select Edit > Clear > All. Then press Enter or click OK to empty the worksheet
and start again.
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You can disable FlashBack during normal operations to conserve memory on
your local machine. Do not disable FlashBack for this tutorial.

To disable Flashback:

1. Select Essbase > Options and click the Global tab.

2. Clear the Enable FlashBack check box.

Drilling Down to More Detail
With Hyperion Essbase, you can drill down to various levels of
multidimensional data in the worksheet. For example, if you want to view
data for a specific quarter or month rather than an aggregate data value for
the whole year, you can drill down on the Year dimension to see more
detailed data.

You have three options for drilling down on a member:
v Select the member and select Essbase > Zoom In.
v Select the member and double-click the primary mouse button.
v Select the member and click the Zoom In button on the Hyperion Essbase

toolbar.

To drill down to lower levels of the Year dimension:
1. On Year in cell A2, double-click the primary mouse button.

The drill-down action retrieves data for the level below (the children of)
Year: Qtr1, Qtr2, Qtr3, and Qtr4.

Note: For a discussion of the relationships among Hyperion Essbase
database members, see “Database Outlines” on page 7 on page 29.

With Hyperion Essbase, you can retrieve members into grouped, or nested,
columns or rows. Row groups containing more than one level of data are
nested within single-member row groups. For example, a row group
containing Qtr1, Qtr2, Qtr3, and Qtr4 may be nested within a
single-member row for a specific region, such as East (see the following
illustration). Drilling down to lower levels of database members is one
way to retrieve data into nested groups.

Figure 16. Result of Drilling Down on the Year Dimension
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2. In cell D1, double-click to drill down on Market and create nested groups
of rows down the worksheet.

Because worksheets can accommodate more rows than columns, Hyperion
Essbase is preset to retrieve data into rows when you drill down on a
member. You can change this default behavior and display the results of a
drill-down across columns. Drilling across columns applies only to the
top-level member of a dimension (for example, Market or Scenario).

Follow these steps to drill down on Scenario and retrieve its respective
members into columns rather than rows:
1. Press and hold the Alt key.
2. Double-click Scenario (in cell E1).
3. Release the Alt key.

Hyperion Essbase displays the data in columns across the worksheet.

Drilling Down on Attribute Members
You can use the Hyperion Essbase attribute feature to retrieve and analyze in
terms of characteristics, or attributes, of dimensions. For example, you can
analyze product profitability based on size or packaging. Attribute dimensions
are associated with base dimensions.

Figure 17. Result of Drilling Down on the Market Dimension (Nested Rows)

Figure 18. Result of Drilling-Down on the Scenario Dimension (Nested Columns)
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You can use an attribute dimension to drill down on the base dimension with
which it is associated. In the Sample Basic database, the Product base
dimension is associated with several attribute dimensions, such as
Caffeinated, Ounces, and Pkg_Type. Each attribute dimension consists of level
0 attribute members. Level 0 attribute members are the lowest level attributes
that are associated with members of a base dimension. The Pkg_Type attribute
dimension, for instance, has two level 0 members, Bottle and Can.

You can extract information on all products sold in a can by entering
manually the name Can in the worksheet. You can also use Hyperion Essbase
Query Designer or the Essbase Member Selection dialog box to select the
attribute and display it in the worksheet.

Open a worksheet, connect to the Sample Basic database, and select Essbase >
Retrieve. Select Product and replace it with Can by typing Can manually.
Click anywhere outside of cell C1 and select Essbase > Retrieve again. The
result is displayed below:

Drill down to all products sold in a can by double-clicking Can in cell C1.
Cola, Diet Cola, and Diet Cream are the members of Product that have the
Can attribute. The result is displayed below:

Drilling Down on Level 0 Attribute Members: The following is a
description of the general behavior of Hyperion Essbase Spreadsheet Add-in
when you drill down on a level 0 attribute member:
v If the level 0 attribute member is in a column, a drill-down pivots the

attribute to the innermost row of the worksheet.
v If the level 0 attribute member is in a row, a drill-down does not change the

position of the attribute in the worksheet.
v A drill-down on a level 0 attribute member displays the associated base

members to the right of the level 0 attribute.
v If there is more than one level 0 attribute member in a worksheet, a

drill-down on one attribute displays other attributes to the left of the level 0

Figure 19. An Attribute Member in a Report

Figure 20. Result of Drilling Down on an Attribute Member
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attribute member. Level 0 attribute members in columns pivot to rows, and
level 0 attribute members already in rows remain in rows.

v A drill-down on non-level 0 attribute members is the same as the current
drill- down behavior for other types of members.

The drill-down behavior for non-level 0 attribute members is the same as the
current drill-down behavior for other types of members. See the Hyperion
Essbase Spreadsheet Add-in online help for examples of drilling down on
level 0 attribute members. For more information on attributes, refer to the
Hyperion Essbase Database Administrator’s Guide, Volume 1.

Drilling Up to Less Detail
With Hyperion Essbase, you can drill up to higher levels in the
multidimensional database outline by collapsing the current member tree. For
example, if you previously drilled down on a dimension, such as Scenario, to
view data for Actual and Budget, you may need to drill up to view aggregate
data for the Scenario dimension.

You have three options for drilling up on a member:
v Select the member and select Essbase > Zoom Out.
v Select the member and double-click the secondary mouse button.
v Select the member and click the Zoom Out button on the Hyperion Essbase

toolbar.

To drill up on the Scenario dimension in the current worksheet:
1. On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or

G2), double-click the secondary mouse button.
Hyperion Essbase collapses the members of the Scenario dimension.

2. In cell A3, double-click the secondary mouse button to drill up on East.
Hyperion Essbase collapses East, West, South, and Central into the single
Market dimension and keeps the dimension in the A column.

Figure 21. Result of Drilling Up On the Scenario Dimension
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Customizing Drill-Down and Drill-Up Behavior
You can customize the behavior of the Zoom In and Zoom Out commands in
the Hyperion Essbase Options dialog box. The following steps illustrate some
drill-down and drill-up techniques.

To retrieve all members of a dimension with a single drill-down operation:
1. Select Essbase > Options and select the Zoom tab.

Hyperion Essbase displays the Zoom Tab.

The Zoom In option group contains items that enable you to customize
drilling behavior. You can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select
Bottom Level, Hyperion Essbase retrieves data for the lowest level of
members in a dimension. With this option, a drill-down on Year retrieves
Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retains the selected member along with the other members
retrieved as a result of a drill down. For example, if you drill down on
Qtr1, Hyperion Essbase retrieves data for Jan, Feb, and Mar, as well as for
Qtr1. When this option is disabled, Hyperion Essbase retrieves data only
for Jan, Feb, and Mar; Qtr1 is eliminated.

Figure 22. Result of Drilling Up On East

Figure 23. Zoom In and Member Retention Option Settings
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Note: For more information on the Zoom In and Member Retention
option groups, see the Hyperion Essbase Spreadsheet Add-in online
help.

2. In the Zoom In option group, select the All Levels option and click OK to
save the setting.

3. In cell A3, drill down (double-click) on Market.
4. In cell C2, drill down (double-click) on Scenario.

Hyperion Essbase retrieves all members of Market and Scenario. For the
Market dimension, Hyperion Essbase drilled down two levels to get to the
bottom-most members, which are individual states. The Scenario
dimension has only one member level, so the members of Scenario would
also be retrieved if you selected Next Level in the Zoom In option group.

5. Select Essbase > Options and select the Zoom tab.
6. Return the Zoom In option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected
Group in the Member Retention option group.

To drill up only on Qtr1:
1. In the Member Retention option group on the Zoom Tab, click the Within

Selected Group check box and click OK.
Make sure that Include Selection is also still checked.

2. To drill up on Qtr 1 (in cell B3), double-click the secondary mouse button.
Notice that drilling up to the Year dimension affects only New York. All
other states show data for all four quarters.

Figure 24. Result of Drilling Down to All Member Levels
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3. Before moving on with the tutorial, disable the Within Selected Group
option:
a. Select Essbase > Options and select the Zoom tab.
b. In the Member Retention option group, clear the Within Selected

Group check box.
4. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Pivoting, Retaining, and Suppressing Data

After you retrieve data into the worksheet, you may want to manipulate the
data in various ways. For example, you may want to move rows and columns
to different positions in the worksheet, or you may want to tell Hyperion
Essbase to suppress or retain specific data during data retrievals.

To help you manipulate worksheet data, this section steps you through the
following procedures:
v “Pivoting Rows and Columns”
v “Retaining a Data Subset” on page 37
v “Removing a Data Subset” on page 39
v “Navigating Through the Worksheet Without Retrieving Data” on page 40
v “Suppressing Missing Values, Zero Values, and Underscore Characters” on

page 43

Pivoting Rows and Columns
With the Pivot command, you can change the orientation of worksheet data.
Use the Pivot command to do any of the following:
v Move a row group to a column group
v Move a column group to a row group
v Change the order of row groups
v Change the order of column groups

Figure 25. Result of Drilling Up Within a Selected Group
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You can execute the Pivot command in two ways:
v Select the member cell that you want to pivot, and select Essbase > Pivot.

This method applies only to moving a row group to a column group or a
column group to a row group.

v Click in the center of the member cell that you want to pivot, press and
hold the secondary mouse button, and drag the group to the desired
location. This method applies to swapping row and column groups and to
changing the order within groups.

To pivot Year data from a row group to a column group:
1. To open a new worksheet, select File > New or click the

icon.

Note: You should already be connected to the Sample Basic database. If
you are not connected, follow the steps in “Connecting to a
Database” on page 22.

2. Select Essbase > Retrieve.
3. Drill down (double-click) on Measures and Product (in cells B1 and C1,

respectively).
4. Press and hold the Alt key, and, in cell E1, drill down (double-click) on

Scenario.

5. In cell C3, select Year and select Essbase > Pivot.

Figure 26. View Before Pivoting
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Hyperion Essbase pivots the Year dimension to a column group next to
Market (above the Scenario members).

6. As another example, in cell C2, select Actual.
7. Right click and drag Actual to product 100 in cell A3.

Note: The member label box that is displayed under the cursor during the
pivot operation displays the names of the members that you are
pivoting. The orientation of the member label box, however, does not
determine the orientation of the pivot result. Hyperion Essbase
determines the data orientation by the location of the destination
cell.

Hyperion Essbase pivots the Scenario members (Actual, Budget, Variance,
and Variance%) from a column group to a row group that is displayed to
the left of the Product members.

Figure 27. Result of Pivoting a Row Group to a Column Group

Figure 28. Pivoting a Column Group to a Row Group
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To transpose the order of row groups:
1. In cell A2, select Actual.
2. Right-click and drag Actual to Profit (cell C2).

The pivot changes the order of the row groups.

Figure 29. Result of Pivoting a Column Group to a Row Group

Figure 30. Pivoting the Order of Row Groups
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In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are
members of different row groups, Hyperion Essbase exchanges the
member groups. You must select a destination cell that contains a member
name to exchange row members. You can also exchange column members
by choosing a destination cell in another column that contains a member
name.

Retaining a Data Subset
The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete
individual cells.

To keep only Actual and Budget data in the current worksheet:
1. In cell C2, select Actual and, in cell C3, select Budget.

Figure 31. Result of Pivoting the Order of Row Groups

Figure 32. Selecting Members for the Keep Only Command
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2. Select Essbase > Keep Only.
Hyperion Essbase removes the Variance, Variance%, and Scenario rows
from the worksheet and retains only Actual and Budget data.

Occasionally, the data that you want to remove from the worksheet does
not lie in an adjacent range of cells.

To select and retain nonadjacent cells.
1. Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.
2. Select Qtr2 (in cell E2).
3. Press and hold the Ctrl key and select Qtr4 (in cell G2).

4. Select Essbase > Keep Only.

Figure 33. Result of Retaining a Data Subset (Adjacent Cells)

Figure 34. Selecting Nonadjacent Members for the Keep Only Command
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Hyperion Essbase retains only Qtr2 and Qtr4 data and deletes the other
Year members.

Removing a Data Subset
The Remove Only command is the counterpart to the Keep Only command.
With Remove Only, you can remove selected member rows or columns and
retain all other data in the worksheet view.

To remove a data subset from the current worksheet view:
1. In cell B7, select Ratios.
2. Press and hold Ctrl, and, in cell B9, select Measures.
3. Select Essbase > Remove Only.

Hyperion Essbase removes data for Ratios and Measures but retains data
for Profit and Inventory.

Figure 35. Result of Retaining a Data Subset (Nonadjacent Cells)

Figure 36. Result of Removing a Data Subset

Chapter 2. A Basic Hyperion EssbaseTutorial 39



Navigating Through the Worksheet Without Retrieving Data
With the Navigate Without Data feature, you can perform navigational
operations, such as pivot, zoom in, zoom out, keep only, and remove only,
without retrieving any data into the worksheet.

This feature is especially useful when dealing with dynamic calculation
members, which are usually specified by the application designer. By
activating Navigate Without Data, you are effectively telling Hyperion Essbase
not to dynamically calculate values (that is, calculate the database at retrieval
time) while you are creating the spreadsheet report. Dynamic calculation is
discussed in more detail in “Retrieving Dynamic Calculation Members” on
page 113 on page 169.

To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.

Hyperion Essbase displays a check mark next to the menu item.

Note: You can also enable Navigate Without Data by selecting the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2.
Hyperion Essbase shows the collapsed Year dimension but withholds
retrieving any data that is changed as a result of drilling up. The cells
where data would normally be displayed are blank.

3. In cell D2, drill down (double-click) on Year by pressing and holding the
Alt key.
Hyperion Essbase drills down without retrieving data.

4. In Cell C3, select Actual and select Essbase > Pivot.
Hyperion Essbase executes the pivot but does not retrieve data.

Figure 37. Result of Zooming Out (Navigate Without Data Enabled)
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Note: You get the same result by pivoting any of the other Scenario
members.

5. In cell G1, click the secondary mouse button on Market and drag Market
to product 100 (cell A4).
Hyperion Essbase executes the pivot without retrieving data.

Navigating without data also works with the Keep Only and Remove
Only commands.

To navigate without data when using the Keep Only or Remove Only
command:
1. Select Qtr1 (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Hyperion Essbase retains only the selected members and does not retrieve
data.

Figure 38. Result of Pivoting (Navigate Without Data Enabled)

Figure 39. Result of Pivoting (Navigate Without Data Enabled)
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2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select
Essbase > Remove Only.
Hyperion Essbase executes the Remove Only command without actually
querying the database for information.

To turn off Navigate Without Data when you are ready to retrieve data:
1. Select Essbase > Navigate Without Data.

Hyperion Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell A3, drill down (double-click) on Market.
Hyperion Essbase drills down on the Market dimension and also retrieves
data into the worksheet.

Figure 40. Result of Keep Only (Navigate Without Data Enabled)

Figure 41. Result of Remove Only (Navigate Without Data Enabled)
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Note: If you want to retrieve data without changing the current worksheet
view, you can also retrieve data by simply double-clicking in any
data cell or by selecting Essbase > Retrieve (after disabling Navigate
Without Data).

Suppressing Missing Values, Zero Values, and Underscore Characters
Several types of data can be returned to a worksheet view:
v Numeric data values
v #NoAccess strings, which are displayed when you do not have the proper

security access to view a data value
v #Missing strings, which indicate that no data exists for that member

intersection
v Zero data values

A missing value is not the same as a zero value that is loaded into the
Hyperion Essbase database. When data does not exist for a data cell in
Hyperion Essbase, a value of #Missing is returned to the worksheet. If any
cell in a row contains a value, that row is not suppressed on a retrieval.

With Hyperion Essbase, you can suppress missing and zero values from the
display in the worksheet. In addition, you can tell Hyperion Essbase to
suppress underscore characters that are in some member names.

To suppress rows that contain missing values from displaying in the
worksheet:
1. In cell C3, double-click the secondary mouse button to drill up on Profit.
2. Pivot Measures (in cell C3) to Actual (in cell D1).
3. In cell B4, drill down (double-click) on product 100.

Figure 42. Result of Drilling down (Navigate Without Data Disabled)
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Notice that, in the South, the product 100–30 row contains all missing
values, indicating that this product is not sold in the South. You may need
to scroll down the worksheet to see this row.

4. Select Essbase > Options, and select the Display tab.
5. In the Suppress option group, click the #Missing Rows check box and click

OK.

Note: The Suppress #Missing Rows and Zero Rows options are not
available when any of the Formula Preservation options are selected
in the Essbase Options dialog box. For more information on
Formula Preservation, see “Preserving Formulas When Retrieving
Data” on page 104 on page 158.

6. Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog
box, you must perform a retrieval or drill operation to have the new
setting take effect.

Hyperion Essbase suppresses product 100–30 from the South member
group.

Figure 43. Worksheet View Displaying Missing Data Values
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7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data
retrieval are not retrieved again by simply disabling the feature. If
you disable the feature in the Essbase Options dialog box, missing
values are retrieved from only that point on. For example, in the
tutorial task described above, Hyperion Essbase could not go back
and return the missing values for product 100–30. To return these
missing values to the worksheet, you disable the Suppress #Missing
Rows feature, drill up on a Product member, and then drill down
again.

You can also suppress zeros and underscore characters as described in the
task above by clicking the appropriate options in the Suppress option group
in the Essbase Options dialog box (Display tab).

In addition to suppressing specific values and characters during retrieval,
Hyperion Essbase enables you to define a label for missing values (#Missing)
or for data you do not have access to (#NoAccess). If you define a
replacement label for these values, Hyperion Essbase displays the replacement
labels instead of the default labels. For more information on defining
replacement labels for the #Missing and #NoAccess labels, see the Hyperion
Essbase Spreadsheet Add-in online help.

Figure 44. Result of Suppressing Missing Data Values
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Formatting the Worksheet

Hyperion Essbase provides you with various ways to customize the
worksheet view. For example, you may want to apply visual cues, or styles, to
certain member names or to data cells in the worksheet, or you may want to
display alternative names, or aliases, for member names. This section steps
you through the following formatting procedures:
v “Formatting Text and Cells”
v “Displaying Aliases for Member Names” on page 53
v “Displaying Both Member Names and Aliases” on page 55
v “Repeating Member Labels” on page 55

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells
In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the
text and cells in the worksheet, you can easily keep track of specific database
members, dimensions, and cell functions. Styles are a great way to help view
and distinguish data in Hyperion Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during
a retrieval request. For more information, see “Removing Styles” on
page 52.

This section of the tutorial describes the following:
v “Applying Styles to Parent Members”
v “Applying Styles to Dimension Members” on page 49
v “Applying Styles to Data Cells” on page 51
v “Determining the Precedence of Overlapping Styles” on page 51
v “Removing Styles” on page 52

Note: For a discussion of the relationships among Hyperion Essbase database
members, see “Database Outlines” on page 7 on page 29.

Applying Styles to Parent Members
Each dimension in a database may contain a large number of hierarchical
levels. As you view data in the worksheet, you may not be familiar with all
the hierarchical levels of the database outline. To indicate which members
have underlying children, you can apply formatting styles to parent members,
including those with attributes.

To apply styles to parent members:
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1. To open a new worksheet, select File > New or click the

icon.
2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you
are not connected, follow the steps in “Connecting to a Database”
on page 22.

3. In cell A2, drill down (double-click) on Year.
4. Select Essbase > Options.
5. In the Essbase Options dialog box, select the Style tab.

Note: The Style tab is available only when you are connected to a
database.

Hyperion Essbase displays the Styletab.

In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. In the Members group box, click the Parent check box.

Figure 45. Essbase Options Dialog Box, Style Tab
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Clicking this box defines a font and color style for parent member names.
Hyperion Essbase defines a default color of navy for all parent members.
You can select a font format by clicking the Format button to the right of
the Members box and using the Font dialog box.

7. Click the Format button.
Hyperion Essbase displays the Font dialog box.

8. In the Font style list box, select Bold and then click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

9. Click OK again.
Even though you have defined styles, they are not enabled until you click
the Use Styles check box from the Essbase Options dialog box and
refresh the worksheet.

10. Select Essbase > Options, and select the Display tab.
11. In the Cells option group, click the Use Styles check box to enable your

styles, and then click OK.
12. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Hyperion Essbase displays parent member names in bold, navy font.
13. In cell A2, drill down (double-click) on Qtr1.

Hyperion Essbase displays Jan, Feb, and Mar in a regular font, because
these members do not have underlying children.

Figure 46. Font Dialog Box
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Applying Styles to Dimension Members
In addition to applying styles to parent members (as you did in the previous
section), you can also apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Hyperion Essbase Spreadsheet Add-in.

To apply styles to dimensions:
1. Select Essbase > Options and select the Style tab.
2. In the Dimensions group box, select Year.
3. Select the Cell Border check box to create a border around each cell that

contains a member from the selected dimension.
4. From the Background Color list box, select Yellow.

Figure 47. Styles Applied to Parent Members

Figure 48. Selecting a Background Color from the Style Tab
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5. Click the Format button that is to the right of the Dimensions list.
Hyperion Essbase displays the Font dialog box.

6. From the Font style list box, select Bold, and then click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

7. From the list of dimensions, select the Measures dimension and, from the
Background Color list box, select Fuschia.

8. From the list of dimensions, select Product, and clear the Cell Border
check box.

9. From the Background Color list box, select Aqua.
10. Scroll down the list of dimensions, and select Market.
11. Select the Cell Border check box, and click the Format button that is to

the right of the Dimensions list.
When the Font dialog box is displayed, from the Font style list box select
Italic, and then click OK.

12. From the list of dimensions, select Scenario, and from the Background
Color list box, select Red.

13. Click the Format button, and from the Color list box, select White.
14. Click OK twice to return to the worksheet.

Note: When you define styles, your choices are saved to the essbase.ini
file on your local machine. You can define one set of styles per
database.

15. In cell D1, drill down (double-click) on Market.
16. Press and hold the Alt key and drill down (double-click) on Scenario (in

cell E1).
17. Select Essbase > Retrieve to refresh the worksheet.

Hyperion Essbase redisplays the worksheet and implements the newly
defined styles. For example, members of the Scenario dimension are
displayed with a red background.
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Applying Styles to Data Cells
You can apply styles to data cells, such as read-only cells, read/write cells,
linked object cells, and Hyperion Integration Server Drill-Through cells to
distinguish them from other cells in the worksheet. The Sample Basic database
that you are using for this tutorial does not contain data cells with any of
these characteristics. In the advanced tutorial presented in Chapter 3, you
attach a linked reporting object to a data cell and apply a style to the cell.

Note: You cannot perform the actions in shaded boxes.

In general, you apply styles to data cells by following these steps:

1. Select Essbase > Options, and select the Style tab.

2. In the Data Cells option group, click the Linked Objects, Integration Server Drill-Through, Read
Only, or Read/Write check box.

3. Click Format.

4. In the Font dialog box, specify the font, font size, font style, color, and effects, and click OK.
Note: Hyperion Essbase displays an example of the selected style in the Sample box.

5. Repeat steps 2–4 to set styles for other data cells.

6. Select the Display tab and select the Use Styles check box to apply styles to the worksheet.

7. Click OK to close the Essbase Options dialog box.

8. Select Essbase > Retrieve to display the new styles in the worksheet.

Determining the Precedence of Overlapping Styles
The only way you can apply a background color to data is to define a style
for dimensions. If dimension styles are defined, and the Use Styles setting is
turned on, members of a dimension always have the background color
defined for their dimension.

Figure 49. Dimensions with Styles Applied
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The text styles that you can apply to members, dimensions, and data cells
have a hierarchy that determines which characteristics are applied. Member
styles are at the top of that hierarchy. Thus, member styles are always applied
(as long as styles are turned on). Note that in Figure 47 on page 49, the Qtr1
label in cell B6 is in bold, navy font, and has a yellow background. The navy
font comes from the style defined for parent members, and the yellow
background comes from the style defined for Year.

Hyperion Essbase uses the following order of precedence when applying
multiple text styles:
v Linked object cells
v Integration Server Drill-Through cells
v Read-only cells
v Read/write cells
v Parent member cells
v Child member cells
v Shared member cells
v Cells containing formulas
v Dynamic calculation member cells
v Attribute cells
v Dimension cells

If you want to see a child member style, make sure that the parent member
style is turned off. If you want to see a shared member style, make sure that
both parent and child member styles are turned off.

Removing Styles
Styles can be very helpful tools for keeping track of data in Hyperion Essbase
Spreadsheet Add-in. Applying styles, however, involves additional processing
time during a retrieval request. This additional processing has a slight impact
on the speed of Hyperion Essbase retrievals.

If you do not want to apply styles to the worksheet view, you can clear them.
You can also turn off styles so they are not displayed when you refresh the
view (by selecting Essbase > Retrieve, for example). So that the worksheet
matches the illustrations presented in the following tasks, do not remove styles
if you are stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the
FlashBack command, these styles are temporarily removed from the
current view. The styles are re-applied whenever you initiate a retrieval.
You cannot perform the actions in shaded boxes.
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To remove all styles from a worksheet:

1. Select all cells in the worksheet.

2. From the Lotus 1-2-3 menu bar, select Edit > Clear > Styles.

To disable styles:

1. Select Essbase > Options and, select the Display tab.

2. In the Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the
styles remain in the current worksheet view when you refresh the view.
The styles remain to avoid removing any styles that you may apply to
individual cells using native worksheet formatting options.

Displaying Aliases for Member Names
Aliases are alternate names for database members. You can create reports that
use the database member name, which is often a stock number or a product
code, or an alias name, which can be more descriptive. Aliases are defined by
the Hyperion Essbase application designer. Each database can contain one or
more alias tables.

For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product,
such as Colas and Root Beer, is defined in an alias table. In some cases, alias
names may vary depending on the combination of other database members.
For example, a Product member may have a different alias for each market in
which it is sold. For more information, see the Hyperion Essbase Spreadsheet
Add-in online help or the Hyperion Essbase Database Administrator’s Guide.

To display the alias of a member rather than its database name:
1. In cell C2, double-click the secondary mouse button to drill up on Actual.
2. Press and hold the Alt key and drill down (double-click) on Product (in

cell D1).
3. Select Essbase > Options, and select the Display tab.
4. In the Aliases option group, click the Use Aliases check box to display

member aliases.
5. Select Default from the Alias list box.
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6. Click OK.
7. Select Essbase > Retrieve to refresh the worksheet and display the alias

names.
Hyperion Essbase changes the Product codes (100, 200, and so forth) to
their predefined aliases (Colas, Root Beer, Cream Soda, and so forth). In
the Sample Basic database, Product is the only dimension with predefined
aliases.

Notice that Hyperion Essbase is still displaying the styles that you created
and applied in the previous sections.

Figure 50. Enabling Aliases in the Essbase Options Display Tab

Figure 51. Result of Displaying Aliases
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Displaying Both Member Names and Aliases
In addition to displaying aliases for database members, you can also tell
Hyperion Essbase to display both aliases and database member names in
Hyperion Essbase Spreadsheet Add-in.

To display the name and alias of a member:
1. In cell B8, double-click the secondary mouse button to drill up on Qtr2.
2. In cell C2, click Colas, and then select Essbase > Pivot.
3. In cell C3. click Year, and then select Essbase > Pivot.
4. Select Essbase > Options, and select the Display tab.
5. In the Aliases option group, select the check box for Use Both Member

Names and Aliases for Row Dimensions.
Be sure that Use Aliases is already checked.

6. Click OK to return to the worksheet, and select Essbase > Retrieve.
Hyperion Essbase displays both member names and their aliases for row
dimensions. Because the only row dimension in this example that has
preassigned aliases is Product, only the Product members display their
aliases. Region members simply repeat the member name instead of
displaying an alias.

Repeating Member Labels
By default, Hyperion Essbase displays member labels only once for each
nested row and column group. If you are connected to a large database when
using Hyperion Essbase Spreadsheet Add-in, you may have to scroll down or
across the worksheet to see additional data rows and columns. In some cases,
as you scroll down or across, member labels may disappear from view.
Hyperion Essbase provides a feature for repeating member labels in each row
or column cell that represents a data point so that you can always see a
member label in the worksheet view.

Figure 52. Result of Displaying Both Member Names and Aliases
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To repeat member labels down and across the worksheet:
1. Select Essbase > Options, and select the Display tab.
2. In the Aliases option group, clear the Use Both Member Names and

Aliases for Row Dimensions check box.
3. In the Cells option group, select the Repeat Member Labels check box,

and then click OK.

4. In cell E1, drill down (double-click) on Year.
Hyperion Essbase displays a member label in every column and row cell.
For the Sample Basic database that you are using for this tutorial,
repeating member labels is probably not necessary because the database is
relatively small. This feature is particularly helpful for keeping track of
member labels when scrolling through large worksheets.

Figure 53. Enabling the Repeat Member Labels Option
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Note: Even if you clear the Repeat Member Labels check box in the
Essbase Options dialog box, Hyperion Essbase retains the repeated
member labels in the worksheet view. To remove the repeated
labels, you need to do one of the following: (1) clear the check box
and open a new worksheet; (2) clear the check box and pivot the
row group to a column group and then pivot it back to a row group
(or vice versa); or (3) select Essbase > FlashBack and clear the check
box.

5. Before returning to the tutorial, complete the following actions:
a. Select Essbase > Options, and select the Display tab.
b. In the Cells option group, clear the Repeat Member Labels check box,

and then click OK.
c. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Creating Queries Using Hyperion Essbase Query Designer

So far, you have seen how easy it is to retrieve data and navigate through
Hyperion Essbase Spreadsheet Add-in in an ad hoc fashion. Hyperion Essbase
also provides a query designer so that you can define a database query for
retrieving dimensions and database members into the worksheet. Hyperion
Essbase Query Designer (EQD) is a new feature that replaces Retrieval
Wizard, used to define queries in previous versions of Hyperion Essbase
Spreadsheet Add-in.

Before Hyperion Essbase actually retrieves data, Hyperion Essbase Query
Designer provides a series of panels so you can request the data that you
want to view in the worksheet. It is particularly helpful when you know
exactly which data you want to retrieve from the server. In addition, you can
save a query and use it again.

Figure 54. Result of Repeating Member Labels
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The Hyperion Essbase Query Designer window consists of the following
panels:
v The navigation panel provides access to the various features in Hyperion

Essbase Query Designer. You can display all the dimensions used in a
particular query and access the various properties of each dimension
member.

v The hint panel provides a brief description of the feature that is selected
from the navigation panel.

v The properties panel provides access to the following functions:
– Layout: Design the layout of the spreadsheet report. To change the

default layout, select a dimension tile and drag it to one of the other
dimension boxes. To access the member select panel and to define a
member for a query, double-click a dimension tile.

– Member Select: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click a member to add
it to the selection rules.

– Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

– Data Filter: Retrieve rows of data. The retrieval is based on the ranking of
the rows within certain columns. Use this panel to access the data
restriction panel.

– Data Restriction: Filter data by comparing it to a fixed data value, a set of
data values, or #Missing data values.

– Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

– Messages and Confirmation: Turn on and turn off certain messages from
Hyperion Essbase Query Designer.

– Help: Access documentation about Hyperion Essbase Query Designer.

Creating and Changing Queries
To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an
open query, click on the specific dimension or member in the query outline
that is displayed in the navigation panel. Selected members are displayed in
the member selection panel on the right.
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You can also revise an existing query in the member selection panel. For
example, you can delete a member or add a member to the query by selecting
a member in the navigation panel and making the appropriate changes in the
properties panel.

Note: Files created in Retrieval Wizard can be opened in Hyperion Essbase
Query Designer. However, if a query contains more than two member
filters per selection rule or more than two data restrictions, the member
filters may be out of order. To ensure correct results, rearrange the
member filters in the navigation panel, if necessary. For complete
information on Hyperion Essbase Query Designer options, see the
Hyperion Essbase Spreadsheet Add-in online help.

CAUTION:
Manipulation of worksheets in VBA such as naming worksheets or moving
worksheets may not work when EQD is running.

Creating Queries
To create a query using Hyperion Essbase Query Designer:
1. Select Essbase > Query Designer.

Hyperion Essbase displays the Hyperion Essbase Query Designer
welcome panel.

2. To create a new query, select <<c:\lotus\Work\123\Untitled.123>>A,
right-click, and select New > Query.

Figure 55. Hyperion Essbase Query Designer Displaying Welcome Panel
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Hyperion Essbase displays the layout panel of Hyperion Essbase Query
Designer.

3. Define the worksheet layout by dragging the dimension tiles as follows:
a. Drag Market and Product to the Row location.
b. Drag Measures to the Page location.
c. Drag Scenario below Year (in the Column location).

Figure 56. Hyperion Essbase Query Designer Displaying Layout Panel
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4. To select the Measures dimension in the navigation panel, click the
Measures icon. Alternatively, double-click the Measures tile in the layout
panel.
Hyperion Essbase displays the member select panel, where you can select
a member from the Measures dimension.

Note: You can select only one member from the dimension in the Page
location.

5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.
Profit is displayed in the selection rules list.

Figure 57. Changing the Worksheet Layout
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Note: In Hyperion Essbase Query Designer, after you make your
selections, you do not need to confirm them; for example, you do
not have to click OK. If you do not select members from any given
dimension, Hyperion Essbase uses the top member of the
dimension.

6. To select members of the Year dimension, complete the following actions:
a. In the navigation panel, click the Year icon. Alternatively, double-click

the Year tile in the layout panel.
Hyperion Essbase displays the member select panel for the Year
dimension.

b. Select Qtr1, right-click, and select Add to Selection Rules.
c. Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.

Because Year is in a Column location, you can select one or more
members.

Figure 58. Hyperion Essbase Query Designer Displaying the Member Select Panel
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7. To select members of the Scenario dimension, complete the following
actions:
a. In the navigation panel, click Scenario. Alternatively, double-click the

Scenario tile in the layout panel.
The members of the Scenario dimension are displayed in the member
select panel.

b. Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.

c. In the same manner, add Budget to the Selection Rules box.
8. To select members of the Product dimension, complete the following

actions:
a. In the navigation panel, click Product. Alternatively, double-click the

Product tile in the layout panel.
The members of the Product dimension are displayed in the member
select panel.

b. Select product code 100, right-click, and select Add to Selection Rules.
c. Repeat the process for product codes 200, 300, and 400.
d. In the Selection Rules list box, select product code 100, right-click, and

then, from the popup menu, choose Select > Children.
This action selects all children of 100. Hyperion Essbase displays All
Children next to 100 in the Selection Rules list box.

e. In the Selection Rules list box, select product code 400, right-click, and
choose Select > Descendants.

Figure 59. Adding Members to the Selection Rules
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Hyperion Essbase displays All Descendants next to 400 in the Selection
Rules list box.

f. To view the list of all product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box (for
example, 200), right-click, and select Preview.
Hyperion Essbase displays the Member Selection Preview dialog box.

Figure 60. Selecting Members of Product
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g. Click Close to close the Member Selection Preview dialog box.
9. To select members of the Market dimension, complete the following

actions:
a. In the navigation panel, click Market. Alternatively, double-click the

Market tile in the layout panel.
The members of the Market dimension are displayed in the member
select panel.

b. In the Member list box, select East, right-click, and select View by >
Generation.

c. To pick the second generation of the Market dimension, in the Member
list box, select Region, right-click, and select Add to Selection Rules.
Alternatively, double-click Region to add it to the selection rules.
Region is displayed in the Selection Rules list box.

d. To view the list of members that will be retrieved into the worksheet,
in the Selection Rules list box, select Region, right-click, and select
Preview.
Hyperion Essbase displays East, West, South, and Central in the
Member Selection Preview dialog box.

Figure 61. Selected Members of Product Dimension
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e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic Hyperion Essbase query. The outline of the
query is displayed in the navigation panel.

10. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>>A -
Query1, and then right-click and select Save Query.
Hyperion Essbase displays the Hyperion Essbase Query Designer Save
As Query dialog box. You can save your query to the server or to your
own client machine. To save to the server, you must have a security level
of database designer or higher. Contact the Hyperion Essbase system
administrator for more information.

11. Select Client.

Figure 62. Generation Name Selection

Figure 63. Hyperion Essbase Query Designer Save As Query Dialog Box
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12. Click the File System button.
Hyperion Essbase displays the Save As dialog box.

13. Select a location, in the File nametext box, type Basic1 and then click
Save.
You will use the Basic1 query again in Chapter 3.

14. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>> A -
Basic1, then right-click, and select Apply Query.
The result of the query is displayed in the worksheet.

Figure 64. Save As Dialog Box

Figure 65. Hyperion Essbase Query Designer Displaying Query Information Panel
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Note: In the Display tab under Essbase > Options, if you select UseUse Styles
and Use Sheet Options with Query Designer, the styles you selected
for dimension members will be applied to the initial query results. If
you do not select Use Sheet Options with Query Designer, even if you
have selected Use Styles, they will not be applied to the initial query
results. To apply styles, select Essbase > Retrieve. When Hyperion
Essbase returns the data to the worksheet, you are free to further
investigate the data by performing Zoom, Keep Only, Remove Only,
and Pivot operations.

Deleting Queries
You can delete a query only from the location where you saved that query.
For example, if you save a query in the /essbase/client/sample directory,
you can delete the query from within the sample directory. You cannot delete
the query from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations
Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations
panel.

To turn on or turn off messages and confirmations:
1. Select the Messages and Confirmations icon in the navigation panel.
2. To turn on (enable) a message, select the check box that is displayed next

to that message.
3. To turn off (disable) a message, select the check box again (clear the check

box).

Figure 66. Results of a Hyperion Essbase Query Designer Query
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Accessing Help
Access online help or the tutorial for Hyperion Essbase Query Designer by
using the help panel. To access the help panel, in the navigation panel, select
Help. For more information on a particular topic, click the Online Help button
in the properties panel. To access the online tutorial, click the Tutorial button
in the properties panel.

Figure 67. Messages and Confirmations Panel
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Connecting to Multiple Databases from Hyperion Essbase Query Designer
You can connect to several databases and create separate queries on each
database from Hyperion Essbase Query Designer.

To connect to multiple databases from Hyperion Essbase Query Designer:
1. Logon to Hyperion Essbase and connect to the server you want to access.
2. Select Essbase > Query Designer to open Hyperion Essbase Query

Designer.
3. Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select

Connect.
Hyperion Essbase displays the Essbase System Login dialog box.

4. Type your password, and click OK. Select Sample Basic, and click OK.
5. Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select New

> Worksheet.
6. Select the new worksheet, <<c:\lotus\Work\123\Untitled.123>>B, right

click, and select Connect.
Hyperion Essbase displays the Essbase System Login dialog box.

7. Type your password, and click OK. Select Samppart Company, and click
OK.

Figure 68. Hyperion Essbase Query Designer Help Panel
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Note: You are restricted to one connection per worksheet. The connection
information is displayed in the query information panel of the
Hyperion Essbase Query Designer only when you open an existing
query or create a new query.

8. To create a new query based on Sample Basic, select
<<c:\lotus\Work\123\Untitled.123>>A, right click, and select New >
Query.

9. To create a new query based on Samppart Company, select
<<c:\lotus\Work\123\Untitled.123>>B, right-click, and select New >
Query.

10. To open an existing query, right click, and select Open Query.

You are now ready to proceed with the process of creating queries or opening
existing queries.

Applying Worksheet Options to Hyperion Essbase Query Designer
Results

You can also apply any of the worksheet options you have previously set
from the Essbase Options dialog box to the results of a query created in
Hyperion Essbase Query Designer.

To enable Hyperion Essbase Query Designer to use your previously set
worksheet options:
1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the Use Sheet Options with Query Designer check box, and select

OK.
4. Select Essbase > Retrieve to refresh the worksheet.

Hyperion Essbase displays the results of the query you created in
Hyperion Essbase Query Designer and implements your previously set
worksheet options. For example, note that aliases, instead of the numeric
codes, are now displayed for the Product dimension.
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5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Selecting Members

A Hyperion Essbase database may contain hundreds or even thousands of
members, making it difficult to remember each member name. You can use
the Essbase Member Selection dialog box to find and select members and to
define the layout of members in the worksheet. In addition, you can use
Boolean operators, such as AND, OR, and NOT, or other search parameters to
specify criteria and conditions that members must meet for the member
selection. Member selection is an important method of creating a spreadsheet
report for the data you want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box,
see the Hyperion Essbase Spreadsheet Add-in online help.

To view specific members from the Product dimension:
1. To open a new worksheet, select File > New or click the

icon.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on
page 22.

2. Select Essbase > Retrieve.

Figure 69. Results of Query with Options Applied

72 OLAP Spreadsheet Add-in User’s Guide for 1-2-3



3. Select Product and select Essbase > Pivot to display Product as a row,
rather than a column, dimension.

4. Select Product again, and select Essbase > Member Selection.
Hyperion Essbase displays the Essbase Member Selection dialog box. In
the Essbase Member Selection dialog box, Hyperion Essbase displays
the Product dimension in the Dimension list box and its children, Colas,
Root Beer, Cream Soda, Fruit Soda, and Diet Drinks, in the Members list
box.

5. Select Colas and click the Member Information button.
Hyperion Essbase displays the Member Information dialog box. The
dialog box provides information about the selected member, such as
dimension, generation, level, storage setting, formula, UDAs, and
member comments.

Figure 70. Initial Worksheet for Member Selection

Figure 71. Essbase Member Selection Dialog Box
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6. To close the Member Information dialog box, click OK.
7. In the Essbase Member Selection dialog box, click Add to add Colas to

the Rules list box.

Note: Alternatively, you can double-click an item in the Members list
box to add the item.

8. Select Cream Soda, and click the Find button.
Hyperion Essbase displays the Find Member dialog box.
In the Find Member dialog box, you can do pattern-match searches for
members in the selected dimension. You can use Wildcard
patterns—(trailing asterisk, *) and (single-character match, ?). Hyperion
Essbase locates the members that match the text string (in alphabetical
order) and keeps them selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character
wildcard in the text string. The * wildcard replaces a string of
characters, whereas the ? wildcard replaces a single character. J?n
and 100* are examples of valid wildcard strings; *-10 and J*n are
examples of invalid wildcard strings.

9. In the Find Member dialog box, type D* in the text box.

Figure 72. Member Information Dialog Box
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10. Click Find to locate all members that match D*.
Hyperion Essbase locates and selects Diet Cream. Its parent, Cream Soda,
is also selected because it was highlighted before the search.

11. To close the Find Member dialog box, click Close.
12. Clear Cream Soda, leaving only Diet Cream selected, and click Add.

Hyperion Essbase displays Colas and the new selection, Diet Cream, in
the Rules list box.

13. In the Essbase Member Selection dialog box, select Colas in the Rules
list box, and then right-click. From the pop-up menu, select All Children
and Member.
Hyperion Essbase displays All Children and Member next to Colas in the
Selection Rules list box.

14. In the Selection Rules list box, select Colas, All Children and Member,
and then right-click again.

15. From the pop-up menu, select Subset.
Hyperion Essbase displays the Subset Dialog box, where you can further
define conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog
box.

16. In the Subset Dialog box, in the first list box, select Caffeinated. In the
second list box, select Is. In the third list box select Caffeinated_True.

17. Click the Add as AND Condition button.
Hyperion Essbase displays Caffeinated = Caffeinated_True in the
Conditions list box.
When you use Add as AND Condition, the subsetting condition in the
Conditions list box is evaluated using AND logic. AND logic means that
the selection must meet the current condition and the following condition
in the Conditions list box.

Figure 73. Find Member Dialog Box
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18. In the first list box, select Ounces. In the second list box, select the logical
operator “=”. In the third list box, select Ounces_12.

19. Click the Add as AND Condition button.
Hyperion Essbase displays Ounces = Ounces_12 in the Conditions box.

20. In the first list box, select Ounces. In the second list box, select the logical
operator “<=”. In the third list box, select Ounces_32.

21. Click the Add as OR Condition button.
Hyperion Essbase displays Ounces <= Ounces_32 in the Conditions box.
When you use the Add as OR Condition, the subsetting condition in the
Conditions list box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in
the Conditions list box.

22. In the first list box, select Pkg Type. In the second list box, select Is. In
the third list box, select Bottle.

23. Click the Add as AND Condition button.
Hyperion Essbase displays Pkg Type = Bottle in the Conditions list box.

24. In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

25. Select Pkg Type = Bottle, and click the Add ) button.
The Add ( and Add ) buttons add a left parenthesis and right
parenthesis, respectively, to selected items. Use parentheses for grouping
multiple subsetting conditions to determine the order of priority for
analyzing the conditions. Each item in the Conditions list box can have
either the left or right parenthesis, but not both. In this example,
Hyperion Essbase first evaluates members that are equal to or less than
32 ounces and are packaged in a bottle. Hyperion Essbase then evaluates
the results from this condition against members that are 12 ounces.

Figure 74. Subset Dialog Box (Before Adding Conditions)
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Note: Use the Remove ( ) button to remove an individual group of
parentheses from a selected item in the Conditions list box. Use
the Remove All ( )button to remove all parenthetical groupings
from the Conditions list box.

The Subset Dialog box is displayed as follows:

26. To open the Member Preview dialog box, click Preview.
In the Member Preview dialog box, you can view the member selection
that results from the conditions you defined.

27. To close the Member Preview dialog box, click Close.

Figure 75. Subset Dialog Box (After Adding Conditions)

Figure 76. Member Selection That Results from Subsetting Conditions
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28. To close the Subset dialog box and return to the Essbase Member
Selection dialog box, click OK.
The conditions you set in the Subset dialog box are displayed in the
Selection Rules list box.

29. To change the order in which Diet Cream is displayed in the worksheet,
select Diet Cream and click the Move Item Up button.
Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Rules list box. You can move only the top-level
item (the item you added from the Members list box), not the individual
subset conditions.

30. To preview the members that will be retrieved in the worksheet, click
Preview.
Hyperion Essbase displays the Member Preview dialog box.

31. After previewing the list, click Close.

Figure 77. Selecting Members Completed
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32. To close the Essbase Member Selection dialog box and insert the new
members into the worksheet, click OK.

Note: The FlashBack command cannot undo a Member Selection action.
33. Starting with Diet Cream, type Year next to each product.

You need to do this step so that every product has a matching Year
dimension associated with it in the report.

34. To update the values in the worksheet, select Essbase > Retrieve .
Hyperion Essbase retrieves data for the members that you selected and
also applies the styles you previously set.

Figure 78. Members to be Retrieved in Worksheet

Figure 79. Result of Selecting Members

Figure 80. Worksheet After Adding the Year Dimension to All States
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Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can
save worksheets and disconnect from Hyperion Essbase. This section instructs
you in the following procedures:
v “Saving a Worksheet”
v “Disconnecting from Hyperion Essbase”
v “Logging Off” on page 81

Saving a Worksheet
At any point during the Hyperion Essbase session, you can save the active
worksheet with the Lotus 1-2-3 commands, File > Save or File > Save As.
Thus, you can keep a personal library of database views. You can open the
worksheet during a later session and retrieve the latest data values to update
the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog
box unless the worksheet is protected. Hyperion Essbase cannot save
option settings for a protected worksheet.

Disconnecting from Hyperion Essbase
When you finish retrieving and navigating through data, disconnect from the
Hyperion Essbase server to free up a port (or user count) on the server for
other Hyperion Essbase Spreadsheet Add-in users.

To disconnect from the server:
1. Select Essbase > Disconnect.

Hyperion Essbase displays the Essbase Disconnect dialog box, where you
can disconnect any worksheet that is connected to a database.

Figure 81. Result After Retrieving with Member Selection
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2. From the list, select a worksheet name, and then click Disconnect.
3. Repeat step 2 until you have disconnected all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Lotus 1-2-3.
An abnormal termination of a Lotus 1-2-3 session, such as a power loss
or system failure, does not disconnect your server connection.

Logging Off
Hyperion Essbase provides two administrative facilities that control user
connections:
v Forced Logout, where an administrator disconnects users at any point in

time. This logoff usually occurs when maintenance operations are
performed on databases.

v Auto Logout, where Hyperion Essbase automatically disconnects users that
are inactive for a time interval specified by an administrator.

For further information, contact the Hyperion Essbase system administrator.

Moving on to Advanced Tasks

Now that you have completed the basic Hyperion Essbase tutorial, you are
ready to move on to more complex tasks. In the next chapter, you will use the
sample Lotus 1-2-3 files to see how to perform advanced tasks in Hyperion
Essbase Spreadsheet Add-in.

Figure 82. Hyperion Essbase Disconnect Dialog Box
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Chapter 3. An Advanced Hyperion Essbase Tutorial

The tutorial you completed in “Chapter 2. A Basic Hyperion EssbaseTutorial”
on page 11 teaches basic data retrieval and navigation concepts for Hyperion
Essbase Spreadsheet Add-in. This chapter builds on your basic skills and
expands your knowledge of Hyperion Essbase and Hyperion Essbase
Spreadsheet Add-in.

This chapter provides the following sections on advanced tasks:
v “Preparing to Begin the Tutorial”
v “Performing Advanced Retrieval Tasks” on page 89
v “Using Linked Reporting Objects” on page 128
v “Connecting to Multiple Databases” on page 142
v “Accessing Linked Partitions” on page 143
v “Updating Data on the Server” on page 145
v “Calculating a Database” on page 148
v “Creating Multiple Worksheets from Data” on page 149
v “Working with Currency Conversions” on page 153

In this advanced tutorial, you use several sampleMicrosoft ExcelLotus 1-2-3
files that were installed as part of the default Hyperion Essbase installation.
These files are stored in the \essbase\client\sample directory. You also
reconnect to the Sample Basic database.

Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two
sections, “Connecting to a Database” and “Setting Hyperion Essbase Options”
on page 85. In addition, be sure to read “Following Guidelines During the

Tutorial” on page 20 and “Reviewing the Sample Basic Database” on page 21
for important information about what you should expect as you perform the
tutorial steps.

Connecting to a Database
To access Hyperion Essbase data for the advanced tutorial, first connect to the
Sample Basic database on the server. This tutorial assumes that you have the
appropriate privileges to connect to a server, an application, and a database.
1. Select Essbase > Connect.

Hyperion Essbase displays the Essbase System Login dialog box.
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Note: To complete the steps that follow, you need to know the name of
the Hyperion Essbase server, your username, and your password. If
you do not have this information, contact the Hyperion Essbase
system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the
server that you want to access.)

3. To move to the Username text box, press Tab and then, in the Username
text box, type your username.

4. To move to the Password text box, press Tab, and then, in the Password
text box, type your password.

Note: You can change your password when you are connected to a server.
See “Changing a Password” on page 24.

5. To connect to the server, click OK.
Hyperion Essbase displays a list of available application/database pairs in
the list box. A Hyperion Essbase server allows simultaneous access to
multiple applications. An application can contain multiple databases. Only
the databases to which you have security access appear in the list.
For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Hyperion Essbase installation, it is
shown in the list. If Sample Basic is not shown in the
Application/Database list, ask the Hyperion Essbase system administrator
to install it.

Figure 83. Essbase System Login Dialog Box
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6. In the Application/Database list, double-click Sample Basic, or, from the
Application/Database list select Sample Basic and then click OK.

If the application is not already running, Hyperion Essbase automatically
starts it. There may be a brief pause as the application loads; the time
required to start an application depends on the number of databases, the sizes
of the databases, and the sizes of the indexes of the databases that are
contained within the applications.

Setting Hyperion Essbase Options
Before you begin the tutorial, make sure that the worksheet options are set to
the initial settings shown in the figures in this section.

Note: For information on each option in the Essbase Options dialog box, see
the Hyperion Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches Figure 85 on page 86.

Figure 84. Available Application and Database Pairs
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4. Select the Zoom tab.
5. Select the appropriate check boxes and option buttons so that your

display matches Figure 86 on page 87.

Figure 85. Initial Settings for Display Options
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6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display matches Figure 87 on page 88.

Figure 86. Initial Settings for Zoom Options
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8. Skip the Style tab.
9. Select the Global tab.

10. Select the appropriate check boxes and option buttons so that your
display matches Figure 88 on page 89.

Figure 87. Initial Settings for Mode Options
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11. To save the settings for this session and close the Essbase Options dialog
box, select OK.

Note: The settings in the Essbase Options dialog box may change as you
access the various sample Lotus 1-2-3 files as part of the tutorial.
Leave the settings as they are unless the tutorial advises you to
change them. If you have different option settings, the illustrations
presented in this chapter may not match the worksheet view.

Performing Advanced Retrieval Tasks

The tutorial in “Chapter 2. A Basic Hyperion EssbaseTutorial” on page 11
describes how to perform basic data retrieval and navigation tasks in
Hyperion Essbase Spreadsheet Add-in. This section walks you through
performing the following advanced retrieval tasks:
v “Filtering Data” on page 90
v “Sorting Data” on page 94
v “Retrieving Data into Asymmetric Reports” on page 97
v “Working with Formatted Worksheets” on page 99
v “Preserving Formulas When Retrieving Data” on page 104
v “Retrieving a Range of Data” on page 107
v “Retrieving Data by Using a Function” on page 110

Figure 88. Initial Settings for Global Options
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v “Retrieving Dynamic Calculation Members” on page 113
v “Specifying the Latest Time Period for Dynamic Time Series” on page 115
v “Using Free-Form Reporting to Retrieve Data” on page 119

Remember that you can perform common data retrieval tasks in any of the
following ways:
v Selecting commands from the Essbase menu on the Lotus 1-2-3 menu bar
v Clicking the appropriate buttons on the Hyperion Essbase toolbar
v Double-clicking the primary or the right-mouse button in the appropriate

cell (for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data
Despite the ease and speed with which you can navigate through large
Hyperion Essbase databases, it is not practical to use the capabilities of
Lotus1-2-3 to filter and sort very large databases; however, Hyperion Essbase
OLAP Server includes powerful data filtering and sorting capabilities. In
“Chapter 2. A Basic Hyperion EssbaseTutorial” on page 11, you learned to use
Hyperion Essbase Query Designer to define a dimensional layout and to
select members to view. Hyperion Essbase Query Designer also provides a
powerful, yet easy-to-use tool to define conditional retrievals.

To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basic1, that you saved in “Chapter 2. A Basic Hyperion
EssbaseTutorial” on page 11, and perform the following steps:

Note: If you skipped the tutorial in “Chapter 2. A Basic Hyperion
EssbaseTutorial” on page 11, follow the steps in “Creating Queries
Using Hyperion Essbase Query Designer” on page 57 to create and save
the Basic1 query.

1. Select Essbase > Query Designer.
Hyperion Essbase displays the query information panel of Hyperion
Essbase Query Designer.

2. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>>A.
3. Right-click and select Open Query.

Hyperion Essbase displays the Open Query dialog box.
4. From the location that you specified in “Chapter 2. A Basic Hyperion

EssbaseTutorial” on page 11, select the Basic1 file.
5. Click OK.

The member selection, displayed in the properties panel, remains
unaltered from the last Hyperion Essbase Query Designer session.

6. From the navigation panel, select Data Filtering.

90 OLAP Spreadsheet Add-in User’s Guide for 1-2-3



Hyperion Essbase displays the data filter settings in the data filter panel.
The filter controls the number of data rows that are retrieved. The
number is based on the column criteria that you define. You can define
data filtering criteria on data values that reside in one or more columns
of the view.

7. The data filtering panel contains the following items:
v A check box for ranking so many of top rows or so many bottom rows

of data. You can select the highest or lowest rows. Your selection is
based on previously selected row dimension members. When using the
top or bottom criterion, you specify the number of rows, such as “top
10.” The default is the top 25 rows.

v A Dimension being ranked list box to specify the dimension to which
ranking should be applied.

v A Column used for ranking list box to specify the data column on
which data values are based.

v A Data Restrictions box to specify standard data comparison
operations, such as greater than, less than, and equal to. You can apply
the comparison operator to data values in one or more data columns;
you can even apply criteria to compare values between two columns.

v Buttons for OR and AND operators. If you define more than one
column criterion, you can use these operators to link the criteria.

8. Click the Top check box, and enter a value of 30 in the Rows text box.

Figure 89. Data Filter Panel
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When you apply the query, Hyperion Essbase retrieves the top thirty
rows of the dimension.

9. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.

10. From the Column list box, select Qtr1, Actual. Qtr1, Actual is the column
on which data values are based.

11. In the navigation panel, select the Data Filtering icon. Right-click and
select Apply Query.
Your query results should look as shown below.

You can further filter your data output by specifying data comparison
operations in the Data Restrictions box.

12. In the navigation panel, select the Data Filtering icon.
The data filters that you specified are displayed in the properties panel.

13. In the Data Restrictions box, double-click.
The data restriction settings are displayed in the properties panel.

14. Select the Value option and type 500 in the Value box.
Observe that the is option in the Data list box changed to =.

15. Click the down arrow of the Data list box and select <=.
16. Select Qtr1, Actual in the Column list box.
17. In the navigation panel, select the Data Filtering icon. Right-click, and

select Apply Query.

Figure 90. Data Filtering Query Results
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Notice that the query results now reflect only Actual and Budget data
that are less than or equal to 500.

18. In the navigation panel, select the Data Filtering icon to display the data
filter setting in the properties panel.

19. In the Data Restrictions box, select Qtr1, Actual <= 500, right-click and
select New Data Restriction.

20. In the Data box, click the down arrow and select <.
21. In the data values list box, select Qtr2, Actual. Under Combined With

Other Restrictions, click the Or button.
22. In the navigation panel, click the Data Filtering icon to access the data

filter panel.
23. In the Data Restrictions box, double click to create a new data restriction.
24. In the Data box, click the down arrow and select Is Not.
25. Click the button for the #Missing Value option.

This option instructs Hyperion Essbase to discard data that have
#Missing values.

26. In the Column list box, select Qtr1, Actual. Under Combined With Other
Restrictions, select the And button.
The data restrictions should appear as follows:

27. Select the Data Filtering icon, right-click, and select Apply Query.

Figure 91. Data Filtering
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Hyperion Essbase retrieves data for all the quarters. Notice that the
retrieved data for Qtr1, Actual is less than or equal to 500 or is less than
Qtr2, Actual. The results should appear as follows:

Note: To delete all data restrictions, select the Data Filtering icon in the
navigation panel, right-click, and select Delete All Data Restrictions.
Alternatively, select any data restriction in the Data Restriction box,
right-click, and select Delete All Data Restrictions.

To delete a particular data restriction, select the data restriction in the query
outline, right-click, and select Delete Data Restriction. Alternatively, select the
data restriction in the Data Restriction box, right-click, and select Delete Data
Restriction.

Sorting Data
Using the data sort panel, you can sort the output from the Basic1 query in
ascending or descending order.
1. From the navigation panel, select the Data Sorting icon.

The data sorting settings are displayed in the properties panel. You can
specify data sorting criteria that affect the order in which the selected
rows are retrieved in the data sorting panel.
The data sorting panel contains the following items:

Figure 92. Data Filtering Results
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v A Dimension being sorted list box that lists the dimensions specified in
row format in the query.

v A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

v An Ordering list box that you use to apply an ascending or descending
sort order for the selected column. You can also specify sorting to
occur over a specific row dimension group. For example, you can sort
by Product or by Market.

2. In the Column used for sort list box, double-click.
The selection defaults to Qtr1, Actual. The sort order defaults to
Ascending in the Ordering list box.

3. Click Ascending. A down arrow is displayed next to Ascending.
4. Click the down arrow. Descending is displayed below Ascending.
5. In the Ordering list box, select Descending.

Figure 93. Data Sorting Panel

Chapter 3. An Advanced Hyperion Essbase Tutorial 95



6. In the next row of the Column used for sort list box, double click.
The selection defaults to Qtr1, Actual.

7. Click the down arrow and select Qtr1, Budget.
Observe that the order in the Ordering list box has defaulted to
Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtr1,
Budget. Right-click and select Delete Sorting Rule.
The Ascending, Qtr1, Budget sorting rule is deleted from the query.

9. In the navigation panel, select the Data Sorting icon. Right-click and
select Apply Query.
Hyperion Essbase returns the results sorted in descending order for each
quarter, as shown below:

Figure 94. Specifying Data Sorting Order
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Note: The values that you are ranking and sorting must be the same. For
example, you cannot specify Product in the Dimension being
ranked box and Market in the Dimension being sorted box. If you
specify different values, Hyperion Essbase Query Designer
automatically changes both values to the last specified value.

10. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Retrieving Data into Asymmetric Reports
When you retrieve data into a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, Figure 95 shows a symmetric
report that contains Actual and Budget members nested below Year members
(Qtr1, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that
differ by at least one member. There can be a difference in the number of
members or in the names of members.

You can create asymmetric reports in one of the following ways:
v Enter member names into the worksheet in free-form retrieval mode.
v Use a drill action with the Within Selected Group option selected from the

Essbase Options dialog box (Zoom tab).

Figure 95. Result of Filtering and Sorting Data
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v Suppress rows that contain missing values, zero values, or underscore
characters during data retrievals.

If you retrieve data into an asymmetric report, Hyperion Essbase must
perform additional internal processing to maintain the asymmetric layout.
This processing may increase the retrieval time on large reports. For more
information regarding optimizing reports, see the Hyperion Essbase Database
Administrator’s Guide, Volume II.

As part of the default Hyperion Essbase installation, Hyperion Essbase
provides a sample file, Asymm.123, that illustrates how to create asymmetric
reports.

To view the sample file Asymm.123:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Asymm.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

In Asymm.123, row and column dimension groups are asymmetric. Thus,
the nested member groups from the Product dimension differ in member
content within respective markets. For example, Colas and Fruit Soda are
included in East but not in West. In addition, Actual data is displayed for
Qtr1, whereas Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also
notice that the sample file displays styles for members of the Scenario and
Year dimensions.

3. Leave the Asymm.123 file open for the next tutorial task.

Pivoting in Asymmetric Reports
When you pivot a group of members in an asymmetric report, Hyperion
Essbase keeps only unique members from dimensions that are not involved in
the pivot.

Figure 96. Asymmetric Report
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To use the open Asymm.123 file to illustrate this point:
1. Using the right-mouse button, drag East to the cell below Qtr1.

Hyperion Essbase combines the Product members into all unique
members. For example, Root Beer, which is displayed twice in Figure 96 on
page 98, is displayed only once in the current view. Colas, which is
displayed in only one market in Figure 96 on page 98, now appears in East
and West.

Hyperion Essbase also removes the blank line between Product row
groups. A pivot action always eliminates any rows or columns in which all
cells are empty.

2. Close Asymm.123 without saving the changes.

Working with Formatted Worksheets
In addition to providing flexible, ad hoc retrievals, Hyperion Essbase supports
retrieving data into formatted worksheets. A worksheet can contain the
following formats:
v Spaces between rows and columns
v Cell values that contain text or data that is not defined in the database

outline
v Member names in noncontiguous locations at the top of a worksheet
v Lotus 1-2-3 formulas (see also “Preserving Formulas When Retrieving Data”

on page 104)
v Visual cues (styles)

After you format and save a worksheet, you may want to retrieve and
navigate through new data in the existing worksheet format. This section
provides the following information on working with formatted worksheets:
v “Observing the Rules for Working with Formatted Worksheets” on page 100
v “Retrieving Data into Formatted Worksheets” on page 100
v “Pivoting Data on Formatted Worksheets” on page 103

Figure 97. Result of Pivoting in an Asymmetric Report
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Observing the Rules for Working with Formatted Worksheets
Observe the following rules when retrieving data into a formatted worksheet:

Rule 1

In the worksheet, no numeric cells can be located before the first Hyperion
Essbase data cell. For example, in Figure 98 on page 101, the first Hyperion
Essbase data cell is B6. Neither any cell in rows 1 through 5 nor cell A6 can
contain numeric values. Also, these cells cannot contain formulas that resolve
to numeric values.

Rule 2

A cell that lies within a row or column of Hyperion Essbase data cannot
contain text or numeric values. For example, in Figure 98 on page 101, the
cells in columns B, C, D, and F and rows 6 through 9 and 11 through 14
cannot contain any nondata text or numbers, for such values may be
overwritten (or emptied) by the retrieved data. These cells can contain
formulas, however, if Formula Preservation options are used. For more
information on Formula Preservation options, see “Preserving Formulas When
Retrieving Data” on page 104.

Tip: If you need to preserve text in a cell, define that text or value as an
Lotus 1-2-3 formula, and use the Formula Preservation options.

Rule 3

The Pivot command is not available when the Retain on Retrieval check box is
selected in the Essbase Options dialog box (Mode tab).

Rule 4

The Pivot command removes all cells that contain text other than database
member names.

Retrieving Data into Formatted Worksheets
As part of the default Hyperion Essbase installation, Hyperion Essbase
provides a sample file, P&l.123, that illustrates how to retrieve data into a
formatted worksheet. The P&l.xls sample file illustrates how to retrieve data
into a worksheet that contains formatted text, formulas, and protected cells.

To view the P&l.123 worksheet:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the P&l.123 file.
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Depending on how software is installed on your machine, the file may
not be available or may be located in a different directory. Contact the
Hyperion Essbase system administrator for more information.

3. Select Essbase > Options and select the Display tab.
4. In the Cells option group, make sure that Adjust Columns is checked.
5. Select the Mode tab.
6. In the Formula Preservation group, select the Retain on Retrieval check

box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay
in retrieval time.

7. Click OK.
By default, a Hyperion Essbase retrieval overwrites Lotus 1-2-3 formula
with data values in the retrieval area of a worksheet. The retrieval
process also eliminates formulas in cells outside the retrieval area.
However, the Retain on Retrieval option enables you to define retrievals
that do not overwrite formulas in any area of the worksheet.

8. Select Essbase > Retrieve to update the worksheet with the latest data
values.
Hyperion Essbase determines that some text cells in the worksheet do not
correspond to database member names. When Hyperion Essbase is
unable to resolve text in the worksheet, the following message is
displayed:

Figure 98. A Sample Formatted Worksheet
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In this example, the first unknown member detected is Market: (in cell
A1). Hyperion Essbase does not recognize the colon (:) that follows
Market in the cell. If you click Yes, Hyperion Essbase displays the next
unknown member; if you click No, Hyperion Essbase continues with the
retrieval.

Note: If you work with formatted worksheets often, you may want to
tell Hyperion Essbase not to display this message. For more
information, see “Pivoting Data on Formatted Worksheets” on
page 103.

9. Click No to close the dialog box and continue with the retrieval.
Hyperion Essbase retrieves new data but retains the formatting and
formulas in the worksheet.

10. Close P&l.123 without saving it.

Note: This chapter’s section on “Preserving Formulas When Retrieving Data”
on page 104 provides additional tutorial tasks that show you how to

take advantage of all the Formula Preservation options.

Figure 99. Hyperion Essbase Unknown Member Message

Figure 100. Result of Retrieving on a Formatted Worksheet
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Pivoting Data on Formatted Worksheets
With the Pivot command, you can produce ad hoc reports in both formatted
and unformatted worksheets. However, a formatted worksheet may contain
labels and formulas that make the result of a pivot operation ambiguous. The
pivot is designed to compress and retain only the database elements
represented in the worksheet. The worksheet also retains labels in areas that
are not overwritten by pivoted data.

Note: Hyperion Essbase prevents pivot operations on worksheets that contain
formulas when Formula Preservation mode is active.

Inv.123, a sample file installed as part of the Hyperion Essbase installation
process, illustrates how to pivot data in a worksheet. It was saved with the
Retain on Retrieval option disabled so that you can pivot on its worksheets.

To view the Inv.123 worksheet:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Inv.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

3. Select Essbase > Options and select the Global tab.
4. In the Display Messages group, clear the Display Unknown

Memberscheck box to avoid seeing the Hyperion Essbase messages when
working with formatted worksheets.

5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested
below Jan (C4).

Figure 101. Formatted Worksheet Before Pivoting
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Hyperion Essbase pivots the Sales member group so that it is nested
below the monthly members. However, during the pivot, Hyperion
Essbase retains only database elements. For example, all data for Stock to
Sales and Adjusted for Audit is deleted during the pivot.

6. Close Inv.123 without saving it.

Preserving Formulas When Retrieving Data
In “Retrieving Data into Asymmetric Reports” on page 97, you used the
Retain on Retrieval option to preserve formatting and formulas in an existing
worksheet. Collectively, the Formula Preservation options enables you to
retain formulas during data retrievals, keep and remove only operations, and
drill operations. In addition, Hyperion Essbase can replicate formulas for
additional members retrieved into the worksheet as part of a drilling
operation. This section steps you through using all of the Formula
Preservation options in a report that you create.

You must enable some options before you can enable other options. Keep in
mind the following guidelines and restrictions when using the Formula
Preservation options:
v On the Mode tab of the Essbase Options dialog box, you must have the

Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.

v You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

v You must enable Retain on Zooms to enable Formula Fill.
v When you select the Retain on Retrieval check box, the Suppress #Missing

Rows and Zero Rows options on the Display tab become disabled.
Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.

Figure 102. Result of Pivoting on a Formatted Worksheet
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v When you select the Retain on Zooms check box, the Remove Unselected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

v When Retain on Retrieval is enabled, there may be a slight delay in
retrieval time.

v As a general rule, insert a blank row as the last row in the formula range to
ensure that the cell range in the formula expands properly when you drill
down on members with Retain on Zooms enabled. For more information,
see the Hyperion Essbase Spreadsheet Add-in online help.

v Formula arrays are not supported in Hyperion Essbase Spreadsheet Add-in
when the preserve formula option is on. If you have formula arrays in the
worksheet, Hyperion Essbase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:
1. To open a new worksheet, select File > New or click the

icon.
2. Select Essbase > Retrieve.
3. In cell A2, drill down (double-click) on Year.
4. Press and hold the Alt key and, in cell E1, drill down (double-click) on

Scenario.
5. Select cell G3 and enter the following formula in the cell: =B3/B7*100

6. Press Enter.
Lotus 1-2-3 calculates the formula that you entered in cell G3 and now
reflects Qtr1 as a percentage of Year.

Figure 103. Entering an Lotus 1-2-3 Formula into a Cell
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7. Select Essbase > Options and select the Mode tab.
8. In the Formula Preservation area, select the check boxes for Retain on

Retrieval and Retain on Keep and Remove Only. Click OK.
9. In cells D2, E2, and F2, respectively, select Variance, %Variance, and

Scenario.
10. Select Essbase > Remove Only.

Hyperion Essbase removes the selected columns but retains the Lotus
1-2-3 formula that you entered, keeping it with the retained dataset.

11. Select Essbase > Options and select the Mode tab.
12. In the Formula Preservation area, click the box for Retain on Zooms and

click OK.
13. In cell A3, drill down (double-click) on Qtr1.

Hyperion Essbase drills down on Qtr1 and moves the formula down
with the Qtr1 member.

Figure 104. Result of Lotus 1-2-3 Formula with Hyperion Essbase Data

Figure 105. Result of Removing Columns with Retain on Keep or Remove Only Enabled
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14. Select Essbase > FlashBack.
15. Select Essbase > Options and select the Mode tab.
16. In the Formula Preservation area, select the Formula Fillcheck box. Click

OK.
17. In cell A3, drill down (double-click) on Qtr1.

Hyperion Essbase drills down on Qtr1 and replicates the formula for
each member of Qtr1 (Jan, Feb, and Mar). To view the replicated
formulas, click in cells D3, D4, D5, and D6 and look at the new syntax in
the Lotus 1-2-3 formula bar.

18. Before moving on with the tutorial, complete each of the following
actions:
a. Select Essbase > Options and select the Mode tab.
b. Clear all of the Formula Preservation options.
c. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Retrieving a Range of Data
In a typical Lotus 1-2-3 worksheet, you can select a range of cells by dragging
the mouse across the worksheet. You can also select a range of cells and tell

Figure 106. Result of Drilling Down with Retain on Zooms Enabled

Figure 107. Result of Drilling Down with Formula Fill Enabled
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Hyperion Essbase to restrict the data retrieval to the selected range in the
worksheet. Retrieving a range of data is particularly useful in the following
situations:
v A worksheet contains multiple reports.
v A worksheet contains extraneous information that is not supported in a

formatted report retrieval.
v You need to retrieve only a small subset of values from the server, thus

dramatically decreasing retrieval time for large datasets.
v You need to retrieve data to an area of the worksheet other than the first

column.

As part of the default Hyperion Essbase installation, Hyperion Essbase
provides a sample file, Profit.123, that illustrates how to retrieve a range of
data.

To view the Profit.123 file:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Profit.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.
Profit.123 has already selected a range of cells (B2 through F9) for you.

3. Select Essbase > Retrieve to update the selected range.

Figure 108. Selected Range of Cells for Retrieval
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Hyperion Essbase updates only the data in the selected range of cells.
4. Select cells B12 through G16.

5. Select Essbase > Retrieve once again to update the selected range.
Hyperion Essbase updates the data in the selected range.

Figure 109. Figure 112. Result of Retrieving First Range of Data

Figure 110. Figure 113. Selecting Cells for Retrieval
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6. Close Profit.123 without saving it.

Retrieving Data by Using a Function
The Hyperion Essbase cell retrieve function, EssCell, retrieves a single
database value into a worksheet cell. Enter an EssCell function directly into a
worksheet or select an EssCell function from the Lotus 1-2-3 menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform a Hyperion Essbase retrieval or
when you recalculate a worksheet throughLotus 1-2-3. As part of the default
Hyperion Essbase installation, Hyperion Essbase provides a sample file,
Summary.123. This file has EssCell functions already set in cells B16 and B17.

To view the Summary.123 file:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Summary.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Hyperion
Essbase system administrator for more information.

Figure 111. Result of Retrieving Second Range of Data
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Cells B16 and B17 in Summary.123 contain the EssCell function. If you
select either of these cells, you can view the syntax for the EssCell function
in the Lotus 1-2-3 formula bar at the top of the worksheet.

The EssCell function is defined in a cell as follows:

@EssCell(mbrList)

mbrList is one of the following:
v A null value. If the parameters of the function are empty, Hyperion

Essbase returns the data value from the top of each dimension.
v A comma-delimited list of member names. Member names must be

enclosed in double quotes, with only one member per dimension
allowed. If you list no members from a particular dimension, the
function returns the data value from the top member of the unspecified
dimension. Furthermore, you can include aliases in the member list,
subject to the same rules as member names.

v A Lotus 1-2-3 cell reference. The reference must point to a cell that
contains a valid member name. Member names, such as 200 and 300-10,
need to be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B16 in the
Summary.123 file is the following:

@EssCell(″Sales″, A1, A2, B4, F5)

When you open the worksheet, the values in these cells are #N/A. To
update the values with the data in your database, you must perform a
retrieval from Hyperion Essbase.

Figure 112. Worksheet Containing EssCell Functions
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3. Select Essbase > Retrieve.
Hyperion Essbase calculates the EssCell functions in cells B16 and B17.

Now update the EssCell functions to retrieve data for a different state.
4. Change the contents of cell A2 from Texas to Florida.

The values in cells B16 and B17 are updated as soon as you update the
cell. The update occurs because Lotus 1-2-3 has recalculated the worksheet
(if you have configured Lotus 1-2-3 to calculate changes automatically).
The remaining data cells do not change. To completely update the
worksheet, you must retrieve data from the server.

Note: If the worksheet contains many EssCell functions, change Lotus
1-2-3 to manual calculation mode. This change prevents the cell

Figure 113. Retrieval on a Worksheet Containing the EssCell Function

Figure 114. Updating the EssCell Function
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retrieve from calculating until you retrieve data or calculate the
worksheet manually. For more information, see the Lotus 1-2-3
documentation.

5. Select Essbase > Retrieve to update the report.
Hyperion Essbase returns an error message if EssCell is unsuccessful. The
following table lists messages that Hyperion Essbase displays in the
EssCell cell and explains the conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double quotation marks.

6. Close Summary.123 without saving it.
The sample file that you used for this tutorial task already had EssCell
functions defined. To enter your own EssCell function into a worksheet,
you do the following:

Enter the EssCell syntax in the 1-2-3 formula bar at the top of the sheet.

Note: For more information on EssCell functions, see the Hyperion Essbase
Spreadsheet Add-in online help.

Retrieving Dynamic Calculation Members
Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation
time. The Hyperion Essbase Application Designer tags dynamic calculation
members in the database outline so that Hyperion Essbase knows not to
calculate those members until a data retrieval requests them. This process is
referred to as dynamic calculation. Dynamically calculating database members
benefits the Hyperion Essbase server in the following ways:
v Reduced disk usage
v Reduced database restructuring time
v Reduced time to back up the database

Database values that Hyperion Essbase calculates dynamically take slightly
longer to retrieve in Hyperion Essbase Spreadsheet Add-in because Hyperion
Essbase must perform calculations before retrieving data into the worksheet.
For more information on dynamic calculation, see the Hyperion Essbase
Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the
spreadsheet report so that Hyperion Essbase does not dynamically
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calculate the database when you are creating the report. For more
information on the Navigate Without Data feature, see “Navigating
Through the Worksheet Without Retrieving Data” on page 40.

Because there may be a performance impact on retrieving data for dynamic
calculation members, define visual cues, or styles, for these members so that
you can identify them in Hyperion Essbase Spreadsheet Add-in.

To illustrate how to use Dynamic Calculation members, use the Asymm.123 file.

To view the Asymm.123 file:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Asymm.123 file.
3. Drill up on Actual by double-clicking the right-mouse button in cell C3.
4. In cell C3, drill down on Scenario to display all members of Scenario.

Hyperion Essbase displays only the Scenario members for Qtr1.

5. Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the
Style tab. For more information on connecting to a database, see
“Connecting to a Database” on page 83.

6. In the Members group, scroll down until you see Dynamic Calculations.
7. Select the Dynamic Calculations check box and click the Format button.
8. In the Font style list, select Bold Italic.
9. In the Color list, select Gray.

10. Click OK and then select the Display tab.
11. In the Cells option group, click Use Styles. Click OK.
12. Select Essbase > Retrieve.

Hyperion Essbase displays the data and applies all the visual cues, or
styles, that you set, including the newly set styles for dynamic calculation
members and the styles you set in “Chapter 2. A Basic Hyperion

Figure 115. Displaying Scenario Members
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EssbaseTutorial” on page 11. You can tell that the columns for Variance
and Variance% are dynamically calculated because Hyperion Essbase
displays these members in gray, bold, italicized font. (Variance and
Variance% also have a red background because that style was previously
set for all members of the Scenario dimension.)

Note: Occasionally, other styles you have set may override a style for
dynamic calculation members. For example, if a parent member is
also a dynamic calculation member, and if you have styles set for
both parent and dynamic calculations, the style for the parent
member overrides the style for the dynamic calculation member. In
this case, you need to remove the style for parent members in
order to see the style for dynamic calculation members. For more
information on the precedence of styles, see “Determining the
Precedence of Overlapping Styles” on page 51 on page 88.

13. Close the Asymm.123 file without saving it.

Specifying the Latest Time Period for Dynamic Time Series
Dynamic Time Series members are predefined database members that are used
in dynamic, to-date reporting, such as year-to-date or month-to-date values.
Dynamic Time Series members do not appear as individual members in the
database outline; instead, they correspond to a generation name that uses a
key term for time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter
was created for generation 2 in the Year dimension. Generation 2 includes the
members for Qtr1, Qtr2, Qtr3, and Qtr4. When the generation name Quarter
was created, Hyperion Essbase created a Dynamic Time Series member called
Q-T-D, or quarter-to-date.

To take advantage of Dynamic Time Series in Hyperion Essbase Spreadsheet
Add-in, choose the latest time period for which you want data in a to-date
calculation. The calculated value of the Dynamic Time Series member is
derived when you define the latest time period to be reported. In the Sample
Basic database, for example, the level 0 members of the Year dimension are

Figure 116. Result of Retrieving Dynamic Calculation Members
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the months of the year: Jan, Feb, Mar, and so on. If the current month is
August, and you want to know the sales data for the quarter up to the current
month, a quarter-to-date calculation gives you the sales data for the months of
July and August.

To illustrate the concept of Dynamic Time Series:
1. To open a new worksheet, select File > New or click the New Worksheet

icon.
2. Select Essbase > Options and select the Zoom tab.
3. In the Zoom In option group, select Next Level.
4. Clear the Within Selected Group check box and click OK.
5. Select Essbase > Retrieve.
6. In cell B1, drill down (double-click) on Measures.
7. In cell B2, click Year.
8. Type Q-T-D in cell B2 and press Enter to enter a predefined Dynamic

Time Series member (Q-T-D):

Note: For a list of other possible Dynamic Time Series members, see the
Hyperion Essbase Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.
10. In the Dynamic Time Series area, select the Latest Time Period check box.
11. From the list box, select May. Click OK.

Figure 117. Entering a Dynamic Time Series Member into a Worksheet
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Note: If you do not specify a latest time period, Hyperion Essbase uses
the first level 0 member (Jan) as the default.

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not
supported with Dynamic Time Series members.

Hyperion Essbase displays data for the Q-T-D member. The data values
in the worksheet are the aggregated values for April and May, because
May is the month you specified as the latest month in the quarter-to-date
Dynamic Time Series.

13. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Figure 118. Specifying Latest Time Period in a Dynamic Time Series

Figure 119. Result of Specifying Latest Time Period in a Dynamic Time Series
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Note: You can also create a report like the one shown above by simply typing
the name of the Dynamic Time Series member followed by the name of
latest time period in parentheses: for example, Q-T-D (May). If you are
using free-form retrieval mode, you must enter the Dynamic Time
Series member and the latest time period in separate, adjacent cells.
You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member
Selection.

Note: For more information on Dynamic Time Series, see the Hyperion
Essbase Spreadsheet Add-in online help.

Using Substitution Variables
The Hyperion Essbase application designer uses substitution variables to
define global variables to represent values that are specific to Hyperion
Essbase. For example, Latest can be a substitution variable representing the
latest time period in a Dynamic Time Series. Using Hyperion Essbase
Application Manager, Application Designer sets substitution variables and
their corresponding values for a specific application. Hyperion Essbase stores
these variables and their values on the Hyperion Essbase server. You can take
advantage of the predefined substitution variables in Hyperion Essbase
Spreadsheet Add-in during Dynamic Time Series reporting.

For example, say the application designer sets a substitution variable on the
server for the current month. The variable is called CurMnth and has a value
of August. If you use the substitution variable in the worksheet, a retrieval
returns values for August, because August is set as the current month on the
server. If, at a later date, the application designer changes the value of the
CurMnth substitution variable to October, a retrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a
substitution variable in the database you are using, you could enter a
substitution variable directly into a worksheet. For example, you could open a
blank worksheet and type member names as follows:

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an
ampersand (&).

Figure 120. Entering a Substitution Variable in a Worksheet
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In this example, a retrieval produces the following results:

Hyperion Essbase queries the server for the value of the substitution variable
CurMnth, which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a
template, make sure that you save the worksheet before you retrieve
data. For example, if you save the worksheet shown in Figure 121 as a
template, each time you retrieve the template, August rather than the
substitution variable CurMnth is displayed.

Using Free-Form Reporting to Retrieve Data
So far, you have learned how to retrieve Hyperion Essbase data into a
worksheet through ad hoc retrieval, Hyperion Essbase Query Designer
queries, and Member Selection operations. In addition to these retrieval
methods, Hyperion Essbase supports free-form reporting. Free-form reporting
enables you to tell Hyperion Essbase specifically what you want to retrieve by
simply typing data into the worksheet. Free-form reporting is especially useful
when you are familiar with the dimensions and members in the database
outline.

Hyperion Essbase provides two different retrieval modes for free-form
reporting:
v Advanced Interpretation
v Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode
The Hyperion Essbase server contains an advanced spreadsheet interpretation
engine that scans a worksheet and interprets its content when fulfilling
retrieval requests. When you construct a report by entering names directly
into a worksheet in Advanced Interpretation retrieval mode, Hyperion Essbase
interprets the member names and creates a default view that is based on the
location of the labels.

Figure 121. Result of Retrieval on a Substitution Variable
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Keep in mind the following guidelines when you are working in Advanced
Interpretation mode:
v Precede all member names that consist of numbers with a single quotation

mark. For example, for Product dimension member 100, type ’100 in the
worksheet.

v If you define a report that does not contain all of the database dimensions,
you may need to enter a dummy value, such as 0, in the first data cell.
Hyperion Essbase overwrites this value with the contents of the database
cell upon retrieval. Be sure to use a numeric value as the dummy value.

To construct a free-form report in Advanced Interpretation retrieval mode:
1. To open a new worksheet, select File > New or click the

icon.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation(the default

setting) and click OK.
4. Enter member names and data as in the following illustration.

Note: If a member name consists of a number, such as 100, you must
precede the member name with a single quotation mark (for
example, ’100). This rule also applies to member names with spaces
between words.

5. Select Essbase > Retrieve or double-click in a data cell.
Hyperion Essbase retrieves data for the members you entered into the
free-form report and implements the Use Aliasesoption that you set in the
Essbase Options dialog box in the beginning of this chapter.

Figure 122. Creating a New Free-Form Report
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Now define a free-form report that does not contain all of the dimensions
from the database. In Advanced Interpretation mode, you may need to
enter a dummy data value, such as 0, into the first Hyperion Essbase data
cell to tell Hyperion Essbase where the data starts in the worksheet. Be
sure to use a numeric value as the dummy value.

For example:
a. Select Essbase > FlashBack.
b. Delete cells A1, B1, and C1.
c. In cell B4, type 0 in cell B4 to provide Hyperion Essbase with a data

cell reference point.

6. Select Essbase > Retrieve.
Hyperion Essbase adds the dimensions that were omitted from the
free-form report to the worksheet and retrieves data.

Figure 123. Retrieving Data into a Free-Form Report

Figure 124. Defining a Free-Form Report Without All Dimensions

Figure 125. Retrieval in a Free-Form Report Without all Dimensions
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7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Free-Form Mode
Similar to Advanced Interpretation mode, Free-Form mode enables you to
enter member names into any location in a worksheet and then interprets the
contents of the worksheet when fulfilling the retrieval request. In addition,
with Free-Form mode, you can use Hyperion Essbase report script commands
to retrieve data into a worksheet.

Report script commands are most useful for defining member references that
can bring back the most current member information dynamically. For
example, if you need to create a report that shows every product, including
the products added since the last retrieval, standard retrieval mode reflects
changes only when you zoom in on the product. If you use the report script
command <IDESCENDANTS, Hyperion Essbase retrieves all descendants of a
specified member, including the specified member. For more information on
the syntax of report script commands and on guidelines for developing
reports, see the online Technical Reference and the Hyperion Essbase Database
Administrator’s Guide.

Keep in mind the following guidelines when working in Free-Form retrieval
mode:
v You must precede all member names that consist of numbers with a single

quotation mark. For example, for the Product dimension member 100, you
need to type ’100 in the worksheet.

v You cannot cancel a retrieve in Free-Form mode.
v You cannot apply Hyperion Essbase styles in Free-Form mode.
v Hyperion Essbase removes blank rows and columns on any retrieval action.
v When you are in Free-Form mode, an Auto Sort Rows option is enabled in

the Display tab of the Essbase Options dialog box. If you select this feature,
Hyperion Essbase retrieves data in symmetric rows. The rows are sorted
according to the order specified in the database outline.

v Not all Formula Preservation and Modes options (Essbase Options dialog
box, Mode tab) are available in Free-Form mode.

v To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb))
in the same cell. You need to type the Dynamic Time Series member, Q-T-D
in one cell, and the latest time period within parentheses, (Feb), in a
separate, adjacent cell.

To construct a free-form report in Free-Form retrieval mode:
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1. To open a new worksheet, select File > New or click the

icon.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Free Form.
4. Select the Display tab.
5. In the Cells option group, select Auto Sort Rows. Click OK.
6. Enter the member names into the worksheet as shown in Figure 126:

7. Select Essbase > Retrieve.
Hyperion Essbase retrieves data for the members and creates a default
view according to the location of the labels. Note that three members were
pivoted from row groups to column groups.

8. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Now create a report by entering member names and a report script command:
1. To open a new worksheet, select File > New or click the

icon.
2. Enter the member names into the blank worksheet as shown in Figure

3-46.

Figure 126. Typing Member Names In a Free-Form Report

Figure 127. Result of Retrieving in Free-Form Retrieval Mode

Chapter 3. An Advanced Hyperion Essbase Tutorial 123



3. In cell A3, type <IDESCENDANTS Product. Press Enter.

4. Select Essbase > Retrieve.
Hyperion Essbase retrieves data into the worksheet for all descendants of
Product and for the members you entered in the worksheet.

Note: When Hyperion Essbase completes the retrieval, the report script
command is overwritten by the data it returns. You can use
FlashBack to restore the previous view in Free-Form mode.

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Attributes in Free-Form Reporting
Hyperion Essbase enables you to retrieve data selectively by specifying
attributes that are associated with a base dimension. For example, in the
Sample Basic database, the Product base dimension is associated with
attributes such as packaging and size. You can enter an attribute name into
the worksheet to retrieve data that is associated with that attribute.

Figure 128. Typing Member Names in a Free-Form Report

Figure 129. Typing a Report Script Command in a Free-Form Report

Figure 130. Result of a Retrieve with a Report Script Command
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To use attributes in a free-form report:
1. To open a new worksheet, select File > New or click the

icon.
2. Enter member names as shown in the Figure 131.

Caffeinated is an attribute dimension associated with the Product base
dimension. Bottle is a level 0 member of the Pkg_Type attribute
dimension. The Pkg_Type dimension is associated with the Product base
dimension. A level 0 member is the lowest level member in a dimension.

3. Click in any empty cell and select Essbase > Retrieve or double-click in an
empty data cell.
Hyperion Essbase retrieves information on profits for the first quarter of
the year for all members of the Product base dimension that are associated
with both the level 0 attribute members of the Caffeinated attribute
dimension (Caffeinated_True and Caffeinated_False) and the level 0
member Bottle of the Pkg_Type attribute dimension. The results should
appear as shown below:

4. You can drill down to data on the level 0 attribute members of the
Caffeinated attribute dimension. The results should appear as shown
below:

Figure 131. Using Attributes in Free-Form Reports

Figure 132. Result of Using Attributes in Free-Form Reports

Figure 133. Drilling Down on Attributes in Free-Form Reports
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5. To drill down further for data on profits for the first quarter for all
members of the East base dimension, double-click on cell E1. The results
should appear as shown below:

Entering Generation and Level Names
In addition to entering database member names into a free-form report, you
can enter generation or level names directly into a worksheet to retrieve
specific members. The Hyperion Essbase application designer defines
generation and level names for database dimensions in the database outline.
You have two options for discovering what generation and level names are
defined in the database:
v View generation and level names in the Essbase Member Selection dialog

box or through Hyperion Essbase Query Designer.
v Contact the Hyperion Essbase application designer to see what generation

and level names are defined in the database outline.

To enter generation and level names directly into a free-form report:
1. To open a new worksheet, select File > New or click the

icon.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation. Click OK.
4. Enter member names as shown in Figure 135 on page 127:

Figure 134. Result of Drilling Down on East
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5. Enter a generation name as shown in Figure 136:
Family is a generation name in the Product dimension. The name is
already defined in the Sample Basic database.

6. Select Essbase > Retrieve.
Hyperion Essbase retrieves data for the member and generation names
that you entered. The Family generation name expands to its individual
members.

7. Change Year to a level name (Lev0,Year) as shown in the following
illustration.

Figure 135. Entering Member Names in a Free-Form Report

Figure 136. Entering a Generation Name in a Free-Form Report

Figure 137. Result of Free-Form Retrieval with Generation Name

Figure 138. Entering a Level Name in a Free-Form Report
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Note: Be sure not to insert a space between the comma after 0 and the
word Year. Generation and level names that are entered directly into
a worksheet must be precise.

8. Select Essbase > Retrieve.
Hyperion Essbase retrieves data for the level 0 members of the Year
dimension, which are the individual months (Jan, Feb, Mar, and so forth).

9. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to a cell in a Hyperion Essbase database. The file, note,
or Web resource (indicated by a URL, or Uniform Resource Locator) can then
be retrieved by the Hyperion Essbase Spreadsheet Add-in users who have
access to the database.

Note: If your organization has licensed and implemented Hyperion Essbase
Partitioning option, you can also access linked partitions from cells in
Hyperion Essbase Spreadsheet Add-in. For more information on linked
partitions, see “Accessing Linked Partitions” on page 143.

This section describes the following procedures:
v “Linking a File to a Data Cell” on page 129
v “Linking a Cell Note to a Data Cell” on page 132
v “Linking a URL to a Data Cell” on page 133
v “Accessing and Editing Linked Reporting Objects” on page 135

Note: For additional information on using linked reporting objects, see the
Hyperion Essbase Spreadsheet Add-in online help.

Figure 139. Result of Free-Form Retrieval with Level Name
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Linking a File to a Data Cell
With the linked reporting objects feature, you can link an external file to a
data cell in Hyperion Essbase Spreadsheet Add-in. Hyperion Essbase stores
the file on the Hyperion Essbase server. Users who have access to the
database can then retrieve the file and view the data contained in the cell.

The following example uses the Asymm.123 sample worksheet with data from
the Sample Basic database. It links a sample file, Budasmp.txt, to a cell
containing the Budget figure. Budasmp.txt details the budgetary assumptions
for the current year.

Follow these steps to link a file to a data cell:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Asymm.123 file.
3. Make sure that you are connected to the Sample Basic database. If you

are not connected, see “Connecting to a Database” on page 83.
4. Select cell D5.

Note: You can link objects only to data cells, not to cells containing
member names.

5. Select Essbase > Linked Objects.
Hyperion Essbase displays the Linked Objects Browser dialog box.

Figure 140. Selecting a Data Cell for Linking an External File
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6. In the Linked Objects Browser dialog box, click the Attach button.
Hyperion Essbase displays the Attach Linked Object dialog box.

7. Under the Attachment Type option group, select File.

8. Click the Browse button (next to the File Name text box).
Hyperion Essbase displays the Browse Files dialog box.

9. Go to the \essbase\client\sample directory and select the Budasmp.txt
file.

10. Click Open.
11. Under File Description, enter a brief description for the file as indicated

in Figure 143 on page 131.

Figure 141. Linking a File

Figure 142. Linking a File to a Data Cell
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Note: Entering text in the File Description text box is optional.
12. Click OK to close the dialog box and link the file to the cell.

Hyperion Essbase copies the file to the server and establishes a link to
the current data cell.

13. Click Close to close the Linked Objects Browser dialog box.
14. Do not close the Asymm.123 file. You use it in the next tutorial task.

To recognize cells that have linked reporting objects attached to them,
you may want to apply a visual cue, or style, to the cells.

To apply styles:
1. Select Essbase > Options and select the Style tab.
2. In the Data Cells area, select Linked Objects.
3. Click Format.
4. In the Font style list box, select Italic.
5. In the Color list box, select Purple. Click OK.
6. Select the Display tab.
7. In the Cells option group, select the Use Styles box. Click OK.
8. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Cell D5 (the cell you just attached the linked file to) is now displayed in
purple, italic font. Hyperion Essbase also refreshes the worksheet with the
other options set in the Essbase Options dialog box.

Figure 143. Selecting and Describing a File to Link
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9. Leave the Asymm.123 file open for the next tutorial task.

Linking a Cell Note to a Data Cell
In addition to linking external files to a data cell in Hyperion Essbase
Spreadsheet Add-in, you can also link individual cell notes that contain
information on particular data cells. Cell notes can have no more than 599
characters. If you need to link information to a data cell that is longer than
599 characters, you need to create and save an external file and then link the
file to the data cell.

To link a cell note to a data cell:
1. In the Asymm.123 file, select cell C5.

Note: You can link objects only to data cells, not to cells containing
member names.

2. Select Essbase > Linked Objects.
Hyperion Essbase displays the Linked Objects Browser dialog box.

3. In the Linked Objects Browser dialog box, click Attach.
Hyperion Essbase displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select Cell Note.
5. In the Cell Note box, type the note as indicated in the following

illustration:

Figure 144. Result of Applying a Style to a Linked Reporting Object Cell
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6. To close the dialog box and link the cell note, click OK.
Hyperion Essbase copies the note to the server and establishes a link to
the current data cell.

7. To close the Linked Objects Browser dialog box, click Close.
8. Select Essbase > Retrieve to refresh the worksheet and apply the style you

defined for linked objects.
Now Hyperion Essbase displays two data cells (C5 and D5) in purple,
italic font to represent a cell that contains a linked reporting object.

9. Leave the Asymm.123 file open for the next tutorial task.

Linking a URL to a Data Cell
A URL is an address string that identifies resources on the World Wide Web,
such as documents, images, and downloadable files. With the linked reporting
objects feature, you can link a URL to a data cell so that users who have
access to the database can link directly to the specified URL. When you access
the cell from Hyperion Essbase Spreadsheet Add-in, your default Web
browser opens and displays the specified URL.

Figure 145. Creating a Cell Note to Link

Figure 146. Result of Creating a Linked Cell Note
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Note: For more information on URL syntax, see the Hyperion Essbase
Spreadsheet Add-in online help.

If you have a Web browser and Internet access, follow these steps to link a
data cell to the Hyperion Web site:
1. In the Asymm.123 file, select cell E5.

Note: You can link objects only to data cells, not to cells containing
member names.

2. Select Essbase > Linked Objects.
Hyperion Essbase displays the Linked Objects Browser dialog box.

3. In the Linked Objects Browser dialog box, click Attach.
Hyperion Essbase displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select URL.

5. Enter a URL in the Location text box and a brief description in the URL
Description text box, as indicated in Figure 151 on page 137.

Figure 147. Selecting a Data Cell for Linking to a URL

Figure 148. Linking a URL to a Data Cell
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Note: Entering text in the URL Description text box is optional. The text
field for entering the URL location is limited to 512 characters. The
text field for entering the URL description is limited to 80
characters.

6. To close the dialog box and link the URL to the cell, click OK.
Hyperion Essbase copies the URL string to the server and establishes a
link to the current data cell.

Note: The syntax for the URL is not checked at creation time; Hyperion
Essbase checks the syntax when the user accesses the URL from the
worksheet. The default Web browser checks for the existence (or
validity) of the URL.

7. To close the Linked Objects Browser dialog box, click Close.
8. Select Essbase > Retrieve to refresh the worksheet and apply the style that

you defined for linked objects.
9. Leave the Asymm.123 file open for the next tutorial task.

Now that you have learned to create linked reporting objects, you are
ready to learn how to access them from Hyperion Essbase Spreadsheet
Add-in.

Accessing and Editing Linked Reporting Objects
You have two options for accessing and editing a linked reporting object that
is attached to a data cell:
v Select the cell (as identified by the style applied to it) and select Essbase >

Linked Objects.
v Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing,
double-clicking behavior changes for retrieving data and performing

Figure 149. Entering and Describing a URL to Link
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drill actions. For more information on these changes, see the Hyperion
Essbase Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in
the previous sections by using the Essbase menu item instead of the
double-clicking action.

Accessing a Linked File
Sometimes you want to check an external file that is linked to a data cell.

To access the external file that you previously linked to a data cell:
1. In the Asymm.123, select cell D5.
2. Select Essbase > Linked Objects.
3. In the Linked Objects Browser dialog box, select the Budasmp.txt file.

4. To view the linked file, click View/Launch.
The Budasmp.txt file is opened from the source application.

Figure 150. Accessing a Linked External File
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Note: Edit the contents of a file in the source application. After the edits
are made and the file saved, you can re-attach the edited file by
clicking the Edit button in the Linked Objects Browser dialog box.
Hyperion Essbase displays the Re-attach Linked Object dialog box,
which you can use to re-attach, or relink, the edited file to the data
cell. For more information, see the Hyperion Essbase Spreadsheet
Add-in online help.

5. Close the Budasmp.txt file and click Close to close the Linked Objects
Browser dialog box.

6. Leave the Asymm.123 file open for the next task.

Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

To access and edit the cell note that you previously created:
1. In the Asymm.123 file, select cell C5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is
linked to the selected data cell.

3. In the Linked Objects Browser dialog box, select the cell note.

Figure 151. Viewing the Contents of a Linked External File
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4. To edit the contents of the cell note, click Edit.
Hyperion Essbase displays the Edit Cell Note dialog box with the selected
cell note displayed.

Note: If you simply want to view the contents of the cell note, click the
View/Launch button instead of the Edit button in the Linked
Objects Browser dialog box.

5. Edit the contents of the cell note as indicated in the following illustration:

Figure 152. Accessing a Linked Cell Note

Figure 153. Editing the Contents of a Linked Cell Note
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6. Click OK to close the Edit Cell Note dialog box and save the edits you
made to the note.
Hyperion Essbase saves the edits to the cell note on the server.

7. To close the Linked Objects Browser dialog box, click Close.
8. Leave the Asymm.123 file open for the next tutorial task.

Accessing a Linked URL
If you followed the steps in “Linking a URL to a Data Cell” on page 133, you
can access and edit the URL that you created.

To access the URL:
1. In the Asymm.123 file, select cell E5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to
the selected data cell.

3. In the Linked Objects Browser dialog box, select the URL.

4. To view the linked URL, click View/Launch.

Figure 154. Result of Editing Cell Note Contents

Figure 155. Accessing a Linked URL
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Hyperion Essbase checks the syntax of the URL. If there are syntax errors,
Hyperion Essbase displays an error message. If the URL syntax is correct,
the default Web browser launches and connects to the specified site. In this
case, the syntax for the URL is correct, so the default Web browser
launches and connects to the Hyperion Web site.

5. Close the Web browser.

To edit the URL:
1. In the Linked Objects Browser dialog box, select the URL.
2. To edit the linked URL, click Edit.

Hyperion Essbase displays the Edit URL dialog box with the selected URL
displayed.

Figure 156. Viewing a Linked URL
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3. Edit the URL location and description as show in the following
illustration:

4. To close the Edit URL dialog box and save the edits that you made, click
OK.
Hyperion Essbase saves the edits to the URL on the server.

5. To view the new URL, click View/Launch.
The Web browser launches and connects to the new URL.

Figure 157. Preparing to Edit the Contents of a Linked URL

Figure 158. Editing the Contents of a Linked URL
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6. Close the Web browser.
7. To close the Linked Objects Browser dialog box, click Close.
8. Close the Asymm.123 file without saving it.

Connecting to Multiple Databases

Hyperion Essbase supports simultaneous access to multiple databases. The
databases can be in different applications and can be stored on different
servers. In Lotus 1-2-3, you can open multiple worksheets, each of which can
be connected to a different database. An individual worksheet can access only
one database at a time. Use the Connect command from the Essbase menu to
switch the connection between databases.

Note: Depending on the status of production applications at your site, you
may not have access to additional applications or databases. Check
with the Hyperion Essbase system administrator if you need access to
other applications.

Figure 159. Viewing an Edited URL
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For this tutorial, you do not need to connect to another database.

To access multiple databases, use the following procedure:

1. Select Essbase > Connect.

2. In the Essbase System Login dialog box, select the server you want to access from the Server list
box (or type in the name of the server).

3. Press Tab to move to the Username text box and type your username.

4. Press Tab to move to the Password text box and type your password.

5. Click OK to connect to the server.

When the server connection is complete, a list of available application and database pairs appears
in the Application/Database list.

6. Double-click the Application/Database pair that you want to connect to in the
Application/Database list. Alternatively, you can select the Application/Database pair and click OK.

If the application is not already running, Hyperion Essbase automatically starts it. There may be a
brief pause as the application loads; the time required to start an application depends on number of
databases, the sizes of the databases, and the sizes of the indexes of the databases contained within
the application.

7. Open a new worksheet and repeat the steps to connect to additional databases. You can open one
database at a time per worksheet.

For information on connecting to multiple databases from Hyperion Essbase
Query Designer, refer to “Chapter 3. An Advanced Hyperion Essbase Tutorial”
on page 83.

Viewing Active Database Connections
If you frequently connect to multiple databases, you may need to check the
active database for each worksheet. There are two ways to view the database
connection status:
v The Style tab of the Essbase Options dialog box contains a Connection

Information text box. This box displays connection information for the
active worksheet.

v The Hyperion Essbase Disconnect dialog box lists all active worksheets and
their connection information. This dialog box also enables you to disconnect
one or more worksheets from their respective databases.

Accessing Linked Partitions

Linked partitions are part of the Hyperion Essbase Partitioning product. They
provide the ability to link Hyperion Essbase databases that contain different
dimensions without losing access to all dimensions of both databases. If your
organization has purchased and implemented the partitioning product, you
can take advantage of its powerful capabilities. The Hyperion Essbase Database
Administrator’s Guide describes how to design and implement a linked
partition. Hyperion Essbase Application Designer usually sets up partitioning.
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Note: The Partitioning product also allows the Hyperion Essbase application
designer to set up transparent or remote partitions. For more
information on partitioning, see the Hyperion Essbase Database
Administrator’s Guide .

You can set visual cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. You have
two options for accessing a linked partition from a data cell in Hyperion
Essbase Spreadsheet Add-in:
v Select the cell and select Essbase > Linked Objects.
v Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Hyperion Essbase Spreadsheet Add-in
online help.

When you select Essbase > Linked Objects from a linked partition cell,
Hyperion Essbase completes the following actions:
v Hyperion Essbase displays the Linked Objects Browser dialog box, which

contains a list of possible partitions to access. From this dialog box, select
the partition to connect to.

Note: The Linked Objects Browser dialog box may also contain a list of
linked reporting objects, such as cell notes and external files. For
more information, see “Using Linked Reporting Objects” on page 128.

v After you select a partition, Hyperion Essbase creates a new worksheet that
contains corresponding members and dimensions for the cell in the linked
partition.

Note: Hyperion Essbase does not preserve formulas across partitions.
v Hyperion Essbase retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more
information on the new worksheet.

Note: The Sample Basic database that you are using for this tutorial does not
contain a linked partition.
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If the Hyperion Essbase application designer has a linked partition set up, use the following procedure
to access the linked partition in Hyperion Essbase Spreadsheet Add-in:

1. Locate a linked object cell, as indicated by the style applied to the cell.

2. Select Essbase > Linked Objects to open the Linked Objects Browser dialog box.
Note: Alternatively, select the Enable Linked Object Browsing check box in the Essbase Options
dialog box to enable double-clicking to view linked objects.

3. Select the partition that you want to connect to and click View/Launch.

Hyperion Essbase creates a new worksheet that contains the dimensions and members for the cell in
the linked partition.

Note: You need to have the proper privileges to access a linked partition. If
your user account and password match the account information for the
linked partition, Hyperion Essbase establishes a connection with the
linked partition. Otherwise, Hyperion Essbase displays the Essbase
System Login dialog box for you to enter the user account and
password information manually.

Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve data into the worksheet, you
can use Hyperion Essbase Spreadsheet Add-in to change values, enter
formulas, and format data. Hyperion Essbase is also designed to permit
multiuser, concurrent database access and update. Depending on your
security privileges, you may be able to modify all data values or a certain
subset of values. To recognize cells to which you have read/write access,
apply a visual cue, or style, to the cells. For more information, see “Applying
Styles to Data Cells” on page 51. To update data from a worksheet, you must
lock the database area that contains the values that you want to change.
Locking prohibits other users from changing the data that you want to
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update. Other users can retrieve locked data but cannot lock or change the
data. You have exclusive update rights to that area.

Note: You cannot update attribute-related data on the server because attribute
data is always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:
v The Retrieve & Lock command retrieves data into the worksheet while

locking the corresponding data area on the server. When you perform a
subsequent retrieval, Hyperion Essbase automatically unlocks the previous
data values.

Note: The Retrieve & Lock command is not supported with Dynamic Time
Series members.

v The Lock command locks information that you have already retrieved.
When you perform a subsequent retrieval, Hyperion Essbase automatically
unlocks the previous data values.

v The Update Mode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send
command on the Hyperion Essbase menu. After updating the server, the Send
command automatically unlocks data (unless you are in Update Mode). You
must disable Update Mode to stop locking blocks automatically.

You can unlock data blocks in two ways:
v The Unlock command unlocks all blocks that you have locked.
v The server automatically unlocks data blocks that have been locked for the

maximum time allowed as defined by the Hyperion Essbase system
administrator. Automatic unlock ensures that blocks are not locked for
extended periods of time.

P&l.123, a sample Lotus 1-2-3 file installed as part of the default Hyperion
Essbase installation, illustrates how to update data on the server.

To view the P&l.123 worksheet:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the P&l.123 file.
3. Select Essbase > Retrieve & Lock.

Hyperion Essbase retrieves data and locks the appropriate area of the
database.
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4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.
Hyperion Essbase changes the affected data values.

5. Select Essbase > Send to update the server with the new values.
Hyperion Essbase updates the server and unlocks the data blocks.

6. Close P&l.123 without saving it.

Note: Hyperion Essbase provides a worksheet update logging facility that
tracks and logs all data updates sent from Hyperion Essbase
Spreadsheet Add-in to the server. The Hyperion Essbase system
administrator enables this facility for extra protection against data loss.
For more information, see the Hyperion Essbase Database Administrator’s
Guide or contact the Hyperion Essbase system administrator.

Figure 160. P&L Worksheet After Retrieve & Lock

Figure 161. P&L Worksheet After Sending New Values to the Server
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Calculating a Database

Sending updated data to the server does not automatically recalculate the
database. If you have the appropriate security privileges to perform database
calculations, you can calculate the database from Hyperion Essbase
Spreadsheet Add-in with the Calculation command. For this tutorial, you will
not actually calculate the Sample Basic database. For more information on
Hyperion Essbase calculations, see the Hyperion Essbase Database
Administrator’s Guide.

CAUTION:
Do not perform any calculation operations for this tutorial.

When you select Essbase > Calculation, Hyperion Essbase displays the
Essbase Calculation dialog box.
The Essbase Calculation dialog box contains the following items:

v The Connection Information text box displays the active database
connection.

v The Select Calc Script list box contains the server-based calculation scripts
to which you have access.

v The Database State text box indicates the current calculation state of the
database. The following states are possible:
– Calculating—indicates that a calculation is currently running on the

database.
– Data values have been modified since the last calculation—indicates that

data values have changed since the database was last calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.

Figure 162. Essbase Calculation Dialog Box
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– No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or a calculation of any subset of the database.
CAUTION:
If the last calculation was performed on a subset of the data, the entire
database may not have been calculated since values last changed. To
ensure that the results of calculations are up-to-date, you may want to
run a calculation of the entire database. For more information, contact
the Hyperion Essbase system administrator.

Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applications is to send
worksheets to various functional areas of an organization. After the
worksheets have been distributed, the recipients can review the contents,
make modifications, and send updates back to the distributor. Using the
Hyperion Essbase Cascade feature, you can create multiple worksheet files
based on a single database view. You can specify at what level of detail you
want to replicate the worksheets to tailor the information to each recipient’s
needs.

The Sample Basic database contains data for beverage products sold in
different states across the U.S. For example, assume that you want all product
managers to review and respond to a proposed budget and to return their
changes to the finance department. We must create a worksheet for each
combination of budget and P&L data to distribute to the product managers
for their respective products.

To create this set of worksheets:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the P&l.123 file. This

file contains the data that you need to replicate for each worksheet.
3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set
for this file in the Essbase Options dialog box. In this example, product
200 changes to Root Beer, which is its preassigned alias.

4. Select Central (in cell B1) and Root Beer (in cell B2) as the members to be
represented in the resulting worksheets.

5. Select Essbase > Cascade.
Hyperion Essbase displays the Essbase Cascade Options dialog box.

6. Click the Cascade Information tab.
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The Cascade Information page contains the list of members that you
selected and the options for specifying the level at which the selected
members are retrieved into the cascaded worksheets.

Note: For more information on each option, see the Hyperion Essbase
Spreadsheet Add-in online help.

7. Select Central in the Member list box, and select Same levelin the
Choose Level for Selected Member option group.

8. Select Root Beer in the Member list box, and select Next level (the
default setting).

The replicated, or cascaded, spreadsheet reports now provide data for
members at the same level as Central (East, West, and South) and for
members at the level below Root Beer (Old Fashioned, Diet Root Beer,
Sarsaparilla, and Birch Beer).

9. Click the Destination Options tab.
10. In the Destination Directory text box, enter C:\temp as the name of the

directory where you want the cascaded worksheets to be stored.
You can also click Browse to select a destination directory from the
Browse dialog box.

11. In the Destination Types option group, select Separate Workbooks (the
default setting) to create separate Lotus 1-2-3 files for each cascaded
worksheet.
You can also tell Hyperion Essbase to create only one workbook with
separate worksheets for each cascaded report, or you can send the
cascaded reports to the printer.

Figure 163. Cascade Information Tab
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12. In the File Information option group, click Overwrite Existing Files (the
default setting). This option tells Hyperion Essbase to overwrite any
cascaded worksheets with the same file name.
You can also select Open Created Files to open each cascaded file in
Lotus1-2-3 as it is created.
CAUTION:
Depending on the number of replicated worksheets that you want to
create, the Cascade command can create more worksheets than can be
stored in the memory of your computer. Therefore, the Open Created
Files option should not be used when you are replicating large
numbers of worksheets.

13. In the Naming Information option group, enter BUD in the Prefix text box.

When you assign a prefix or suffix in the Naming Information option
group, the worksheet files that are generated as a result of executing the
Cascade command are named with the prefix or suffix that you specify.
The default is to generate worksheet names that are numbered 1 through
n, where n is the total number of worksheets created. The syntax for the
file names is PrefixnSuffix.123. If you do not specify a prefix or suffix,
Hyperion Essbase creates the worksheets , 2.xls1.123, 2.123, and so on.
If you are creating a single workbook, the same naming convention is
used for the worksheet tab names within the workbook.

CAUTION:
Do not specify a prefix and suffix combination that leaves no
characters free for Hyperion Essbase to create unique file names. If file
names are duplicated, Hyperion Essbase overwrites the duplicate file
name with the last cascaded worksheet.

Figure 164. Destination Options Tab
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14. Click the Format Options tab.
15. To copy the formatting of the source worksheet into each cascaded

worksheet, select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Hyperion
Essbase and the cell formatting that you set using the worksheet. It
does not copy formulas, column formatting, worksheet formatting,
or graphs.

In the Header and Footer text boxes, specify a header or footer name to
be used for all of the cascaded worksheets.

16. In the Sheet Formatting group, select the Suppress Missing Rows check
box so that rows containing only #Missing values are not replicated.

17. In the Table of Contents group, select the Include Table of
Contentscheck box to create a text file that lists all replicated worksheets,
their creation dates, and their member content.
By default, Hyperion Essbase names the Table of Contents file with the
extension .lst.

18. Click OK to create the cascaded worksheets.
Hyperion Essbase rapidly creates the cascaded worksheets (nine total
worksheets in this example). As each worksheet is created, it is
automatically saved, closed, and logged in the Table of Contents. Each
individual file is saved in the directory that you specified, named
Bud1.xls through Bud9.xls. When the Cascade is completed, Hyperion
Essbase returns you to the original worksheet view (that is, the source
file).

Figure 165. Format Options Tab
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19. Using a text editing application, open the Table of Contents file from the
destination directory that you specified earlier. This file is named
BUD0.LST and contains a list of all cascaded worksheets.

20. Select File > Close to close the worksheet.
You do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a
product. Type in the attribute names in the top row of the
worksheet. Select the attribute names and select Essbase >
Cascade. Proceed as described in the above example.

Working with Currency Conversions

Organizations with offices in different countries generally do business in the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currencies to a common currency for
consolidation and analysis.

The Hyperion Essbase Currency Conversion product can be purchased
separately for Hyperion Essbase. If your organization has purchased this
product and has implemented a currency conversion application, you can take
advantage of the powerful capabilities of Hyperion Essbase Currency
Conversion. The Hyperion Essbase Database Administrator’s Guide describes how
to design and implement a currency conversion application.

The following sections provide a brief tutorial for working with currency
conversions:
v “Retrieving Currency Conversion Data” on page 154
v “Connecting to the Sample Currency Databases” on page 154
v “Performing Ad Hoc Currency Reporting” on page 156

Figure 166. Table of Contents File for Cascaded Worksheets
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Retrieving Currency Conversion Data
This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
v A main database that contains data in local and converted values
v A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from
the main database to derive converted values.The Hyperion Essbase OLAP
Server product installation includes a sample currency conversion application
(installation options) that consists of two sample databases: a main database
called Interntl and a currency rates database called Xchgrate.

The Sample Interntl database consists of five dimensions: Year, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions
are identical to the Sample Basic database. The Market dimension includes
Toronto, Vancouver, Montreal, France, Germany, Spain, and the UK. The
Scenario dimension handles different currency types (such as Actual and
Budget) in both local and converted currencies. In this database, all local
currencies are converted to the common currency of U.S. dollars.

The Sample Xchgrate database, which is a subset of the main database,
contains four dimensions:
v The CurTime dimension accommodates different exchange rates by month.
v The CurName dimension contains names of currencies from their respective

markets.
v The CurCategory dimension contains the names of the various currency

categories that may be applied to the categories of Measures. For example,
one rate is applied to Profit and Loss items and another rate is applied to
Balance Sheet items.

v The CurType dimension allows a currency database to contain rates for
different scenarios, such as Actual and Budget.

Connecting to the Sample Currency Databases
To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.
2. Select the Sample Interntl database and click OK to complete the

connection.
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The Hyperion Essbase installation also includes sample Lotus 1-2-3 files
that illustrate currency conversion concepts.

3. From the \essbase\client\sample directory, open Local.123.
The worksheet contains actual (Act) and budget (Bud) data entered in
local currencies for New York and Germany.

4. From the \essbase\client\sample directory, open Convert.123.
5. Select Essbase > Retrieve.

The worksheet contains values for Actual and Budget as they appear after
conversion.

Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Hyperion Essbase converts the values by using the exchange rates from
the Sample Xchgrate database.

Figure 167. Retrieving Local Data

Figure 168. Retrieving Converted Data Values
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6. From the \essbase\client\sample directory, open Rates.123. Connect to
the Sample Xchgrate database.

7. Select Essbase > Retrieve.

The worksheet contains all possible combinations of exchange rate scenarios,
categories, and types by month. Because this example converts to U.S. dollars
(US$), the sample file contains a base rate of 1 for US$. Therefore, the local
and converted figures remain the same for New York. Hyperion Essbase
converts the figures for Germany, however, by using data values in the
currency database, as follows:
v Hyperion Essbase divides data values from Actual by values in the Act

xchg currency type.
v Hyperion Essbase divides data values from Actual @ Bud xchg by values in

the Bud xchg currency type.
v Hyperion Essbase divides data values from Budget by values in the Bud

xchg currency type.
v Hyperion Essbase bases all figures in Convert.123 on the CurCategory of

P&L and the CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation
on exchange rates. The definition is determined by the application
designer.

Performing Ad Hoc Currency Reporting
A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. You may want to perform currency
conversions dynamically, as well. Hyperion Essbase provides this capability
with the Currency Report command. This command enables you to
interactively change the currency rates and types applied to the retrieval.

To perform an ad hoc conversion on data in the Convert.123 file:
1. From the \essbase\client\sample directory, open Convert.123.

The worksheet contains data that is already converted to U.S. dollars.

Figure 169. Retrieving Exchange Rates from a Currency Database
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2. Select Essbase > Connect and connect to the Sample Interntl database.
3. Select Essbase > Retrieve.
4. Select Essbase > Currency Report.

Hyperion Essbase displays the Essbase Currency Report dialog box.

The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains
options for currency settings, names, categories, and years. For more
information on these options, see the Hyperion Essbase Spreadsheet
Add-in online help.

Note: The dimension names CurName, CurType, and CurCategory are
default names for a currency database. The application designer can
use different names for any of these dimensions.

5. Select the currency settings that you want to apply.
For example, select CN$ from the CurName list box and Bud xchg from
the CurType list box.

6. Click Apply to apply the settings.
7. Select Essbase > Retrieve to refresh the data in the worksheet with the

results of the ad hoc conversion.

Figure 170. Essbase Currency Report Dialog Box
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Hyperion Essbase converts the New York and Germany figures to
Canadian dollars (CN$).

8. Click the Clear button in the Essbase Currency Report dialog box to
disable currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the
retrieval. Converted data values may not always balance, because
the ad hoc conversion is performed on values that were previously
calculated or previously consolidated in another currency.

If values must balance and verify, they must be converted to the target
currency in the database, calculated, and retrieved. This procedure differs
from the ad hoc currency conversion retrievals described in this section; see
the Hyperion Essbase system administrator for more information.

Figure 171. Performing an Ad Hoc Currency Conversion
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Chapter 4. Using Hyperion Integration Server Drill-Through

Hyperion Integration Server is a product that works with Hyperion Essbase,
Microsoft Excel, and Lotus 1-2-3. Integration Server is a suite of tools and data
integration services that serve as a bridge between relational data sources and
the Hyperion Essbase OLAP Server. Hyperion Integration Server
Drill-Through is one of these tools. Drill-Through enables you to view and
customize spreadsheet reports that display data retrieved from relational
databases. Your organization must license Hyperion Integration Server for you
to use the Drill-Through tool.

This chapter provides:
v A brief overview of the Drill-Through feature
v A description of the sample database, Lotus1-2-3 file, and Drill-Through

report used for the tutorial
v A tutorial that walks you through tasks for using Drill-Through

What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic
data, some data elements that are required for analysis are better suited to
remain in the relational structure, in a relational database. The scope of data
residing in a Hyperion Essbase database is typically at a summary level,
where data is summarized and calculated for planning and analysis. Detailed,
transactional data usually is not examined during the planning and analysis
of a business.

For example, say you are using Hyperion Essbase to analyze retail sales for
the first quarter in the Eastern region. Detailed data, such as a list of
customers who purchased a particular product in a particular size, is not used
during the normal course of analyzing business performance. However, as
you analyze sales results, you may want to view more detailed information.
Drill-Through is a tool that enables you to drill from the summarized and
calculated data stored in your organization’s Hyperion Essbase OLAP Server
into detailed data stored in a relational database.

The database administrator predefines a data mapping for you from Hyperion
Essbase to the relational source. For example, the Hyperion Essbase members
East, West, South, and Central might map to a field called Region in a
relational database. As you navigate through data in the spreadsheet,

© Copyright IBM Corp. 1998, 2000 159



Hyperion Essbase knows how the current data maps to the relational source.
For example, suppose you select cell E4 in the following sheet:

The dimensional attributes of the cell are: East, Feb, 1996, Marketing, Bottles,
Retail, and Colas. The combination of one or more of these attributes becomes
the basis of a Drill-Through query that returns data from the relational source.

From Hyperion Essbase Spreadsheet Add-in, you can access a predefined
Drill-Through report that is based on the dimension or member intersections
of Hyperion Essbase data cells in the sheet. Using an Integration Server tool
called Hyperion OLAP Desktop Model interface, an administrator at your
organization sets up Drill-Through reports for you to access; that is, each
Drill-Through report is already defined in terms of what to retrieve from the
relational source.

Access Drill-Through reports from the Hyperion Essbase Spreadsheet Add-in
Linked Objects Browser dialog box. When you select a Drill-Through cell in
the sheet and choose Essbase > Linked Objects, the Linked Objects Browser
dialog box displays an entry for Drill-Through that you can select and launch.

Figure 172. Example of Drill-Through Sheet
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Identify which cells in the sheet have Drill-Through reports associated with
them, you can define a style for cells tagged as Drill-Through. For more
information, see “Accessing Drill-Through from the Spreadsheet” on page 169.

What Is the Drill-Through Wizard?
Integration Server Drill-Through reports are predefined by an administrator at
your organization for you to view or customize. The person who develops a
report determines whether or not the report can be customized by
Drill-Through users. If a report can be customized, use the Integration Server
Drill-Through Wizard to customize it. The Drill-Through Wizard is a graphical
user interface that steps you through the following customization tasks:
v Selecting columns to retrieve from the relational data source

Decide which columns from the predefined report you need to see.
v Selecting the display order for columns

Change the default display order of columns across the sheet.
v Selecting a sort order for data

Choose an ascending or descending sort order for a particular column for
example, sort a list of managers in alphabetical order.

v Selecting data filters
Define a filter on a column so that only data meeting certain criteria is
retrieved.

Figure 173. Linked Objects Browser Dialog Box with Drill-Through Entry
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Before You Start

Before starting the tutorial, you should have a working familiarity with the
Hyperion Essbase product through the use of the Hyperion Essbase
Spreadsheet Add-in interface. As a prerequisite, you should review
“Chapter 2. A Basic Hyperion EssbaseTutorial” on page 11 and “Chapter 3. An
Advanced Hyperion Essbase Tutorial” on page 83 of this guide.

A sample Hyperion Essbase database is the basis for the examples in this
tutorial. The database administrator creates this sample Hyperion Essbase
database using the sample metaoutline supplied with Integration Server. For
more information, see the Hyperion Integration Server Desktop OLAP Model
User’s Guide. A sample Lotus 1-2-3 file, Dtreport.wk4, contains a sheet with the
appropriate member intersections for the sample Drill-Through report. For
more information on the sample database,Lotus 1-2-3 file, and Drill-Through
report, see “About the Samples Used in This Tutorial” on page 168.

If you plan to follow the examples in a live working session, check with the
person at your organization who installs the Hyperion Integration Server
product family for information on the sample database needed for
Drill-Through, and to which Hyperion Essbase server you should connect.

Before starting the tutorial, make sure you meet the following requirements:
v You must install the following components on your client PC:

– A 32-bit version of Lotus 1-2-3
– Hyperion Essbase Spreadsheet Add-in forLotus 1-2-3
– Drill-Through

The Drill-Through module is installed automatically when you install
Hyperion Essbase Spreadsheet Add-in. This module is transparent until
you invoke it from the Linked Objects Browser. For more information on
installation, contact the Hyperion Essbase System Administrator.

v The Hyperion Essbase System Administrator must install the Hyperion
Essbase server.

v You must have access to the Hyperion Essbase Integration Server and to the
Hyperion Essbase server. For more information, contact the Hyperion
Essbase System Administrator or the person who administers Integration
Server at your organization.

v You must have access to the underlying relational database (typically using
a user name and password that are different from Hyperion Essbase). For
more information, contact the Hyperion Essbase System Administrator or
the person who administers Hyperion Essbase Integration Server at your
organization.

v Make sure that the sample Lotus 1-2-3 file, Dtreport.wk4, is available in the
\Essbase\Client\Sample directory.
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v The sample database that contains the Drill-Through report must be set up
and running. The sample Drill-Through report used in this tutorial (called
“Promotion Media Mix for Cities”) is available with the sample database.
Contact the person at your organization who installs Integration Server to
find out the name of the sample database needed for Drill-Through.

Note: For more information on Integration Server installations, see the
Hyperion Integration Server Desktop Installation Guide. For more
information on Hyperion Essbase installations, see the Hyperion Essbase
Installation Guide.

Keep in mind the following guidelines during the tutorial:
v Each tutorial task builds upon the previous task and tasks must be followed

in succession.
v Tasks that should not be performed as part of the tutorial appear in gray

boxes. These tasks are included for your reference. You can find more
information on these tasks in the Integration Server Drill-Through online
help.

v The examples used in this tutorial are based on the sample database that is
included with the Integration Server installation. Contact the person at your
organization who installs Integration Server for information about accessing
the sample database.

v Set the options in the Hyperion Essbase Options dialog box as described in
the following section, “Setting Hyperion Essbase Options” If the option
settings are different, the illustrations presented in this chapter may not
match the spreadsheet view.

v If you make a mistake during the tutorial, choose Essbase > FlashBack to
return to the previous spreadsheet view.

Setting Hyperion Essbase Options
Before you begin the tutorial, make sure that the spreadsheet options are set
to the initial settings as illustrated in the following figures. If the option
settings are different, the illustrations presented in this chapter may not match
the spreadsheet view.

Note: For information about each option in the Hyperion Essbase Options
dialog box, click Help to see the Hyperion Essbase Spreadsheet Add-in
online help.

1. From the Spreadsheet menu, choose Essbase > Options.
2. In the Essbase Options dialog box select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:
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4. Select the Zoom tab.
5. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 174. Initial Settings for Display Options
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6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 175. Initial Settings for Zoom Options
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8. Select the Style tab.
9. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 176. Initial Settings for Mode Options
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10. Select the Global tab.
11. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 177. Initial Settings for Style Options
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12. Click OK to save the settings for this session and close the Essbase
Options dialog box.

About the Samples Used in This Tutorial
The sample database used for this tutorial contains the following dimensions:
Scenario, Products, Package, Markets, Accounts, Time, and Channel. The
sample Lotus 1-2-3 file provides a particular view from this database:
For this spreadsheet view, detail-level data exists in a relational data

source—data that is not available from Hyperion Essbase. For example, the
relational source contains columns of data for cities, seasons, and different
types of media (for example, print, radio, and so forth). This tutorial walks

Figure 178. Initial Settings for Global Options

Figure 179. View from Sample Database
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you through a sample Integration Server Drill-Through session, where you
will drill down from the data shown above into the detail data from the
relational source.

This tutorial uses a sample Hyperion Drill-Through report called “Promotion
Media Mix for Cities.” As with all Hyperion Drill-Through reports, this report
has been predefined to retrieve specific columns from the relational source.
You will use the Drill-Through Wizard to customize the predefined report.

Note: The sample file also contains a second sample report, called “City
Demographics,” that you can use for Drill-Through practice.

Using Drill-Through

Drill-Through consists of the following tasks:
v Accessing Drill-Through from Hyperion Essbase Spreadsheet Add-in
v Selecting Drill-Through Reports to View or Customize
v Selecting and Ordering Columns
v Sorting Data
v Filtering Data

The following sections describe each of these tasks and step you through a
live working Drill-Through session.

Accessing Drill-Through from the Spreadsheet
From Hyperion Essbase Spreadsheet Add-in, you can access detail-level
Drill-Through reports that are based on the member intersections of Hyperion
Essbase data cells in the sheet. Each Drill-Through report has been predefined
by an administrator at your organization; that is, each Drill-Through report is
already set up to retrieve specific columns from the relational source, sort data
in these columns in specific ways, and so forth. Using the Drill-Through
Wizard, you can customize these predefined Drill-Through reports to retrieve
only the data you want, displayed in a specific way.

To access the predefined Drill-Through report, double-click a Drill-Through
cell in the spreadsheet (or select a range of cells and choose Essbase > Linked
Objects). To help identify which cells in the sheet are associated with
Drill-Through reports, you can set styles for cells tagged as Drill-Through.
When you double-click a Drill-Through cell, Hyperion Essbase displays the
Linked Objects Browser dialog box, which displays a Drill-Through report
entry. A single cell can have multiple reports associated with it. The Linked
Objects Browser dialog box also displays entries for linked partitions and
other linked object types (for example, cell notes and application files). After
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you view or customize the Drill-Through report, the Hyperion Essbase
retrieves data from the relational source and displays the results in a new
spreadsheet.

Before starting the Drill-Through tutorial, you will:
1. Open a sample Lotus 1-2-3 file that contains the appropriate member

intersections from the sample database for the Drill-Through report. This
file, Dtreport.wk4, is provided as part of the default Hyperion Essbase
installation

2. Set a style for data cells that have Drill-Through reports associated with
them.

To access the sample file and sample database:
1. Start Lotus 1-2-3.
2. Choose File > Open and open the Dtreport.wk4 file from the

Essbase\Client\Sample directory.
The sample file should look like this:

The sample file shows data for specific members of a Hyperion Essbase
database. From this view, a predefined Drill-Through report exists for all
member intersections in the sheet. Using Drill-Through, you can access
this report and customize it so that the Integration Server retrieves only
the data you need and displays the data in the desired format.

3. Select Essbase > Connect and connect to the appropriate sample database.

Note: For information on the sample database, contact the person at your
organization who installs Integration Server.

4. Select Essbase > Options and select the Style tab.
5. In the Data Cells option group, click the Integration Server

Drill-Through check box and click Format.
Hyperion Essbase displays the Font dialog box.

Figure 180. Sample Lotus 1-2-3 File for Drill-Through
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6. Select Bold Italic from the Font style list box.
7. Select Red from the Color drop-down list, and click OK.

Note: Hyperion Essbase displays an example of the selected style in the
Sample box.

8. Click OK to close the Essbase Options dialog box.
9. Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample Drill-Through report is associated with every
member intersection in the sheet, so all cells are now displayed in red,
bold, italic font.

To access the sample Drill-Through report from the Hyperion Essbase
Spreadsheet Add-in:

10. Select any Drill-Through cell; for example, cell E4.

Figure 181. Sample Style for Integration Server Drill-Through Data Cells

Figure 182. Sample Lotus 1-2-3 File with Drill-Through Style Applied
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Note: You can also select a continuous range of cells in the sheet to
display all Drill-Through reports associated with cells you select.
In this example, we have only one Drill-Through report attached to
the range of cells.

11. Select Essbase > Linked Objects to open the Linked Objects Browser
dialog box.
Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to
double-click a linked object cell to open the Linked Objects Browser
dialog box. This option works only with single-cell selection. If you select
a range of cells, use the Essbase > Linked Objects menu command.

12. Select the Drill-Through report entry and click View/Launch.
Hyperion Essbase launches Drill-Through and displays the Select
Drill-Through Report dialog box.

Figure 183. Selecting a Drill-Through Cell

Figure 184. Linked Objects Browser Dialog Box with Drill-Through Entry Selected
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Note: If the Integration Server is not running, Drill-Through does not
launch properly. For more information, contact the Hyperion
Essbase System Administrator.

13. If you are prompted with the Drill-Through Login dialog box to connect
to the Integration Server and the relational data source, enter the
appropriate connection information. The person at your organization who
administers Integration Server and develops Drill-Through reports should
provide you with this information.

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized,
Drill-Through generates the report and immediately displays the
results in the spreadsheet. The person at your organization who
develops Drill-Through reports specifies whether you can
customize a report and whether you need to log in to the
Integration Server and relational data source.

14. Follow the steps in the next section, “Selecting Drill-Through Reports to
View or Customize” to select a report to customize.

Selecting Drill-Through Reports to View or Customize
After you launch Drill-Through from the Linked Objects Browser dialog box,
the Integration Server displays the Select Drill-Through Report dialog box if:
v More than one Drill-Through report exists for the cell or cell range that you

select in the spreadsheet, or
v Only one report exists, but you have the option of customizing it using the

Drill-Through Wizard.
The Select Drill-Through Report dialog box displays the list of
Drill-Through reports available for the cells you select in the spreadsheet.

Figure 185. Select Drill-Through Report Dialog Box
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Depending on how a report is defined in OLAP Desktop Model interface,
you may have access only to view, not customize, the report.

The sample report used for this tutorial is the Promotion Media Mix for Cities report. You will use the
Drill-Through Wizard to customize this sample report. To execute a predefined Drill-Through report
without customizing it, you would:

1. Select the report that you want to view from the Available Reports list box.

2. Click Execute.

The Integration Server retrieves the data from the relational source and displays the results in a new
spreadsheet. The new sheet is added before the current sheet.

To customize the sample Drill-Through report:
1. Select the Promotion Media Mix for Cities report from the Available

Reports list box.

2. Click Customize.

Note: The Customize button may be enabled or disabled for any given
report, depending on how the report was defined in OLAP Builder.

The Integration Server displays the first screen of the Drill-Through
Wizard.

Figure 186. Selecting the Sample Drill-Through Report
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3. Click Next to display the Select Columns and Display Order dialog box.

4. Follow the steps in the next section, “Selecting and Ordering Columns”, to
select and order rows for the customized report.

Selecting and Ordering Columns
Using the Drill-Through Wizard, you can customize predefined Drill-Through
reports. The first task in the Drill-Through Wizard is selecting and ordering

Figure 187. Drill-Through Wizard Dialog Box, Introductory Screen

Figure 188. Select Columns and Display Order Dialog Box
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columns to retrieve from the relational database. These columns contain
detailed information that is not available in the Integration Server database.

In the Select Columns and Display Order dialog box, you can select which
columns you want the Integration Server to retrieve from the relational data
source. From this dialog box, you can also specify how the columns are
displayed in the resulting report.

The Available Columns list box displays a list of columns available from the
relational data source for this report (as defined in OLAP Desktop Model
interface). The Selected Columns list box displays the columns from the
Available Columns list box in expanded form. You can remove columns from
the Selected Columns list box to exclude them from the Drill-Through report.

In this example, the columns from the Available Columns list box are selected
for inclusion in the sample Promotion Media Mix for Cities report. These
columns are displayed in expanded form in the Selected Columns list box. In
this task, you will remove several of the selected columns from the
Drill-Through report:
1. In the Selected Columns list box, select the TIME.PRINTMEDIA,

TIME.TV, TIME.RADIO, and TIME.DIRECT columns.
Hold down the Ctrl key to select multiple columns at once.

2. Click

Figure 189. Selecting Columns to Remove From the Drill-Through Report
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to move the selected columns from the Selected Columns list box back to
the Available Columns list box.

To move a column from one list box to another, click

or

. To move all columns from one list box to another, click

or

.
3. To rearrange the display order of columns, select each PRODUCTS column

(one at a time) in the Selected Columns list box and click Move Up twice
to move each column up above the MARKETS columns.
The customized report will display the columns in the Selected Columns
list box in the order in which they appear. The PRODUCTS columns will
appear as the first (left-most) columns, then the MARKETS columns, and
so forth.

Figure 190. Rearranging the Display Order of Columns
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4. Click Next to display the Select Data Sort Order dialog box, and follow
the steps in the following section, “Ordering Data” to further customize
the report.

Note: When you finish customizing the report, click Finish at any time to
generate the report and view the results in a new sheet. The new sheet
is placed before the current sheet.

Ordering Data
In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the data in a column. Sort order determines the
order in which rows will be displayed in the Drill-Through report. For
example, you can sort the contents of a MARKETS.CITY column in ascending
order, which presents the cities in alphabetical order in the Drill-Through
report.

To define the sort order of rows in the Drill-Through report:
1. In the Available Columns list box, select the SALESINVACT.MARKETING

column.
The columns in the Available Columns list box are those that you selected
in “Selecting and Ordering Columns” on page 175. The columns in the
Column list box are those for which a sort order has already been defined
in OLAP Builder.
If a data sort order was selected when the report was created in OLAP
Desktop Model interface, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.

2. Click

to move the SALESINVACT.MARKETING column to the Column list box
so that you can define a sort order for the column.

To move a column from one list box to another, click

or

. To move all columns from one list box to another, click

or
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.

3. Rearrange the display order of columns in the Column list box so that the
columns are grouped as follows:
a. Click MARKETS.CITY and click Move Up twice.
b. Click SALESINVACT.MARKETING and click Move Up twice.

4. In the Column list box, double-click the SALESINVACT.SALES column to
change the data sort order from Descending to Ascending so that SALES
values are displayed in chronological order in the Drill-Through report.
The Integration Server now sorts the columns it retrieves first by state (in
alphabetical order), then by city (in alphabetical order), then by sales (in
chronological order).

Figure 191. Moving a Column to the Column List Box for Sorting
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5. Click Next to display the Select Data Filters dialog box, and follow the
steps in the following section, “Filtering Data” to further customize the
report.
To change the data sort order for multiple columns at one time:

a. Hold down the Ctrl key and select the desired columns from the Column list box.

b. Click Order By. The Integration Server displays the Order By dialog box.

c. Select Ascending or Descending and click OK to return to the Selecting Data Sort Order dialog
box.

Filtering Data
You can apply filters to determine what the Integration Server retrieves for the
Drill-Through report. For any given column, you may want to retrieve only
data that meets certain conditions. For example, the MARKETS.CITY column

Figure 192. Selecting the Data Sort Order
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in the sample database contains many cities. In the sample Drill-Through
report, if you did not apply a filter to this list of cities, the Integration Server
would retrieve all cities in the East from the relational source, because the
sample Drill-Through report applies to the entire Eastern region. In this
section, you will apply a filter to the MARKETS.CITY column so that only
specific Eastern cities are included in the report.

To define a filter:
1. Select the MARKETS.CITY column from the Column list box.

The columns in the Column list box are those that you selected in
“Selecting and Ordering Columns” on page 175.

Note: If there is a filter already attached to the column, it is displayed in
the Condition list box. The full string of the filter is displayed in
the lower Condition text box.

2. With the MARKETS.CITY column selected, click Add.
The Integration Server displays the Set Filter on Column dialog box.

Figure 193. Select Data Filters Dialog Box
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3. Select the CITY column from the Column drop-down list box.
The column displayed in the Column drop-down list box is the one that
you selected in “Filtering Data” on page 180.

4. Select the in operator from the Operator drop-down list box.

Note: For more information on filter operators, see the Integration Server
Drill-Through online help.

5. Click the Browse

button to open the Select Filter Values from the List dialog box, which
lists all possible values for that column.

The Integration Server displays the Select Filter Values from the List
dialog box.

Note: The Integration Server retrieves these values directly from the
relational data source. If the relational data source contains many
values, the Integration Server confirms if you want to view them
all before it retrieves them from the data source.

6. Hold down the Ctrl key, select Andover, Boston, and Cape Cod, and click
OK.
You can select multiple values at one time only if you have selected In or
Not In as the filter operator.

Figure 194. Set Filter on Column Dialog Box
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7. Select And from the Add Type option group.
8. Click Add to add the condition to the Filters list box.

Note: For information on using multiple filter conditions, see the
Integration Server Drill-Through online help.

The Set Filter on Column dialog box should now look like this:

The filter defined above causes only Andover, Boston, and Cape Cod
data to show in the Drill-Through report.

Figure 195. Selecting Filter Values from the List

Figure 196. Defining a Filter for a Column
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9. Click OK to return to the Select Data Filters dialog box.

Note: You can also create a filter by typing the filter conditions directly
into the Filters list box. For more information, see the Integration
Server Drill-Through online help. To delete a filter, select the filter
and click Clear. To delete all filters, click Clear All.

10. Click Finish.
The Integration Server generates the customized Drill-Through report and
displays the results in a new spreadsheet. The new sheet is added to the
workbook before the current sheet.

In this sample, the customized Drill-Through report reflects the specifications
that you set using the Drill-Through Wizard:
v The TIME.PRINTMEDIA, TIME.TV, TIME.RADIO, and TIME.DIRECT

columns are excluded.
v The columns are displayed across the sheet in the order that you specified

in the Selected Columns list box in the Select Columns and Display Order
dialog box.

Figure 197. Result of Defining a Filter for a Column

Figure 198. Customized Drill-Through Report
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v The STATE, CITY, SALES, MARKETING, FAMILYDESC, and PRODDESC
columns are sorted in ascending order, starting with the STATE column and
proceeding to the PRODDESC column. For example, the Integration Server
first sorts the STATE column in ascending order. Because there is only one
state represented in this column (Massachusetts), the Integration Server
moves on to the CITY column and sorts its contents in ascending
(alphabetical) order. Within the SALES column, the values are sorted in
ascending (chronological) order within each city. This process continues
until all specified columns are sorted first by CITY and then in ascending
order within CITY.

v The only cities retrieved from the relational source are Andover, Boston,
and Cape Cod, as you specified in the filtering part of the Drill-Through
Wizard.

Disconnecting from Hyperion Essbase

When you finish using Drill-Through, disconnect from the Hyperion Essbase
server to free up a port on the server for other Hyperion Essbase Spreadsheet
Add-in users.

To disconnect from the server:
1. Choose Essbase > Disconnect.

Hyperion Essbase displays the Essbase Disconnect dialog box, where you
can disconnect any sheet that is connected to a database.

Note: Hyperion Essbase may return an error message when you attempt
to disconnect after using Drill-Through. If an error message is
returned, choose Essbase > Retrieve from the sheet and then
disconnect.

2. Select a sheet name from the list and click Disconnect.
3. Repeat Step 2 until you have disconnected from all active sheets.

Figure 199. Essbase Disconnect Dialog Box
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4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing Lotus 1-2-3. An
abnormal termination of an Lotus 1-2-3 session, such as a power
loss or system failure, does not disconnect your server connection.
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Appendix. Using the DB2 Library

The DB2 Universal Database library consists of online help, books (PDF and
HTML), and sample programs in HTML format. This section describes the
information that is provided, and how you can access it.

To access product information online, you can use the Information Center. For
more information, see “Accessing Information with the Information Center”
on page 201. You can view task information, DB2 books, troubleshooting
information, sample programs, and DB2 information on the Web.

DB2 PDF Files and Printed Books

DB2 Information
The following table divides the DB2 books into four categories:

DB2 Guide and Reference Information
These books contain the common DB2 information for all platforms.

DB2 Installation and Configuration Information
These books are for DB2 on a specific platform. For example, there are
separate Quick Beginnings books for DB2 on OS/2, Windows, and
UNIX-based platforms.

Cross-platform sample programs in HTML
These samples are the HTML version of the sample programs that are
installed with the Application Development Client. The samples are
for informational purposes and do not replace the actual programs.

Release notes
These files contain late-breaking information that could not be
included in the DB2 books.

The installation manuals, release notes, and tutorials are viewable in HTML
directly from the product CD-ROM. Most books are available in HTML on the
product CD-ROM for viewing and in Adobe Acrobat (PDF) format on the DB2
publications CD-ROM for viewing and printing. You can also order a printed
copy from IBM; see “Ordering the Printed Books” on page 197. The following
table lists books that can be ordered.

On OS/2 and Windows platforms, you can install the HTML files under the
sqllib\doc\html directory. DB2 information is translated into different
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languages; however, all the information is not translated into every language.
Whenever information is not available in a specific language, the English
information is provided

On UNIX platforms, you can install multiple language versions of the HTML
files under the doc/%L/html directories, where %L represents the locale. For
more information, refer to the appropriate Quick Beginnings book.

You can obtain DB2 books and access information in a variety of ways:
v “Viewing Information Online” on page 200
v “Searching Information Online” on page 204
v “Ordering the Printed Books” on page 197
v “Printing the PDF Books” on page 196

Table 2. DB2 Information

Name Description Form Number

PDF File Name

HTML
Directory

DB2 Guide and Reference Information

Administration Guide Administration Guide: Planning provides
an overview of database concepts,
information about design issues (such as
logical and physical database design),
and a discussion of high availability.

Administration Guide: Implementation
provides information on implementation
issues such as implementing your
design, accessing databases, auditing,
backup and recovery.

Administration Guide: Performance
provides information on database
environment and application
performance evaluation and tuning.

You can order the three volumes of the
Administration Guide in the English
language in North America using the
form number SBOF-8934.

SC09-2946
db2d1x70

SC09-2944
db2d2x70

SC09-2945
db2d3x70

db2d0

Administrative API
Reference

Describes the DB2 application
programming interfaces (APIs) and data
structures that you can use to manage
your databases. This book also explains
how to call APIs from your applications.

SC09-2947

db2b0x70

db2b0
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

Application Building
Guide

Provides environment setup information
and step-by-step instructions about how
to compile, link, and run DB2
applications on Windows, OS/2, and
UNIX-based platforms.

SC09-2948

db2axx70

db2ax

APPC, CPI-C, and SNA
Sense Codes

Provides general information about
APPC, CPI-C, and SNA sense codes that
you may encounter when using DB2
Universal Database products.

Available in HTML format only.

No form number

db2apx70

db2ap

Application Development
Guide

Explains how to develop applications
that access DB2 databases using
embedded SQL or Java (JDBC and
SQLJ). Discussion topics include writing
stored procedures, writing user-defined
functions, creating user-defined types,
using triggers, and developing
applications in partitioned environments
or with federated systems.

SC09-2949

db2a0x70

db2a0

CLI Guide and Reference Explains how to develop applications
that access DB2 databases using the DB2
Call Level Interface, a callable SQL
interface that is compatible with the
Microsoft ODBC specification.

SC09-2950

db2l0x70

db2l0

Command Reference Explains how to use the Command Line
Processor and describes the DB2
commands that you can use to manage
your database.

SC09-2951

db2n0x70

db2n0

Connectivity Supplement Provides setup and reference information
on how to use DB2 for AS/400, DB2 for
OS/390, DB2 for MVS, or DB2 for VM as
DRDA application requesters with DB2
Universal Database servers. This book
also details how to use DRDA
application servers with DB2 Connect
application requesters.

Available in HTML and PDF only.

No form number

db2h1x70

db2h1
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

Data Movement Utilities
Guide and Reference

Explains how to use DB2 utilities, such
as import, export, load, AutoLoader, and
DPROP, that facilitate the movement of
data.

SC09-2955

db2dmx70

db2dm

Data Warehouse Center
Administration Guide

Provides information on how to build
and maintain a data warehouse using
the Data Warehouse Center.

SC26-9993

db2ddx70

db2dd

Data Warehouse Center
Application Integration
Guide

Provides information to help
programmers integrate applications with
the Data Warehouse Center and with the
Information Catalog Manager.

SC26-9994

db2adx70

db2ad

DB2 Connect User’s Guide Provides concepts, programming, and
general usage information for the DB2
Connect products.

SC09-2954

db2c0x70

db2c0

DB2 Query Patroller
Administration Guide

Provides an operational overview of the
DB2 Query Patroller system, specific
operational and administrative
information, and task information for the
administrative graphical user interface
utilities.

SC09-2958

db2dwx70

db2dw

DB2 Query Patroller
User’s Guide

Describes how to use the tools and
functions of the DB2 Query Patroller.

SC09-2960

db2wwx70

db2ww

Glossary Provides definitions for terms used in
DB2 and its components.

Available in HTML format and in the
SQL Reference.

No form number

db2t0x70

db2t0

Image, Audio, and Video
Extenders Administration
and Programming

Provides general information about DB2
extenders, and information on the
administration and configuration of the
image, audio, and video (IAV) extenders
and on programming using the IAV
extenders. It includes reference
information, diagnostic information
(with messages), and samples.

SC26-9929

dmbu7x70

dmbu7

Information Catalog
Manager Administration
Guide

Provides guidance on managing
information catalogs.

SC26-9995

db2dix70

db2di
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

Information Catalog
Manager Programming
Guide and Reference

Provides definitions for the architected
interfaces for the Information Catalog
Manager.

SC26-9997

db2bix70

db2bi

Information Catalog
Manager User’s Guide

Provides information on using the
Information Catalog Manager user
interface.

SC26-9996

db2aix70

db2ai

Installation and
Configuration Supplement

Guides you through the planning,
installation, and setup of
platform-specific DB2 clients. This
supplement also contains information on
binding, setting up client and server
communications, DB2 GUI tools, DRDA
AS, distributed installation, the
configuration of distributed requests,
and accessing heterogeneous data
sources.

GC09-2957

db2iyx70

db2iy

Message Reference Lists messages and codes issued by DB2,
the Information Catalog Manager, and
the Data Warehouse Center, and
describes the actions you should take.

You can order both volumes of the
Message Reference in the English
language in North America with the
form number SBOF-8932.

Volume 1
GC09-2978

db2m1x70
Volume 2
GC09-2979

db2m2x70

db2m0

OLAP Integration Server
Administration Guide

Explains how to use the Administration
Manager component of the OLAP
Integration Server.

SC27-0787

db2dpx70

n/a

OLAP Integration Server
Metaoutline User’s Guide

Explains how to create and populate
OLAP metaoutlines using the standard
OLAP Metaoutline interface (not by
using the Metaoutline Assistant).

SC27-0784

db2upx70

n/a

OLAP Integration Server
Model User’s Guide

Explains how to create OLAP models
using the standard OLAP Model
Interface (not by using the Model
Assistant).

SC27-0783

db2lpx70

n/a

OLAP Setup and User’s
Guide

Provides configuration and setup
information for the OLAP Starter Kit.

SC27-0702

db2ipx70

db2ip

OLAP Spreadsheet Add-in
User’s Guide for Excel

Describes how to use the Excel
spreadsheet program to analyze OLAP
data.

SC27-0786

db2epx70

db2ep
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

OLAP Spreadsheet Add-in
User’s Guide for Lotus
1-2-3

Describes how to use the Lotus 1-2-3
spreadsheet program to analyze OLAP
data.

SC27-0785

db2tpx70

db2tp

Replication Guide and
Reference

Provides planning, configuration,
administration, and usage information
for the IBM Replication tools supplied
with DB2.

SC26-9920

db2e0x70

db2e0

Spatial Extender User’s
Guide and Reference

Provides information about installing,
configuring, administering,
programming, and troubleshooting the
Spatial Extender. Also provides
significant descriptions of spatial data
concepts and provides reference
information (messages and SQL) specific
to the Spatial Extender.

SC27-0701

db2sbx70

db2sb

SQL Getting Started Introduces SQL concepts and provides
examples for many constructs and tasks.

SC09-2973

db2y0x70

db2y0

SQL Reference, Volume 1
and Volume 2

Describes SQL syntax, semantics, and the
rules of the language. This book also
includes information about
release-to-release incompatibilities,
product limits, and catalog views.

You can order both volumes of the SQL
Reference in the English language in
North America with the form number
SBOF-8933.

Volume 1
SC09-2974

db2s1x70

Volume 2
SC09-2975

db2s2x70

db2s0

System Monitor Guide and
Reference

Describes how to collect different kinds
of information about databases and the
database manager. This book explains
how to use the information to
understand database activity, improve
performance, and determine the cause of
problems.

SC09-2956

db2f0x70

db2f0

Text Extender
Administration and
Programming

Provides general information about DB2
extenders and information on the
administration and configuring of the
text extender and on programming using
the text extenders. It includes reference
information, diagnostic information
(with messages) and samples.

SC26-9930

desu9x70

desu9
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

Troubleshooting Guide Helps you determine the source of
errors, recover from problems, and use
diagnostic tools in consultation with DB2
Customer Service.

GC09-2850

db2p0x70

db2p0

What’s New Describes the new features, functions,
and enhancements in DB2 Universal
Database, Version 7.

SC09-2976

db2q0x70

db2q0

DB2 Installation and Configuration Information

DB2 Connect Enterprise
Edition for OS/2 and
Windows Quick
Beginnings

Provides planning, migration,
installation, and configuration
information for DB2 Connect Enterprise
Edition on the OS/2 and Windows 32-bit
operating systems. This book also
contains installation and setup
information for many supported clients.

GC09-2953

db2c6x70

db2c6

DB2 Connect Enterprise
Edition for UNIX Quick
Beginnings

Provides planning, migration,
installation, configuration, and task
information for DB2 Connect Enterprise
Edition on UNIX-based platforms. This
book also contains installation and setup
information for many supported clients.

GC09-2952

db2cyx70

db2cy

DB2 Connect Personal
Edition Quick Beginnings

Provides planning, migration,
installation, configuration, and task
information for DB2 Connect Personal
Edition on the OS/2 and Windows 32-bit
operating systems. This book also
contains installation and setup
information for all supported clients.

GC09-2967

db2c1x70

db2c1

DB2 Connect Personal
Edition Quick Beginnings
for Linux

Provides planning, installation,
migration, and configuration information
for DB2 Connect Personal Edition on all
supported Linux distributions.

GC09-2962

db2c4x70

db2c4

DB2 Data Links Manager
Quick Beginnings

Provides planning, installation,
configuration, and task information for
DB2 Data Links Manager for AIX and
Windows 32-bit operating systems.

GC09-2966

db2z6x70

db2z6

Appendix. Using the DB2 Library 193



Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

DB2 Enterprise - Extended
Edition for UNIX Quick
Beginnings

Provides planning, installation, and
configuration information for DB2
Enterprise - Extended Edition on
UNIX-based platforms. This book also
contains installation and setup
information for many supported clients.

GC09-2964

db2v3x70

db2v3

DB2 Enterprise - Extended
Edition for Windows Quick
Beginnings

Provides planning, installation, and
configuration information for DB2
Enterprise - Extended Edition for
Windows 32-bit operating systems. This
book also contains installation and setup
information for many supported clients.

GC09-2963

db2v6x70

db2v6

DB2 for OS/2 Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on the OS/2
operating system. This book also
contains installation and setup
information for many supported clients.

GC09-2968

db2i2x70

db2i2

DB2 for UNIX Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on
UNIX-based platforms. This book also
contains installation and setup
information for many supported clients.

GC09-2970

db2ixx70

db2ix

DB2 for Windows Quick
Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database on Windows
32-bit operating systems. This book also
contains installation and setup
information for many supported clients.

GC09-2971

db2i6x70

db2i6

DB2 Personal Edition
Quick Beginnings

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database Personal
Edition on the OS/2 and Windows 32-bit
operating systems.

GC09-2969

db2i1x70

db2i1

DB2 Personal Edition
Quick Beginnings for
Linux

Provides planning, installation,
migration, and configuration information
for DB2 Universal Database Personal
Edition on all supported Linux
distributions.

GC09-2972

db2i4x70

db2i4
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Table 2. DB2 Information (continued)

Name Description Form Number

PDF File Name

HTML
Directory

DB2 Query Patroller
Installation Guide

Provides installation information about
DB2 Query Patroller.

GC09-2959

db2iwx70

db2iw

DB2 Warehouse Manager
Installation Guide

Provides installation information for
warehouse agents, warehouse
transformers, and the Information
Catalog Manager.

GC26-9998

db2idx70

db2id

Cross-Platform Sample Programs in HTML

Sample programs in
HTML

Provides the sample programs in HTML
format for the programming languages
on all platforms supported by DB2. The
sample programs are provided for
informational purposes only. Not all
samples are available in all
programming languages. The HTML
samples are only available when the DB2
Application Development Client is
installed.

For more information on the programs,
refer to the Application Building Guide.

No form number db2hs

Release Notes

DB2 Connect Release
Notes

Provides late-breaking information that
could not be included in the DB2
Connect books.

See note #2. db2cr

DB2 Installation Notes Provides late-breaking
installation-specific information that
could not be included in the DB2 books.

Available on
product
CD-ROM only.

DB2 Release Notes Provides late-breaking information about
all DB2 products and features that could
not be included in the DB2 books.

See note #2. db2ir

Notes:

1. The character x in the sixth position of the file name indicates the
language version of a book. For example, the file name db2d0e70 identifies
the English version of the Administration Guide and the file name db2d0f70
identifies the French version of the same book. The following letters are
used in the sixth position of the file name to indicate the language version:

Language Identifier
Brazilian Portuguese b
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Bulgarian u
Czech x
Danish d
Dutch q
English e
Finnish y
French f
German g
Greek a
Hungarian h
Italian i
Japanese j
Korean k
Norwegian n
Polish p
Portuguese v
Russian r
Simp. Chinese c
Slovenian l
Spanish z
Swedish s
Trad. Chinese t
Turkish m

2. Late breaking information that could not be included in the DB2 books is
available in the Release Notes in HTML format and as an ASCII file. The
HTML version is available from the Information Center and on the
product CD-ROMs. To view the ASCII file:
v On UNIX-based platforms, see the Release.Notes file. This file is located

in the DB2DIR/Readme/%L directory, where %L represents the locale name
and DB2DIR represents:
– /usr/lpp/db2_07_01 on AIX
– /opt/IBMdb2/V7.1 on HP-UX, PTX, Solaris, and Silicon Graphics IRIX
– /usr/IBMdb2/V7.1 on Linux.

v On other platforms, see the RELEASE.TXT file. This file is located in the
directory where the product is installed. On OS/2 platforms, you can
also double-click the IBM DB2 folder and then double-click the Release
Notes icon.

Printing the PDF Books
If you prefer to have printed copies of the books, you can print the PDF files
found on the DB2 publications CD-ROM. Using the Adobe Acrobat Reader,
you can print either the entire book or a specific range of pages. For the file
name of each book in the library, see Table 2 on page 188.
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You can obtain the latest version of the Adobe Acrobat Reader from the
Adobe Web site at http://www.adobe.com.

The PDF files are included on the DB2 publications CD-ROM with a file
extension of PDF. To access the PDF files:
1. Insert the DB2 publications CD-ROM. On UNIX-based platforms, mount

the DB2 publications CD-ROM. Refer to your Quick Beginnings book for
the mounting procedures.

2. Start the Acrobat Reader.
3. Open the desired PDF file from one of the following locations:

v On OS/2 and Windows platforms:
x:\doc\language directory, where x represents the CD-ROM drive and
language represent the two-character country code that represents your
language (for example, EN for English).

v On UNIX-based platforms:
/cdrom/doc/%L directory on the CD-ROM, where /cdrom represents the
mount point of the CD-ROM and %L represents the name of the desired
locale.

You can also copy the PDF files from the CD-ROM to a local or network drive
and read them from there.

Ordering the Printed Books

You can order the printed DB2 books either individually or as a set (in North
America only) by using a sold bill of forms (SBOF) number. To order books,
contact your IBM authorized dealer or marketing representative, or phone
1-800-879-2755 in the United States or 1-800-IBM-4YOU in Canada. You can
also order the books from the Publications Web page at
http://www.elink.ibmlink.ibm.com/pbl/pbl.

Two sets of books are available. SBOF-8935 provides reference and usage
information for the DB2 Warehouse Manager. SBOF-8931 provides reference
and usage information for all other DB2 Universal Database products and
features. The contents of each SBOF are listed in the following table:
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Table 3. Ordering the printed books

SBOF Number Books Included

SBOF-8931 v Administration Guide: Planning

v Administration Guide: Implementation

v Administration Guide: Performance

v Administrative API Reference

v Application Building Guide

v Application Development Guide

v CLI Guide and Reference

v Command Reference

v Data Movement Utilities Guide and
Reference

v Data Warehouse Center Administration
Guide

v Data Warehouse Center Application
Integration Guide

v DB2 Connect User’s Guide

v Installation and Configuration
Supplement

v Image, Audio, and Video Extenders
Administration and Programming

v Message Reference, Volumes 1 and 2

v OLAP Integration Server
Administration Guide

v OLAP Integration Server Metaoutline
User’s Guide

v OLAP Integration Server Model User’s
Guide

v OLAP Integration Server User’s Guide

v OLAP Setup and User’s Guide

v OLAP Spreadsheet Add-in User’s
Guide for Excel

v OLAP Spreadsheet Add-in User’s
Guide for Lotus 1-2-3

v Replication Guide and Reference

v Spatial Extender Administration and
Programming Guide

v SQL Getting Started

v SQL Reference, Volumes 1 and 2

v System Monitor Guide and Reference

v Text Extender Administration and
Programming

v Troubleshooting Guide

v What’s New

SBOF-8935 v Information Catalog Manager
Administration Guide

v Information Catalog Manager User’s
Guide

v Information Catalog Manager
Programming Guide and Reference

v Query Patroller Administration Guide

v Query Patroller User’s Guide

DB2 Online Documentation

Accessing Online Help
Online help is available with all DB2 components. The following table
describes the various types of help.
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Type of Help Contents How to Access...

Command Help Explains the syntax of
commands in the command
line processor.

From the command line processor in interactive
mode, enter:

? command

where command represents a keyword or the entire
command.

For example, ? catalog displays help for all the
CATALOG commands, while ? catalog database
displays help for the CATALOG DATABASE
command.

Client Configuration
Assistant Help

Command Center Help

Control Center Help

Data Warehouse Center
Help

Event Analyzer Help

Information Catalog
Manager Help

Satellite Administration
Center Help

Script Center Help

Explains the tasks you can
perform in a window or
notebook. The help includes
overview and prerequisite
information you need to
know, and it describes how
to use the window or
notebook controls.

From a window or notebook, click the Help push
button or press the F1 key.

Message Help Describes the cause of a
message and any action you
should take.

From the command line processor in interactive
mode, enter:

? XXXnnnnn

where XXXnnnnn represents a valid message
identifier.

For example, ? SQL30081 displays help about the
SQL30081 message.

To view message help one screen at a time, enter:

? XXXnnnnn | more

To save message help in a file, enter:

? XXXnnnnn > filename.ext

where filename.ext represents the file where you
want to save the message help.
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Type of Help Contents How to Access...

SQL Help Explains the syntax of SQL
statements.

From the command line processor in interactive
mode, enter:

help statement

where statement represents an SQL statement.

For example, help SELECT displays help about the
SELECT statement.
Note: SQL help is not available on UNIX-based
platforms.

SQLSTATE Help Explains SQL states and
class codes.

From the command line processor in interactive
mode, enter:

? sqlstate or ? class code

where sqlstate represents a valid five-digit SQL
state and class code represents the first two digits
of the SQL state.

For example, ? 08003 displays help for the 08003
SQL state, while ? 08 displays help for the 08 class
code.

Viewing Information Online
The books included with this product are in Hypertext Markup Language
(HTML) softcopy format. Softcopy format enables you to search or browse the
information and provides hypertext links to related information. It also makes
it easier to share the library across your site.

You can view the online books or sample programs with any browser that
conforms to HTML Version 3.2 specifications.

To view online books or sample programs:
v If you are running DB2 administration tools, use the Information Center.
v From a browser, click File —>Open Page. The page you open contains

descriptions of and links to DB2 information:
– On UNIX-based platforms, open the following page:

INSTHOME/sqllib/doc/%L/html/index.htm

where %L represents the locale name.
– On other platforms, open the following page:

sqllib\doc\html\index.htm

The path is located on the drive where DB2 is installed.
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If you have not installed the Information Center, you can open the page
by double-clicking the DB2 Information icon. Depending on the system
you are using, the icon is in the main product folder or the Windows
Start menu.

Installing the Netscape Browser
If you do not already have a Web browser installed, you can install Netscape
from the Netscape CD-ROM found in the product boxes. For detailed
instructions on how to install it, perform the following:
1. Insert the Netscape CD-ROM.
2. On UNIX-based platforms only, mount the CD-ROM. Refer to your Quick

Beginnings book for the mounting procedures.
3. For installation instructions, refer to the CDNAVnn.txt file, where nn

represents your two character language identifier. The file is located at the
root directory of the CD-ROM.

Accessing Information with the Information Center
The Information Center provides quick access to DB2 product information.
The Information Center is available on all platforms on which the DB2
administration tools are available.

You can open the Information Center by double-clicking the Information
Center icon. Depending on the system you are using, the icon is in the
Information folder in the main product folder or the Windows Start menu.

You can also access the Information Center by using the toolbar and the Help
menu on the DB2 Windows platform.

The Information Center provides six types of information. Click the
appropriate tab to look at the topics provided for that type.

Tasks Key tasks you can perform using DB2.

Reference DB2 reference information, such as keywords, commands, and
APIs.

Books DB2 books.

Troubleshooting
Categories of error messages and their recovery actions.

Sample Programs
Sample programs that come with the DB2 Application
Development Client. If you did not install the DB2
Application Development Client, this tab is not displayed.

Web DB2 information on the World Wide Web. To access this
information, you must have a connection to the Web from
your system.
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When you select an item in one of the lists, the Information Center launches a
viewer to display the information. The viewer might be the system help
viewer, an editor, or a Web browser, depending on the kind of information
you select.

The Information Center provides a find feature, so you can look for a specific
topic without browsing the lists.

For a full text search, follow the hypertext link in the Information Center to
the Search DB2 Online Information search form.

The HTML search server is usually started automatically. If a search in the
HTML information does not work, you may have to start the search server
using one of the following methods:

On Windows
Click Start and select Programs —> IBM DB2 —> Information —>
Start HTML Search Server.

On OS/2
Double-click the DB2 for OS/2 folder, and then double-click the Start
HTML Search Server icon.

Refer to the release notes if you experience any other problems when
searching the HTML information.

Note: The Search function is not available in the Linux, PTX, and Silicon
Graphics IRIX environments.

Using DB2 Wizards
Wizards help you complete specific administration tasks by taking you
through each task one step at a time. Wizards are available through the
Control Center and the Client Configuration Assistant. The following table
lists the wizards and describes their purpose.

Note: The Create Database, Create Index, Configure Multisite Update, and
Performance Configuration wizards are available for the partitioned
database environment.

Wizard Helps You to... How to Access...

Add Database Catalog a database on a client workstation. From the Client Configuration
Assistant, click Add.

Back up Database Determine, create, and schedule a backup
plan.

From the Control Center, right-click
the database you want to back up
and select Backup —> Database
Using Wizard.
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Wizard Helps You to... How to Access...

Configure Multisite
Update

Configure a multisite update, a distributed
transaction, or a two-phase commit.

From the Control Center, right-click
the Databases folder and select
Multisite Update.

Create Database Create a database, and perform some basic
configuration tasks.

From the Control Center, right-click
the Databases folder and select
Create —> Database Using
Wizard.

Create Table Select basic data types, and create a primary
key for the table.

From the Control Center, right-click
the Tables icon and select Create
—> Table Using Wizard.

Create Table Space Create a new table space. From the Control Center, right-click
the Table Spaces icon and select
Create —> Table Space Using
Wizard.

Create Index Advise which indexes to create and drop for
all your queries.

From the Control Center, right-click
the Index icon and select Create
—> Index Using Wizard.

Performance
Configuration

Tune the performance of a database by
updating configuration parameters to match
your business requirements.

From the Control Center, right-click
the database you want to tune and
select Configure Performance
Using Wizard.

For the partitioned database
environment, from the Database
Partitions view, right-click the first
database partition you want to
tune and select Configure
Performance Using Wizard.

Restore Database Recover a database after a failure. It helps
you understand which backup to use, and
which logs to replay.

From the Control Center, right-click
the database you want to restore
and select Restore —> Database
Using Wizard.

Setting Up a Document Server
By default, the DB2 information is installed on your local system. This means
that each person who needs access to the DB2 information must install the
same files. To have the DB2 information stored in a single location, perform
the following steps:
1. Copy all files and subdirectories from \sqllib\doc\html on your local

system to a Web server. Each book has its own subdirectory that contains
all the necessary HTML and GIF files that make up the book. Ensure that
the directory structure remains the same.
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2. Configure the Web server to look for the files in the new location. For
information, refer to the NetQuestion Appendix in the Installation and
Configuration Supplement.

3. If you are using the Java version of the Information Center, you can
specify a base URL for all HTML files. You should use the URL for the list
of books.

4. When you are able to view the book files, you can bookmark commonly
viewed topics. You will probably want to bookmark the following pages:
v List of books
v Tables of contents of frequently used books
v Frequently referenced articles, such as the ALTER TABLE topic
v The Search form

For information about how you can serve the DB2 Universal Database online
documentation files from a central machine, refer to the NetQuestion
Appendix in the Installation and Configuration Supplement.

Searching Information Online
To find information in the HTML files, use one of the following methods:
v Click Search in the top frame. Use the search form to find a specific topic.

This function is not available in the Linux, PTX, or Silicon Graphics IRIX
environments.

v Click Index in the top frame. Use the index to find a specific topic in the
book.

v Display the table of contents or index of the help or the HTML book, and
then use the find function of the Web browser to find a specific topic in the
book.

v Use the bookmark function of the Web browser to quickly return to a
specific topic.

v Use the search function of the Information Center to find specific topics. See
“Accessing Information with the Information Center” on page 201 for
details.
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Index

Special Characters
? wildcard character 74
* wildcard character 74
#Missing strings, suppressing 43
#NoAccess strings, suppressing 43

A
access

to databases 22, 83
to Essbase data 22, 83
to linked partitions 143
to linked reporting objects 135
to multiple databases 142
to online help 14
using Essbase commands 20
with Hyperion Integration Server

Drill-Through 169
Acrobat Reader vi
ad hoc reports 1, 24, 103, 156
Add button 181
add database wizard 202, 203
Add-in Manager 12
adding members 72
adjusting columns 21, 101
administrators 2
Adobe Acrobat Reader vi
advanced interpretation engine 119
Advanced Interpretation mode 119,

126
aliases

definition of 53
displaying

process of 53
with member names 55
with Query Designer

results 71
in tables 53

alternate dimensions 5
alternate names 53
ancestors, definition of 8
AND operators 72
API 4
application designer 2
application partitions 143
application programming

interface 4
applications/databases

Sample Basic 11, 21, 23, 84

applications/databases (continued)
sample for Hyperion Integration

Server Drill-Through 168
Sample Interntl 154
Sample Xchgrate 154

ascending sort order
with Hyperion Integration Server

Drill-Through 178
with Query Designer 95, 97

asymmetric reports
definition of 97
pivoting 98
retrieving data into 97

Attach Linked Object dialog
box 130, 132, 134

attaching reporting objects to
cells 129

attaching to databases 22
attributes, drill down 28
auditing updates 147
auto logouts 81
Auto Sort Rows option 122

B
back up database wizard 202
blank

columns 99
rows 99

blocks, locking data 146
books 187, 197
Boolean operators 72, 75

C
Calculation command 148
Calculation dialog box 148
calculations

database status 148
databases 113, 148
dynamic 113
reducing calculation time 113
scripts 148
specifying latest time period 115
substitution variables 118
with Dynamic Time Series 115
with EssCell 112

canceling data retrievals 26
Cascade command 149
Cascade Information page 149
Cascade Options dialog box 149

cascading sheets
creating table of contents 152
destination 150
format 152
level of detail 149
names 151
output type 150

cell notes
accessing linked 137
linking to cells 132

cell ranges
keeping 37
removing 39
retrieving 107
selecting nonadjacent 38
with Hyperion Integration Server

Drill-Through 172
cells

accessing linked partitions 143
applying styles 46, 51
attaching reports 129
attaching URLs 134
EssCell function in 110
formatting 46, 51, 131

in data cells 51
of dimension members 49
of Dynamic Calculation

members 114
of parent members 46

formulas in 99, 101, 104, 110
linked reporting objects 129, 134
linking files to 129
linking notes to 132
linking URLs to 134
retrieving a range 107
retrieving single values 110
selecting nonadjacent 38
with nondatabase values 99

Change Password dialog box 24
changing

passwords 24
row and column orientation 33
spreadsheet format 46
styles 46

children (defined) 8
Clear All button 184
Clear button 184
Clear command 26
clearing styles 52
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click (defined) 15
client

components 2
software 11
upgrading with server ix

client-server environment 2
collapsing data views 30
colors, setting 46
columns

adjusting width 21, 101
blank 99
displaying as rows 33
displaying selected 37
filtering by 91
keeping selected 37
nested 27
pivoting 33
removing selected 39
retrieving into 28

columns, Hyperion Integration
Server Drill-Through

choosing 176
selecting display order 176, 177
selecting for retrieval from

relational source 176
sorting 178
sorting multiple columns 180

commands
Calculation 148
Cascade 149
Clear 26
Connect 22, 83, 143
Currency Report 154, 157
Disconnect 80
FlashBack 26
Keep Only 37
Linked Objects 129, 134
Lock 146
Member Selection 73
Navigate Without Data 40, 42
new in release 6 ix
Pivot 33
Remove Only 39
Retrieve 25
Retrieve & Lock 146
Send 146
Undo 26
Unlock 146
Zoom In 27
Zoom Out 30

comparison operators 72, 91
computing environment v
concurrent

database access 23, 142
updates to server 146

conditional retrievals 90
configure multisite update

wizard 202
Connect command 22, 83, 143
connecting 22

to a database 22, 83
to a relational data source 159,

169, 173
to Essbase 23, 84
to Hyperion Integration

Server 169, 173
to multiple databases 142
viewing current connections 143

Connection Information text
box 143, 148

consolidations (defined) 9
conversions, currency 153
create database wizard 203
create table space wizard 203
create table wizard 203
creating queries 59
creating reports 24
Currency Conversion product 4
currency conversions

modifying exchange rates 157
reporting 156
sample databases 154
settings 157

Currency Report command 154,
157

Currency Report dialog box 157
current time period 115
cursors (Essbase) 25
custom applications 4
Customize button 174
customizing Hyperion Integration

Server Drill-Through reports 161,
174

D
data

calculating 148
changing orientation 33
comparison operators 91
displaying 5, 25
dynamically calculating 113
filtering 90
filtering, with Hyperion

Integration Server
Drill-Through 184

formatting 46
locking 146
missing 43
modifying 145
navigating 9, 40
pivoting 33

data (continued)
relational, with Hyperion

Integration Server
Drill-Through 159

removing subsets 39
retaining subsets 37
retrieving 21
sorting 90
unlocking 146
updating 145, 147

data sort order, with Hyperion
Integration Server
Drill-Through 178

data source, relational 173
databases

calculating 148
connecting 142
consolidations 9
defined 5
dimensions 8
disconnecting from 80
linked 143
loading 24, 85
locking 146
members 8
organization 7
outlines 9
queries 57
restoring previous views 26
rules 7
sample 21, 154, 168
selecting 84
switching 143
viewing connections 143

DB2 library
books 187
Information Center 201
language identifier for

books 195
late-breaking information 196
online help 198
ordering printed books 197
printing PDF books 196
searching online

information 204
setting up document server 203
structure of 187
viewing online information 200
wizards 202

deleting
filters, Hyperion Integration

Server Drill-Through 184
selected members 39
styles 52

descendants (defined) 8
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descending sort order
with Hyperion Integration Server

Drill-Through 178
with Query Designer 95, 97

Destination Options page 150
destinations

cascaded sheets 150
Query Designer queries 66

detaching 80
dialog boxes, Help buttons 14
dimensions

alternate 5
applying styles 49
currency conversion and 154
described 5, 8
drilling down on 27, 28
drilling up on 30
naming elements 8
pivoting 33

disabling data retrieval 40
Disconnect

command 80
dialog box 80

disconnecting
forced logouts 81
from Essbase 80
from Hyperion Integration

Server 185
discontinuous rows and

columns 38
disk space, effect on Dynamic

Calculation 113
display

options 46
order of columns, Hyperion

Integration Server
Drill-Through 176

Display page (Essbase Options
dialog box) 16, 163

Display Unknown Member
option 101, 103

displaying data 5, 25
distributed sheets 149
double-clicking

defined 15
enabling

for drilling 15
for linked object

browsing 135, 144, 172
downloading Acrobat Reader vi
drag, defined 15
drag-and-drop operations 34
drill

by double-clicking 15
down on attributes 28, 29

drill (continued)
down on consolidations 9
Formula Fill 104
retain formulas during 104
to less detail 30

Drill-Through, Hyperion Integration
Server

accessing 160, 169
cells, defining styles for 169
described 159
Drill-Through Wizard 161
installing 162
multiple reports 160
requirements 162
sample

database 168
Drill-Through report 168
file 170

styles for cells 161
tasks 169
tutorial guidelines 163
using 169

Drill-Through Wizard
described 161
dialog box 174
introductory screen 174

duplicating sheets 149
Dynamic Calculation members,

applying styles to 114
Dynamic Time Series

defined 115
specifying latest time

period 116, 118

E
Edit Cell Note dialog box 138
Edit menu 26
Edit URL dialog box 140
editing

cell notes 137
linked files 137
URLs 139, 140

editing in cells 15
enabling

FlashBack setting 27
mouse actions 15, 135, 144
Navigate Without Data 40

environment (computing) v
Essbase

API 4
architecture 2
Cascade Options dialog box 149
computing environment v
connecting to 22
Disconnect dialog box 80

Essbase (continued)
disconnecting from. See

disconnecting 80
Member Selection dialog

box 73, 78
Member Selection dialog box,

from Query Designer 61
menu 13
new features ix
Options dialog box 16, 85, 163
starting a session 13
System Login dialog box 22, 83
upgrades ix

EssCell function 110
error messages 113
syntax 111

Excel
Add-in Manager, installing

Essbase menu 12
clearing formats 26, 53
manually adding Spreadsheet

Add-in 12
mouse actions 15
sample tutorial files 83
status bar 14

Excel Spreadsheet Add-in 12
exchange rates 154
Execute button 174
executing Hyperion Integration

Server Drill-Through reports 173,
174

expanding data views 27
expanding formulas when

drilling 105
external files 128

F
features, Spreadsheet Add-in ix
files

accessing linked 136
destinations

cascaded sheets 150
Query Designer queries 67

linking to data cells 129
sample for tutorial vii, 83

filtering data 90
filters

operators 182
with Hyperion Integration Server

Drill-Through 184
Find Member dialog box 74
finding members 72, 74
FlashBack command 26
font

formats 48
style list 48
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Font dialog box 48
forced logouts 81
formatted sheets

pivoting in 103
retrieving data into 99

formatting
data cells

linked objects 131, 144
read-only 51
read/write 51

dimension members 49
displaying aliases 53
displaying aliases and names 55
Dynamic Calculation

members 114
enabling styles 48
linked object cells 131, 144
options for cascaded sheets 152
parent members 46
repeating member labels 55
spreadsheets 46
text and cell styles 51

Formula Fill option 104, 107
Formula Preservation mode

Formula Fill 104
pivoting in 103
restrictions with 103, 104
Retain on Keep and Remove

Only 104
Retain on Retrieval 101, 104

formulas
EssCell 110
expanding when drilling 105
in cells 99, 104
preservation

effects on other
operations 104

enabling 101, 104
restrictions with 103

free-form reporting
entering generation and level

names in 126
in Advanced Interpretation

mode 119
in Free-Form mode 122
retrieving data 119

Free-Form retrieval mode 122
guidelines 122

functions 14

G
generations

defined 9
entering names in

spreadsheet 126

Global page (Essbase Options dialog
box) 15

H
Help, accessing 14
Help buttons 14
HTML

sample programs 195
Hyperion Essbase

intended audience 1
migration information ix
products of 3

Hyperion Essbase Spreadsheet
Add-in

accessing Hyperion Integration
Server Drill-Through from 169

installing, manually adding 12
logging data updates 147
retrieval cursors 25
starting 13
users, described 2

Hyperion Integration Server 4, 159
Hyperion Integration Server

Drill-Through 159

I
in-cell editing 15
index wizard 203
Information Center 201
installation

Hyperion Integration Server
Drill-Through 162

manually adding Spreadsheet
Add-in 12

installing
Netscape browser 201

Integration Server Drill-Through 4
Internet, linking cells to URLs 134
Interntl sample database 154

K
Keep Only command

described 37
in Formula Preservation

mode 104

L
labels

applying styles 49
displaying with aliases 55
entering in spreadsheet 119, 122
member names 99
repeating 55

LAN v
language identifier

books 195
late-breaking information 196

latest time period, specifying 115
Latest Time Period option 116
levels

cascading by 149
defined 9
drilling down 31
drilling in 31
entering names 126

linked objects
partitions 51
reporting objects 51

Linked Objects Browser dialog
box 142, 144, 172

LROs 129
Linked Objects command 129, 132,

134
linked partitions

access privileges 145
accessing from spreadsheet 143
cells, applying styles 144

Linked Reporting Objects
accessing from spreadsheet 135
applying styles 131
cell notes 132
creating 128
external files 129
URLs 134

linking
cell notes 132
external files 129
partitions 143
URLs to data cells 134

list, cascaded sheets 152
local area network v
Lock command 146
locking data blocks, with multiple

users 146
logging

off of Essbase 80
on to a relational data

source 173
on to Essbase 22
on to Hyperion Integration

Server 173
logging data updates from

spreadsheet 147
logical operators 76
logouts, forced or auto 81
Lotus 1-2-3

clearing formats 53
mouse actions 15
sample tutorial files 83
status bar 14
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M
macro functions

EssCell 110
Spreadsheet Toolkit vi, 3, 14

main menu (Essbase) 13
manual calculation mode 113
Member Information dialog box 73
member names

aliases for 53
alternate 53
applying styles 46
displaying with aliases 55
entering in spreadsheet 119, 122
formatted sheets 99
indenting 9
repeating 55
with EssCell function 111

Member Preview dialog box 77
Member Retention option 31
Member Selection, with Query

Designer 61
Member Selection command 73
Member Selection dialog box 73
Member Selection Preview dialog

box 64
members

adding 61
aliases for 53
ancestors 8
applying styles 46, 49
children 8
collapsing 30
defined 8
deleting 39
descendants 8
deselecting 79
drilling down on 27, 28
drilling up on 30
Dynamic Calculation 113
Dynamic Time Series 115
finding 72, 74
generations 9
levels 9
names 9
parents 8
retaining 37
selecting 61, 72
siblings 8

menu, Essbase 13
messages (Essbase)

database calculation status 148
display options 103
EssCell 113
unknown member 101

migrating to release 6 ix

missing values
suppressing 43
suppressing disabled 104

missing values, suppressing
in cascaded sheets 152
unavailable 104

Mode page (Essbase Options dialog
box) 18, 88, 104

money 153
mouse actions, enabling 14
Move Down button 177
Move Up button 177
moving

rows and columns 33
through worksheets 40

multidimensional databases 5
multiple filter conditions, with

Hyperion Integration Server
Drill-Through 183

N
Named Pipes protocol 3
names

alternate 9
applying styles 46
displaying with aliases 55
entering generation 126
entering level 126
repeating 55

Navigate Without Data
command 40, 42

nested columns or rows 27
Netscape browser

installing 201
networks 3
Next Level option 31, 150
nonadjacent cells 38
notes, linking to data cells 132
null values 111
numeric values, preserving 100

O
Objects product 4
ODBC clients 3
OLAP

defined 1
server 2

online analytical processing 1
online help 198

displaying for spreadsheet 14
online information

searching 204
viewing 200

opening
Essbase 13

operating systems 2

operators, comparison 72, 91
options

Cascade 149
Display 16, 85, 163
Global 15, 19, 88, 167
Mode 18, 87, 104, 165
settings for advanced tutorial 85
settings for basic tutorial 16
settings for Drill-Through

tutorial 163
Style 47
Zoom 17, 31, 86, 164

Options dialog box 16, 163
OR operators 72
Order By button 180
Order By dialog box 180
ordering

columns, Hyperion Integration
Server Drill-Through 176, 177

rows, Hyperion Integration
Server Drill-Through 178

outlines
consolidations 9
described 7
dimensions 8
Dynamic Calculation

members 113
Dynamic Time Series

members 115
members 8

output, cascaded sheets 149
overlapping styles 51

P
parent members

applying styles to 46
defined 8

Partitioning product 3
partitions 3
passwords

changing 24
entering 84

pattern matching 76
PDF 196
performance configuration

wizard 203
pivot

asymmetric reports and 98
by dragging 34
described 15, 33
effect on text 100
formatted sheets and 103
formula preservation and 103
rows or columns 33, 99
unavailable 100
without retrieving data 40
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Pivot command 33
power loss 81
preferences 15
preserving formulas 101, 107
primary mouse button 14
printer destination, cascaded

sheets 150
printing PDF books 196
programming interface 4

Q
queries

applying styles 68
creating 59
defining 57
deleting 68
retrieving 57
saving 66

Query Designer
applying option settings 71
connecting to multiple

databases 70
creating queries 60
data filtering panel 91
data sorting panel 94
filtering data 90
hint panel 58
layout panel 60
messages 97
messages and confirmations 68
navigation panel 58
properties panel 58
save as query dialog box 66
sorting data 94

R
read-only cells 51
read/write cells 51
relational data source 173
relational databases, accessing with

Hyperion Integration Server
Drill-Through 159

release 6 (Essbase), new features ix
release notes 196
remote databases 143
Remove Only command

described 39
in Formula Preservation

mode 104
Remove Unselected Groups

option 105
removing 39
Repeat Member Labels option 55
report script commands 122, 124
reports

ad hoc 24, 103

reports (continued)
ad hoc currency 156
asymmetric 97
creating multiple 149
formatted 99
free-form 119
methods of generating v
saving 80

reports, creating
ad hoc 24, 156
Cascade 149
Member Selection 72
methods v
Query Designer 57

reports, Hyperion Integration Server
Drill-Through

accessing 169
customizing 161, 174
disconnecting from 185
executing 173
selecting to view or

customize 174
restore wizard 203
restoring database views 26
restrictions, with Formula

Preservation 104
Retain on Keep and Remove Only

option 104
Retain on Retrieval option

disabled 104
enabled 101, 104

Retain on Zooms option 104, 106
retaining

data subsets 37
formulas 99, 100

when drilling 104
when retaining data 104
when retrieving 101, 104

selected members 37
Retrieve & Lock command 146
Retrieve command 25
retrieving

Advanced Interpretation mode
and 119

canceling 26
conditional 90
currency conversion 154
cursors 25
data 21
Dynamic Calculation

members 113
formula preservation and 104
Free-Form mode and 122
functions 110
increasing speed 52, 98, 108, 113

retrieving (continued)
into asymmetric reports 97
into columns 28
into formatted sheets 99

rules for 100
into rows 28
less detail 30
modes 119
more detail 27
performance impact 52, 98, 113
range of cells 107
retaining formulas and 101, 104
selected cells 107
starting process and 24
suppressing data and 40

reverting to previous database
view 26

rows
blank 99
deleting during pivot 99
displaying as columns 33
displaying selected 37
filtering by 91
keeping discontinuous 38
nested 27
pivoting 33
removing selected 39
retrieving into 28
sorting within 95, 97
suppressing values in 43, 152

S
sample

databases
connecting to 23, 154
described vi, 21, 154

databases, in Hyperion
Integration Server
Drill-Though 168

files for tutorial, location 83
Sample Basic

connecting to 23
described 21

Sample directory 83
sample programs

cross-platform 195
HTML 195

Save As command 80
Save command 80
saving

queries 66
worksheets 80

searching
online information 202, 204

secondary mouse button 14
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select (defined) 15
Select Calc Script option 148
Select Columns and Display Order

dialog box 176
Select Data Filters dialog box 181
Select Data Sort Order dialog

box 178
Select Drill-Through Report dialog

box 173, 174
Select Filter Values from the List

dialog box 182, 183
selecting

cells to keep 37
cells to remove 39
latest time period 115
members 72
nonadjacent cells 38
range of cells for retrieval 107

Send command 146
sending

data to server 145
log file 147

server 2
changing password 24
client-server environment 2
connecting to 23, 84
described 2
disconnecting from 80
Essbase OLAP, described 2
Hyperion Integration Server 4,

159
logging updates to 145
migrating to release 5, with

client ix
name 23, 84
on network 3
sending data to 145

Set Filter on Column dialog
box 181

setting up document server 203
shared members, applying styles

to 47
sheet destination, Cascade

option 150
sheets 24
shortcuts, mouse actions 15
siblings (defined) 8
SmartGuides

wizards 202
sort order

with Hyperion Integration Server
Drill-Through 178

sorting multiple columns 180
with Query Designer 94

sorting criteria 90

Spreadsheet Toolkit product 3
spreadsheets

applying styles 46
cascading 149
creating multiple 149
data update log file 147
described 5
displaying aliases 53, 55
displaying member names 55
distributing 149
drilling options 31
global options 15, 27, 103
mode options 104, 119
preserving formulas 104
repeating member labels 55
retrieving data 21
saving 80
setting options 16
style options 46
suppressing missing and zero

values 43
zoom options 31

SQL Interface 3
starting

data retrieval 25
Hyperion Essbase 13
Hyperion Essbase Spreadsheet

Add-in 13
Hyperion Integration Server

Drill-Through 169
status bar, enabling and

disabling 14
status of database connections 143
Style page (Essbase Options dialog

box) 47
styles

applying
to data cells 51
to dimension members 49
to dimensions 49
to Hyperion Integration

Server Drill-Through
cells 169

to linked partition cells 144
to linked reporting object

cells 131
to members 46
to parent members 46
to Query Designer results 71
to shared members 47

clearing 53
defining 46, 47
hierarchy of 51
overlapping 51
removing 52

styles (continued)
selecting members 47
stored in ESSBASE.INI 50
turning off 53
turning on 48

Subset dialog box 75, 77
subsets

defining members 75
removing 39
retaining 37

substitution variables 118, 119
suppressing

data retrieval 40
disabled 104
missing and zero values 43
underscore characters 43

symmetric reports 97
system administrator 2
system failure 81

T
table of contents, with Cascade 152
TCP/IP protocol 3
terminating database

connections 80
termination, abnormal 81
text

entering free-form 119
formatting 48
hierarchy of styles 51
pivoting 33
preserving formatted 100

time periods 115
title members, with drill-down 28
to-date calculations, specifying 115
tracking data updates 147
transaction-level data, accessing with

Hyperion Integration Server
Drill-Through 159

transparent partitions 144
transport protocol 3
tutorial

basic tasks 11
guidelines 20
preparing for 16

U
UDA 75
underscore characters,

suppressing 45
Undo command 26
undoing actions 26
Unlock command 146
unlocking data blocks 146
up-to-date calculations 115
Update Mode 146
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updating
data 145
log file 147

upgrading ix
URLs

accessing linked 139
editing 140
length limits 135
linking to data cells 134

Use Aliases option 53
Use Both Member Names and

Aliases option 55
Use Sheet Options with Query

Designer option 71
Use Styles option 48
User-Defined Attributes 75
username, entering 84
users 2

V
V2.x mode 122
VBA functions vi
viewing

active connections 143
aliases 53
aliases and names 55
data in spreadsheet 24
Dynamic Calculation

members 114
Essbase menu 13
fewer members 30
linked partitions 143
linked reporting objects 135
more members 27
multidimensional data 5
online help 14
online information 200
repeated member labels 55
spreadsheet without data 40
styles 48

views, restoring 26
Visual Basic for Applications vi
visual cues 46, 99

W
Web Gateway product 4
Web resources, linking to data

cells 134
wildcard characters 74
Windows NT Registry, changes

to 12
Within Selected Group option 32,

98
wizard

restore database 203

wizards

add database 202, 203
back up database 202
completing tasks 202
configure multisite update 202
create database 203
create table 203
create table space 203
index 203
performance configuration 203

worksheets

formatting 46
navigating without data in 40

World Wide Web, linking to data
cells 134

X
Xchgrate sample database 154

Z
zero values

suppressing 43, 45
suppressing disabled 104

Zoom commands, customizing 31

Zoom In command

drilling down options 27
selecting levels 31

Zoom Out command, drilling up
options 30

Zoom page (Essbase Options dialog
box) 17, 31
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Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
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be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM Corporation
J74/G4
555 Bailey Avenue,
P.O. Box 49023
San Jose, CA 95161-9023
U.S.A

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Trademarks

DB2 OLAP Server IBM OS/390
OpenEdition DB2 AIX
DB2 Universal Database

Lotus and 1-2-3 are trademarks of Lotus Development Corporation in the
United States, or other countries, or both.

UNIX is a registered trademark in the United States and other countries
licensed exclusively through X/Open Company Limited.

Microsoft, Windows, and Windows NT are registered trademarks of Microsoft
Corporation.

Other company, product, and service names may be trademarks or service
marks of others.
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Contacting IBM

If you have a technical problem, please review and carry out the actions
suggested by the Troubleshooting Guide before contacting DB2 Customer
Support. This guide suggests information that you can gather to help DB2
Customer Support to serve you better.

For information or to order any of the DB2 Universal Database products
contact an IBM representative at a local branch office or contact any
authorized IBM software remarketer.

If you live in the U.S.A., then you can call one of the following numbers:
v 1-800-237-5511 for customer support
v 1-888-426-4343 to learn about available service options

Product Information

If you live in the U.S.A., then you can call one of the following numbers:
v 1-800-IBM-CALL (1-800-426-2255) or 1-800-3IBM-OS2 (1-800-342-6672) to

order products or get general information.
v 1-800-879-2755 to order publications.

http://www.ibm.com/software/data/
The DB2 World Wide Web pages provide current DB2 information
about news, product descriptions, education schedules, and more.

http://www.ibm.com/software/data/db2/library/
The DB2 Product and Service Technical Library provides access to
frequently asked questions, fixes, books, and up-to-date DB2 technical
information.

Note: This information may be in English only.

http://www.elink.ibmlink.ibm.com/pbl/pbl/
The International Publications ordering Web site provides information
on how to order books.

http://www.ibm.com/education/certify/
The Professional Certification Program from the IBM Web site
provides certification test information for a variety of IBM products,
including DB2.
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ftp.software.ibm.com
Log on as anonymous. In the directory /ps/products/db2, you can
find demos, fixes, information, and tools relating to DB2 and many
other products.

comp.databases.ibm-db2, bit.listserv.db2-l
These Internet newsgroups are available for users to discuss their
experiences with DB2 products.

On Compuserve: GO IBMDB2
Enter this command to access the IBM DB2 Family forums. All DB2
products are supported through these forums.

For information on how to contact IBM outside of the United States, refer to
Appendix A of the IBM Software Support Handbook. To access this document,
go to the following Web page: http://www.ibm.com/support/, and then
select the IBM Software Support Handbook link near the bottom of the page.

Note: In some countries, IBM-authorized dealers should contact their dealer
support structure instead of the IBM Support Center.
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