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Introduction

Welcome to the Hyperion Essbase SQL Interface Guide. To help you get started, 
this introduction provides the following information: 

● What you will find in this book

● How it is organized, with a brief description of each chapter

● What you will not find in this book

● What you should know to use Hyperion Essbase™ SQL Interface

● All about the sample files referred to in this book

● The formatting conventions for this book

● Where to find other sources of Hyperion Essbase information

Who Should Read This Guide
This guide is primarily for database administrators who install SQL Interface, 
configure Open Database Connectivity (ODBC) drivers, and load relational data 
into Hyperion Essbase.

What This Guide Contains
The Hyperion Essbase SQL Interface Guide describes how to load data from SQL, 
relational, and flat-file data sources into a Hyperion Essbase database. Use this 
guide to learn how to:

● Prepare data for loading into an Hyperion Essbase database.

● Troubleshoot common relational database server connections and transfer 
problems.
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● Construct a data load rules file to map the data source to the Hyperion Essbase 
database.

● Select and configure the correct database driver to ensure a fast and smooth 
data load.

This guide also briefly describes what’s new in Release 6 of SQL Interface.

Note: For a high-level list of steps for using SQL Interface and the 
supporting documentation, see “About Loading SQL Data” on 
page 14.

What Each Chapter Contains
The chapters in this guide are organized as follows:

● provides a conceptual overview of data loading using SQL Interface.

● describes how to use the ODBC Administrator Utility to choose your 
MERANT (formerly INTERSOLV) ODBC driver and point it to its data 
source.

● describes two ways to prepare multiple-table data for loading, and when to 
choose each one.

● describes how to load data from a relational data source into a Hyperion 
Essbase database.

● describes how to configure non-MERANT drivers and data sources.

What Is Not in This Guide
This guide does not describe the following material:

● Procedures for installing the Hyperion Essbase OLAP Server and SQL 
Interface. For this information, see the Hyperion Essbase Installation Guide.

● Detailed information on each of the MERANT (formerly INTERSOLV) 
ODBC drivers tested with Hyperion Essbase. For this information, see the 
INTERSOLV DataDirect Connect ODBC Reference, which is provided with 
SQL Interface. This reference is in the ARBORPATH\ODBCDOCS 
(ARBORPATH\odbcdocs on UNIX) directory in.PDF format for online 
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viewing and printing in Adobe Acrobat Reader (Version 3.0.1 or later). Adobe 
Acrobat Reader is provided on the Hyperion Essbase CD-ROM, or you can 
download Acrobat Reader from WWW.ADOBE.COM.

● Basic data retrieval. For this information, you need to use the spreadsheet 
environment. See the Hyperion Essbase Spreadsheet Add-in User’s Guide.

This guide describes data loading and data load rules only in the context of loading 
data from SQL, relational, and flat-file sources. For a complete discussion of 
rules files and data loading techniques, see the Hyperion Essbase Database 
Administrator’s Guide, online help available in the Hyperion Essbase Application 
Manager, and online HTML documentation provided with the Application 
Manager.

What You Should Know Before You Start
To use the information in this book, you need an understanding of relational 
databases and ODBC drivers, and knowledge of Hyperion Essbase database 
outlines.

Sample Applications
This book provides examples based on an application called Sample, which is 
provided with the Hyperion Essbase server software, and a dBASE file called 
BUDGET.DBF (budget.dbf on UNIX platforms), which is provided with the SQL 
Interface software.

The individual who installs the server is responsible for making Sample available 
to end users. Sample contains three databases: Basic, Interntl, and Xchgrate. 
Contact the Hyperion Essbase System Administrator if any of the following 
problems occur when you connect to the Hyperion Essbase server:

● You cannot find the Sample application.

● You do not have adequate access to the Sample application.

● You do not see any data in the Sample databases.
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Documentation Conventions
This book uses several formatting styles to indicate actions you should take or 
types of information that you need. The following table lists each document 
convention:

Table i: Document Conventions 

Type Description

1, 2, 3 Indicates procedures to follow in a specific order.

●  Indicates a list of related items.

Product Dimension names and member names are in upper and 
lower case and in this font.

italics Introduces new terms that you may not be familiar with, and 
is used occasionally for emphasis. Titles of books are also in 
italics. 

bold Names of dialog boxes and their controls, such as buttons, 
text boxes, and list boxes, appear in boldface.

UPPERCASE Indicates the name of a file or directory. For operating 
environments that use case-sensitive file names, the correct 
capitalization is used for information specific to those 
environments.

monospace Syntax examples, directories, specific text that you must 
type, and results that you receive.

monospaced 
italics 

Names that are placeholders for values that you specify 
(for example, filename).

greater than
symbol (>) 

Indicates a menu followed by an individual menu command 
in that menu (for example, File > Open). Or, it indicates an 
OR separator to delineate items.

brackets [ ] Indicates optional items (for example, SELECT 
[DISTINCT]). In the example, DISTINCT is an optional 
keyword.

braces {} Indicates that you must select one item (for example, 
{yes|no}). In the example, you must specify either yes or no.
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This book uses the following terminology:

● The term ODBC.INI refers to the ODBC.INI file format as defined by the 
Microsoft ODBC specification.

● The suffix.DLL refers to a dynamic link library file. Your operating system 
might use the term shared object or shared library files instead.

Environment-Specific Information
This book supports users of the Windows NT, Windows 2000, AIX, Solaris, and 
HP-UX operating environments. Where it provides information that is not 
applicable to all environments, the following symbols are used to identify that 
information:

This manual shows dialog boxes that are specific to Windows NT. The dialog 
boxes that you see in other platforms may differ slightly from the NT versions.

Additional Sources of Documentation
If you do not find what you need in this book, refer to the following 
documentation:

● The Hyperion Essbase Installation Guide shows you how to install and 
configure the Hyperion Essbase server, Hyperion Essbase Spreadsheet 
Add-in, Hyperion Essbase Application Manager, Hyperion Essbase SQL 
Interface, Hyperion Essbase API, Runtime Client, and sample applications.

● The INTERSOLV DataDirect Connect ODBC Reference, in your ODBCDocs 
directory, provides detailed driver-specific information.

Symbol Environment

Information specific to the Microsoft Windows NT environment is 
identified by the Windows symbol and the letters “NT.” This 
information also applies to Windows 2000.

Information specific to the UNIX environment (Solaris, AIX, and 
HP-UX platforms) is identified by the UNIX symbol.
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● The Hyperion Essbase Start Here booklet provides late-breaking information 
as well as the most important migration and feature information for this 
release of Hyperion Essbase.

● The Hyperion Essbase Documentation Roadmap lists all the Hyperion 
Essbase documentation and tells you how to access the online information.

● The Hyperion Essbase Quick Path Card (QPC) provides an overview of the 
tasks involved in creating, using, and maintaining Hyperion Essbase 
databases.

● The Hyperion Essbase Database Administrator’s Guide explains the 
architecture of Hyperion Essbase, how to design databases, how to design 
calculations, how to set up Hyperion Essbase security, how the database is 
stored, and how to optimize Hyperion Essbase.

● The Hyperion Essbase Application Manager online help file explains how to 
use the Application Manager user interface.

● The online Technical Reference in the DOCS directory lists and describes 
Hyperion Essbase functions, calculation commands, report commands, 
ESSCMD commands, and configuration file (.CFG file) settings.

● The Hyperion Essbase Quick Technical Reference provides syntax for 
Hyperion Essbase functions, calculation commands, report commands, 
ESSCMD commands, and configuration file (.CFG file) settings.

● The online API Reference in your DOCS directory lists and describes 
programmatic functions available through the Hyperion Essbase API, and 
provides information to help you start programming with these functions..

Hyperion Essbase also includes these sources of documentation:

● The Hyperion Essbase Spreadsheet Add-in User’s Guide, in your 
DOCS\CLIENT directory, explains how to use Hyperion Essbase Spreadsheet 
Add-in features with Microsoft Excel or Lotus 1-2-3 for Windows. This guide 
is provided in the \ESSBASE\DOCS\CLIENT directory in.PDF format.

● The Hyperion Essbase Spreadsheet Add-in online help files explain how to 
use Hyperion Essbase Spreadsheet Add-in, and provide all the spreadsheet 
macros and VBA functions.
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What’s New in Release 6

Hyperion Essbase SQL Interface Release 6 supports MERANT DataDirect ODBC 
drivers Version 3.11 on Windows NT and UNIX.

Note: INTERSOLV Solutions has changed its corporate name to MERANT 
Solutions. If you are using MERANT version 3.11 drivers, the name 
on the package is still “INTERSOLV.”

Hyperion Essbase SQL Interface 6 now runs on HP-UX and Windows 2000, as 
well as on AIX, Solaris, and Windows NT.

With the release of Hyperion Essbase 6, SQL Drill-Through is no longer 
provided.To use a previous release of Hyperion Essbase SQL Drill-Through with 
Release 6, do the following:

1. Install Hyperion Essbase Spreadsheet Add-in, Release 6.

2. Install Hyperion Essbase SQL Drill-Through, Release 5.0.2 Patch 9 (or later), 
in the same directory.

For information on the data sources qualified for use with Hyperion Essbase on 
Windows NT and UNIX platforms, see the Hyperion Essbase Start Here booklet 
or the README.TXT file.

Note: You can also load spreadsheet and text-file data directly, using 
Hyperion Essbase Application Manager. See the Hyperion Essbase 
Database Administrator’s Guide.
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Chapter

1
Introducing SQL Interface

This chapter provides a conceptual overview of Hyperion Essbase SQL Interface 
and includes the following topics:

● “What Is SQL Interface?” on page 13

● “About Loading SQL Data” on page 14

What Is SQL Interface?
Using SQL Interface, you can load summary-level data from a number of popular 
SQL, relational, and flat-file database servers. You can also load summary-level 
data from flat files that are in ASCII text format. When you load the data, you can 
also optionally build Hyperion Essbase dimensions dynamically.

Note: You can load data from spreadsheets using Hyperion Essbase 
Application Manager. You do not need to use SQL Interface. See the 
Hyperion Essbase Database Administrator’s Guide.

SQL Interface performs the following actions:

1. Passes SQL statements from the Application Manager to the SQL or relational 
database server. (For non-SQL data sources, SQL Interface converts SQL 
statements to requests for data that the source understands.)

2. Interprets the records received from the SQL, relational, or flat-file database 
server using the rules defined in the data load rules file. (For more information 
on data load rules files, see Chapter 4, “Loading SQL Data.”)

3. Loads the interpreted, summary-level data into the Hyperion Essbase 
database.
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About Loading SQL Data
To load SQL, relational, or flat-file data, you must complete these basic steps:

1. Install SQL Interface on your Hyperion Essbase server machine. See the 
Hyperion Essbase Installation Guide.

2. Configure the relevant data source, which means to choose your ODBC driver 
and point it to its data source. See Chapter 2, “Configuring Your Data Source.”

3. If your data is in multiple tables, prepare your data for loading by doing either 
of the following actions:

● Create one table or view in your SQL database before using SQL 
Interface.

● Join the tables during the data load by entering a SELECT statement in 
the Application Manager.

See “About Preparing Multiple-Table Data” on page 21.

4. Check that you can connect to the data source by using the Data Prep Editor 
in the Application Manager to open the SQL source file. See Chapter 4, 
“Loading SQL Data.”

Create a data load rules file to tell SQL Interface how to interpret and load the SQL 
data into your Hyperion Essbase database, then load the data. See Chapter 4, 
“Loading SQL Data.”
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Chapter

2
Configuring Your 
Data Source

Before you can access data using Hyperion Essbase SQL Interface, you need to 
tell Hyperion Essbase what data sources are available and which drivers it must 
use. On Windows NT, do this using the ODBC Administrator. See “Configuring 
the Data Source on UNIX” on page 20 for UNIX-specific information.

Note: For detailed, driver-specific information on each of the MERANT 
(formerly INTERSOLV) drivers, see the INTERSOLV DataDirect 
Connect ODBC Reference in your ODBCDOCS directory.

This chapter contains the following topics:

● “Configuring the Data Source on Windows NT” on page 15

● “Configuring the Data Source on UNIX” on page 20

Configuring the Data Source on Windows NT
On Windows NT, use the ODBC Administrator, an executable file, to configure 
the data source. This file is located in the BIN directory of the Hyperion Essbase 
server machine. If you installed Hyperion Essbase in the default directory, this 
directory is C:\HYPERION\ESSBASE\BIN. Complete the following steps:

1. Take one of the following actions:

● To start the ODBC Administrator on Windows NT, run ODBCAD32.EXE. 
At the Windows NT command prompt, type:

C:\HYPERION\ESSBASE\BIN\ODBCAD32

● If you installed Hyperion Essbase in a different directory than the default, 
type the appropriate path (for example, D:\ESSBASE\BIN\ODBCAD32).

2. Choose a driver, and then enter the required information about the data source.
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For detailed information, see the appropriate driver chapter in the 
INTERSOLV DataDirect Connect ODBC Reference (for example, “ Connect 
ODBC for dBASE,” or “Connect ODBC for Oracle”). For an example of 
configuring a dBASE data source on Windows NT, see “Configuring a 
dBASE Data Source on Windows NT” on page 16.

Configuring a dBASE Data Source 
on Windows NT

➤ To configure the dBASE data source, complete the following steps:

1. Start the ODBC Administrator to display the ODBC Data Source 
Administrator dialog box. 

Figure 1: User DSN Page of the ODBC Data Source Administrator Dialog Box
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2. Click the Add button on the User DSN page.

The Create New Data Source dialog box is displayed. 

Figure 2: Create New Data Source Dialog Box

3. From the list box, select INTERSOLV OEM 3.11 32-bit dBASEFile 
(*.dbf) for Windows NT and click the Finish button to display the 
General tab of the ODBC dBASE Driver Setup dialog box.

Figure 3: General Page of the ODBC dBASE Driver Setup Dialog Box
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4. Type the following information on the General page:

a. Type dBASEFiles in the Data Source Name text box.

b. Type Load Files in the Description text box.

c. Type C:\HYPERION\ESSBASE\APP\SAMPLE in the Database 
Directory text box and click OK. If you installed Hyperion Essbase in 
the default directory, C:\HYPERION\ESSBASE,  BUDGET.DBF is stored 
in this subdirectory.  

The User DSN tab of the ODBC Data Source Administrator dialog box 
is displayed with dBASEFiles listed in the User Data Sources list box.

Figure 4: User DSN Page with dBASEFiles Listed

5. Click OK to close the ODBC Data Source Administrator dialog box.
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You have configured the dBASE data source. Now you need to create a data load 
rules file to tell Hyperion Essbase how to load the data from BUDGET.DBF.

Note: Online help explains the configuration procedure more fully. For 
example, clicking the Help button on the General tab of the ODBC 
dBASE Driver Setup dialog box (in step 3) brings up the following 
Help screen:

Figure 5: Help Screen for the ODBC dBASE Driver Setup Dialog Box
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Configuring the Data Source on UNIX
The ODBC Administrator is not available on UNIX platforms. SQL Interface 
generates the.odbc.ini file upon installation, and you do not need to do any 
further configuration to use the budget.dbf file. 

The.odbc.ini file contains the ODBC connection and configuration 
information, such as data source name and driver product name. Specific 
information varies among platforms.

Because the.odbc.ini file maps data source names to driver products, you must 
edit the.odbc.ini file if you add a new driver product or data source or change 
driver products or data sources.

Here is the entry you make in the.odbc.ini file for the Oracle 8 driver (assuming 
you installed to home/hyperion/essbase):

[ARor8]

Driver=/home/hyperion/essbase/dlls/ARor813.so
Description=INTERSOLV Oracle driver
ServerName=Poplar
LogonID=Henry

For more information about the.odbc.ini file, see the INTERSOLV DataDirect 
Connect ODBC Reference in your ODBCDOCS directory.
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Chapter

3
Preparing Multiple-table 
Data for Loading

This chapter tells you how to prepare relational data in multiple tables for loading 
into Hyperion Essbase. The following topics in this chapter describe two methods 
and explain when to choose them:

● “About Preparing Multiple-Table Data” on page 21

● “Preparing Data in Your SQL Database” on page 22

● “Preparing Data in the Hyperion Essbase Application Manager” on page 23

● “Choosing the Method to Prepare Your Data” on page 24

Note: If all your data is in one table, skip to Chapter 4, “Loading SQL 
Data.”

About Preparing Multiple-Table Data
If data is in multiple tables, you need to create a single table or a view of the data. 
You can do this in one of the following two ways:

● Create one table or view in the SQL database before using Hyperion Essbase 
SQL Interface, as illustrated in Figure 6.

● Join the tables by entering a SELECT statement in the Hyperion Essbase 
Application Manager during the data load, as illustrated in Figure 7.

The following sections describe these two methods.

Note: The SQL data source file must always be accessible to the Hyperion 
Essbase server. It can be on the server machine or on the network.
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Preparing Data in Your SQL Database
When you create a single physical or virtual table based on data from multiple 
tables in the source database, you need to have the appropriate security privileges 
on your SQL database server. You need privileges to create a table or view and to 
read from all the tables that contain relevant data. Figure 6 illustrates the process 
of loading SQL data from a single table or view.

Figure 6: Loading SQL Data from a Single Table or View 
Created in the SQL Database
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Preparing Data in the Hyperion Essbase 
Application Manager

If you have data in multiple tables, you can tell Hyperion Essbase to join the tables 
during the data load by entering a SELECT statement in the Hyperion Essbase 
Application Manager, as illustrated in Figure 7. Hyperion Essbase passes the 
SELECT statement to the SQL server, without verifying the syntax.

➤ To join multiple tables, do the following:

1. Identify the tables and columns (or fields) containing the data that you want to 
load into Hyperion Essbase.

2. Choose File > Open SQL in the Application Manager Data Prep Editor to 
display the Define SQL dialog box. For more information, see “Opening the 
Data Prep Editor” on page 27.

3. Write a SELECT statement that joins the tables. For more information, see 
“Selecting the SQL Data Source” on page 28 and “More About SQL Queries” 
on page 30.

Figure 7: Loading SQL Data by Joining Tables in the Application Manager
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Choosing the Method to Prepare Your Data
Creating a single table or view in the source database before you use SQL Interface 
is usually the most efficient method. Because an SQL database server reads from 
a single table and maintains a single view more efficiently than it processes a 
multiple-table SELECT statement, creating a single table or view before you use 
SQL Interface greatly reduces the amount of processing time the SQL server 
needs.

You need CREATE access privileges in the SQL database to create a single table 
or view. If you do not have CREATE privileges, use the Define SQL dialog box 
of the Data Prep Editor in the Application Manager to join tables during the data 
load. (Alternatively, you can ask the SQL Database Administrator to provide you 
with the appropriate CREATE privileges.)

Note: For either method, you need SELECT access privileges to all tables 
containing the relevant data.
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Chapter

4
Loading SQL Data

This chapter describes how to load SQL data into the Hyperion Essbase OLAP 
Server using the Hyperion Essbase Application Manager. It explains how to create 
a data load rules file and load data from a dBASE file into the Hyperion Essbase 
server.

The example is based on the Sample Basic database and the dBASE data file 
BUDGET.DBF (budget.dbf on UNIX platforms), which is installed with SQL 
Interface. This file contains budget data for the West and the East regions of a 
fictitious company. For more information on the sample applications, see “Sample 
Applications” on page vii.

This chapter contains the following topics:

● “About Loading Data” on page 25

● “Creating a Data Load Rules File” on page 26

● “Loading the Data” on page 40

About Loading Data
After you have configured the data source and prepared the multiple-table data for 
loading, you need to do the following:

1. Create a data load rules file.

2. Load the dBASE data into the Hyperion Essbase database.
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Creating a Data Load Rules File
To load SQL data into the Hyperion Essbase database, you must create and use a 
data load rules file.

Data load rules are a set of operations that Hyperion Essbase performs on data 
when it loads it into a Hyperion Essbase database. The operations are stored in a 
rules file that tells Hyperion Essbase how to load the SQL data and map it to your 
database outline. The rules file can also reject invalid records in the data source.

You can reuse a rules file with any data source that needs the same set of data 
load rules.

Summary of Steps to Create a 
Data Load Rules File 

To create a data load rules file for the sample dBASE file, BUDGET.DBF 
(budget.dbf on UNIX platforms), follow these steps:

1. Open the Data Prep Editor.

2. Select BUDGET.DBF as the SQL data source (budget.dbf on UNIX 
platforms).

3. Define the data load rules in a rules file.

4. Associate the data load rules file with the Sample Basic database outline.

5. Validate the data load rules file.

6. Save the data load rules file.

Each of these steps is described in detail in the following sections.
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Opening the Data Prep Editor

➤ To open the Data Prep Editor:

1. Start the Application Manager and connect to your server.

The Application Desktop window is displayed.

Figure 8: Application Desktop Window

2. Choose Sample from the Applications list box and Basic from the Databases 
list box.

3. Click the Data Load Rules button, .
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4. Click New to display the Data Prep Editor.

Figure 9: Data Prep Editor

Now you are ready to select and view the SQL data source.

Selecting the SQL Data Source

➤ To select the dBASE file, BUDGET.DBF (budget.dbf on UNIX platforms):

1. Choose File > Open SQL.

Figure 10: Choosing File > Open SQL with the Data Prep Editor Active



Loading SQL Data

■ 29Hyperion Essbase SQL Interface Guide

4

4

4

4

4

4

4

4

4

4

The Select Server, Application and Database dialog box is displayed. The 
Sample Basic database is selected.

Figure 11: The Select Server, Application and Database Dialog Box

2. Click OK to display the Define SQL dialog box.

Figure 12: The Define SQL Dialog Box with BUDGET.DBF Selected

In the SQL Data Sources list box, dBASE Files is selected. This is the SQL 
source that you configured in Chapter 2, “Configuring Your Data Source.”

The wildcard character (*) appears in the Select text box. This loads all the 
fields from the dBASE file.
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3. Type BUDGET.DBF in the From text box (budget.dbf on UNIX platforms).

You defined the path for this file in Chapter 2, “Configuring Your 
Data Source,” so you need not define it here.

Leave the Where text box empty to load all the rows from the dBASE table.

4. Click OK/Retrieve.

Hyperion Essbase opens the dBASE file in the Data Prep Editor. See 
“Defining the Data Load Rules” on page 31 for more information.

Note: The BUDGET.DBF file (budget.dbf on UNIX platforms) must 
be stored on the Hyperion Essbase server, not on the client 
machine.

On UNIX platforms, if you have defined the path for the SQL 
source file in the.odbc.ini file, you can either enter that path 
or a different path in the Database text box of the Define SQL 
dialog box.

On Windows NT, if you have not defined the path for the SQL 
source file in the ODBC Administrator, you can type the path in 
the Database text box of the Define SQL dialog box.

If you do not define a path, Hyperion Essbase looks for the SQL 
source file in the directory from which you are running the 
Hyperion Essbase servers.

More About SQL Queries
The Define SQL dialog box has Select, From, and Where text boxes. The example 
in the previous section uses the wildcard character (*) in the Select text box to load 
data from all the fields in the dBASE file. Alternatively, you can type the names 
of all the fields: 

VERSION,PRODNO,STATE,ACCOUNT,MONTH,MEASURE

Or, you can type only the names of the fields that you want to load:

PRODNO,STATE,MONTH
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This example uses the name of a single dBASE file (BUDGET.DBF) in the From 
text box, and leaves the Where text box empty. If you are loading data from two 
tables, you can join the tables by specifying both the table names, separated by a 
comma (,) in the From text box, and specifying the common (key) fields in the 
Where text box, separated by an equal sign (=).

For example, to load data from two tables, TABLE1.DBF and TABLE2.DBF, where 
the Key_No field of TABLE1.DBF contains the same data as the Key_Code field 
of TABLE2.DBF, type the following text in the From text box:

TABLE1.DBF,TABLE2.DBF

In the Where text box, type the following text:

TABLE1.Key_No = TABLE2.Key_Code

You can also use the Where text box to choose a subset of rows to load from the 
SQL source files. For example, if you want to load only those rows for January into 
the Sample Basic database, in the Where text box type:

MONTH = "Jan"

Note: See the INTERSOLV DataDirect Connect ODBC Reference for more 
information about SQL statements for your specific driver.

Defining the Data Load Rules
When you click OK/Retrieve in the Define SQL dialog box, Hyperion Essbase 
displays the dBASE fields in the Data Prep Editor. Notice that the field names 
differ from the Sample Basic dimension names.

Figure 13: Data Prep Editor Displaying BUDGET.DBF
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Changing Field Names

➤ To change the field names to match the Sample Basic dimension names, do the 
following:

1. Select the first cell in the VERSION field and choose Field > Properties from 
the Application Manager menu.

Figure 14: Choosing Field > Properties with the Data Prep Editor Active

The Field Properties dialog box is displayed. 

Figure 15: Field Properties Dialog Box Showing Data Load Properties
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2. Select the Data Load Properties tab.

The data load properties for Field Number 1 are displayed.

3. In the Field Name text box, type Scenario over the existing name 
(VERSION) and click the Next >> button.

The data load properties for Field Number 2 are displayed.

4. Type Product over the existing name (PRODNO) and click the Next >> button.

The data load properties for Field Number 3 are displayed.

5. Type Market over the existing name (STATE) and click the Next >> button.

 The data load properties for Field Number 4 are displayed.

6. Type Measures over the existing name (ACCOUNT) and click the Next >> 
button.

 The data load properties for Field Number 5 are displayed.

7. Type Year over the existing name (MONTH) and click the Next >> button.

The data load properties for Field Number 6 are displayed. This is the 
last field in BUDGET.DBF. It contains data values. Because you have fully 
specified each dimension, you do not match this field to a dimension name.

8. Delete the existing name (MEASURE) in the Field Name text box, and leave the 
box blank.

9. Click OK to save all your changes.

The Data Prep Editor is displayed again with the fields renamed. Notice that 
the last column has a temporary name of field 6.

Figure 16: Data Prep Editor with the Fields Renamed
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Changing Field Properties
The fields in the dBASE file contain unnecessary leading and trailing white 
spaces. To ensure that Hyperion Essbase deletes these white spaces in each of 
the fields when it loads the data, do the following:

1. Select the first cell in the Scenario field and choose Field > Properties to 
display the Field Properties dialog box (see Figure 17).

Figure 17: Choosing Field > Properties with the First Scenario Cell Selected

2. Click the Global Properties tab.
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3. Select the Drop leading/trailing whitespace check box, as shown in 
Figure 18.

Figure 18: Global Properties Page with Drop Leading/Trailing 
Whitespace Checked

4. Click the Next >> button and select Drop leading/trailing whitespace for all 
six fields.

5. When you reach Field 6, select the Data Field check box, as shown in 
Figure 19, to tell Hyperion Essbase that this field contains data values.

Figure 19: Global Properties Page with Data Field Also Selected 

6. Click OK to close the Field Properties dialog box.
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You have defined the data load rules for the dBASE file. For more information on 
creating data load rules files, see the Hyperion Essbase Database Administrator’s 
Guide.

Now you need to associate the rules file with the database outline into which you 
are loading the data.

Associating the Rules File with an Outline

➤ To associate the rules file with the Sample Basic outline:

1. Choose Options > Associate Outline.

Figure 20: Choosing Options > Associate Outline with the 
Data Prep Editor Active
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 The Associate Server Outline Object dialog box is displayed.

Figure 21: Associate Server Outline Object Dialog Box

2. Choose the BASIC outline from the Objects list box and click OK. 

You are now ready to validate the rules file.

Validating the Rules File

➤ To validate the rules file against the Sample Basic outline:

1. Choose Options > Validate.

Figure 22: Choosing Options > Validate with the Data Prep Editor Active
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If the rules files have no problems, Hyperion Essbase displays the Verify 
message box.

Figure 23: Verify Message Box.

2. Click OK to close this message box.

If there are validation problems, Hyperion Essbase displays the problems in a 
Validate Rules dialog box. If a field has validation problems, ensure that the field 
name is correct. For more information on validating rules files, see the Hyperion 
Essbase Database Administrator’s Guide.

You can now save, then use the rules file to load data.

Saving the Rules File

➤ To save the rules file: 

1. Choose File > Save.

Figure 24: Choosing File > Save with the Data Prep Editor Active
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The Save Server Object dialog box is displayed. 

Figure 25: Save Server Object Dialog Box.

2. Type BUDGET in the Object Name text box.

This gives the rules file the name BUDGET.RUL.

3. Click OK.

4. Choose File > Close to close the Data Prep Editor.

You can now use the BUDGET rules file to load the data from the dBASE file into 
the Sample Basic database.
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Loading the Data

➤ To load the data into Sample Basic:

1. In the Application Desktop Window, select the Sample application and the 
Basic database.

Figure 26: Choosing Database > Load Data

2. Choose Database > Load Data to display the Data Load dialog box 
(see Figure 28).

3. Select the SQL option in the Type group of the Data Load dialog box.

4. Select the Use Rules check box.
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5. Click the Find button to display the Open Server Rules Object dialog box.

Figure 27: Open Server Rules Object Dialog Box

6. Ensure that the Sample application and Basic database are selected.

7. Choose the BUDGET rules file from the Objects list box.

8. Click OK to display the Data Load dialog box again.



42 ■

Loading SQL Data

Hyperion Essbase SQL Interface Guide

9. Select the Load Data and Abort On Error during dataload check boxes in 
the Options group as shown in Figure 28, and ensure that all other options in 
the group are unchecked.

Figure 28: Data Load Dialog Box

10. Click OK to load the data.

Note: You may need to type in an SQL user name and SQL password 
when you connect to some SQL databases (for example, when 
you connect to an Oracle database). You do not need to enter a 
user name and password when you connect to a dBASE database.

When Hyperion Essbase has loaded the data, a message box tells you that the 
load was successful.

Figure 29: SQL Dataload Complete Message Box.
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11. Click OK to close the message box.

Hyperion Essbase loads the SQL data into the Sample Basic database. The dBASE 
file contains budget data for the West and the East regions. Hyperion Essbase loads 
the data into member combinations for these regions. If you have problems loading 
the data, see the Hyperion Essbase Database Administrator’s Guide for 
information on data loading or troubleshooting.
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Chapter

5
Using Non-MERANT ODBC 
Drivers

You can use ODBC database drivers with Hyperion Essbase other than the 
MERANT (formerly INTERSOLV) drivers provided with SQL Interface. For 
example, you can use a Microsoft ODBC driver to connect to Microsoft Access, 
or an IBM ODBC driver to connect to IBM DB2/6000. Some non-MERANT 
ODBC drivers are tested with Hyperion Essbase. For more information on tested 
and supported drivers and data sources, see the Hyperion Essbase Start Here 
booklet or the README.TXT file.   

To use a non-MERANT driver, you need to:

1. Configure the driver.

2. Configure the data source.

This chapter contains the following topics that describe how to use 
non-INTERSOLV ODBC drivers:

● “Configuring a Non-MERANT (INTERSOLV) Driver” on page 45

● “Configuring Non-MERANT (INTERSOLV) Data Sources” on page 52

● “Support for Non-MERANT (INTERSOLV) Drivers” on page 57

Configuring a Non-MERANT (INTERSOLV) 
Driver

When you configure a MERANT driver, Hyperion Essbase recognizes the basic 
configuration information for the driver. For example, Hyperion Essbase 
recognizes the name of the driver and whether the name and password are 
case-sensitive. However, when you use a non-MERANT driver, you must give 
Hyperion Essbase the configuration information for the driver that you use.
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You give Hyperion Essbase the configuration information for your non-MERANT 
driver by creating a driver configuration file called ESSSQL.CFG (esssql.cfg 
on UNIX platforms), which is an ASCII text file. Place this file in your 
ARBORPATH\BIN directory on your Hyperion Essbase server. This is 
C:\HYPERION\ESSBASE\BIN if you installed Hyperion Essbase in the default 
directory (/home/hyperion/essbase/bin on UNIX platforms). 

Note: If you do not create a configuration file, Hyperion Essbase uses its 
own default values. You may not be able to connect to the SQL 
database using the default values.

Creating a Configuration File
The configuration file must contain at least some of the following configuration 
values for each non-MERANT ODBC driver that you use. Which values are 
required varies from driver to driver. See the online help for each driver or 
documentation for specific information.

At a minimum, your configuration file must contain at least the DriverName for 
every non-MERANT ODBC driver that you use. Surround all values for each 
driver with  brackets ([]). Leave one or more spaces between the configuration 
keyword and its corresponding value.

[ 
Description "Description of Driver" 
DriverName  DriverName 
UserId Value 
Password Value 
Database Value 
Server Value 
Application Value 
Dictionary Value 
Files Value 
SingleConnection Value 
UpperCaseConnection Value 
IsQEDriver Value 
] 

Description of Driver is your description of the driver. Enclose the description in 
quotation marks (""). The default value is "".

DriverName is the file name of the non-MERANT ODBC driver and is required.
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On Windows NT, you can use the ODBC Administrator to see the name of the 
driver. To display the name:

1. At the Windows NT command prompt, type:

C:\HYPERION\ESSBASE\BIN\ODBCAD32.EXE 

to display the User DSN screen of the ODBC Data Source Administrator 
dialog box.

(If you installed Hyperion Essbase SQL Interface in a different 
directory than the default, type the appropriate path; for example, 
D:\ESSBASE\BIN\ODBCAD32.EXE.)

Data sources that you have configured are in the User Data Sources list box.

Figure 30: User DSN Page of the ODBC Data Source Administrator 
Dialog Box

Note: Drivers that have not been properly configured may also be in the 
User Data Sources list box. Ignore them.
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2. Select the ODBC Drivers tab to display the ODBC Drivers screen.

Figure 31: ODBC Drivers Page of the ODBC Data Source Administrator 
Dialog Box

3. Obtain the file name of the driver by scrolling left to right across the installed 
ODBC Drivers list box.

For example, the file name for the Microsoft Access Driver is 
ODBCJT32.DLL.

4. Click OK when you have selected the driver.

For more information on the ODBC Administrator, see “Configuring a Microsoft 
Access Data Source on Windows NT” on page 52.

On UNIX, the driver’s name is in the.odbc.ini file. For more information on 
the.odbc.ini file, see “Configuring the Data Source on UNIX” on page 20.
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For all other configuration keywords, set Value to be either 1 or 0, according to the 
following table. The defaults apply if you do not specify the value for the driver. 
These are different from the Hyperion Essbase default values that apply if you do 
not create an ESSSQL.CFG file.

Configuration 
Information Value Description

UserId 1 User ID required.

0 User ID not required. Default: 0

Password 1 Password required.

0 Password not required. Default: 0

Database 1 Database name required.

0 Database name not required. Default: 0

Server 1 Server name required.

0 Server name not required. Default: 0

Application 1 Application name required.

0 Application name not required. Default: 0

Dictionary 1 Dictionary name required.

0 Dictionary name not required. Default: 0

Files 1 Files name required.

0 Files name not required. Default: 0

SingleConnection 1 Driver not thread-safe. One active connection 
allowed.

0 Driver thread-safe. Multiple active connections 
allowed. Default: 1

Recommendation for MERANT 
(INTERSOLV) drivers: 1

CAUTION: Specifying 0 (multiple active 
connections allowed) for MERANT 
(INTERSOLV) or non-MERANT drivers may 
lead to instability.
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Include configuration information for all the non-MERANT drivers in one 
configuration file. Enclose the values for each driver in brackets ([]) as follows:

[ 
Description "Description of Driver" 
DriverName DriverName 
... 
] 

[ 
Description "Description of Driver" 
DriverName DriverName 
... 
] 

Creating a Configuration File for the 
Microsoft Access Driver on Windows NT
The driver name for the Microsoft Access driver on Windows NT is 
ODBCJT32.DLL. This driver requires a database name, server name, application 
name, and dictionary (directory path). This driver is not a MERANT 
(INTERSOLV) driver. Therefore, enter its configuration values in an ASCII-text 
ESSSQL.CFG file as follows: 

UpperCaseConnection 1 Driver not case-sensitive. Connection 
information is converted to uppercase.

0 Driver case-sensitive. Connection information 
is unchanged. Default: 0

IsQEDriver 1 Driver is a MERANT (INTERSOLV) driver. 
You can specify configuration information for 
MERANT drivers (for example, if you have the 
latest version of an MERANT driver, which 
Hyperion Essbase does not yet support).

0 Driver is a non-MERANT driver. Default: 0

Configuration 
Information Value Description
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[ 
Description "Microsoft Access Driver (*.MDB)" 
DriverName ODBCJT32.DLL 
Database 1 
Server 1 
Database 1 
Application 1 
Dictionary 1 
IsQEDriver 0 
] 

Note: See “Configuring a Microsoft Access Data Source on Windows NT” 
on page 52.

Creating a Configuration File for the 
IBM DB2/6000 Driver on AIX
The driver name for the IBM DB2/6000 driver on AIX is DB2.0. This driver 
requires a user ID, password, and database name, but not a server name. This 
driver is thread-safe and case-sensitive. It is not a MERANT (INTERSOLV) 
driver. Therefore, enter its configuration values in an ASCII-text esssql.cfg file 
as follows:

[ 
Description "IBM DB2/6000 ODBC Driver" 
DriverName DB2.0 
UserId 1 
Password 1 
Database 1 
SingleConnection 0 
UpperCaseConnection 0 
IsQEDriver 0 
] 

Note: See “Configuring an IBM DB2/6000 Data Source on AIX” on 
page 57.
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Configuring Non-MERANT (INTERSOLV) Data 
Sources

You configure a non-MERANT (formerly INTERSOLV) data source in the same 
way that you configure a MERANT data source. See Chapter 2, “Configuring 
Your Data Source” for more information. The following sections tell you how to 
configure a Microsoft Access data source on Windows NT and an IBM DB2/6000 
data source on AIX.

Note: Before you configure a non-MERANT data source, you must first 
configure the driver by creating an ESSSQL.CFG configuration file 
(esssql.cfg on UNIX platforms). See “Configuring 
Non-MERANT (INTERSOLV) Data Sources” on page 52.

Configuring a Microsoft Access 
Data Source on Windows NT

The following example describes how to configure a Microsoft Access data source 
on a Windows NT Hyperion Essbase server. Your data source and driver may 
differ, but the steps that you take to configure the data source are essentially the 
same. The example assumes:

● You have installed the Microsoft Access ODBC 32-bit database driver on the 
Hyperion Essbase server.

● The Hyperion Essbase server has access to a sample Microsoft Access 
(*.MDB) file.

On Windows NT, you use the ODBC Administrator, ODBCAD32.EXE, to configure 
a non-INTERSOLV data source, just as you use it to configure an INTERSOLV 
data source. This file is located in the BIN directory of the Hyperion Essbase server 
machine, C:\HYPERION\ESSBASE\BIN, if you installed Hyperion Essbase in the 
default directory.

This example uses the ORDERS.MDB file, which is installed with Microsoft Access, 
but you can use any .MDB file to test the data source configuration.
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The Microsoft Access ODBC 32-bit database driver is also installed with 
Microsoft Access, but it can be installed in other ways. For Microsoft Access, you 
need to specify the data source name and database. You can also provide a 
description. Other ODBC drivers may require additional information. See the 
documentation for each driver, and online help, for what is required.

To configure the Microsoft Access data source:

1. At the Windows NT command prompt, type:

C:\HYPERION\ESSBASE\BIN\ODBCAD32.EXE

to display the User DSN screen of the ODBC Data Source Administrator 
dialog box.

(If you installed Hyperion Essbase in a different directory than the default, 
type the appropriate path; for example, D:\ESSBASE\BIN\ODBCAD32.EXE.)

 Data sources that you have configured are in the User Data Sources list box.

Figure 32: User DSN Page of the ODBC Data Source Administrator 
Dialog Box

Note: Drivers that have not been properly configured may also be in the 
User Data Sources list box. Ignore or remove them, and proceed 
with these instructions.
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2. Click the Add button to display the Create New Data Source dialog box.

Figure 33: Create New Data Source Dialog Box

3. Scroll down the list of available drivers and select Microsoft Access 
Driver (*.mdb).

4. Click  Finish to display the ODBC Microsoft Access 97 Setup dialog box.

Figure 34: ODBC Microsoft Access 97 Setup Dialog Box

5. Type MSAccess Orders, or any other name, in the Data Source Name text 
box.
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6. Type Load Data in the Description text box.

7. Click  Select in the Database group to display the Select Database dialog 
box.

8. Locate and select ORDERS.MDB (or the name of your.MDB file if it is not 
ORDERS.MDB) and click OK.

Figure 35: Select Database Dialog Box

The ODBC Microsoft Access 97 Setup dialog box is displayed with the path 
and file that you selected. 

Figure 36: ODBC Microsoft Access 97 Setup Dialog Box with 
ORDERS.MDB Selected

9. Click OK to display the ODBC Data Source Administrator dialog box. 
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The Microsoft Access data source is in the User Data Sources list box, with 
other data sources that you may or may not have configured.

Figure 37: ODBC Data Source Administrator Dialog Box with 
Microsoft Access Listed

10. Click OK.

You can now load data from the Microsoft Access data source file that you chose 
into a Hyperion Essbase database. For information on loading SQL data, see 
Chapter 4, “Loading SQL Data.” For general information on loading data, see the 
Hyperion Essbase Database Administrator’s Guide.

Note: Remember that source files must be accessible to the Hyperion 
Essbase server. They can be on the server machine or on the network.
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Configuring an IBM DB2/6000 
Data Source on AIX

If you use AIX, you can connect to an IBM DB2/6000 data source using the IBM 
DB2/6000 ODBC driver. Consult the database administrator for information on 
configuration, authorization, binding, and other steps that may be required to 
connect to the data source.

Note: See “Creating a Configuration File for the IBM DB2/6000 Driver on 
AIX” on page 51.

Support for Non-MERANT (INTERSOLV) 
Drivers

Some non-MERANT drivers are not tested or supported with Hyperion Essbase. 
The driver that you choose might not be specifically tested to work with Hyperion 
Essbase. For information on qualified drivers and data sources, see the Hyperion 
Essbase Start Here booklet, or the README.TXT file.



58 ■

Using Non-MERANT ODBC Drivers

Hyperion Essbase SQL Interface Guide



■ 59Hyperion Essbase SQL Interface Guide

In
d

e
x

Index

Symbols
* (wildcard characters)

in SQL queries, 30
, (commas)

in SQL queries, 31
= (equal signs)

in SQL queries, 31

A
Access, Microsoft

data source, 52, 55, 56
configuring, 53

database, 45
ODBC driver, 48, 54

AIX environments
IBM DB2/6000

data source files, 57
IBM DB2/6000 driver, 51
support for, ix

Application Manager See Hyperion Essbase 
Application Manager

ARBORPATH, 46
ASCII data, loading, 13

B
Basic database, 27
Basic outline, 37
BIN directory, 15, 46, 52
budget.dbf, 18, 25

Sample application dBASE file, vii
selecting, 28

building Hyperion Essbase dimensions, 13

C
cfg (.CFG) file

creating, 46
choosing

a driver, 15
a subset of rows, 31

configuration file
for non-MERANT (INTERSOLV) drivers, 46

configuring
data sources

dBASE, 16
IBM DB2/6000, 57
Microsoft Access, 53
non-MERANT (INTERSOLV), 52
online help, 19
overview, 15

IBM DB2/6000 ODBC driver, 51
Microsoft Access data source, 53
Microsoft Access ODBC driver, 50
non-MERANT (INTERSOLV) drivers, 45, 50

connecting
to DB2/6000 data source, 57
to SQL databases, 42

conventions, documentation, viii
converting SQL statements, 13
CREATE privileges, 24
creating

data load rules file, 26
driver configuration file, 46, 49

for IBM DB2/6000, 51
Microsoft Access driver configuration file, 50
single table or view, 21, 24

required security privileges, 24



Index

60 ■ Hyperion Essbase SQL Interface Guide

D
data

load preparation, 21
load preparation methods, 24
SQL, mapping, 26
values, fields, 33

Data Load Properties tab, 33
Data Load Rules button, 27
data load rules file

associating with outline, 36
creating, 26
definition, 26
saving, 38
SQL records, 13
validating, 37

Data Prep Editor
button for opening, 27
displaying fields, 31
opening, 27

data sources
configuring

for IBM DB2/6000, 57
for Microsoft Access, 53

connecting to, 57
dBASE, 16
describing, 54
Microsoft Access, 56
naming, 18, 54
non-MERANT (INTERSOLV), 52
paths, 30

Microsoft Access data source, 55
selecting, 28
storing on network, 56
storing on server, 30

databases
Basic, 25, 27
IBM DB2/6000, 45
Microsoft Access, 45
multidimensional, v
multidimensional data

summary level, 13
DB2.0, 51
DB2/6000

See IBM DB2/6000, 45
dBASE files

configuring, 16

data loading, 25
selecting, 28

deleting white spaces, 34
describing data sources, 18
dialog box

Open Server Rules Object, 41
Select Database, 55

dialog boxes
Associate Server Outline Object, 37
Create New Data Source, 17, 54
Data Load, 40
Define SQL, 24, 29
Field Attributes, 32
for Windows NT, ix
OCBC Microsoft Access 97 Setup, 55
ODBC Data Source Administrator, 16, 47
ODBC dBASE Driver Setup, 17
Save Server Object, 39
Select Server, Application and Database, 29
Validate Rules, 38

dimensions
building, 13
mapping to fields, 32

directories
BIN, 15, 46

ODBC Administrator in, 52
data source, 18
data sources, default, 30
driver configuration file, 46

documentation, ix
conventions, viii
Essbase, related, ix

driver configuration file
creating, 46, 49

for IBM DB2/6000, 51
for Microsoft Access, 50

default values, 46, 49
in BIN directory, 46
keyword values, 49
required values, 46
syntax, non-MERANT (INTERSOLV) drivers, 

50
drivers

choosing in ODBC Administrator, 15
configuring

for IBM DB2/6000, 51



Index

■ 61Hyperion Essbase SQL Interface Guide

non-MERANT (INTERSOLV), 52
description of, 46
file names, 48
Microsoft Access, 52, 54
naming, 46
non-MERANT (INTERSOLV), 45

tested, 57
password, 45
UNIX, names, 48

dynamic link library (.DLL) files, ix

E
environments

supported, ix
Essbase

default values for drivers, 46, 49
loading data into, v
outline, mapping data to, 26
server on Windows NT, 52

esssql.cfg, 46, 49, 50, 51
Excel, loading data from, xi

F
fields

Data Prep Editor, 31
data values, 33
mapping to dimensions, 32
selecting, 29
selecting or naming, 30
validating names of, 38

files
.CFG (config), 46
.DBF (dBASE), 26
.DLL, ix
.MDB, 52, 54
.odbc.ini, ix
.PDF, ix
data load rules, 26

flat file data, loading, v
FROM statement, 30

to join tables, 31

H
help, online, ix, 19

HTML, online, ix
Hyperion Essbase

loading data into, 25
Hyperion Essbase Application Manager

joining tables, 23
loading spreadsheet data, xi, 13
loading SQL data, 25
SELECT statement, 21, 23

I
IBM DB2/6000

data source, 57
driver and database, 45

IBM DB2/6000 data source
database, 45
ODBC driver for, 51

installed ODBC drivers, listed, 48
interpreting SQL records, 13
INTERSOLV

drivers See MERANT (INTERSOLV) ODBC 
drivers

J
joining tables, 21

FROM statement, 31
Hyperion Essbase Application Manager, 23
SELECT statement, 23

K
key fields, 31
keywords, driver configuration file, 49

L
library files, shared, ix
library. See dynamic link library
loading data, v

data load rules, vii, 26
from single table, 22
from spreadsheets, xi
into outline, 40
joining tables, 21, 23
member combinations, 43
overview, 14, 25



Index

62 ■ Hyperion Essbase SQL Interface Guide

preparing for, 21
summary level data, 13
using Hyperion Essbase Application Manager, 25

Lotus 1-2-3, loading data from, xi

M
mapping

fields to dimensions, 32
SQL data to Essbase outline, 26

MDB (.MDB) file, 52, 54
member combinations, 43
MERANT (INTERSOLV) ODBC drivers

Version 3.11 on Windows NT, xi
Microsoft

driver and database, 45
Microsoft Access

data source, 52, 53, 55, 56
driver, 54
ODBC driver for, 48

multidimensional databases
building Hyperion Essbase dimensions, 13
loading data into, v, 13

multiple tables
joining, 21, 23
loading from, 21
preparing, 21

N
naming data sources, 18
network, data source files, 56
non-MERANT (INTERSOLV)

data source, configuring, 52
drivers

configuring, 45
tested, 45, 57

drivers See also drivers
NT. See Windows NT

O
object, shared, ix
ODBC Administrator, 15, 47

online help, 19
to configure non-MERANT (INTERSOLV) 

driver, 52

ODBC drivers
configuring

for IBM DB2/6000, 51
file names, 48
MERANT (INTERSOLV) Version 3.11 on 

Windows NT, xi
Microsoft Access, 52, 54
non-MERANT (INTERSOLV), 45
tested, 45
UNIX, names, 48

odbc.ini file, ix, 30
ODBCAD32.EXE, 15, 47, 52, 53
ODBCJT32.DLL, 48
online documentation, ix

help in ODBC Administrator, 19
PDF files, ix

Open Server Rules Object dialog box, 41
opening Data Prep Editor, 27
operating environments, ix
ORDERS.MDB, 55

testing data source configuration, 52
outline

associating with rules, 36
Basic, 37
loading data, 40

P
passing

SELECT statements, 23
SQL statements, 13

passwords
for driver, 45
for IBM DB2/6000 driver, 51
for SQL database, 42

paths
esssql.cfg, 46
for data sources, 30
for ODBCAD32.EXE, 53
ODBCAD32, 47

platforms, ix
processing time, 24

R
relational data, loading, 13

See also data
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requesting non-SQL data, 13
re-using data load rules file, 26
rows, choosing with WHERE, 31
rules file.  See data load rules file

S
Sample application, vii, 25, 27

Basic database, 25, 27
directory, 18

saving rules files, 38
security privileges, 22, 24
Select Database dialog box, 55
SELECT statement, 21, 23

processing time, 24
selecting all fields, 30
selecting specific fields, 29

selecting
fields, 29, 30
SQL data sources, 28

servers
data sources, 30
machine, data source files, 56

shared library files, ix
shared object, ix
Solaris environments

support for, ix
source. See  data sources
spaces, deleting, 34
spreadsheets, loading data, xi
SQL

queries, 30
server, 22
statements, 13

SQL data
joining tables, 23
loading, v, 13
mapping to Essbase, 26
selecting source, 28

SQL databases
connecting to, 42
security privileges, 22
single tables in, 21, 22, 24

SQL server, 24
summary data, loading, 13
supported platforms, ix, xi

systems, operating, ix

T
tables

creating, 21
efficiency, 24
joining, 21, 23
loading from, 21
SQL databases, 22

tested
drivers

where to find information about, 45
non-MERANT (INTERSOLV) drivers, 57

text file data, loading, 13

U
UNIX environments

budget.dbf, 25
configuring data sources on, 20
IBM DB2/6000

data source files, 57
IBM DB2/6000 driver, 51
odbc.ini file, 30, 48
support for, ix

user names, 42

V
validating rules file, 37
views, 24

creating, 21
SQL databases, 22

W
WHERE statements, 30

key fields, 31
white spaces, deleting, 34
Windows NT environments, xi

configuring data sources on, 15
configuring dBASE data sources, 16
dialog boxes, ix
displaying driver names, 47
Essbase server, 52
ODBC Administrator
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data sources, configuring, 15
ODBCAD32.EXE, 15
support for, ix
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