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Preface

Purpose

This guide provides all the information that you need to use the IBM DB2
OLAP Server Spreadsheet Add-in for Lotus 1-2-3. It explains the features and
options and discusses the concepts, processes, procedures, formats, tasks, and
examples that you need to use the software.

IBM DB2 OLAP Server Version 8.1, known as Essbase 6.5 in this guide, is an
online analytical processing (OLAP) solution that satisfies the complex
calculation requirements of financial, accounting, and marketing professionals.
Essbase operates in a client-server computing environment on a local area
network (LAN). In this environment, multiple users can use their desktop
computers to retrieve and analyze centralized data.

You can create reports from the data residing on the Essbase server in several

ways:

* Generate database reports through a spreadsheet interface, called Essbase
Spreadsheet Add-in, as explained in this guide.

* Use Essbase Application Manager Report Writer to create a report script
and run a report. For more information, see the Database Administrator’s
Guide.

* Use Essbase Application Programming Interface (API) to create and run
database reports. For more information, see the Essbase API Reference.

 Use reporting tools, such as Hyperion Reporting for Essbase.

Audience

© Copyright IBM Corp. 1998, 2002

This guide is for Essbase end users who are responsible for some or all of the
following tasks:

* Starting Essbase and connecting and disconnecting from Essbase databases
* Retrieving data from a database into a worksheet

* Dirilling down, drilling up, and navigating through a worksheet to analyze
and arrange data from multiple viewpoints

* Working with linked reporting objects and linked partitions

* Updating data on the Essbase server

* Using the worksheet to load and calculate data in the database
* Creating multiple sheets from data

¢ Working with currency conversions



Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Essbase Spreadsheet Add-in.
This document contains the following information:

* [Chapter 1, “Introducing Release 6.5” on page 1| provides information on
migrating from previous versions of Essbase to Release 6.5 and lists all new
features and enhancements.

* [Chapter 2, “Introducing Essbase” on page 3 introduces you to basic concepts
of retrieving and manipulating data through the spreadsheet interface.

* [Chapter 3, “A Basic Essbase Tutorial” on page 11|provides a step-by-step
tutorial of basic data navigation, ad hoc retrieval, and reporting techniques.

* [Chapter 4, “An Advanced Essbase Tutorial” on page 95 describes advanced
reporting and retrieval techniques for users that need special reports or
formatted data views.

* [Chapter 5, “Using Drill-Through” on page 183 provides a brief overview of
the Essbase Integration Services drill-through product.

* The Index contains a list of terms and their page numbers. Select or look up
an index entry to view the page to which the entry refers.

Note: The Essbase Spreadsheet Add-in online help provides a comprehensive
section on Essbase Spreadsheet Toolkit. This section enables you to
customize and automate your use of Essbase by using Lotus 1-2-3
macros and Visual Basic for Applications (VBA) functions. For more
information on the Essbase Spreadsheet Add-in online help, see
[“Accessing Online Help” on page 14|

The Spreadsheet Add-in User’s Guide for Lotus 1-2-3 is provided in the
ibm\db2olap\docs\pdf directory in .pdf format for online viewing and
printing in Adobe Acrobat Reader (Release 3.0.1 or higher). The .pdf file is
named Ess123w.pdf. You can download Adobe Acrobat Reader from the
Essbase CD-ROM or from http://www.adobe.com. On the Essbase CD-ROM,
the Acrobat Reader executable file is located in the Adobe directory under the
appropriate platform and language-version subdirectories. To install Adobe
Acrobat Reader, launch the executable file, follow the prompts, and provide
the information requested.

Sample Databases and Files

vi

This book provides tutorial steps that are based on sample databases and files
that are provided with the Essbase server software. You use the Sample Basic
database for most tasks in [Chapter 3, “A Basic Essbase Tutorial” on page 11|
and |Chapter 4, “An Advanced Essbase Tutorial” on page 95 You use a sample
Essbase Currency Conversion application for the section on currency

Spreadsheet Add-in User’s Guide for 1-2-3



conversion. See [Chapter 4, “An Advanced Essbase Tutorial” on page 95| For
information on the Sample Basic database, see [Chapter 3, “A Basic Essbase
[Tutorial” on page 11}

In addition to these sample applications and databases, you also use several
sample Lotus 1-2-3 files in the advanced tutorial in [Chapter 4, “An Advanced|
[Essbase Tutorial” on page 95| The individual at your organization who installs
the server is responsible for making these applications, databases, and files
available to you. Contact the Essbase system administrator for more
information.

Related Documentation

When you licensed Hyperion Essbase, you received the following printed
documentation:

¢ The Installation Guide, which shows you how to install and configure the
Essbase server, Essbase Spreadsheet Add-in, Essbase Application Manager,
Essbase SQL Interface, Essbase API, Runtime Client, and sample
applications.

* The New Features booklet, which describes the new features that have been
added for this release of Hyperion Essbase.

In addition to the printed documentation and this Spreadsheet Add-in User’s
Guide for Lotus 1-2-3, you have access to the following online documentation:

¢ The Documentation Roadmap, which lists all the Essbase documentation and
tells you how to access the online information.

* The Quick Path Card, which provides an overview of the tasks involved in
creating, using, and maintaining Essbase databases.

* The online Database Administrator’s Guide in the docs directory, which
explains the architecture of Essbase, how to design databases, how to
design calculations, how to set up Essbase security, how the database is
stored, and how to optimize Essbase.

* The Application Manager Online Help file, which explains how to use the
Application Manager user interface.

* The Technical Reference, which lists and describes Essbase functions,
calculation commands, report commands, ESSCMD commands, and
configuration file (.cfg file) settings.

The , which explains how to use Essbase Spreadsheet Add-in features with .
This guide is provided in the \ibm\db2olap\docs\pdf directory in .PDF
format for online viewing and printing in Adobe Acrobat Reader (Version
3.0.1 or later). Adobe Acrobat Reader is provided on the Essbase CD-ROM,
and can also be downloaded from http://www.adobe.com.
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The Essbase Spreadsheet Add-in online help files, which explain how to use
Essbase Spreadsheet Add-in, and provide all the spreadsheet macros and
VBA functions.

The API Reference, which lists and describes programmatic functions
available through the Essbase API, and provides information to help you
start programming with these functions.

The Essbase SQL Interface Guide, which contains information on how to set
up systems to load data by means of Essbase SQL Interface. This guide is
provided in the \ibm\db2olap\docs\pdf directory in .PDF format for online
viewing and printing in Adobe Acrobat Reader (Version 3.0.1 or later).
Adobe Acrobat Reader is provided on the Essbase CD-ROM, and can also
be downloaded from http://www.adobe.com.

The Adminstration Services Online Help which you can access by launching
Essbase Administration Services and clicking Help in the main menu.

Accessing Hyperion Documentation

All documentation is accessible from the following locations:

You can access online documentation from the Information Map, an HTML
file. To open the Information Map, launch the essdocs.htm file located in
the ARBORPATH/docs directory.

Online help is accessible from the Spreadsheet Add-in. Start the product
and click the Help button or menu command.

The DB2 OLAP Server Web site is located at:
www. ibm.com\software\db2\db2olap\library.html

Online Help

To access online help, click the Help button in any Essbase dialog box or
select Essbase Help from the Spreadsheet Help menu.

To print an online help topic, display the topic and select File > Print, or
right-click and select Print from the pop-up menu.

Note: You must have first installed HTML documentation to access it.

Online Guides

Online guides are electronic versions of printed documentation.

To display an online guide, start Adobe Acrobat Reader, and then open one of
the Essbase .pdf files located in your \ibm\db2olap\docs\pdf directory.

viii  Spreadsheet Add-in User’s Guide for 1-2-3



Conventions

The following table shows the conventions that are used in this document:

Table 1. Conventions Used in This Document

Item

Meaning

Brackets [ ]

In examples, brackets indicates that the enclosed elements
are optional.

Bold Bold text indicates words or characters that you type
exactly as they display on the page. Bold in procedural
steps highlight major interface elements.

CAPITAL LETTERS Capital letters denote commands and various IDs.

(Example: CLEARBLOCK command)

Example text

Courier font indicates that the material shown is a code
or syntax example.

Ctrl + 0

Keystroke combinations shown with the plus symbol (+)
indicate that you should press the first key and hold it
while you press the next key. Do not type the + symbol.

Courier italics

Courier italic text indicates a variable field in command
syntax. Substitute a value in place of the variable shown
in Courier italics.

Italics

Italics in a product-related term in the body of a book
indicates that the term is included in the glossary of the
book.

Ellipses (...)

Ellipsis points indicate that text has been omitted from an
example.

Mouse orientation

This document provides examples and procedures using a
right-handed mouse. If you are using a left-handed
mouse, adjust the procedures accordingly.

Menu options

Options in menus are shown in the following format:
Menu name > Menu command > Extended menu command

For example: File > Desktop > Accounts

The variable n indicates that you must supply a generic
number; the variable x indicates that you must supply a
generic letter.

Preface  1X
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Chapter 1. Introducing Release 6.5

This chapter provides compatibility information for Essbase Release 6.5 and
previous releases of Essbase, including migration information and new feature
descriptions and enhancements. It contains the following sections:

* [‘Migrating to Release 6.5” on page 1|
* ["'What’s New in Release 6.5

Migrating to Release 6.5

As you migrate (upgrade) from previous releases of Essbase to Release 6.5
(DB2 OLAP Server Version 8.1), keep in mind that Release 6.5 of Essbase
Spreadsheet Add-in is designed to work with Release 6.5 of the Essbase
server. If the Essbase system administrator upgrades the Essbase server to
Release 6.5, Release 5.x of Essbase Spreadsheet Add-in works on only a
limited basis. Upgrade to Essbase Spreadsheet Add-in for Release 6.5 as soon
as possible.

Read the Installation Guide for detailed information about migrating from
previous releases of Essbase.

What's New in Release 6.5

Hybrid Analysis
With Hybrid Analysis, Essbase supports retrieval of data from a external
relational data source. By enabling Hybrid Analysis in Essbase Integration
Services, a portion of database cell values are computable from an external
relational source, instead of being loaded into an OLAP Server database.

Hybrid Analysis allows access to lower level data that is too large to load into
an OLAP Server database.

You need to license Essbase Integration Services to build Hybrid
Analysis-enabled metaoutlines.

Support for Negative Numbers in Filter Criteria in EQD
Essbase Query Designer (EQD) provides the ability to design queries with
filtering criteria. With Release 6.5, EQD supports the use of negative numbers
in the filtering criteria.

Enhanced Keyboard Accessibility in EQD

Keyboard accessibility for EQD is greatly enhanced in Release 6.5. When
launching EQD, focus is set to the first item in the tree in the navigation

© Copyright IBM Corp. 1998, 2002 1



panel. From there, users can access most EQD functionality using the
keyboard. For more information see the Spreadsheet Add-in online help on
EQD keyboard shortcuts.
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Chapter 2. Introducing Essbase

Essbase is multidimensional database software that is optimized for planning,
analysis, and management reporting applications. Essbase uniquely blends an
innovative technical design with an open, client-server architecture. Essbase
enables you to extend your decision support systems beyond ad hoc queries
and reports on historical performance to dynamic, operational systems that
combine historical analysis and future planning. By consolidating and staging
historical and projected data for detailed analysis, you gain perspectives about
your business that enable you to take appropriate actions.

Essbase provides both power and flexibility. Thus, it can be used for a broad
range of online analytical processing (OLAP) applications including the
following:

* Budgeting

* Forecasting and seasonal planning

¢ Financial consolidations and reporting
 Customer and product profitability analysis
* Price, volume, and mix analysis

* Executive information systems (EIS)

Essbase enables you and others in your organization to share, access, update,
and analyze enterprise data from any perspective and at any level of detail
without learning new tools, query languages, or programming skills.

Typical Users of Essbase

Essbase is designed for use in many different applications. Financial analysts
have found Hyperion Essbase to be invaluable in budget analysis, currency
conversion, and consolidation. Cost accountants apply the powerful
capabilities of Essbase to evaluate allocation and elimination scenarios.
Product managers and analysts use Essbase to plan and analyze multiple
product lines and distribution channels. Essbase can also be used as a
repository database for spreadsheet data. Anyone who uses a spreadsheet is a
potential user of Essbase. Because Essbase is applicable to such a broad
variety of environments, individuals using it at your organization may fill one
or more roles in implementing and running applications. This guide refers to
specific roles by three titles. However, in actuality, a role may be performed
by one person or by several people working collaboratively.

* Essbase system administrator. The Essbase system administrator typically has
experience in networking, installing software packages, and administering

© Copyright IBM Corp. 1998, 2002 3



system functions. In addition to installing the Essbase software, the Essbase
system administrator may also set up Essbase user accounts, set up the
security system, and maintain the Essbase server.

* Application designer. The application designer sets up the Essbase database,
creates the database outline, and develops calculation and report scripts.
The responsibilities of the Essbase system administrator and the application
designer may overlap in some areas. The application designer has probably
developed spreadsheet or database applications and understands the
operational problems and the tools being employed to solve them.

* User. The user interacts with Essbase databases through spreadsheets, using
Microsoft Excel for Windows or Lotus 1-2-3. Users are typically analysts
and managers who use spreadsheet programs as their primary tool for
viewing and analyzing data.

Components of the Client-Server Environment

4

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of a local area
network (LAN). The PC workstation acts as a client by requesting data from
the server. The server processes the request and returns the desired result to
the client.

Essbase is built as a client-server system. System performance and multiuser
capabilities are greatly enhanced in the Essbase client-server environment.

The Server

Essbase server is a multidimensional database that supports analysis of an
unlimited number of data dimensions and an unlimited number of members
within these dimensions. Developed using a true client-server architecture, all
data, the database outline, the calculations, and the data security controls
reside on the Essbase server.

The Essbase server operates on Windows 98, Windows NT 4.0, Windows Me,
Windows 2000, and UNIX operating systems.

Essbase Spreadsheet Add-in

Essbase Spreadsheet Add-in is a software program that merges seamlessly
with Microsoft Excel and Lotus 1-2-3. After Essbase is installed, a special
menu is added to Lotus 1-2-3. The menu provides enhanced commands such
as Connect, Pivot, Drill-down, and Calculate. Users can access and analyze
data on the Essbase server by using simple mouse clicks and drag-and-drop
operations. Essbase Spreadsheet Add-in enables multiple users to access and
update data on the Essbase server simultaneously.

Spreadsheet Add-in User’s Guide for 1-2-3



The Network

Essbase runs on PC-based LANSs that support the Named Pipes or TCP/IP
protocol.

Note: Supported network environments and technical requirements are
discussed in detail in the Installation Guide, which is included with the
Essbase server package.

Essbase Application Products

Several optional products, designed to extend and enhance the scope of OLAP
applications, can be addressed using the Essbase server. The following
sections describe these products.

Essbase Spreadsheet Toolkit

Essbase Spreadsheet Toolkit includes over 20 macro and Visual Basic for
Applications (VBA) functions that enable you to build customized Microsoft
Excel and Lotus 1-2-3 applications. The applications incorporate Essbase
commands. Commands such as EssCascade, EssConnect, and EssDisconnect
provide all of the functionality of their corresponding Essbase menu
commands. For more information, see the Essbase Spreadsheet Add-in online
help.

Essbase Partitioning Option

Essbase Partitioning option enables you to define areas of data that are shared
or linked between data models. Partitioning can affect the performance and
scalability of Essbase applications. Partitioning provides more effective
response to organizational demands, reduced calculation time, increased
reliability and availability, and incorporation of detail and dimensionality. For
more information, see|”Accessing Linked Partitions” on page 165]

Essbase Structured Query Language Interface

Essbase SQL Interface enables access to PC and structured query language
(SQL) relational databases by making the Essbase server operate as an open
database connectivity client. Using Essbase SQL Interface, data can be moved
easily from these diverse corporate data sources into the Essbase server for
user access and analysis. For more information, see the Essbase SQL Interface
Guide.

Essbase Application Programming Interface

Essbase Application Programming Interface (API) enables application
developers to create custom applications quickly by using standard tools
while taking advantage of the robust data storage, retrieval, and manipulation
capabilities of Essbase. Essbase API supports Visual Basic and C. For more
information, see the API Reference.

Chapter 2. Introducing Essbase 5



Essbase Currency Conversion

Essbase Currency Conversion translates, analyzes, and reports on foreign
financial data. Any exchange rate scenario can be modeled, and you can even
perform ad hoc currency conversions of data directly from the spreadsheet.
The Currency Conversion product is compliant with Financial Accounting

Standards Board 52 (FASB52). For more information, see

|Currency Conversions” on page 176|

Hyperion Objects

Essbase Integration Services

Essbase Integration Services works with Essbase, Microsoft Excel, and Lotus
1-2-3. Essbase Integration Services is a suite of tools and data integration
services that serve as a bridge between relational data sources and the Essbase
server. Integration Server drill-through is one of the tools of Essbase
Integration Services. Using Integration Server drill-through, you can view and
customize spreadsheet reports that display data retrieved from relational
databases. For more information, see [Chapter 5, “Using Drill-Through” on|

Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in
Essbase servers. You can combine objects with other controls in a visual
design environment to construct new programs.

The Multidimensional Database

6

The Essbase multidimensional database stores and organizes data. It is
optimized to handle applications that have large amounts of numeric data
and are consolidation-intensive or computation-intensive. In addition, the
database organizes data in a way that reflects how the user wants to view the
data.

Definition of Multidimensional

A dimension is a perspective or view of a specific dataset. A different view of
the same data is an alternate dimension. A system that supports simultaneous,
alternate views of datasets is multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on.
Each dimension contains additional categories that have various relationships
one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:

Spreadsheet Add-in User’s Guide for 1-2-3



Figure 1. Two-Dimensional Representations of Data in a Worksheet

An Essbase application contains an unlimited number of dimensions, so you

A | B [ D | E | 6 ]
1 Jan Apr Jun
2 |Sales 1212 1421 1354 1178 1254 1465
3 |COGS 345 392 a7 I 320 401
4 | Margin 867 10239 967 857 934 1064
5
6 |Marketing 45 24 95 11 a6 ]
7 _|Freight 21 71 93 23 aa 21
8 |Discounts 2 24 52 14 53 59
9 [ Total Expenses B9 119 240 43 197 e}
10
11 (Gross Profit 793 910 727 803 737 979
12
13

can analyze large amounts of data from multiple viewpoints.

Database Outlines

Understanding the database outline is the key to understanding Essbase. To
define a multidimensional database, you design its database outline. The

database outline contains the database organization (structure), the database

members, and the database rules, as shown in Figure

Chapter 2. Introducing Essbase
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[~|Database: Basic (Current Alias Table: Default)
— [~ ear Tirme (Active Dynarnic Time Series Members: H-T-D, G-T-D, M-T-D)

Qtrd (+)

— [~ Measures Accounts

— [ Prafit (+)

— [ Inventary (~)

— [v|Ratios (~)

— [~ Product {Caffeinated, Intro Date, Ounces, Pkg Type |
— [ 100 (4 (AMias: Colas)

— [w|200 (+) (Alias: Root Beer)
— [»]300 (+) (Alias: Cream Soda)
— [400 (+) (Alias: Fruit Soda)
L [»| Diet (~) (Alias: Diet Drinks)
— [~ tarket {Population |

— [~ Scenario
— | |Actual (+)

—|__|Budget (~)

— | |“ariance [~}

— [_|"ariance % (~)

— | Ounces Attribute (Type: Mumeric)
— | Pkg Type Attribute (Type: Text)
— | Population Attribute (Type: Mumeric)

Figure 2. Essbase Database Outline

Note: The application designer or Essbase system administrator usually
creates the database outline. For more information on creating the
database outline, see the Database Administrator’s Guide.

The components of the database outline are the following;:
* Dimensions

* Members

* Attributes

* Formulas

¢ Aliases

8  Spreadsheet Add-in User’s Guide for 1-2-3



* Consolidations

Refer to the following sections for descriptions of the outline components.

Dimensions

Dimensions are the most basic categorical definitions of data within the
database outline. You need at least two dimensions to make any meaningful
reference to data; for example, a time dimension and an accounts dimension.
Other dimensions may categorize products, markets, and scenarios. Using
dimensional organization, you can define any consolidation structure or any
slice of data that is relevant to the application. Essbase supports an unlimited
number of dimensions.

Members

Members are the names of the elements within a dimension. A dimension can
contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Essbase use the following terms to describe
members.

* Parents. A parent is a member with a consolidation branch below it. For
example, in the illustration below, Qtrl is a parent member because there is
a branch containing monthly members below it.

atabase: Basic (Currert Aliaz Table: Default)
@Year Time (Active Dyvnamic Time Series Members: H-T-D, @-T-D, M-T-L (Dvnamic Calc)
— [~ @tr () (Dynamic Calc)

— Jan (+)
— Feb (+]
- har [+

— [ @tr2 ¢+ (Dynamic Calc)
— | |Rpr(+)

— | My (]

Jun [+

3 (+] (Dynamic Calc)
Jul i+

— | [Aud ()

Sep (+)

trd [+ (Dynamic Calc)
ot [+

— Mo [+

- Dec (+)

|
2

I
2

Figure 3. Relationships Among Database Members

* Children. A child is a member with a parent above it. For example, Jan, Feb,
and Mar are children of the parent Qtrl.
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* Siblings. A sibling is a child member of the same parent and on the same
branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not
a sibling of Jan, Feb, or Mar, however, because it has a different parent,
Qtr2.

* Descendants. A descendant is a member at any level below a parent. For
example, each member that falls in the Year branch is a descendant of Year.
The following members are all descendants of Year: Qtrl, Jan, Feb, Mar;
Qtr2, Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

e Ancestors. An ancestor is a member of a branch above a member. For
example, Qtr2 and Year are ancestors of Apr.

* Generations. The term generation describes the branch number of a member.
Generations count from the root of the tree (generation 1, which is the
dimension name) toward the leaf node.

e Levels. The term level describes the branch number of a member. Levels
count from the leaf node (level 0) toward the root (the dimension name).

Attributes

Attributes describe characteristics of data, such as the size and color of
products. Through attributes, you can group and analyze members of
dimensions based on their characteristics. Attribute dimensions must be
associated with base dimensions. For more information, see the Database
Administrator’s Guide.

Formulas

Each database member can have one or more formulas associated with it in
the database outline. For example, the Variance members of the Scenario
dimension, as shown in Figure El contain formulas. Formulas can be simple or
complex. For more information, see the Database Administrator’s Guide.

Aliases

Essbase supports alternative names, or aliases, for database members. Aliases
are useful when various labels are used for the same member in various
worksheets. One worksheet, for example, may refer to Cost_of_Goods_Sold as
COGS. Aliases also can be used for reporting in alternative languages or for
more formal output name sets, such as account numbers.

Consolidations

Consolidations in Essbase applications are defined by member branches. The
database outline determines consolidation paths. The determination is based
on the location of members within a dimension. Indentation of one member
below another indicates a consolidation relationship. Indenting members is
important for the drill-down capabilities in Essbase Spreadsheet Add-in. As
you navigate your way through data, you can drill down through levels of
consolidations. The database outline is the roadmap that determines the levels
of data navigation.
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Chapter 3. A Basic Essbase Tutorial

When you add Essbase Spreadsheet Add-in to Lotus 1-2-3, most Lotus 1-2-3
operations remain unchanged; Essbase Spreadsheet Add-in simply adds a new
menu, a Essbase toolbar, and mouse shortcuts with which you can access the
Essbase server.

The tasks described in this tutorial are basic tasks. That is, these are tasks that

you probably use often when working with Essbase. [Chapter 4, “A

|[Advanced Essbase Tutorial” on page 95| describes more advanced tasks. This
tutorial chapter contains the following sections:

* ['Getting Acquainted with Essbase Spreadsheet Add-in” on page 11|

* ['Preparing to Begin the Tutorial” on page 17

* [‘Retrieving Data” on page 23
* [“Pivoting, Retaining, and Suppressing Data” on page 35|

* [“Formatting the Worksheet” on page 50|

* [‘Creating Queries Using Essbase Query Designer” on page 65|

* ["Deleting Queries” on page 78|

* ["Viewing Messages and Confirmations” on page 78|

* [“Accessing Help” on page 79|

* [‘Selecting Members” on page 82|

* [‘Saving and Disconnecting” on page 91|

* ["Moving on to Advanced Tasks” on page 93|

Note: Each tutorial task builds upon the previous task. Therefore, tasks must
be completed in succession.

The examples used in this tutorial are based on the sample database (called
Sample Basic) that is included with the Essbase installation. Contact the
Essbase system administrator for information about accessing the Sample
Basic database or about accessing other databases on the Essbase server.

Getting Acquainted with Essbase Spreadsheet Add-in

This section provides the following information to help you get acquainted
with Essbase Spreadsheet Add-in:

* ["Adding Essbase Spreadsheet Add-in” on page 12
* [‘Starting Essbase Spreadsheet Add-in” on page 13

s [“Accessing Online Help” on page 14|
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* ['Enabling Mouse Actions” on page 15|
Adding Essbase Spreadsheet Add-in

If you manually update your environment settings or if you have removed
Essbase Spreadsheet Add-in from the Lotus 1-2-3 environment, you must use
the Lotus 1-2-3 facility to add Essbase Spreadsheet Add-in into Lotus 1-2-3.
The facility adds the Essbase menu to the Lotus 1-2-3 menu bar and points
Lotus 1-2-3 to the Essbase Spreadsheet Add-in file in the \Esshase\bin
directory. This file is on the hard drive of your PC, if that is where you
installed Essbase Spreadsheet Add-in, or on the network drive if that is where
you set up your PC operating environment to run Essbase Spreadsheet

Add-in.

To add Essbase Spreadsheet Add-in to Lotus 1-2-3:

1. In Lotus 1-2-3, select File > Add-Ins > Manage Add-Ins.
Lotus 1-2-3 displays the Manage Add-ins dialog box.

2. Click Register and select the file ESS123.12A in the \Esshase\bin directory
where you installed Hyperion Essbase Spreadsheet Add-in on your PC
hard drive (if you installed the Add-in software there), or in the bin
directory where the Hyperion Essbase system administrator installed the
Hyperion Essbase Spreadsheet Add-in on a network drive (if you set up
the PC operating environment to run the Add-in software there).

3. Click Open and select the ESS123.12A add-in file. Make sure there is a

check mark next to the add-in file.

Manage Add-Ins [ x| I

W L AE SoEAaE WOINeE 551 21 28

Check an Add-in to load it; uncheck it to unload it

¢ Cohlotuzh 12 adding\dgaui 1 2a

Done

Beaizter...

Remove

Help

Figure 4. Manage Add-ins Dialog Box

4. Click Done to close the Manage Add-ins dialog box and start the

Hyperion Essbase Spreadsheet Add-in.
The Essbase startup screen is displayed.
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If you do not see the Essbase startup screen or if your system does not list
the Essbase Spreadsheet Add-in menu options, see the Installation Guide for
troubleshooting information.

Starting Essbase Spreadsheet Add-in
Because Essbase Spreadsheet Add-in software for Lotus 1-2-3 is implemented
as a Lotus 1-2-3 add-in, you must start Lotus 1-2-3 from Windows to use
Essbase Spreadsheet Add-in software.

You must open a worksheet before attempting to connect to the Hyperion
Essbase server. An attempt to connect to theHyperion Essbase server without
opening a worksheet results in an error message.

To begin an Essbase session:

1. Start Lotus 1-2-3.
After the Lotus 1-2-3 startup screen disappears, the Essbase startup screen
is displayed.
The Hyperion Essbase menu should be displayed in the Lotus 1-2-3 menu
bar. If you do not see the Hyperion Essbase menu, you may need to use
the Lotus 1-2-3add-in facility to add Essbase Spreadsheet Add-in into
Lotus 1-2-3. For more information, see|[“Adding Essbase Spreadsheet|
[Add-in” on page 12|

2. From the Lotus 1-2-3 menu bar, select Essbase to open the menu.

Chapter 3. A Basic Essbase Tutorial 13
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BRetrieve

Keep Only

Remave Only

Zoom [n

Zoom Out

Pivot

Mavigate Without [ ata
Linked Objects...
Luery Designer...

FlazhB ack
Options...

Member Selection...
Currency Repaort...
Cazcade...

Rigtrieve & Lock
Lock

Unlock

Send
Lalculation...

Connect...
Disconnect...
Eszhaze Help

Figure 5. The Essbase Menu

Note: If the Lotus 1-2-3 status bar is not displayed, you can display it by
selecting View > Show Status Bar.

Accessing Online Help

Essbase Spreadsheet Add-in includes a context-sensitive online help system.
You access the Essbase Spreadsheet Add-in online help in one of three ways.
Which way you choose depends on the type of information that you need,

* Access the entire online help system for browsing or searching for information. To

access the entire help system, select Essbase > Essbase Help. After you
access online help, you can browse or search through the system to view
general information on Essbase Spreadsheet Add-in, Essbase command
descriptions, procedural information for completing tasks, Spreadsheet
Toolkit macros, and Visual Basic for Applications (VBA) function
descriptions.

Access context-specific information from dialog boxes in Essbase Spreadsheet
Add-in. Each dialog box in Essbase Spreadsheet Add-in features a Help
button that accesses online help topics that are specific to the particular
dialog box. The buttons enable you to find the information you need
without having to search through the entire help system.

Note: The Essbase Spreadsheet Add-in online help also provides a
comprehensive section on Essbase Spreadsheet Toolkit, which enables
you to customize and automate your use of Essbase by using Lotus
1-2-3 macros.
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* Access information on a specific Hyperion Essbase Query Designer function.
Access What’s This? Help in the Hyperion Essbase Query Designer dialog
box, and then click an item in the dialog box to access information on that
item.

H
Figure 6. EQD Help Button

Enabling Mouse Actions

The following terms are used throughout this guide to describe mouse
operations:

* Primary mouse button and secondary mouse button describe the buttons on a
two- or three-button mouse. Usually, right-handed users configure the left
mouse button as the primary button and the right mouse button as the
secondary mouse button. The primary mouse button is the one that you use
to start Windows applications, such as Lotus 1-2-3; the secondary mouse
button is used for auxiliary operations. The term click refers to use of the
primary mouse button. The term right-click refers to use of the secondary
mouse button.

* Select chooses the object that is under the cursor when you press and
release the primary mouse button. You can select a worksheet cell, for
example, by moving the cursor to the cell and pressing and releasing the
primary mouse button.

* Click (that is, both click and right-click) describes a quick press-and-release
action on a command object. You can click a button, for example, to execute
a command.

* Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example,
to start a Windows application.

* Drag describes a press, hold, and move action. You place the cursor on an
object, press a mouse button, hold the mouse button and move the object,
and release the mouse button when you reach your goal. For example, you
can highlight a range of cells in Lotus 1-2-3 worksheet by dragging the
cursor over the cells.

Note: Hyperion Essbase uses a drag operation called a pivot. A pivot
requires use of the secondary mouse button. To execute a pivot, you
must press and hold the secondary, rather than the primary, mouse
button while dragging the selection.

Essbase offers enhanced mouse actions in Lotus 1-2-3. You can use the mouse
to do any of the following:

* Retrieve data
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* Drill down and drill up on database members

* Pivot (move or transpose) data rows and columns
* Access linked reporting objects

* Access linked partitions

To enable double-clicking to retrieve, drill down, and drill up on Essbase data:
1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Global tab.

3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up
to less detailed data (secondary mouse button). When the double-clicking

option is enabled, the Lotus 1-2-3 in-cell editing feature is overridden.
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[ Mavigate without Data Addns..
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Figure 7. Essbase Options Dialog Box—Global Tab

4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the Essbase
Spreadsheet Add-in online help.

Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:

* [‘Setting Essbase Options” on page 18§|

* [‘Following Guidelines During the Tutorial” on page 21|

* ['Reviewing the Sample Basic Database” on page 22|
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Setting Essbase Options
Before you begin the tutorial steps, make sure that the worksheet options are

set to the initial settings as illustrated in Figure [8] through Figure [L1] If the
option settings are different, the illustrations presented in this chapter may

not match the worksheet view.

Note: For information about each option in the Essbase Options dialog box,
see the Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display of the Display tab matches the following illustration:

Eszshase Options

Display |Z|:u:|m | Mode | Global |

v Adjust Columns
[T fute Sort Bavs
[ Eepeat Member Labels

— Indentation — Replacement
T Mgne HMissing Label: |
" Subijtemns T .
ok Mo Accesz Label: I
— Suppresz —Aliazes
[T #Missing Fows V¥ Lsze Aliazes
[T Zem FRows [T Use Bath Member Mames and Aliazes
[ Underscore Characters for Row Dimensions
= Aliaz:
—Cellz
[ Use Styles I j

— Euey Dezigner
[ Usze Sheet Options with Querny Desigrner

— Dynamic Time Seres

[™ Latest Time Period I

[4

o]

Cancel

Help

Figure 8. Initial Settings for Display Options
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4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your
display of the Zoom tab matches the following illustration:

Ezzbaze Ophions
Display  Zoom | Made | Glabal |

Zoom |n

* HNext Level
Al Levels

(" Bottom Level

" Sibling Level

" Same Level

" Same Generation

" Formulas

M ermber Fetention

[+ Include Selection

[ "within Selected Group

[ Femove Unselected Groups

Huybrid Analyziz
[ Enable Hybrid Analysiz

k. | Cancel Help

Figure 9. Initial Settings for Zoom Options

6. Select the Mode tab.

7. Select the appropriate check boxes and option buttons so that your
display of the Mode tab matches the following illustration:
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Esshase Options
Displa_l,l] Zoom  Mode lGIDbaI]

Retrewval
v 4 dvanced Interpretation
" Free Form

=

Mode
[ Update Mode

Formula Prezeration

[ Betain on Retrieval
-
-

-

Mate: Certain optiohs cannot be uged in conjunction with Farmula Preservation,
|f any af theze options are selected, the Formula Prezervation optionsz are grayed out and
cannot be selected, and vice verza. Click Help far mare infarmation.

QE. | Cancel Help

Figure 10. Initial Settings for Mode Options

Note: If you are already connected to a Essbase database, the Essbase

Options dialog box also displays a Style tab. You can skip this tab

for now.
8. Select the Global tab.

9. Select the appropriate check boxes and option buttons so that your
display of the Global tab matches the following illustration:
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Displa_l,l] Zoom ] bdode ] Style  Global l

Mouze Achions Dizplay Mezzages
[+ Enable Secondany Buttor £ Infarmation
¥ Enable Double-Clicking (" wamings
[+ Enable Linked Object Browsing (" Erors
" Mone
M emary [ Dizplay Unknown Members
[+ Enable Flashback
Log File
tember Select [+ Boute Meszages to Log File
[ Display Save Dialog [V Purge Log File Every Session

tode

[ Mavigate without Data Addns..

k. | Cancel Help

Figure 11. Initial Settings for Global Options

Note: You should have already selected the appropriate boxes for Mouse
Actions, as described in [“Enabling Mouse Actions” on page 15,

10. Click OK to save the settings for this session and close the Essbase
Options dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:

¢ Tasks that should not be performed as part of the tutorial are displayed in
gray boxes. These tasks are included only for your future reference. You can
find more information on these tasks in the Essbase Spreadsheet Add-in
online help.
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* You must be connected to the Sample Basic database during the tutorial. If
you are not connected to this database, the illustrations presented in this
chapter will not match the worksheet view.

* You can access many Essbase commands in any one of these ways:
— By selecting the command from the Essbase menu
— By dlicking the appropriate button on the Essbase toolbar

— For the Zoom In and Zoom Out commands, by double-clicking either the
primary mouse or the secondary mouse button

* You must set the options in the Essbase Options dialog box as described in
[‘Setting Essbase Options” on page 18] If the option settings are different,
the illustrations presented in this chapter may not match the worksheet
view.

* After you change a worksheet option in the Essbase Options dialog box,
you must perform a retrieval or a drill-down operation to have the new
setting take effect.

* Be sure to follow each step in the tutorial. Each tutorial task builds upon
the previous task. Do not skip the final steps at the end of sections, because
these steps are often necessary to prepare you for the next tutorial task.

* If you make a mistake during the tutorial, you can select Essbase >
FlashBack to return to the previous worksheet view.

* The values in the Sample Basic database that represent ratios or percentages
are calculated to a very high level of precision (for example, 55.26162826).
In Lotus 1-2-3, you can apply a cell format to control the number of decimal
places that are displayed in data values. For more information, see the
Lotus1-2-3 documentation.

* The numeric values that are shown in the illustrations used throughout this
tutorial may not match the values stored in your database. The values
shown in these illustrations reflect a freshly loaded database.

* Some worksheet columns have been adjusted for clarity in the illustrations.
You do not need to change the width of columns in the worksheet to follow
the tutorial steps. The Adjust Columns option in the Essbase Options dialog
box (Display Tab) adjusts columns for you.

Reviewing the Sample Basic Database

The Sample Basic database that you use for the tutorial is based on a
hypothetical company in the beverage industry. The major products of the
company are various kinds of sodas. These products are sold in U.S. markets,
which are categorized by state and region. Financial data for the company is
collected monthly and is summarized by quarter and by year. The company
uses Essbase to calculate financial and accounting data, such as sales, cost of
goods sold, and payroll. The company tracks both actual and budget data, as
well as the variance and percent variance between the two.
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Retrieving Data

Now that you are more familiar with the Essbase environment, you can
connect to the Essbase server and start using Essbase and Essbase Spreadsheet
Add-in. The following section guides you through a typical Essbase session
where you connect to a database and retrieve data in various ways.

This section outlines the following basic retrieval tasks:

* [“Connecting to a Database” on page 23|

* ["Changing a Password” on page 25|

* [‘Retrieving Data from a Database” on page 25|

* [‘Canceling a Data Retrieval Request” on page 27|

* ['Restoring the Previous Database View” on page 27|

* ['Drilling Down to More Detail” on page 28|

* [‘Drilling Up to Less Detail” on page 32

.| ‘Customizing Drill-Down and Drill-Up Behavior” on page 33|

Note: Make sure that you followed the steps in [“Setting Essbase Options” on|
If the settings in the Essbase Options dialog box are different
from the settings previously illustrated, the worksheet view will differ
from the illustrations shown in this chapter.

Remember that you can perform common data retrieval tasks by doing any of
the following:

¢ Selecting commands from the Essbase menu on the Lotus1-2-3 menu bar
* Clicking the appropriate buttons on the Essbase toolbar
* Double-clicking the primary or the secondary mouse button in the
appropriate cell (for Retrieve, Zoom In, and Zoom Out commands)
Connecting to a Database

To access Essbase data, you must first connect to a database on the server.
This tutorial assumes that you have the appropriate privileges to connect to a
server, an application, and a database.

1. Select Essbase > Connect
Essbase displays the Essbase System Login dialog box.
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Essbase System Login [ %]

Server. ILocthost j ] 4 I
Usemame: W ﬂl
Password: l— Help |

Lhange Fassword.. |

Application/D atabaze:

[Ipdate |
Hote... |

Figure 12. Essbase System Login Dialog Box

Note: To complete the steps that follow, you need to know the name of
the Essbase server, your username, and your password. If you do
not have this information, contact the Essbase system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want does not display in the list, you can type in the
name of the server you want to access.)

3. Press Tab to move to the Username text box; type your username in the
text box.

4. Press Tab to move to the Password text box; type your password in the
text box.

Note: You can change your password when you are connected to a server.
To change your password, see [’Changing a Password” on page 25

5. To connect to the server, click OK.

Essbase displays a list of available application/database pairs in the
Application/Database list box. An Essbase server enables simultaneous
access to multiple applications. An application can contain multiple
databases. Only the databases to which you have security access are
shown in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the
list. If Sample Basic is not shown in the Application/Database list box, ask
the Essbase system administrator to install it.
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Figure 13. Available Application and Database Pairs

6. In the Application/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.

If the application is not already running, Essbase automatically starts it. There
may be a brief pause as the application loads. The time required to start an
application depends on the number of databases, the sizes of the databases,
and the sizes of the indexes of the databases contained within the application.

Changing a Password
You can change your password only if you are connected to a server.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

To change your password:
1. In the Essbase System Login dialog box, select the Change Password button.

2. In the Change Password dialog box in the New Password text box, type your
new password.

3. In the Confirm Password text box, type the password again.
The passwords must be identical.

4. Click OK to change your password.

5. Click OK again to close the Essbase System Login dialog box.

Retrieving Data from a Database

Each time you retrieve information from an Essbase server, the following
actions occur:

* Essbase Spreadsheet Add-in requests data from the server.
* The server processes the request and prepares the data.
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* The server transmits the data to Essbase Spreadsheet Add-in.

* Lotus 1-2-3 receives the data from Essbase and organizes it in a worksheet.

To help you monitor these operations, Essbase uses three custom cursors.

Table 2. Essbase Custom Cursor

This cursor: Is displayed when:

E Essbase requests information from the server.
'

The server is processing the request.

E The server returns the data.
.

Note: Small retrieval actions display the cursors very quickly; you may not
notice changes in the direction of the arrow when retrieving small
amounts of data.

To retrieve data into an empty worksheet:

1. Open a new worksheet by selecting File > New or by clicking the QI
button.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in [“Connecting to a Database” on|

2. Select Essbase > Retrieve.

Essbase retrieves data into the Lotus 1-2-3 worksheet.
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Figure 14. Initial Data Retrieval from Sample Basic

Because you selected the Enable Double-Clicking box in the Essbase Options
dialog box (Global tab), you can double-click in an empty cell to retrieve
data. You can also click the Retrieve button on the Essbase toolbar.

When you retrieve data into an empty worksheet, Essbase returns data from
the top levels of each database dimension. The top level is used as a starting
point to navigate, or drill down, into levels of detailed data. In the Sample
Basic database, the following five dimensions are retrieved: Measures,
Product, Market, Scenario, and Year.

For the remainder of tasks in this tutorial, you can retrieve data by
double-clicking in a data cell, selecting Essbase > Retrieve, or by clicking the
Retrieve button on the Essbase toolbar.

Canceling a Data Retrieval Request

Occasionally, you may want to cancel a retrieval request. For instance, you
may want to stop a request if a retrieval is taking longer than expected or if
you mistakenly double-click.

Because Essbase returns data so quickly to the worksheet, you may not be
able to cancel a retrieval before the retrieval is complete. The cancel feature is
most useful when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.
Note: You can cancel a retrieval only while Essbase is processing in Essbase

Spreadsheet Add-in. You cannot cancel a retrieval when Essbase is
processing from the server.

Restoring the Previous Database View

The FlashBack command restores the previous database view. A database view
is simply what you see in the worksheet after a retrieval or navigation
operation. FlashBack is similar to the Lotus 1-2-3 Edit > Undo command,
which reverses the last action. The FlashBack command uses the memory of
your machine to store the current view before processing an Essbase retrieval
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request. You can use FlashBack to undo only the most recent operation.
FlashBack cannot undo multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are
presented. If you make a mistake or find yourself out of step with the tutorial,
you can use the FlashBack command from the Essbase menu or toolbar to
undo the last command and return to the previous database view. If you want
to start the tutorial over from the beginning, select the entire worksheet and
select Edit > Clear > All. Then press Enter or click OK to empty the worksheet
and start again.

You can disable FlashBack during normal operations to conserve memory on
your local machine. Do not disable FlashBack for this tutorial.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

To disable Flashback:
1. Select Essbase > Options and click the Global tab.
2. Clear the Enable FlashBack check box.

Drilling Down to More Detail

With Essbase, you can drill down to various levels of multidimensional data
in the worksheet. For example, if you want to view data for a specific quarter
or month rather than an aggregate data value for the whole year, you can drill
down on the Year dimension to see more detailed data.

You have three options for drilling down on a member:

* Select the member and select Essbase > Zoom In.

* Select the member and double-click the primary mouse button.

* Select the member and click the Zoom In button on the Essbase toolbar.

To drill down to lower levels of the Year dimension:
1. On Year in cell A2, double-click the primary mouse button.

The drill-down action retrieves data for the level below (the children of)
Year: Qtrl, Qtr2, Qtr3, and Qtr4.
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Figure 15. Result of Drilling Down on the Year Dimension

Measures Product Market Scenario

Note: For a discussion of the relationships among Essbase database

members, see [“Database Outlines” on page 7}

With Essbase, you can retrieve members into grouped, or nested, columns
or rows. Row groups containing more than one level of data are nested
within single-member row groups. For example, a row group containing
Qtrl, Qtr2, Qtr3, and Qtr4 may be nested within a single-member row for
a specific region, such as East (see the following illustration). Drilling
down to lower levels of database members is one way to retrieve data into

nested groups.

In cell D1, double-click to drill down on Market and create nested groups
of rows down the worksheet.

A | B | C D E | F |
1 MeasuresIF'rnduu:t_Sn:enarin
2 |East Gt 5380
3 (2 b499
4 (13 b34h
9 (trd a935h
b6 Year 24161
I [West (2t 7137
g (2 /915
9 (3 7939
10 (trd 7270
11 Year 298R1

Figure 16. Result of Drilling Down on the Market Dimension (Nested Rows)
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Because worksheets can accommodate more rows than columns, Essbase is
preset to retrieve data into rows when you drill down on a member. You
can change this default behavior and display the results of a drill-down
across columns. Drilling across columns applies only to the top-level
member of a dimension (for example, Market or Scenario).

Follow these steps to drill down on Scenario and retrieve its respective
members into columns rather than rows:

1. Press and hold the Alt key.
2. Double-click Scenario (in cell E1).
3. Release the Alt key.

Essbase displays the data in columns across the worksheet.

A | B | ¢ | D E F | 6 |
1 Measures Product | I
. Actual Budget ‘“ariance “ariance % Scenario
3 |East e 5350  BS00 11200 -17 23076923 5380
4 Qtr2 B499 7550 1051 -13.9205295 B4599
5 Ctr3 G345 7550 -1204 0 -15.94701957 5345
& Ctrd 8935  B7S0 -394 1257731958 5336
7 W ear 24161 28330 4228 1489609017 24161
8 |[West Qtr1 71537 8960 -1823 -20.34595214 7157
9 Cltr2 7515 9240 1775 -19.1065652 7515
10 Qtr3 7939 8570 -1931 -18.56433637 7959
11 Cltrd 7270 9060 S1790 -18.75717439 7270
12 ear 295861 37180 7318 -19.68531469 29561

Figure 17. Result of Drilling-Down on the Scenario Dimension (Nested Columns)
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Drilling Down on Attribute Members
You can use the Essbase attribute feature to retrieve and analyze in terms of

characteristics, or attributes, of dimensions. For example, you can analyze
product profitability based on size or packaging. Attribute dimensions are
associated with base dimensions.

You can use an attribute dimension to drill down on the base dimension with
which it is associated. In the Sample Basic database, the Product base
dimension is associated with several attribute dimensions, such as
Caffeinated, Ounces, and Pkg_Type. Each attribute dimension consists of level
0 attribute members. Level 0 attribute members are the lowest level attributes
that are associated with members of a base dimension. The Pkg Type attribute
dimension, for instance, has two level 0 members, Bottle and Can.
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You can extract information on all products sold in a can by entering
manually the name Can in the worksheet. You can also use Essbase Query
Designer or the Essbase Member Selection dialog box to select the attribute
and display it in the worksheet.

Open a worksheet, connect to the Sample Basic database, and select Essbase >
Retrieve. Select Product and replace it with Can by typing Can manually.
Click anywhere outside of cell C1 and select Essbase > Retrieve again. Figure
displays the results:

A,

B C L E

2 | Year

Mezsuras Can Marizat Soenatio
34578

Figure 18. An Attribute Member in a Report

Drill down to all products sold in a can by double-clicking Can in cell C1.
Cola, Diet Cola, and Diet Cream are the members of Product that have the
Can attribute. The result is displayed below:

A | B C D | E | F
1 . _Measures Market Scenatio
2 |Year Can Cola 22T
3 Diet Cola 5708
4 Diet Cream 11093

Figure 19. Result of Drilling Down on an Attribute Member

Drilling Down on Level 0 Attribute Members
The following is a description of the general behavior of Essbase Spreadsheet

Add-in when you drill down on a level 0 attribute member:

¢ If the level 0 attribute member is in a column, a drill-down pivots the
attribute to the innermost row of the worksheet.

* If the level 0 attribute member is in a row, a drill-down does not change the
position of the attribute in the worksheet.

* A drill-down on a level 0 attribute member displays the associated base
members to the right of the level 0 attribute.

* If there is more than one level 0 attribute member in a worksheet, a
drill-down on one attribute displays other attributes to the left of the level 0
attribute member. Level 0 attribute members in columns pivot to rows, and
level 0 attribute members already in rows remain in rows.
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¢ A drill-down on non-level 0 attribute members is the same as the current
drill- down behavior for other types of members.

The drill-down behavior for non-level 0 attribute members is the same as the
current drill-down behavior for other types of members. See the Essbase
Spreadsheet Add-in online help for examples of drilling down on level 0
attribute members. For more information on attributes, refer to the Database
Administrator’s Guide.

Drilling Up to Less Detail

With Essbase, you can drill up to higher levels in the multidimensional
database outline by collapsing the current member tree. For example, if you
previously drilled down on a dimension, such as Scenario, to view data for
Actual and Budget, you may need to drill up to view aggregate data for the
Scenario dimension.

You have three options for drilling up on a member:

* Select the member and select Essbase > Zoom Out.

* Select the member and double-click the secondary mouse button.

* Select the member and click the Zoom Out button on the Essbase toolbar.

To drill up on the Scenario dimension in the current worksheet:

1. On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or
G2), double-click the secondary mouse button.

Essbase collapses the members of the Scenario dimension.

A | B | ¢ | b | E | F | 6 | H

1 Measures Product

2z Scenario 1

3 |East Citr 5380

4 itz G499

i i3 G345

6 Citrd 5036

I ear 24161

Figure 20. Result of Drilling Up On the Scenario Dimension

2. In cell A3, double-click the secondary mouse button to drill up on East.

Essbase collapses East, West, South, and Central into the single Market
dimension and keeps the dimension in the A column.
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A | B | € [ b [ E J F | &6 [ H

1 Measures Product
2 SCenaro

3 Iedarket 1t 24703

4 Qitr2 27107

5 Qi3 27912

b Citrd 25800

7 Year 105622

Figure 21. Result of Drilling Up On East

Customizing Drill-Down and Drill-Up Behavior

You can customize the behavior of the Zoom In and Zoom Out commands in
the Essbase Options dialog box. The following steps illustrate some drill-down
and drill-up techniques.

To retrieve all members of a dimension with a single drill-down operation:
1. Select Essbase > Options and select the Zoom tab.
Essbase displays the Zoom Tab.

—Zoom |n

Al Levels

" Bottom Level
" Sibling Level
' Same Level

" Same Generation
' Formulas

— Member Retention
¥ Include Selection

™ ‘within Selected Group

™ Remove Unselected Gioups

Figure 22. Zoom In and Member Retention Option Settings

The Zoom In option group contains items that enable you to customize
drilling behavior. You can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select
Bottom Level, Essbase retrieves data for the lowest level of members in a
dimension. With this option, a drill-down on Year retrieves Jan, Feb, Mar,
Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retains the selected member along with the other members
retrieved as a result of a drill down. For example, if you drill down on

Chapter 3. A Basic Essbase Tutorial 33



34

Qtrl, Essbase retrieves data for Jan, Feb, and Mar, as well as for Qtrl.
When this option is disabled, Essbase retrieves data only for Jan, Feb, and
Mar; Qtrl is eliminated.

Note: For more information on the Zoom In and Member Retention
option groups, see the Essbase Spreadsheet Add-in online help.

In the Zoom In option group, select the All Levels option and click OK to
save the setting.

In cell A3, drill down (double-click) on Market.
In cell C2, drill down (double-click) on Scenario.

Essbase retrieves all members of Market and Scenario. For the Market
dimension, Essbase drilled down two levels to get to the bottom-most
members, which are individual states. The Scenario dimension has only
one member level, so the members of Scenario would also be retrieved if
you selected Next Level in the Zoom In option group.

I A B | ¢ [ p | E | F .G

1 | ] Measures Product

2 Actual  Budget  Wariance Mariance % Saenario
3 Mew York it 1656 2000 -344 172 1656
4 tr2 2363 2610 247 -9 46360153 2363
5 tr3 1943 2290 -347 -15. 15283584 15943
b i2trd 2240 2320 -g0 -3.44327536 2240
Fi fear g202 9220 -1018 -11.0412148 g202
8 |Massachusetts  Gitrd 1632 1590 -158 -0.34911243 1532
9 itz 1750 1900 -1E60 -7.894 73634 1750
10 itr3 1936 2100 -164 -7 B096233H 1936
11 itrd 1494 1610 116 -7.20495894 1494
12 ‘fear 6712 7300 588 -8.054 70452 6712

Figure 23. Result of Drilling Down to All Member Levels

5.
6.

Select Essbase > Options and select the Zoom tab.
Return the Zoom In option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected
Group in the Member Retention option group.

To drill up only on Qtrl:

1.

In the Member Retention option group on the Zoom Tab, click the Within
Selected Group check box and click OK.

Make sure that Include Selection is also still checked.
To drill up on Qtr 1 (in cell B3), double-click the secondary mouse button.
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Notice that drilling up to the Year dimension affects only New York. All
other states show data for all four quarters.

| A 8 | e | b | E | F e |

1 | ] Measuras Product

2 Actual  Budget  Nariance Mariance % Scenario
3 Mew York ear 2202 8220 -1018 -11. 04121475 8202
4 Massachusetts Gt 16532 1630 -158 -3.349112426 1632
5 tr2 1750 1900 -150 -7 804735842 1750
G itr3 1936 2100 -164 -7.B0052381 1934
7 Sitrd 1494 1610 116 -7.204068044 1494
8 Year §712 7300 588 -5. 054794521 6712
9  [Florida it 1070 1300 230 -17.69230769 1070
10 Gtz 1338 1570 21 -14.7133768 1334
11 tra 1485 1730 235 -13.58381503 1495
12 Gitrd 1125 1300 -176 -13.46153844 1125

Figure 24. Result of Drilling Up Within a Selected Group

3. Before moving on with the tutorial, disable the Within Selected Group
option:
a. Select Essbase > Options and select the Zoom tab.

b. In the Member Retention option group, clear the Within Selected
Group check box.

4. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Pivoting, Retaining, and Suppressing Data

After you retrieve data into the worksheet, you may want to manipulate the
data in various ways. For example, you may want to move rows and columns
to different positions in the worksheet, or you may want to tell Essbase to
suppress or retain specific data during data retrievals.

To help you manipulate worksheet data, this section steps you through the
following procedures:

* ['Pivoting Rows and Columns” on page 35

* [‘Retaining a Data Subset” on page 40|

* ['Removing a Data Subset” on page 43|

* ['Navigating Through the Worksheet Without Retrieving Data” on page 43

* [‘Suppressing Missing Values, Zero Values, and Underscore Characters” on|
page 42]
Pivoting Rows and Columns

With the Pivot command, you can change the orientation of worksheet data.
Use the Pivot command to do any of the following:
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* Move a row group to a column group
* Move a column group to a row group
* Change the order of row groups

* Change the order of column groups

You can execute the Pivot command in two ways:

* Select the member cell that you want to pivot, and select Essbase > Pivot.
This method applies only to moving a row group to a column group or a
column group to a row group.

* Click in the center of the member cell that you want to pivot, press and
hold the secondary mouse button, and drag the group to the desired
location. This method applies to swapping row and column groups and to
changing the order within groups.

To pivot Year data from a row group to a column group:
1. To open a new worksheet, select File > New or click the QI icon.
Note: You should already be connected to the Sample Basic database. If

you are not connected, follow the steps in [“Connecting to a|
[Database” on page 23|

2. Select Essbase > Retrieve.
3. Dirill down (double-click) on Measures and Product (in cells B1 and C1,

respectively).
4. Press and hold the Alt key, and, in cell E1, drill down (double-click) on
Scenario.
A ] B [ c] D | E | F [ G | H

11| Market
| 2 | Actual Budget “ariance “ariance % Scenartio
| 3 (100 Profit Year 30468 41840 S114720 27 35335195 30468
| 4 | Inventory Year 29448 31590 2142 B.780626781 29448
| 5 | Ratios Year| &Y. 27288145 57 BZA0049 0351123447 -0B09335377 57 27288145
| 6 | Measures Year 30468 41940 S11472 0 27 35336195 30468
|7 (200 Profit Year 27854 35850 -FO8E -22.24200278 27954
| 8 | Inventary Year 33000 31090 -1910 -B.143454457 33000
| 9| Ratios Year | B5.53966505 57 46674162 -1.927V075664 -3.353375551 5553966595
|10 | Measures Year 27854 35850 -F996 2224200278 27954
| 11 (300 Profit Year 25799 29360 -3561 1212674659 25799
112 | Inventary Year 28865 27140 S1725 -B.355932203 28865
113 | Fatios Year 59423795671 5713950437 -2.901548161 -5.078007182 54.23795671
| 14 | Measures Year 25799 29360 -3561 -12.1287 4650 25799
| 15 [400 Profit Year 213 22130 -5929 -3.746045021 213M

Figure 25. View Before Pivoting
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5. In cell C3, select Year and select Essbase > Pivot.

Figure 26. Result of Pivoting a Row Group to a Column Group

A B | C | D E F

1 ear Market

2 Actual Budget “ariance “ariance %

3 |100 Profit 30465 41940 11472 -27 35336155
4 Inventory 29448 31520 2142 B.780E267581
] Ratios 57 27288145 57 B240049 -0.351123447 -0.B09335377
b Measures 30468 41940 11472 -27 353361595
7 |200 Frofit 27954 35950 S7996 22 24200278
] Inventory 33000 31020 1910 -6.1434544587
9 Ratios 5553966595 57 46674162 -1.927075664 -3.353375551
10 Measures 27954 35950 S7996 22 24200278
11 |300 Profit 25799 29360 -3561 -12.1267 4655
12 Inventory 28865 27140 -1725  -B.355932203
13 Ratios 54 23795671 57.13950457  -2.901548161 -5.078007 1582
14 Measures 25799 29360 -3561 -12.1267 4659

Essbase pivots the Year dimension to a column group next to Market
(above the Scenario members).

6. As another example, in cell C2, select Actual.
7. Right click and drag Actual to product 100 in cell A3.

Figure 27. Pivoting a Column Group to a Row Group

| B | C | D | E | F

1 ear hlarket

2 Actual Budget Yariance Yariance %

3 [100 [Actual Budget Variance Variance? Scenario| 11472 -27.35336155
4 Trventory JEF JTEH] 2142 B.780626731
5 Fatios A7.27288145 A7 B240049  -0.351123447  -0.B09335377
] Measures 30458 41940 11472 -27 353361595
7 |200 Profit 27954 35950 S7996 22 24200278
] Inventory 33000 31080 -1910 -5.143454487
9 Ratios 5563966595 57 46674162 -1.927075664 -3.353375551
10 Measures 27954 35950 STH95 22 24200278
11 |300 Profit 25799 29360 -3561 -12 126874659
12 Inventory 28865 27140 -1725 -B.3555932203
13 Fatios A4 23795671 A7.13950437  -2.901548161 -5.078007 182
14 Measures 25739 29360 -3561 -12.1267 4653

Note: The member label box that is displayed under the cursor during the
pivot operation displays the names of the members that you are
pivoting. The orientation of the member label box, however, does not
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determine the orientation of the pivot result. Essbase determines the
data orientation by the location of the destination cell.

Essbase pivots the Scenario members (Actual, Budget, Variance, and
Variance%) from a column group to a row group that is displayed to the
left of the Product members.

A | B | C | D | E | F |
1 Year Market
2 |Actual 100 Profit 30463
3 1 Inventary 294458
4 Ratios a7 272aa145
] Measures 30468
[} 200 Profit 27954
7 Inventary 33000
] Ratios 55 53966595
9 Measures 27954
10 300 Profit 25799
" Inventary 28865
12 Ratins 54 23A79E67 1
13 Measures 25799
14 400 Profit 21301

Figure 28. Result of Pivoting a Column Group to a Row Group

To transpose the order of row groups:
1. In cell A2, select Actual.
2. Right-click and drag Actual to Profit (cell C2).
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Figure 29. Pivoting the Order of Row Groups

A B | C | D | E | F | 6 |

1 | i‘m"ear M arket

2 |Actual 100 [Profit Actual Budget Variance Variance% Scenario|
3 Inventory RS

4 Fatios 57 27288145

5 Measures 30465

6 200 Profit 27954

7 Irventory 33000

] Fatios 5553966595

9 Meazures 27954

10 300 Frofit 25799

11 Irventory 2080865

12 Fatios 54 23795671

13 Measures 25799

14 400 Frofit 21301

15 Irventary 26092

16 Fatios 5359966755

The pivot changes the order of the row groups.

A B | C | D E | F
1 _ Cfear hark et
2 [100 Praofit [Actual 1 30463
3 Budyet 1 41940
4 “Yariance -11472
5 “ariance %o -2¥.35336195
6 SCENAro J0465
7 Inventory Actual 29443
8 Budget 31590
9 “Yariance 2142
10 “ariance % B.7A0R267E1
11 SCENaNo 29448
12 Ratins Actual 57272858145
13 Budget 576240049
14 “Yariance -0.351123447
15 “ariance %o -0.609335377
16 Scenario | 5727288145

Figure 30. Result of Pivoting the Order of Row Groups

In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are
members of different row groups, Essbase exchanges the member groups.
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You must select a destination cell that contains a member name to
exchange row members. You can also exchange column members by
choosing a destination cell in another column that contains a member
name.

Retaining a Data Subset

The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete
individual cells.

To keep only Actual and Budget data in the current worksheet:
1. In cell C2, select Actual and, in cell C3, select Budget.

A | B | C | D | E | F |
1 Year hark et
Z (100 Profit Actual 3043
3 Il 41940
4 “ariance 11472
5 Yariance % -27.35336195
b SCenario 30465
7 Inventory Actual 29448
] Budget 31580
9 “ariance 2142
10 Yariance % B.780R267581
1 SCcenario 29448
12 Fatios Actual 5727288145
13 Budget 57 .B24004%
14 “ariance -0.351123447
15 “ariance % -0.B09335377
16 Scenario . 57.27288145

Figure 31. Selecting Members for the Keep Only Command

2. Select Essbase > Keep Only.

Essbase removes the Variance, Variance%, and Scenario rows from the
worksheet and retains only Actual and Budget data.

40 Spreadsheet Add-in User’s Guide for 1-2-3



| B | € | D E | F
1 | Year Miarket
2 |100 Profit [Actual | 30465
3 ([Eudyet] 41940
4 Inventory Actual 29445
5 Budget 31550
b Ratios Actual 57 27255145
7 Budget 57 6240043
i) hMeasures Actual 30465
9 Budget 41340
10 |200 Frofit Actual 27954
11 Budget 35950
12 Inventory Actual 33000
13 Budget 31090
14 Ratios Actual | 5553966595
15 Budget 57 4BE74162
16 Measures Actual 275954

Figure 32. Result of Retaining a Data Subset (Adjacent Cells)

Occasionally, the data that you want to remove from the worksheet does not

lie in an adjacent range of cells.

To select and retain nonadjacent cells.

1. Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.

2. Select Qtr2 (in cell E2).

3. Press and hold the Ctrl key and select Qtr4 (in cell G2).
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A | B [ ¢ ] D | G |
1

7| Qtrl
| 3 (100 Profit Actual 7048 7872 8511 7037
EN Budget §790 106E0D 11440 10050
15 | Irventary Actual 28448 25860 36451 35811
| 6 | Budget 31550 29950 34830 32340
i Ratios Actual | &7 40178857 67 28473167 57 39589578 5609467567
| & | Budget &7 737BA66 57 39041794 57 45231167 57 96344648
19 Measures Actual 7048 7872 8511 037
|10 | Budget 8790 10660 11440 10050
| 11 [200 Profit Actual 6721 7030 7005 7198
112 | Budget 8480 BE40 85830 §800
113 | Irventary Actual 33000 31361 35253 32760
|14 | Budget 31030 28040 30260 26460
|15 | Ratios Actual | 5538738574 5549797453 5506764011 56.21773123
| 16 | Budget 57 36255286 57 403956375 5711143695 567 9954955
17 | Measures Actual G721 7030 7005 7193

Figure 33. Selecting Nonadjacent Members for the Keep Only Command

4. Select Essbase > Keep Only.
Essbase retains only Qtr2 and Qtr4 data and deletes the other Year

members.
A | B | € | D | E | F

1 farket

2 Ctr2 Crd

3 (100 Profit Actual 7872 7037
4 Budget 10660 10050
5 Inventory Actual 259560 35811
6 Budget 28950 32340
7 Ratiog Actual | &7.28473167  BB.99467561
i} Budget  57.39041794 57 85344643
9 Measures Actual 7872 7037
10 Budget 10660 10050
11 |200 Profit Actual 7030 7198
12 Budget ag40 Q800
13 Inventory Actual 31361 32760
14 Budget 28040 2h4E0
15 Fatiog Actual | 5549797453 5621773123
16 Budget 5740395375 579954055
17 Measures Actual F030 7198

Figure 34. Result of Retaining a Data Subset (Nonadjacent Cells)
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Removing a Data Subset

The Remove Only command is the counterpart to the Keep Only command.
With Remove Only, you can remove selected member rows or columns and

retain all other data in the worksheet view.

To remove a data subset from the current worksheet view:
1. In cell B7, select Ratios.
2. Press and hold Ctrl, and, in cell B9, select Measures.

3. Select Essbase > Remove Only.

Essbase removes data for Ratios and Measures but retains data for Profit
and Inventory.

Figure 35. Result of Removing a Data Subset

A B C D E F

1 flarket

2 e Gitrd

3 |100 Frofit Actual /872 7037
4 Budget 10660 10050
] lrwentory Actual 29860 35511
b Budget 29950 32340
{ |200 Frofit Actual f030 7198
] Budget 5840  S500
9 lrwentory Actual 31361 32760
10 Budget 25040 2B460
11 300 Frofit Actual B/ES BAD3
12 Budget 7RO 7000
13 lrwentory Actual 303534 35142
14 Budget 23460 35460

Navigating Through the Worksheet Without Retrieving Data
With the Navigate Without Data feature, you can perform navigational

operations, such as pivot, zoom in, zoom out, keep only, and remove only,

without retrieving any data into the worksheet.
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This feature is especially useful when dealing with dynamic calculation
members, which are usually specified by the application designer. By
activating Navigate Without Data, you are effectively telling Essbase not to
dynamically calculate values (that is, calculate the database at retrieval time)
while you are creating the spreadsheet report. Dynamic calculation is

discussed in more detail in [‘Retrieving Dynamic Calculation Members” on|
0

To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.
Essbase displays a check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2.

Essbase shows the collapsed Year dimension but withholds retrieving any
data that is changed as a result of drilling up. The cells where data would
normally be displayed are blank.

A | B | ¢ | p| E |F|[G|[H]I

1 barket
2 Y ear
3 (100 Frofit Actual

4 Budget

5 Inventory Actual

b6 Budget

I 200 Frofit Actual

8 Budget

9 Inventory Actual

10 Budget

11 | 300 Frofit Actual

12 Budget

13 Inventory Actual

14 Budget

Figure 36. Result of Zooming Out (Navigate Without Data Enabled)

3. In cell D2, drill down (double-click) on Year by pressing and holding the
Alt key.

Essbase drills down without retrieving data.
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4, In Cell C3, select Actual and select Essbase > Pivot.

Essbase executes the pivot but does not retrieve data.

Note: You get the same result by pivoting any of the other Scenario

members.
A | B [c|[D|] EJF] G [H]I] J JK][L]
1 | harket
2 [ lactual Budget
3 Qtrl Qb2 Q3 Ctrd Year  Otrl Q2 Q3 Qted Year
4 |100 Profit
5 Irwventory
6 |200 Profit
7 Irwventory
8 |300 Profit
9 Irwventory
10 (400 Profit
11 Irwventory
12 |Diet Profit
13 Irwventory
14 Product Profit

Figure 37. Result of Pivoting (Navigate Without Data Enabled)

5. In cell GI, click the secondary mouse button on Market and drag Market
to product 100 (cell A4).

Essbase executes the pivot without retrieving data.

A | B | ¢ [D]JE] F[G[H]I1T]J] K JL|
1 Actual Budget
z Ot Ot2 Ot3 Otrd Year Otrl Ot2 O3 Otrd
3 [Market 100 Profit
4 | Inventary
] 200 Profit
b Inventory
7 300 Profit
(] Inventory
9 400 Profit
10 Inventory
11 Diet Profit
12 Inventory
13 Product Profit
14 Inventory

Figure 38. Result of Pivoting (Navigate Without Data Enabled)
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Navigating without data also works with the Keep Only and Remove Only
commands.

To navigate without data when using the Keep Only or Remove Only
command:

1. Select Qtrl (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.
Essbase retains only the selected members and does not retrieve data.

A | B | ¢ | p|E] F [6g|H]I1]J]
1 Actual Budget
7 et G2
3 |Market 100 Profit
4 Irventary
] 200 Frofit
b Inventary
Fi 300 Frofit
3] Inventory
9 400 Profit
10 Inventary
11 Diet Profit
12 Inventary
13 FProduct |Profit

Figure 39. Result of Keep Only (Navigate Without Data Enabled)

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select
Essbase > Remove Only.

Essbase executes the Remove Only command without actually querying
the database for information.

A [ B [ € [Dp [E[]F [G][H[I]J]
Actual Budget
Citrl G2 Ot ltr2

Market 100 Profit
Inventary

200 Profit
Inventary

I Product _lF'rl:uﬁt
Inventary

= e e ) R L P

Figure 40. Result of Remove Only (Navigate Without Data Enabled)
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To turn off Navigate Without Data when you are ready to retrieve data:
1. Select Essbase > Navigate Without Data.

Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell A3, drill down (double-click) on Market.
Essbase drills down on the Market dimension and also retrieves data into
the worksheet.
A | B | ¢ | p | E | F | 6 [H[I1]
1 Actual Budget
2 Citr1 Citr2 Citr1 Citr2
J |East !1 oo Profit 2rd7 3352 X880 34380
4 Irventory 5384 4490 5200 3530
H 200 Profit ah2 G10 os0 1070
6 Irventory 5957 B442 5610 &910
7 Product Profit 5380 B499 RSO0 F550
8 Irventory 26744 26214 24710 24030
9 [VWest 100 Profit 1042 849 2350 M30
10 Inventory | 85592 9556 10250 10950
11 200 Profit 2328 M23 A570 AF20
12 Ireentory 11755 11643 11070 10900
13 Product Profit 7137 7515 8950 9290
14 lrventory 387571 41574 30020 42820

Figure 41. Result of Drilling down (Navigate Without Data Disabled)

Note: If you want to retrieve data without changing the current worksheet
view, you can also retrieve data by simply double-clicking in any
data cell or by selecting Essbase > Retrieve (after disabling Navigate
Without Data).

Suppressing Missing Values, Zero Values, and Underscore Characters
Several types of data can be returned to a worksheet view:

Numeric data values

#NoAccess strings, which are displayed when you do not have the proper
security access to view a data value

#Missing strings, which indicate that no data exists for that member
intersection

Zero data values
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A missing value is not the same as a zero value that is loaded into the Essbase
database. When data does not exist for a data cell in Essbase, a value of
#Missing is returned to the worksheet. If any cell in a row contains a value,
that row is not suppressed on a retrieval.

With Essbase, you can suppress missing and zero values from the display in
the worksheet. In addition, you can tell Essbase to suppress underscore
characters that are in some member names.

To suppress rows that contain missing values from displaying in the
worksheet:

1. In cell C3, double-click the secondary mouse button to drill up on Profit.
2. Pivot Measures (in cell C3) to Actual (in cell D1).
3. In cell B4, drill down (double-click) on product 100.

Notice that, in the South, the product 100-30 row contains all missing
values, indicating that this product is not sold in the South. You may need
to scroll down the worksheet to see this row.

A | B | ¢ | p | E | F | 6
1 Measures
z Actual Budget
3 it Litrd &t Ltr2
4 |East 100-10 2461 2940 2550 3050
] 100-20 212 303 220 300
6 100-30 74 109 110 130
7 100 2747 3352 2830 3430
8 200 562 510 960 1070
) Product £330 G499 BA00 7550
10 |'West 100-10 1047 1189 1720 1900
11 100-20 &7 177 320 200
12 100-30 B2 -163 10 a0
13 100 1042 849 2330 2130
14 200 2325 2423 2670 2720
15 Product 7137 7515 8960 9290
16 | South 100-10 745 835 1160 1280
17 100-20 306 363 570 BEQ
18 100-30 #dissing #Missing  #lissing #dissing

Figure 42. Worksheet View Displaying Missing Data Values

4. Select Essbase > Options, and select the Display tab.

5. In the Suppress option group, select the #Missing Rows check box and
click OK.
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Note: The Suppress #Missing Rows and Zero Rows options are not
available when any of the Formula Preservation options are selected
in the Essbase Options dialog box. For more information on
Formula Preservation, see [‘Preserving Formulas When Retrieving|
[Data” on page 117

6. Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog
box, you must perform a retrieval or drill operation to have the new
setting take effect.

Essbase suppresses product 100-30 from the South member group.

A | B | ¢ | b | E ] F|] G [H]1]
4 [East 100-10 2461 2940 2850 3050
5 100-20 212 303 220 300
6 100-30 74 109 110 130
7 100 2747 3352 2880 3480
8 200 562 610 960 1070
9 Product 5380 6499 G500 7550
10 |VWest 100-10 1047 1189 1720 1900
1 100-20 -57 477 3200 200
12 100-30 62 63 310 30
13 100 1042 849 2380 2130
14 200 2325 2423 2870 2720
15 Product 7137 7515 8960 9290
16 |South 100-10 745 835 1160 1280
17 100-20 306 I3 570 BRD
18 100 1051 1198 1730 1940
19 200 1465 1540 1640 1700
20 Product 3077 3267 4180 4410
2 |Central  100-10 843 928 1080 1180

Figure 43. Result of Suppressing Missing Data Values

7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data
retrieval are not retrieved again by simply disabling the feature. If
you disable the feature in the Essbase Options dialog box, missing
values are retrieved from only that point on. For example, in the
tutorial task described above, Essbase could not go back and return
the missing values for product 100-30. To return these missing
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values to the worksheet, you disable the Suppress #Missing Rows
feature, drill up on a Product member, and then drill down again.

You can also suppress zeros and underscore characters as described in the
task above by clicking the appropriate options in the Suppress option group
in the Essbase Options dialog box (Display tab).

In addition to suppressing specific values and characters during retrieval,
Essbase enables you to define a label for missing values (#Missing) or for data
you do not have access to (#NoAccess). If you define a replacement label for
these values, Essbase displays the replacement labels instead of the default
labels. For more information on defining replacement labels for the #Missing
and #NoAccess labels, see the Essbase Spreadsheet Add-in online help.

Formatting the Worksheet

50

Essbase provides you with various ways to customize the worksheet view. For
example, you may want to apply visual cues, or styles, to certain member
names or to data cells in the worksheet, or you may want to display
alternative names, or aliases, for member names. This section steps you
through the following formatting procedures:

+ [“Formatting Text and Cells” on page 50|

+ ["'Displaying Aliases for Member Names” on page 59

* ['Displaying Both Member Names and Aliases” on page 61|

* ['Repeating Member Labels” on page 62|

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells

In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the
text and cells in the worksheet, you can easily keep track of specific database
members, dimensions, and cell functions. Styles are a great way to help view
and distinguish data in Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during
a retrieval request. For more information, see [“Removing Styles” on|

This section of the tutorial describes the following:

* ["Applying Styles to Parent Members” on page 51|

* ["Applying Styles to Dimension Members” on page 54|

* ["Applying Styles to Data Cells” on page 56

* ['Determining the Precedence of Overlapping Styles” on page 57
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¢ ['/Removing Styles” on page 58|

Note: For a discussion of the relationships among Essbase database members,
see ["Database Outlines” on page 7|

Applying Styles to Parent Members
Each dimension in a database may contain a large number of hierarchical

levels. As you view data in the worksheet, you may not be familiar with all
the hierarchical levels of the database outline. To indicate which members
have underlying children, you can apply formatting styles to parent members,
including those with attributes.

To apply styles to parent members:

1. To open a new worksheet, select File > New or click the QI icon.
2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you
are not connected, follow the steps in [’Connecting to a Database”]

3. In cell A2, drill down (double-click) on Year.
4. Select Essbase > Options.
5. In the Essbase Options dialog box, select the Style tab.

Note: The Style tab is available only when you are connected to a
database.

Essbase displays the Style tab.
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Essbase Options

Displa_l,l] Zoom ] Mode Style ]GIDI::aI]

tembers
Sample
[ Child FarEit
[ Shared
Dimenszions
S ample
v teazures Year
v Product ﬂ
[w Cell Border
Backaround Calar; | Maone j Farmat...
Data Cellz
Sample

WL inked Objects

[ Intearation Server Drll-Through

[~ Fead Only -]

Connection [nfaormation;
Localhozt Sample:B azic

QE. Cancel Help

Figure 44. Essbase Options Dialog Box, Style Tab

In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. In the Members group box, select the Parent check box.

Clicking this box defines a font and color style for parent member names.
Essbase defines a default color of navy for all parent members. You can
select a font format by clicking the Format button to the right of the
Members box and using the Font dialog box.

7. Click the Format button.
Essbase displays the Font dialog box.
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Font E
Eori: Faont ztule: Sizer
[ Bold 10 oK
1&' Albertus Extra Baold 3 Reqgular - Im "‘I
T Albertus Medium Italic - 11 Laiee)
Apina 12
T antique Olive Bold [talic 14
% Arial 16
Arial Black 18
M Avial Marow ;I j 20
— Effects — Sample
[~ Strikeout
[ Underine
Calar:
I- M aey ;I Script:

Figure 45. Font Dialog Box

8. In the Font style list box, select Bold and then click OK.

10.
11.

12.

13.

Note: Essbase displays an example of the selected style in the Sample

box.
Click OK again.

Even though you have defined styles, they are not enabled until you
select the Use Styles check box from the Essbase Options dialog box and
refresh the worksheet.

Select Essbase > Options, and select the Display tab.

In the Cells option group, select the Use Styles check box to enable your
styles, and then click OK.

Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Essbase displays parent member names in bold, navy font.
In cell A2, drill down (double-click) on Qtrl.

Chapter 3. A Basic Essbase Tutorial

53



Essbase displays Jan, Feb, and Mar in a regular font, because these
members do not have underlying children.

A, | B | ¢ | D | E
1 Measures Product Market  Scenario
2 |Jan al24
J |Feb 3346
4 |Mar 333
5 Qtr 24703
B Qtr? 27107
F Qir3 27912
g Qird 26800
g Yool 105522

Figure 46. Styles Applied to Parent Members

Applying Styles to Dimension Members
In addition to applying styles to parent members (as you did in the previous

section), you can also apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Essbase Spreadsheet Add-in.

To apply styles to dimensions:
1. Select Essbase > Options and select the Style tab.
2. In the Dimensions group box, select Year.

3. Select the Cell Border check box to create a border around each cell that
contains a member from the selected dimension.

4. From the Background Color list box, select Yellow.
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Esshase Dptions

Displa_l,l] Zoom ] bMode Style lGIDI::aI]

tdembers
Attribute; Sample
Parent
[ Shared -
J Farmat...

Dimengions
Dimengion: Sarnple

[ Measures Year

[ Product ﬂ

[v Cell Border

B ackground Calor; ||:| “Yellow j Farmat...
Data Cells B Red -
uttribe: 1 Lime Sample

WiLinked Objects (v ellow
[ Integration Ser| I Blue -

[ Read Ornly ﬂ

Caonnection [nformation:

Poplar:5 ample: B azic

k. | Cancel Help

Figure 47. Selecting a Background Color from the Style Tab

5.

10.

Click the Format button that is to the right of the Dimensions list.
Essbase displays the Font dialog box.

From the Font style list box, select Bold, and then click OK.

Note: Essbase displays an example of the selected style in the Sample
box.

From the list of dimensions, select the Measures dimension and, from the
Background Color list box, select Fuschia.

From the list of dimensions, select Product, and clear the Cell Border
check box.

From the Background Color list box, select Aqua.
Scroll down the list of dimensions, and select Market.
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11.

12.

13.
14.

15.
16.

17.

Select the Cell Border check box, and click the Format button that is to
the right of the Dimensions list.

When the Font dialog box is displayed, from the Font style list box select
Italic, and then click OK.

From the list of dimensions, select Scenario, and from the Background
Color list box, select Red.

Click the Format button, and from the Color list box, select White.
Click OK twice to return to the worksheet.

Note: When you define styles, your choices are saved to the Windows
Registry on your local machine. You can define one set of styles
per database.

In cell D1, drill down (double-click) on Market.

Press and hold the Alt key and drill down (double-click) on Scenario (in
cell E1).

Select Essbase > Retrieve to refresh the worksheet.

Essbase redisplays the worksheet and implements the newly defined
styles. For example, members of the Scenario dimension are displayed
with a red background.

0| 00| | O | e [0 P | —

A | B C b | E | F | G
FProduct
Actual “ariance
East Jan 1732 2080 -348  -16.7308 1732
Feb 1843 2230 -387 -17.3543 1843
Mar 1805 2180 -385  -17.5799 1805
Qtr1 5380 B500 -11200 -17.2308 5330
Qtr2 B499 7550 -1051 -13.9205 5493
Qtr3 B346 7550 -1204 15947 5346
Qtrd 5936 B740 854 125773 A936
Year 24161 28390 4228 14,8961 24161
West Jan 2338 2580 -B41 215101 2339
Feb 2394 2990 596 -19.9331 2394
Mar 2404 2990 586 -19.5957 2404
Qi1 7137 8960 -1823 -20.345 7137

Figure 48. Dimensions with Styles Applied

Applying Styles to Data Cells
You can apply styles to data cells, such as read-only cells, read /write cells,

linked object cells, and Essbase Integration Server drill-through cells to
distinguish them from other cells in the worksheet. The Sample Basic database
that you are using for this tutorial does not contain data cells with any of
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these characteristics. In the advanced tutorial presented in you
attach a linked reporting object to a data cell and apply a style to the cell.

Note: You cannot perform the actions in light-shaded boxes.

In general, to apply styles to data cells, follow these steps:
Select Essbase > Options, and select the Style tab.

In the Data Cells option group, select the Linked Objects, Integration Server Drill-Through, Read
Only, or Read/Write check box.

Click Format.

In the Font dialog box, specify the font, font size, font style, color, and effects, and click OK.
Note: Essbase displays an example of the selected style in the Sample box.

1.
2.

Data Cellz

[~ Integration Server Drll-Through
[ Bead Orly ;I

— Sample

Linked Ohjects

....................................

Farmat,

Figure 49. Sample Style for Read/Write Data Cells

Repeat Step through Step || to set styles for other data cells.

. Select the Display tab and select the Use Styles check box to apply styles to the worksheet.
Click OK to close the Essbase Options dialog box.

. Select Essbase > Retrieve to display the new styles in the worksheet.

5.

6
7.
8

Determining the Precedence of Overlapping Styles
The only way you can apply a background color to data is to define a style

for dimensions. If dimension styles are defined, and the Use Styles setting is
turned on, members of a dimension always have the background color
defined for their dimension.

The text styles that you can apply to members, dimensions, and data cells
have a hierarchy that determines which characteristics are applied. Member
styles are at the top of that hierarchy. Thus, member styles are always applied
(as long as styles are turned on). Note that in Figure the Qtrl label in cell
B6 is in bold, navy font, and has a yellow background. The navy font comes
from the style defined for parent members, and the yellow background comes
from the style defined for Year.

Essbase uses the following order of precedence when applying multiple text
styles:

* Linked object cells
¢ Integration Server Drill-Through cells
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* Read-only cells

e Read/write cells

e Parent member cells

e Child member cells

e Shared member cells

* Cells containing formulas

* Dynamic calculation member cells
e Attribute cells

¢ Dimension cells

If you want to see a child member style, make sure that the parent member
style is turned off. If you want to see a shared member style, make sure that
both parent and child member styles are turned off.

Removing Styles
Styles can be very helpful tools for keeping track of data in Essbase

Spreadsheet Add-in. Applying styles, however, involves additional processing
time during a retrieval request. This additional processing has a slight impact
on the speed of Essbase retrievals.

If you do not want to apply styles to the worksheet view, you can clear them.
You can also turn off styles so they are not displayed when you refresh the
view (by selecting Essbase > Retrieve, for example). So that the worksheet
matches the illustrations presented in the following tasks, do not remove styles
if you are stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the
FlashBack command, these styles are temporarily removed from the
current view. The styles are re-applied whenever you initiate a retrieval.
You cannot perform the actions in the light-shaded boxes.

To remove all styles from a worksheet:
1. Select all cells in the worksheet.
2. From the Lotus 1-2-3 menu bar, select Edit > Clear > Styles.

To disable styles:
1. Select Essbase > Options and, select the Display tab.
2. In the Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the
styles remain in the current worksheet view when you refresh the view.
The styles remain to avoid removing any styles that you may apply to
individual cells using native worksheet formatting options.
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Displaying Aliases for Member Names

Aliases are alternate names for database members. You can create reports that
use the database member name, which is often a stock number or a product
code, or an alias name, which can be more descriptive. Aliases are defined by
the Essbase application designer. Each database can contain one or more alias
tables

.For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product,
such as Colas and Root Beer, is defined in an alias table. In some cases, alias
names may vary depending on the combination of other database members.
For example, a Product member may have a different alias for each market in
which it is sold. For more information, see the Essbase Spreadsheet Add-in
online help or the Database Administrator’s Guide.

To display the alias of a member rather than its database name:
1. In cell C2, double-click the secondary mouse button to drill up on Actual.

2. Press and hold the Alt key and drill down (double-click) on Product (in
cell D1).

3. Select Essbase > Options, and select the Display tab.

4. In the Aliases option group, select the Use Aliases check box to display
member aliases.

5. Select Default from the Alias list box.
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Esshase Options

Display lEu:u:um ] bl ode ] Style ] GI:::I::aI]

Indentation
" Mone
" Subiterns
{* Totals

Suppress
[ #Mizsing Fows
[T Zemo Rows

[ Underscaore Characters

Cellz

W Usze Shyles

[+ &djust Columns
-

[ Bepeat Member Labels

Diynamic Time Seriez
[ Latest Time Perniod

Replacement

#hdizzing Label: |

fMo Access Label; |

bliazes
W Uze Aliazes

[ Usze Both Member Mames and Aliases
for Row Dimensions

Aliaz:

| Crefault j

Long Marnes

uery Designer
[ Use Sheet Options with Query Designer

-

Cancel

o |

Help

Figure 50. Enabling Aliases in the Essbase Options Display Tab

6. Click OK.

7. Select Essbase > Retrieve to refresh the worksheet and display the alias

names.

Essbase changes the Product codes (100, 200, and so forth) to their
predefined aliases (Colas, Root Beer, Cream Soda, and so forth). In the
Sample Basic database, Product is the only dimension with predefined

aliases.

Spreadsheet Add-in User’s Guide for 1-2-3




E c | D E F | G
1

| 2 Colas Root Beer Cream Soda Fruit Sod: Diet Drinks
El

| 4 |East Jan 924 158 184 466 181
= Feh Bao 242 200 513 185
= Mar 535 162 207 501 ==
. ur? 747 562 591 1480 545
| B | Q2 3352 610 822 1614 B&2
=N Qtrd 3740 372 522 1712 644
|10 ird 2817 590 592 1537 557
|11 Year 12656 2534 2627 G344 2408
| 12 | West Jan 378 782 785 454 B&3
|13 Feh 337 781 797 479 B&3
| 14 Mar 327 792 811 474 679

Figure 51. Result of Displaying Aliases

Notice that Essbase is still displaying the styles that you created and
applied in the previous sections.

Displaying Both Member Names and Aliases

In addition to displaying aliases for database members, you can also tell
Essbase to display both aliases and database member names in Essbase
Spreadsheet Add-in.

To display the name and alias of a member:

1.

a kDN

In cell B8, double-click the secondary mouse button to drill up on Qtr2.
In cell C2, select Colas, and then select Essbase > Pivot.

In cell C3. select Year, and then select Essbase > Pivot.

Select Essbase > Options, and select the Display tab.

In the Aliases option group, select the check box for Use Both Member
Names and Aliases for Row Dimensions.

Be sure that Use Aliases is already checked.
Click OK to return to the worksheet, and select Essbase > Retrieve.

Essbase displays both member names and their aliases for row
dimensions. Because the only row dimension in this example that has
preassigned aliases is Product, only the Product members display their
aliases. Region members simply repeat the member name instead of
displaying an alias.
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A, | B | ¢ | D | E F

1 Year

2 Scenario
3 To0 Colas East East 12R56
4 Wast Wast J545
] South South 4773
G Central Central 9490
7 Market Markat 30458
g8 200 Root Bear  Fast Fast 2534
9 West West 972y
10 South South G115
11 Central Central 9578
12 Market Market 27954
13 | 300 Cream Soda Fast Fast 257
14 Weast West 10731
15 South South 2350

Figure 52. Result of Displaying Both Member Names and Aliases

Repeating Member Labels

By default, Essbase displays member labels only once for each nested row and
column group. If you are connected to a large database when using Essbase
Spreadsheet Add-in, you may have to scroll down or across the worksheet to
see additional data rows and columns. In some cases, as you scroll down or
across, member labels may disappear from view. Essbase provides a feature
for repeating member labels in each row or column cell that represents a data
point so that you can always see a member label in the worksheet view.

To repeat member labels down and across the worksheet:
1. Select Essbase > Options, and select the Display tab.

2. In the Aliases option group, clear the Use Both Member Names and
Aliases for Row Dimensions check box.

3. In the Cells option group, select the Repeat Member Labels check box,
and then click OK.
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Essbase Options
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Figure 53. Enabling the Repeat Member Labels Option

4. In cell E1, drill down (double-click) on Year.

Essbase displays a member label in every column and row cell. For the
Sample Basic database that you are using for this tutorial, repeating
member labels is probably not necessary because the database is relatively
small. This feature is particularly helpful for keeping track of member
labels when scrolling through large worksheets.
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A B i D

1

2 Scenario
3 L Colas Fast 2747
4 Crolas Viest 1042
o L Colas Dot 1051
b Colas Central 2208
FARIN ] Crolas Wark et 048
g L Root Bear  East a6z
=Wy Root Beer Viest 2325
10 | CtrT Root Beer South 14B5
11 |Gt Root Beer  Central 2365
12 | tr] Root Beer Wark et B 21
13 |t Ceream Soda  East 2491
14 | L] Crearn Sodda West 2363
15 |tr] Coream Soda  South 561
16 | L] Crearn Soda  Central 2414

Figure 54. Result of Repeating Member Labels

Note: Even if you clear the Repeat Member Labels check box in the
Essbase Options dialog box, Essbase retains the repeated member
labels in the worksheet view. To remove the repeated labels, you
need to do one of the following;:

* Clear the check box and open a new worksheet

* Clear the check box and pivot the row group to a column group and
then pivot it back to a row group (or vice versa)

* Select Essbase > FlashBack and clear the check box
5. Before returning to the tutorial, complete the following actions:
a. Select Essbase > Options, and select the Display tab.

b. In the Cells option group, clear the Repeat Member Labels check box,
and then click OK.

c. Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Creating Queries Using Essbase Query Designer

So far, you have seen how easy it is to retrieve data and navigate through
Essbase Spreadsheet Add-in in an ad hoc fashion. Essbase also provides a
query designer so that you can define a database query for retrieving
dimensions and database members into the worksheet. Essbase Query
Designer (EQD) replaces Retrieval Wizard, and is used to define queries in
previous versions of Essbase Spreadsheet Add-in.

Before Hyperion Essbase actually retrieves data, Essbase Query Designer
provides a series of panels so you can request the data that you want to view
in the worksheet. It is particularly helpful when you know exactly which data
you want to retrieve from the server. In addition, you can save a query and
use it again.

The Essbase Query Designer window (Figure consists of the following
panels:

* The navigation panel provides access to the various features in Essbase
Query Designer. You can display all the dimensions used in a particular
query and access the various properties of each dimension member.

* The hint panel provides a brief description of the feature that is selected
from the navigation panel.

* The properties panel provides access to the following functions:

— Layout: Design the layout of the spreadsheet report. To change the
default layout, select a dimension tile and drag it to one of the other
dimension boxes. To access the member select panel and to define a
member for a query, double-click a dimension tile.

— Member Select: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click a member to add
it to the selection rules.

— Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

— Data Filter: Retrieve rows of data. The retrieval is based on the ranking of
the rows within certain columns. Use this panel to access the data
restriction panel.

— Data Restriction: Filter data by comparing it to a fixed data value
(including a negative value), a set of data values, or #Missing data
values.

— Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

— Messages and Confirmation: Turn on and turn off certain messages from
Essbase Query Designer.

— Help: Access documentation about Essbase Query Designer.
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Creating and Changing Queries

To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an
open query, click on the specific dimension or member in the query outline
that is displayed in the navigation panel. Selected members are displayed in
the member selection panel on the right.

You can also revise an existing query in the member selection panel. For
example, you can delete a member or add a member to the query by selecting
a member in the navigation panel and making the appropriate changes in the
properties panel.

Note: Files created using the obsolete Retrieval Wizard feature can be opened
in Essbase Query Designer. However, if a query contains more than two
member filters per selection rule or more than two data restrictions, the
member filters may be out of order. To ensure correct results, rearrange
the member filters in the navigation panel, if necessary.

For complete information on Essbase Query Designer options, see the
Essbase Spreadsheet Add-in online help.

CAUTION:
Manipulation of worksheets in VBA such as naming worksheets or moving
worksheets may not work when EQD is running.

Creating Queries

To create a query using Essbase Query Designer:
1. Select Essbase > Query Designer.

Essbase displays the Essbase Query Designer welcome panel.
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otustiéorkh ] 23 Untited 123>
<<ootusiork V1 238U ntitled 1235 >4
B Messages & Confirmations

E Help

[7]x]

Hypetion Essbage Query Desigrer replaces the Retrieval Wizard to
create reports using a more advanced user interface. Tse this feature
to:

*  Create and modify spreadsheet queries.

Specify which dimensions display in rows and columns.

QO
o
coe

Quickly select members and attributes to view in reports.
Filter members to create more detailed reports.
Analyze data in reports by sorting, ranking, and filtering data.

To start a new gquery:

1. Fromthe navigation panel (the screen to the left of this panel), select the name of the
wiotksheet; for example, [Book] [Sheet] in Exeel, or <<Untitled 123>>4 in Lotus 1-2-3.

2. With the worksheet selected, click the right mouse button, and from the pop-up menu, select

Hew > Query.

Hote: If you have not logged into a database, the Essbase System Login dislog boxis

displayed. You need to log into a database before procesding,

Fefer to the hint panel (the panel above this screen) for help on other panels.

Click the question mark icon in the navigation panel cthe screen to the left of this panel to
access a tutorial and online help for Hyperion Esshase Query Designer.

Click the question mark icon in the title bar of this screen to access What's This? Help.

Figure 55. Essbase Query Designer Displaying Welcome Panel

2. To create a new query, select <<c:\lotus\Work\123\Untitled.123>>A,

right-click, and select New > Query.

Hyperion Essbase displays the layout panel of Hyperion Essbase Query
Designer.
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Figure 56. Essbase Query Designer Displaying Layout Panel

3. Define the worksheet layout by dragging the dimension tiles as follows:
a. Drag Market and Product to the Row location.
b. Drag Measures to the Page location.

c. Drag Scenario below Year (in the Column location).
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[Use this layout panel to design the layout of the report.
1

Select a dimension tile from a dimension box

Dirag the dimension tile to a page, row, or column dimension

o

Double-click a dimension tile to access the member select

patiel to define members for the gquery.

Vo have completed designing the layout of the query.
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Figure 57. Changing the Worksheet Layout

4. To select the Measures dimension in the navigation panel, select the

Measures icon. Alternatively, double-click the Measures tile in the layout

panel.

Essbase displays the member select panel, where you can select a

member from the Measures dimension.

Note: You can select only one member from the dimension in the Page

location.

5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.

Profit is displayed in the selection rules list.
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m Spreadshests - Lotus 1-2:3 - Use this member select panel to select a mesmber for the page
E‘@ & Motusiorki] 23\Untlt|6dj1 2> dimension. ¥ou can select only one member per page dimension
;<c:\\.otus\¥v\u"ork\1 23 ntitled 123524 - Quenyl 1. Select a member in the "Members" list box,
ol D'B”S'Ons bo 2. With the member selected, click the right mouse butlon, and
= EI:‘age : from the pop-up menw, select Add to Selection Rules
5. Belect the member in the "Selection Rules" list box.
You have completed defining the member for the page dimension.
&8 Scenario
= Available Dimensiors Members:
Cafteinated [Baze:Product] = Measures
Intra D ate [Base: Product] :
Ounces [Base:Product]
Pkg Type (Base:Product) Riatios
Population [B ase:Market]
Lot Attribute Calculations
-3 Data Filtering
%] DataSorting
B Messages & Confimations

[ Help

Selection Rules:

Figure 58. Hyperion Essbase Query Designer Displaying the Member Select Panel

Note: In Essbase Query Designer, after you make your selections, you do
not need to confirm them; for example, you do not have to click
OK. If you do not select members from any given dimension,
Essbase uses the top member of the dimension.
6. To select members of the Year dimension, complete the following actions:
a. In the navigation panel, click the Year icon. Alternatively, double-click
the Year tile in the layout panel.
Essbase displays the member select panel for the Year dimension.
Select Qtrl, right-click, and select Add to Selection Rules.

Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.
Because Year is in a Column location, you can select one or more
members.
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Figure 59. Adding Members to the Selection Rules

7.

To select members of the Scenario dimension, complete the following
actions:

a.

C.

In the navigation panel, select Scenario. Alternatively, double-click the
Scenario tile in the layout panel.

The members of the Scenario dimension are displayed in the member
select panel.

Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.
In the same manner, add Budget to the Selection Rules box.

To select members of the Product dimension, complete the following
actions:

a.

c.
d.

In the navigation panel, select Product. Alternatively, double-click the
Product tile in the layout panel.

The members of the Product dimension are displayed in the member
select panel.

Select product code 100, right-click, and select Add to Selection
Rules.

Repeat the process for product codes 200, 300, and 400.

In the Selection Rules list box, select product code 100, right-click,
and then, from the popup menu, choose Select > Children.
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This action selects all children of 100. Essbase displays All Children
next to 100 in the Selection Rules list box.

e. In the Selection Rules list box, select product code 400, right-click,
and choose Select > Descendants.

Essbase displays All Descendants next to 400 in the Selection Rules
list box.

p’}- Hyperion Esshase Query Designer [ 2] ] I
& D Spreadshests - Lotus 1-2:3 = se this member select panel to select a member for the row

= @ e otushiw/okhT 23 Untited 123 > dimension
<<c Sotusihwtork T 238U ntitled 12354 - Quen, 1. Select a member it the "Members" list box.
E . Dlmanslons 2. WWith the member selected, click the right mouse button, and

Page from the pop-up menn, select Add to Selection Rules

B ' Measures 3. Select the member in the "Selection Rules" list box.

B Prafit 4. With the member selected, click the right mouse button, and

= Row from the pop-up mes, select Member Filter.
: Market Mote: Follow Step 4 if you want to filter the member selection;
Praduct otherwize, you have completed the member selection for the rowr
OF 100, &l Children dimension
By 200
By 200 Members:
B 400, Al Descendarts = Product
Colurn
Year
B
oy quz
R - Dist
o7 aud

Scenario
- By Actual
B Budget
H--Ej Avwailable Dimensions
--Wy Caffeinated (Base:Product)
Mg Intro Date [Baze:Product)
Ounces [Bagze:Product] i
Pkg Tupe (B ase:Product) Selection Rules:
M7 Population [B ase:tarket] 100, All Children

§/ Attribute Calculations — - 200

%% Diata Fitering - 300

-I Data Snrtmg =
P TR S,
el I _»l_I

Figure 60. Selecting Members of Product

Bow

f. To view the list of all product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box (for
example, 200), right-click, and select Preview.

Hyperion Essbase displays the Member Selection Preview dialog box.

72 Spreadsheet Add-in User’s Guide for 1-2-3



Member Selection Preview [ %] I

Selected Members:

100-10 -
100-20 _I
100-30

200

300

400-10

400-20

400-30

The selected rule returned 8 members.

Figure 61. Selected Members of Product Dimension

g. Click Close to close the Member Selection Preview dialog box.

9. To select members of the Market dimension, complete the following
actions:

a. In the navigation panel, select Market. Alternatively, double-click the
Market tile in the layout panel.

The members of the Market dimension are displayed in the member
select panel.

b. In the Member list box, select East, right-click, and select View by >
Generation.

c. To pick the second generation of the Market dimension, in the
Member list box, select Region, right-click, and select Add to
Selection Rules. Alternatively, double-click Region to add it to the
selection rules.

Region is displayed in the Selection Rules list box.

d. To view the list of members that will be retrieved into the worksheet,
in the Selection Rules list box, select Region, right-click, and select
Preview.

Essbase displays East, West, South, and Central in the Member
Selection Preview dialog box.
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Selected Members:

East ;I
st

South

Central

The selected rule returned 4 members.

Figure 62. Generation Name Selection

e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic Essbase query. The outline of the query is
displayed in the navigation panel.

10. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>>A -
Queryl, and then right-click and select Save Query.
Essbase displays the Essbase Query Designer Save As Query dialog box.
You can save your query to the server or to your own client machine. To
save to the server, you must have a security level of database designer or
higher. Contact the Essbase system administrator for more information.

11. Select Client.
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Application:
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Gueny Type:

| =

Caonnection information;
Server: Localhost
Application: Sample
[Databaze: Basic

Ok

Cancel

Help

File Spstem...

Figure 63. Essbase Query Designer Save As Query Dialog Box

12. Click the File System button.

Essbase displays the Save As dialog box.
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Save As
Save in: Ia Temp j | |-=~_h|'i| el
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File narme: IEasic'I Save

Save ag wpe; IEI]D[“.equ:I] j Cancel

Figure 64. Save As Dialog Box

13. Select a location, in the File name text box, type Basicl and then click
Save.

You will use the Basicl query again in
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[Use this query information panel to find out information about
lthe query, such as the query name, the database that the query is
connected to, and so on.

M ote: Whern you initially create a new query, most of the fields
rill be empty. When you open an existing gquery, the fields will be
[filled with the appropriate information.

Query Name:

Locatior:

Current Connection:

Created For:

Modified
Locked:

-

Basicl eqd
Chilotush123

Localhost:5 ample B asic

Figure 65. Hyperion Essbase Query Designer Displaying Query Information Panel

14. In the navigation panel, select <<c:\lotus\Work\123\ Untitled.123>> A -
Basicl, then right-click, and select Apply Query.

The result of the query is displayed in the worksheet.

A B [ e [ B [ E F G | H [ J

1
2]
| 4 |East Cola 2580 3080 3440 2410
| 5 | Diet Cola 220 300 310 290
| 6 | Caffeine Free Cala 110 130 190 150
| 7 | Root Beer 960 1070 830 1500
| & | Cream Soda 770 1010 60 530
| 9 | Grape 840 860 920 800
| 10| Orange 3a0 380 420 440
|11 Strawherry 700 780 780 670
| 12 |West Cola 1720 1500 2120 1780
|13 Diet Cola 320 200 250 320
| 14 | Caffeine Free Cala 30 30 -130 70
| 15 | Root Beer 2570 2720 2820 2840
| 16 | Cream Soda 2620 2970 3230 2840
| 17 | Grape 920 960 1020 920
| 18 | Orange 1002 810 890 1000 680
| 19 | Strawberry 734 310 -380 -440 -400
| 20 |South  Caola 745 1160 1280 1490 1510

21 Diet Cola 306 570 B0 570 550

Figure 66. Results of a Essbase Query Designer Query
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Note: In the Display tab under Essbase > Options, if you select Use
Styles and Use Sheet Options with Query Designer, the styles you
selected for dimension members will be applied to the initial query
results. If you do not select Use Sheet Options with Query
Designer, even if you have selected Use Styles, they will not be
applied to the initial query results. To apply styles, select Essbase >
Retrieve. When Essbase returns the data to the worksheet, you are
free to further investigate the data by performing Zoom, Keep
Only, Remove Only, and Pivot operations.

Deleting Queries
You can delete a query only from the location where you saved that query.
For example, if you save a query in the /essbase/client/sample directory,
you can delete the query from within the sample directory. You cannot delete
the query from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations

Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations
panel.

To turn on or turn off messages and confirmations:
1. Select the Messages and Confirmations icon in the navigation panel.

2. To turn on (enable) a message, select the check box that is displayed next
to that message.

3. To turn off (disable) a message, select the check box again (clear the check
box).
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Figure 67. Messages and Confirmations Panel

Accessing Help

Access online help or the tutorial for Hyperion Essbase Query Designer by

using the help panel. To access the help panel, in the navigation panel, select
Help. For more information on a particular topic, click the Online Help button
in the properties panel. To access the online tutorial, click the Tutorial button

in the properties panel.
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Figure 68. Essbase Query Designer Help Panel

Connecting to Multiple Databases from Essbase Query Designer

You

can connect to several databases and create separate queries on each

database from Essbase Query Designer.

To connect to multiple databases from Essbase Query Designer:

1.
2.
3.

Logon to Essbase and connect to the server you want to access.
Select Essbase > Query Designer to open Essbase Query Designer.

Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select
Connect.

Essbase displays the Essbase System Login dialog box.
Type your password, and click OK. Select Sample Basic, and click OK.

Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select New
> Worksheet.

Select the new worksheet, <<c:\lotus\Work\123\ Untitled.123>>B, right
click, and select Connect.

Essbase displays the Essbase System Login dialog box.
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7.

8.

9.

Type your password, and click OK. Select Samppart Company, and click
OK.

Note: You are restricted to one connection per worksheet. The connection
information is displayed in the query information panel of the
Hyperion Essbase Query Designer only when you open an existing
query or create a new query.

To create a new query based on Sample Basic, select
<<c:\lotus\Work\ 123\ Untitled.123>>A, right click, and select New >
Query.

To create a new query based on Samppart Company, select
<<c:\lotus\Work\ 123\ Untitled.123>>B, right-click, and select New >
Query.

10. To open an existing query, right click, and select Open Query.

You are now ready to proceed with the process of creating queries or opening
existing queries.

Applying Worksheet Options to Essbase Query Designer Results

You can also apply any of the worksheet options you have previously set
from the Essbase Options dialog box to the results of a query created in
Essbase Query Designer.

To enable Essbase Query Designer to use your previously set worksheet
options:

1.
2.

3.

Select Essbase > Options.
In the Essbase Options dialog box, select the Display tab.

Select the Use Sheet Options with Query Designer check box, and select
OK.
Select Essbase > Retrieve to refresh the worksheet.

Essbase displays the results of the query you created in Essbase Query
Designer and implements your previously set worksheet options. For
example, note that aliases, instead of the numeric codes, are now
displayed for the Product dimension.
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| 2 |
| 4 |East Cola 2E1 2550 3050 34400 2430 2410
15 | Grape F45 540 8r0 920 B8 Fo0
| B | Cream Soda 591 770 1010 BED 592 530
L7 Root Beer 562 aE0 1070 830 990 1500
| & | Strawberry 545 700 A0 780 &ZA 570
|9 | Orange 240 350 3a0 420 394 440
110 | Diet Cola 212 220 300 3o 27 290
|11 | Caffeine Free Cola 74 110 130 190 100 150
| 12 |West Cream Soda 2363 2620 2970 32300 2BHU2 2850
113 | Root Beer 2325 2570 2720 20200 2439 2840
| 14 | Grape 1143 20 850 1020 124149 20
| 15 | Cola 1047 1720 1900 21200 1018 17E0
|16 | Orange 1002 a10 go0 1000 940 &30
|17 Caffeine Free Cola G2 310 30 -1300 123 70
| 18 | Diet Cola -G7 320 200 250 13k 320
19 Strawberry -fa3 0 -3 -380 -4400 -FF9 -400

0 | South Root Beer 1466 16040

1700 17100 1483 1330
Figure 69. Results of Query with Options Applied

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Selecting Members

82

A Essbase database may contain hundreds or even thousands of members,
making it difficult to remember each member name. You can use the Essbase
Member Selection dialog box to find and select members and to define the
layout of members in the worksheet. In addition, you can use Boolean
operators, such as AND, OR, and NOT, or other search parameters to specify
criteria and conditions that members must meet for the member selection.
Member selection is an important method of creating a spreadsheet report for
the data you want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box,
see the Essbase Spreadsheet Add-in online help.

To view specific members from the Product dimension:
1. To open a new worksheet, select File > New or click the QI icon.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in [“Connecting to a Database” on|
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2. Select Essbase > Retrieve.

3. Select Product and select Essbase > Pivot to display Product as a row,

rather than a column, dimension.

n | B

Product  [Vear 105522

L1 [ |l [Po |t

Figure 70. Initial Worksheet for Member Selection

4. Select Product again, and select Essbase > Member Selection.

Essbase displays the Essbase Member Selection dialog box. In the
Essbase Member Selection dialog box, Essbase displays the Product
dimension in the Dimension list box and its children, Colas, Root Beer,
Cream Soda, Fruit Soda, and Diet Drinks, in the Members list box.

Essbase Member Selection

Dinersior > Buies

tembers
[A] Product  [5) =
B caas (3]
BARoot Beer (4]
[ Cream Soda (3]
B4 Fruit Soda (3]

[ Diet Drinks (3] Al > |

-

4 v
0 of 22 Selected, Mate: Use the: right mouse button to apply
advanced selection rules.

Find... | Expand|To Deseendants | ioyelem e | Femove [tem
Llear | fEember [nformation... | td e ke Down | Femove &l

Wiew Method Output Optiot

&+ By Member Mame IV Use Aliases I Drefault - I

" By Generation Mame ™| Suppress Shared Members

" By Level Name [V Place Down the Sheet

! By Dynamiz Tine Seres ™ Insen List Before Active Cell

Cancel

Help

Open...

Save...

|l el

Freview...

Figure 71. Essbase Member Selection Dialog Box

5. Select Colas and click the Member Information button.
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Essbase displays the Member Information dialog box. The dialog box
provides information about the selected member, such as dimension,
generation, level, storage setting, formula, UDAs, and member comments.

Member Information

Member |nfarmation far  Calas:

Dimenziar: Product
Generatian: 2
Lewel 1

Storage Setting:  Mormal

Farmula:

K3

Uzer Defined
Attributes [UDA):

kMember Comment:

-1
g E S YRS o EOTS

[T

Ok,

I
L
=]

Figure 72. Member Information Dialog Box

6. To close the Member Information dialog box, click OK.

7. In the Essbase Member Selection dialog box, click Add to add Colas to
the Rules list box.

Note: Alternatively, you can double-click an item in the Members list box
to add the item.
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8. Select Cream Soda, and click the Find button.
Essbase displays the Find Member dialog box.
In the Find Member dialog box, you can do pattern-match searches for
members in the selected dimension. You can use Wildcard
patterns—(trailing asterisk, *) and (single-character match, ?). Hyperion
Essbase locates the members that match the text string (in alphabetical
order) and keeps them selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character
wildcard in the text string. The * wildcard replaces a string of
characters, whereas the ? wildcard replaces a single character. J?n
and 100* are examples of valid wildcard strings; *-10 and J*n are
examples of invalid wildcard strings.

9. In the Find Member dialog box, type D* in the text box.

Find Member I

Enter Member Mame or Pattern in Field Below:
D:-:

Eind | Find e Clase Help

Figure 73. Find Member Dialog Box

10. Click Find to locate all members that match D*.
Essbase locates and selects Diet Cream. Its parent, Cream Soda, is also
selected because it was highlighted before the search.

11. To close the Find Member dialog box, click Close.

12. Clear Cream Soda, leaving only Diet Cream selected, and click Add.

Essbase displays Colas and the new selection, Diet Cream, in the Rules
list box.

13. In the Essbase Member Selection dialog box, select Colas in the Rules
list box, and then right-click. From the pop-up menu, select All Children
and Member.

Essbase displays All Children and Member next to Colas in the
Selection Rules list box.

14. In the Selection Rules list box, select Colas, All Children and Member,
and then right-click again.
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15. From the pop-up menu, select Subset.

Essbase displays the Subset Dialog box, where you can further define
conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog
box.

16. In the Subset Dialog box, in the first list box, select Caffeinated. In the
second list box, select Is. In the third list box select Caffeinated_True.

17. Click the Add as AND Condition button.

Essbase displays Caffeinated = Caffeinated_True in the Conditions list
box.

When you use Add as AND Condition, the subsetting condition in the
Conditions list box is evaluated using AND logic. AND logic means that
the selection must meet the current condition and the following condition
in the Conditions list box.

Select member Colas and its children where: k.

I Caffeinated j Iis j IEaffeinated_True j

SubsetDislog |
|

Cancel |
Add as OF, Conditon | e |
LConditionz:
Caffeinated = Caffeinated True
FRemowve [kem |
Add Aad] |
Hemowe [ ] |
Femovedlll ]|
Prewview. . |

Figure 74. Subset Dialog Box (Before Adding Conditions)

18. In the first list box, select Ounces. In the second list box, select the logical
operator “=". In the third list box, select Ounces_12.

19. Click the Add as AND Condition button.
Essbase displays Ounces = Ounces_12 in the Conditions box.

20. In the first list box, select Ounces. In the second list box, select the logical
operator “<=". In the third list box, select Ounces_32.

21. Click the Add as OR Condition button.
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22.

23.

24,

25.

Essbase displays Ounces <= Ounces_32 in the Conditions box.

When you use the Add as OR Condition, the subsetting condition in the
Conditions list box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in
the Conditions list box.

In the first list box, select Pkg Type. In the second list box, select Is. In
the third list box, select Bottle.

Click the Add as AND Condition button.
Essbase displays Pkg Type = Bottle in the Conditions list box.

In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

Select Pkg Type = Bottle, and click the Add ) button.

The Add ( and Add ) buttons add a left parenthesis and right
parenthesis, respectively, to selected items. Use parentheses for grouping
multiple subsetting conditions to determine the order of priority for
analyzing the conditions. Each item in the Conditions list box can have
either the left or right parenthesis, but not both. In this example, Essbase
first evaluates members that are equal to or less than 32 ounces and are
packaged in a bottle. Essbase then evaluates the results from this
condition against members that are 12 ounces.

Note: Use the Remove ( ) button to remove an individual group of
parentheses from a selected item in the Conditions list box. Use
the Remove All () button to remove all parenthetical groupings
from the Conditions list box.

The Subset Dialog box is displayed as follows:
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Subszet Dialog

Select member Colaz and ite children where: 0k |

[Plg Type =il [=leote - _ Cencel |
AddasOF Condifion | Add 2 AND Condiion | _ Hep |

Conditionz:
Caffeinated = Caffeinated_Tue
AND Remaove [tem |
Ounces = Ounces 12
oR
[ Ounces <= Ounces_32
AND add] |
Pkg Type = Bottle |
Bemove [ ] |
Remaove & [ ] |
Frewview. .. |

Figure 75. Subset Dialog Box (After Adding Conditions)

26. To open the Member Preview dialog box, click Preview.

In the Member Preview dialog box, you can view the member selection
that results from the conditions you defined.

Member Preview

Selected Members:

Cala
Diet Cala

Caffeine Free Cola Help

-]

The Selected miles returned 3 members

Figure 76. Member Selection That Results from Subsetting Conditions

27. To close the Member Preview dialog box, click Close.

28. To close the Subset dialog box and return to the Essbase Member
Selection dialog box, click OK.
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The conditions you set in the Subset dialog box are displayed in the
Selection Rules list box.

29. To change the order in which Diet Cream is displayed in the worksheet,
select Diet Cream and click the Move Item Up button.

Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Rules list box. You can move only the top-level
item (the item you added from the Members list box), not the individual
subset conditions.

Esshase Member Selection

Dlirersiar: IProduct j Rules:
il Diet Cream
= Colas, All Children and Member
A Product (5] = Caffeinated = Caffeinated_True Cancel |
[ Colas (3] AND
B4 Rroot Beer 4] Dlaanes =0unces 12 Help |
(& Cream Soda (3 [ Ounces <= Ounces_32
Doark Cream AMD
Yanilla Cream | o |
. Open...
Diet Cream Seld -
[ Fruit Soda (3] Save.. |
(5 Diet Diinks  (3) —
T Frewview. ..
i v 4|
0 of 22 Selected. Mate: Use the right mause buttan to apply
advanced selection ules.
Find... | Expatid/ o Descendants | Mivelem | Eemeve [tem |
LElear | tEember [nfomation .. | F el tem Wowh | Remaowve Al |
Wiew Method Output Option
(¢ By Member Name V¥ Use Aliases I Drefault hd I
" By Generation Mame 7| Suppress SharedMembers
By Level Name ¥ Place Down the Sheet
1 By Dynamiz Tine Seres ™ Insert List Before fictive Cell

Figure 77. Selecting Members Completed

30. To preview the members that will be retrieved in the worksheet, click
Preview.

Essbase displays the Member Preview dialog box.
31. After previewing the list, click Close.
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Member Preview [ %] I

Selected Members:

Diet Cream
Cola

Diet Cala
Caffeine Free Cola &I

[

The Selected rules returmed 4 members

Figure 78. Members to be Retrieved in Worksheet

32. To close the Essbase Member Selection dialog box and insert the new
members into the worksheet, click OK.

A _B | cC D E
1 Market
2 |Diet Cream Year 105522
J Cola
4 |Diet Cola
5 | Caffeine Free Cola

Figure 79. Result of Selecting Members

Note: The FlashBack command cannot undo a Member Selection action.
33. Starting with Diet Cream, type Year next to each product.

You need to do this step so that every product has a matching Year
dimension associated with it in the report.

A B | c D E
1 Market
2 |Diet Cream Year 105522
2 |Cola Year
4 |Diet Cola Year
5 |Caffeine Free Cola Year

Figure 80. Worksheet After Adding the Year Dimension to All States
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34. To update the values in the worksheet, select Essbase > Retrieve.

Essbase retrieves data for the members that you selected and also applies
the styles you previously set.

A B
1
Z2 |Diet Cream Year 11D93_
J [Cola Year 22T
4 |Diet Cola Year 5708
5 |Caffeine Free Cola Year 1983

Figure 81. Result After Retrieving with Member Selection

Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can
save worksheets and disconnect from Essbase. This section instructs you in
the following procedures:

* [‘Saving a Worksheet”|

« ["'Disconnecting from Essbase” on page 91|

* ["Logging Off” on page 92|

Saving a Worksheet

At any point during the Essbase session, you can save the active worksheet
with the Lotus 1-2-3 commands, File > Save or File > Save As. Thus, you can
keep a personal library of database views. You can open the worksheet during
a later session and retrieve the latest data values to update the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog
box unless the worksheet is protected. Essbase cannot save option settings
for a protected worksheet.

Disconnecting from Essbase

When you finish retrieving and navigating through data, disconnect from the
Essbase server to free up a port (or user count) on the server for other Essbase
Spreadsheet Add-in users.

To disconnect from the server:
1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can
disconnect any worksheet that is connected to a database.
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Ezsbaze Dizconnect E4

Sheet
E' Dizconnect I

Close

Serverdpplication-»0 atabaze

Help

J | 0

Figure 82. Essbase Disconnect Dialog Box

2. From the list, select a worksheet name, and then click Disconnect.
3. Repeat Step El until you have disconnected all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Lotus 1-2-3.
An abnormal termination of a Lotus 1-2-3 session, such as a power loss
or system failure, does not disconnect your server connection.

Logging Off
Essbase provides two administrative facilities that control user connections:

* Forced Logout, where an administrator disconnects users at any point in
time. This logoff usually occurs when maintenance operations are
performed on databases.

* Auto Logout, where Essbase automatically disconnects users that are inactive
for a time interval specified by an administrator.

For further information, contact the Essbase system administrator.
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Moving on to Advanced Tasks

Now that you have completed the basic Essbase tutorial, you are ready to
move on to more complex tasks. In the next chapter, you will use the sample
Lotus 1-2-3 files to see how to perform advanced tasks in Essbase Spreadsheet
Add-in.
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Chapter 4. An Advanced Essbase Tutorial

The tutorial you completed in teaches basic data retrieval and
navigation concepts for Essbase Spreadsheet Add-in. This chapter builds on
your basic skills and expands your knowledge of Essbase and Essbase
Spreadsheet Add-in. This chapter provides the following sections on advanced
tasks:

* [‘Preparing to Begin the Tutorial” on page 95

s ["Performing Advanced Retrieval Tasks” on page 102

* ["Using Linked Reporting Objects” on page 146

* [‘Connecting to Multiple Databases” on page 163

* [‘Accessing Linked Partitions” on page 165|

. "Updating Data on the Server” on page 165'

« [“Calculating a Database” on page 169|

* [“Creating Multiple Worksheets from Data” on page 171

+ [“Working with Currency Conversions” on page 176

In this advanced tutorial, you use several sample Lotus 1-2-3 files that were
installed as part of the default Essbase installation. These files are stored in
the \Essbase\client\sample directory. You also reconnect to the Sample Basic
database.

Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two
sections, [‘Connecting to a Database” on page 95| and [’Setting Essbase]
Options” on page 97| In addition, be sure to read [“Following Guidelines|
During the Tutorial” on page 21| and [“Reviewing the Sample Basic Database”]
on page 22 for important information about what you should expect as you
perform the tutorial steps.

Connecting to a Database

To access Essbase data for the advanced tutorial, first connect to the Sample
Basic database on the server. This tutorial assumes that you have the
appropriate privileges to connect to a server, an application, and a database.

1. Select Essbase > Connect.
Essbase displays the Essbase System Login dialog box.
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Essbase System Login [ %]

Username: W Cancel |
Password: l— Help |

Application/D atabaze:

Server. ILocthost j ] 4 I

Lhange Fassword.. |

[Ipdate |
Hote... |

Figure 83. Essbase System Login Dialog Box

Note: To complete the steps that follow, you need to know the name of
the Essbase server, your username, and your password. If you do
not have this information, contact the Essbase system administrator.

From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the
server that you want to access.)

To move to the Username text box, press Tab and then, in the Username
text box, type your username.

To move to the Password text box, press Tab, and then, in the Password
text box, type your password.

Note: You can change your password when you are connected to a server.
See[’Changing a Password” on page 25|

To connect to the server, click OK.

Essbase displays a list of available application/database pairs in the list
box. An Essbase server enables simultaneous access to multiple
applications. An application can contain multiple databases. Only the
databases to which you have security access display in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the
list. If Sample Basic is not shown in the Application/Database list, ask the
Essbase system administrator to install it.
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Essbase System Login [ %]

Server. ILocthost j oK I
Usemame: W ﬂl
Password: lm Help |

LChange Password... |

Application/D atabaze:

Demo Basic Update |

S ampeast East

S ample Intemtl HNote... |
S ample Hchgrate

S amppart Company

Sourcel Basic

Targetl Basic

Figure 84. Available Application and Database Pairs

6. In the Application/Database list, double-click Sample Basic, or, from the

Application/Database list select Sample Basic and then click OK.

If the application is not already running, Essbase automatically starts it. There

may be a brief pause as the application loads; the time required to start an
application depends on the number of databases, the sizes of the databases,
and the sizes of the indexes of the databases that are contained within the

applications.

Setting Essbase Options

Before you begin the tutorial, make sure that the worksheet options are set to
the initial settings shown in the Figure [85 through Figure .

Note: For information on each option in the Essbase Options dialog box, see
the Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches Figure
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Esshase Options

Display lEu:u:um ] bl ode ] Style ] GI:::I::aI]

[ndentation
" Mone
" Subiterns

Suppress
[ #Mizsing Fows
[T Zemo Rows

[ Underscaore Characters

Cellz

W Usze Shyles

[ Adjust Columns
-

[ Bepeat Member Labels

Diynamic Time Seriez
[ Latest Time Perniod

Replacement

HMigsing Label  [N/4

fMo Access Label; |

bliazes
W Uze Aliazes

[ Usze Both Member Mames and Aliases
for Row Dimensions

Aliaz:

| Crefault j

Cluen Dezigner
¥ Use Sheet Options with Query Designer

-

Cancel

o |

Help

Figure 85. Initial Settings for Display Options

4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your

display matches [Figure 86 on page 99|
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Ezzbaze Ophions

Display  Zoom | Made | Glabal |

Al Levels

(" Bottom Level

" Sibling Level

" Same Level

" Same Generation
" Formulas

M ermber Fetention

[+ Include Selection

[ "within Selected Group

[ Femove Unselected Groups

Huybrid Analyziz
[ Enable Hybrid Analysiz

k. | Cancel Help

Figure 86. Initial Settings for Zoom Options

6. Select the Mode tab.

7. Select the appropriate check boxes and option buttons so that your
display matches Figure
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Esshase Options
Displa_l,l] Zoom  Mode lGIDbaI]

Retrewval
v 4 dvanced Interpretation
" Free Form

=

Mode
[ Update Mode

Formula Prezeration

[ Betain on Retrieval
-
-

-

Mate: Certain optiohs cannot be uged in conjunction with Farmula Preservation,
|f any af theze options are selected, the Formula Prezervation optionsz are grayed out and
cannot be selected, and vice verza. Click Help far mare infarmation.

QE. | Cancel Help

Figure 87. Initial Settings for Mode Options

8. Skip the Style tab.
9. Select the Global tab.

10. Select the appropriate check boxes and option buttons so that your
display matches Figure
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Esshase Dptions

Displa_l,l] Zoom ] bdode ] Style  Global l

Mouze Achions Dizplay Mezzages
[+ Enable Secondany Buttor £ Infarmation
¥ Enable Double-Clicking (" wamings
[+ Enable Linked Object Browsing (" Erors
" Mone
M emary [ Dizplay Unknown Members
[+ Enable Flashback
Log File
tember Select [+ Boute Meszages to Log File
[ Display Save Dialog [V Purge Log File Every Session

tode

[ Mavigate without Data Addns..

k. | Cancel Help

Figure 88. Initial Settings for Global Options

11. To save the settings for this session and close the Essbase Options dialog
box, select OK.

Note: The settings in the Essbase Options dialog box may change as you
access the various sample Lotus 1-2-3 files as part of the tutorial.
Leave the settings as they are unless the tutorial advises you to
change them. If you have different option settings, the illustrations
presented in this chapter may not match the worksheet view.
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Performing Advanced Retrieval Tasks

102

The tutorial in describes how to perform basic data retrieval and
navigation tasks in Essbase Spreadsheet Add-in. This section walks you
through performing the following advanced retrieval tasks:

* ['Filtering Data” on page 102|

* [“Sorting Data” on page 107

* ['Retrieving Data into Asymmetric Reports” on page 110|

* ["Working with Formatted Worksheets” on page 112

* ['Preserving Formulas When Retrieving Data” on page 117|

* [‘Retrieving a Range of Data” on page 121
* [‘Retrieving Data by Using a Function” on page 124_L|
* ['Retrieving Dynamic Calculation Members” on page 129

* [‘Specifying the Latest Time Period for Dynamic Time Series” on page 131]

* ['Using Free-Form Reporting to Retrieve Data” on page 135|

Remember that you can perform common data retrieval tasks in any of the
following ways:

* Selecting commands from the Essbase menu on the Lotus 1-2-3 menu bar
* Clicking the appropriate buttons on the Essbase toolbar

* Double-clicking the primary or the right-mouse button in the appropriate
cell (for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data

Despite the ease and speed with which you can navigate through large
Hyperion Essbase databases, it is not practical to use the capabilities of Lotus
1-2-3 to filter and sort very large databases; however, the Essbase server
includes powerful data filtering and sorting capabilities. In you
learned to use Essbase Query Designer to define a dimensional layout and to
select members to view. Essbase Query Designer also provides a powerful, yet
easy-to-use tool to define conditional retrievals.

To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basicl, that you saved in and perform the
following steps:

Note: If you skipped the tutorial in [Chapter 3] follow the steps in

[Queries Using Essbase Query Designer” on page 65|to create and save
the Basicl query.

1. Select Essbase > Query Designer.

Essbase displays the query information panel of Essbase Query Designer.
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In the navigation panel, select
<<c:[Book1]Sheet1\lotus\Work\ 123\ Untitled.123>>A.

Right-click and select Open Query.

Essbase displays the Open Query dialog box.

From the location that you specified in select the Basicl file.
Click OK.

The member selection, displayed in the properties panel, remains
unaltered from the last Essbase Query Designer session.

From the navigation panel, select Data Filtering.

Essbase displays the data filter settings in the data filter panel. The filter
controls the number of data rows that are retrieved. The number is based
on the column criteria that you define. You can define data filtering
criteria on data values that reside in one or more columns of the view.

,’} Hyperion Essbase Query Designer EHE
- Dlenslons = Tse this data filter panel to retrieve data basedon =
EI'" Pane the rank order that you have specified.
5 - Measures 1. Zelectthe Top or Bottom check hox, or hoth.
] Prafi 2. Specify how many rows you want to retrieve.
3. Belect a dimension from the "Dimension being
ranked" drop-down list box.
4. Belect the column from the "Column used for
ranking" drop-down list box.
5. Double-click in the "Data Restrictions" boxto
create additional data filters.
Mote: Follow Step 5 only if you want to define j

B Column

B Budget

&% Data Filtering
=] Data Sorting
- B Messages & Confimations

Help

<

E‘E 400, Al Descendants

El"@ Avyailable Dimensions

-7 Caffeinated [B ase:Praduct]
Irtra Date [Baze Product)
Ounces [Base:Praduct]
Pkg Type [Base:Product)
Population [B ase:Market)
B2 Attribute Caleulations

Rark: T

i |25 _Igﬁows ™ Battom |25 _,::' Rows

Dimengzion being ranked
I Product

=]
Coluran uzed for ranking
I Ot Actual

Diata Restrictions:

[double click ta create a new data restriction)

|5l

Figure 89. Data Filter Panel

6.

The data filtering panel contains the following items:

* A check box for ranking so many of top rows or so many bottom rows
of data. You can select the highest or lowest rows. Your selection is
based on previously selected row dimension members. When using the
top or bottom criterion, you specify the number of rows, such as “top
10.” The default is the top 25 rows.
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* A Dimension being ranked list box to specify the dimension to which
ranking should be applied.

* A Column used for ranking list box to specify the data column on
which data values are based.

* A Data Restrictions box to specify standard data comparison
operations, such as greater than, less than, and equal to. You can apply
the comparison operator to data values, including negative data values,
in one or more data columns; you can even apply criteria to compare
values between two columns.

* Buttons for OR and AND operators. If you define more than one
column criterion, you can use these operators to link the criteria.

7. Click the Top check box, and enter a value of 30 in the Rows text box.

When you apply the query, Essbase retrieves the top thirty rows of the
dimension.

8. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.

9. From the Column list box, select Qtrl, Actual. Qtrl, Actual is the column
on which data values are based.

10. In the navigation panel, select the Data Filtering icon. Right-click and
select Apply Query.

Your query results should look as shown below.
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A B [ ¢ | ©o | E F c | H | 0 [ 4 =
1 =
12 |
| 4 |East Cola 2461 2580 3080 3440 2410
15 | Grape 645 840 860 920
| B | Cream Soda 591 770 1010 BE0
1 7 Root Beer 562 960 1070 830
| & Strawherry 544 700 7a0 780
19 | Orange 290 350 380 420
| 10| Diet Cola 212 220 300 310
|11 | Caffeine Free Cola 74 110 130 190
| 12 | West Cream Soda 2363 2620 2970 3230
113 | Root Beer 2325 2570 2720 2820
| 14 | Grape 1143 920 960 1020
115 | Cola 1047 1720 1500 2120
| 16 | Orange 1002 810 830 1000
|17 Cafteine Free Cola g2 310 a0 -130
| 18 | Diet Cola 87 320 200 280
| 15 | Strawberry -738 -310 -380 -440
| 20 | South Root Beer 1465 1640 1700 1710
121 Cala 745 1160 1260 1490
122 | Cream Soda 561 810 770 840
123 | Diet Cola 306 570 660 570
| 24 | Central Cream Soda 2414 7o 2530 2580
125 | Root Beer 2369 3310 3380 3470
| 26 | Grape 10450 1030 1120 1150
|27 | Orange 991 910 1020 1010
2 Diet Cola 908 1130 1320 1340
14 [ 4[» [pi[Sheet1 ; Sheetz [ Sheet3 |

Figure 90. Data Filtering Query Results

11.

12.

13.

14,

15.
16.

17.

18.

19.

You can further filter your data output by specifying data comparison
operations in the Data Restrictions box.

In the navigation panel, select the Data Filtering icon.

The data filters that you specified are displayed in the properties panel.
In the Data Restrictions box, double-click.

The data restriction settings are displayed in the properties panel.
Select the Value option and type 500 in the Value box.

Observe that the is option in the Data list box changed to =.

Click the down arrow of the Data list box and select <=.

Select Qtrl, Actual in the Column list box.

In the navigation panel, select the Data Filtering icon. Right-click, and
select Apply Query.

Notice that the query results now reflect only Actual and Budget data
that are less than or equal to 500.

In the navigation panel, select the Data Filtering icon to display the data
filter setting in the properties panel.

In the Data Restrictions box, select Qtrl, Actual <= 500, right-click and
select New Data Restriction.

In the Data box, click the down arrow and select <.
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20.

21.

22.
23.
24,

25.

In the data values list box, select Qtr2, Actual. Under Combined With
Other Restrictions, click the Or button.

In the navigation panel, click the Data Filtering icon to access the data
filter panel.

In the Data Restrictions box, double click to create a new data restriction.
In the Data box, click the down arrow and select Is Not.

Click the button for the #Missing Value option.

This option instructs Essbase to discard data that have #Missing values.
In the Column list box, select Qtrl, Actual. Under Combined With Other

Restrictions, select the And button.

The data restrictions should display as follows:

r’} Hyperion Essbase Query Designer

Froduct

g 100, &0 Children

DR 400, &l Descendants
Column
Year

Scenario

l:'E| Actual

Available Dimenzions

9 Caffeinated [Basze:Product]

ntio D ate [Base:Product)

Ounces [Baze:Product]

Pkg Type [Base:Product]

1 Population (Base:Market)
§/ Attribute Calcu\atlons

Gt fciual <= SDD
OR G, Actual < Qtr2, Actual
AND G, Actual is not #missing

[Tse this data filter panel to retrieve data hased on

the rank order that you have specified,

1. Select the Top or Bottom check box, or both.

2. Bpecify how maty rows you want to retrieve.

3. Select a dimension from the "Dimension being
ranked" drop-dovrn list box

4. Select the column from the "Column used for
ranking" drop-down list box.

5. Double-click in the "Data Restrictions" box to
create additional data filters.

Hote: Follow Step 5 only if you want to define

-

=l

=] Data Sorting

! =
| v

Fiank:

¥ Top |3U _Izﬁows ™ Eattam |25 _Ij Rows

Dimension being ranked:

I Product

=

Colurn uzed far ranking:

I Gtrl, Actual

Diata Restrictions:

Gl Actual <= 500

-~ AND G, Actual is

- OR G, Actual < 02, Actual

ot Hriszing

- [double click to create a new data restriction]

Figure 91. Data Filtering

26.
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Select the Data Filtering icon, right-click, and select Apply Query.

Essbase retrieves data for all the quarters. Notice that the retrieved data
for Qtrl, Actual is less than or equal to 500 or is less than Qtr2, Actual.
The results should display as follows:

Spreadsheet Add-in User’s Guide for 1-2-3



A B C D E F G | H | I

- =
2
=R E & a Actua £
| 4 |East Cola 2451 2550 2940 3050 3295 3440
| 5 | Grape B45 840 B76 860 710 920
| 6 | Cream Soda 591 770 922 1010 522 660
| 7| Root Beer a62 960 B10 1070 372 530
| & Strawberry a45 700 612 750 625 780
ER Orange 290 350 327 330 377 420
| 10 Diet Cola 212 220 303 300 312 310
|11 Caffeine Free Cola 74 110 109 130 130 190
| 12 |West Cream Soda 2363 2520 2738 2970 2937 3230
|13 Root Beer 2325 2570 2423 2720 2540 2820
| 14 | Grape 1143 920 1167 950 1271 1020
| 15| Cola 1047 1720 1188 1900 1339 2120
| 16 | Orange 1002 810 1120 850 1192 1000
|17 Caffeine Free Cola B2 310 -163 30 -286 -130
| 15 | Diet Cola -B7 320 -177 200 -154 250
|19 Strawberry -738 -310 -783 -380 -300 -440
| 20 | South Root Beer 1465 1640 1540 1700 1612 1710
| 21 Cola 745 1160 835 1280 1031 1490
| 22 | Diet Cola 306 570 363 BE0 281 570
| 23 | Central Cream Soda 2414 2770 2578 2930 2645 2980
| 24 | Root Beer 2369 3310 2457 3350 2481 3470
| 25 | Grape 1050 1030 1155 1120 1220 1150
| 26 | Orange 991 910 1075 1020 1073 1010
| 27 | Diet Cola 903 1130 1045 1320 1089 1340
| 25 Cola 843 1080 928 1180 95 1170
129 | Caffeine Free Cola 457 B20 500 B10 556 BS0
30 Strawberry 77 90 a7 90 130 140
14| 4[¥ [p]Sheet1 ; sheet? £ Sheeta | <]

Figure 92. Data Filtering Results

Note: To delete all data restrictions, select the Data Filtering icon in the
navigation panel, right-click, and select Delete All Data Restrictions.
Alternatively, select any data restriction in the Data Restriction box,
right-click, and select Delete All Data Restrictions.

Note: To delete a particular data restriction, select the data restriction in the
query outline, right-click, and select Delete Data Restriction.
Alternatively, select the data restriction in the Data Restriction box,
right-click, and select Delete Data Restriction.

Sorting Data

Using the data sort panel, you can sort the output from the Basicl query in
ascending or descending order.

1. From the navigation panel, select the Data Sorting icon.

The data sorting settings are displayed in the properties panel. You can
specify data sorting criteria that affect the order in which the selected
rows are retrieved in the data sorting panel.

The data sorting panel contains the following items:

¢ A Dimension being sorted list box that lists the dimensions specified in
row format in the query.
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* A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

* An Ordering list box that you use to apply an ascending or descending
sort order for the selected column. You can also specify sorting to
occur over a specific row dimension group. For example, you can sort
by Product or by Market.

Market ) :l‘ Use this data sort panel to sort rowsin =+
“ Region = ascending or descending order based on
o Product ) = column data walues.
""" DF 100, AN Children = 1. Belect a dimension from the
""" 200 "Dimension being sorted" drop-
----- Bg 300 G down lst box
----- By 400, &ll Descendarts 2. Click "Ordering" and select
=0 Calumn Aarending ar Tleanending feam the LI
S vear
----- OF ol
----- B ow2
----- B Q3
""" I:S‘El m"_‘ Dimenszion being sorted:
CEnario
o9 Actual Product j
D Budget =
N Available Dimensions Ordering Column used for sort
Caffeinated [Base:Produc [double click to create a new sort rule]

7 Intro Date [B ase: Product]
7 Ounces (Base:Product]
Plg Type (B aze:Product]
Population [Baze:barket]
Attribute Calculations
£ Data Filtering, Top 30

23] O, Actual < 500
OF Qil, Actual < O2, Actua
AMD O, Actual is not Bmiss

[Data Sorting

=
1 | ]

Figure 93. Data Sorting Panel

2. In the Column used for sort list box, double-click.

The selection defaults to Qtrl, Actual. The sort order defaults to
Ascending in the Ordering list box.

3. Click Ascending. A down arrow is displayed next to Ascending.
4. Click the down arrow. Descending is displayed below Ascending.
5. In the Ordering list box, select Descending.
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+» Hypernon Essbase Query Designer (7 1] I

4]

-] 400, &1l Descendants

=[] Colurn

E|---D. Year
DE| [elia}

Scenario

By Actual
B Budget

E"Ej Available Dimensions

Caffeinated [Base:Product]
Intro Date (Baze:Product]
Ounces [Base:Product]
Pkg Type [Basze:Praduct]
Population [Base:Market]
----- Z2 Attribute Calculations

OR O, Actual < Ok2, Actual
AND Gtrl, Actual is not #missing

Use this data sott panel to sort rows in ascending or +

descending order based on column data values.

1. Helect a dimension from the "Dimension being
sotted" drop-down list box

2. Click "Ordeting" and select Ascending or
Descending from the drop-down list box.

3. From "Colamn used for sor," select the coluwmn
ditnensiog.

4. Double-click in "Column used for sort” to create
another sort rule.

Descending, G, Actual

|2

You have completed defining the sort rules. LI
Dimenzion being sorted:
IPdeuct j
Orderin Column used for sort

|Descendin~

Qtrl, Actual

[double click to create a new sort rule]

Figure 94. Specifying Data Sorting Order

6. In the next row of the Column used for sort list box, double click.
The selection defaults to Qtrl, Actual.

7. Click the down arrow and select Qtrl, Budget.
Observe that the order in the Ordering list box has defaulted to

Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtrl,

Budget. Right-click and select Delete Sorting Rule.
The Ascending, Qtrl, Budget sorting rule is deleted from the query.

9. In the navigation panel, select the Data Sorting icon. Right-click and

select Apply Query.

Essbase returns the results sorted in descending order for each quarter, as
shown below:
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B [ ¢ [ b | E F c | H | 1 [ 4
1 =

[ 2

| 4 |Cola 2461 2550 3440 2430
| 5 |Grape G454 G40 920 618
| 6 | Cream Soda 591 770 660 592
| 7 | RootBeer 562 S50 830 930
| 8 |Strawherry 545 700 780 524
| 9 |Orange 290 350 420 394
| 10 |Diet Cola 22 220 310 287
| 11 |Caffeine Free Cala 74 110 190 100
| 12|  Cream Soda 2363 2620 2739 2970 2937 3230 2652
|13 | Root Beer 2328 2570 2423 2720 2540 2320 2439
| 14 |Grape 1143 920 1167 960 1271 1020 1219
| 15 |Cola 1047 1720 1189 1900 1339 2120 1015
| 16 |Qrange 1002 a10 1120 ga0 1192 1000 340
| 17 |Caffeine Free Cola B2 310 -163 30 -286 -130 -123
| 18 |Diet Cola RaTi 320 -7 200 -154 240 -136
| 19 | Strawherry -738 -310 -783 -380 -20a -440 -77a
|20 |  RootBeer 1465 1640 1540 1700 1612 1710 1498
| 21 |Cola 744 1160 G35 1280 1031 1450 965
| 22 |Diet Cola 306 570 363 60 281 570 247
123 Cream Soda 2414 2770 2579 2930 2643 2930 2450
| 24| Root Beer 2369 3310 2457 3350 2481 3470 227
| 25 |Grape 1050 1030 1155 1120 1220 1150 970
| 26 |Qrange 991 910 1075 1020 1073 1010 1070
| 27 |Diet Cola 903 1130 1045 1320 1039 1340 832
| 28 |Cola 843 1080 928 1180 315 1170 793
| 29 |Caffeine Free Cola 447 620 400 610 falala) 590 a6y
30 | Strawherry 77 90 g7 130 140 205
14 4[> [M]sheet1 ( sheetz f Sheets /

Figure 95. Result of Filtering and Sorting Data
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Retriev

Spreadsheet

Note: The values that you are ranking and sorting must be the same. For
example, you cannot specify Product in the Dimension Being
Ranked box and Market in the Dimension Being Sorted box. If you
specify different values, Hyperion Essbase Query Designer
automatically changes both values to the last specified value.

10. To close the worksheet, select File > Close. You do not need to save the
worksheet.

ing Data into Asymmetric Reports

When you retrieve data into a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, Figure P5|shows a symmetric
report that contains Actual and Budget members nested below Year members
(Qtr1, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that
differ by at least one member. There can be a difference in the number of
members or in the names of members.
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You can create asymmetric reports in one of the following ways:

Enter member names into the worksheet in free-form retrieval mode.

Use a drill action with the Within Selected Group option selected from the
Essbase Options dialog box (Zoom tab).

Suppress rows that contain missing values, zero values, or underscore
characters during data retrievals.

If you retrieve data into an asymmetric report, Essbase must perform
additional internal processing to maintain the asymmetric layout. This
processing may increase the retrieval time on large reports. For more
information regarding optimizing reports, see the Database Administrator’s
Guide.

As part of the default Essbase installation, Hyperion Essbase provides a
sample file, Asymm. 123, that illustrates how to create asymmetric reports.

To view the sample file, Asymm.123:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Asymm.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

A B | ¢ | b | E | F | G|
1 |Sales
2
3 Aoiusl | Budgs! | Sudgs? | Suage?
1 Qtrl Qtr2 Qtr3 Qtr4
h |East Colas h24z b7R0 /300 RRY0
b Root Beer h72hB hBA0 hE00 h730
7 Fruit Soda 3735 4150 4350 3850
8
9 |"West RootBeer g2vh 74970 8320 /820
10 Cream Soda 8043 7720 §300 /570
11

Figure 96. Asymmetric Report

In Asymm. 123, row and column dimension groups are asymmetric. Thus,

the nested member groups from the Product dimension differ in member
content within respective markets. For example, Colas and Fruit Soda are
included in East but not in West. In addition, Actual data is displayed for
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Qtrl, whereas Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also
notice that the sample file displays styles for members of the Scenario and
Year dimensions.

3. Leave the Asymm.123 file open for the next tutorial task.

Pivoting in Asymmetric Reports
When you pivot a group of members in an asymmetric report, Essbase keeps
only unique members from dimensions that are not involved in the pivot.

To use the open Asymm.123 file to illustrate this point:
1. Using the right-mouse button, drag East to the cell below Qtrl.

A | B |lc|] b lE] F || H [ 1]
1 sales
2
3 Actist Hudgst Huags? Hudgst
4 Qtrl Qtr2 Qir3 Qtr4
b East IWeat!East “West East “West East West
B |Colas B292 6950 G760 8800 7300 3100 E570 3430
7/ |RootBeer R726 8278 BB50 7970 BBO0 8320 5780 7820
8 |FruitSoda 3735 8403 4150 5840 4350 BO70 3850 5280
8 |Cream Soda 4863 8043 40300 7720 3850 3300 3N70 7570
10

Figure 97. Result of Pivoting in an Asymmetric Report

Essbase combines the Product members into all unique members. For
example, Root Beer, which is displayed twice in Figure@ is displayed
only once in the current view. Colas, which is displayed in only one
market in Figure 96, now is displayed in East and West.

Essbase also removes the blank line between Product row groups. A pivot
action always eliminates any rows or columns in which all cells are empty.

2. Close Asymm. 123 without saving the changes.

Working with Formatted Worksheets

In addition to providing flexible, ad hoc retrievals, Essbase supports retrieving
data into formatted worksheets. A worksheet can contain the following
formats:

* Spaces between rows and columns

e Cell values that contain text or data that is not defined in the database
outline

* Member names in noncontiguous locations at the top of a worksheet
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* Lotus 1-2-3 formulas (see also [‘Preserving Formulas When Retrieving Data”|
on page 117

* Visual cues (styles)

After you format and save a worksheet, you may want to retrieve and
navigate through new data in the existing worksheet format. This section
provides the following information on working with formatted worksheets:

* [“Observing the Rules for Working with Formatted Worksheets” on page 113|

* ['Retrieving Data into Formatted Worksheets”

* [‘Pivoting Data on Formatted Worksheets” on page 116|

Observing the Rules for Working with Formatted Worksheets
Observe the following rules when retrieving data into a formatted worksheet:

Rule 1: In the worksheet, no numeric cells can be located before the first
Hyperion Essbase data cell. For example, in Figure [98 the first Essbase data
cell is B6. Neither any cell in rows 1 through 5 nor cell A6 can contain
numeric values. Also, these cells cannot contain formulas that resolve to
numeric values.

Rule 2: A cell that lies within a row or column of Essbase data cannot
contain text or numeric values. For example, in Figure [98} the cells in columns
B, C, D, and F and rows 6 through 9 and 11 through 14 cannot contain any
nondata text or numbers, for such values may be overwritten (or emptied) by
the retrieved data. These cells can contain formulas, however, if Formula
Preservation options are used. For more information on Formula Preservation
options, see [‘Preserving Formulas When Retrieving Data” on page 117}

Tip: If you need to preserve text in a cell, define that text or value as an
Lotus 1-2-3 formula, and use the Formula Preservation options.

Rule 3: The Pivot command is not available when the Retain on Retrieval
check box is selected in the Essbase Options dialog box (Mode tab).

Rule 4: The Pivot command removes all cells that contain text other than
database member names.

Retrieving Data into Formatted Worksheets
As part of the default Essbase installation, Essbase provides a sample file,

P&l1.123, that illustrates how to retrieve data into a formatted worksheet. The
P&1.123 sample file illustrates how to retrieve data into a worksheet that
contains formatted text, formulas, and protected cells.

To view the P&1.123 worksheet:
1. Select File > Open.
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2. From the \Essbase\client\sample directory, open the P&l.123 file.

Depending on how software is installed on your machine, the file may
not be available or may be located in a different directory. Contact the
Essbase system administrator for more information.

A | B | ¢ | o | E T F ] G | H
L1 Market: Central The Beverage Company
| 2 | Product: 200 Flanning Dept.
| 3 | Scenario: Gudget
4
I—
6 [Misc 5 10 10 25 030
7 |Payrall 200 200 200 GO0 0.07
8 |Marketing 350 340 340 1050 12.47
9 Total Expenses 555 &&0 5E0 1675 19.89
10
11 [COGS 1170 1180 1200 3550 4216
12 [Sales 2740 2820 2860 a420 100.00
13 Margin 1570 1640 1660 4870 57.84
14 Profit 1015 1080 1100 3195 37.95
15
16 |Ratio Analysis
17 [Markup 57.3% 58.2% 63.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.5%

Figure 98. A Sample Formatted Worksheet

3. Select Essbase > Options and select the Display tab.

4. In the Cells option group, make sure that Adjust Columns is checked.
5. Select the Mode tab.
6

In the Formula Preservation group, select the Retain on Retrieval check
box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay
in retrieval time.

7. Click OK.

By default, an Essbase retrieval overwrites Lotus 1-2-3 formula with data
values in the retrieval area of a worksheet. The retrieval process also
eliminates formulas in cells outside the retrieval area. However, the
Retain on Retrieval option enables you to define retrievals that do not
overwrite formulas in any area of the worksheet.

8. Select Essbase > Retrieve to update the worksheet with the latest data
values.

Essbase determines that some text cells in the worksheet do not
correspond to database member names. When Essbase is unable to
resolve text in the worksheet, the following message is displayed:
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Ezzhase Message Eq

::) The zheet containg an unknown member; b arket;,
[ ]

Thiz item will be ignored when you retliese data from the server.

There may be additional cells that contain unknown database members.
D'o pou want to display additional unknown members in this retrieeal?

Ve Mo

Figure 99. Essbase Unknown Member Message

In this example, the first unknown member detected is Market: (in cell
Al). Essbase does not recognize the colon (:) that follows Market in the
cell. If you click Yes, Essbase displays the next unknown member; if you
click No, Essbase continues with the retrieval.

Note: If you work with formatted worksheets often, you may want to
tell Essbase not to display this message. For more information, see
[“Pivoting Data on Formatted Worksheets” on page 116}

9. Click No to close the dialog box and continue with the retrieval.
Essbase retrieves new data but retains the formatting and formulas in the
worksheet.

A | B | ¢ | b | E | F ] G | H
| 1] Market: Central The Beverage Company
| 2 | Product: 200 Planning Dept.
| 3 | Scenario: Budget

4

5

6 |[Mhisc

¥ |Payroll 210 210 210 G330 0.07

8 |Marketing 300 310 320 930 11.05

9 Total Expenses 510 520 530 1560 18.53

10

11 [COGS 1170 1180 1200 3550 4216

12 [Sales 2740 2520 268680 5420 100.00

13 hargin 1570 1640 1680 4870 57.84

14 Profit 1060 1120 1130 3310 39.31

15

16 |Ratio Analysis

17 |Markup a7.3% 558.2% a3.0% a7.8%

18 |Marketing % 10.9% 11.0% 11.2% 11.0%

Figure 100. Result of Retrieving on a Formatted Worksheet

10.

Close P&1.123 without saving it.
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Note: This chapter’s section on [“Preserving Formulas When Retrieving Data”|
provides additional tutorial tasks that show you how to
take advantage of all the Formula Preservation options.

Pivoting Data on Formatted Worksheets
With the Pivot command, you can produce ad hoc reports in both formatted

and unformatted worksheets. However, a formatted worksheet may contain
labels and formulas that make the result of a pivot operation ambiguous. The
pivot is designed to compress and retain only the database elements
represented in the worksheet. The worksheet also retains labels in areas that
are not overwritten by pivoted data.

Note: Essbase prevents pivot operations on worksheets that contain formulas
when Formula Preservation mode is active.

Inv.123, a sample file installed as part of the Essbase installation process,
illustrates how to pivot data in a worksheet. It was saved with the Retain on
Retrieval option disabled so that you can pivot on its worksheets.

To view the Inv.123 worksheet:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Inv.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

n | B | c | D | E F | G
1 |[Market fmveniarn: Anahsis
2 |Astual
3 Jan Feb Mlar &t
4
5 |Zales 100 8314 8327y 8407 25048
b 200 876 BOG0 8954 26627
i 300 Ja7a 8045 aoy7 23897
8 400 G634 6736 G778 20148
9 Product 31638 32069 32213 45820
10
11 Cpening Inventory 100 29448 20124 28929 29448
12 " Adjusted for Audit 200 33000 32100 31125 33000
13 300 28865 28064 29005 28865
14 400 26092 26246 26408 26092
15 Product 117405 116434 115568 117405
16
17 |Stock to Sales 3.72 3.63 3.59
16

Figure 101. Formatted Worksheet Before Pivoting

3. Select Essbase > Options and select the Global tab.
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4. In the Display Messages group, clear the Display Unknown Members
check box to avoid seeing the Essbase messages when working with
formatted worksheets.

5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested
below Jan (C4).

Essbase pivots the Sales member group so that it is nested below the
monthly members. However, during the pivot, Essbase retains only
database elements. For example, all data for Stock to Sales and Adjusted
for Audit is deleted during the pivot.

A | c | b | E I F | G
1 faverion: Aralvsis Market
2 Actual
3 Jan Feh Mar
4 Sales [[Opening Inventery  [Rales Qpening InventerySalas Opening [nventorny
5
LY 834 20448 8327 20124 8407 28929
¥ 200 8716 33000 2960 32100 8951 126
g8 300 TaTd 288465 andg 28964 anyy 28095
9 400 6634 26092 G736 26246 G778 26408
10 Product 5838 117405 A2069 116434 32213 115558
11
12 [" Adjusted fer Audit
13
14
15
16
17 |Stock to Bales
18 ===== :: ===== —====

Figure 102. Result of Pivoting on a Formatted Worksheet

6. Close Inv.123 without saving it.

Preserving Formulas When Retrieving Data

In [“Retrieving Data into Formatted Worksheets” on page 113} you used the
Retain on Retrieval option to preserve formatting and formulas in an existing
worksheet. Collectively, the Formula Preservation options enable you to retain
formulas during data retrievals, keep and remove only operations, and drill
operations. In addition, Essbase can replicate formulas for additional members
retrieved into the worksheet as part of a drilling operation. This section steps
you through using all of the Formula Preservation options in a report that you
create.

You must enable some options before you can enable other options. Keep in
mind the following guidelines and restrictions when using the Formula
Preservation options:

* On the Mode tab of the Essbase Options dialog box, you must have the
Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.
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* You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

* You must enable Retain on Zooms to enable Formula Fill.
* When you select the Retain on Retrieval check box, the Suppress #Missing
Rows and Zero Rows options on the Display tab become disabled.

Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.

* When you select the Retain on Zooms check box, the Remove Unselected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

* When Retain on Retrieval is enabled, there may be a slight delay in
retrieval time.

* As a general rule, insert a blank row as the last row in the formula range to
ensure that the cell range in the formula expands properly when you drill
down on members with Retain on Zooms enabled. For more information,
see the Essbase Spreadsheet Add-in online help.

* Formula arrays are not supported in Essbase Spreadsheet Add-in when the
preserve formula option is on. If you have formula arrays in the worksheet,
Essbase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Retrieve.
In cell A2, drill down (double-click) on Year.

Press and hold the Alt key and, in cell E1, drill down (double-click) on
Scenario.

5. Select cell G3 and enter the following formula in the cell: =B3/B$7+100.

o DdPRE

Note: The $ in front of the 7 anchors the formula to the Year member.
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A | B | ¢ | p ] E [ F ] G | H
L1 Measures Product Market
| 2 | Actual Budget “ariance “ariance % Scenario
| 3 |Gl 24703 30580 5877 -19.21844343 24?03|=EBIEI?*1DD _l
| 4 G2 2007 32870 5763 -17.63270459 27107
| 5 |G 27912 33980 FOE3 -17. 85756327 27912
| 6 [Citrd 26800 F1950 6150 -19.248582629 25800
| ¥ | ear 105522 1295380 -23853 -18.44025352 1055272
[i]
| 9
|10 |
Figure 103. Entering an Lotus 1-2-3 Formula into a Cell

6. Press Enter.

Lotus 1-2-3 calculates the formula that you entered in cell G3 and now
reflects Qtrl as a percentage of Year.

A | B | ¢ | b ] E [ F ] G | H
11 Measures Product Market
| 2 | Actual Budget “ariance Variance % Scenario
| 3 |Gir 24703 30880 5877 -19.21844343 24?03' 23.41028411!
| 4 |Gtr2 207 32870 -57B3) 1753270458 ZA107
| 5 |Gtr3 27912 33980 BOBB -17.86756327 27912
| 6 |Citrd 28800 31980  B180) -19.24882625 25800
| 7| fear 108522 129380 -23858 -18.44026352 105522
i
9]
10 |

Figure 104. Result of Lotus 1-2-3 Formula with Essbase Data

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, select the check boxes for Retain on
Retrieval and Retain on Keep and Remove Only. Click OK.

© N

©

In cells D2, E2, and F2, respectively, select Variance, % Variance, and
Scenario.

10. Select Essbase > Remove Only.

Essbase removes the selected columns but retains the Lotus 1-2-3 formula
that you entered, keeping it with the retained dataset.
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A | B | ¢ ] DD | E | F | 6

=N ==NE =i L Nl DTN F N

—
=

Measures FProduct Market
Actual Budget

it 24703 30580| 3. 410284111
Gt 2007 32570
Gtr3 27912 33950
Gitrd 268000 31950

Year 105522 125330

Figure 105. Result of Removing Columns with Retain on Keep or Remove Only Enabled

11.
12.

13.

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, click the box for Retain on Zooms and
click OK.

In cell A3, drill down (double-click) on Qtrl.

Essbase drills down on Qtrl and moves the formula down with the Qtrl
member.

A | B | ¢ ] b | E | F | &

| 20|l [ | | e (ot | P [ e

— | —
= ]

Measures Product Market
Actual Budget

Jan 8024 9940
Feb 8346 10350
Mar 8333 10290
it 24703 30580( 23410284111
Gt 2M07 0 32570
Gtr3 272 33530
Gitrd 25800 31950

Year 105522 129350

Figure 106. Result of Drilling Down with Retain on Zooms Enabled

14.
15.
16.

17.

Select Essbase > FlashBack.
Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, select the Formula Fill check box.
Click OK.

In cell A3, drill down (double-click) on Qtr1.

Essbase drills down on Qtrl and replicates the formula for each member
of Qtrl (Jan, Feb, and Mar). To view the replicated formulas, click in cells
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D3, D4, D5, and D6 and look at the new syntax in the Lotus 1-2-3
formula bar.

A | B | c | D | E | F
1 beasures Product Market
. Actual Budget
3 |Jan B024 9940 29.60121002
4 |Feh 9345 10350 29.9011178
5 |Mar 8333 10290 32.29844951
6 it 24703 30580 23.41023411
7 itz 2707 32870
8 i3 27912 33980
9 Citrd 25800 319580
10 Year 108522 129380
11

Figure 107. Result of Drilling Down with Formula Fill Enabled

18. Before moving on with the tutorial, complete each of the following
actions:

a. Select Essbase > Options and select the Mode tab.
b. Clear all of the Formula Preservation options.
C. Select File > Close to close the worksheet. You do not need to save
the worksheet.
Retrieving a Range of Data

In a typical Lotus 1-2-3 worksheet, you can select a range of cells by dragging
the mouse across the worksheet. You can also select a range of cells and tell
Essbase to restrict the data retrieval to the selected range in the worksheet.
Retrieving a range of data is particularly useful in the following situations:

* A worksheet contains multiple reports.

* A worksheet contains extraneous information that is not supported in a
formatted report retrieval.

* You need to retrieve only a small subset of values from the server, thus
dramatically decreasing retrieval time for large datasets.

* You need to retrieve data to an area of the worksheet other than the first
column.

As part of the default Essbase installation, Essbase provides a sample file,
Profit.123, that illustrates how to retrieve a range of data.

To view the Profit.123 file:
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1. Select File > Open.
2. From the \Esshase\client\sample directory, open the Profit.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Profit.123 has already selected a range of cells (B2 through F9) for you.

A | B | ¢ | b | E | F | & | H
1
z2
3
4
5
b
7
8
9
10
11
12 Central  Actual Frofit %4
13 2t Citr? Citrd Citrd “ear
14 100-10 220 | ez 22 ez
15 100-20 220 ez ez 22 ez
16 100-30 220 220 220 220 220

Figure 108. Selected Range of Cells for Retrieval

3. Select Essbase > Retrieve to update the selected range.
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k| k| | k[ k| |
mm_hmm_,:mmumm.hmm—h

Central  Actual Profit %4
2 Ciire O3 Citrd “ear
100-10 220 220 220 220 220
100-20 ez 220 | | 220
100-30 220 220 220 220 220

Figure 109. Result of Retrieving First Range of Data

Essbase updates only the data in the selected range of cells.
4. Select cells B12 through Gl16.

A | B C D E F | & | |
1
2 100 Central
3 Actual Budget
4 Sales Profit %2 Sales Profit %4
h i a074 273 g200 345
b Citre a7l 284 aa70 351
7 (i aa594 288 59060 353
8 Citrd a1349 276 7800 381
9 Year 33808 281 335930 357
10
11
12
13
14
15
16

Figure 110. Selecting Cells for Retrieval

5. Select Essbase > Retrieve once again to update the selected range.
Essbase updates the data in the selected range.
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A | B [ D E F | G |
1
2 100 Central
3 Actual Budget
4 Sales Frofit %2 Sales Frofit 22
5 Citrl g074 273 az20n 3445
b Citrd 8701 c8.4 aav0 3h.1
7 Citr3 g8494 78.a 9060 35.3
8 Citrd 8139 27 A 7800 381
9 Year 33808 8.1 33930 35.7
10
11
12
13
14
15
16

Figure 111. Result of Retrieving Second Range of Data

6. Close Profit.123 without saving it.

Retrieving Data by Using a Function

The Essbase cell retrieve function, EssCell, retrieves a single database value
into a worksheet cell. Enter an EssCell function directly into a worksheet or

select an EssCell function from the Lotus 1-2-3 menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform an Essbase retrieval or when you
recalculate a worksheet through Lotus 1-2-3. As part of the default Essbase
installation, Hyperion Essbase provides a sample file, Summary.123. This file

has EssCell functions already set in cells B16 and B17.

To view the Summary.123 file:

1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Summary.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase

system administrator for more information.
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Figure 112. Worksheet Containing EssCell Functions

A A [B | ¢ | [ £ [ &6 |
1 200

2 |Texas

3

4 Budget

] Citr1 Citr2 Citr3 rear

B |Sales 1130 1260 1440 1200 5030

T |COGS 450 500 570 4490 2010

] bargin 530 760 870 710 3020

8  |Marketing 270 300 360 290 1220

10 Payroll 120 120 120 100 460

11 Misc #hdisging  #Missing  #Missing  #Missing  #Missing

12 Total Expenses 330 420 480 390 1680

13 Profit 2490 340 3490 320 1340

14

15

16 “ear Sales

17 “ear Margin %

18

15 N ETRIE BAFSSCELL"Sales" "200" A2 "Budget' "Year' "MULL" "NULL" "M
20 {LET B17.(@ESSCELL{"Margin %" "200" A2, "Budget" "Year" "NULL" "NULL

Cells B19 and B20 in Summary.123 contain the EssCell function, which will
display the results of the function in cells B16 and B17, respectively.

The EssCell function is defined in a cell as follows:

{LET cellref,@EssCell(mbrList)}

where cellref is a reference that points to the cell where Hyperion Essbase

should return the database value.

mbrList is one of the following:

* A null value. If the parameters of the function are empty, Essbase
returns the data value from the top of each dimension.

¢ A comma-delimited list of member names. Member names must be

enclosed in double quotes, with only one member per dimension
allowed. If you list no members from a particular dimension, the
function returns the data value from the top member of the unspecified

dimension. Furthermore, you can include aliases in the member list,

subject to the same rules as member names.

* A Lotus 1-2-3 cell reference. The reference must point to a cell that

contains a valid member name. Member names, such as 200 and 300-10,
need to be formatted as text cells, rather than numeric cells.
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For example, the syntax for the EssCell function in cell B19 in the
Summary.123 file is the following:

{LET B16,@ESSCELL("Sales", "200", "A2", "Budget", "Year","NULL","NULL",
"NULL”,"NULL”,"NULL”,"NULL”,"NULL”, IINULLII’IINULLII’IINULLII)}

When you open the worksheet, the values in these cells are #N/A. To
update the values with the data in your database, you must run the macro
function.

3. Select cell B19, then select Edit > Scripts & Macros > Run. In the Run
Scripts & Macros dialog box, select the Macro option, then click Run.

Bun Scripts & Macros |

" Script & Macro Bun
From:
[ Step
EI Cancel
Help

Figure 113. Run Scripts & Macros dialog box
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A B | ¢ | D | E | F ]
1 |200
2 |Texas
3
4 Budget
5 Qi Oitr2 Citr3 Citrd r'ear
b [Sales 1460 1560 1630 1320 5370
7 [COGE BED 530 B30 500 2280
8 bdargin q00 970 1000 820 3630
9 [Marketing 160 160 170 120 E10
10 Payraoll G0 &0 60 110 230
11 |Misc #hdissing #hissing #Missing #Missing  #Missing
12 | Total Expenses 220 220 230 230 300
13 Frofit 630 750 770 540 2730
14
15
16 “rear Sales 5470
17 Year Margin % 61.81

Figure 114. Retrieval on a Worksheet Containing the EssCell Function

Now update the EssCell functions to retrieve data for a different state.

Change the contents of cell A2 from Texas to Florida.

Select cell B19, then select Edit > Scripts & Macros > Run. In the Run
Scripts & Macros dialog box, select the Macro option, then click Run.

Hyperion Essbase recalculates the EssCell functions in cells B16 and B17.
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A | B | ¢ | b | E | F | &
1 (200
2 |Florida |
3
1 Budget
5 Citr1 Citr2 Oitr3 Citrd ‘ear
b [Sales 1460 1560 1630 1320 5970
7 [C0GS RED 530 630 00 2280
8 hdargin 800 970 1000 520 3690
9 [Marketing 160 160 170 120 E10
10 [Payroll 60 G0 G0 110 230
11 |Misc #hissing #Missing #Missing  #Missing  #Missing
12 | Total Expenszes 220 220 230 230 300
13 Frofit a0 750 770 90 2790
14
15
16 ‘ear Sales 5030
17 “'ear Margin G0.04

Figure 115. Updating the EssCell Function

Tip: If the worksheet contains many EssCell functions, change Lotus 1-2-3
to manual calculation mode. This change prevents the cell retrieve
from calculating until you retrieve data or calculate the worksheet

manually.

For more information, see the Lotus 1-2-3 documentation.

Essbase returns an error message if EssCell is unsuccessful. The following
table lists messages that Essbase displays in the EssCell cell and explains
the conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double quotation
marks.

5. Close Summary.

123 without saving it.

The sample file that you used for this tutorial task already had EssCell

functions defined.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

To enter your own EssCell function into a worksheet, you do the following: Enter the
EssCell syntax in the 1-2-3 formula bar at the top of the sheet.
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Note: For more information on EssCell functions, see the Essbase Spreadsheet
Add-in online help.

Retrieving Dynamic Calculation Members

Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation
time. The Essbase application designer tags dynamic calculation members in
the database outline so that Essbase knows not to calculate those members
until a data retrieval requests them. This process is referred to as dynamic
calculation. Dynamically calculating database members benefits the Essbase
server in the following ways:

* Reduced disk usage
* Reduced database restructuring time
¢ Reduced time to back up the database

Database values that Essbase calculates dynamically take slightly longer to
retrieve in Essbase Spreadsheet Add-in because Essbase must perform
calculations before retrieving data into the worksheet. For more information on
dynamic calculation, see the Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the
spreadsheet report so that Essbase does not dynamically calculate the
database when you are creating the report. For more information on the
Navigate Without Data feature, see [“Navigating Through the Worksheet|
[Without Retrieving Data” on page 43

Because there may be a performance impact on retrieving data for dynamic
calculation members, define visual cues, or styles, for these members so that
you can identify them in Essbase Spreadsheet Add-in.

To illustrate how to use Dynamic Calculation members, use the Asymm.123
file.

To view the Asymm.123 file:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Asymm.123 file.
3. Dirill up on Actual by double-clicking the right-mouse button in cell C3.
4. In cell C3, drill down on Scenario to display all members of Scenario.
Essbase displays only the Scenario members for Qtrl.
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A B | ¢ | b | E | F | G |
1 =ales
2
3 I/‘éﬂ-‘ﬁ&;’ .l Hudgs? | Varvsesos  Vasasoe W Sossanc
4 Qtrl Qtrl Qtrl Qtrl Qtrl
5 |East Colas b292 5870 422 71890587104 b292
b Foot Beer h72h 54R0 cbh 4871734572 57Eh
7 Fruit Soda 3735 3880 -145 -3.737113402 3735
8
9 |'\West RootBeer 8278 7700 578 7.50B493506 5278
10 Cream Soda | 8043 BG40 1153 16.73439764 8043

Figure 116. Displaying Scenario Members

5. Select Essbase > Options and select the Style tab.

© 0 N o

10.
11.
12.

Note: You must be connected to the Sample Basic database to display the
Style tab. For more information on connecting to a database, see
[‘Connecting to a Database” on page 95|

In the Members group, scroll down until you see Dynamic Calculations.
Select the Dynamic Calculations check box and click the Format button.
In the Font style list, select Bold Italic.

In the Color list, select Gray.

Click OK and then select the Display tab.

In the Cells option group, click Use Styles. Click OK.

Select Essbase > Retrieve.

Essbase displays the data and applies all the visual cues, or styles, that
you set, including the newly set styles for dynamic calculation members
and the styles you set in You can tell that the columns for
Variance and Variance% are dynamically calculated because Hyperion
Essbase displays these members in gray, bold, italicized font. (Variance

and Variance% also have a red background because that style was
previously set for all members of the Scenario dimension.)
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A B ¢ | D E F G ]
1 Sales
2
3  Varasce | Vavasce % | |
4 Qtrl Qtrl Qtrl
£ |East Colas 6292 G&70 422 7189097104 (292
B Root Beer E726 G460 PBE 4871794872 5726
7 Fruit Soda 3735 3880 145 3737113402 3735
8
3 |West RootBeer g278 7700 £78 7 E0R493506 8278
10 Cream Soda G043 6390 1153 16.73439768 8043

Figure 117. Result of Retrieving Dynamic Calculation Members

Note: Occasionally, other styles you have set may override a style for
dynamic calculation members. For example, if a parent member is
also a dynamic calculation member, and if you have styles set for
both parent and dynamic calculations, the style for the parent
member overrides the style for the dynamic calculation member. In
this case, you need to remove the style for parent members in
order to see the style for dynamic calculation members. For more
information on the precedence of styles, see|“Determining the|
[Precedence of Overlapping Styles” on page 57|

13. Close the Asymm.123 file without saving it.

Specifying the Latest Time Period for Dynamic Time Series

Dynamic Time Series members are predefined database members that are used
in dynamic, to-date reporting, such as year-to-date or month-to-date values.
Dynamic Time Series members do not display as individual members in the
database outline; instead, they correspond to a generation name that uses a
key term for time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter
was created for generation 2 in the Year dimension. Generation 2 includes the
members for Qtrl, Qtr2, Qtr3, and Qtr4d. When the generation name Quarter
was created, Essbase created a Dynamic Time Series member called Q-T-D, or
quarter-to-date.

To take advantage of Dynamic Time Series in Essbase Spreadsheet Add-in,
choose the latest time period for which you want data in a to-date calculation.
The calculated value of the Dynamic Time Series member is derived when
you define the latest time period to be reported. In the Sample Basic database,
for example, the level 0 members of the Year dimension are the months of the
year: Jan, Feb, Mar, and so on. If the current month is August, and you want
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to know the sales data for the quarter up to the current month, a
quarter-to-date calculation gives you the sales data for the months of July and
August.

To illustrate the concept of Dynamic Time Series:

© Nk wDdhPRE

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Options and select the Zoom tab.

In the Zoom In option group, select Next Level.

Clear the Within Selected Group check box and click OK.

Select Essbase > Retrieve.

In cell B1, drill down (double-click) on Measures.

In cell B2, click Year.

Type Q-T-D in cell B2 and press Enter to enter a predefined Dynamic
Time Series member (Q-T-D):

A, = C O E

Product Market

Q-T-O 105522
Year 117405

Year 5526162827
Year 105527

00| = D | —

li

Figure 118. Entering a Dynamic Time Series Member into a Worksheet

10.

11.

Note: For a list of other possible Dynamic Time Series members, see the
Essbase Spreadsheet Add-in online help.

Select Essbase > Options and select the Display tab.

In the Dynamic Time Series area, select the Latest Time Period check
box.

From the list box, select May. Click OK.
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Essbase Options

Display lEu:n:um ] i ode ] Style ] GI:::I::aI]

Indentation
" Mone
" Subiterns
{* Totals

Suppress
[ #Mizzing Fows
[T Zemn Bows

[ Underscore Characters

Cellz

[ Usze Shles

[+ &djust Columns

=

[ Bepeat Member Labels

Dynamic Time Senes

R eplacement

Hhdizzing Label: |

#Mo Access Label; |

Aliazes
W Usze pliazes

[ Usze Both Member Mames and Aliases
for Row Dimenzions

Aliaz:

| Drefault j

Cluery Dezigner
[ Use Sheet Options with Buery Designer

[+ Latest Time Period T

Cancel

o |

Help

Figure 119. Specifying Latest Time Period in a Dynamic Time Series

Note: If you do not specify a latest time period, Essbase uses the first
level 0 member (Jan) as the default.

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not
supported with Dynamic Time Series members.

Essbase displays data for the Q-T-D member. The data values in the
worksheet are the aggregated values for April and May, because May is
the month you specified as the latest month in the quarter-to-date

Dynamic Time Series.
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A | B | ¢ | D | E

1 Product Market
2 Q-T-D 17573
3 Year 117405
4 Year 5520162827
5 Year 105522

Figure 120. Result of Specifying Latest Time Period in a Dynamic Time Series

13. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Note: You can also create a report like the one shown above by simply typing
the name of the Dynamic Time Series member followed by the name of
latest time period in parentheses: for example, Q-T-D (May). If you are
using free-form retrieval mode, you must enter the Dynamic Time
Series member and the latest time period in separate, adjacent cells.
You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member
Selection.

Note: For more information on Dynamic Time Series, see the Essbase
Spreadsheet Add-in online help.

Using Substitution Variables
The Essbase application designer uses substitution variables to define global

variables to represent values that are specific to Essbase. For example, Latest
can be a substitution variable representing the latest time period in a Dynamic
Time Series. Using Essbase Application Manager, the application designer sets
substitution variables and their corresponding values for a specific
application. Essbase stores these variables and their values on the Essbase
server. You can take advantage of the predefined substitution variables in
Essbase Spreadsheet Add-in during Dynamic Time Series reporting

.For example, say the application designer sets a substitution variable on the
server for the current month. The variable is called CurMnth and has a value
of August. If you use the substitution variable in the worksheet, a retrieval
returns values for August, because August is set as the current month on the
server. If, at a later date, the application designer changes the value of the
CurMnth substitution variable to October, a retrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a
substitution variable in the database you are using, you could enter a
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substitution variable directly into a worksheet. For example, you could open a
blank worksheet and type member names as follows:

A B C D E
Froduct Measures Market Scenario
S&Curhnth

ot | L) | Pl | e

5

Figure 121. Entering a Substitution Variable in a Worksheet

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an
ampersand (&).

In this example, a retrieval produces the following results:

A B C D E F
Froduct Measures Market Scenario
Ay H545

st | Gt | Pl | e

3

Figure 122. Result of Retrieval on a Substitution Variable

Essbase queries the server for the value of the substitution variable CurMnth,
which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a
template, make sure that you save the worksheet before you retrieve
data. For example, if you save the worksheet shown in Figure as a
template, each time you retrieve the template, August rather than the
substitution variable CurMnth is displayed.

Using Free-Form Reporting to Retrieve Data

So far, you have learned how to retrieve Essbase data into a worksheet
through ad hoc retrieval, Hyperion Essbase Query Designer queries, and
Member Selection operations. In addition to these retrieval methods, Essbase
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supports free-form reporting. Free-form reporting enables you to tell Essbase
specifically what you want to retrieve by simply typing data into the
worksheet. Free-form reporting is especially useful when you are familiar with
the dimensions and members in the database outline.

Essbase provides two different retrieval modes for free-form reporting:
* Advanced Interpretation
* Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode
The Essbase server contains an advanced spreadsheet interpretation engine

that scans a worksheet and interprets its content when fulfilling retrieval
requests. When you construct a report by entering names directly into a
worksheet in Advanced Interpretation retrieval mode, Essbase interprets the
member names and creates a default view that is based on the location of the
labels.

Keep in mind the following guidelines when you are working in Advanced

Interpretation mode:

* Precede all member names that consist of numbers with a single quotation
mark. For example, for Product dimension member 100, type 100 in the
worksheet.

* If you define a report that does not contain all of the database dimensions,
you may need to enter a dummy value, such as 0, in the first data cell.
Essbase overwrites this value with the contents of the database cell upon
retrieval. Be sure to use a numeric value as the dummy value.

To construct a free-form report in Advanced Interpretation retrieval mode:

1. To open a new worksheet, select File > New or click the QI button.
2. Select Essbase > Options and select the Mode tab.

3. In the Retrieval option group, select Advanced Interpretation (the default
setting) and click OK.

4. Enter member names and data as in the following illustration.

Note: If a member name consists of a number, such as 100, you must
precede the member name with a single quotation mark (for
example, "100). This rule also applies to member names with spaces
between words.
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A | B | ¢ | bp | E | F
1 |=ales East Budget
2
3 tr1 tr2
4 [100
5 |200
6 300
7 |400
8 |
g L]

Figure 123. Creating a New Free-Form Report

5. Select Essbase > Retrieve or double-click in a data cell.
Essbase retrieves data for the members you entered into the free-form
report and implements the Use Aliases option that you set in the Essbase
Options dialog box in the beginning of this chapter.
A |l B | ¢ | b | E | F |

1 |Sales East  Budget

2

3 Girl G2

4 |Calas 5870  B7RO

3 |Root Beer 5460 Ak&0

b |Cream Soda dbE0 4050

f_|Fruit Soda dJgald 4150

]

Figure 124. Retrieving Data into a Free-Form Report

Now define a free-form report that does not contain all of the dimensions
from the database. In Advanced Interpretation mode, you may need to enter a
dummy data value, such as 0, into the first Essbase data cell to tell Essbase
where the data starts in the worksheet. Be sure to use a numeric value as the
dummy value.

For example:

1.
2.

Select Essbase > FlashBack.
Delete cells A1, B1, and C1.
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3. In cell B4, type 0 in cell B4 to provide Essbase with a data cell reference

point.
A |l B | ¢ | b | E | F
1
2
3 tr1 Gt
4 [100 D_I
5 |200
6 [300
7 [400
f

Figure 125. Defining a Free-Form Report Without All Dimensions

4. Select Essbase > Retrieve.

Essbase adds the dimensions that were omitted from the free-form report
to the worksheet and retrieves data.

A | B | ¢ [ b | E | F
1
2
3 Measures Market Scenario
4 1 Chtr2
5 [Colas 045 7872
6 |Foot Beer b1 F030
§ |Cream Soda 58249 B/BY
8 |Fruit Soda S005 5436
9

Figure 126. Retrieval in a Free-Form Report Without all Dimensions

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Free-Form Mode
Similar to Advanced Interpretation mode, Free-Form mode enables you to

enter member names into any location in a worksheet and then interprets the
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contents of the worksheet when fulfilling the retrieval request. In addition,
with Free-Form mode, you can use Essbase report script commands to retrieve
data into a worksheet.

Report script commands are most useful for defining member references that
can bring back the most current member information dynamically. For
example, if you need to create a report that shows every product, including
the products added since the last retrieval, standard retrieval mode reflects
changes only when you zoom in on the product. If you use the report script
command <IDESCENDANTS, Essbase retrieves all descendants of a specified
member, including the specified member. For more information on the syntax
of report script commands and on guidelines for developing reports, see the
Technical Reference in the docs directory and the Database Administrator’s Guide

Keep in mind the following guidelines when working in Free-Form retrieval
mode:

* You must precede all member names that consist of numbers with a single
quotation mark. For example, for the Product dimension member 100, you
need to type 100 in the worksheet.

* You cannot cancel a retrieve in Free-Form mode.
* You cannot apply Essbase styles in Free-Form mode.
* Essbase removes blank rows and columns on any retrieval action.

* When you are in Free-Form mode, an Auto Sort Rows option is enabled in
the Display tab of the Essbase Options dialog box. If you select this feature,
Essbase retrieves data in symmetric rows. The rows are sorted according to
the order specified in the database outline.

* Not all Formula Preservation and Modes options (Essbase Options dialog
box, Mode tab) are available in Free-Form mode.

* To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb))
in the same cell. You need to type the Dynamic Time Series member, Q-T-D
in one cell, and the latest time period within parentheses, (Feb), in a
separate, adjacent cell.

To construct a free-form report in Free-Form retrieval mode:

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Options and select the Mode tab.

In the Retrieval option group, select Free Form.

Select the Display tab.

In the Cells option group, select Auto Sort Rows. Click OK.

o0 ks whPRE

Enter the member names into the worksheet as shown in Figure :
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A |l B | ¢ | b | E | F |

1 |Product COGS
2 |Jan
3 |East
4 |Budget
5 [Actual
6 |

-
Fi

Figure 127. Typing Member Names In a Free-Form Report

7. Select Essbase > Retrieve.

Essbase retrieves data for the members and creates a default view
according to the location of the labels. Note that three members were
pivoted from row groups to column groups.

A | B ] ¢ | b | E | F |
1 Froduct COGS  Jan East
2 |Budget I EEBD!
3 |Actual 3007
4
5

Figure 128. Result of Retrieving in Free-Form Retrieval Mode

8. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Now create a report by entering member names and a report script command:

1. To open a new worksheet, select File > New or click the QI button.
2. Enter the member names into the blank worksheet as shown in Figure m

Figure 129. Typing Member Names in a Free-Form Report

3. In cell A3, type <IDESCENDANTS Product. Press Enter.
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A . B | © | D
1 Actual males East
2 Jan Feb Mar
3 [<IDESCENDANTS _|
4
5

Figure 130. Typing a Report Script Command in a Free-Form Report

4. Select Essbase > Retrieve.

Essbase retrieves data into the worksheet for all descendants of Product

and for the members you entered in the worksheet.

A | B | ¢ | b | E]|] F

1 Actual  Sales East

2 Jan Feh Mlar

3 [Cola 1812 1754 1805
4 [Diet Cola I EIIIEI! 206 214
5 |Caffeine Free Cola 43 101 107
b6 Colas 2105 2061 2120
£ [O1d Fashioned b47 (3] ata] G772
8 [Diet Hoot Beer 310 310 312
9 |Sasparilla #lissing #dissing #lissing
10 |Birch Beer 396 953 923
11 Foot Beer 1853 1966 1907
12 |Dark Creamn 999 1012 1026

Figure 131. Result of a Retrieve with a Report Script Command

Note: When Essbase completes the retrieval, the report script command is
overwritten by the data it returns. You can use FlashBack to restore

the previous view in Free-Form mode.

5. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Using Attributes in Free-Form Reporting

Essbase enables you to retrieve data selectively by specifying attributes that

are associated with a base dimension. For example, in the Sample Basic
database, the Product base dimension is associated with attributes such as
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packaging and size. You can enter an attribute name into the worksheet to
retrieve data that is associated with that attribute.

To use attributes in a free-form report:

1. To open a new worksheet, select File > New or click the QI button.
2. Enter member names as shown in the Figure m
Caffeinated is an attribute dimension associated with the Product base
dimension. Bottle is a level 0 member of the Pkg_Type attribute

dimension. The Pkg_Type dimension is associated with the Product base
dimension. A level 0 member is the lowest level member in a dimension.

A [ B [ ¢ | D
| 1 |Caffeinated Battle Prafit Qtrt

| 2 |
14 [4[» [»i]sSheet1 { sheetz f shesta /| 4|

Figure 132. Using Attributes in Free-Form Reports

3. Click in any empty cell and select Essbase > Retrieve or double-click in an
empty data cell.

Essbase retrieves information on profits for the first quarter of the year for
all members of the Product base dimension that are associated with both
the level 0 attribute members of the Caffeinated attribute dimension
(Caffeinated_True and Caffeinated_False) and the level 0 member Bottle of
the Pkg_Type attribute dimension. The results should display as shown
below:

A |_B | c|DJE]F [T
1 Caffeinated Bottle Profit Otrl Eas
&

Figure 133. Result of Using Attributes in Free-Form Reports

2 Scenariol 2604!
3

14 4[» [#]\Sheet1 / sheetz £5]4]

4. You can drill down to data on the level 0 attribute members of the
Caffeinated attribute dimension. The results should display as shown
below:

A [ B JcC[DJTEJFI[T
|1 Bottle Profit Qtrl East =3
Caffeinated_True  Scenario 142

?Caﬁeinated_False Scenatio 2462' _l -

44> [biSheet1 {Sheetz  Sheet: | 4| | Il

[gul

Figure 134. Drilling Down on Attributes in Free-Form Reports
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5. To drill down further for data on profits for the first quarter for all

members of the East base dimension, double-click on cell E1. The results
should display as shown below:

Figure 135. Result of Drilling Down on East

Entering Generation and Level Names
In addition to entering database member names into a free-form report, you

can enter generation or level names directly into a worksheet to retrieve
specific members. The Essbase application designer defines generation and
level names for database dimensions in the database outline. You have two

A B ¢c | Db |E| F |
1 1 Bottle Profit Scenario
2 Mew York Caffeinated True Year -2050
3 Cafteinated False Year &/54
4 Caffeinated Wear 4704
5 Massachusetts Caffeinated True  Year 30
b Caffeinated False Year 1577
7 Caffeinated Year 1607
8 Flarida Caffeinated True Year 1727
9 Caffeinated _False Year 934
10 Caffeinated Year  ZbbT
11 |Connecticut Caffeinated True Year 1134
12 Caffeinated False Year 742
13 Caffeinated Year 1876
14 |Mew Hampshire Caffeinated True Year -84
15 Caffeinated False Year 842
16 Caffeinated Year 768
17 East Caffeinated True Year 757
18 Caffeinated False Year 10543
19 Caffeinated Year 11606

options for discovering what generation and level names are defined in the

database:

* View generation and level names in the Essbase Member Selection dialog
box or through Essbase Query Designer.

* Contact the Essbase application designer to see what generation and level
names are defined in the database outline.

To enter generation and level names directly into a free-form report:
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To open a new worksheet, select File > New or click the QI button.

1.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation. Click OK.
4. Enter member names as shown in Figure
A | B [ ¢c | b [ E | F
1] males  Budget West fear
2
3
& |
3
6 |

Figure 136. Entering Member Names in a Free-Form Report

5. Enter a generation name as shown in Figure m

Family is a generation name in the Product dimension. The name is
already defined in the Sample Basic database.

A | B | ¢ | b | E | F

=ales  Budget Ywest ear

Family

T | ke | ot | Pl | e
B

b

Figure 137. Entering a Generation Name in a Free-Form Report

6. Select Essbase > Retrieve.

Essbase retrieves data for the member and generation names that you
entered. The Family generation name expands to its individual members.
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A | B | ¢ [ b | E [ F |

1 oales Budget  WWest fear
2 [Colas 34330

3 [Foot Beer 31810

4 |Cream Soda a0480

5 |Fruit Soda 22730

6 [Diet Drinks 35650

Fi

Figure 138. Result of Free-Form Retrieval with Generation Name

7. Change Year to a level name (Lev0,Year) as shown in the following

illustration.
A | B | C | D E F

1 males Budget  “WWest ILevd Yearl
2 |Colas 34530
3 |Foot Beer 31810
4 [Cream Soda 30450
5 [Fruit Soda 22730
6 |Diet Drinks 35R90
7

Figure 139. Entering a Level Name in a Free-Form Report

Note: Be sure not to insert a space between the comma after 0 and the
word Year. Generation and level names that are entered directly into
a worksheet must be precise.

8. Select Essbase > Retrieve.

Essbase retrieves data for the level 0 members of the Year dimension,
which are the individual months (Jan, Feb, Mar, and so forth).
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A | B | ¢ | b | E | F
1 males Budget  West
2 |Jan Colas 20860
3 Foot Beer 2540
4 Cream Soda 2220
5 Fruit Soda 1840
b Diet Drinks 2810
¥ |Feh Colas 2820
(i} oot Beer 2560
9 Cream Soda 2310
10 Fruit Soda 1840
11 Diet Drinks 2900
12 |Mar Colas 2820

Figure 140. Result of Free-Form Retrieval with Level Name

9. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to a cell in a Essbase database. The file, note, or Web
resource (indicated by a URL, or Uniform Resource Locator) can then be
retrieved by the Essbase Spreadsheet Add-in users who have access to the
database.

Note: If your organization has licensed and implemented Essbase Partitioning
option, you can also access linked partitions from cells in Essbase
Spreadsheet Add-in. For more information on linked partitions, see
[“Accessing Linked Partitions” on page 165}

This section describes the following procedures:

* [’Linking a File to a Data Cell” on page 147]

* [‘Linking a Cell Note to a Data Cell” on page 151

* ['Linking a URL to a Data Cell” on page 153|

* ["Accessing and Editing Linked Reporting Objects” on page 155

Note: For additional information on using linked reporting objects, see the
Essbase Spreadsheet Add-in online help.
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Linking a File to a Data Cell

With the linked reporting objects feature, you can link an external file to a

data cell in Essbase Spreadsheet Add-in. Essbase stores the file on the Essbase
server. Users who have access to the database can then retrieve the file and

view the data contained in the cell.

The following example uses the Asymm.123 sample worksheet with data from

the Sample Basic database. It links a sample file, Budasmp.txt, to a cell

containing the Budget figure. Budasmp.txt details the budgetary assumptions

for the current year.

Follow these steps to link a file to a data cell:
1. Select File > Open.

2. From the \essbase\client\sample directory, open the Asymm.123 file.
3. Make sure that you are connected to the Sample Basic database. If you

are not connected, see [“Connecting to a Database” on page 95|
4. Select cell D5.

Note: You can link objects only to data cells, not to cells containing

member names.

A B | ¢ | b | E | F [ G|
1 |Sales
2
3 Acivad | Sudpst | Suagst | Suoget
4 Otrl Otr? Otr3 Otrd
b |Esst Colas g29z[_6760] 7300 5570
b Foot Beer 5726 BRSO BEOOD 57E0
7 Fruit Soda 3735 4150 4350 3850
8
9 |'est FootBeer 8278 7970 @320 FAE0
10 Cream Soda 8043 77200 @300 7570
11

Figure 141. Selecting a Data Cell for Linking an External File

5. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.
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Linked Objects Browzer -- Aspen:Sample:Basic

Member Combination: IﬂtlZ.Sd&s,Enlas.EastBudget

Linked Objects:

Object Type II]hiactDmi:lim |FieNane |Ereatedﬂy Last Modified
ptach. |  Edi. | Viewlounch|  Delete Help Dl

Figure 142. Linking a File

6. In the Linked Objects Browser dialog box, click the Attach button.
Essbase displays the Attach Linked Object dialog box.
7. Under the Attachment Type option group, select File.
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Attach Linked Object

tember Combination: IE!trE,S alez Colaz.E azt Budget

Attachment Type
™ Cell note

.........

File 1 arne:

File Dezcription:

Ok

Canicel

Help

Browsze. .. |

[—
=

Figure 143. Linking a File to a Data Cell

8. Click the Browse button (next to the File Name text box).

Essbase displays the Browse Files dialog box.

9. Go to the \Esshase\client\sample directory and select the Budasmp.txt

file.
10. Click Open.

11. Under File Description, enter a brief description for the file as indicated

in Figure
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Attach Linked Object ]|

ember Combination: IE! tr2 Salesz Colaz E azt Budget

Attachment Type 0K

™ Cell note

o Elles Cancel

i URL Help
File M arme:

CAESSBASEMCLIEMTSSAMPLENBudazmp.txt Browsze... |

File Diezcription:

Budgetam azzumption report ;I

[

Figure 144. Selecting and Describing a File to Link

Note: Entering text in the File Description text box is optional.
12. Click OK to close the dialog box and link the file to the cell.

Essbase copies the file to the server and establishes a link to the current
data cell.

13. Click Close to close the Linked Objects Browser dialog box.

14. Do not close the Asymm.123 file. You use it in the next tutorial task.

To recognize cells that have linked reporting objects attached to them, you
may want to apply a visual cue, or style, to the cells.

To apply styles:

Select Essbase > Options and select the Style tab.

In the Data Cells area, select Linked Objects.

Click Format.

In the Font style list box, select Italic.

In the Color list box, select Purple. Click OK.

Select the Display tab.

In the Cells option group, select the Use Styles box. Click OK.

© N Ok wDNE

Select Essbase > Retrieve to refresh the worksheet and apply the styles.
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Cell D5 (the cell you just attached the linked file to) is now displayed in

purple, italic font. Essbase also refreshes the worksheet with the other

options set in the Essbase Options dialog box.

Figure 145. Result of Applying a Style to a Linked Reporting Object Cell

9. Leave the Asymm.123 file open for the next tutorial task.

Linking a Cell Note to a Data Cell

In addition to linking external files to a data cell in Essbase Spreadsheet

f B I - I
1 H
2
3
4 Qtrl Qtr2
5 [East |[CRlESN (292 EHLT 7300 E570
b Root Beer 5726 5G50 EG0D E780
7 Fruit Soda 3735 4150 4350 3850
8
9 est |RootBeer 5278 7970 g320 7820
10 Cream Soda 8043 7720 §300 7570

Add-in, you can also link individual cell notes that contain information on

particular data cells. Cell notes can have no more than 599 characters. If you
need to link information to a data cell that is longer than 599 characters, you
need to create and save an external file and then link the file to the data cell.

To link a cell note to a data cell:
1. In the Asymm.123 file, select cell C5.

Note: You can link objects only to data cells, not to cells containing

member names.
2. Select Essbase > Linked Objects.

Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select Cell Note.

5. In the Cell Note box, type the note as indicated in the following

illustration:
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152

Attach Linked Object

Member Combination: IE! tr1 Sales. Colas E ast Actual

—Attach

f;" q

LCell Mote:

Thiz nurmber needs to be updated by the Eastern Sales Manager. ﬂ

[

Ok

Cancel

Help

Figure 146. Creating a Cell Note to Link

6. To close the dialog box and link the cell note, click OK.

Essbase copies the note to the server and establishes a link to the current

data cell.

7. To close the Linked Objects Browser dialog box, click Close.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style you

defined for linked objects.

Now Essbase displays two data cells (C5 and D5) in purple, italic font to

represent a cell that contains a linked reporting object.

Figure 147. Result of Creating a Linked Cell Note

9. Leave the Asymm.123 file open for the next tutorial task.
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1 H
2
3 Actual Budget Budget Budget
4 Qtrl Qtr2 Qtr3 Qtrd
5 [East  |Colacy PR PR 7300 E570
6 Root Beer YR T | EGO0 5780
7 Fruit Soda 3735 EE 4350 3850
g
9 West  |RoouBcco 8278 7970 8320 7820
10 Cream Soda 8043 7720 8300 7570



Linking a URL to a Data Cell

A URL is an address string that identifies resources on the World Wide Web,
such as documents, images, and downloadable files. With the linked reporting

objects feature, you can link a URL to a data cell so that users who have

access to the database can link directly to the specified URL. When you access

the cell from Essbase Spreadsheet Add-in, your default Web browser opens

and displays the specified URL.

Note: For more information on URL syntax, see the Essbase Spreadsheet

Add-in online help.

If you have a Web browser and Internet access, follow these steps to link a

data cell to the Hyperion Web site:
1. In the Asymm.123 file, select cell E5.

Note: You can link objects only to data cells, not to cells containing

member names.

| A B c | b E e |
1
2
3 At Budget Budget Budget
4 Qtrl Qtr2 Qtr3 Qtrd
t [East  [COlEsH R H 7300 EE70
6 Root Beer | 5726 BE50 5600 5780
7 Fruit Soda 3738 4150 4350 3850
8
9 [West  |ocuBceol 8278 7470 8320 7820
10 Cream Soda 8043 7720 8300 7570
Figure 148. Selecting a Data Cell for Linking to a URL
2. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select URL.
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Attach Linked Object

ember Combination: IE! tr3.5alesz Colaz E azt Budget

Attachment Type
™ Cell note

Location:

Ok

Cancel

Help

LIRL Dezcription:

=
=

Figure 149. Linking a URL to a Data Cell

5. Enter a URL in the Location text box and a brief description in the URL

Description text box, as indicated in Figure
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Attach Linked Dbject ]|

tember Combination: IE!trE,S alez Colaz.E azt Budget

Attachment Type 0k,

™ Cell note

© File Cancel

= 1AL Help
Location:

hittp: A v hoperion. com

LIRL Description:

Hyperion Solutions' home page ;I

[

Figure 150. Entering and Describing a URL to Link

Note: Entering text in the URL Description text box is optional. The text
field for entering the URL location is limited to 512 characters. The
text field for entering the URL description is limited to 80
characters.

6. To close the dialog box and link the URL to the cell, click OK.

Essbase copies the URL string to the server and establishes a link to the
current data cell.

Note: The syntax for the URL is not checked at creation time; Essbase
checks the syntax when the user accesses the URL from the
worksheet. The default Web browser checks for the existence (or
validity) of the URL.

7. To close the Linked Objects Browser dialog box, click Close.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style that
you defined for linked objects.

9. Leave the Asymm.123 file open for the next tutorial task.
Now that you have learned to create linked reporting objects, you are ready to
learn how to access them from Essbase Spreadsheet Add-in.

Accessing and Editing Linked Reporting Objects

You have two options for accessing and editing a linked reporting object that
is attached to a data cell:
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* Select the cell (as identified by the style applied to it) and select Essbase >
Linked Objects.

* Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing,
double-clicking behavior changes for retrieving data and performing
drill actions. For more information on these changes, see the Essbase
Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in
the previous sections by using the Essbase menu item instead of the
double-clicking action.

Accessing a Linked File
Sometimes you want to check an external file that is linked to a data cell.

To access the external file that you previously linked to a data cell:

1. In the Asymm.123 file, select cell D5.

2. Select Essbase > Linked Objects.

3. In the Linked Objects Browser dialog box, select the Budasmp.txt file.

Linked Objects Browzer -- Aszpen:Sample:Basic

Member Combination: IlltlZ,Sd&s,Enlas,East,Budget
Linked Objects

Object Type Object Descphion Fie Mame Created By Laszt Maodified

Budgetany assumplion repot pdasmp st Sys Mon Oct 27 14

[« | 2

atach. |  Edt. | Viewleunch| Deete Hep | Cose |

Figure 151. Accessing a Linked External File

4. To view the linked file, click View/Launch.
The Budasmp.txt file is opened from the source application.
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a Budazmp.txt - Notepad [_ (O] ] I

File Edit Search Help
The Beverage Company ;I

1998 Budget Assumptions
The following factors were used to estimate our 1998 Corporate Budget:

1) Sales increases will be 5% in Large Markets, due to market maturity
2) Sales increases will be 16% in Small Harkets, due to our focused advertising
3) Expenses will be reduced by ?% across the entire company

We are faced with the challenge of continuing to grow our business, in spite
of increasing competition. We will have to seek out and implement as many cost
saving measures as possible. =

] ol

Figure 152. Viewing the Contents of a Linked External File

Note: Edit the contents of a file in the source application. After the edits
are made and the file saved, you can re-attach the edited file by
clicking the Edit button in the Linked Objects Browser dialog box.
Essbase displays the Re-attach Linked Object dialog box, which you
can use to re-attach, or relink, the edited file to the data cell. For
more information, see the Essbase Spreadsheet Add-in online help.

5. Close the Budasmp.txt file and click Close to close the Linked Objects
Browser dialog box.

6. Leave the Asymm.123 file open for the next task.

Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

To access and edit the cell note that you previously created:
1. In the Asymm.123 file, select cell C5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is
linked to the selected data cell.

3. In the Linked Objects Browser dialog box, select the cell note.
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Linked Objects Browser -— Poplar-Sample-Basic

Member Combination: |Dtr1 Sales Colas F ast Actua

Linked Objects:

Object Type Object Descnption Linked Oiyect and Object Created By |L.
Cell Mote Thi:::: ru.u]'!:ler_nagds tube_ ]

[« | i

Attach. Edit. View/1 aunch Delete Help | LCloze ‘

Figure 153. Accessing a Linked Cell Note

4. To edit the contents of the cell note, click Edit.

Essbase displays the Edit Cell Note dialog box with the selected cell note
displayed.

Edit Cell Hote

Member Combination: Q1.5 ales,100,E ast Actual

Cell Maote:

Thiz number needs
Eaztern Sales

o be updated by the

B oK,

Cancel

Help

[

Figure 154. Editing the Contents of a Linked Cell Note
Note: If you simply want to view the contents of the cell note, click the

View /Launch button instead of the Edit button in the Linked
Objects Browser dialog box.

158  Spreadsheet Add-in User’s Guide for 1-2-3




5.

Edit the contents of the cell note as indicated in the following illustration:

Edit Cell Note =]

tember Cormbination: IE!tr1 .S ales, 100.E ast Actual

Cell Haote:

Thig number was updated on 8/26/97. ;I k.
Cancel
Help

[~

Figure 155. Result of Editing Cell Note Contents

6.

7.
8.

Accessing a Linked URL

Click OK to close the Edit Cell Note dialog box and save the edits you
made to the note.

Essbase saves the edits to the cell note on the server.
To close the Linked Objects Browser dialog box, click Close.
Leave the Asymm. 123 file open for the next tutorial task.

If you followed the steps in [’Linking a URL to a Data Cell” on page 153 you
can access and edit the URL that you created.

To access the URL:

1.
2.

In the Asymm. 123 file, select cell E5.
Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to
the selected data cell.

In the Linked Objects Browser dialog box, select the URL.
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Linked Objects Browzer -— PoplarSample:Basic

Member Combination: IﬂtlE,Sd&s,Enlas.EastBudget
Linked Objects:

Object Type Object Descphion Linked Olyect and Olyect Created By (L.

Hyperion Solubons’ home ntip vy hypenon. com

[« | i

ftach. |  Edt. | Viewlamch| Delete Hep | Close |

Figure 156. Accessing a Linked URL

4. To view the linked URL, click View/Launch.

Essbase checks the syntax of the URL. If there are syntax errors, Essbase
displays an error message. If the URL syntax is correct, the default Web
browser launches and connects to the specified site. In this case, the syntax
for the URL is correct, so the default Web browser launches and connects
to the Hyperion Web site.
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File Edit “iew Go Communicator Help
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Back Fonward  Reload Home Search  Metscape Frirt Security Stop
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Boluiions » Corporats » Neéws - Evants - Partnars - Support and Sarvices - Software Downloads

& Year 2000 Worldwide Search ®Contact Us Sie Map
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Hyperionr malyze ﬂ #22
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FAET 50
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See the Future First™
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Applicaion
integration
made easy

-

Careers at Hyperian Warldwide

Discounts offered on Wired for OLAP softvware I Select an Intemnational Location j @
and services in Morth America.

Products
Hyperion Essbase Spreadshest Add-in End User CET nowy

zvailzble! |Se|eu:t a Product ﬂ

o)

| (== |&pplet Home Page running = e S SR EE P v

Figure 157. Viewing a Linked URL

5. Close the Web browser.

To edit the URL:

1. In the Linked Objects Browser dialog box, select the URL.

2. To edit the linked URL, click Edit.

Essbase displays the Edit URL dialog box with the selected URL

displayed.
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Edit URL E

Member Combination: IIJ tr3.5ales_Colas.E ast_ Budget

Location:
I hittp: S, hyperion. com

URL Description:

Hyperion Solutions' home page -
Cancel

Figure 158. Preparing to Edit the Contents of a Linked URL

3. Edit the URL location and description as show in the following
illustration:

Edit URL E

Member Combination: I 3tr3.5ales Colas E ast Budget

Location:

Ihttp: H v hpperion, comysolutions. cfm

URL Description:

Hyperion Solutions’ home page -
Cancel

Figure 159. Editing the Contents of a Linked URL

4. To close the Edit URL dialog box and save the edits that you made, click
OK.
Essbase saves the edits to the URL on the server.

5. To view the new URL, click View/Launch.
The Web browser launches and connects to the new URL.
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Figure 160. Viewing an Edited URL

Close the Web browser.

7. To close the Linked Objects Browser dialog box, click Close.
8. Close the Asymm.123 file without saving it.

Connecting to Multiple Databases

Essbase supports simultaneous access to multiple databases. The databases
can be in different applications and can be stored on different servers. In
Lotus 1-2-3, you can open multiple worksheets, each of which can be
connected to a different database. An individual worksheet can access only
one database at a time. Use the Connect command from the Essbase menu to
switch the connection between databases.
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Note: Depending on the status of production applications at your site, you
may not have access to additional applications or databases. Check
with the Essbase system administrator if you need access to other
applications.

For this tutorial, you do not need to connect to another database.

Note: Tasks that you should not perform as part of the tutorial are shown in
light colored boxes.

To access multiple databases, use the following procedure:

1. Select Essbase > Connect.

2. In the Essbase System Login dialog box, select the server you want to access
from the Server list box (or type in the name of the server).

3. Press Tab to move to the Username text box and type your username.

4. Press Tab to move to the Password text box and type your password.

5. Click OK to connect to the server.
When the server connection is complete, a list of available application and
database pairs is displayed in the Application/Database list.

6. Double-click the Application/Database pair that you want to connect to in the
Application/Database list. Alternatively, you can select the Application/Database
pair and click OK.

If the application is not already running, Essbase automatically starts it. There
may be a brief pause as the application loads; the time required to start an
application depends on number of databases, the sizes of the databases, and the
sizes of the indexes of the databases contained within the application.

7. Open a new worksheet and repeat the steps to connect to additional databases.
You can open one database at a time per worksheet.

For information on connecting to multiple databases from Essbase Query

Designer, refer to

Viewing Active Database Connections

If you frequently connect to multiple databases, you may need to check the
active database for each worksheet. There are two ways to view the database
connection status:

* The Style tab of the Essbase Options dialog box contains a Connection
Information text box. This box displays connection information for the
active worksheet.

* The Essbase Disconnect dialog box lists all active worksheets and their
connection information. This dialog box also enables you to disconnect one
or more worksheets from their respective databases.

Spreadsheet Add-in User’s Guide for 1-2-3



Accessing Linked Partitions

Linked partitions are part of the Essbase Partitioning product. They provide the
ability to link Essbase databases that contain different dimensions without
losing access to all dimensions of both databases. If your organization has
purchased and implemented the partitioning product, you can take advantage
of its powerful capabilities. The Database Administrator’s Guide describes how
to design and implement a linked partition. The Essbase application designer
usually sets up partitioning.

Note: The Partitioning product also enables the Essbase application designer
to set up transparent or remote partitions. For more information on
partitioning, see the Database Administrator’s Guide.

You can set visual cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. You have
two options for accessing a linked partition from a data cell in Essbase
Spreadsheet Add-in:

* Select the cell and select Essbase > Linked Objects.
* Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Essbase Spreadsheet Add-in online
help.

When you select Essbase > Linked Objects from a linked partition cell,
Hyperion Essbase completes the following actions:

* Essbase displays the Linked Objects Browser dialog box, which contains a
list of possible partitions to access. From this dialog box, select the partition
to connect to.

Note: The Linked Objects Browser dialog box may also contain a list of
linked reporting objects, such as cell notes and external files. For
more information, see [“Using Linked Reporting Objects” on page|

* After you select a partition, Essbase creates a new worksheet that contains
corresponding members and dimensions for the cell in the linked partition.

Note: Essbase does not preserve formulas across partitions.
* Essbase retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more
information on the new worksheet.
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Note: The Sample Basic database that you are using for this tutorial does not
contain a linked partition. Tasks that you should rnot perform as part of
the tutorial are shown in light colored boxes.

To access a linked partition in Essbase Spreadsheet Add-in if the Essbase application
designer has a linked partition set up:

1. Locate a linked object cell, as indicated by the style applied to the cell.

2. Select Essbase > Linked Objects to open the Linked Objects Browser dialog box.
Note: Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box to enable double-clicking to view linked objects.

3. Select the partition that you want to connect to and click View/Launch.

Linked Objects Browser — Aspen:Sample-Basic

tember Combinaton: Ilth,Sdes,Edas,EastBudget
Linked Objects:

Object Type Object Description File Mame Crzated By Lazt Modified
Linked Partition wied Dec 31 16

<] | 2l

mach. | Edi. | Viewlamch|  Delete Hep |  Close |

Figure 161. Linked Objects Browser Dialog Box, Linked Partition

Essbase creates a new worksheet that contains the dimensions and members for the cell in the linked
partition.

Note: You need to have the proper privileges to access a linked partition. If
your user account and password match the account information for the
linked partition, Essbase establishes a connection with the linked
partition. Otherwise, Essbase displays the Essbase System Login dialog
box for you to enter the user account and password information
manually.
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Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve data into the worksheet, you
can use Essbase Spreadsheet Add-in to change values, enter formulas, and
format data. Essbase is also designed to permit multiuser, concurrent database
access and update. Depending on your security privileges, you may be able to
modify all data values or a certain subset of values. To recognize cells to
which you have read/write access, apply a visual cue, or style, to the cells.
For more information, see [“Applying Styles to Data Cells” on page 56 To
update data from a worksheet, you must lock the database area that contains
the values that you want to change. Locking prohibits other users from
changing the data that you want to update. Other users can retrieve locked
data but cannot lock or change the data. You have exclusive update rights to
that area.

Note: You cannot update attribute-related data on the server because attribute
data is always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:

* The Retrieve & Lock command retrieves data into the worksheet while
locking the corresponding data area on the server. When you perform a
subsequent retrieval, Essbase automatically unlocks the previous data
values.

Note: The Retrieve & Lock command is not supported with Dynamic Time
Series members.

¢ The Lock command locks information that you have already retrieved.
When you perform a subsequent retrieval, Essbase automatically unlocks
the previous data values.

¢ The Update Mode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send
command on the Essbase menu. After updating the server, the Send command
automatically unlocks data (unless you are in Update Mode). You must
disable Update Mode to stop locking blocks automatically.

You can unlock data blocks in two ways:
* The Unlock command unlocks all blocks that you have locked.

* The server automatically unlocks data blocks that have been locked for the
maximum time allowed as defined by the Essbase system administrator.
Automatic unlock ensures that blocks are not locked for extended periods
of time.
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P&1.123, a sample Lotus 1-2-3 file installed as part of the default Essbase
installation, illustrates how to update data on the server.

To view the P&1.123 worksheet:
1. Select File > Open.
2. From the \Esshase\client\sample directory, open the P&1.123 file.
3. Select Essbase > Retrieve & Lock.
Essbase retrieves data and locks the appropriate area of the database.

A | B | € [ b [ EJ] F | 6 [ H
Market: Central The Beverage Company
Product: 200 Flanning Dept.

Scenario: Budget

Qtrl % Sales

Misc flissing BMissing #Missing 0 0.00
Payroll 210 210 210 §30 0.a7
Marketing 300 310 320 930 11.05
Total Expenses 510 520 530 1560 158.53
COGS 1170 1180 1200 3550 4216
Sales 2740 2820 2860 8420 100.00
Margin 1570 1640 1660 4870 57.84
Profit 1060 1120 1130 3310 38.31

Ratio Analysis
Markup 57.3%  5B2% 558.0% 57.8%
18 |Marketing % 10.9% 11.0% 11.2% 11.0%

e [ e | e | e | | i | o |

Figure 162. P&L Worksheet After Retrieve & Lock

4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.
Essbase changes the affected data values.
5. Select Essbase > Send to update the server with the new values.

Essbase updates the server and unlocks the data blocks.
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A | B C | F ] G | H
|1 Market: Central The Beverage Company
| 2 | Product: 200 Planning Dept.
| 3 | Scenario: Budget

4
E—
6 |Misc 5 10 10 25 0.30
7 |Payrall 200 200 GO0 0.07
8 |Marketing 350 350 1050 12.47
9 Total Expenges 5255 560 560 1675 19.589
10

11 [COGS 1170 1180 1200 3550 4216
12 [Sales 2740 2520 2860 G420 100.00
13 Margin 1570 1640 1660 4570 57.84
14 Profit 1015 1080 1100 3195 37.95
15

16 |Ratio Analysis

17 [Markup a7 3% 58.2% 558.0% 57.8%

18 [Marketing % 12.8% 12.4% 12.2% 12.5%

Figure 163. P&L Worksheet After Sending New Values to the Server

6. Close P&1.123 without saving it.

Note: Essbase provides a worksheet update logging facility that tracks and
logs all data updates sent from Essbase Spreadsheet Add-in to the
server. The Essbase system administrator enables this facility for extra
protection against data loss. For more information, see the Database
Administrator’s Guide or contact the Essbase system administrator.

Calculating a Database

Sending updated data to the server does not automatically recalculate the
database. If you have the appropriate security privileges to perform database
calculations, you can calculate the database from Essbase Spreadsheet Add-in
with the Calculation command. For this tutorial, you will not actually
calculate the Sample Basic database. For more information on Essbase
calculations, see the Database Administrator’s Guide.

CAUTION:
Do not perform any calculation operations for this tutorial.

When you select Essbase > Calculation, Essbase displays the Essbase
Calculation dialog box.
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Essbase Calculation [ %] I
Connection Infarmation
(Aspen: S ample-»B asic

CalcRel

Calchat ﬂl
Calcine

Calclanc

CalcDes
CalclDes il
Stop Calc |

Select Calc Script:

— Database State

Mo data values have been changed
since the last calculation.

Figure 164. Essbase Calculation Dialog Box

The Essbase Calculation dialog box contains the following items:

* The Connection Information text box displays the active database
connection.

* The Select Calc Script list box contains the server-based calculation scripts
to which you have access.

¢ The Database State text box indicates the current calculation state of the
database. The following states are possible:

— Calculating—indicates that a calculation is currently running on the
database.

— Data values have been modified since the last calculation—indicates that
data values have changed since the database was last calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.

— No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or a calculation of any subset of the database.

CAUTION:

If the last calculation was performed on a subset of the data, the entire
database may not have been calculated since values last changed. To
ensure that the results of calculations are up-to-date, you may want to
run a calculation of the entire database. For more information, contact
the Essbase system administrator.
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Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applications is to send
worksheets to various functional areas of an organization. After the
worksheets have been distributed, the recipients can review the contents,
make modifications, and send updates back to the distributor. Using the
Essbase Cascade feature, you can create multiple worksheet files based on a
single database view. You can specify at what level of detail you want to
replicate the worksheets to tailor the information to each recipient’s needs.

The Sample Basic database contains data for beverage products sold in
different states across the U.S. For example, assume that you want all product
managers to review and respond to a proposed budget and to return their
changes to the finance department. We must create a worksheet for each
combination of budget and P&L data to distribute to the product managers
for their respective products.

To create this set of worksheets:
1. Select File > Open.

2. From the \Essbase\client\sample directory, open the P&I1.123 file. This
file contains the data that you need to replicate for each worksheet.

3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set
for this file in the Essbase Options dialog box. In this example, product
200 changes to Root Beer, which is its preassigned alias.

4. Select Central (in cell B1) and Root Beer (in cell B2) as the members to be
represented in the resulting worksheets.

5. Select Essbase > Cascade.
Essbase displays the Essbase Cascade Options dialog box.
6. Click the Cascade Information tab.

The Cascade Information page contains the list of members that you
selected and the options for specifying the level at which the selected
members are retrieved into the cascaded worksheets.

Note: For more information on each option, see the Essbase Spreadsheet
Add-in online help.

7. Select Central in the Member list box, and select Same level in the
Choose Level for Selected Member option group.

8. Select Root Beer in the Member list box, and select Next level (the
default setting).
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Eszsbase Cascade Options |

Cascade [nformation I D estination Dptiu:unsl Farrnat Dptiu:unsl

— Cazcade Or;
Member: Chooze Level for
Selected Member:

Central Same level

iHoot Beer et level & Next Level
Al Levels
" Bottom Level
™ Sibling Lewvel
™ Same Level

i~ Same Generation

i~ Fomulaz

k. I Cancel Help

Figure 165. Cascade Information Tab

10.

11.

12.

The replicated, or cascaded, spreadsheet reports now provide data for
members at the same level as Central (East, West, and South) and for
members at the level below Root Beer (Old Fashioned, Diet Root Beer,
Sarsaparilla, and Birch Beer).

Click the Destination Options tab.

In the Destination Directory text box, enter C:\temp as the name of the
directory where you want the cascaded worksheets to be stored.

You can also click Browse to select a destination directory from the
Browse dialog box.

In the Destination Types option group, select Separate Workbooks (the
default setting) to create separate Lotus 1-2-3 files for each cascaded
worksheet.

You can also tell Essbase to create only one workbook with separate
worksheets for each cascaded report, or you can send the cascaded
reports to the printer.

In the File Information option group, click Overwrite Existing Files (the
default setting). This option tells Essbase to overwrite any cascaded
worksheets with the same file name.
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You can also select Open Created Files to open each cascaded file in
Lotus1-2-3 as it is created.

CAUTION:

Depending on the number of replicated worksheets that you want to
create, the Cascade command can create more worksheets than can be
stored in the memory of your computer. Therefore, the Open Created
Files option should not be used when you are replicating large
numbers of worksheets.

13. In the Naming Information option group, enter BUD in the Prefix text
box.

Eszsbase Cascade Ophions E |

Cascade Information  Destination Options | Farmat Elptiu:unsl

— Destination Directory: ————  — Destination Typez

c:\temp ¥ Separate Workbooks
" One'Woaorkbook, Separate Sheets

Browsze... | = Printer Frinter... |

— File Information — Marming Infarmation
[~ Open Created Files Frefis: IBLID
v Owenwiite Existing Files S i I

Waforkbook: I

k. I Cancel Help

Figure 166. Destination Options Tab

When you assign a prefix or suffix in the Naming Information option
group, the worksheet files that are generated as a result of executing the
Cascade command are named with the prefix or suffix that you specify.
The default is to generate worksheet names that are numbered 1 through
n, where n is the total number of worksheets created. The syntax for the
file names is PrefixnSuffix.123. If you do not specify a prefix or suffix,
Essbase creates the worksheets 1.123, 2.123, and so on. If you are
creating a single workbook, the same naming convention is used for the
worksheet tab names within the workbook.
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14.
15.

16.

17.

CAUTION:

Do not specify a prefix and suffix combination that leaves no
characters free for Essbase to create unique file names. If file names are
duplicated, Essbase overwrites the duplicate file name with the last
cascaded worksheet.

Click the Format Options tab.

To copy the formatting of the source worksheet into each cascaded
worksheet, select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Essbase and
the cell formatting that you set using the worksheet. It does not
copy formulas, column formatting, worksheet formatting, or
graphs.

In the Header and Footer text boxes, specify a header or footer name to
be used for all of the cascaded worksheets.

In the Sheet Formatting group, select the Suppress Missing Rows check
box so that rows containing only #Missing values are not replicated.

In the Table of Contents group, select the Include Table of Contents
check box to create a text file that lists all replicated worksheets, their
creation dates, and their member content.

By default, Essbase names the Table of Contents file with the extension
.Ist.
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[+ rclude Table of Contents
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Figure 167. Format Options Tab

18. Click OK to create the cascaded worksheets.

Essbase rapidly creates the cascaded worksheets (nine total worksheets in
this example). As each worksheet is created, it is automatically saved,
closed, and logged in the Table of Contents. Each individual file is saved
in the directory that you specified, named Budl.123 through Bud9.123.
When the Cascade is completed, Essbase returns you to the original
worksheet view (that is, the source file).

19. Using a text editing application, open the Table of Contents file from the
destination directory that you specified earlier. This file is named
BUDO.LST and contains a list of all cascaded worksheets.
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/*t1:**t*t1:**t*t***t*t*tt1:**t*t***t*t*tff****t******t*t****ttﬁf

/% File name: cohtemphBUDD . 1st */

/* Creation date: Mon Nowv 10 11:48:34 1897 =/
/ttff**tttff**tttff**ttt*tt***ttt***ttt*tff***tt****ttttt****tt*/

cihtenptBUDL  xls /* East, ¢ld Fashioned */
c:h\temp\BUDZ .x1s /* Bast, Diet Root Besr */
crhtenph\BUD3 .x1s /% East, Sasparilla */
cihtemp\BUD4L . x1s /* East, Birch Beer */
cr\temp\BUDS .x1s /% TWest, ©0ld Fashioned */
cihtenptBUDA . x1ls /* West, Diet Root Besr */
cihtenphBUDT . xls /% Test, ZSasparilla */
crhtenp\BUDS .x1s /* South, ©ld Fashioned */
cihtemp\BUDY . x1s /*  South, Diet Root Beer */
ci\temp\BUDLIO . x1s /*  South, Sasparilla */

Figure 168. Table of Contents File for Cascaded Worksheets

20. Select File > Close to close the worksheet.

You do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a
product. Type in the attribute names in the top row of the worksheet.
Select the attribute names and select Essbase > Cascade. Proceed as
described in the above example.

Working with Currency Conversions

176

Organizations with offices in different countries generally do business in the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currencies to a common currency for
consolidation and analysis.

The Essbase Currency Conversion product can be purchased separately for
Essbase. If your organization has purchased this product and has
implemented a currency conversion application, you can take advantage of
the powerful capabilities of Hyperion Essbase Currency Conversion. The
Database Administrator’s Guide describes how to design and implement a
currency conversion application.

The following sections provide a brief tutorial for working with currency
conversions:

* ['Retrieving Currency Conversion Data” on page 177

+ ["Connecting to the Sample Currency Databases” on page 177|

s ["Performing Ad Hoc Currency Reporting” on page 180|
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Retrieving Currency Conversion Data

This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
* A main database that contains data in local and converted values
* A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from
the main database to derive converted values.The Essbase server product
installation includes a sample currency conversion application (installation
options) that consists of two sample databases: a main database called Interntl
and a currency rates database called Xchgrate.

The Sample Interntl database consists of five dimensions: Year, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions
are identical to the Sample Basic database. The Market dimension includes
Toronto, Vancouver, Montreal, France, Germany, Spain, and the UK. The
Scenario dimension handles different currency types (such as Actual and
Budget) in both local and converted currencies. In this database, all local
currencies are converted to the common currency of U.S. dollars.

The Sample Xchgrate database, which is a subset of the main database,
contains four dimensions:

* The CurTime dimension accommodates different exchange rates by month.

* The CurName dimension contains names of currencies from their respective
markets.

¢ The CurCategory dimension contains the names of the various currency
categories that may be applied to the categories of Measures. For example,
one rate is applied to Profit and Loss items and another rate is applied to
Balance Sheet items.

* The CurType dimension enables a currency database to contain rates for
different scenarios, such as Actual and Budget.
Connecting to the Sample Currency Databases

To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.

2. Select the Sample Interntl database and click OK to complete the
connection.
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The Essbase installation also includes sample Lotus 1-2-3 files that
illustrate currency conversion concepts.

3. From the \Essbase\client\sample directory, open Local.123.

The worksheet contains actual (Act) and budget (Bud) data entered in
local currencies for New York and Germany.

A | B | Cc | D | E | F
1 Jan 100-10
i
3 |EEY Bud
4 Hew York Germany Mew York  Germany
h |=ales b7d 210 E40 140
B |COGS 271 G| 2k0 a0
7 bdargin #hdissing #hissing #Missing  #dissing
(]
9 |Marketing 94 2v Gl 20
10 |Fayrall 51 3 40 20
11 |Misc 0 0 #Missing  #hissing
12 | Total Expenses  #Missing #Missing #Missing  #Missing
13
14 bdargin = #hdissing #hissing #Missing  #dissing
15 Frafit % #hdissing #Missing #Missing  #Missing
16
17
18

Figure 169. Retrieving Local Data

4. From the \Esshase\client\sample directory, open Convert.123.
5. Select Essbase > Retrieve.

The worksheet contains values for Actual and Budget as they display after
conversion.
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Figure 170. Retrieving Converted Data Values

A B | ¢ | D E | F | G
1 Jan 100-10
¢
3 Acteal Acfisal & Bud X Fendaef
4 Mew York Germany Mew York Gemany MNew York Germany
h |Sales R78 130 678 210 640 133
B |COGS 27 52 2 84 260 =1
7 kargin 407 78 407 120 380 7
g
9 [Marketing 494 17 494 a7 a0 14
10 |Payroll 51 19 51 31 40 14
11 |Misc 0 0 0 0 #hdissing #Missing
12 | Total Expenses 145 36 145 il 120 20
13
14 Margin % 60.03 £0.00 £0.03 60.00 h9 .34 L7849
15 Profit %2 38.54 32.38 38.54 3238 4063 3684

Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Essbase converts the values by using the exchange rates from the Sample

Xchgrate database.

6. From the \Essbase\client\sample directory, open Rates.123. Connect to
the Sample Xchgrate database.

7. Select Essbase > Retrieve.

Figure 171. Retrieving Exchange Rates from a Currency Database

A |l B [c] D] E]|FJ] G [ HTITJ] 1T [ 4]
1 Jdan Feb bar  Apr May  Jun Jul
2 [USF  Actxchg PEL 1 1 1 1 1 1 1
3 B/S 1 1 1 1 1 1 1
4 Bud xchg PaL 1 1 1 1 1 1 1
b B/S 1 1 1 1 1 1 1
B [CM$  Actxchg PEL 153 183 1563 153 153 153 153
7 B/S 156 185 165 185 18R 155 15§
8 Bud xchg PaL 15 15 15 15 15 1.5 15
9 B/S 15 15 15 15 15 1.5 15
10 [Mark Actxchg PaL 062 0B2 062 062 082 062 062
11 B/S 063 0B3 0B3 0B3 0K 0B3 063
12 Bud xchg PaL 0.7 0.7 0.7 0.7 0.7 0.7 0.7

The worksheet contains all possible combinations of exchange rate scenarios,
categories, and types by month. Because this example converts to U.S. dollars
(US$), the sample file contains a base rate of 1 for US$. Therefore, the local
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and converted figures remain the same for New York. Essbase converts the
tigures for Germany, however, by using data values in the currency database,
as follows:

* Essbase divides data values from Actual by values in the Act xchg currency
type.

* Essbase divides data values from Actual @ Bud xchg by values in the Bud
xchg currency type.

* Essbase divides data values from Budget by values in the Bud xchg
currency type.

* Essbase bases all figures in Convert.123 on the CurCategory of P&L and the
CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation
on exchange rates. The definition is determined by the application
designer.

Performing Ad Hoc Currency Reporting

A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. You may want to perform currency
conversions dynamically, as well. Essbase provides this capability with the
Currency Report command. This command enables you to interactively
change the currency rates and types applied to the retrieval.

To perform an ad hoc conversion on data in the Convert.123 file:
1. From the \Essbase\client\sample directory, open Convert.123.

The worksheet contains data that is already converted to U.S. dollars.
2. Select Essbase > Connect and connect to the Sample Interntl database.
3. Select Essbase > Retrieve.
4. Select Essbase > Currency Report.

Essbase displays the Essbase Currency Report dialog box.
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Figure 172. Esshase Currency Report Dialog Box

The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains
options for currency settings, names, categories, and years. For more
information on these options, see the Essbase Spreadsheet Add-in online
help.

Note: The dimension names CurName, CurType, and CurCategory are
default names for a currency database. The application designer can
use different names for any of these dimensions.

5. Select the currency settings that you want to apply.
For example, select CN$ from the CurName list box and Bud xchg from
the CurType list box.

6. Click Apply to apply the settings.

7. Select Essbase > Retrieve to refresh the data in the worksheet with the
results of the ad hoc conversion.
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A B | ¢ | D E | F | G
1 Jan Cola
2
3 Apfeaf Arfual (5 B X ey Fudieef
4 Hew York Germany Mew York Germmany Mew York Germany
5 [Sales 452 61 452 64 427 G2
B [COGE 181 29 181 27 173 Zh
7 bdargin 27 36 27 41 263 K]
a
9 | karketing 63 g8 63 g K] 7
10 |Fayrall 34 9 34 10 2 7
11 [Misc o o o 0 #tdissing #Missing
12 Total Expenses 97 17 97 14 ]l 13
13
14 hargin % £0.03 &0.00 £0.03 50.00 5938 57.84
15 Profit %2 38.64 32.38 38.64 J2.34 40.63 J6.84
16

Figure 173. Performing an Ad Hoc Currency Conversion

Essbase converts the New York and Germany figures to Canadian dollars

(CN$).

8. Click the Clear button in the Essbase Currency Report dialog box to
disable currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the
retrieval. Converted data values may not always balance, because
the ad hoc conversion is performed on values that were previously
calculated or previously consolidated in another currency.

If values must balance and verify, they must be converted to the target
currency in the database, calculated, and retrieved. This procedure differs
from the ad hoc currency conversion retrievals described in this section; see
the Essbase system administrator for more information.
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Chapter 5. Using Drill-Through

Essbase Integration Services is a product that works with Essbase and Essbase
Spreadsheet Add-in for Microsoft Excel and Lotus 1-2-3. Essbase Integration
Services is a suite of tools and data integration services that serves as a bridge
between relational data sources and the Essbase server. Drill-through is one of
these tools. Drill-through enables you to view and customize spreadsheet
reports that display data retrieved from relational databases. Your
organization must license Essbase Integration Services for you to use the
drill-through tool.

This chapter provides the following information:
* A brief overview of the drill-through feature

* A description of the sample database, Lotus 1-2-3 file, and drill-through
report used for the tutorial

* A tutorial that guides you through tasks for using drill-through

What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic
data, some data elements required for analysis are better suited to the
relational structure of a relational database. The scope of data residing in an
Essbase database is typically at a summary level, where data is summarized
and calculated for planning and analysis. Detailed, transactional data usually
is not examined during the planning and analysis of a business.

For example, say you are using Essbase to analyze retail sales for the first
quarter in the Eastern region. Detailed data, such as a list of customers who
purchased a particular product in a particular size, is not used during the
normal course of analyzing business performance. However, as you analyze
sales results, you may want to view more detailed information. Drill-through
is a tool that enables you to drill from the summarized and calculated data
stored in the Essbase server of your organization into detailed data stored in a
relational database.

The database administrator predefines a data mapping for you from Essbase
to the relational source. For example, the Essbase members East, West, South,
and Central might map to a field called Region in a relational database. As
you navigate through data in the spreadsheet, Essbase knows how the current
data maps to the relational source. For example, suppose you select cell G4 in
the following sheet:
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wiarket crill ¥ [Market Detail\ Measures drilll \ Measures drill2 \ Measures Detail \ Froduct cirill \

B A =3 1 = = = S [ [ Y |
1 Frofit  Product

2 Scenario Actual Budget

3 Jan  Feb Mar Gt Jan  Feb far G Jan  Feb tlar (i1

4 Mew York B2 G0 543 166 B12[_E00] 543 1856 G20 rall 570 2.000
5 Massachusetts | 514 495 B15 15832 H19 498 B15 1,832 570 550 570 1.640
B Florida 336 361 3¢ 1,070 336 361 373 1,070 400 450 4500 1.300
7 Connecticut 321 309 2490 gz 31 309 290 9200 380 390 3600 1130
] Mew Harnpshire 44 74 g4 202 44 74 a4 202 110 130 140 380
] East 1,732 1,843 1805 5380 1.732 1,843 1.805 5380 2080 2230 2790 6500
10 Wwest 2,339 2394 2404 7137 2339 2394 2404 7137 2950 24990 2990 8960
il South 997 1046 1.034 3077 997 1046 1.034 5077 1,330 1.4400 1.410 4180
12 Central 2956 3063 3090 97109 2956 3063 3.090 9109 3550 3690 3700 10.940
13 |Market 6.024 8346 08333 24703 8024 8346 8333 24703 9940 10350 10,290 30,580

Figure 174. Example of Drill-Through Sheet

The dimensional attributes of the cell are as follows: Actual, Profit, New York,
Feb, and Product. The combination of one or more of these attributes becomes
the basis of a drill-through query that returns data from the relational source.

From Essbase Spreadsheet Add-in, you can access a predefined drill-through
report that is based on the dimension or member intersections of Essbase data
cells in the sheet. Using an Essbase Integration Services tool called Integration
Services Console, an administrator at your organization sets up drill-through
reports for you to access; that is, each drill-through report is already defined
in terms of what to retrieve from the relational source.

In Essbase Spreadsheet Add-in, you can access drill-through reports from the
Linked Objects Browser dialog box. When you select a drill-through cell in the
sheet and select Essbase > Linked Objects, the Linked Objects Browser dialog
box displays an entry for drill-through that you can select and launch.

i Linked Objects Browser -- Localhost:5ample:0LAP_TEC

Member Combination:

Linked Objects:

4] | Bl

Attach... Edit.. Eilewaaunch [e|ete Help | LClose |

Figure 175. Linked Objects Browser Dialog Box with Drill-Through Entry
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You can define a style for cells tagged as drill-through to identify which cells
in the spreadsheet are associated with drill-through reports. For more
information, see|”Accessing Drill-Through from the Spreadsheet” on page 194}

What Is the Drill-Through Wizard?

An administrator at your organization can predefine drill-through reports for
you to view or customize. The person who develops a report determines
whether the report can be customized by drill-through users. If a report can
be customized, use the Drill-Through Wizard to customize it. The
Drill-Through Wizard is a graphical user interface that steps you through the
following customization tasks:

* Selecting columns to retrieve from the relational data source
Decide which columns from the predefined report you need to see.
* Selecting the display order for columns
Change the default display order of columns across the sheet.
* Selecting a sort order for data

Select an ascending or descending sort order for a particular column; for
example, sort a list of store managers in alphabetical order.

* Selecting data filters

Define a filter on a column so that only data meeting certain criteria is
retrieved.

Before You Start

Before starting the tutorial, you should have a working familiarity with the
Essbase product through the use of the Essbase Spreadsheet Add-in interface.
Review in this guide|Chapter 3, “A Basic Essbase Tutorial” on page 11| and
[Chapter 4, “An Advanced Essbase Tutorial” on page 95|as prerequisite
reading.

A sample Essbase database is the basis for the examples in this tutorial. The
database administrator creates this sample Essbase database using the sample
metaoutline supplied with Essbase Integration Services. For more information,
see the OLAP Metaoutline User’s Guide. A sample Lotus 1-2-3 file, Essdt.123,
contains a sheet with the appropriate member intersections for the sample
drill-through report. For more information on the sample database, Lotus
1-2-3 file, and drill-through report, see [“About the Samples Used in This|
[Tutorial” on page 192|

If you plan to follow the examples in a live working session, check with the
person at your organization who installs the Essbase Integration Services
product family for information on the sample database you need for
drill-through, and to which Essbase server you should connect.
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Note: The Essdt.123 file also contains sample results of the drill-through
reports when you run them without customizing the reports. The
results are provided in separate sheets in the workbook so that you can
see the sample report results without working through the tutorial For
more information about the sample reports, see [’About the Samples|
[Used in This Tutorial” on page 192

Before starting the tutorial, make sure you meet the following requirements:
* You must install the following components on your client PC:

— A 32-bit version of Lotus 1-2-3

— Essbase Spreadsheet Add-in for Lotus 1-2-3

— Dirill-through

The drill-through module is installed automatically when you install
Essbase Spreadsheet Add-in. This module is transparent until you invoke
it from the Linked Objects Browser. For more information on installation,
contact the Essbase system administrator.

* The Essbase system administrator must install the Essbase server.

* You must have access to Essbase Integration Services and to the Essbase
server. For more information, contact the Essbase system administrator or
the person who administers Essbase Integration Services at your
organization.

* You must have access to the underlying relational database (typically using
a user name and password that are different from those you use for
Essbase). For more information, contact the Essbase system administrator or
the person who administers Essbase Integration Services at your
organization.

* Make sure that the sample Lotus 1-2-3 file, Essdt.123, is available in the
\Esshase\client\sample directory.

* In order to use the sample drill-through report, Essdt.123, you need to login
to a machine that has both the Essbase server and Essbase Integration
Services installed. You must run member and data load and calculate the
data for the sample Essbase Integration Services database that you will
access from Essbase Spreadsheet Add-in.

* The sample database that contains the drill-through report must be set up
and running. The sample drill-through reports used in this tutorial (called
“Market Detail,” “Measures Detail,” and “Product Detail”) are available
with the sample database. Contact the person at your organization who
installs Essbase Integration Services to find out the name of the sample
database needed for drill-through.

Note: For more information on Essbase Integration Services installations, see

the Installation Guide. For more information on Essbase installations, see
the Installation Guide.
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Keep in mind the following guidelines during the tutorial:

Each tutorial task builds upon the previous one, and tasks must be
followed in succession.

Tasks that should not be performed as part of the tutorial are displayed in
gray boxes. These tasks are included for your reference. You can find more
information on these tasks in the Drill-Through online help.

The examples used in this tutorial are based on the sample database that is
included with the Essbase Integration Services installation. Contact the
person at your organization who installs Essbase Integration Services for
information about accessing the sample database.

Set the options in the Essbase Options dialog box as described in the
following section, [“Setting Essbase Options” on page 187] If the option
settings are different, the illustrations presented in this chapter may not
match the spreadsheet view.

If you make a mistake during the tutorial, select Essbase > FlashBack to
return to the previous spreadsheet view.

Setting Essbase Options

Be
to

fore you begin the tutorial, make sure that the spreadsheet options are set
the initial settings, as illustrated in Figure through Figure If your

option settings are different, the illustrations presented in this chapter may
not match the spreadsheet view.

Note: For information about each option in the Essbase Options dialog box,

To

1.
2.
3.

click Help to see the Essbase Spreadsheet Add-in online help.

set Essbase options:
From the spreadsheet menu, select Essbase > Options.
In the Essbase Options dialog box, select the Display tab.

Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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[v Adjust Columns

r Cuery Designer

[ Bepeat Member Labels [ Use Sheet Options with Querny Designer
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v Latest Time Period m

k. | Cancel Help

Figure 176. Initial Settings for Display Options

4. Select the Zoom tab.

5. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Figure 177. Initial Settings for Zoom Options

6. Select the Mode tab.

7. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Figure 178. Initial Settings for Mode Options

8. Select the Style tab.

9. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Figure 179. Initial Settings for Style Options

10. Select the Global tab.

11. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:
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Figure 180. Initial Settings for Global Options

12. Click OK to save the settings for this session and close the Essbase
Options dialog box.
About the Samples Used in This Tutorial

The sample database used for this tutorial contains the following dimensions:
Scenario, Product, Market, Measures, and Year. The sample Lotus 1-2-3 file
shown in Figure provides a particular view from this database:
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wiarket crill ¥ [Market Detail\ Measures drilll \ Measures drill2 \ Measures Detail \ Product drill \

B A =3 1 = = = O o 7|
1 Frofit  Product

2 Scenario Actual Eudget

3 Jan  Feb far Gl Jan  Fehb far G Jan  Fehb hdtar (i1

4 Mew York B2 B0 843 166 B12[_E00] 543 1856 G20 fall 570 2000
5 Massachusetts | 514 498 B15 1532 519 495 B15 1532 570 301] 570 1650
B Flarida 336 3610 373 1,070 336 361 373 1070 400 450 450 1,300
7 Connecticut 321 309 290 gz 31 309 290 920 380 390 3600 1130
] Mew Harnpshire 44 74 84 202 44 74 a4 202 110 130 140 380
] East 1,732 1,843 1.805 5380 1,732 1.843 1,805 5380 2080 2230 2190 6500
10 West 2,339 2394 2404 7137 2339 2394 2404 7137 2950 24990 2930 8960
il South 997 1,046 1,034 3077 997 1,046 1,034 3077 1,330 1440 1,410 4180
12 Central 24956 3063 3090 9109 2956 3063 3090 9709 35660 3690 3,700 10940
13 |Market 6.024 8346 8,333 24703 8,024 8346 8,333 24703 9,940 10350 10,290 30,580

Figure 181. View from Sample Database

For this spreadsheet view, detail-level data exists in a relational data
source—data that is not available from Essbase. For example, the relational
source contains columns of data for market detail, measures detail, and
product detail. This tutorial walks you through a sample drill-through session,
where you will drill down from the data shown in Figure into the detail
data from the relational source.

This tutorial uses two sample drill-through reports, “Measures Detail” and
“Market Detail.” As with all drill-through reports, these reports have been
predefined to retrieve specific columns from the relational source. You will use
the Drill-Through Wizard to customize the report, “Measures Detail.”

Note: The sample file also contains two more sample reports called “Product
Detail” and “Two reports” that you can use for drill-through practice.
In “Two reports,” select the drill-through cell B3 to select from two
drill-through reports, “Product Detail” and Market Detail, select cell B6
to view “Market Detail,” and cell G3 to view “Product Detail.”

In addition to the sample drill-through reports, Essdt.123 provides sample
results of the drill-through reports. The following list describes the
drill-through results that are provided:

* The Market Detail drill tab displays the results for Market Detail when you
run a drill-through report on cell G4 without customizing the report.

* The Measures Detail drilll tab displays the results for Measures Detail
when you run a drill-through report on cell C4 without customizing the
report.

¢ The Measures Detail drill2 tab displays the results for Measures Detail
when you run a drill-through report on cell G6 without customizing the
report.

¢ The Product Detail drill tab displays the results for Product Detail when
you run a drill-through report on cell D5.

Chapter 5. Using Drill-Through 193



Using Drill-Through

194

Drill-through consists of the following tasks:

* Accessing Drill-Through from Essbase Spreadsheet Add-in
* Selecting Drill-Through Reports to View or Customize

* Selecting and Ordering Columns

* Sorting Data

* Filtering Data

The following sections describe each of these tasks and step you through a
live working drill-through session.

Accessing Drill-Through from the Spreadsheet

From Essbase Spreadsheet Add-in, you can access detail-level drill-through
reports that are based on the member intersections of Essbase data cells in the
sheet. Each drill-through report has been predefined by an administrator at
your organization; that is, each drill-through report is already set up to
retrieve specific columns from the relational source, to sort data in these
columns in specific ways, and so forth. Using the Drill-Through Wizard, you
can customize these predefined drill-through reports to retrieve only the data
you want, displayed in a specific way.

To access the predefined drill-through report, double-click a drill-through cell
in the spreadsheet (or select a range of cells and select Essbase > Linked
Objects). You can set styles for cells tagged as drill-through to help identify
which cells in the sheet are associated with drill-through reports. When you
double-click a drill-through cell, Essbase displays the Linked Objects Browser
dialog box, which displays an drill-through report entry. A single cell can
have multiple reports associated with it. The Linked Objects Browser dialog
box also displays entries for linked partitions and other linked object types,
such as cell notes, URLs, and application files. After you view or customize
the drill-through report, Essbase Integration Services retrieves data from the
relational source and displays the results in a new spreadsheet.

Before starting the drill-through tutorial, perform the following tasks:

1. Open a sample Lotus 1-2-3 file that contains the appropriate member
intersections from the sample database for the drill-through report. This
file, Essdt.123, is provided as part of the default Essbase installation.

2. Set a style for data cells that are associated with drill-through reports.

To access the sample file and sample database:
1. Start Lotus 1-2-3.

2. Select File > Open and open the Essdt.123 file from the
Essbase\client\sample directory.
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The sample file should look like the following screen. Note that the
Market Detail tab is selected in this example. The default tab that is
selected when you first open the file may be different.

Market drill ¥ [Market DEtﬁ"\ Measures drilll \ Measures drill2 \ Measures Detail \ Product drill \

B A [ec ol e e lH v ol k[ [Fwu]|
1 Profit  Product

2 Scenario Actual Eudget

3 Jan  Feb fdar @t Jan  Feb G| Jan  Feb hdtar Qi1

q Mew ¥ork 512 601 543 1,656 512[_EO0T] 543 1656 620 710 670 2000
5 Massachusetts | 519 4958 515 1532 518 498 515 1532 570 550 570 1,630
[ Flarida 336 31 373 10700 336 361 373 1.0700 400 450 450 1.300
7 Connecticut 321 309 290 920 321 309 290 920 380 390 360 1130
i Mew Harnpshire 44 484 202 44 7 84 202 111 130 140 380
9 East 1,732 1,843 1805 5380 1,732 1,843 1,805 5380 2080 2230 2190 6500
10 Wwest 2,339 2394 2404 737 2339 2394 2404 P37 2980 2990 2990 8960
11 South 997 1046 1.034 3077 4997 1046 1.034 3077 1,330 1440 1410 4780
12 Central 2956 3063 3.090 9109 2956 3063 3090 9109 3580 3630 3700 10940
13 |Market 8.024 8346 8333 24703 8.024 8346 8333 24703 9,940 10350 10,290 30580

Figure 182. Sample Lotus 1-2-3 File for Drill-Through

The sample file shows data for specific members of an Essbase database.
This sample file contains the following three predefined drill-through
reports, indicated by the tabs of the spreadsheet: “Market Detail,”
“Measures Detail,” and “Product Detail.” Using drill-through, you can
access these reports and customize them so that Essbase Integration
Services retrieves only the data you need and displays it in the desired
format.

Select the Market Detail tab on the spreadsheet.

Select Essbase > Connect and connect to the appropriate sample
database.

Note: A specific sample database for drill-through is not automatically
provided with Essbase Integration Services. For information on the
sample database, contact the person at your organization who
installs Essbase Integration Services to set up a database for you.

Select Essbase > Options and select the Style tab.

In the Data Cells option group, select the Integration Server

Drill-Through check box and click Format.

Essbase displays the Font dialog box.

Select Bold Italic from the Font style list box.

Select Blue from the Color drop-down list, and click OK to return to the
Essbase Options dialog box.

Chapter 5. Using Drill-Through 195



- |

Font: Font ztyle: Size:
[MS Sans Seri 1l [talic 10 [ ok |
an ii Regular B N
Itahe —I Canhicel |
' Mews Gothic Bold 12
B Mews Gothic: Condens Eold Italic 14
% Mimrad — 18
Dl 24
H Perpetua LI LI LI
— Effects — Sample
™ Stikeout
™ Underline A e
LColor:
I- Blue LI Script:
IWeslem :I

Figure 183. Font Dialog Box Selection

Note: In the Essbase Options dialog box, Essbase displays an example of
the selected style in the Sample box.

The following screen shows how the Essbase Options Style tab looks
with the style for drill-through cells defined:
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Figure 184. Sample Style for Drill-Through Data Cells

9. In the Essbase Options dialog box, select the Display tab, and then select
the Use Styles check box.
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Figure 185. Setting the Use Styles Option

10. Click OK to close the Essbase Options dialog box.
11. Select Essbase > Retrieve to display the new style in the spreadsheet.

In Figure the sample drill-through report is associated with the data
cells for Actual, Profit, and Product at the month and Eastern state levels,
so that these data cells are displayed in blue, bold, italic font.

A, [ B [ ¢© [ o [ E F G | H =
L1 Profit Product =
[2 | Scenario Actual
[ 3| Jan Feb har Citrl Jan Feh har Otrl Jan -
L4 Mews ¥ ark 5iZ L2774 H4F7 1656 5EE SO7L S4F 1 E56 [
| 5 | Massachusetts 577 F9F 574 1532 574 FI5 575 1532 X
| B | Flarida FIE J&ET Z7F 1070 FIF JEF FAF 1070 L2
L7 Connecticut JPF Jag iy 920 kigd Jag g 920 F5
| 8 | Mew Hampshire kil e sl 202 7 -~ el 202 Frg
[ 9| East 1732 1843 1805 5380 1732 1843 14805 5330 2080
[10] ‘West 2339 2394 2404 737 23380 2394 2404 71370 25380
[11] South 997 1046 1,034 3077 997 1046 1034 30770 1330
[12| Central 2956 3063 3090 5109 295 3083 3080 91090 3550
[ 13| Market g024 83468 8333 24703 85024 8346 B333 24703 9540
14 =
10« [p [ M5 Market dril % Market Detail  Measures drill 4 Measures drilz { ] 4] | A

Figure 186. Sample Lotus 1-2-3 File with Drill-Through Style Applied

To access the sample drill-through report from Essbase Spreadsheet Add-in:
1. Select any drill-through cell; for example, cell G4.

198  Spreadsheet Add-in User’s Guide for 1-2-3



A [ B [ ¢ [ o [ E T F [ 6 | H T 1T [ 1T —
| 1] Profit | Product I~
2] Scenario Actual
| 3| Jan Feb Mlar Qtrl Jan Feh Iar Otrl Jan —
4| Mew fork 577 77 543 1558 577 £arl 547 1656 £20
| 5 | Massachusetts EXE) 475 7% 1532 EYE) S95 A7& 1532 LX)
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| & | New Hampshire E&d B d #4202 k&d i & 202 bEL
| 9| East 1732 1843 1805 5380 1732 1843 1p05 5380 2080
|10  ‘West 2,339 2394 2404 TIIFF 2338 2394 2404 7137 2580
| 11| South 997 1046 1,034 3077 997 1046 1034 3077 1330
| 12| Central 2956 3063 3090 9708 2956 3063 3090 9709 3550
| 13| Market 8,024 5346 5333 24703 8024 8345 8333 24703 9540

14 -
14 [ 4 [ [, Market dril_},Market Detail { Measares drill_{ Measures drilz_£ 1| 4] nie

Figure 187. Selecting a Drill-Through Cell

Note: You can also select a continuous range of cells in the sheet to
display all drill-through reports associated with cells you select. In
this example, we have only one drill-through report attached to the
range of cells.

2. Select Essbase > Linked Objects to open the Linked Objects Browser
dialog box.

Alternatively, select the Enable Linked Object Browsing check box in the

Essbase Options dialog box (Global tab), which enables you to

double-click a linked object cell to open the Linked Objects Browser

dialog box. This option works only with single-cell selection. If you select

a range of cells, use the Essbase > Linked Objects menu command.

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Member Combinatian:

Linked Dbjects:

Object Type
Dill-Throwgh

[

Attach... | Edit... |Ei‘ewf’Launch| Delete | Help | Close |

Figure 188. Linked Objects Browser Dialog Box with Drill-Through Entry Selected

3. Select the drill-through report entry and click View/Launch.
4. In the Select Drill-Through Report dialog box, select Market detail and
click Execute.

The results of the drill-through report are displayed in a spreadsheet.The
results of the Market Detail report shows that the regional director for the
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East region is John West and that the population for New York is between
18,000,001-21,000,000.

A B | © | D | E |
REGIOMIDIRECTOR | STATE  |POPULATION ALIAS
East John West |Mew Yaork (18,000 001--21 000,000

P | DD | P |

Figure 189. Results of Market Detail Drill-Through Report

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized,
drill-through generates the report and immediately displays the
results in the spreadsheet. The person at your organization who
develops drill-through reports specifies whether you can customize
a report and whether you need to log in to drill-through and the
relational data source.

5. Follow the steps in the next section, [“Selecting Drill-Through Reports to
[View or Customize” on page 200| to select a report to customize.

Selecting Drill-Through Reports to View or Customize

After you launch drill-through from the Linked Objects Browser dialog box,
Essbase Integration Services displays the Select Drill-Through Report dialog
box under the following conditions:

* More than one drill-through report exists for the cell or cell range that you
select in the spreadsheet, or

* Only one report exists, but you have the option of customizing it using the
Drill-Through Wizard.

The Select Drill-Through Report dialog box displays the list of drill-through
reports available for the cells you select in the spreadsheet. Depending on
how a report is defined in Integration Services Console, you may have access
only to view, not customize, the report.

Note: Tasks that you should not perform as part of the tutorial are shown in
light colored boxes.

The sample report used for this tutorial is the Measures Detail report. You will use
the Drill-Through Wizard to customize this sample report. To execute a predefined
drill-through report without customizing it, perform these tasks:

1. Select the report that you want to view from the Available Reports list box.

2. Click Execute.

Essbase Integration Services retrieves the data from the relational source and displays
the results in a new spreadsheet. The new sheet is added before the current sheet.

Spreadsheet Add-in User’s Guide for 1-2-3



To customize the sample drill-through report:
1. In Essdt.123, select the Measures Detail tab.

2. Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically
provided with Essbase Integration Services. For information on the
sample database, contact the person at your organization who
installs Essbase Integration Services to set up a database for you.

3. Select Essbase > Options and select the Style tab to define styles for this
sheet.

4. In the Data Cells option group, select the Integration Server
Drill-Through check box and click Format.

Essbase displays the Font dialog box.

Note: The style for drill-through cells may already be set as blue, bold,
italic font because you set the style in the previous exercise. If this is
the case, then go to Step Iz

5. Select Bold Italic from the Font style list box.

6. Select Blue from the Color drop-down list, and click OK to return to the
Essbase Options dialog box.

Font EHE I
Eont: Font style: Size:
IMS Sans Serf Bold [talic 10 | Ok, I
rAS 5 Reqgular | B«
T Italic —I Cancel |
T Mews Gothic Eold 12
Hr Mews Gothic Condens Eold [talic 14
% Mimrod =l 18
Qs 24
T Perpetua =l =] =l
—Effects——————— ~Sample
[ Stikeout
[ Undefline L
Color:
|- Blue j Script:
IWestem ;I

Figure 190. Font Dialog Box Selection
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Note: In the Essbase Options dialog box, Essbase displays an example of
the selected style in the Sample box.

Essbase Options
Display | Zoom | Mode  Stvle | Global |
~ Member
— Sample
el
v Chid Parent
™ Shared LI
Format..
r— Dimension:
— Sample
=
I Measures
™ Product j
™| CellBorder
Background Color: I Mone j Farmat...
— Data Cell
— Bl
I Linked Qbjects = D
[Ellintearation Server Diill-Through ftegration Sern
™ Read Only j
Format...
Connection Infarmation:
’7 lzgal7:EIS:Main ‘
Q. I Canicel | Help |

Figure 191. Sample Style for Drill-Through Data Cells

7. In the Essbase Options dialog box, select the Display tab and select the
Use Styles check box.
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Ezzbase Options

Display |Zoom | Mode I Style: | Globall

™ Underscore Characters

Aliasg:
— EE —_—

— Indentation — Replacement

" None tiMigsing Label |0

(¢ Subitems

 Totals H#Mo Access Label: l—
— Suppre — dliase

™ #HiMizsing Fows ¥ Use dliases

™ Zero Rows ™ Use Bath Member Mames and Aliazes

for Row Dimensions

7 IDefauIt

W Adiugt Columns

=

= it St Baws
W Bepeat Member Labels

Quer Designer
’7|_ Use Sheet Options with Query Designer |

— Diynamic: Time Serie:

I Latest Time Period IJan

|

o]

Cancel |

Help

Figure 192. Setting the Use Styles Option

Click OK to close the Essbase Options dialog box.
Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample drill-through report is associated with every
member intersection at the state level in the East region, so that all data
cells associated with an Eastern state and children of Cola are now

displayed in blue, bold, italic font.

Figure 193. Sample File with Drill-Through Style Applied

A B [ ¢ | D | E [ F G| H
1
2 Mew ¥ ork Massachusetts
[3] Cala Diet Cola | Caffeine Free Cola | Colas | Cola Diet Cala
[ 4 Sales Year 2848 7 & 940 [ET LA
5] Cost of Goods Sold | Year 2&57T 7 7 3573 s AN
[B | Margin ‘Year 6T 4 7 5,367 £F35 7
| 7 | TotalExpenses ‘rear ragd & 7 1,869 &3 7
[ 8 | Profit ‘rear 298 4 & 3.493 L1857

To access the sample drill-through report from the Essbase Spreadsheet
Add-in:

1. Select any drill-through cell; for example, cell Gé.
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A [B ] © [ 10 1] E [ F 1 6 ] H

1
Z Mews York Massachusetts
| 3 | Cola Diet Cola  Caffeine Free Cola | Colas  Cola Diet Cola
| 4| Sales Year 2290 7 7 G940 £578 87
| 6 | Cost of Goods Sold | Year 577 7 I 3573 A

6 bdargin Year ETET B & 5367 5,7.?5_ 7
| 7 | TotalExpenses Year A &g 1,869 EIF 7
| B | Profit Year X887 7 34598 EN NS

Figure 194. Selecting the Drill-Through Cell for the Measures Detail Report

Note: If Essbase Integration Services is not running, drill-through does not

launch properly. For more information, contact the Essbase system
administrator.

Note: If you are prompted with the Drill-Through Login dialog box to
connect to Essbase Integration Services and the relational data
source, enter the appropriate connection information. The person at
your organization who administers Essbase Integration Services and
develops drill-through reports should provide you with this
information.

2. Select Essbase > Linked Objects to open the Linked Objects Browser
dialog box.

Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to
double-click a linked object cell to open the Linked Objects Browser
dialog box. This option works only with single-cell selection. If you select
a range of cells, use the Essbase > Linked Objects menu command.

i Linked Objects Browser -- Localhost:Sample:0LAP_TBC

Member Combination:

Linked Objects:

[« | i

Attach... Edit.. Ei.ewaaunch [elete Help | LCloze |

Figure 195. Linked Objects Browser Dialog Box with Drill-Through Entry Selected

3. Select the drill-through report entry and click View/Launch.
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The Select Drill Through Report dialog box is displayed.

Note: In the Select Drill Through Report dialog box, if the Customize
button is selectable, then you can customize the report. If more than
one drill-through report is displayed, then you can select from the
different drill-through reports. In this tutorial, only one report,
“Measures detail,” is displayed and customizable.

4. Select the Measures detail report from the Available Reports list box.

Select Dnll-Through Report M= E I
Available Reports Execute
Cuztomize ...
Canhicel
Help

Figure 196. Selecting the Sample Drill-Through Report

5. Click Customize.
Note: The Customize button may be selectable or not selectable for any
given report, depending on how the report was defined in

Integration Services Console.

Essbase Integration Services displays the first screen of the Drill-Through
Wizard.
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Drill-Through Wizard

Fallow theze steps to customize the tranzactional report
related to the OLAR intersections pou have selected:

1. Select the columns to retrisve and define their
display order.
2 Define a sort order for colurnng.

3 Define filters for columns.

Click. the finish button at any point to generate the report.

< Back |

Next > |

Cancel | Help |

Figure 197. Drill-Through Wizard Dialog Box, Introductory Screen

6. Click Next to display the Select Columns and Display Order dialog box.

Select Columns and Display Order B
Repart Mame

IMaasules detail

Available Columns

- MARKET
PRODUCT
=+ SCEMARID
& Time

- SALES

Bl E] =[]

Selected Columns

MARKET STATE
PRODUCT SKU
SCENARIO.SCENARID
Time TRANSDATE
SALES AMOUNT

tove Down

iave g

< Back |

Nest » | Finish I Cancel | Help

Figure 198. Select Columns and Display Order Dialog Box

7. Follow the steps in the next section, [“Selecting and Ordering Columns” on|
to select and order rows for the customized report.

Selecting and Ordering Columns

Using the Drill-Through Wizard, you can customize predefined drill-through
reports. The first task in the Drill-Through Wizard is selecting and ordering
columns to retrieve from the relational database. These columns contain
detailed information that is not available in the Essbase database.
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In the Select Columns and Display Order dialog box, you can select which
columns you want Essbase Integration Services to retrieve from the relational
data source. From this dialog box, you can also specify how the columns are
displayed in the resulting report.

The Available Columns list box displays a list of columns available from the
relational data source for this report (as defined in Integration Services
Console). The Selected Columns list box displays the columns from the
Available Columns list box in expanded form. You can remove columns from
the Selected Columns list box to exclude them from the drill-through report.

In this example, the columns from the Available Columns list box are selected
for inclusion in the sample Measures detail report. These columns are
displayed in expanded form in the Selected Columns list box.

To remove one of the selected columns from the drill-through report:
1. In the Selected Columns list box, select the MARKET.STATE column.

Note: To select multiple columns in the list that are not adjacent to each
other, hold down the Ctrl key and select each column. To select a
range of columns, hold down the Shift key and click the first and
last columns in the list, which also selects all columns in between
them.

Select Columns and Display Order [ ]

Fieport Mame

IMeasuras detail

Aywailable Colurnis Selected Colurng

- MEASURES MEASIRES CHILD
o MARKET
__ PRODLCT PRODUCT.SKU
; SCENARID SCENARIO
SCEMARID Time TRANSDATE
(- Time SALES.AMOUNT
- SALES

Mave Up |
3 Move Qownl

£

EEAN SN

< Back | Mewt s | Finizh I Cancel | Help |

Figure 199. Selecting Columns to Remove From the Drill-Through Report

2. Click to move the selected column from the Selected Columns list
box back to the Available Columns list box.
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Note: To move a column from one list box to another, click or .

To move all columns from one list box to another, click or

. Click Next to display the Select Data Sort Order dialog box, and follow

the steps in the following section, [’Ordering Data” on page 208|to further
customize the report.

Note: When you finish customizing the report, click Finish at any time to
generate the report and view the results in a new sheet. The new
sheet is placed before the current sheet.

Ordering Data
In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the data in a column. Sort order determines the
order in which rows will be displayed in the drill-through report. For
example, you can sort the contents of the Time. TRANSDATE column, which
represents the transaction dates, in ascending order in the drill-through report.

To define the sort order of rows in the drill-through report:
1. In the Available Columns list box, select the Time. TRANSDATE column.

The columns in the Available Columns list box are those that you selected
in [“Selecting and Ordering Columns” on page 206| The columns in the
Column list box are those for which a sort order has already been defined
in Integration Services Console.

If a data sort order was selected when the report was created in Essbase
Integration Services Console, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.

. Click to move the Time. TRANSDATE column to the Column list box

so that you can define a sort order for the column.

Note: To move a column from one list box to another, click or .

To move all columns from one list box to another, click or

Spreadsheet Add-in User’s Guide for 1-2-3



Select Data Sort Order

Report Marme

IMeasules detail

Available Columns Calurin I Order By I
MEASURES CHILD Time TRAMNSDATE  Ascending

PRODUCT.SKU

RIO

lave g

> fdme Dawn|

< Mrden B

L

< Back | Mext > | Finizh | Cancel | Help |

Figure 200. Moving a Column to the Column List Box for Sorting

3. In the Column list box, double-click the Time. TRANSDATE column to
change the data sort order from Ascending to Descending so that

transaction date values are displayed in reverse chronological order in the
drill-through report.

Select Data Sort Order

Report Mame

IMeasules detail

Available Columns
MEASURES CHILD
FRODUCT.SKU
SCENARID.SCENARID
SALES AMOUNT

tdawe U

> e Dawn|

EIEIET ]

4 DOrder By...

FLL

< Back | Mewt s | Finizh I Cancel Help

Figure 201. Selecting the Data Sort Order

4. Click Next to display the Select Data Filters dialog box, and follow the

steps in the following section, [“Filtering Data” on page 210|to further
customize the report.
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Note: Tasks that you should not perform as part of the tutorial are shown
in light-shaded boxes.

To change the data sort order for multiple columns at one time, perform these tasks:
1. Hold down the Ctrl key and select the desired columns from the Column list box.
2. Click Order By.

Essbase Integration Services displays the Order By dialog box.

Order By I

It | oK |

BAzcending

D escending Cancel |
Help |

Figure 202. Order By Dialog Box
3. Select Ascending or Descending and click OK to return to the Selecting Data Sort Order dialog
box.

Filtering Data

You can apply filters to determine what Essbase Integration Services retrieves
for the drill-through report. For any given column, you may want to retrieve
only data that meets certain conditions. For example, the MEASURES.CHILD
column in the sample database contains all children of the Measures
dimension. In the sample drill-through report, if you did not apply a filter to
this list of measures, Essbase Integration Services would retrieve all children
from the relational source, because the sample drill-through report applies to
all children of Measures. In this section, you will apply a filter to the
MEASURES.CHILD column so that all children of Measures, except Misc, are
included in the report.

Note: When you apply a filter on a non-level 0 member using Essbase
Integration Services, the filter may return more members than expected.
To work around this problem, use the Drill-Through Wizard.
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To define a filter:
1. Select the MEASURES.CHILD column from the Column list box.

The columns in the Column list box are those that you selected in
[‘Selecting and Ordering Columns” on page 206,

Select Data Filters

Column | Condition I Add ..
MEASURES.CHILD _I
MARKET.STATE

PRODUCT.SKL ﬂl
SCENARID.SCEMARID

Time. TRANSDATE Clear Al |
SALES.AMOUNT

Caondition

=
I]

< Back R | Finizh I Cancel | Help

Figure 203. Select Data Filters Dialog Box

Note: If there is a filter already attached to the column, it is displayed in
the Condition list box. The full string of the filter is displayed in the
lower Condition text box.

2. With the MEASURES.CHILD column selected, click Add.
The Set Filter on Column dialog box is displayed.
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Set Filter On Column : CHILD E

Filters |

Calunin; Operator; Condition:

[E -] [E——] | _|
il | Add Type
" and

0

Filters:

kK I Cancel | Help |

Figure 204. Set Filter on Column Dialog Box

3. Select CHILD from the Column drop-down list box.

The column displayed in the Column drop-down list box is the one that
you selected in|“Filtering Data” on page 210}

Select the < > operator, which represents not equal to, from the Operator
drop-down list box.

Note: You can select multiple values at one time only if you have selected
In or Not In as the filter operator. For more information on filter
operators, see the Drill-Through online help.

Click the BrowseL—1 button to open the Select Filter Values from the
List dialog box, which lists all possible values for that column.

The Select Filter Values from the List dialog box is displayed.

Note: Essbase Integration Services retrieves these values directly from the
relational data source. If the relational data source contains many
values, Essbase Integration Services confirms if you want to view
them all before it retrieves them from the data source.

In the Select Filter Values from the List dialog box, select Misc and click
OK. The Set Filter On Column dialog box is displayed.
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Select Filter Yalues from the List

W alue |
Additions

COGS LCanicel
Ending [mventory
Ibrventarny Help
kargin

Margin %

M arketing

did

Opening Inventary
Fayrall

Profit

Profit %

Profit per Dunce

R atios

Sales

Total Expenses

Figure 205. Selecting Filter Values from the List

7. Click Add to add the condition to the Filters list box.

Note: For information on using multiple filter conditions, see the
Integration Server Drill-Through online help.

The Set Filter on Column dialog box should now look like Figure
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Set Filter On Column : CHILD E

Filters |
Calunin; Operator; Condition:
[E = e = [
" and
0
Filters:
MEASIJRES.CHILD <> Misc' ;l
« of
ar. | Cancel | Help |

Figure 206. Defining a Filter for a Column

The filter defined above causes all children of Measures, except Misc data,
to show in the drill-through report.

Note: The Add button becomes unselectable after creating the first filter,

but becomes selectable when you create another filter. In this
tutorial, you are creating only one filter. The And and Or options
are used when combining multiple filters. The default value is Or,
which means that Essbase Integration Services applies the filter if
any of the conditions you specify are met. If you select And,
Essbase Integration Services applies the filter only if all the
conditions are met.

8. Click OK to return to the Select Data Filters dialog box. Notice that the
filter defined in the Set Filter on Column dialog box is displayed in the
Condition list box and text box of the Select Data Filters dialog box.

Spreadsheet Add-in User’s Guide for 1-2-3



Select Data Filters

Column | Condition |
MEASURES.CHILD MEASURES.CHILD <> Misc'

MARKET.STATE

PRODUCT.5KU ﬂl
SCENARIO.SCENARIO

Time. TRANSDATE Clear &1 |
SALES.AMOUNT

Condition
MEASURES .CHILD <> 'Misc' ﬂ
< Back TEsts Finish I Cancel | Help

Figure 207. Result of Defining a Filter for a Column

Note: You can also create a filter by typing the filter conditions directly
into the Filters list box of the Set Filter on Column dialog box. For
more information, see the Drill-Through online help.

To delete a filter, select the filter and click Clear. To delete all filters,
click Clear All.

9. Click Finish.

Essbase Integration Services generates the customized drill-through report
and displays the results in a new spreadsheet. The new spreadsheet is
added to the workbook before the current spreadsheet.
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Figure 208. Customized Drill-Through Report

In this sample, the customized drill-through report reflects the specifications

that you set using the Drill-Through Wizard:

* The Time.TRANSDATE column is sorted in descending order, displaying

the transaction dates in reverse chronological order.

* All children of Measures, Additions, COGS, Marketing, Payroll, Sales, and
Opening Inventory, except Misc, are displayed as you specified in the

filtering part of the Drill-Through Wizard.

A B | C D | E
1 [CHILD SKU  SCEMARIO TRANSDATE AMOUNT
2 |Additions 100-10 Actual 2000-12-09 00:00:00.000 123.97
3 |coGs 100-10 Actual 2000-12-09 00:00:00.000 51.59
4 |Marketing 100-10 Actual 2000-12-09 00:00:00.000 16.94
5 |Payroll 100-10 Actual 2000-12-09 00:00:00.000 23.87
B |Sales 100-10 Actual 2000-12-09 00:00:00.000 3927
7 | Additions 100-10 Actual 2000-12-04 00:00:00.000 37.03
B |COGS 100-10 Actual 2000-12-04 00:00:00.000 15.41
9 |Marketing 100-10 Actual 2000-12-04 00:00:00.000 5.06
10 | Payroll 100-10 Actual 2000-12-04 00:00:00.000 7.13
11 |Sales 100-10 Actual 2000-12-04 00:00:00.000 117.3
12 | Additions 100-10 Actual 2000-11-28 00:00:00.000 &3.82
13 |COGS 100-10 Actual 2000-11-28 00:00:00.000 19.5
14 | Marketing 100-10 Actual 2000-11-28 00:00:00.000 6.24
15 | Payroll 100-10 Actual 2000-11-28 00:00:00.000 8.06
16 | Sales 100-10 Actual 2000-11-28 00:00:00.000 118.04
17 | Additions 100-10 Actual 2000-11-19 00:00:00.000 15318
18 |COGS 100-10 Actual 2000-11-19 00:00:00.000 55.5
19 | Marketing 100-10 Actual 2000-11-19 00:00:00.000 17.76
20 | Payroll 100-10 Actual 2000-11-19 00:00:00.000 22.94
21 |Sales 100-10 Actual 2000-11-19 00:00:00.000  335.96
22 | Additions 100-10 Actual 2000-10-16 00:00:00.000 191
23|CoGS 100-10 Actual 2000-10-16 00:00:00.000 72

Disconnecting from Essbase

216

When you finish using drill-through, disconnect from the Essbase server to
free up a port on the server for other Essbase Spreadsheet Add-in users.

To disconnect from the server:

1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can

disconnect any spreadsheet that is connected to a database.
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Ezsbase Disconnect

Sheet ServerApplication-» 0 atabase

Dizconnect

Help |

Figure 209. Essbase Disconnect Dialog Box

Note: Essbase may return an error message when you attempt to
disconnect after using drill-through. If an error message is returned,
select Essbase > Retrieve from the sheet and then disconnect.

2. Select a sheet name from the list and click Disconnect.
3. Repeat Step IZl until you have disconnected from all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing Lotus 1-2-3. An

abnormal termination of a Lotus 1-2-3 session, such as a power loss
or system failure, does not disconnect your server connection.
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Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
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be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for
this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM Corporation
J74/G4

555 Bailey Avenue,

P.O. Box 49023

San Jose, CA 95161-9023
US.A

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available
sources. IBM has not tested those products and cannot confirm the accuracy
of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be
addressed to the suppliers of those products.

Trademarks

1-2-3 Language Environment
AIX Net.Data

AS/400 Notes

DB2 0Ss/2

DB2 OLAP Server 0S/390
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DB2 Universal Database RS/6000

DRDA S/390
IBM SecureWay
OpenEdition 0S/400

The following terms are trademarks or registered trademarks of other
companies:

1-2-3, Notes, and Lotus are registered trademarks of Lotus Development
Corporation and/or IBM Corporation.

Hyperion, Essbase, and the Hyperion “H” logo are registered trademarks, and
Hyperion Solutions is a trademark of Hyperion Solutions Corporation

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or
both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ActionMedia, LANDesk, MMX, Pentium and ProShare are trademarks of Intel
Corporation in the United States, other countries, or both. (For a complete list
of Intel trademarks, see www.intel.com/tradmarx.htm.)

UNIX is a registered trademark of The Open Group in the United States and
other countries.

Other company, product or service names may be the trademarks or service
marks of others.
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Glossary

This glossary defines terms that are used in
this book and throughout the IBM DB2
OLAP Server library.

accounts dimension. A dimension type that
makes accounting intelligence available. You can
tag one dimension as an accounts dimension, but
an accounts dimension is not required.

administrator. A person who is responsible for
installing and maintaining DB2 OLAP Server and
for setting up user accounts and security.

agent. A process that starts and stops
applications and databases, manages connections
from users, and handles user-access security.

alias ID table. A table created by DB2 OLAP
Server in your relational database that contains a
mapping of multidimensional alias table names
to ID numbers allocated by DB2 OLAP Server.

alias ID view. A view created by DB2 OLAP
Server in your relational database that contains
one row for each multidimensional alias table
used with a relational cube. There is one alias ID
view for each relational cube.

alias name. An alternate name for a dimension
or member.

anchor dimension. A dense dimension that is
specified as the dimension that DB2 OLAP
Server uses to help define the structure of the
fact table it creates in the relational cube for a
multidimensional database.

API. Application programming interface. The
DB2 OLAP Server API is a library of functions
that you can use in a custom C or Visual Basic
program to access DB2 OLAP Server.

Application Manager. A tool that you can use
to create and maintain OLAP applications.
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block. A string of data elements recorded or
transmitted as a unit.

cache. A component of memory. Each
multidimensional database contains a data cache
and an index cache.

calculation. An equation within a database
outline, a calculation script, or a report script
that calculates a value for a particular member or
point in a report.

calculation script. A text file that contains
instructions to perform calculations within a
multidimensional database. Also called a calc
script.

Commit Block parameter. A parameter on the
Transaction page of the Database Settings
notebook in the Application Manager that you
use to set the number of blocks that can be
changed before DB2 OLAP Server commits the
blocks.

cube catalog table. A table that DB2 OLAP
Server creates in your relational database that
contains a list of all the multidimensional
databases that are stored in your relational
database. The cube catalog table also shows the
application with which each cube is associated.
Each time that you create a multidimensional
database, DB2 OLAP Server creates a new row in
this table.

cube catalog view. A view that DB2 OLAP
Server creates in your relational database that
allows an SQL user to access a list of OLAP
applications and relational cubes.

cube table. A table that DB2 OLAP Server
creates in your relational database that contains a
list of dimensions in a relational cube and
information about each dimension.

cube view. A view that DB2 OLAP Server
creates in your relational database that allows an
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SQL user to access the names of all dimensions
in a relational cube and associated information
for each dimension. There is one cube view for
each relational cube in your relational database.

data load. The process of populating a
multidimensional database with data. Loading
data establishes actual values for the values of
the cells defined in the database outline for the
database.

data load rules. A set of operations that DB2
OLAP Server performs on data as it is loaded
from an external source file.

database administrator. A person responsible
for administering a relational database.

database log file. A set of primary and
secondary log files consisting of log records that
record all changes to a database. The database
log file is used to roll back changes for units of
work that are not committed and to recover a
database to a consistent state.

database managed space (DMS). Space in a
table that is managed by the database.

database name. The name of the relational
database where you want DB2 OLAP Server to
store your multidimensional data.

database outline. The structure that defines all
elements of a database within DB2 OLAP Server.
It contains definitions of dimensions and
members, dense or sparse dimension tags and
attributes, the anchor dimension attribute,
calculations, shared members, and alternations to
the basic roll-up structure of the database.

database password. The password for the user
ID that you want DB2 OLAP Server to use to log
on to your relational database.

database section. A section in the Relational
Storage Manager configuration file that contains
values for parameters that override the values
for the same parameters for the current
application.

database settings. Settings that you can modify
to improve performance and space utilization for
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your relational database. You can change
database settings by using utilities or commands
supplied with your relational database
management system.

database user ID. The user ID that you want
DB2 OLAP Server to use to log on to your
relational database. The default is the supervisor
ID that you specify when you start DB2 OLAP
Server for the first time.

dense dimension. A dimension with a high
probability for occupying one or more data
points in every combination of dimensions that
occurs.

dimension. A data category, such as time,
accounts, products, or markets. In a
multidimensional database outline, the
dimensions represent the highest consolidation
level.

dimension table. A table that DB2 OLAP Server
creates in your relational database that contains
detailed information about the members in a
dimension. There is one dimension table for each
dimension in an outline.

dimension view. A view that DB2 OLAP Server
creates in your relational database that allows an
SQL user to access information about members
contained in a dimension.

ESSCMD. A command-line interface used to
perform server operations interactively or
through a batch file.

generation name. A unique name that describes
a generation in a database outline.

generation table. A table that DB2 OLAP Server
creates in your relational database that contains
generation numbers and names for each named
generation specified when you created the
outline. There is one generation table for each
dimension in an outline.

level name. A unique name that describes a
level in a database outline.



member. A discrete component within a
dimension. For example, January 1997 or 1Qtr97
are typical members of a Time dimension.

metaoutline. A template containing the
structure and rules for creating a database
outline from an OLAP model. Using the
metaoutline, you can create a database outline
and load data into it. The DB2 OLAP Integration
Server desktop includes a tool called OLAP
Metaoutline that you can use to create one or
more metaoutlines from an OLAP model.

model. A logical model (star schema) that you
create from tables and columns in a relational
database. You can use the OLAP model to create
a metaoutline that generates the structure of a
multidimensional database. The DB2 OLAP
Integration Server desktop includes a tool called
OLAP Metaoutline that you can use to design
and create an OLAP model based on a relational
data source.

multidimensional data. The data in a
multidimensional database. Data can include
basic data values (loaded from an external
source) that represent combinations of the lowest
level of members in the dimensions of the
database; data values that are calculated from the
base data values; and rolled up data values that
are created by combining values for members in
dimension hierarchies.

multidimensional database. An OLAP database
that you create using the Application Manager or
ESSCMD commands (in DB2 OLAP Server) or
with the DB2 OLAP Integration Server desktop,
which is in the Starter Kit. An OLAP database
includes a database outline, data, associated
optional calculation scripts, optional report
scripts, and data load rules. DB2 OLAP Server
stores the actual data and a shadow of the
database outline in tables in a relational
database.

named pipes. An API used for special
node-to-node applications and particularly for
access to communications and database servers.

OLAP application. An application that you
create using the Application Manager or the

ESSCMD commands (in DB2 OLAP Server) or
with the DB2 OLAP Integration Server desktop,
which is in the Starter Kit. An OLAP application
can contain one or more multidimensional
databases and any associated calculation scripts,
report scripts, and data load rules.

OLAP metaoutline. See metaoutline.
OLAP model. See model.

online analytical processing (OLAP). A
multidimensional, multi-user, client server
computing environment for users who need to
analyze consolidated enterprise data in real time.
OLAP systems feature zooming, data pivoting,
complex calculations, trend analyses, and
modeling.

outline. See database outline.

RDBMS. Relational database management
system. A database that can be perceived as a set
of tables and manipulated in accordance with the
relational model of data.

relational attribute. A characteristic of a
dimension table, represented by a column. You
can run SQL statements against the data in
relational attribute columns.

relational database. A database that is
organized and accessed according to
relationships between data items. A relational
database contains a collection of relational tables,
views, and indexes.

report script. An ASCII file that contains Report
Writer commands that generate one or more
production reports. Report scripts can be run in
batch mode, using the ESSCMD command-line
interface, or through the Application Manager.
The script is a text file that contains data
retrieval, formatting, and output instructions.

restructure. An operation to regenerate or
rebuild the tables and views that DB2 OLAP
Server created in your relational database.

shadow. Information stored in relational tables
that shadows the information stored in a
multidimensional database outline.
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shared member. A member that explicitly
shares storage space with another member of the
same name. This member has an attribute that
designates it as shared. Shared members prevent
making extra calculations on a member that
appears in more than one location in a database
outline.

sibling. A child member at the same branch
level.

sparse dimension. A dimension with a low
percentage of available data positions filled. For
example, a product that is not sold in all of a
company’s available markets would be a good
sparse candidate.

Spreadsheet Add-in. Software that merges with
Microsoft Excel and Lotus 1-2-3 to enable
analysis of multidimensional databases. The
software library appears as a menu Add-In to the
spreadsheet and provides such features as
connect, zoom-in, and calculate.

SQL application. An application that uses SQL
statements. You can use SQL applications to
access data in a relational cube.

SQL. Structured Query Language. A
standardized language for defining and
manipulating data in a relational database.

star schema. The type of relational database
schema used by DB2 OLAP Server. When you
use the Application Manager to create a
multidimensional database, DB2 OLAP Server
creates a main fact table and a set of dimension
tables. The fact table holds the actual data values
for the database, and the dimension tables hold
data about members and their relationships.

star view. A relation view that DB2 OLAP
Server creates in your relational database that
allows an SQL user to access data from the star
schema in a single view with the JOIN already
done.

table space. An abstraction of a collection of
containers into which database objects are stored.
A table space provides a level of indirection
between a database and the tables stored within
the database. A table space:
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* Has space on media storage devices assigned
to it.

* Has tables created within it. These tables will
consume space in the containers that belong to
the table space. The data, index, long field,
and LOB portions of a table can be stored in
the same table space, or can be individually
broken out into separate table spaces.

time dimension. A dimension type that defines
how often you collect and update data. You can
tag only one dimension as Time, although you
do not need to have a Time dimension.
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Special Characters
? wildcard character 85

* wildcard character 85

#Missing strings, suppressing 48
#NoAccess strings, suppressing 48

A

access
to databases 23, 95
to Essbase data 23, 95
to linked partitions 165
to linked reporting objects 155
to multiple databases 163
to online help 14
using Essbase commands 22
with drill-through 194
Acrobat Reader
See Adobe Acrobat Reader
ad hoc reports 3, 25, 116, 180
Add button 211
Add-in Manager 12
adding members
See members, adding
adjusting columns
See columns, adjusting width
administrators 3
Adobe Acrobat Reader vi
advanced interpretation engine 136
Advanced Interpretation mode 136,
143
aliases
definition of 59
displaying
process of 59
with member names 61
with Query Designer
results 81
in tables 59
alternate dimensions
See dimensions, alternate
alternate names
See aliases
ancestors, definition of 10
AND operators 82
API 5
application designer 4
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application partitions
See linked partitions
application programming
interface 5
applications/databases
Sample Basic 11, 22, 24, 96
sample for drill-through 192
Sample Interntl 177
Sample Xchgrate 177
ascending sort order
with drill-through 208
with Query Designer 108
asymmetric reports
definition of 110
pivoting 112
retrieving data into 110
Attach Linked Object dialog
box 148, 151, 153
attaching reporting objects to cells
See linking
attaching to databases
See connecting
attributes, drill down 30
auditing updates 169
auto logouts 92
Auto Sort Rows option 139

blank
columns 112
rows 112

blocks, locking data 167
Boolean operators 82, 86

C

Calculation command 169
Calculation dialog box 169
calculations

database status 170

databases 129, 169

dynamic 129

reducing calculation time 129

scripts 170

specifying latest time period 131

substitution variables 134

with Dynamic Time Series 131
canceling data retrievals 27
Cascade command 171
Cascade Information page 171
Cascade Options dialog box 171

cascading sheets
creating table of contents 174
destination 172
format 174
level of detail 171
names 173
output type 172

cell notes
accessing linked 157
linking to cells 151

cell ranges
keeping 40
removing 43
retrieving 121
selecting nonadjacent 41
with drill-through 199

cells
accessing linked partitions 165
applying styles 50, 56

attaching reports
See linking
attaching URLs
See linking
EssCell function in 124
formatting 50, 56, 150
in data cells 56
of dimension members 54
of Dynamic Calculation
members 129
of parent members 51
formulas in 113, 114, 117, 124
linked reporting objects 147, 153
linking files to 147
linking notes to 151
linking URLs to 153
retrieving a range 121
retrieving single values 124
selecting nonadjacent 41
with nondatabase values 112
Change Password dialog box 25
changing
passwords 25
row and column orientation 35
spreadsheet format 50
styles 50
children (defined) 9
Clear All button 215
Clear button 215
Clear command 28
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clearing styles 58
click (defined) 15
client
components 4
software 11
upgrading with server 1
client-server environment 4
collapsing data views
See drill
colors, setting 50
columns
adjusting width 22, 114
blank 112
displaying as rows 35
displaying selected 40
filtering by 104
keeping selected 40
nested 29
pivoting 35
removing selected 43
retrieving into 30
columns, drill-through
choosing 207
selecting display order 207
selecting for retrieval from
relational source 207
sorting 208
commands
Calculation 169
Cascade 171
Clear 28
Connect 23, 95, 163
Currency Report 177, 180
Disconnect 91
FlashBack 27
Keep Only 40
Linked Objects 147, 153
Lock 167
Member Selection 83
Navigate Without Data 44, 47
Pivot 35
Remove Only 43
Retrieve 26
Retrieve & Lock 167
Send 167
Undo 27
Unlock 167
Zoom In 28
Zoom Out 32
comparison operators 82, 104
computing environment v
concurrent
database access 24, 163
updates to server 167
conditional retrievals 102

Connect command 23, 95, 163
connecting
See also disconnecting
to a database 23, 95
to a relational data source 183,
194, 204
to Essbase 24, 96
to Essbase Integration
Server 194, 204
to multiple databases 163

viewing current connections 164

Connection Information text
box 164, 170
consolidations (defined) 10
conversions, currency 176
creating queries 66
creating reports
See reports, creating
Currency Conversion product 6
currency conversions
modifying exchange rates 181
reporting 180
sample databases 177
settings 181
Currency Report command 177,
180
Currency Report dialog box 181
current time period
See Dynamic Time Series
cursors (Essbase) 26
custom applications 5, 6
Customize button 205
customizing drill-through
reports 201

D

data
calculating 169
changing orientation 35
comparison operators 104
displaying 7, 26
dynamically calculating 129
filtering 102

filtering, with drill-through 215

formatting 50
locking 167
missing 48
modifying 167
navigating 10, 44
pivoting 35
relational, with
drill-through 183
removing subsets 43
retaining subsets 40
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data (continued)
retrieving
See retrieving
sorting 102
unlocking 167
updating 167, 169
data sort order, with
drill-through 208
data source, relational 204
databases
calculating
See calculations
connecting
See connecting
consolidations 10
defined 6
dimensions 9
disconnecting from 91
linked
See linked partitions
loading 25, 97
locking 167
members 9
organization 7
outlines 10
queries
See queries
restoring previous views 27
rules 7
sample 22,177,192
selecting
See connecting
switching 163
viewing connections 164
deleting
filters, drill-through 215
selected members 43
styles 58
descendants (defined) 10
descending sort order
with drill-through 208
with Query Designer 108
Destination Options page 172
destinations
cascaded sheets 172
Query Designer queries 74
detaching
See disconnecting
dialog boxes, Help buttons 14
dimensions
alternate 6
applying styles 54
currency conversion and 177
described 6, 9
drilling down on 28, 30



dimensions (continued)
drilling up on 32
naming elements 9
pivoting 35
disabling data retrieval
See navigating without data
Disconnect
command 91
dialog box 91
disconnecting
forced logouts 92
from Essbase 91
from Essbase Integration
Server 216
discontinuous rows and
columns 41
disk space, effect on Dynamic
Calculation 129
display
options 50
order of columns,
drill-through 207
Display page (Essbase Options
dialog box) 18, 187
Display Unknown Member
option 114, 117
displaying data 7, 26
distributed sheets
See cascading sheets
double-clicking
defined 15
enabling
for drilling 16
for linked object

browsing 156, 165, 199, 204
downloading Acrobat Reader vi

drag-and-drop operations 36
drag, defined 15
drill
by double-clicking 16
down on attributes 30, 31
down on consolidations 10
Formula Fill 117
retain formulas during 117
to less detail 32
drill-through
accessing 184, 194
cells, defining styles for 194
described 183
installing 186
multiple reports 184
requirements 186
sample
database 192
drill-through report 193

drill-through (continued)
sample (continued)
file 194, 195
styles for cells 185
tutorial guidelines 187
Drill-Through Wizard
dialog box 205
introductory screen 205
duplicating sheets
See cascading sheets
Dynamic Calculation members,
applying styles to 129, 130
Dynamic Time Series
defined 131
specifying latest time
period 132, 134

E

Edit Cell Note dialog box 158
Edit menu 28
Edit URL dialog box 161
editing
cell notes 157
linked files 157
URLs 159, 161
editing in cells 15
Enable Hybrid Analysis option in
Zoom page (Essbase Options
dialog box) 19
enabling
FlashBack setting 28
mouse actions 15, 156, 165
Navigate Without Data 44
environment (computing) v
Essbase
API 5
architecture 4
Cascade Options dialog box 171
computing environment v
connecting to
See connecting
Disconnect dialog box 91
disconnecting from. See
disconnecting 91
Member Selection dialog
box 83, 89
Member Selection dialog box,
from Query Designer 69
menu 13
migration information 1
Options dialog box 18, 97, 187
starting a session 13
System Login dialog box 23, 95
upgrades 1

Essbase Integration Server 6, 183

Essbase Integration Server
drill-through
See drill-through
EssCell function 124
error messages 128
syntax 125
exchange rates 177
Execute button 205
executing drill-through reports
expanding data views
See drill down
expanding formulas when
drilling 118
external files 146

F

files
accessing linked 156
destinations
cascaded sheets 172
linking to data cells 147
sample for tutorial vii, 95
filtering data 102
filters
operators 212
with drill-through 215
Find Member dialog box 85
finding members 82, 85
FlashBack command 27
font
formats 52
style list 53
Font dialog box 52
forced logouts 92
formatted sheets
pivoting in 116
retrieving data into 112
formatting
data cells
linked objects
read-only 56
read/write 56
dimension members 54
displaying aliases 59

150, 165

200

displaying aliases and names 61

Dynamic Calculation
members 129

enabling styles 53

linked object cells 150, 165

options for cascaded sheets

parent members 51

repeating member labels 62

spreadsheets 50

text and cell styles 57

Formula Fill option 118, 120
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Formula Preservation mode
Formula Fill 117
pivoting in 116
restrictions with 116, 117
Retain on Keep and Remove
Only 117
Retain on Retrieval 114, 117
formulas
EssCell 124
expanding when drilling 118
in cells 113, 117
preservation
effects on other
operations 117
enabling 114, 117
restrictions with 116
free-form reporting
entering generation and level
names in 143
in Advanced Interpretation
mode 136
in Free-Form mode 138
retrieving data 135
Free-Form retrieval mode 138
guidelines 139
functions
See macro functions

G

generations
defined 10
entering names in
spreadsheet 143
Global page (Essbase Options dialog
box) 16

H

Help buttons 14
Help, accessing 14
Hybrid Analysis
Enabling in the Zoom page
(Essbase Options dialog
box) 19
Hyperion Essbase
intended audience 3
products of 5
Hyperion Essbase Spreadsheet
Add-in
accessing drill-through from 194
logging data updates 169
retrieval cursors 26
starting 13
users, described 4
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in-cell editing 15
installation, drill-through 186
Integration Server drill-through

See drill-through
Internet, linking cells to URLs 153
Interntl sample database 177

K

Keep Only command
described 40
in Formula Preservation
mode 117

L
labels
applying styles 54
displaying with aliases 61
entering in spreadsheet 136, 139
member names
See member names
repeating 62
LAN
See networks
Latest Time Period option 132
latest time period, specifying 131
levels
cascading by 171
defined 10
drilling down 33
drilling in 33
entering names 143
linked objects
partitions
See linked partitions
reporting objects
See linked reporting objects
Linked Objects Browser dialog
box 163, 165, 199, 204
LROs 147
Linked Objects command 147, 151,
153
linked partitions
access privileges 166
accessing from spreadsheet 165
cells, applying styles 165
Linked Reporting Objects
accessing from spreadsheet 155
applying styles 150
cell notes 151
creating 146
external files 147
URLs 153
linking
cell notes 151
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linking (continued)
external files 147
partitions 165
URLs to data cells 153
list, cascaded sheets 174
local area network
See networks
Lock command 167
locking data blocks, with multiple
users 167
logging
off of Essbase
See disconnecting
on to a relational data
source 204
on to Essbase
See connecting
on to Essbase Integration
Server 204
logging data updates from
spreadsheet 169
logical operators 86
logouts, forced or auto 92
Lotus 1-2-3
clearing formats 58
mouse actions 15
sample tutorial files 95
status bar 14

M

macro functions

EssCell 124

Spreadsheet Toolkit vi, 5, 14
main menu (Essbase) 13
manual calculation mode 128
Member Information dialog box 84
member names

aliases for 59

alternate

See aliases

applying styles 51

displaying with aliases 61

entering in spreadsheet 136, 139

formatted sheets 112

indenting 10

repeating 62

with EssCell function 125
Member Preview dialog box 88
Member Retention option 33
Member Selection command 83
Member Selection dialog box 83
Member Selection Preview dialog

box 72
Member Selection, with Query
Designer 69



members
adding 69
aliases for 59
ancestors 10
applying styles 51, 54
children 9
collapsing 32
defined 9
deleting 43
descendants 10
deselecting 90
drilling down on 29, 30
drilling up on 32
Dynamic Calculation 129
Dynamic Time Series 131
finding 82, 85
generations 10
levels 10
names
See member names
parents 9
retaining 40
selecting 69, 82
siblings 9
menu, Essbase 13
messages (Essbase)
database calculation status 170
display options 117
EssCell 128
unknown member 114
migrating to release 6 1
missing values
suppressing 48
suppressing disabled 118
missing values, suppressing
in cascaded sheets 174
unavailable 118
Mode page (Essbase Options dialog
box) 19, 100, 117
money
See currency conversions
mouse actions, enabling 15
moving
rows and columns
See pivot
through worksheets 44
multidimensional databases
See databases
multiple filter conditions, with
drill-through 213

N

Named Pipes protocol 5

names

alternate
See aliases

applying styles 51
displaying with aliases 61
entering generation 143
entering level 143
repeating 62

Navigate Without Data

command 44, 47

nested columns or rows 29

networks 5

Next Level option 33, 171

nonadjacent cells 41

notes, linking to data cells 151

null values 125

numeric values, preserving 113

O

Objects product 6
ODBC clients 5

OLAP
defined 3
server
See server

online analytical processing 3
online help

displaying for spreadsheet 14
opening

Essbase 13
operating systems 4
operators, comparison 82, 104
options

Cascade 171

Display 18, 97, 187

Global 16, 20, 100, 191

Mode 19, 99, 117, 189

settings for advanced tutorial

settings for basic tutorial 18

settings for drill-through

tutorial 187

Style 51

Zoom 19, 33, 98, 188
Options dialog box 18, 187
OR operators 82
Order By dialog box 210
ordering

columns, drill-through 207

rows, drill-through 208
outlines

consolidations 10

described 7

dimensions 9

Dynamic Calculation

members 129

outlines (continued)
Dynamic Time Series
members 131
members 9
output, cascaded sheets 171
overlapping styles 57

P

parent members
applying styles to 51
defined 9
Partitioning product
See linked partitions

partitions

See linked partitions
passwords

changing 25

entering 96
pattern matching 86
pivot
asymmetric reports and 112
by dragging 36
described 15, 35
effect on text 113
formatted sheets and 116
formula preservation and 116
rows or columns 35, 112
unavailable 113
without retrieving data 45
Pivot command 35
power loss 92
preferences
See options
preserving formulas 114, 121
primary mouse button 15
printer destination, cascaded
sheets 172
programming interface 5

Q

queries
applying styles 78
creating 66
defining 65
deleting 78
retrieving 65
saving 74

Query Designer
applying option settings 81
connecting to multiple
databases 80
creating queries 67
data filtering panel 103
data sorting panel 107
filtering data 102
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Query Designer (continued)
hint panel 65
layout panel 68
messages 110
messages and confirmations 78
navigation panel 65
properties panel 65
save as query dialog box 74
sorting data 107

R

read-only cells 57
read /write cells 57
relational data source 204
relational databases, accessing with
drill-through 183
remote databases
See linked partitions
Remove Only command
described 43
in Formula Preservation
mode 117
Remove Unselected Groups
option 118
removing
See deleting
Repeat Member Labels option 62

report script commands 139, 141
reports
ad hoc 25, 116

ad hoc currency 180
asymmetric 110
creating multiple 171
formatted 112
free-form 135
methods of generating v
saving 91
reports, creating
ad hoc 25, 180
Cascade 171
Member Selection 82
methods v
Query Designer 65
reports, drill-through
accessing 194
customizing 185, 201
disconnecting from 216
executing 200
selecting to view or
customize 200
restoring database views 27
restrictions, with Formula
Preservation 117
Retain on Keep and Remove Only
option 118

232

Retain on Retrieval option
disabled 118
enabled 114, 117
Retain on Zooms option 118, 120
retaining
data subsets 40
formulas 113
when drilling 117
when retaining data 117
when retrieving 114, 117
selected members 40
Retrieve & Lock command 167
Retrieve command 26
retrieving
Advanced Interpretation mode
and 136
canceling 27
conditional 102
currency conversion 177
cursors 26
data 23
Dynamic Calculation
members 129
formula preservation and 117
Free-Form mode and 139
functions 124
increasing speed 58, 111, 121,
129
into asymmetric reports 110
into columns 30
into formatted sheets 112
rules for 113
into rows 30
less detail 32
modes 136
more detail 28
performance impact 58, 111, 129
range of cells 121
retaining formulas and 114, 117
selected cells 121
starting process and 25
suppressing data and 44
reverting to previous database
view 27
rows
blank 112
deleting during pivot 112
displaying as columns 35
displaying selected 40
filtering by 103
keeping discontinuous 41
nested 29
pivoting 35
removing selected 43
retrieving into 30
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rows (continued)
sorting within 108
suppressing values in 48, 174

S

sample
databases
connecting to 24, 177
described i, 22, 177
databases, in drill-through 192
files for tutorial, location 95
Sample Basic
connecting to 24
described 22
Sample directory 95
Save As command 91
Save command 91
saving
queries 74
worksheets 91
secondary mouse button 15
select (defined) 15
Select Calc Script option 170
Select Columns and Display Order
dialog box 207
Select Data Filters dialog box 211
Select Data Sort Order dialog
box 208
Select Drill-Through Report dialog
box 200, 205
Select Filter Values from the List
dialog box 212, 213
selecting
cells to keep 40
cells to remove 43
latest time period 131
members 82
nonadjacent cells 41
range of cells for retrieval 121
Send command 167
sending
data to server 167
log file 169
server
changing password 25
client-server environment 4
connecting to 24, 96
described 4
disconnecting from 91
Essbase Integration Server 6,
183
Essbase OLAP, described 4
logging updates to 167
migrating to release 5, with
client 1



server (continued)
name 24, 96
on network 5
sending data to 167
Set Filter on Column dialog
box 211
shared members, applying styles
to 52
sheet destination, Cascade
option 172
sheets
See worksheets
shortcuts, mouse actions 15
siblings (defined) 9
sort order
with drill-through 208
with Query Designer 107
sorting criteria 102
Spreadsheet Toolkit product 5
spreadsheets
applying styles 50
cascading 171
creating multiple 171
data update log file 169
described 6
displaying aliases 59, 61
displaying member names 61
distributing 171
drilling options 33
global options 16, 28, 117
mode options 117, 136
preserving formulas 117
repeating member labels 62
retrieving data 23
saving 91
setting options 18
style options 50
suppressing missing and zero
values 48
zoom options 33
SQL Interface 5
starting
data retrieval 26
drill-through 194
Hyperion Essbase 13
Hyperion Essbase Spreadsheet
Add-in 13
status bar, enabling and
disabling 14
status of database connections 164
Style page (Essbase Options dialog
box) 51
styles
applying
to data cells 56

styles (continued)
applying (continued)
to dimension members 54
to dimensions 54
to drill-through cells 194
to linked partition cells 165
to linked reporting object
cells 150
to members 51
to parent members 51
to Query Designer results 81
to shared members 52
clearing 58
defining 51
hierarchy of 57
overlapping 57
removing 58
selecting members 52
stored in ESSBASE.INI 56
turning off 58
turning on 53
Subset dialog box 86, 87
subsets
defining members 86
removing 43
retaining 40
substitution variables
suppressing
data retrieval 44
disabled 118
missing and zero values 48
underscore characters 48
symmetric reports 110
system administrator 3
system failure 92

T

table of contents, with Cascade 174
TCP/IP protocol 5
terminating database connections
See disconnecting
termination, abnormal 92
text
entering free-form 136
formatting 52
hierarchy of styles 57
pivoting
See pivot
preserving formatted 113
time periods 131
title members, with drill-down 30
to-date calculations, specifying 131
tracking data updates 169
transaction-level data, accessing with
drill-through 183

134, 135

transparent partitions
See linked partitions
transport protocol 5
tutorial
basic tasks 11
guidelines 21
preparing for 17

U
UDA
See user-defined attributes
underscore characters,
suppressing 50
Undo command
See FlashBack command
undoing actions 27
Unlock command 167
unlocking data blocks 167
up-to-date calculations 131
Update Mode 167
updating
data 167
log file 169
upgrading 1
URLs
accessing linked 159
editing 161
length limits 155
linking to data cells 153
Use Aliases option 59
Use Both Member Names and
Aliases option 61
Use Sheet Options with Query
Designer option 81
Use Styles option 53
User-Defined Attributes 86
username, entering 96
users 4

V2.x mode 139
VBA functions vi

viewing
active connections 164
aliases 59

aliases and names 61
data in spreadsheet 25
Dynamic Calculation
members 129
Essbase menu 13
fewer members
See drill
linked partitions 165
linked reporting objects 155
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viewing (continued)

more members
See drill

multidimensional data 7
online help 14
repeated member labels 62
spreadsheet without data 44
styles 53

views, restoring 27

Visual Basic for Applications
See VBA functions

visual cues
See styles

w

Web resources, linking to data
cells 153
wildcard characters 85
Within Selected Group option 34,
111
worksheets
formatting 50
navigating without data in 44
World Wide Web, linking to data
cells 153

X

Xchgrate sample database 177

Z

zero values
suppressing 48, 50
suppressing disabled 118
Zoom commands, customizing 33
Zoom In command
drilling down options 28
selecting levels 33
Zoom Out command, drilling up
options 32
Zoom page (Essbase Options dialog
box) 19, 33
Enable Hybrid Analysis
option 19
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Contacting IBM

If you have a technical problem, please review and carry out the actions
suggested by the product documentation before contacting DB2 OLAP Server
Customer Support. This guide suggests information that you can gather to
help DB2 OLAP Server Customer Support to serve you better.

For information or to order any of the DB2 OLAP Server products, contact an
IBM representative at a local branch office or contact any authorized IBM
software remarketer.

If you live in the U.S.A., you can call one of the following numbers:
* 1-800-237-5511 for customer support
+ 1-888-426-4343 to learn about available service options

Product Information

If you live in the U.S.A., then you can call one of the following numbers:

* 1-800-IBM-CALL (1-800-426-2255) or 1-800-31BM-OS2 (1-800-342-6672) to
order products or get general information.

* 1-800-879-2755 to order publications.

http://www.ibm.com/software/data/db2/db2olap/
The DB2 OLAP Server World Wide Web pages provide current DB2
OLAP Server information about news, product descriptions, education
schedules, and more.

http://www.ibm.com/software/data/db2/db2olap/library.html
The DB2 OLAP Server Technical Library provides access to frequently
asked questions, fixes, books, and up-to-date DB2 technical
information.

Note: This information may be in English only.

http://www.elink.ibmlink.ibm.com/public/applications/
publications/cgibin/pbi.cgi The International Publications ordering
Web site provides information about how to order books.

http://www.ibm.com/education/certify/
The Professional Certification Program from the IBM Web site
provides certification test information for a variety of IBM products.

Note: In some countries, IBM-authorized dealers should contact their dealer
support structure instead of the IBM Support Center.
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