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Preface

Purpose

This guide provides all the information that you need to use the IBM DB2
OLAP Server Spreadsheet Add-in for Microsoft Excel. It explains the features
and options and discusses the concepts, processes, procedures, formats, tasks,
and examples that you need to use the software.

IBM DB2 OLAP Server Version 8.1, known as Essbase 6.5 in this guide, is an
online analytical processing (OLAP) solution that satisfies the complex
calculation requirements of financial, accounting, and marketing professionals.
Essbase operates in a client-server computing environment on a local area
network (LAN). In this environment, multiple users can use their desktop
computers to retrieve and analyze centralized data.

You can create reports from the data residing on the Essbase server in several
ways:
v Generate database reports through a spreadsheet interface, called Essbase

Spreadsheet Add-in, as explained in this guide.
v Use Essbase Application Manager Report Writer to create a report script

and run a report. For more information, see the Database Administrator’s
Guide.

v Use Essbase Application Programming Interface (API) to create and run
database reports. For more information, see the Essbase API Reference.

v Use reporting tools, such as Hyperion Reporting for Essbase.

Audience

This guide is for Essbase end users who are responsible for some or all of the
following tasks:
v Starting Essbase and connecting and disconnecting from Essbase databases
v Retrieving data from a database into a worksheet
v Drilling down, drilling up, and navigating through a worksheet to analyze

and arrange data from multiple viewpoints
v Working with linked reporting objects and linked partitions
v Updating data on the Essbase server
v Using the worksheet to load and calculate data in the database
v Creating multiple sheets from data
v Working with currency conversions

© Copyright IBM Corp. 1998, 2002 v



Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Essbase Spreadsheet Add-in.
This document contains the following information:
v Chapter 1, “Introducing Release 6.5” on page 1 provides information on

migrating from previous versions of Essbase to Release 6.5 and lists all new
features and enhancements.

v Chapter 2, “Introducing Essbase” on page 3 introduces you to basic concepts
of retrieving and manipulating data through the spreadsheet interface.

v Chapter 3, “A Basic Essbase Tutorial” on page 11 provides a step-by-step
tutorial of basic data navigation, ad hoc retrieval, and reporting techniques.

v Chapter 4, “An Advanced Essbase Tutorial” on page 97 describes advanced
reporting and retrieval techniques for users that need special reports or
formatted data views.

v Chapter 5, “Using Drill-Through” on page 185 provides a brief overview of
the Essbase Integration Services drill-through product.

v The Index contains a list of terms and their page numbers. Select or look up
an index entry to view the page to which the entry refers.

Note: The Essbase Spreadsheet Add-in online help provides a comprehensive
section on Essbase Spreadsheet Toolkit. This section enables you to
customize and automate your use of Essbase by using Excel macros
and Visual Basic for Applications (VBA) functions. For more
information on the Essbase Spreadsheet Add-in online help, see
“Accessing Online Help” on page 18.

The Spreadsheet Add-in User’s Guide for Excel is provided in the
ibm\db2olap\docs\pdf directory in .pdf format for online viewing and
printing in Adobe Acrobat Reader (Release 3.0.1 or higher). The .pdf file is
named essexcel.pdf. You can download Adobe Acrobat Reader from the
Essbase CD-ROM or from http://www.adobe.com. On the Essbase CD-ROM,
the Acrobat Reader executable file is located in the Adobe directory under the
appropriate platform and language-version subdirectories. To install Adobe
Acrobat Reader, launch the executable file, follow the prompts, and provide
the information requested.

Sample Databases and Files

This book provides tutorial steps that are based on sample databases and files
that are provided with the Essbase server software. You use the Sample Basic
database for most tasks in Chapter 3, “A Basic Essbase Tutorial” on page 11
and Chapter 4, “An Advanced Essbase Tutorial” on page 97. You use a sample
Essbase Currency Conversion application for the section on currency
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conversion. See Chapter 4, “An Advanced Essbase Tutorial” on page 97 For
information on the Sample Basic database, see Chapter 3, “A Basic Essbase
Tutorial” on page 11.

In addition to these sample applications and databases, you also use several
sample Excel files in the advanced tutorial in Chapter 4, “An Advanced
Essbase Tutorial” on page 97. The individual at your organization who installs
the server is responsible for making these applications, databases, and files
available to you. Contact the Essbase system administrator for more
information.

Related Documentation

When you licensed Hyperion Essbase, you received the following printed
documentation:
v The Installation Guide, which shows you how to install and configure the

Essbase server, Essbase Spreadsheet Add-in, Essbase Application Manager,
Essbase SQL Interface, Essbase API, Runtime Client, and sample
applications.

v The New Features booklet, which describes the new features that have been
added for this release of Hyperion Essbase.

In addition to the printed documentation and this Spreadsheet Add-in User’s
Guide for Excel, you have access to the following online documentation:
v The Documentation Roadmap, which lists all the Essbase documentation and

tells you how to access the online information.
v The Quick Path Card, which provides an overview of the tasks involved in

creating, using, and maintaining Essbase databases.
v The online Database Administrator’s Guide in the docs directory, which

explains the architecture of Essbase, how to design databases, how to
design calculations, how to set up Essbase security, how the database is
stored, and how to optimize Essbase.

v The Application Manager Online Help file, which explains how to use the
Application Manager user interface.

v The Technical Reference in the docs directory, which lists and describes
Essbase functions, calculation commands, report commands, ESSCMD
commands, and configuration file (.cfg file) settings.

The Spreadsheet Add-in User’s Guide for Lotus 1-2-3Spreadsheet Add-in User’s
Guide for Excel, which explains how to use Essbase Spreadsheet Add-in
features with Microsoft ExcelLotus 1-2-3. for Windows. This guide is provided
in the \ibm\db2olap\docs\pdf directory in .PDF format for online viewing
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and printing in Adobe Acrobat Reader (Version 3.0.1 or later). Adobe Acrobat
Reader is provided on the Essbase CD-ROM, and can also be downloaded
from http://www.adobe.com.
v The Essbase Spreadsheet Add-in online help files, which explain how to use

Essbase Spreadsheet Add-in, and provide all the spreadsheet macros and
VBA functions.

v The API Reference, which lists and describes programmatic functions
available through the Essbase API, and provides information to help you
start programming with these functions.

v The Essbase SQL Interface Guide, which contains information on how to set
up systems to load data by means of Essbase SQL Interface. This guide is
provided in the \ibm\db2olap\docs\pdf directory in .PDF format for online
viewing and printing in Adobe Acrobat Reader (Version 3.0.1 or later).
Adobe Acrobat Reader is provided on the Essbase CD-ROM, and can also
be downloaded from http://www.adobe.com.

v The Adminstration Services Online Help which you can access by launching
Essbase Administration Services and clicking Help in the main menu.

Accessing Hyperion Documentation

All documentation is accessible from the following locations:
v You can access online documentation from the Information Map, an HTML

file. To open the Information Map, launch the essdocs.htm file located in
the ARBORPATH/docs directory.

v Online help is accessible from the Spreadsheet Add-in. Start the product
and click the Help button or menu command.

v The DB2 OLAP Server Web site is located at:
www.ibm.com\software\db2\db2olap\library.html

Online Help

To access online help, click the Help button in any Essbase dialog box or
select Essbase Help from the Spreadsheet Help menu.

To print an online help topic, display the topic and select File > Print, or
right-click and select Print from the pop-up menu.

Note: You must have first installed HTML documentation to access it.

Online Guides

Online guides are electronic versions of printed documentation.
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To display an online guide, start Adobe Acrobat Reader, and then open one of
the Essbase .pdf files located in your \ibm\db2olap\docs\pdf directory.

Conventions

The following table shows the conventions that are used in this document:

Table 1. Conventions Used in This Document

Item Meaning

Brackets [ ] In examples, brackets indicates that the enclosed elements
are optional.

Bold Bold text indicates words or characters that you type
exactly as they display on the page. Bold in procedural
steps highlight major interface elements.

CAPITAL LETTERS Capital letters denote commands and various IDs.
(Example: CLEARBLOCK command)

Example text Courier font indicates that the material shown is a code
or syntax example.

Ctrl + 0 Keystroke combinations shown with the plus symbol (+)
indicate that you should press the first key and hold it
while you press the next key. Do not type the + symbol.

Courier italics Courier italic text indicates a variable field in command
syntax. Substitute a value in place of the variable shown
in Courier italics.

Italics Italics in a product-related term in the body of a book
indicates that the term is included in the glossary of the
book.

Ellipses (...) Ellipsis points indicate that text has been omitted from an
example.

Mouse orientation This document provides examples and procedures using a
right-handed mouse. If you are using a left-handed
mouse, adjust the procedures accordingly.

Menu options Options in menus are shown in the following format:
Menu name > Menu command > Extended menu command

For example: File > Desktop > Accounts

n, x The variable n indicates that you must supply a generic
number; the variable x indicates that you must supply a
generic letter.
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Chapter 1. Introducing Release 6.5

This chapter provides compatibility information for Essbase Release 6.5 and
previous releases of Essbase, including migration information and new feature
descriptions and enhancements. It contains the following sections:
v “Migrating to Release 6.5” on page 1
v “What’s New in Release 6.5”

Migrating to Release 6.5

As you migrate (upgrade) from previous releases of Essbase to Release 6.5
(DB2 OLAP Server Version 8.1), keep in mind that Release 6.5 of Essbase
Spreadsheet Add-in is designed to work with Release 6.5 of the Essbase
server. If the Essbase system administrator upgrades the Essbase server to
Release 6.5, Release 5.x of Essbase Spreadsheet Add-in works on only a
limited basis. Upgrade to Essbase Spreadsheet Add-in for Release 6.5 as soon
as possible.

Read the Installation Guide for detailed information about migrating from
previous releases of Essbase.

What’s New in Release 6.5

Hybrid Analysis
With Hybrid Analysis, Essbase supports retrieval of data from a external
relational data source. By enabling Hybrid Analysis in Essbase Integration
Services, a portion of database cell values are computable from an external
relational source, instead of being loaded into an OLAP Server database.
Hybrid Analysis allows access to lower level data that is too large to load into
an OLAP Server database.

You need to license Essbase Integration Services to build Hybrid
Analysis-enabled metaoutlines.

Support for Negative Numbers in Filter Criteria in EQD
Essbase Query Designer (EQD) provides the ability to design queries with
filtering criteria. With Release 6.5, EQD supports the use of negative numbers
in the filtering criteria.

Enhanced Keyboard Accessibility in EQD
Keyboard accessibility for EQD is greatly enhanced in Release 6.5. When
launching EQD, focus is set to the first item in the tree in the navigation
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panel. From there, users can access most EQD functionality using the
keyboard. For more information see the Spreadsheet Add-in online help on
EQD keyboard shortcuts.
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Chapter 2. Introducing Essbase

Essbase is multidimensional database software that is optimized for planning,
analysis, and management reporting applications. Essbase uniquely blends an
innovative technical design with an open, client-server architecture. Essbase
enables you to extend your decision support systems beyond ad hoc queries
and reports on historical performance to dynamic, operational systems that
combine historical analysis and future planning. By consolidating and staging
historical and projected data for detailed analysis, you gain perspectives about
your business that enable you to take appropriate actions.

Essbase provides both power and flexibility. Thus, it can be used for a broad
range of online analytical processing (OLAP) applications including the
following:
v Budgeting
v Forecasting and seasonal planning
v Financial consolidations and reporting
v Customer and product profitability analysis
v Price, volume, and mix analysis
v Executive information systems (EIS)

Essbase enables you and others in your organization to share, access, update,
and analyze enterprise data from any perspective and at any level of detail
without learning new tools, query languages, or programming skills.

Typical Users of Essbase

Essbase is designed for use in many different applications. Financial analysts
have found Hyperion Essbase to be invaluable in budget analysis, currency
conversion, and consolidation. Cost accountants apply the powerful
capabilities of Essbase to evaluate allocation and elimination scenarios.
Product managers and analysts use Essbase to plan and analyze multiple
product lines and distribution channels. Essbase can also be used as a
repository database for spreadsheet data. Anyone who uses a spreadsheet is a
potential user of Essbase. Because Essbase is applicable to such a broad
variety of environments, individuals using it at your organization may fill one
or more roles in implementing and running applications. This guide refers to
specific roles by three titles. However, in actuality, a role may be performed
by one person or by several people working collaboratively.
v Essbase system administrator. The Essbase system administrator typically has

experience in networking, installing software packages, and administering
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system functions. In addition to installing the Essbase software, the Essbase
system administrator may also set up Essbase user accounts, set up the
security system, and maintain the Essbase server.

v Application designer. The application designer sets up the Essbase database,
creates the database outline, and develops calculation and report scripts.
The responsibilities of the Essbase system administrator and the application
designer may overlap in some areas. The application designer has probably
developed spreadsheet or database applications and understands the
operational problems and the tools being employed to solve them.

v User. The user interacts with Essbase databases through spreadsheets, using
Microsoft Excel for Windows or Lotus 1-2-3. Users are typically analysts
and managers who use spreadsheet programs as their primary tool for
viewing and analyzing data.

Components of the Client-Server Environment

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of a local area
network (LAN). The PC workstation acts as a client by requesting data from
the server. The server processes the request and returns the desired result to
the client.

Essbase is built as a client-server system. System performance and multiuser
capabilities are greatly enhanced in the Essbase client-server environment.

The Server
Essbase server is a multidimensional database that supports analysis of an
unlimited number of data dimensions and an unlimited number of members
within these dimensions. Developed using a true client-server architecture, all
data, the database outline, the calculations, and the data security controls
reside on the Essbase server.

The Essbase server operates on Windows 98, Windows NT 4.0, Windows Me,
Windows 2000, and UNIX operating systems.

Essbase Spreadsheet Add-in
Essbase Spreadsheet Add-in is a software program that merges seamlessly
with Microsoft Excel and Lotus 1-2-3. After Essbase is installed, a special
menu is added to Excel. The menu provides enhanced commands such as
Connect, Pivot, Drill-down, and Calculate. Users can access and analyze data
on the Essbase server by using simple mouse clicks and drag-and-drop
operations. Essbase Spreadsheet Add-in enables multiple users to access and
update data on the Essbase server simultaneously.
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The Network
Essbase runs on PC-based LANs that support the Named Pipes or TCP/IP
protocol.

Note: Supported network environments and technical requirements are
discussed in detail in the Installation Guide, which is included with the
Essbase server package.

Essbase Application Products

Several optional products, designed to extend and enhance the scope of OLAP
applications, can be addressed using the Essbase server. The following
sections describe these products.

Essbase Spreadsheet Toolkit
Essbase Spreadsheet Toolkit includes over 20 macro and Visual Basic for
Applications (VBA) functions that enable you to build customized Microsoft
Excel and Lotus 1-2-3 applications. The applications incorporate Essbase
commands. Commands such as EssCascade, EssConnect, and EssDisconnect
provide all of the functionality of their corresponding Essbase menu
commands. For more information, see the Essbase Spreadsheet Add-in online
help.

Essbase Partitioning Option
Essbase Partitioning option enables you to define areas of data that are shared
or linked between data models. Partitioning can affect the performance and
scalability of Essbase applications. Partitioning provides more effective
response to organizational demands, reduced calculation time, increased
reliability and availability, and incorporation of detail and dimensionality. For
more information, see “Accessing Linked Partitions” on page 166.

Essbase Structured Query Language Interface
Essbase SQL Interface enables access to PC and structured query language
(SQL) relational databases by making the Essbase server operate as an open
database connectivity client. Using Essbase SQL Interface, data can be moved
easily from these diverse corporate data sources into the Essbase server for
user access and analysis. For more information, see the Essbase SQL Interface
Guide.

Essbase Application Programming Interface
Essbase Application Programming Interface (API) enables application
developers to create custom applications quickly by using standard tools
while taking advantage of the robust data storage, retrieval, and manipulation
capabilities of Essbase. Essbase API supports Visual Basic and C. For more
information, see the API Reference.

Chapter 2. Introducing Essbase 5



Essbase Currency Conversion
Essbase Currency Conversion translates, analyzes, and reports on foreign
financial data. Any exchange rate scenario can be modeled, and you can even
perform ad hoc currency conversions of data directly from the spreadsheet.
The Currency Conversion product is compliant with Financial Accounting
Standards Board 52 (FASB52). For more information, see “Working with
Currency Conversions” on page 177.

Essbase Integration Services
Essbase Integration Services works with Essbase, Microsoft Excel, and Lotus
1-2-3. Essbase Integration Services is a suite of tools and data integration
services that serve as a bridge between relational data sources and the Essbase
server. Integration Server drill-through is one of the tools of Essbase
Integration Services. Using Integration Server drill-through, you can view and
customize spreadsheet reports that display data retrieved from relational
databases. For more information, see Chapter 5, “Using Drill-Through” on
page 185

Hyperion Objects
Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in
Essbase servers. You can combine objects with other controls in a visual
design environment to construct new programs.

The Multidimensional Database

The Essbase multidimensional database stores and organizes data. It is
optimized to handle applications that have large amounts of numeric data
and are consolidation-intensive or computation-intensive. In addition, the
database organizes data in a way that reflects how the user wants to view the
data.

Definition of Multidimensional
A dimension is a perspective or view of a specific dataset. A different view of
the same data is an alternate dimension. A system that supports simultaneous,
alternate views of datasets is multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on.
Each dimension contains additional categories that have various relationships
one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:
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An Essbase application contains an unlimited number of dimensions, so you
can analyze large amounts of data from multiple viewpoints.

Database Outlines

Understanding the database outline is the key to understanding Essbase. To
define a multidimensional database, you design its database outline. The
database outline contains the database organization (structure), the database
members, and the database rules, as shown in Figure 2:

Figure 1. Two-Dimensional Representations of Data in a Worksheet
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Note: The application designer or Essbase system administrator usually
creates the database outline. For more information on creating the
database outline, see the Database Administrator’s Guide.

The components of the database outline are the following:
v Dimensions
v Members
v Attributes
v Formulas
v Aliases

Figure 2. Essbase Database Outline
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v Consolidations

Refer to the following sections for descriptions of the outline components.

Dimensions
Dimensions are the most basic categorical definitions of data within the
database outline. You need at least two dimensions to make any meaningful
reference to data; for example, a time dimension and an accounts dimension.
Other dimensions may categorize products, markets, and scenarios. Using
dimensional organization, you can define any consolidation structure or any
slice of data that is relevant to the application. Essbase supports an unlimited
number of dimensions.

Members
Members are the names of the elements within a dimension. A dimension can
contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Essbase use the following terms to describe
members.
v Parents. A parent is a member with a consolidation branch below it. For

example, in the illustration below, Qtr1 is a parent member because there is
a branch containing monthly members below it.

v Children. A child is a member with a parent above it. For example, Jan, Feb,
and Mar are children of the parent Qtr1.

Figure 3. Relationships Among Database Members
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v Siblings. A sibling is a child member of the same parent and on the same
branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not
a sibling of Jan, Feb, or Mar, however, because it has a different parent,
Qtr2.

v Descendants. A descendant is a member at any level below a parent. For
example, each member that falls in the Year branch is a descendant of Year.
The following members are all descendants of Year: Qtr1, Jan, Feb, Mar;
Qtr2, Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

v Ancestors. An ancestor is a member of a branch above a member. For
example, Qtr2 and Year are ancestors of Apr.

v Generations. The term generation describes the branch number of a member.
Generations count from the root of the tree (generation 1, which is the
dimension name) toward the leaf node.

v Levels. The term level describes the branch number of a member. Levels
count from the leaf node (level 0) toward the root (the dimension name).

Attributes
Attributes describe characteristics of data, such as the size and color of
products. Through attributes, you can group and analyze members of
dimensions based on their characteristics. Attribute dimensions must be
associated with base dimensions. For more information, see the Database
Administrator’s Guide.

Formulas
Each database member can have one or more formulas associated with it in
the database outline. For example, the Variance members of the Scenario
dimension, as shown in Figure 2, contain formulas. Formulas can be simple or
complex. For more information, see the Database Administrator’s Guide.

Aliases
Essbase supports alternative names, or aliases, for database members. Aliases
are useful when various labels are used for the same member in various
worksheets. One worksheet, for example, may refer to Cost_of_Goods_Sold as
COGS. Aliases also can be used for reporting in alternative languages or for
more formal output name sets, such as account numbers.

Consolidations
Consolidations in Essbase applications are defined by member branches. The
database outline determines consolidation paths. The determination is based
on the location of members within a dimension. Indentation of one member
below another indicates a consolidation relationship. Indenting members is
important for the drill-down capabilities in Essbase Spreadsheet Add-in. As
you navigate your way through data, you can drill down through levels of
consolidations. The database outline is the roadmap that determines the levels
of data navigation.
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Chapter 3. A Basic Essbase Tutorial

When you add Essbase Spreadsheet Add-in to Microsoft Excel, most Excel
operations remain unchanged; Essbase Spreadsheet Add-in simply adds a new
menu, a Essbase toolbar, and mouse shortcuts with which you can access the
Essbase server.

The tasks described in this tutorial are basic tasks. That is, these are tasks that
you probably use often when working with Essbase. Chapter 4, “An
Advanced Essbase Tutorial” on page 97 describes more advanced tasks. This
tutorial chapter contains the following sections:
v “Getting Acquainted with Essbase Spreadsheet Add-in” on page 11
v “Preparing to Begin the Tutorial” on page 20
v “Retrieving Data” on page 26
v “Pivoting, Retaining, and Suppressing Data” on page 38
v “Formatting the Worksheet” on page 53
v “Creating Queries Using Essbase Query Designer” on page 68
v “Deleting Queries” on page 80
v “Viewing Messages and Confirmations” on page 80
v “Accessing Help” on page 81
v “Selecting Members” on page 84
v “Saving and Disconnecting” on page 93
v “Moving on to Advanced Tasks” on page 95

Note: Each tutorial task builds upon the previous task. Therefore, tasks must
be completed in succession.

The examples used in this tutorial are based on the sample database (called
Sample Basic) that is included with the Essbase installation. Contact the
Essbase system administrator for information about accessing the Sample
Basic database or about accessing other databases on the Essbase server.

Getting Acquainted with Essbase Spreadsheet Add-in

This section provides the following information to help you get acquainted
with Essbase Spreadsheet Add-in:
v “Adding Essbase Spreadsheet Add-in” on page 12
v “Starting Essbase Spreadsheet Add-in” on page 12
v “Installing the Essbase Toolbar” on page 13
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v “Using the Essbase Toolbar” on page 14
v “Accessing Online Help” on page 18
v “Enabling Mouse Actions” on page 18

Adding Essbase Spreadsheet Add-in
If you manually update your environment settings or if you have removed
Essbase Spreadsheet Add-in from the Microsoft Excel environment, you must
use the Excel facility to add Essbase Spreadsheet Add-in into Excel. The
facility adds the Essbase menu to the Excel menu bar and points Excel to the
Essbase Spreadsheet Add-in file in the \Essbase\bin directory. This file is on
the hard drive of your PC, if that is where you installed Essbase Spreadsheet
Add-in, or on the network drive if that is where you set up your PC
operating environment to run Essbase Spreadsheet Add-in.

Note: essexcln.xll is the add-in file for Excel 97, Excel 2000, and Excel XP.
Adding Essbase Spreadsheet Add-in into Excel 97, Excel 2000, and
Excel XP modifies the Windows Registry. The Registry point to where
the Essbase Spreadsheet Add-in file is installed.

To add Essbase Spreadsheet Add-in to Excel:
1. In Excel, select Tools > Add-Ins.

Excel displays the Add-Ins dialog box.
2. Click the Browse button.

Excel displays the Browse dialog box.
3. Select the file essexcln.xll in the bin directory where you installed

Essbase Spreadsheet Add-in on your PC hard drive (if you installed
Essbase Spreadsheet Add-in there) or in the bin directory where the
Essbase system administrator installed Essbase Spreadsheet Add-in on a
network drive (if you set up your PC operating environment to run
Essbase Spreadsheet Add-in there).

4. Click OK twice to close the dialog boxes and start Essbase Spreadsheet
Add-in.
The Essbase startup screen is displayed.
If you do not see the Essbase startup screen or if your system does not list
the Essbase Spreadsheet Add-in menu options, see the Installation Guide for
troubleshooting information.

Starting Essbase Spreadsheet Add-in
Because Essbase Spreadsheet Add-in software for Excel is implemented as
anExcel add-in, you must start Excel from Windows to use Essbase
Spreadsheet Add-in software.
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You must open a worksheet before attempting to connect to the server. An
attempt to connect to the server without opening a worksheet results in an
error message.

To begin an Essbase session:
1. Start Excel.

After the Excel startup screen disappears, the Essbase startup screen is
displayed.
The menu should be displayed in the Excel menu bar. If you do not see
the menu, you may need to use the Excel add-in facility to add Essbase
Spreadsheet Add-in into Excel. For more information, see “Adding Essbase
Spreadsheet Add-in” on page 12.
The Essbase toolbar should also be visible. If you do not see the Essbase
toolbar, see “Installing the Essbase Toolbar” and “Using the Essbase
Toolbar” on page 14.

2. From the Excel menu bar, select Essbase to open the menu.

Note: If the Excel status bar is not displayed, you can display it by
selecting View > Status Bar.

Installing the Essbase Toolbar
Essbase Spreadsheet Add-in provides a convenient toolbar that displays
buttons for accessing most of the common Essbase commands without having
to open the Essbase menu. Prior to using the Essbase toolbar, you must install

Figure 4. The Essbase Menu
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the toolbar by opening an Excelfile that is provided as part of the default
Essbase installation. For more information on using the toolbar, see “Using the
Essbase Toolbar”.

To install the Essbase toolbar:
1. Start Excel.
2. Select File > Open.
3. From the \essbase\client\sample directory, open the esstoolb.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.
A blank worksheet opens.

Note: If you are using Excel 97, two dialog boxes may be displayed when
you open the esstoolb.xls file. If so, click the Enable Macros
button on the first dialog box, and click OK on the second dialog
box.

4. Select File > Close to close the esstoolb.xls file. You do not need to
modify or save the file.

You should not have to perform the toolbar installation procedure again
unless you delete the Essbase toolbar from the Toolbars dialog box in Excel. If
you delete the toolbar, perform the installation procedure again.

Note: If you have toolbars turned off in Excel, you do not see the Essbase
toolbar immediately. You must first enable toolbars. For more
information, see “Using the Essbase Toolbar”.

Using the Essbase Toolbar
Essbase Spreadsheet Add-in for Excel features a convenient toolbar that
displays buttons for accessing most of the common Essbase commands

Figure 5. esstoolb.xls File
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without having to open the Essbase menu. You can view a short description
of a button in a pop-up on the toolbar by moving your cursor over the
button.

Note: Before you can view the Essbase toolbar, you must install it. See
“Installing the Essbase Toolbar” on page 13.

To view the Essbase toolbar, select View > Toolbars > Essbase from the Excel
menu bar. A check box must be displayed next to Essbase in the menu.

Note: If you select the Essbase check box and click Delete, you must reinstall
the toolbar. See “Installing the Essbase Toolbar” on page 13 for
instructions.

The toolbar provides the following buttons:

Table 2. Essbase Toolbar

Button Purpose Description

Connect Enables you to connect to an Essbase
server. When you click the Connect
button on the toolbar, Essbase displays
the Essbase System Login dialog box.

Navigate with or without
data

Toggles the Navigate Without Data
feature, which tells Essbase to retrieve or
not to retrieve data when you perform
navigational operations, such as pivot,
zoom in, zoom out, keep only, and
remove only.

This button serves the same function as
the Navigate Without Data check box in
the Essbase Options dialog box (Global
tab).
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Table 2. Essbase Toolbar (continued)

Button Purpose Description

Retrieve Retrieves data into the active worksheet.
A retrieve request places data at the
beginning of the active worksheet. When
you click the Retrieve button, if you are
not already connected to an Essbase
server, the Essbase System Login dialog
box is displayed.
Tip: If you have mouse actions enabled,
you can retrieve data by double-clicking
the primary mouse button in any empty
cell in the worksheet. To enable
double-click support, select Essbase >
Options, select the Global tab, and select
the Enable Double-Clicking option. For
more information, see “Enabling Mouse
Actions” on page 18.

Keep only Retains only the selected member (the
active cell) or member range in the
worksheet. When you click the Keep
Only button, all unselected members are
removed from the worksheet.

Remove only Removes the selected member (the active
cell) or member range from the
worksheet. When you click the Remove
Only button, all unselected members are
retained in the worksheet.

Zoom in Retrieves and expands data from the
Essbase server according to the options
specified in the Essbase Options dialog
box.
Tip: If you have mouse actions enabled,
you can drill down on data by
double-clicking the primary mouse
button in the cell that contains the
member you want to expand. To enable
double-click support, select Essbase >
Options, select the Global tab, and select
the Enable Double-Clicking option. For
more information, see “Enabling Mouse
Actions” on page 18.

16 Spreadsheet Add-in User’s Guide for Excel



Table 2. Essbase Toolbar (continued)

Button Purpose Description

Zoom out Collapses the view according to the
options specified in the Essbase Options
dialog box in the cell that contains the
member that you want to collapse. To
enable double-click support for drilling
up, select Essbase > Options, select the
Global tab, and select the Enable
Double-Clicking option.

Open Essbase Query
Designer

Opens the Essbase Query Designer,
which makes it easy to define a page
orientation for dimensions and selected
database members. You can also save
queries for later use. Essbase Query
Designer is a new feature designed to
create report queries, view attributes, and
perform calculations based on attributes.

FlashBack Restores the previous worksheet view.

Set options Enables you to set display, zoom, mode,
style, and global options for the active
worksheet to customize the behavior of
Essbase Spreadsheet Add-in software.
When you click the Options button,
Essbase displays the Essbase Options
dialog box.

Select members Enables you to select members from the
multidimensional database outline. When
you click the Member Selection button,
Essbase displays the Essbase Member
Selection dialog box.

Attach linked objects Enables you to attach comments or files
to data cells. When you click the linked
objects button, Essbase displays the
linked objects browser dialog box.
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Accessing Online Help
Essbase Spreadsheet Add-in includes a context-sensitive online help system.
You access the Essbase Spreadsheet Add-in online help in one of three ways.
Which way you choose depends on the type of information that you need,
v Access the entire online help system for browsing or searching for information. To

access the entire help system, select Help Essbase> Essbase Help. After you
access online help, you can browse or search through the system to view
general information on Essbase Spreadsheet Add-in, Essbase command
descriptions, procedural information for completing tasks, Spreadsheet
Toolkit macros, and Visual Basic for Applications (VBA) function
descriptions.

v Access context-specific information from dialog boxes in Essbase Spreadsheet
Add-in. Each dialog box in Essbase Spreadsheet Add-in features a Help
button that accesses online help topics that are specific to the particular
dialog box. The buttons enable you to find the information you need
without having to search through the entire help system.

Note: The Essbase Spreadsheet Add-in online help also provides a
comprehensive section on Essbase Spreadsheet Toolkit, which enables
you to customize and automate your use of Essbase by using Excel
macros and VBA functions.

v Access information on a specific Query Designer function. Access What’s This?
Help in the Query Designer dialog box, and then click an item in the dialog
box to access information on that item.

Enabling Mouse Actions
The following terms are used throughout this guide to describe mouse
operations:
v Primary mouse button and secondary mouse button describe the buttons on a

two- or three-button mouse. Usually, right-handed users configure the left
mouse button as the primary button and the right mouse button as the
secondary mouse button. The primary mouse button is the one that you use
to start Windows applications, such as Excel; the secondary mouse button is
used for auxiliary operations. The term click refers to use of the primary
mouse button. The term right-click refers to use of the secondary mouse
button.

Figure 6. Excel Help Button

Figure 7. EQD Help Button
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v Select chooses the object that is under the cursor when you press and
release the primary mouse button. You can select a worksheet cell, for
example, by moving the cursor to the cell and pressing and releasing the
primary mouse button.

v Click (that is, both click and right-click) describes a quick press-and-release
action on a command object. You can click a button, for example, to execute
a command.

v Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example,
to start a Windows application.

v Drag describes a press, hold, and move action. You place the cursor on an
object, press a mouse button, hold the mouse button and move the object,
and release the mouse button when you reach your goal. For example, you
can highlight a range of cells in an Excel worksheet by dragging the cursor
over the cells.

Note: uses a drag operation called a pivot. A pivot requires use of the
secondary mouse button. To execute a pivot, you must press and
hold the secondary, rather than the primary, mouse button while
dragging the selection.

Essbase offers enhanced mouse actions in Excel. You can use the mouse to do
any of the following:
v Retrieve data
v Drill down and drill up on database members
v Pivot (move or transpose) data rows and columns
v Access linked reporting objects
v Access linked partitions

To enable double-clicking to retrieve, drill down, and drill up on Essbase data:
1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Global tab.
3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up
to less detailed data (secondary mouse button). When the double-clicking
option is enabled, the Excel in-cell editing feature is overridden.
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4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the Essbase
Spreadsheet Add-in online help.

Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:
v “Setting Essbase Options” on page 21
v “Following Guidelines During the Tutorial” on page 24
v “Reviewing the Sample Basic Database” on page 25

Figure 8. Essbase Options Dialog Box—Global Tab
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Setting Essbase Options
Before you begin the tutorial steps, make sure that the worksheet options are
set to the initial settings as illustrated in Figure 9 through Figure 12. If the
option settings are different, the illustrations presented in this chapter may
not match the worksheet view.

Note: For information about each option in the Essbase Options dialog box,
see the Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display of the Display tab matches the following illustration:

Figure 9. Initial Settings for Display Options

Chapter 3. A Basic Essbase Tutorial 21



4. Select the Zoom tab.
5. Select the appropriate check boxes and option buttons so that your

display of the Zoom tab matches the following illustration:

6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display of the Mode tab matches the following illustration:

Figure 10. Initial Settings for Zoom Options
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Note: If you are already connected to a Essbase database, the Essbase
Options dialog box also displays a Style tab. You can skip this tab
for now.

8. Select the Global tab.
9. Select the appropriate check boxes and option buttons so that your

display of the Global tab matches the following illustration:

Figure 11. Initial Settings for Mode Options
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Note: You should have already selected the appropriate boxes for Mouse
Actions, as described in “Enabling Mouse Actions” on page 18.

10. Click OK to save the settings for this session and close the Essbase
Options dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:
v Tasks that should not be performed as part of the tutorial are displayed in

gray boxes. These tasks are included only for your future reference. You can
find more information on these tasks in the Essbase Spreadsheet Add-in
online help.

Figure 12. Initial Settings for Global Options
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v You must be connected to the Sample Basic database during the tutorial. If
you are not connected to this database, the illustrations presented in this
chapter will not match the worksheet view.

v You can access many Essbase commands in any one of these ways:
– By selecting the command from the Essbase menu
– By clicking the appropriate button on the Essbase toolbar
– For the Zoom In and Zoom Out commands, by double-clicking either the

primary mouse or the secondary mouse button
v You must set the options in the Essbase Options dialog box as described in

“Setting Essbase Options” on page 21. If the option settings are different,
the illustrations presented in this chapter may not match the worksheet
view.

v After you change a worksheet option in the Essbase Options dialog box,
you must perform a retrieval or a drill-down operation to have the new
setting take effect.

v Be sure to follow each step in the tutorial. Each tutorial task builds upon
the previous task. Do not skip the final steps at the end of sections, because
these steps are often necessary to prepare you for the next tutorial task.

v If you make a mistake during the tutorial, you can select Essbase >
FlashBack to return to the previous worksheet view.

v The values in the Sample Basic database that represent ratios or percentages
are calculated to a very high level of precision (for example, 55.26162826).
In Excel, you can apply a cell format to control the number of decimal
places that are displayed in data values. For more information, see the
Excel documentation.

v The numeric values that are shown in the illustrations used throughout this
tutorial may not match the values stored in your database. The values
shown in these illustrations reflect a freshly loaded database.

v Some worksheet columns have been adjusted for clarity in the illustrations.
You do not need to change the width of columns in the worksheet to follow
the tutorial steps. The Adjust Columns option in the Essbase Options dialog
box (Display Tab) adjusts columns for you.

Reviewing the Sample Basic Database
The Sample Basic database that you use for the tutorial is based on a
hypothetical company in the beverage industry. The major products of the
company are various kinds of sodas. These products are sold in U.S. markets,
which are categorized by state and region. Financial data for the company is
collected monthly and is summarized by quarter and by year. The company
uses Essbase to calculate financial and accounting data, such as sales, cost of
goods sold, and payroll. The company tracks both actual and budget data, as
well as the variance and percent variance between the two.
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Retrieving Data

Now that you are more familiar with the Essbase environment, you can
connect to the Essbase server and start using Essbase and Essbase Spreadsheet
Add-in. The following section guides you through a typical Essbase session
where you connect to a database and retrieve data in various ways.

This section outlines the following basic retrieval tasks:
v “Connecting to a Database” on page 26
v “Changing a Password” on page 28
v “Retrieving Data from a Database” on page 28
v “Canceling a Data Retrieval Request” on page 30
v “Restoring the Previous Database View” on page 30
v “Drilling Down to More Detail” on page 31
v “Drilling Up to Less Detail” on page 35
v “Customizing Drill-Down and Drill-Up Behavior” on page 36

Note: Make sure that you followed the steps in “Setting Essbase Options” on
page 21. If the settings in the Essbase Options dialog box are different
from the settings previously illustrated, the worksheet view will differ
from the illustrations shown in this chapter.

Remember that you can perform common data retrieval tasks by doing any of
the following:
v Selecting commands from the Essbase menu on the Excel menu bar
v Clicking the appropriate buttons on the Essbase toolbar
v Double-clicking the primary or the secondary mouse button in the

appropriate cell (for Retrieve, Zoom In, and Zoom Out commands)

Connecting to a Database
To access Essbase data, you must first connect to a database on the server.
This tutorial assumes that you have the appropriate privileges to connect to a
server, an application, and a database.

Note: Essbase does not support multiple instances of Excel.
1. Select Essbase > Connect

Essbase displays the Essbase System Login dialog box.
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Note: To complete the steps that follow, you need to know the name of
the Essbase server, your username, and your password. If you do
not have this information, contact the Essbase system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want does not display in the list, you can type in the
name of the server you want to access.)

3. Press Tab to move to the Username text box; type your username in the
text box.

4. Press Tab to move to the Password text box; type your password in the
text box.

Note: You can change your password when you are connected to a server.
To change your password, see “Changing a Password” on page 28.

5. To connect to the server, click OK.
Essbase displays a list of available application/database pairs in the
Application/Database list box. An Essbase server enables simultaneous
access to multiple applications. An application can contain multiple
databases. Only the databases to which you have security access are
shown in the list.
For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the
list. If Sample Basic is not shown in the Application/Database list box, ask
the Essbase system administrator to install it.

Figure 13. Essbase System Login Dialog Box
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6. In the Application/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.

If the application is not already running, Essbase automatically starts it. There
may be a brief pause as the application loads. The time required to start an
application depends on the number of databases, the sizes of the databases,
and the sizes of the indexes of the databases contained within the application.

Changing a Password
You can change your password only if you are connected to a server.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

To change your password:

1. In the Essbase System Login dialog box, select the Change Password button.

2. In the Change Password dialog box in the New Password text box, type your
new password.

3. In the Confirm Password text box, type the password again.

The passwords must be identical.

4. Click OK to change your password.

5. Click OK again to close the Essbase System Login dialog box.

Retrieving Data from a Database
Each time you retrieve information from an Essbase server, the following
actions occur:
v Essbase Spreadsheet Add-in requests data from the server.
v The server processes the request and prepares the data.

Figure 14. Available Application and Database Pairs
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v The server transmits the data to Essbase Spreadsheet Add-in.
v Excel receives the data from Essbase and organizes it in a worksheet.

To help you monitor these operations, Essbase uses three custom cursors.

Table 3. Essbase Custom Cursor

This cursor: Is displayed when:

Essbase requests information from the server.

The server is processing the request.

The server returns the data.

Note: Small retrieval actions display the cursors very quickly; you may not
notice changes in the direction of the arrow when retrieving small
amounts of data.

To retrieve data into an empty worksheet:

1. Open a new worksheet by selecting File > New or by clicking the
button.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on
page 26.

2. Select Essbase > Retrieve.
Essbase retrieves data into the Excel worksheet.
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Because you selected the Enable Double-Clicking box in the Essbase Options
dialog box (Global tab), you can double-click in an empty cell to retrieve
data. You can also click the Retrieve button on the Essbase toolbar.

When you retrieve data into an empty worksheet, Essbase returns data from
the top levels of each database dimension. The top level is used as a starting
point to navigate, or drill down, into levels of detailed data. In the Sample
Basic database, the following five dimensions are retrieved: Measures,
Product, Market, Scenario, and Year.

For the remainder of tasks in this tutorial, you can retrieve data by
double-clicking in a data cell, selecting Essbase > Retrieve, or by clicking the
Retrieve button on the Essbase toolbar.

Canceling a Data Retrieval Request
Occasionally, you may want to cancel a retrieval request. For instance, you
may want to stop a request if a retrieval is taking longer than expected or if
you mistakenly double-click.

Because Essbase returns data so quickly to the worksheet, you may not be
able to cancel a retrieval before the retrieval is complete. The cancel feature is
most useful when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.

Note: You can cancel a retrieval only while Essbase is processing in Essbase
Spreadsheet Add-in. You cannot cancel a retrieval when Essbase is
processing from the server.

Restoring the Previous Database View
The FlashBack command restores the previous database view. A database view
is simply what you see in the worksheet after a retrieval or navigation
operation. FlashBack is similar to the Excel Edit > Undo command, which
reverses the last action. The FlashBack command uses the memory of your
machine to store the current view before processing an Essbase retrieval

Figure 15. Initial Data Retrieval from Sample Basic
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request. You can use FlashBack to undo only the most recent operation.
FlashBack cannot undo multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are
presented. If you make a mistake or find yourself out of step with the tutorial,
you can use the FlashBack command from the Essbase menu or toolbar to
undo the last command and return to the previous database view. If you want
to start the tutorial over from the beginning, select the entire worksheet and
select Edit > Clear > All. Then press Enter or click OK to empty the worksheet
and start again.

You can disable FlashBack during normal operations to conserve memory on
your local machine. Do not disable FlashBack for this tutorial.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

To disable Flashback:

1. Select Essbase > Options and click the Global tab.

2. Clear the Enable FlashBack check box.

Drilling Down to More Detail
With Essbase, you can drill down to various levels of multidimensional data
in the worksheet. For example, if you want to view data for a specific quarter
or month rather than an aggregate data value for the whole year, you can drill
down on the Year dimension to see more detailed data.

You have three options for drilling down on a member:
v Select the member and select Essbase > Zoom In.
v Select the member and double-click the primary mouse button.
v Select the member and click the Zoom In button on the Essbase toolbar.

To drill down to lower levels of the Year dimension:
1. On Year in cell A2, double-click the primary mouse button.

The drill-down action retrieves data for the level below (the children of)
Year: Qtr1, Qtr2, Qtr3, and Qtr4.
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Note: For a discussion of the relationships among Essbase database
members, see “Database Outlines” on page 7.

With Essbase, you can retrieve members into grouped, or nested, columns
or rows. Row groups containing more than one level of data are nested
within single-member row groups. For example, a row group containing
Qtr1, Qtr2, Qtr3, and Qtr4 may be nested within a single-member row for
a specific region, such as East (see the following illustration). Drilling
down to lower levels of database members is one way to retrieve data into
nested groups.

2. In cell D1, double-click to drill down on Market and create nested groups
of rows down the worksheet.

Figure 16. Result of Drilling Down on the Year Dimension

Figure 17. Result of Drilling Down on the Market Dimension (Nested Rows)
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Because worksheets can accommodate more rows than columns, Essbase is
preset to retrieve data into rows when you drill down on a member. You
can change this default behavior and display the results of a drill-down
across columns. Drilling across columns applies only to the top-level
member of a dimension (for example, Market or Scenario).

Follow these steps to drill down on Scenario and retrieve its respective
members into columns rather than rows:
1. Press and hold the Alt key.
2. Double-click Scenario (in cell E1).
3. Release the Alt key.

Essbase displays the data in columns across the worksheet.

Drilling Down on Attribute Members
You can use the Essbase attribute feature to retrieve and analyze in terms of
characteristics, or attributes, of dimensions. For example, you can analyze
product profitability based on size or packaging. Attribute dimensions are
associated with base dimensions.

You can use an attribute dimension to drill down on the base dimension with
which it is associated. In the Sample Basic database, the Product base
dimension is associated with several attribute dimensions, such as
Caffeinated, Ounces, and Pkg_Type. Each attribute dimension consists of level
0 attribute members. Level 0 attribute members are the lowest level attributes
that are associated with members of a base dimension. The Pkg_Type attribute
dimension, for instance, has two level 0 members, Bottle and Can.

Figure 18. Result of Drilling-Down on the Scenario Dimension (Nested Columns)
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You can extract information on all products sold in a can by entering
manually the name Can in the worksheet. You can also use Essbase Query
Designer or the Essbase Member Selection dialog box to select the attribute
and display it in the worksheet.

Open a worksheet, connect to the Sample Basic database, and select Essbase >
Retrieve. Select Product and replace it with Can by typing Can manually.
Click anywhere outside of cell C1 and select Essbase > Retrieve again. Figure
19 displays the results:

Drill down to all products sold in a can by double-clicking Can in cell C1.
Cola, Diet Cola, and Diet Cream are the members of Product that have the
Can attribute. The result is displayed below:

Drilling Down on Level 0 Attribute Members
The following is a description of the general behavior of Essbase Spreadsheet
Add-in when you drill down on a level 0 attribute member:
v If the level 0 attribute member is in a column, a drill-down pivots the

attribute to the innermost row of the worksheet.
v If the level 0 attribute member is in a row, a drill-down does not change the

position of the attribute in the worksheet.
v A drill-down on a level 0 attribute member displays the associated base

members to the right of the level 0 attribute.
v If there is more than one level 0 attribute member in a worksheet, a

drill-down on one attribute displays other attributes to the left of the level 0
attribute member. Level 0 attribute members in columns pivot to rows, and
level 0 attribute members already in rows remain in rows.

Figure 19. An Attribute Member in a Report

Figure 20. Result of Drilling Down on an Attribute Member
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v A drill-down on non-level 0 attribute members is the same as the current
drill- down behavior for other types of members.

The drill-down behavior for non-level 0 attribute members is the same as the
current drill-down behavior for other types of members. See the Essbase
Spreadsheet Add-in online help for examples of drilling down on level 0
attribute members. For more information on attributes, refer to the Database
Administrator’s Guide.

Drilling Up to Less Detail
With Essbase, you can drill up to higher levels in the multidimensional
database outline by collapsing the current member tree. For example, if you
previously drilled down on a dimension, such as Scenario, to view data for
Actual and Budget, you may need to drill up to view aggregate data for the
Scenario dimension.

You have three options for drilling up on a member:
v Select the member and select Essbase > Zoom Out.
v Select the member and double-click the secondary mouse button.
v Select the member and click the Zoom Out button on the Essbase toolbar.

To drill up on the Scenario dimension in the current worksheet:
1. On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or

G2), double-click the secondary mouse button.
Essbase collapses the members of the Scenario dimension.

2. In cell A3, double-click the secondary mouse button to drill up on East.
Essbase collapses East, West, South, and Central into the single Market
dimension and keeps the dimension in the A column.

Figure 21. Result of Drilling Up On the Scenario Dimension
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Customizing Drill-Down and Drill-Up Behavior
You can customize the behavior of the Zoom In and Zoom Out commands in
the Essbase Options dialog box. The following steps illustrate some drill-down
and drill-up techniques.

To retrieve all members of a dimension with a single drill-down operation:
1. Select Essbase > Options and select the Zoom tab.

Essbase displays the Zoom Tab.

The Zoom In option group contains items that enable you to customize
drilling behavior. You can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select
Bottom Level, Essbase retrieves data for the lowest level of members in a
dimension. With this option, a drill-down on Year retrieves Jan, Feb, Mar,
Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retains the selected member along with the other members
retrieved as a result of a drill down. For example, if you drill down on

Figure 22. Result of Drilling Up On East

Figure 23. Zoom In and Member Retention Option Settings
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Qtr1, Essbase retrieves data for Jan, Feb, and Mar, as well as for Qtr1.
When this option is disabled, Essbase retrieves data only for Jan, Feb, and
Mar; Qtr1 is eliminated.

Note: For more information on the Zoom In and Member Retention
option groups, see the Essbase Spreadsheet Add-in online help.

2. In the Zoom In option group, select the All Levels option and click OK to
save the setting.

3. In cell A3, drill down (double-click) on Market.
4. In cell C2, drill down (double-click) on Scenario.

Essbase retrieves all members of Market and Scenario. For the Market
dimension, Essbase drilled down two levels to get to the bottom-most
members, which are individual states. The Scenario dimension has only
one member level, so the members of Scenario would also be retrieved if
you selected Next Level in the Zoom In option group.

5. Select Essbase > Options and select the Zoom tab.
6. Return the Zoom In option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected
Group in the Member Retention option group.

To drill up only on Qtr1:
1. In the Member Retention option group on the Zoom Tab, click the Within

Selected Group check box and click OK.
Make sure that Include Selection is also still checked.

2. To drill up on Qtr 1 (in cell B3), double-click the secondary mouse button.

Figure 24. Result of Drilling Down to All Member Levels
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Notice that drilling up to the Year dimension affects only New York. All
other states show data for all four quarters.

3. Before moving on with the tutorial, disable the Within Selected Group
option:
a. Select Essbase > Options and select the Zoom tab.
b. In the Member Retention option group, clear the Within Selected

Group check box.
4. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Pivoting, Retaining, and Suppressing Data

After you retrieve data into the worksheet, you may want to manipulate the
data in various ways. For example, you may want to move rows and columns
to different positions in the worksheet, or you may want to tell Essbase to
suppress or retain specific data during data retrievals.

To help you manipulate worksheet data, this section steps you through the
following procedures:
v “Pivoting Rows and Columns” on page 38
v “Retaining a Data Subset” on page 43
v “Removing a Data Subset” on page 46
v “Navigating Through the Worksheet Without Retrieving Data” on page 46
v “Suppressing Missing Values, Zero Values, and Underscore Characters” on

page 50

Pivoting Rows and Columns
With the Pivot command, you can change the orientation of worksheet data.
Use the Pivot command to do any of the following:

Figure 25. Result of Drilling Up Within a Selected Group
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v Move a row group to a column group
v Move a column group to a row group
v Change the order of row groups
v Change the order of column groups

You can execute the Pivot command in two ways:
v Select the member cell that you want to pivot, and select Essbase > Pivot.

This method applies only to moving a row group to a column group or a
column group to a row group.

v Click in the center of the member cell that you want to pivot, press and
hold the secondary mouse button, and drag the group to the desired
location. This method applies to swapping row and column groups and to
changing the order within groups.

To pivot Year data from a row group to a column group:

1. To open a new worksheet, select File > New or click the icon.

Note: You should already be connected to the Sample Basic database. If
you are not connected, follow the steps in “Connecting to a
Database” on page 26.

2. Select Essbase > Retrieve.
3. Drill down (double-click) on Measures and Product (in cells B1 and C1,

respectively).
4. Press and hold the Alt key, and, in cell E1, drill down (double-click) on

Scenario.

Figure 26. View Before Pivoting
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5. In cell C3, select Year and select Essbase > Pivot.

Essbase pivots the Year dimension to a column group next to Market
(above the Scenario members).

6. As another example, in cell C2, select Actual.
7. Right click and drag Actual to product 100 in cell A3.

Note: The member label box that is displayed under the cursor during the
pivot operation displays the names of the members that you are
pivoting. The orientation of the member label box, however, does not

Figure 27. Result of Pivoting a Row Group to a Column Group

Figure 28. Pivoting a Column Group to a Row Group
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determine the orientation of the pivot result. Essbase determines the
data orientation by the location of the destination cell.

Essbase pivots the Scenario members (Actual, Budget, Variance, and
Variance%) from a column group to a row group that is displayed to the
left of the Product members.

To transpose the order of row groups:
1. In cell A2, select Actual.
2. Right-click and drag Actual to Profit (cell C2).

Figure 29. Result of Pivoting a Column Group to a Row Group
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The pivot changes the order of the row groups.

In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are
members of different row groups, Essbase exchanges the member groups.

Figure 30. Pivoting the Order of Row Groups

Figure 31. Result of Pivoting the Order of Row Groups
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You must select a destination cell that contains a member name to
exchange row members. You can also exchange column members by
choosing a destination cell in another column that contains a member
name.

Retaining a Data Subset
The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete
individual cells.

To keep only Actual and Budget data in the current worksheet:
1. In cell C2, select Actual and, in cell C3, select Budget.

2. Select Essbase > Keep Only.
Essbase removes the Variance, Variance%, and Scenario rows from the
worksheet and retains only Actual and Budget data.

Figure 32. Selecting Members for the Keep Only Command
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Occasionally, the data that you want to remove from the worksheet does not
lie in an adjacent range of cells.

To select and retain nonadjacent cells.
1. Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.
2. Select Qtr2 (in cell E2).
3. Press and hold the Ctrl key and select Qtr4 (in cell G2).

Figure 33. Result of Retaining a Data Subset (Adjacent Cells)
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4. Select Essbase > Keep Only.
Essbase retains only Qtr2 and Qtr4 data and deletes the other Year
members.

Figure 34. Selecting Nonadjacent Members for the Keep Only Command

Figure 35. Result of Retaining a Data Subset (Nonadjacent Cells)
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Removing a Data Subset
The Remove Only command is the counterpart to the Keep Only command.
With Remove Only, you can remove selected member rows or columns and
retain all other data in the worksheet view.

To remove a data subset from the current worksheet view:
1. In cell B7, select Ratios.
2. Press and hold Ctrl, and, in cell B9, select Measures.
3. Select Essbase > Remove Only.

Essbase removes data for Ratios and Measures but retains data for Profit
and Inventory.

Navigating Through the Worksheet Without Retrieving Data
With the Navigate Without Data feature, you can perform navigational
operations, such as pivot, zoom in, zoom out, keep only, and remove only,
without retrieving any data into the worksheet.

Figure 36. Result of Removing a Data Subset
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This feature is especially useful when dealing with dynamic calculation
members, which are usually specified by the application designer. By
activating Navigate Without Data, you are effectively telling Essbase not to
dynamically calculate values (that is, calculate the database at retrieval time)
while you are creating the spreadsheet report. Dynamic calculation is
discussed in more detail in “Retrieving Dynamic Calculation Members” on
page 130.

To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.

Essbase displays a check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2.
Essbase shows the collapsed Year dimension but withholds retrieving any
data that is changed as a result of drilling up. The cells where data would
normally be displayed are blank.

3. In cell D2, drill down (double-click) on Year by pressing and holding the
Alt key.
Essbase drills down without retrieving data.

Figure 37. Result of Zooming Out (Navigate Without Data Enabled)
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4. In Cell C3, select Actual and select Essbase > Pivot.
Essbase executes the pivot but does not retrieve data.

Note: You get the same result by pivoting any of the other Scenario
members.

5. In cell G1, click the secondary mouse button on Market and drag Market
to product 100 (cell A4).
Essbase executes the pivot without retrieving data.

Figure 38. Result of Pivoting (Navigate Without Data Enabled)

Figure 39. Result of Pivoting (Navigate Without Data Enabled)
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Navigating without data also works with the Keep Only and Remove Only
commands.

To navigate without data when using the Keep Only or Remove Only
command:
1. Select Qtr1 (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Essbase retains only the selected members and does not retrieve data.

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select
Essbase > Remove Only.
Essbase executes the Remove Only command without actually querying
the database for information.

Figure 40. Result of Keep Only (Navigate Without Data Enabled)

Figure 41. Result of Remove Only (Navigate Without Data Enabled)
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To turn off Navigate Without Data when you are ready to retrieve data:
1. Select Essbase > Navigate Without Data.

Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the
appropriate option in the Essbase Options dialog box (Global Tab)
or by clicking the Navigate Without Data button on the Essbase
toolbar.

2. In cell A3, drill down (double-click) on Market.
Essbase drills down on the Market dimension and also retrieves data into
the worksheet.

Note: If you want to retrieve data without changing the current worksheet
view, you can also retrieve data by simply double-clicking in any
data cell or by selecting Essbase > Retrieve (after disabling Navigate
Without Data).

Suppressing Missing Values, Zero Values, and Underscore Characters
Several types of data can be returned to a worksheet view:
v Numeric data values
v #NoAccess strings, which are displayed when you do not have the proper

security access to view a data value
v #Missing strings, which indicate that no data exists for that member

intersection
v Zero data values

Figure 42. Result of Drilling down (Navigate Without Data Disabled)
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A missing value is not the same as a zero value that is loaded into the Essbase
database. When data does not exist for a data cell in Essbase, a value of
#Missing is returned to the worksheet. If any cell in a row contains a value,
that row is not suppressed on a retrieval.

With Essbase, you can suppress missing and zero values from the display in
the worksheet. In addition, you can tell Essbase to suppress underscore
characters that are in some member names.

To suppress rows that contain missing values from displaying in the
worksheet:
1. In cell C3, double-click the secondary mouse button to drill up on Profit.
2. Pivot Measures (in cell C3) to Actual (in cell D1).
3. In cell B4, drill down (double-click) on product 100.

Notice that, in the South, the product 100–30 row contains all missing
values, indicating that this product is not sold in the South. You may need
to scroll down the worksheet to see this row.

4. Select Essbase > Options, and select the Display tab.
5. In the Suppress option group, select the #Missing Rows check box and

click OK.

Figure 43. Worksheet View Displaying Missing Data Values
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Note: The Suppress #Missing Rows and Zero Rows options are not
available when any of the Formula Preservation options are selected
in the Essbase Options dialog box. For more information on
Formula Preservation, see “Preserving Formulas When Retrieving
Data” on page 119.

6. Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog
box, you must perform a retrieval or drill operation to have the new
setting take effect.

Essbase suppresses product 100–30 from the South member group.

7. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data
retrieval are not retrieved again by simply disabling the feature. If
you disable the feature in the Essbase Options dialog box, missing
values are retrieved from only that point on. For example, in the
tutorial task described above, Essbase could not go back and return
the missing values for product 100–30. To return these missing

Figure 44. Result of Suppressing Missing Data Values
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values to the worksheet, you disable the Suppress #Missing Rows
feature, drill up on a Product member, and then drill down again.

You can also suppress zeros and underscore characters as described in the
task above by clicking the appropriate options in the Suppress option group
in the Essbase Options dialog box (Display tab).

In addition to suppressing specific values and characters during retrieval,
Essbase enables you to define a label for missing values (#Missing) or for data
you do not have access to (#NoAccess). If you define a replacement label for
these values, Essbase displays the replacement labels instead of the default
labels. For more information on defining replacement labels for the #Missing
and #NoAccess labels, see the Essbase Spreadsheet Add-in online help.

Formatting the Worksheet

Essbase provides you with various ways to customize the worksheet view. For
example, you may want to apply visual cues, or styles, to certain member
names or to data cells in the worksheet, or you may want to display
alternative names, or aliases, for member names. This section steps you
through the following formatting procedures:
v “Formatting Text and Cells” on page 53
v “Displaying Aliases for Member Names” on page 62
v “Displaying Both Member Names and Aliases” on page 64
v “Repeating Member Labels” on page 65

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells
In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the
text and cells in the worksheet, you can easily keep track of specific database
members, dimensions, and cell functions. Styles are a great way to help view
and distinguish data in Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during
a retrieval request. For more information, see “Removing Styles” on
page 61.

This section of the tutorial describes the following:
v “Applying Styles to Parent Members” on page 54
v “Applying Styles to Dimension Members” on page 57
v “Applying Styles to Data Cells” on page 59
v “Determining the Precedence of Overlapping Styles” on page 60
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v “Removing Styles” on page 61

Note: For a discussion of the relationships among Essbase database members,
see “Database Outlines” on page 7.

Applying Styles to Parent Members
Each dimension in a database may contain a large number of hierarchical
levels. As you view data in the worksheet, you may not be familiar with all
the hierarchical levels of the database outline. To indicate which members
have underlying children, you can apply formatting styles to parent members,
including those with attributes.

To apply styles to parent members:

1. To open a new worksheet, select File > New or click the icon.
2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you
are not connected, follow the steps in “Connecting to a Database”
on page 26.

3. In cell A2, drill down (double-click) on Year.
4. Select Essbase > Options.
5. In the Essbase Options dialog box, select the Style tab.

Note: The Style tab is available only when you are connected to a
database.

Essbase displays the Style tab.
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In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. In the Members group box, select the Parent check box.
Clicking this box defines a font and color style for parent member names.
Essbase defines a default color of navy for all parent members. You can
select a font format by clicking the Format button to the right of the
Members box and using the Font dialog box.

7. Click the Format button.
Essbase displays the Font dialog box.

Figure 45. Essbase Options Dialog Box, Style Tab
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8. In the Font style list box, select Bold and then click OK.

Note: Essbase displays an example of the selected style in the Sample
box.

9. Click OK again.
Even though you have defined styles, they are not enabled until you
select the Use Styles check box from the Essbase Options dialog box and
refresh the worksheet.

10. Select Essbase > Options, and select the Display tab.
11. In the Cells option group, select the Use Styles check box to enable your

styles, and then click OK.
12. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Essbase displays parent member names in bold, navy font.
13. In cell A2, drill down (double-click) on Qtr1.

Figure 46. Font Dialog Box
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Essbase displays Jan, Feb, and Mar in a regular font, because these
members do not have underlying children.

Applying Styles to Dimension Members
In addition to applying styles to parent members (as you did in the previous
section), you can also apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Essbase Spreadsheet Add-in.

To apply styles to dimensions:
1. Select Essbase > Options and select the Style tab.
2. In the Dimensions group box, select Year.
3. Select the Cell Border check box to create a border around each cell that

contains a member from the selected dimension.
4. From the Background Color list box, select Yellow.

Figure 47. Styles Applied to Parent Members
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5. Click the Format button that is to the right of the Dimensions list.
Essbase displays the Font dialog box.

6. From the Font style list box, select Bold, and then click OK.

Note: Essbase displays an example of the selected style in the Sample
box.

7. From the list of dimensions, select the Measures dimension and, from the
Background Color list box, select Fuschia.

8. From the list of dimensions, select Product, and clear the Cell Border
check box.

9. From the Background Color list box, select Aqua.
10. Scroll down the list of dimensions, and select Market.

Figure 48. Selecting a Background Color from the Style Tab
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11. Select the Cell Border check box, and click the Format button that is to
the right of the Dimensions list.
When the Font dialog box is displayed, from the Font style list box select
Italic, and then click OK.

12. From the list of dimensions, select Scenario, and from the Background
Color list box, select Red.

13. Click the Format button, and from the Color list box, select White.
14. Click OK twice to return to the worksheet.

Note: When you define styles, your choices are saved to the Windows
Registry on your local machine. You can define one set of styles
per database.

15. In cell D1, drill down (double-click) on Market.
16. Press and hold the Alt key and drill down (double-click) on Scenario (in

cell E1).
17. Select Essbase > Retrieve to refresh the worksheet.

Essbase redisplays the worksheet and implements the newly defined
styles. For example, members of the Scenario dimension are displayed
with a red background.

Applying Styles to Data Cells
You can apply styles to data cells, such as read-only cells, read/write cells,
linked object cells, and Essbase Integration Server drill-through cells to
distinguish them from other cells in the worksheet. The Sample Basic database
that you are using for this tutorial does not contain data cells with any of

Figure 49. Dimensions with Styles Applied
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these characteristics. In the advanced tutorial presented in Chapter 4, you
attach a linked reporting object to a data cell and apply a style to the cell.

Note: You cannot perform the actions in light-shaded boxes.

In general, to apply styles to data cells, follow these steps:

1. Select Essbase > Options, and select the Style tab.

2. In the Data Cells option group, select the Linked Objects, Integration Server Drill-Through, Read
Only, or Read/Write check box.

3. Click Format.

4. In the Font dialog box, specify the font, font size, font style, color, and effects, and click OK.
Note: Essbase displays an example of the selected style in the Sample box.

Figure 50. Sample Style for Read/Write Data Cells

5. Repeat Step 2 through Step 4 to set styles for other data cells.

6. Select the Display tab and select the Use Styles check box to apply styles to the worksheet.

7. Click OK to close the Essbase Options dialog box.

8. Select Essbase > Retrieve to display the new styles in the worksheet.

Determining the Precedence of Overlapping Styles
The only way you can apply a background color to data is to define a style
for dimensions. If dimension styles are defined, and the Use Styles setting is
turned on, members of a dimension always have the background color
defined for their dimension.

The text styles that you can apply to members, dimensions, and data cells
have a hierarchy that determines which characteristics are applied. Member
styles are at the top of that hierarchy. Thus, member styles are always applied
(as long as styles are turned on). Note that in Figure 49, the Qtr1 label in cell
B6 is in bold, navy font, and has a yellow background. The navy font comes
from the style defined for parent members, and the yellow background comes
from the style defined for Year.

Essbase uses the following order of precedence when applying multiple text
styles:
v Linked object cells
v Integration Server Drill-Through cells
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v Read-only cells
v Read/write cells
v Parent member cells
v Child member cells
v Shared member cells
v Cells containing formulas
v Dynamic calculation member cells
v Attribute cells
v Dimension cells

If you want to see a child member style, make sure that the parent member
style is turned off. If you want to see a shared member style, make sure that
both parent and child member styles are turned off.

Removing Styles
Styles can be very helpful tools for keeping track of data in Essbase
Spreadsheet Add-in. Applying styles, however, involves additional processing
time during a retrieval request. This additional processing has a slight impact
on the speed of Essbase retrievals.

If you do not want to apply styles to the worksheet view, you can clear them.
You can also turn off styles so they are not displayed when you refresh the
view (by selecting Essbase > Retrieve, for example). So that the worksheet
matches the illustrations presented in the following tasks, do not remove styles
if you are stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the
FlashBack command, these styles are temporarily removed from the
current view. The styles are re-applied whenever you initiate a retrieval.
You cannot perform the actions in the light-shaded boxes.

To remove all styles from a worksheet:

1. Select all cells in the worksheet.

2. From the Excel menu bar, select Edit > Clear > Formats.

To disable styles:

1. Select Essbase > Options and, select the Display tab.

2. In the Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the
styles remain in the current worksheet view when you refresh the view.
The styles remain to avoid removing any styles that you may apply to
individual cells using native worksheet formatting options.
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Displaying Aliases for Member Names
Aliases are alternate names for database members. You can create reports that
use the database member name, which is often a stock number or a product
code, or an alias name, which can be more descriptive. Aliases are defined by
the Essbase application designer. Each database can contain one or more alias
tables

.For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product,
such as Colas and Root Beer, is defined in an alias table. In some cases, alias
names may vary depending on the combination of other database members.
For example, a Product member may have a different alias for each market in
which it is sold. For more information, see the Essbase Spreadsheet Add-in
online help or the Database Administrator’s Guide.

To display the alias of a member rather than its database name:
1. In cell C2, double-click the secondary mouse button to drill up on Actual.
2. Press and hold the Alt key and drill down (double-click) on Product (in

cell D1).
3. Select Essbase > Options, and select the Display tab.
4. In the Aliases option group, select the Use Aliases check box to display

member aliases.
5. Select Default from the Alias list box.
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6. Click OK.
7. Select Essbase > Retrieve to refresh the worksheet and display the alias

names.
Essbase changes the Product codes (100, 200, and so forth) to their
predefined aliases (Colas, Root Beer, Cream Soda, and so forth). In the
Sample Basic database, Product is the only dimension with predefined
aliases.

Figure 51. Enabling Aliases in the Essbase Options Display Tab
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Notice that Essbase is still displaying the styles that you created and
applied in the previous sections.

Displaying Both Member Names and Aliases
In addition to displaying aliases for database members, you can also tell
Essbase to display both aliases and database member names in Essbase
Spreadsheet Add-in.

To display the name and alias of a member:
1. In cell B8, double-click the secondary mouse button to drill up on Qtr2.
2. In cell C2, select Colas, and then select Essbase > Pivot.
3. In cell C3. select Year, and then select Essbase > Pivot.
4. Select Essbase > Options, and select the Display tab.
5. In the Aliases option group, select the check box for Use Both Member

Names and Aliases for Row Dimensions.
Be sure that Use Aliases is already checked.

6. Click OK to return to the worksheet, and select Essbase > Retrieve.
Essbase displays both member names and their aliases for row
dimensions. Because the only row dimension in this example that has
preassigned aliases is Product, only the Product members display their
aliases. Region members simply repeat the member name instead of
displaying an alias.

Figure 52. Result of Displaying Aliases
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Repeating Member Labels
By default, Essbase displays member labels only once for each nested row and
column group. If you are connected to a large database when using Essbase
Spreadsheet Add-in, you may have to scroll down or across the worksheet to
see additional data rows and columns. In some cases, as you scroll down or
across, member labels may disappear from view. Essbase provides a feature
for repeating member labels in each row or column cell that represents a data
point so that you can always see a member label in the worksheet view.

To repeat member labels down and across the worksheet:
1. Select Essbase > Options, and select the Display tab.
2. In the Aliases option group, clear the Use Both Member Names and

Aliases for Row Dimensions check box.
3. In the Cells option group, select the Repeat Member Labels check box,

and then click OK.

Figure 53. Result of Displaying Both Member Names and Aliases
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4. In cell E1, drill down (double-click) on Year.
Essbase displays a member label in every column and row cell. For the
Sample Basic database that you are using for this tutorial, repeating
member labels is probably not necessary because the database is relatively
small. This feature is particularly helpful for keeping track of member
labels when scrolling through large worksheets.

Figure 54. Enabling the Repeat Member Labels Option
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Note: Even if you clear the Repeat Member Labels check box in the
Essbase Options dialog box, Essbase retains the repeated member
labels in the worksheet view. To remove the repeated labels, you
need to do one of the following:

v Clear the check box and open a new worksheet
v Clear the check box and pivot the row group to a column group and

then pivot it back to a row group (or vice versa)
v Select Essbase > FlashBack and clear the check box

5. Before returning to the tutorial, complete the following actions:
a. Select Essbase > Options, and select the Display tab.
b. In the Cells option group, clear the Repeat Member Labels check box,

and then click OK.
c. Select File > Close to close the worksheet. You do not need to save the

worksheet.

Figure 55. Result of Repeating Member Labels
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Creating Queries Using Essbase Query Designer

So far, you have seen how easy it is to retrieve data and navigate through
Essbase Spreadsheet Add-in in an ad hoc fashion. Essbase also provides a
query designer so that you can define a database query for retrieving
dimensions and database members into the worksheet. Essbase Query
Designer (EQD) replaces Retrieval Wizard, and is used to define queries in
previous versions of Essbase Spreadsheet Add-in.

Before Hyperion Essbase actually retrieves data, Essbase Query Designer
provides a series of panels so you can request the data that you want to view
in the worksheet. It is particularly helpful when you know exactly which data
you want to retrieve from the server. In addition, you can save a query and
use it again.

The Essbase Query Designer window (Figure Creating Queries) consists of the
following panels:
v The navigation panel provides access to the various features in Essbase

Query Designer. You can display all the dimensions used in a particular
query and access the various properties of each dimension member.

v The hint panel provides a brief description of the feature that is selected
from the navigation panel.

v The properties panel provides access to the following functions:
– Layout: Design the layout of the spreadsheet report. To change the

default layout, select a dimension tile and drag it to one of the other
dimension boxes. To access the member select panel and to define a
member for a query, double-click a dimension tile.

– Member Select: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click a member to add
it to the selection rules.

– Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

– Data Filter: Retrieve rows of data. The retrieval is based on the ranking of
the rows within certain columns. Use this panel to access the data
restriction panel.

– Data Restriction: Filter data by comparing it to a fixed data value
(including a negative value), a set of data values, or #Missing data
values.

– Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

– Messages and Confirmation: Turn on and turn off certain messages from
Essbase Query Designer.

– Help: Access documentation about Essbase Query Designer.

68 Spreadsheet Add-in User’s Guide for Excel



Note: Excel query functionality is not supported in Spreadsheet Add-in.
Use the Essbase Query Designer to define database queries.

Creating and Changing Queries
To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an
open query, click on the specific dimension or member in the query outline
that is displayed in the navigation panel. Selected members are displayed in
the member selection panel on the right.

You can also revise an existing query in the member selection panel. For
example, you can delete a member or add a member to the query by selecting
a member in the navigation panel and making the appropriate changes in the
properties panel.

Note: Files created using the obsolete Retrieval Wizard feature can be opened
in Essbase Query Designer. However, if a query contains more than two
member filters per selection rule or more than two data restrictions, the
member filters may be out of order. To ensure correct results, rearrange
the member filters in the navigation panel, if necessary.

For complete information on Essbase Query Designer options, see the
Essbase Spreadsheet Add-in online help.

CAUTION:
Manipulation of worksheets in VBA such as naming worksheets or moving
worksheets may not work when EQD is running.

Creating Queries
To create a query using Essbase Query Designer:
1. Select Essbase > Query Designer.

Essbase displays the Essbase Query Designer welcome panel.
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2. To create a new query, select [Book1]Sheet1, right-click, and select New >
Query.
Hyperion Essbase displays the layout panel of Hyperion Essbase Query
Designer.

3. Define the worksheet layout by dragging the dimension tiles as follows:
a. Drag Market and Product to the Row location.
b. Drag Measures to the Page location.
c. Drag Scenario below Year (in the Column location).

Figure 56. Essbase Query Designer Displaying Welcome Panel
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4. To select the Measures dimension in the navigation panel, select the
Measures icon. Alternatively, double-click the Measures tile in the layout
panel.
Essbase displays the member select panel, where you can select a
member from the Measures dimension.

Note: You can select only one member from the dimension in the Page
location.

5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.
Profit is displayed in the selection rules list.

Figure 57. Changing the Worksheet Layout
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Note: In Essbase Query Designer, after you make your selections, you do
not need to confirm them; for example, you do not have to click
OK. If you do not select members from any given dimension,
Essbase uses the top member of the dimension.

6. To select members of the Year dimension, complete the following actions:
a. In the navigation panel, click the Year icon. Alternatively, double-click

the Year tile in the layout panel.
Essbase displays the member select panel for the Year dimension.

b. Select Qtr1, right-click, and select Add to Selection Rules.
c. Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.

Because Year is in a Column location, you can select one or more
members.

Figure 58. Hyperion Essbase Query Designer Displaying the Member Select Panel
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7. To select members of the Scenario dimension, complete the following
actions:
a. In the navigation panel, select Scenario. Alternatively, double-click the

Scenario tile in the layout panel.
The members of the Scenario dimension are displayed in the member
select panel.

b. Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.

c. In the same manner, add Budget to the Selection Rules box.
8. To select members of the Product dimension, complete the following

actions:
a. In the navigation panel, select Product. Alternatively, double-click the

Product tile in the layout panel.
The members of the Product dimension are displayed in the member
select panel.

b. Select product code 100, right-click, and select Add to Selection
Rules.

c. Repeat the process for product codes 200, 300, and 400.

Figure 59. Adding Members to the Selection Rules
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d. In the Selection Rules list box, select product code 100, right-click,
and then, from the popup menu, choose Select > Children.
This action selects all children of 100. Essbase displays All Children
next to 100 in the Selection Rules list box.

e. In the Selection Rules list box, select product code 400, right-click,
and choose Select > Descendants.
Essbase displays All Descendants next to 400 in the Selection Rules
list box.

f. To view the list of all product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box (for
example, 200), right-click, and select Preview.
Hyperion Essbase displays the Member Selection Preview dialog box.

Figure 60. Selecting Members of Product
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g. Click Close to close the Member Selection Preview dialog box.
9. To select members of the Market dimension, complete the following

actions:
a. In the navigation panel, select Market. Alternatively, double-click the

Market tile in the layout panel.
The members of the Market dimension are displayed in the member
select panel.

b. In the Member list box, select East, right-click, and select View by >
Generation.

c. To pick the second generation of the Market dimension, in the
Member list box, select Region, right-click, and select Add to
Selection Rules. Alternatively, double-click Region to add it to the
selection rules.
Region is displayed in the Selection Rules list box.

d. To view the list of members that will be retrieved into the worksheet,
in the Selection Rules list box, select Region, right-click, and select
Preview.
Essbase displays East, West, South, and Central in the Member
Selection Preview dialog box.

Figure 61. Selected Members of Product Dimension
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e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic Essbase query. The outline of the query is
displayed in the navigation panel.

10. In the navigation panel, select [Book1]Sheet1, Query1\, and then
right-click and select Save Query.
Essbase displays the Essbase Query Designer Save As Query dialog box.
You can save your query to the server or to your own client machine. To
save to the server, you must have a security level of database designer or
higher. Contact the Essbase system administrator for more information.

11. Select Client.

Figure 62. Generation Name Selection
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12. Click the File System button.
Essbase displays the Save As dialog box.

Figure 63. Essbase Query Designer Save As Query Dialog Box
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13. Select a location, in the File name text box, type Basic1 and then click
Save.
You will use the Basic1 query again in Chapter 4

Figure 64. Save As Dialog Box
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14. In the navigation panel, select [Book1]Sheet1, Basic1. then right-click, and
select Apply Query.
The result of the query is displayed in the worksheet.

Figure 65. Hyperion Essbase Query Designer Displaying Query Information Panel

Figure 66. Results of a Essbase Query Designer Query

Chapter 3. A Basic Essbase Tutorial 79



Note: In the Display tab under Essbase > Options, if you select Use
Styles and Use Sheet Options with Query Designer, the styles you
selected for dimension members will be applied to the initial query
results. If you do not select Use Sheet Options with Query
Designer, even if you have selected Use Styles, they will not be
applied to the initial query results. To apply styles, select Essbase >
Retrieve. When Essbase returns the data to the worksheet, you are
free to further investigate the data by performing Zoom, Keep
Only, Remove Only, and Pivot operations.

Deleting Queries
You can delete a query only from the location where you saved that query.
For example, if you save a query in the /essbase/client/sample directory,
you can delete the query from within the sample directory. You cannot delete
the query from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations
Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations
panel.

To turn on or turn off messages and confirmations:
1. Select the Messages and Confirmations icon in the navigation panel.
2. To turn on (enable) a message, select the check box that is displayed next

to that message.
3. To turn off (disable) a message, select the check box again (clear the check

box).
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Accessing Help
Access online help or the tutorial for Hyperion Essbase Query Designer by
using the help panel. To access the help panel, in the navigation panel, select
Help. For more information on a particular topic, click the Online Help button
in the properties panel. To access the online tutorial, click the Tutorial button
in the properties panel.

Figure 67. Messages and Confirmations Panel
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Connecting to Multiple Databases from Essbase Query Designer
You can connect to several databases and create separate queries on each
database from Essbase Query Designer.

To connect to multiple databases from Essbase Query Designer:
1. Logon to Essbase and connect to the server you want to access.
2. Select Essbase > Query Designer to open Essbase Query Designer.
3. Select [Book1]Sheet1, right-click, and select Connect.

Essbase displays the Essbase System Login dialog box.

Note: The book may be a number other than 1. For example, it may be
[Book5], if four worksheets are already open.

4. Type your password, and click OK. Select Sample Basic, and click OK.
5. Select [Book1]Sheet2 (or Sheet3), right-click, and select Connect.

Essbase displays the Essbase System Login dialog box.
6. Type your password, and click OK. Select Samppart Company, and click

OK.

Figure 68. Essbase Query Designer Help Panel
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Note: You are restricted to one connection per worksheet. The connection
information is displayed in the query information panel of the
Hyperion Essbase Query Designer only when you open an existing
query or create a new query.

7. To create a new query based on Sample Basic, select <<c:[Book1]Sheet1,
right click, and select New > Query.

8. To create a new query based on Samppart Company, select
<<c:[Book1]Sheet2, right-click, and select New > Query.

9. To open an existing query, right click, and select Open Query.

You are now ready to proceed with the process of creating queries or opening
existing queries.

Applying Worksheet Options to Essbase Query Designer Results
You can also apply any of the worksheet options you have previously set
from the Essbase Options dialog box to the results of a query created in
Essbase Query Designer.

To enable Essbase Query Designer to use your previously set worksheet
options:
1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the Use Sheet Options with Query Designer check box, and select

OK.
4. Select Essbase > Retrieve to refresh the worksheet.

Essbase displays the results of the query you created in Essbase Query
Designer and implements your previously set worksheet options. For
example, note that aliases, instead of the numeric codes, are now
displayed for the Product dimension.
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5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Selecting Members

A Essbase database may contain hundreds or even thousands of members,
making it difficult to remember each member name. You can use the Essbase
Member Selection dialog box to find and select members and to define the
layout of members in the worksheet. In addition, you can use Boolean
operators, such as AND, OR, and NOT, or other search parameters to specify
criteria and conditions that members must meet for the member selection.
Member selection is an important method of creating a spreadsheet report for
the data you want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box,
see the Essbase Spreadsheet Add-in online help.

To view specific members from the Product dimension:

1. To open a new worksheet, select File > New or click the icon.

Note: You should be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on
page 26.

Figure 69. Results of Query with Options Applied
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2. Select Essbase > Retrieve.
3. Select Product and select Essbase > Pivot to display Product as a row,

rather than a column, dimension.

4. Select Product again, and select Essbase > Member Selection.
Essbase displays the Essbase Member Selection dialog box. In the
Essbase Member Selection dialog box, Essbase displays the Product
dimension in the Dimension list box and its children, Colas, Root Beer,
Cream Soda, Fruit Soda, and Diet Drinks, in the Members list box.

5. Select Colas and click the Member Information button.

Figure 70. Initial Worksheet for Member Selection

Figure 71. Essbase Member Selection Dialog Box
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Essbase displays the Member Information dialog box. The dialog box
provides information about the selected member, such as dimension,
generation, level, storage setting, formula, UDAs, and member comments.

6. To close the Member Information dialog box, click OK.
7. In the Essbase Member Selection dialog box, click Add to add Colas to

the Rules list box.

Note: Alternatively, you can double-click an item in the Members list box
to add the item.

Figure 72. Member Information Dialog Box
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8. Select Cream Soda, and click the Find button.
Essbase displays the Find Member dialog box.
In the Find Member dialog box, you can do pattern-match searches for
members in the selected dimension. You can use Wildcard
patterns—(trailing asterisk, *) and (single-character match, ?). Hyperion
Essbase locates the members that match the text string (in alphabetical
order) and keeps them selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character
wildcard in the text string. The * wildcard replaces a string of
characters, whereas the ? wildcard replaces a single character. J?n
and 100* are examples of valid wildcard strings; *-10 and J*n are
examples of invalid wildcard strings.

9. In the Find Member dialog box, type D* in the text box.

10. Click Find to locate all members that match D*.
Essbase locates and selects Diet Cream. Its parent, Cream Soda, is also
selected because it was highlighted before the search.

11. To close the Find Member dialog box, click Close.
12. Clear Cream Soda, leaving only Diet Cream selected, and click Add.

Essbase displays Colas and the new selection, Diet Cream, in the Rules
list box.

13. In the Essbase Member Selection dialog box, select Colas in the Rules
list box, and then right-click. From the pop-up menu, select All Children
and Member.
Essbase displays All Children and Member next to Colas in the
Selection Rules list box.

14. In the Selection Rules list box, select Colas, All Children and Member,
and then right-click again.

Figure 73. Find Member Dialog Box
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15. From the pop-up menu, select Subset.
Essbase displays the Subset Dialog box, where you can further define
conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog
box.

16. In the Subset Dialog box, in the first list box, select Caffeinated. In the
second list box, select Is. In the third list box select Caffeinated_True.

17. Click the Add as AND Condition button.
Essbase displays Caffeinated = Caffeinated_True in the Conditions list
box.
When you use Add as AND Condition, the subsetting condition in the
Conditions list box is evaluated using AND logic. AND logic means that
the selection must meet the current condition and the following condition
in the Conditions list box.

18. In the first list box, select Ounces. In the second list box, select the logical
operator “=”. In the third list box, select Ounces_12.

19. Click the Add as AND Condition button.
Essbase displays Ounces = Ounces_12 in the Conditions box.

20. In the first list box, select Ounces. In the second list box, select the logical
operator “<=”. In the third list box, select Ounces_32.

21. Click the Add as OR Condition button.

Figure 74. Subset Dialog Box (Before Adding Conditions)
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Essbase displays Ounces <= Ounces_32 in the Conditions box.
When you use the Add as OR Condition, the subsetting condition in the
Conditions list box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in
the Conditions list box.

22. In the first list box, select Pkg Type. In the second list box, select Is. In
the third list box, select Bottle.

23. Click the Add as AND Condition button.
Essbase displays Pkg Type = Bottle in the Conditions list box.

24. In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

25. Select Pkg Type = Bottle, and click the Add ) button.
The Add ( and Add ) buttons add a left parenthesis and right
parenthesis, respectively, to selected items. Use parentheses for grouping
multiple subsetting conditions to determine the order of priority for
analyzing the conditions. Each item in the Conditions list box can have
either the left or right parenthesis, but not both. In this example, Essbase
first evaluates members that are equal to or less than 32 ounces and are
packaged in a bottle. Essbase then evaluates the results from this
condition against members that are 12 ounces.

Note: Use the Remove ( ) button to remove an individual group of
parentheses from a selected item in the Conditions list box. Use
the Remove All ( ) button to remove all parenthetical groupings
from the Conditions list box.

The Subset Dialog box is displayed as follows:

Chapter 3. A Basic Essbase Tutorial 89



26. To open the Member Preview dialog box, click Preview.
In the Member Preview dialog box, you can view the member selection
that results from the conditions you defined.

27. To close the Member Preview dialog box, click Close.
28. To close the Subset dialog box and return to the Essbase Member

Selection dialog box, click OK.

Figure 75. Subset Dialog Box (After Adding Conditions)

Figure 76. Member Selection That Results from Subsetting Conditions
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The conditions you set in the Subset dialog box are displayed in the
Selection Rules list box.

29. To change the order in which Diet Cream is displayed in the worksheet,
select Diet Cream and click the Move Item Up button.
Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Rules list box. You can move only the top-level
item (the item you added from the Members list box), not the individual
subset conditions.

30. To preview the members that will be retrieved in the worksheet, click
Preview.
Essbase displays the Member Preview dialog box.

31. After previewing the list, click Close.

Figure 77. Selecting Members Completed
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32. To close the Essbase Member Selection dialog box and insert the new
members into the worksheet, click OK.

Note: The FlashBack command cannot undo a Member Selection action.
33. Starting with Diet Cream, type Year next to each product.

You need to do this step so that every product has a matching Year
dimension associated with it in the report.

Figure 78. Members to be Retrieved in Worksheet

Figure 79. Result of Selecting Members

Figure 80. Worksheet After Adding the Year Dimension to All States
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34. To update the values in the worksheet, select Essbase > Retrieve.
Essbase retrieves data for the members that you selected and also applies
the styles you previously set.

Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can
save worksheets and disconnect from Essbase. This section instructs you in
the following procedures:
v “Saving a Worksheet”
v “Disconnecting from Essbase” on page 93
v “Logging Off” on page 94

Saving a Worksheet
At any point during the Essbase session, you can save the active worksheet
with the Excel commands, File > Save or File > Save As. Thus, you can keep a
personal library of database views. You can open the worksheet during a later
session and retrieve the latest data values to update the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog
box unless the worksheet is protected. Essbase cannot save option settings
for a protected worksheet.

Disconnecting from Essbase
When you finish retrieving and navigating through data, disconnect from the
Essbase server to free up a port (or user count) on the server for other Essbase
Spreadsheet Add-in users.

To disconnect from the server:
1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can
disconnect any worksheet that is connected to a database.

Figure 81. Result After Retrieving with Member Selection
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2. From the list, select a worksheet name, and then click Disconnect.
3. Repeat Step 2 until you have disconnected all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Excel. An
abnormal termination of an Excel session, such as a power loss or
system failure, does not disconnect your server connection.

Logging Off
Essbase provides two administrative facilities that control user connections:
v Forced Logout, where an administrator disconnects users at any point in

time. This logoff usually occurs when maintenance operations are
performed on databases.

v Auto Logout, where Essbase automatically disconnects users that are inactive
for a time interval specified by an administrator.

For further information, contact the Essbase system administrator.

Figure 82. Essbase Disconnect Dialog Box
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Moving on to Advanced Tasks

Now that you have completed the basic Essbase tutorial, you are ready to
move on to more complex tasks. In the next chapter, you will use the sample
Excel files to see how to perform advanced tasks in Essbase Spreadsheet
Add-in.
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Chapter 4. An Advanced Essbase Tutorial

The tutorial you completed in Chapter 3 teaches basic data retrieval and
navigation concepts for Essbase Spreadsheet Add-in. This chapter builds on
your basic skills and expands your knowledge of Essbase and Essbase
Spreadsheet Add-in. This chapter provides the following sections on advanced
tasks:
v “Preparing to Begin the Tutorial” on page 97
v “Performing Advanced Retrieval Tasks” on page 104
v “Using Linked Reporting Objects” on page 147
v “Connecting to Multiple Databases” on page 164
v “Accessing Linked Partitions” on page 166
v “Updating Data on the Server” on page 168
v “Calculating a Database” on page 170
v “Creating Multiple Worksheets from Data” on page 172
v “Working with Currency Conversions” on page 177

In this advanced tutorial, you use several sampleMicrosoft Excel files that
were installed as part of the default Essbase installation. These files are stored
in the \Essbase\client\sample directory. You also reconnect to the Sample
Basic database.

Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two
sections, “Connecting to a Database” on page 97 and “Setting Essbase
Options” on page 99. In addition, be sure to read “Following Guidelines
During the Tutorial” on page 24 and “Reviewing the Sample Basic Database”
on page 25 for important information about what you should expect as you
perform the tutorial steps.

Connecting to a Database
To access Essbase data for the advanced tutorial, first connect to the Sample
Basic database on the server. This tutorial assumes that you have the
appropriate privileges to connect to a server, an application, and a database.
1. Select Essbase > Connect.

Essbase displays the Essbase System Login dialog box.
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Note: To complete the steps that follow, you need to know the name of
the Essbase server, your username, and your password. If you do
not have this information, contact the Essbase system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the
server that you want to access.)

3. To move to the Username text box, press Tab and then, in the Username
text box, type your username.

4. To move to the Password text box, press Tab, and then, in the Password
text box, type your password.

Note: You can change your password when you are connected to a server.
See “Changing a Password” on page 28.

5. To connect to the server, click OK.
Essbase displays a list of available application/database pairs in the list
box. An Essbase server enables simultaneous access to multiple
applications. An application can contain multiple databases. Only the
databases to which you have security access display in the list.
For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the
list. If Sample Basic is not shown in the Application/Database list, ask the
Essbase system administrator to install it.

Figure 83. Essbase System Login Dialog Box

98 Spreadsheet Add-in User’s Guide for Excel



6. In the Application/Database list, double-click Sample Basic, or, from the
Application/Database list select Sample Basic and then click OK.

If the application is not already running, Essbase automatically starts it. There
may be a brief pause as the application loads; the time required to start an
application depends on the number of databases, the sizes of the databases,
and the sizes of the indexes of the databases that are contained within the
applications.

Setting Essbase Options
Before you begin the tutorial, make sure that the worksheet options are set to
the initial settings shown in the Figure 85 through Figure 88.

Note: For information on each option in the Essbase Options dialog box, see
the Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches Figure 85.

Figure 84. Available Application and Database Pairs
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4. Select the Zoom tab.
5. Select the appropriate check boxes and option buttons so that your

display matches Figure 86 on page 101.

Figure 85. Initial Settings for Display Options
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6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display matches Figure 87.

Figure 86. Initial Settings for Zoom Options
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8. Skip the Style tab.
9. Select the Global tab.

10. Select the appropriate check boxes and option buttons so that your
display matches Figure 88.

Figure 87. Initial Settings for Mode Options
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11. To save the settings for this session and close the Essbase Options dialog
box, select OK.

Note: The settings in the Essbase Options dialog box may change as you
access the various sample Excel files as part of the tutorial. Leave
the settings as they are unless the tutorial advises you to change
them. If you have different option settings, the illustrations
presented in this chapter may not match the worksheet view.

Figure 88. Initial Settings for Global Options
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Performing Advanced Retrieval Tasks

The tutorial in Chapter 3 describes how to perform basic data retrieval and
navigation tasks in Essbase Spreadsheet Add-in. This section walks you
through performing the following advanced retrieval tasks:
v “Filtering Data” on page 104
v “Sorting Data” on page 109
v “Retrieving Data into Asymmetric Reports” on page 112
v “Working with Formatted Worksheets” on page 114
v “Preserving Formulas When Retrieving Data” on page 119
v “Retrieving a Range of Data” on page 123
v “Retrieving Data by Using a Function” on page 126
v “Retrieving Dynamic Calculation Members” on page 130
v “Specifying the Latest Time Period for Dynamic Time Series” on page 132
v “Using Free-Form Reporting to Retrieve Data” on page 136

Remember that you can perform common data retrieval tasks in any of the
following ways:
v Selecting commands from the Essbase menu on the Excel menu bar
v Clicking the appropriate buttons on the Essbase toolbar
v Double-clicking the primary or the right-mouse button in the appropriate

cell (for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data
Despite the ease and speed with which you can navigate through large
Hyperion Essbase databases, it is not practical to use the capabilities of Excel
to filter and sort very large databases; however, the Essbase server includes
powerful data filtering and sorting capabilities. In Chapter 3, you learned to
use Essbase Query Designer to define a dimensional layout and to select
members to view. Essbase Query Designer also provides a powerful, yet
easy-to-use tool to define conditional retrievals.

To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basic1, that you saved in Chapter 3, and perform the
following steps:

Note: If you skipped the tutorial in Chapter 3, follow the steps in “Creating
Queries Using Essbase Query Designer” on page 68 to create and save
the Basic1 query.

1. Select Essbase > Query Designer.
Essbase displays the query information panel of Essbase Query Designer.

2. From the location that you specified in Chapter 3, select the Basic1 file.
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3. Click OK.
The member selection, displayed in the properties panel, remains
unaltered from the last Essbase Query Designer session.

4. From the navigation panel, select Data Filtering.
Essbase displays the data filter settings in the data filter panel. The filter
controls the number of data rows that are retrieved. The number is based
on the column criteria that you define. You can define data filtering
criteria on data values that reside in one or more columns of the view.

5. The data filtering panel contains the following items:
v A check box for ranking so many of top rows or so many bottom rows

of data. You can select the highest or lowest rows. Your selection is
based on previously selected row dimension members. When using the
top or bottom criterion, you specify the number of rows, such as “top
10.” The default is the top 25 rows.

v A Dimension being ranked list box to specify the dimension to which
ranking should be applied.

v A Column used for ranking list box to specify the data column on
which data values are based.

v A Data Restrictions box to specify standard data comparison
operations, such as greater than, less than, and equal to. You can apply

Figure 89. Data Filter Panel
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the comparison operator to data values, including negative data values,
in one or more data columns; you can even apply criteria to compare
values between two columns.

v Buttons for OR and AND operators. If you define more than one
column criterion, you can use these operators to link the criteria.

6. Click the Top check box, and enter a value of 30 in the Rows text box.
When you apply the query, Essbase retrieves the top thirty rows of the
dimension.

7. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.

8. From the Column list box, select Qtr1, Actual. Qtr1, Actual is the column
on which data values are based.

9. In the navigation panel, select the Data Filtering icon. Right-click and
select Apply Query.
Your query results should look as shown below.

You can further filter your data output by specifying data comparison
operations in the Data Restrictions box.

10. In the navigation panel, select the Data Filtering icon.
The data filters that you specified are displayed in the properties panel.

Figure 90. Data Filtering Query Results
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11. In the Data Restrictions box, double-click.
The data restriction settings are displayed in the properties panel.

12. Select the Value option and type 500 in the Value box.
Observe that the is option in the Data list box changed to =.

13. Click the down arrow of the Data list box and select <=.
14. Select Qtr1, Actual in the Column list box.
15. In the navigation panel, select the Data Filtering icon. Right-click, and

select Apply Query.
Notice that the query results now reflect only Actual and Budget data
that are less than or equal to 500.

16. In the navigation panel, select the Data Filtering icon to display the data
filter setting in the properties panel.

17. In the Data Restrictions box, select Qtr1, Actual <= 500, right-click and
select New Data Restriction.

18. In the Data box, click the down arrow and select <.
19. In the data values list box, select Qtr2, Actual. Under Combined With

Other Restrictions, click the Or button.
20. In the navigation panel, click the Data Filtering icon to access the data

filter panel.
21. In the Data Restrictions box, double click to create a new data restriction.
22. In the Data box, click the down arrow and select Is Not.
23. Click the button for the #Missing Value option.

This option instructs Essbase to discard data that have #Missing values.
24. In the Column list box, select Qtr1, Actual. Under Combined With Other

Restrictions, select the And button.
The data restrictions should display as follows:
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25. Select the Data Filtering icon, right-click, and select Apply Query.
Essbase retrieves data for all the quarters. Notice that the retrieved data
for Qtr1, Actual is less than or equal to 500 or is less than Qtr2, Actual.
The results should display as follows:

Figure 91. Data Filtering
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Note: To delete all data restrictions, select the Data Filtering icon in the
navigation panel, right-click, and select Delete All Data Restrictions.
Alternatively, select any data restriction in the Data Restriction box,
right-click, and select Delete All Data Restrictions.

Note: To delete a particular data restriction, select the data restriction in the
query outline, right-click, and select Delete Data Restriction.
Alternatively, select the data restriction in the Data Restriction box,
right-click, and select Delete Data Restriction.

Sorting Data
Using the data sort panel, you can sort the output from the Basic1 query in
ascending or descending order.
1. From the navigation panel, select the Data Sorting icon.

The data sorting settings are displayed in the properties panel. You can
specify data sorting criteria that affect the order in which the selected
rows are retrieved in the data sorting panel.
The data sorting panel contains the following items:
v A Dimension being sorted list box that lists the dimensions specified in

row format in the query.

Figure 92. Data Filtering Results
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v A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

v An Ordering list box that you use to apply an ascending or descending
sort order for the selected column. You can also specify sorting to
occur over a specific row dimension group. For example, you can sort
by Product or by Market.

2. In the Column used for sort list box, double-click.
The selection defaults to Qtr1, Actual. The sort order defaults to
Ascending in the Ordering list box.

3. Click Ascending. A down arrow is displayed next to Ascending.
4. Click the down arrow. Descending is displayed below Ascending.
5. In the Ordering list box, select Descending.

Figure 93. Data Sorting Panel
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6. In the next row of the Column used for sort list box, double click.
The selection defaults to Qtr1, Actual.

7. Click the down arrow and select Qtr1, Budget.
Observe that the order in the Ordering list box has defaulted to
Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtr1,
Budget. Right-click and select Delete Sorting Rule.
The Ascending, Qtr1, Budget sorting rule is deleted from the query.

9. In the navigation panel, select the Data Sorting icon. Right-click and
select Apply Query.
Essbase returns the results sorted in descending order for each quarter, as
shown below:

Figure 94. Specifying Data Sorting Order
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Note: The values that you are ranking and sorting must be the same. For
example, you cannot specify Product in the Dimension Being
Ranked box and Market in the Dimension Being Sorted box. If you
specify different values, Hyperion Essbase Query Designer
automatically changes both values to the last specified value.

10. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Retrieving Data into Asymmetric Reports
When you retrieve data into a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, Figure 95 shows a symmetric
report that contains Actual and Budget members nested below Year members
(Qtr1, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that
differ by at least one member. There can be a difference in the number of
members or in the names of members.

Figure 95. Result of Filtering and Sorting Data
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You can create asymmetric reports in one of the following ways:
v Enter member names into the worksheet in free-form retrieval mode.
v Use a drill action with the Within Selected Group option selected from the

Essbase Options dialog box (Zoom tab).
v Suppress rows that contain missing values, zero values, or underscore

characters during data retrievals.

If you retrieve data into an asymmetric report, Essbase must perform
additional internal processing to maintain the asymmetric layout. This
processing may increase the retrieval time on large reports. For more
information regarding optimizing reports, see the Database Administrator’s
Guide.

As part of the default Essbase installation, Hyperion Essbase provides a
sample file, Asymm.xls, that illustrates how to create asymmetric reports.

To view the sample file, Asymm.xls:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Asymm.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

In Asymm.xls, row and column dimension groups are asymmetric. Thus,
the nested member groups from the Product dimension differ in member
content within respective markets. For example, Colas and Fruit Soda are
included in East but not in West. In addition, Actual data is displayed for

Figure 96. Asymmetric Report
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Qtr1, whereas Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also
notice that the sample file displays styles for members of the Scenario and
Year dimensions.

3. Leave the Asymm.xls file open for the next tutorial task.

Pivoting in Asymmetric Reports
When you pivot a group of members in an asymmetric report, Essbase keeps
only unique members from dimensions that are not involved in the pivot.

To use the open Asymm.xls file to illustrate this point:
1. Using the right-mouse button, drag East to the cell below Qtr1.

Essbase combines the Product members into all unique members. For
example, Root Beer, which is displayed twice in Figure 96, is displayed
only once in the current view. Colas, which is displayed in only one
market in Figure 96, now is displayed in East and West.

Essbase also removes the blank line between Product row groups. A pivot
action always eliminates any rows or columns in which all cells are empty.

2. Close Asymm.xls without saving the changes.

Working with Formatted Worksheets
In addition to providing flexible, ad hoc retrievals, Essbase supports retrieving
data into formatted worksheets. A worksheet can contain the following
formats:
v Spaces between rows and columns
v Cell values that contain text or data that is not defined in the database

outline
v Member names in noncontiguous locations at the top of a worksheet

Figure 97. Result of Pivoting in an Asymmetric Report
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v Excelformulas (see also “Preserving Formulas When Retrieving Data” on
page 119)

v Visual cues (styles)

After you format and save a worksheet, you may want to retrieve and
navigate through new data in the existing worksheet format. This section
provides the following information on working with formatted worksheets:
v “Observing the Rules for Working with Formatted Worksheets” on page 115
v “Retrieving Data into Formatted Worksheets”
v “Pivoting Data on Formatted Worksheets” on page 118

Observing the Rules for Working with Formatted Worksheets
Observe the following rules when retrieving data into a formatted worksheet:

Rule 1: In the worksheet, no numeric cells can be located before the first
Hyperion Essbase data cell. For example, in Figure 98, the first Essbase data
cell is B6. Neither any cell in rows 1 through 5 nor cell A6 can contain
numeric values. Also, these cells cannot contain formulas that resolve to
numeric values.

Rule 2: A cell that lies within a row or column of Essbase data cannot
contain text or numeric values. For example, in Figure 98, the cells in columns
B, C, D, and F and rows 6 through 9 and 11 through 14 cannot contain any
nondata text or numbers, for such values may be overwritten (or emptied) by
the retrieved data. These cells can contain formulas, however, if Formula
Preservation options are used. For more information on Formula Preservation
options, see “Preserving Formulas When Retrieving Data” on page 119.

Tip: If you need to preserve text in a cell, define that text or value as an Excel
formula, and use the Formula Preservation options.

Rule 3: The Pivot command is not available when the Retain on Retrieval
check box is selected in the Essbase Options dialog box (Mode tab).

Rule 4: The Pivot command removes all cells that contain text other than
database member names.

Retrieving Data into Formatted Worksheets
As part of the default Essbase installation, Essbase provides a sample file,
P&l.xls, that illustrates how to retrieve data into a formatted worksheet. The
P&l.xls sample file illustrates how to retrieve data into a worksheet that
contains formatted text, formulas, and protected cells.

To view the P&l.xls worksheet:
1. Select File > Open.
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2. From the \Essbase\client\sample directory, open the P&l.xls file.
Depending on how software is installed on your machine, the file may
not be available or may be located in a different directory. Contact the
Essbase system administrator for more information.

3. Select Essbase > Options and select the Display tab.
4. In the Cells option group, make sure that Adjust Columns is checked.
5. Select the Mode tab.
6. In the Formula Preservation group, select the Retain on Retrieval check

box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay
in retrieval time.

7. Click OK.
By default, an Essbase retrieval overwrites Excel formula with data
values in the retrieval area of a worksheet. The retrieval process also
eliminates formulas in cells outside the retrieval area. However, the
Retain on Retrieval option enables you to define retrievals that do not
overwrite formulas in any area of the worksheet.

8. Select Essbase > Retrieve to update the worksheet with the latest data
values.
Essbase determines that some text cells in the worksheet do not
correspond to database member names. When Essbase is unable to
resolve text in the worksheet, the following message is displayed:

Figure 98. A Sample Formatted Worksheet
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In this example, the first unknown member detected is Market: (in cell
A1). Essbase does not recognize the colon (:) that follows Market in the
cell. If you click Yes, Essbase displays the next unknown member; if you
click No, Essbase continues with the retrieval.

Note: If you work with formatted worksheets often, you may want to
tell Essbase not to display this message. For more information, see
“Pivoting Data on Formatted Worksheets” on page 118.

9. Click No to close the dialog box and continue with the retrieval.
Essbase retrieves new data but retains the formatting and formulas in the
worksheet.

10. Close P&l.xls without saving it.

Figure 99. Essbase Unknown Member Message

Figure 100. Result of Retrieving on a Formatted Worksheet
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Note: This chapter’s section on “Preserving Formulas When Retrieving Data”
on page 119 provides additional tutorial tasks that show you how to
take advantage of all the Formula Preservation options.

Pivoting Data on Formatted Worksheets
With the Pivot command, you can produce ad hoc reports in both formatted
and unformatted worksheets. However, a formatted worksheet may contain
labels and formulas that make the result of a pivot operation ambiguous. The
pivot is designed to compress and retain only the database elements
represented in the worksheet. The worksheet also retains labels in areas that
are not overwritten by pivoted data.

Note: Essbase prevents pivot operations on worksheets that contain formulas
when Formula Preservation mode is active.

Inv.xls, a sample file installed as part of the Essbase installation process,
illustrates how to pivot data in a worksheet. It was saved with the Retain on
Retrieval option disabled so that you can pivot on its worksheets.

To view the Inv.xls worksheet:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Inv.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

3. Select Essbase > Options and select the Global tab.

Figure 101. Formatted Worksheet Before Pivoting
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4. In the Display Messages group, clear the Display Unknown Members
check box to avoid seeing the Essbase messages when working with
formatted worksheets.

5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested
below Jan (C4).
Essbase pivots the Sales member group so that it is nested below the
monthly members. However, during the pivot, Essbase retains only
database elements. For example, all data for Stock to Sales and Adjusted
for Audit is deleted during the pivot.

6. Close Inv.xls without saving it.

Preserving Formulas When Retrieving Data
In “Retrieving Data into Formatted Worksheets” on page 115, you used the
Retain on Retrieval option to preserve formatting and formulas in an existing
worksheet. Collectively, the Formula Preservation options enable you to retain
formulas during data retrievals, keep and remove only operations, and drill
operations. In addition, Essbase can replicate formulas for additional members
retrieved into the worksheet as part of a drilling operation. This section steps
you through using all of the Formula Preservation options in a report that you
create.

You must enable some options before you can enable other options. Keep in
mind the following guidelines and restrictions when using the Formula
Preservation options:
v On the Mode tab of the Essbase Options dialog box, you must have the

Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.

Figure 102. Result of Pivoting on a Formatted Worksheet
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v You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

v You must enable Retain on Zooms to enable Formula Fill.
v When you select the Retain on Retrieval check box, the Suppress #Missing

Rows and Zero Rows options on the Display tab become disabled.
Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.

v When you select the Retain on Zooms check box, the Remove Unselected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

v When Retain on Retrieval is enabled, there may be a slight delay in
retrieval time.

v As a general rule, insert a blank row as the last row in the formula range to
ensure that the cell range in the formula expands properly when you drill
down on members with Retain on Zooms enabled. For more information,
see the Essbase Spreadsheet Add-in online help.

v Formula arrays are not supported in Essbase Spreadsheet Add-in when the
preserve formula option is on. If you have formula arrays in the worksheet,
Essbase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:

1. To open a new worksheet, select File > New or click the button.
2. Select Essbase > Retrieve.
3. In cell A2, drill down (double-click) on Year.
4. Press and hold the Alt key and, in cell E1, drill down (double-click) on

Scenario.
5. Select cell G3 and enter the following formula in the cell: =B3/B$7*100.

Note: The $ in front of the 7 anchors the formula to the Year member.
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6. Press Enter.
Excel calculates the formula that you entered in cell G3 and now reflects
Qtr1 as a percentage of Year.

7. Select Essbase > Options and select the Mode tab.
8. In the Formula Preservation area, select the check boxes for Retain on

Retrieval and Retain on Keep and Remove Only. Click OK.
9. In cells D2, E2, and F2, respectively, select Variance, %Variance, and

Scenario.
10. Select Essbase > Remove Only.

Essbase removes the selected columns but retains the Excel formula that
you entered, keeping it with the retained dataset.

Figure 103. Entering an Excel Formula into a Cell

Figure 104. Result of Excel Formula with Essbase Data
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11. Select Essbase > Options and select the Mode tab.
12. In the Formula Preservation area, click the box for Retain on Zooms and

click OK.
13. In cell A3, drill down (double-click) on Qtr1.

Essbase drills down on Qtr1 and moves the formula down with the Qtr1
member.

14. Select Essbase > FlashBack.
15. Select Essbase > Options and select the Mode tab.
16. In the Formula Preservation area, select the Formula Fill check box.

Click OK.
17. In cell A3, drill down (double-click) on Qtr1.

Figure 105. Result of Removing Columns with Retain on Keep or Remove Only Enabled

Figure 106. Result of Drilling Down with Retain on Zooms Enabled
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Essbase drills down on Qtr1 and replicates the formula for each member
of Qtr1 (Jan, Feb, and Mar). To view the replicated formulas, click in cells
D3, D4, D5, and D6 and look at the new syntax in the Excel formula bar.

18. Before moving on with the tutorial, complete each of the following
actions:
a. Select Essbase > Options and select the Mode tab.
b. Clear all of the Formula Preservation options.
c. Select File > Close to close the worksheet. You do not need to save

the worksheet.

Retrieving a Range of Data
In a typical Excel worksheet, you can select a range of cells by dragging the
mouse across the worksheet. You can also select a range of cells and tell
Essbase to restrict the data retrieval to the selected range in the worksheet.
Retrieving a range of data is particularly useful in the following situations:
v A worksheet contains multiple reports.
v A worksheet contains extraneous information that is not supported in a

formatted report retrieval.
v You need to retrieve only a small subset of values from the server, thus

dramatically decreasing retrieval time for large datasets.
v You need to retrieve data to an area of the worksheet other than the first

column.

As part of the default Essbase installation, Essbase provides a sample file,
Profit.xls, that illustrates how to retrieve a range of data.

Figure 107. Result of Drilling Down with Formula Fill Enabled
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To view the Profit.xls file:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Profit.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.
Profit.xls has already selected a range of cells (B2 through F9) for you.

3. Select Essbase > Retrieve to update the selected range.

Figure 108. Selected Range of Cells for Retrieval
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Essbase updates only the data in the selected range of cells.
4. Select cells B12 through G16.

5. Select Essbase > Retrieve once again to update the selected range.
Essbase updates the data in the selected range.

Figure 109. Result of Retrieving First Range of Data

Figure 110. Selecting Cells for Retrieval
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6. Close Profit.xls without saving it.

Retrieving Data by Using a Function
The Essbase cell retrieve function, EssCell, retrieves a single database value
into a worksheet cell. Enter an EssCell function directly into a worksheet or
select an EssCell function from the Excel menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform an Essbase retrieval or when you
recalculate a worksheet through Excel. As part of the default Essbase
installation, Hyperion Essbase provides a sample file, Summary.xls. This file
has EssCell functions already set in cells B16 and B17.

To view the Summary.xls file:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Summary.xls file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Figure 111. Result of Retrieving Second Range of Data
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Cells B16 and B17 in Summary.xls contain the EssCell function. If you
select either of these cells, you can view the syntax for the EssCell function
in the Excel formula bar at the top of the worksheet.

The EssCell function is defined in a cell as follows:

=EssCell(mbrList)

mbrList is one of the following:
v A null value. If the parameters of the function are empty, Essbase

returns the data value from the top of each dimension.
v A comma-delimited list of member names. Member names must be

enclosed in double quotes, with only one member per dimension
allowed. If you list no members from a particular dimension, the
function returns the data value from the top member of the unspecified
dimension. Furthermore, you can include aliases in the member list,
subject to the same rules as member names.

v An Excel cell reference. The reference must point to a cell that contains
a valid member name. Member names, such as 200 and 300-10, need to
be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B16 in the
Summary.xls file is the following:

Figure 112. Worksheet Containing EssCell Functions
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=EssCell("Sales", A1, A2, B4, F5)

When you open the worksheet, the values in these cells are #N/A. To
update the values with the data in your database, you must perform a
retrieval from Essbase.

3. Select Essbase > Retrieve. Essbase calculates the EssCell functions in cells
B16 and B17.

Now update the EssCell functions to retrieve data for a different state.
4. Change the contents of cell A2 from Texas to Florida.

The values in cells B16 and B17 are updated as soon as you update the
cell. The update occurs because Excel has recalculated the worksheet (if
you have configured Excel to calculate changes automatically). The
remaining data cells do not change. To completely update the worksheet,
you must retrieve data from the server.

Figure 113. Retrieval on a Worksheet Containing the EssCell Function
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Tip: If the worksheet contains many EssCell functions, change Excel to
manual calculation mode. This change prevents the cell retrieve from
calculating until you retrieve data or calculate the worksheet
manually. For more information, see the Microsoft Excel
documentation.

5. Select Essbase > Retrieve to update the report.
Essbase returns an error message if EssCell is unsuccessful. The following
table lists messages that Essbase displays in the EssCell cell and explains
the conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double quotation
marks.

6. Close Summary.xls without saving it.

The sample file that you used for this tutorial task already had EssCell
functions defined.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

Figure 114. Updating the EssCell Function
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To enter your own EssCell function into a worksheet, you do the following:

1. From the Excel menu bar, select Insert > Function.

2. From the Function Category list, select Essbase Add-in.

The Excel Function Wizard steps you through defining the EssCell function.

Note: For more information on EssCell functions, see the Essbase Spreadsheet
Add-in online help.

Retrieving Dynamic Calculation Members
Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation
time. The Essbase application designer tags dynamic calculation members in
the database outline so that Essbase knows not to calculate those members
until a data retrieval requests them. This process is referred to as dynamic
calculation. Dynamically calculating database members benefits the Essbase
server in the following ways:
v Reduced disk usage
v Reduced database restructuring time
v Reduced time to back up the database

Database values that Essbase calculates dynamically take slightly longer to
retrieve in Essbase Spreadsheet Add-in because Essbase must perform
calculations before retrieving data into the worksheet. For more information on
dynamic calculation, see the Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the
spreadsheet report so that Essbase does not dynamically calculate the
database when you are creating the report. For more information on the
Navigate Without Data feature, see “Navigating Through the Worksheet
Without Retrieving Data” on page 46.

Because there may be a performance impact on retrieving data for dynamic
calculation members, define visual cues, or styles, for these members so that
you can identify them in Essbase Spreadsheet Add-in.

To illustrate how to use Dynamic Calculation members, use the Asymm.xls file.

To view the Asymm.xls file:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Asymm.xls file.
3. Drill up on Actual by double-clicking the right-mouse button in cell C3.
4. In cell C3, drill down on Scenario to display all members of Scenario.
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Essbase displays only the Scenario members for Qtr1.

5. Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the
Style tab. For more information on connecting to a database, see
“Connecting to a Database” on page 97.

6. In the Members group, scroll down until you see Dynamic Calculations.
7. Select the Dynamic Calculations check box and click the Format button.
8. In the Font style list, select Bold Italic.
9. In the Color list, select Gray.

10. Click OK and then select the Display tab.
11. In the Cells option group, click Use Styles. Click OK.
12. Select Essbase > Retrieve.

Essbase displays the data and applies all the visual cues, or styles, that
you set, including the newly set styles for dynamic calculation members
and the styles you set in Chapter 3. You can tell that the columns for
Variance and Variance% are dynamically calculated because Hyperion
Essbase displays these members in gray, bold, italicized font. (Variance
and Variance% also have a red background because that style was
previously set for all members of the Scenario dimension.)

Figure 115. Displaying Scenario Members
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Note: Occasionally, other styles you have set may override a style for
dynamic calculation members. For example, if a parent member is
also a dynamic calculation member, and if you have styles set for
both parent and dynamic calculations, the style for the parent
member overrides the style for the dynamic calculation member. In
this case, you need to remove the style for parent members in
order to see the style for dynamic calculation members. For more
information on the precedence of styles, see “Determining the
Precedence of Overlapping Styles” on page 60.

13. Close the Asymm.xls file without saving it.

Specifying the Latest Time Period for Dynamic Time Series
Dynamic Time Series members are predefined database members that are used
in dynamic, to-date reporting, such as year-to-date or month-to-date values.
Dynamic Time Series members do not display as individual members in the
database outline; instead, they correspond to a generation name that uses a
key term for time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter
was created for generation 2 in the Year dimension. Generation 2 includes the
members for Qtr1, Qtr2, Qtr3, and Qtr4. When the generation name Quarter
was created, Essbase created a Dynamic Time Series member called Q-T-D, or
quarter-to-date.

To take advantage of Dynamic Time Series in Essbase Spreadsheet Add-in,
choose the latest time period for which you want data in a to-date calculation.
The calculated value of the Dynamic Time Series member is derived when
you define the latest time period to be reported. In the Sample Basic database,
for example, the level 0 members of the Year dimension are the months of the
year: Jan, Feb, Mar, and so on. If the current month is August, and you want

Figure 116. Result of Retrieving Dynamic Calculation Members
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to know the sales data for the quarter up to the current month, a
quarter-to-date calculation gives you the sales data for the months of July and
August.

To illustrate the concept of Dynamic Time Series:

1. To open a new worksheet, select File > New or click the button.
2. Select Essbase > Options and select the Zoom tab.
3. In the Zoom In option group, select Next Level.
4. Clear the Within Selected Group check box and click OK.
5. Select Essbase > Retrieve.
6. In cell B1, drill down (double-click) on Measures.
7. In cell B2, click Year.
8. Type Q-T-D in cell B2 and press Enter to enter a predefined Dynamic

Time Series member (Q-T-D):

Note: For a list of other possible Dynamic Time Series members, see the
Essbase Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.
10. In the Dynamic Time Series area, select the Latest Time Period check

box.
11. From the list box, select May. Click OK.

Figure 117. Entering a Dynamic Time Series Member into a Worksheet
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Note: If you do not specify a latest time period, Essbase uses the first
level 0 member (Jan) as the default.

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not
supported with Dynamic Time Series members.

Essbase displays data for the Q-T-D member. The data values in the
worksheet are the aggregated values for April and May, because May is
the month you specified as the latest month in the quarter-to-date
Dynamic Time Series.

Figure 118. Specifying Latest Time Period in a Dynamic Time Series
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13. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Note: You can also create a report like the one shown above by simply typing
the name of the Dynamic Time Series member followed by the name of
latest time period in parentheses: for example, Q-T-D (May). If you are
using free-form retrieval mode, you must enter the Dynamic Time
Series member and the latest time period in separate, adjacent cells.
You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member
Selection.

Note: For more information on Dynamic Time Series, see the Essbase
Spreadsheet Add-in online help.

Using Substitution Variables
The Essbase application designer uses substitution variables to define global
variables to represent values that are specific to Essbase. For example, Latest
can be a substitution variable representing the latest time period in a Dynamic
Time Series. Using Essbase Application Manager, the application designer sets
substitution variables and their corresponding values for a specific
application. Essbase stores these variables and their values on the Essbase
server. You can take advantage of the predefined substitution variables in
Essbase Spreadsheet Add-in during Dynamic Time Series reporting

.For example, say the application designer sets a substitution variable on the
server for the current month. The variable is called CurMnth and has a value
of August. If you use the substitution variable in the worksheet, a retrieval
returns values for August, because August is set as the current month on the
server. If, at a later date, the application designer changes the value of the
CurMnth substitution variable to October, a retrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a
substitution variable in the database you are using, you could enter a

Figure 119. Result of Specifying Latest Time Period in a Dynamic Time Series
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substitution variable directly into a worksheet. For example, you could open a
blank worksheet and type member names as follows:

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an
ampersand (&).

In this example, a retrieval produces the following results:

Essbase queries the server for the value of the substitution variable CurMnth,
which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a
template, make sure that you save the worksheet before you retrieve
data. For example, if you save the worksheet shown in Figure 121 as a
template, each time you retrieve the template, August rather than the
substitution variable CurMnth is displayed.

Using Free-Form Reporting to Retrieve Data
So far, you have learned how to retrieve Essbase data into a worksheet
through ad hoc retrieval, Hyperion Essbase Query Designer queries, and
Member Selection operations. In addition to these retrieval methods, Essbase

Figure 120. Entering a Substitution Variable in a Worksheet

Figure 121. Result of Retrieval on a Substitution Variable
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supports free-form reporting. Free-form reporting enables you to tell Essbase
specifically what you want to retrieve by simply typing data into the
worksheet. Free-form reporting is especially useful when you are familiar with
the dimensions and members in the database outline.

Essbase provides two different retrieval modes for free-form reporting:
v Advanced Interpretation
v Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode
The Essbase server contains an advanced spreadsheet interpretation engine
that scans a worksheet and interprets its content when fulfilling retrieval
requests. When you construct a report by entering names directly into a
worksheet in Advanced Interpretation retrieval mode, Essbase interprets the
member names and creates a default view that is based on the location of the
labels.

Keep in mind the following guidelines when you are working in Advanced
Interpretation mode:
v Precede all member names that consist of numbers with a single quotation

mark. For example, for Product dimension member 100, type ’100 in the
worksheet.

v If you define a report that does not contain all of the database dimensions,
you may need to enter a dummy value, such as 0, in the first data cell.
Essbase overwrites this value with the contents of the database cell upon
retrieval. Be sure to use a numeric value as the dummy value.

To construct a free-form report in Advanced Interpretation retrieval mode:

1. To open a new worksheet, select File > New or click the button.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation (the default

setting) and click OK.
4. Enter member names and data as in the following illustration.

Note: If a member name consists of a number, such as 100, you must
precede the member name with a single quotation mark (for
example, ’100). This rule also applies to member names with spaces
between words.
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5. Select Essbase > Retrieve or double-click in a data cell.
Essbase retrieves data for the members you entered into the free-form
report and implements the Use Aliases option that you set in the Essbase
Options dialog box in the beginning of this chapter.

Now define a free-form report that does not contain all of the dimensions
from the database. In Advanced Interpretation mode, you may need to enter a
dummy data value, such as 0, into the first Essbase data cell to tell Essbase
where the data starts in the worksheet. Be sure to use a numeric value as the
dummy value.

For example:
1. Select Essbase > FlashBack.
2. Delete cells A1, B1, and C1.

Figure 122. Creating a New Free-Form Report

Figure 123. Retrieving Data into a Free-Form Report
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3. In cell B4, type 0 in cell B4 to provide Essbase with a data cell reference
point.

4. Select Essbase > Retrieve.
Essbase adds the dimensions that were omitted from the free-form report
to the worksheet and retrieves data.

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Free-Form Mode
Similar to Advanced Interpretation mode, Free-Form mode enables you to
enter member names into any location in a worksheet and then interprets the

Figure 124. Defining a Free-Form Report Without All Dimensions

Figure 125. Retrieval in a Free-Form Report Without all Dimensions
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contents of the worksheet when fulfilling the retrieval request. In addition,
with Free-Form mode, you can use Essbase report script commands to retrieve
data into a worksheet.

Report script commands are most useful for defining member references that
can bring back the most current member information dynamically. For
example, if you need to create a report that shows every product, including
the products added since the last retrieval, standard retrieval mode reflects
changes only when you zoom in on the product. If you use the report script
command <IDESCENDANTS, Essbase retrieves all descendants of a specified
member, including the specified member. For more information on the syntax
of report script commands and on guidelines for developing reports, see the
Technical Reference in the docs directory and the Database Administrator’s Guide

.Keep in mind the following guidelines when working in Free-Form retrieval
mode:
v You must precede all member names that consist of numbers with a single

quotation mark. For example, for the Product dimension member 100, you
need to type ’100 in the worksheet.

v You cannot cancel a retrieve in Free-Form mode.
v You cannot apply Essbase styles in Free-Form mode.
v Essbase removes blank rows and columns on any retrieval action.
v Do not use Report Writer formatting commands, such as {BRACKETS},

{DECIMAL}, and {EUROPEAN} in Free-Form mode, because they are
incompatible with Excel’s formatting features.

v When you are in Free-Form mode, an Auto Sort Rows option is enabled in
the Display tab of the Essbase Options dialog box. If you select this feature,
Essbase retrieves data in symmetric rows. The rows are sorted according to
the order specified in the database outline.

v Not all Formula Preservation and Modes options (Essbase Options dialog
box, Mode tab) are available in Free-Form mode.

v To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb))
in the same cell. You need to type the Dynamic Time Series member, Q-T-D
in one cell, and the latest time period within parentheses, (Feb), in a
separate, adjacent cell.

To construct a free-form report in Free-Form retrieval mode:

1. To open a new worksheet, select File > New or click the button.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Free Form.
4. Select the Display tab.
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5. In the Cells option group, select Auto Sort Rows. Click OK.
6. Enter the member names into the worksheet as shown in Figure 126:

7. Select Essbase > Retrieve.
Essbase retrieves data for the members and creates a default view
according to the location of the labels. Note that three members were
pivoted from row groups to column groups.

8. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Now create a report by entering member names and a report script command:

1. To open a new worksheet, select File > New or click the button.
2. Enter the member names into the blank worksheet as shown in Figure 128.

3. In cell A3, type <IDESCENDANTS Product. Press Enter.

Figure 126. Typing Member Names In a Free-Form Report

Figure 127. Result of Retrieving in Free-Form Retrieval Mode

Figure 128. Typing Member Names in a Free-Form Report

Chapter 4. An Advanced Essbase Tutorial 141



4. Select Essbase > Retrieve.
Essbase retrieves data into the worksheet for all descendants of Product
and for the members you entered in the worksheet.

Note: When Essbase completes the retrieval, the report script command is
overwritten by the data it returns. You can use FlashBack to restore
the previous view in Free-Form mode.

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Attributes in Free-Form Reporting
Essbase enables you to retrieve data selectively by specifying attributes that
are associated with a base dimension. For example, in the Sample Basic
database, the Product base dimension is associated with attributes such as

Figure 129. Typing a Report Script Command in a Free-Form Report

Figure 130. Result of a Retrieve with a Report Script Command
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packaging and size. You can enter an attribute name into the worksheet to
retrieve data that is associated with that attribute.

To use attributes in a free-form report:

1. To open a new worksheet, select File > New or click the button.
2. Enter member names as shown in the Figure 131.

Caffeinated is an attribute dimension associated with the Product base
dimension. Bottle is a level 0 member of the Pkg_Type attribute
dimension. The Pkg_Type dimension is associated with the Product base
dimension. A level 0 member is the lowest level member in a dimension.

3. Click in any empty cell and select Essbase > Retrieve or double-click in an
empty data cell.
Essbase retrieves information on profits for the first quarter of the year for
all members of the Product base dimension that are associated with both
the level 0 attribute members of the Caffeinated attribute dimension
(Caffeinated_True and Caffeinated_False) and the level 0 member Bottle of
the Pkg_Type attribute dimension. The results should display as shown
below:

4. You can drill down to data on the level 0 attribute members of the
Caffeinated attribute dimension. The results should display as shown
below:

Figure 131. Using Attributes in Free-Form Reports

Figure 132. Result of Using Attributes in Free-Form Reports

Figure 133. Drilling Down on Attributes in Free-Form Reports
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5. To drill down further for data on profits for the first quarter for all
members of the East base dimension, double-click on cell E1. The results
should display as shown below:

Entering Generation and Level Names
In addition to entering database member names into a free-form report, you
can enter generation or level names directly into a worksheet to retrieve
specific members. The Essbase application designer defines generation and
level names for database dimensions in the database outline. You have two
options for discovering what generation and level names are defined in the
database:
v View generation and level names in the Essbase Member Selection dialog

box or through Essbase Query Designer.
v Contact the Essbase application designer to see what generation and level

names are defined in the database outline.

To enter generation and level names directly into a free-form report:

Figure 134. Result of Drilling Down on East
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1. To open a new worksheet, select File > New or click the button.
2. Select Essbase > Options and select the Mode tab.
3. In the Retrieval option group, select Advanced Interpretation. Click OK.
4. Enter member names as shown in Figure 135:

5. Enter a generation name as shown in Figure 136:
Family is a generation name in the Product dimension. The name is
already defined in the Sample Basic database.

6. Select Essbase > Retrieve.
Essbase retrieves data for the member and generation names that you
entered. The Family generation name expands to its individual members.

Figure 135. Entering Member Names in a Free-Form Report

Figure 136. Entering a Generation Name in a Free-Form Report
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7. Change Year to a level name (Lev0,Year) as shown in the following
illustration.

Note: Be sure not to insert a space between the comma after 0 and the
word Year. Generation and level names that are entered directly into
a worksheet must be precise.

8. Select Essbase > Retrieve.
Essbase retrieves data for the level 0 members of the Year dimension,
which are the individual months (Jan, Feb, Mar, and so forth).

Figure 137. Result of Free-Form Retrieval with Generation Name

Figure 138. Entering a Level Name in a Free-Form Report
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9. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to a cell in a Essbase database. The file, note, or Web
resource (indicated by a URL, or Uniform Resource Locator) can then be
retrieved by the Essbase Spreadsheet Add-in users who have access to the
database.

Note: If your organization has licensed and implemented Essbase Partitioning
option, you can also access linked partitions from cells in Essbase
Spreadsheet Add-in. For more information on linked partitions, see
“Accessing Linked Partitions” on page 166.

This section describes the following procedures:
v “Linking a File to a Data Cell” on page 148
v “Linking a Cell Note to a Data Cell” on page 152
v “Linking a URL to a Data Cell” on page 154
v “Accessing and Editing Linked Reporting Objects” on page 156

Note: For additional information on using linked reporting objects, see the
Essbase Spreadsheet Add-in online help.

Figure 139. Result of Free-Form Retrieval with Level Name
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Linking a File to a Data Cell
With the linked reporting objects feature, you can link an external file to a
data cell in Essbase Spreadsheet Add-in. Essbase stores the file on the Essbase
server. Users who have access to the database can then retrieve the file and
view the data contained in the cell.

The following example uses the Asymm.xls sample worksheet with data from
the Sample Basic database. It links a sample file, Budasmp.txt, to a cell
containing the Budget figure. Budasmp.txt details the budgetary assumptions
for the current year.

Follow these steps to link a file to a data cell:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Asymm.xls file.
3. Make sure that you are connected to the Sample Basic database. If you

are not connected, see “Connecting to a Database” on page 97.
4. Select cell D5.

Note: You can link objects only to data cells, not to cells containing
member names.

5. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.

Figure 140. Selecting a Data Cell for Linking an External File
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6. In the Linked Objects Browser dialog box, click the Attach button.
Essbase displays the Attach Linked Object dialog box.

7. Under the Attachment Type option group, select File.

Figure 141. Linking a File
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8. Click the Browse button (next to the File Name text box).
Essbase displays the Browse Files dialog box.

9. Go to the \Essbase\client\sample directory and select the Budasmp.txt
file.

10. Click Open.
11. Under File Description, enter a brief description for the file as indicated

in Figure 143.

Figure 142. Linking a File to a Data Cell
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Note: Entering text in the File Description text box is optional.
12. Click OK to close the dialog box and link the file to the cell.

Essbase copies the file to the server and establishes a link to the current
data cell.

13. Click Close to close the Linked Objects Browser dialog box.
14. Do not close the Asymm.xls file. You use it in the next tutorial task.

To recognize cells that have linked reporting objects attached to them, you
may want to apply a visual cue, or style, to the cells.

To apply styles:
1. Select Essbase > Options and select the Style tab.
2. In the Data Cells area, select Linked Objects.
3. Click Format.
4. In the Font style list box, select Italic.
5. In the Color list box, select Purple. Click OK.
6. Select the Display tab.
7. In the Cells option group, select the Use Styles box. Click OK.
8. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Figure 143. Selecting and Describing a File to Link
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Cell D5 (the cell you just attached the linked file to) is now displayed in
purple, italic font. Essbase also refreshes the worksheet with the other
options set in the Essbase Options dialog box.

9. Leave the Asymm.xls file open for the next tutorial task.

Linking a Cell Note to a Data Cell
In addition to linking external files to a data cell in Essbase Spreadsheet
Add-in, you can also link individual cell notes that contain information on
particular data cells. Cell notes can have no more than 599 characters. If you
need to link information to a data cell that is longer than 599 characters, you
need to create and save an external file and then link the file to the data cell.

To link a cell note to a data cell:
1. In the Asymm.xls file, select cell C5.

Note: You can link objects only to data cells, not to cells containing
member names.

2. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.

3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select Cell Note.
5. In the Cell Note box, type the note as indicated in the following

illustration:

Figure 144. Result of Applying a Style to a Linked Reporting Object Cell
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6. To close the dialog box and link the cell note, click OK.
Essbase copies the note to the server and establishes a link to the current
data cell.

7. To close the Linked Objects Browser dialog box, click Close.
8. Select Essbase > Retrieve to refresh the worksheet and apply the style you

defined for linked objects.
Now Essbase displays two data cells (C5 and D5) in purple, italic font to
represent a cell that contains a linked reporting object.

9. Leave the Asymm.xls file open for the next tutorial task.

Figure 145. Creating a Cell Note to Link

Figure 146. Result of Creating a Linked Cell Note
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Linking a URL to a Data Cell
A URL is an address string that identifies resources on the World Wide Web,
such as documents, images, and downloadable files. With the linked reporting
objects feature, you can link a URL to a data cell so that users who have
access to the database can link directly to the specified URL. When you access
the cell from Essbase Spreadsheet Add-in, your default Web browser opens
and displays the specified URL.

Note: For more information on URL syntax, see the Essbase Spreadsheet
Add-in online help.

If you have a Web browser and Internet access, follow these steps to link a
data cell to the Hyperion Web site:
1. In the Asymm.xls file, select cell E5.

Note: You can link objects only to data cells, not to cells containing
member names.

2. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.

3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select URL.

Figure 147. Selecting a Data Cell for Linking to a URL
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5. Enter a URL in the Location text box and a brief description in the URL
Description text box, as indicated in Figure 149.

Figure 148. Linking a URL to a Data Cell
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Note: Entering text in the URL Description text box is optional. The text
field for entering the URL location is limited to 512 characters. The
text field for entering the URL description is limited to 80
characters.

6. To close the dialog box and link the URL to the cell, click OK.
Essbase copies the URL string to the server and establishes a link to the
current data cell.

Note: The syntax for the URL is not checked at creation time; Essbase
checks the syntax when the user accesses the URL from the
worksheet. The default Web browser checks for the existence (or
validity) of the URL.

7. To close the Linked Objects Browser dialog box, click Close.
8. Select Essbase > Retrieve to refresh the worksheet and apply the style that

you defined for linked objects.
9. Leave the Asymm.xls file open for the next tutorial task.

Now that you have learned to create linked reporting objects, you are ready to
learn how to access them from Essbase Spreadsheet Add-in.

Accessing and Editing Linked Reporting Objects
You have two options for accessing and editing a linked reporting object that
is attached to a data cell:

Figure 149. Entering and Describing a URL to Link
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v Select the cell (as identified by the style applied to it) and select Essbase >
Linked Objects.

v Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing,
double-clicking behavior changes for retrieving data and performing
drill actions. For more information on these changes, see the Essbase
Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in
the previous sections by using the Essbase menu item instead of the
double-clicking action.

Accessing a Linked File
Sometimes you want to check an external file that is linked to a data cell.

To access the external file that you previously linked to a data cell:
1. In the Asymm.xls file, select cell D5.
2. Select Essbase > Linked Objects.
3. In the Linked Objects Browser dialog box, select the Budasmp.txt file.

4. To view the linked file, click View/Launch.
The Budasmp.txt file is opened from the source application.

Figure 150. Accessing a Linked External File
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Note: Edit the contents of a file in the source application. After the edits
are made and the file saved, you can re-attach the edited file by
clicking the Edit button in the Linked Objects Browser dialog box.
Essbase displays the Re-attach Linked Object dialog box, which you
can use to re-attach, or relink, the edited file to the data cell. For
more information, see the Essbase Spreadsheet Add-in online help.

5. Close the Budasmp.txt file and click Close to close the Linked Objects
Browser dialog box.

6. Leave the Asymm.xls file open for the next task.

Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

To access and edit the cell note that you previously created:
1. In the Asymm.xls file, select cell C5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is
linked to the selected data cell.

3. In the Linked Objects Browser dialog box, select the cell note.

Figure 151. Viewing the Contents of a Linked External File
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4. To edit the contents of the cell note, click Edit.
Essbase displays the Edit Cell Note dialog box with the selected cell note
displayed.

Note: If you simply want to view the contents of the cell note, click the
View/Launch button instead of the Edit button in the Linked
Objects Browser dialog box.

Figure 152. Accessing a Linked Cell Note

Figure 153. Editing the Contents of a Linked Cell Note
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5. Edit the contents of the cell note as indicated in the following illustration:

6. Click OK to close the Edit Cell Note dialog box and save the edits you
made to the note.
Essbase saves the edits to the cell note on the server.

7. To close the Linked Objects Browser dialog box, click Close.
8. Leave the Asymm.xls file open for the next tutorial task.

Accessing a Linked URL
If you followed the steps in “Linking a URL to a Data Cell” on page 154, you
can access and edit the URL that you created.

To access the URL:
1. In the Asymm.xls file, select cell E5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to
the selected data cell.

3. In the Linked Objects Browser dialog box, select the URL.

Figure 154. Result of Editing Cell Note Contents
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4. To view the linked URL, click View/Launch.
Essbase checks the syntax of the URL. If there are syntax errors, Essbase
displays an error message. If the URL syntax is correct, the default Web
browser launches and connects to the specified site. In this case, the syntax
for the URL is correct, so the default Web browser launches and connects
to the Hyperion Web site.

Figure 155. Accessing a Linked URL
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5. Close the Web browser.

To edit the URL:
1. In the Linked Objects Browser dialog box, select the URL.
2. To edit the linked URL, click Edit.

Essbase displays the Edit URL dialog box with the selected URL
displayed.

Figure 156. Viewing a Linked URL
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3. Edit the URL location and description as show in the following
illustration:

4. To close the Edit URL dialog box and save the edits that you made, click
OK.
Essbase saves the edits to the URL on the server.

5. To view the new URL, click View/Launch.
The Web browser launches and connects to the new URL.

Figure 157. Preparing to Edit the Contents of a Linked URL

Figure 158. Editing the Contents of a Linked URL
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6. Close the Web browser.
7. To close the Linked Objects Browser dialog box, click Close.
8. Close the Asymm.xls file without saving it.

Connecting to Multiple Databases

Essbase supports simultaneous access to multiple databases. The databases
can be in different applications and can be stored on different servers. In
Excel, you can open multiple worksheets, each of which can be connected to a
different database. An individual worksheet can access only one database at a
time. Use the Connect command from the Essbase menu to switch the
connection between databases.

Figure 159. Viewing an Edited URL
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Note: Depending on the status of production applications at your site, you
may not have access to additional applications or databases. Check
with the Essbase system administrator if you need access to other
applications.

For this tutorial, you do not need to connect to another database.

Note: Tasks that you should not perform as part of the tutorial are shown in
light colored boxes.

To access multiple databases, use the following procedure:

1. Select Essbase > Connect.

2. In the Essbase System Login dialog box, select the server you want to access
from the Server list box (or type in the name of the server).

3. Press Tab to move to the Username text box and type your username.

4. Press Tab to move to the Password text box and type your password.

5. Click OK to connect to the server.

When the server connection is complete, a list of available application and
database pairs is displayed in the Application/Database list.

6. Double-click the Application/Database pair that you want to connect to in the
Application/Database list. Alternatively, you can select the Application/Database
pair and click OK.

If the application is not already running, Essbase automatically starts it. There
may be a brief pause as the application loads; the time required to start an
application depends on number of databases, the sizes of the databases, and the
sizes of the indexes of the databases contained within the application.

7. Open a new worksheet and repeat the steps to connect to additional databases.
You can open one database at a time per worksheet.

For information on connecting to multiple databases from Essbase Query
Designer, refer to Chapter 3.

Viewing Active Database Connections
If you frequently connect to multiple databases, you may need to check the
active database for each worksheet. There are two ways to view the database
connection status:
v The Style tab of the Essbase Options dialog box contains a Connection

Information text box. This box displays connection information for the
active worksheet.

v The Essbase Disconnect dialog box lists all active worksheets and their
connection information. This dialog box also enables you to disconnect one
or more worksheets from their respective databases.
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Accessing Linked Partitions

Linked partitions are part of the Essbase Partitioning product. They provide the
ability to link Essbase databases that contain different dimensions without
losing access to all dimensions of both databases. If your organization has
purchased and implemented the partitioning product, you can take advantage
of its powerful capabilities. The Database Administrator’s Guide describes how
to design and implement a linked partition. The Essbase application designer
usually sets up partitioning.

Note: The Partitioning product also enables the Essbase application designer
to set up transparent or remote partitions. For more information on
partitioning, see the Database Administrator’s Guide.

You can set visual cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. You have
two options for accessing a linked partition from a data cell in Essbase
Spreadsheet Add-in:
v Select the cell and select Essbase > Linked Objects.
v Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Essbase Spreadsheet Add-in online
help.

When you select Essbase > Linked Objects from a linked partition cell,
Hyperion Essbase completes the following actions:
v Essbase displays the Linked Objects Browser dialog box, which contains a

list of possible partitions to access. From this dialog box, select the partition
to connect to.

Note: The Linked Objects Browser dialog box may also contain a list of
linked reporting objects, such as cell notes and external files. For
more information, see “Using Linked Reporting Objects” on page
147.

v After you select a partition, Essbase creates a new worksheet that contains
corresponding members and dimensions for the cell in the linked partition.

Note: Essbase does not preserve formulas across partitions.
v Essbase retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more
information on the new worksheet.
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Note: The Sample Basic database that you are using for this tutorial does not
contain a linked partition. Tasks that you should not perform as part of
the tutorial are shown in light colored boxes.

To access a linked partition in Essbase Spreadsheet Add-in if the Essbase application
designer has a linked partition set up:

1. Locate a linked object cell, as indicated by the style applied to the cell.

2. Select Essbase > Linked Objects to open the Linked Objects Browser dialog box.
Note: Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box to enable double-clicking to view linked objects.

3. Select the partition that you want to connect to and click View/Launch.

Figure 160. Linked Objects Browser Dialog Box, Linked Partition

Essbase creates a new worksheet that contains the dimensions and members for the cell in the linked
partition.

Note: You need to have the proper privileges to access a linked partition. If
your user account and password match the account information for the
linked partition, Essbase establishes a connection with the linked
partition. Otherwise, Essbase displays the Essbase System Login dialog
box for you to enter the user account and password information
manually.
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Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve data into the worksheet, you
can use Essbase Spreadsheet Add-in to change values, enter formulas, and
format data. Essbase is also designed to permit multiuser, concurrent database
access and update. Depending on your security privileges, you may be able to
modify all data values or a certain subset of values. To recognize cells to
which you have read/write access, apply a visual cue, or style, to the cells.
For more information, see “Applying Styles to Data Cells” on page 59. To
update data from a worksheet, you must lock the database area that contains
the values that you want to change. Locking prohibits other users from
changing the data that you want to update. Other users can retrieve locked
data but cannot lock or change the data. You have exclusive update rights to
that area.

Note: You cannot update attribute-related data on the server because attribute
data is always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:
v The Retrieve & Lock command retrieves data into the worksheet while

locking the corresponding data area on the server. When you perform a
subsequent retrieval, Essbase automatically unlocks the previous data
values.

Note: The Retrieve & Lock command is not supported with Dynamic Time
Series members.

v The Lock command locks information that you have already retrieved.
When you perform a subsequent retrieval, Essbase automatically unlocks
the previous data values.

v The Update Mode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send
command on the Essbase menu. After updating the server, the Send command
automatically unlocks data (unless you are in Update Mode). You must
disable Update Mode to stop locking blocks automatically.

You can unlock data blocks in two ways:
v The Unlock command unlocks all blocks that you have locked.
v The server automatically unlocks data blocks that have been locked for the

maximum time allowed as defined by the Essbase system administrator.
Automatic unlock ensures that blocks are not locked for extended periods
of time.
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P&l.xls, a sample Excel file installed as part of the default Essbase
installation, illustrates how to update data on the server.

To view the P&l.xls worksheet:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the P&l.xls file.
3. Select Essbase > Retrieve & Lock.

Essbase retrieves data and locks the appropriate area of the database.

4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.
Essbase changes the affected data values.

5. Select Essbase > Send to update the server with the new values.
Essbase updates the server and unlocks the data blocks.

Figure 161. P&L Worksheet After Retrieve & Lock
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6. Close P&l.xls without saving it.

Note: Essbase provides a worksheet update logging facility that tracks and
logs all data updates sent from Essbase Spreadsheet Add-in to the
server. The Essbase system administrator enables this facility for extra
protection against data loss. For more information, see the Database
Administrator’s Guide or contact the Essbase system administrator.

Calculating a Database

Sending updated data to the server does not automatically recalculate the
database. If you have the appropriate security privileges to perform database
calculations, you can calculate the database from Essbase Spreadsheet Add-in
with the Calculation command. For this tutorial, you will not actually
calculate the Sample Basic database. For more information on Essbase
calculations, see the Database Administrator’s Guide.

CAUTION:
Do not perform any calculation operations for this tutorial.

When you select Essbase > Calculation, Essbase displays the Essbase
Calculation dialog box.

Figure 162. P&L Worksheet After Sending New Values to the Server
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The Essbase Calculation dialog box contains the following items:
v The Connection Information text box displays the active database

connection.
v The Select Calc Script list box contains the server-based calculation scripts

to which you have access.
v The Database State text box indicates the current calculation state of the

database. The following states are possible:
– Calculating—indicates that a calculation is currently running on the

database.
– Data values have been modified since the last calculation—indicates that

data values have changed since the database was last calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.

– No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or a calculation of any subset of the database.
CAUTION:
If the last calculation was performed on a subset of the data, the entire
database may not have been calculated since values last changed. To
ensure that the results of calculations are up-to-date, you may want to
run a calculation of the entire database. For more information, contact
the Essbase system administrator.

Figure 163. Essbase Calculation Dialog Box
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Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applications is to send
worksheets to various functional areas of an organization. After the
worksheets have been distributed, the recipients can review the contents,
make modifications, and send updates back to the distributor. Using the
Essbase Cascade feature, you can create multiple worksheet files based on a
single database view. You can specify at what level of detail you want to
replicate the worksheets to tailor the information to each recipient’s needs.

The Sample Basic database contains data for beverage products sold in
different states across the U.S. For example, assume that you want all product
managers to review and respond to a proposed budget and to return their
changes to the finance department. We must create a worksheet for each
combination of budget and P&L data to distribute to the product managers
for their respective products.

To create this set of worksheets:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the P&l.xls file. This

file contains the data that you need to replicate for each worksheet.
3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set
for this file in the Essbase Options dialog box. In this example, product
200 changes to Root Beer, which is its preassigned alias.

4. Select Central (in cell B1) and Root Beer (in cell B2) as the members to be
represented in the resulting worksheets.

5. Select Essbase > Cascade.
Essbase displays the Essbase Cascade Options dialog box.

6. Click the Cascade Information tab.
The Cascade Information page contains the list of members that you
selected and the options for specifying the level at which the selected
members are retrieved into the cascaded worksheets.

Note: For more information on each option, see the Essbase Spreadsheet
Add-in online help.

7. Select Central in the Member list box, and select Same level in the
Choose Level for Selected Member option group.

8. Select Root Beer in the Member list box, and select Next level (the
default setting).
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The replicated, or cascaded, spreadsheet reports now provide data for
members at the same level as Central (East, West, and South) and for
members at the level below Root Beer (Old Fashioned, Diet Root Beer,
Sarsaparilla, and Birch Beer).

9. Click the Destination Options tab.
10. In the Destination Directory text box, enter C:\temp as the name of the

directory where you want the cascaded worksheets to be stored.
You can also click Browse to select a destination directory from the
Browse dialog box.

11. In the Destination Types option group, select Separate Workbooks (the
default setting) to create separate Excel files for each cascaded worksheet.
You can also tell Essbase to create only one workbook with separate
worksheets for each cascaded report, or you can send the cascaded
reports to the printer.

12. In the File Information option group, click Overwrite Existing Files (the
default setting). This option tells Essbase to overwrite any cascaded
worksheets with the same file name.
You can also select Open Created Files to open each cascaded file in
Excel as it is created.

Figure 164. Cascade Information Tab
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CAUTION:
Depending on the number of replicated worksheets that you want to
create, the Cascade command can create more worksheets than can be
stored in the memory of your computer. Therefore, the Open Created
Files option should not be used when you are replicating large
numbers of worksheets.

13. In the Naming Information option group, enter BUD in the Prefix text
box.

When you assign a prefix or suffix in the Naming Information option
group, the worksheet files that are generated as a result of executing the
Cascade command are named with the prefix or suffix that you specify.
The default is to generate worksheet names that are numbered 1 through
n, where n is the total number of worksheets created. The syntax for the
file names is PrefixnSuffix.xls. If you do not specify a prefix or suffix,
Essbase creates the worksheets 1.xls, 2.xls, and so on. If you are
creating a single workbook, the same naming convention is used for the
worksheet tab names within the workbook.

Figure 165. Destination Options Tab

174 Spreadsheet Add-in User’s Guide for Excel



CAUTION:
Do not specify a prefix and suffix combination that leaves no
characters free for Essbase to create unique file names. If file names are
duplicated, Essbase overwrites the duplicate file name with the last
cascaded worksheet.

14. Click the Format Options tab.
15. To copy the formatting of the source worksheet into each cascaded

worksheet, select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Essbase and
the cell formatting that you set using the worksheet. It does not
copy formulas, column formatting, worksheet formatting, or
graphs.

In the Header and Footer text boxes, specify a header or footer name to
be used for all of the cascaded worksheets.

16. In the Sheet Formatting group, select the Suppress Missing Rows check
box so that rows containing only #Missing values are not replicated.

17. In the Table of Contents group, select the Include Table of Contents
check box to create a text file that lists all replicated worksheets, their
creation dates, and their member content.
By default, Essbase names the Table of Contents file with the extension
.lst.
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18. Click OK to create the cascaded worksheets.
Essbase rapidly creates the cascaded worksheets (nine total worksheets in
this example). As each worksheet is created, it is automatically saved,
closed, and logged in the Table of Contents. Each individual file is saved
in the directory that you specified, named Bud1.xls through Bud9.xls.
When the Cascade is completed, Essbase returns you to the original
worksheet view (that is, the source file).

19. Using a text editing application, open the Table of Contents file from the
destination directory that you specified earlier. This file is named
BUD0.LST and contains a list of all cascaded worksheets.

Figure 166. Format Options Tab
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20. Select File > Close to close the worksheet.
You do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a
product. Type in the attribute names in the top row of the worksheet.
Select the attribute names and select Essbase > Cascade. Proceed as
described in the above example.

Working with Currency Conversions

Organizations with offices in different countries generally do business in the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currencies to a common currency for
consolidation and analysis.

The Essbase Currency Conversion product can be purchased separately for
Essbase. If your organization has purchased this product and has
implemented a currency conversion application, you can take advantage of
the powerful capabilities of Hyperion Essbase Currency Conversion. The
Database Administrator’s Guide describes how to design and implement a
currency conversion application.

The following sections provide a brief tutorial for working with currency
conversions:
v “Retrieving Currency Conversion Data” on page 178
v “Connecting to the Sample Currency Databases” on page 178
v “Performing Ad Hoc Currency Reporting” on page 181

Figure 167. Table of Contents File for Cascaded Worksheets
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Retrieving Currency Conversion Data
This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
v A main database that contains data in local and converted values
v A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from
the main database to derive converted values.The Essbase server product
installation includes a sample currency conversion application (installation
options) that consists of two sample databases: a main database called Interntl
and a currency rates database called Xchgrate.

The Sample Interntl database consists of five dimensions: Year, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions
are identical to the Sample Basic database. The Market dimension includes
Toronto, Vancouver, Montreal, France, Germany, Spain, and the UK. The
Scenario dimension handles different currency types (such as Actual and
Budget) in both local and converted currencies. In this database, all local
currencies are converted to the common currency of U.S. dollars.

The Sample Xchgrate database, which is a subset of the main database,
contains four dimensions:
v The CurTime dimension accommodates different exchange rates by month.
v The CurName dimension contains names of currencies from their respective

markets.
v The CurCategory dimension contains the names of the various currency

categories that may be applied to the categories of Measures. For example,
one rate is applied to Profit and Loss items and another rate is applied to
Balance Sheet items.

v The CurType dimension enables a currency database to contain rates for
different scenarios, such as Actual and Budget.

Connecting to the Sample Currency Databases
To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.
2. Select the Sample Interntl database and click OK to complete the

connection.
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The Essbase installation also includes sample Excel files that illustrate
currency conversion concepts.

3. From the \Essbase\client\sample directory, open Local.xls.
The worksheet contains actual (Act) and budget (Bud) data entered in
local currencies for New York and Germany.

4. From the \Essbase\client\sample directory, open Convert.xls.
5. Select Essbase > Retrieve.

The worksheet contains values for Actual and Budget as they display after
conversion.

Figure 168. Retrieving Local Data
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Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Essbase converts the values by using the exchange rates from the Sample
Xchgrate database.

6. From the \Essbase\client\sample directory, open Rates.xls. Connect to
the Sample Xchgrate database.

7. Select Essbase > Retrieve.

The worksheet contains all possible combinations of exchange rate scenarios,
categories, and types by month. Because this example converts to U.S. dollars
(US$), the sample file contains a base rate of 1 for US$. Therefore, the local

Figure 169. Retrieving Converted Data Values

Figure 170. Retrieving Exchange Rates from a Currency Database
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and converted figures remain the same for New York. Essbase converts the
figures for Germany, however, by using data values in the currency database,
as follows:
v Essbase divides data values from Actual by values in the Act xchg currency

type.
v Essbase divides data values from Actual @ Bud xchg by values in the Bud

xchg currency type.
v Essbase divides data values from Budget by values in the Bud xchg

currency type.
v Essbase bases all figures in Convert.xls on the CurCategory of P&L and the

CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation
on exchange rates. The definition is determined by the application
designer.

Performing Ad Hoc Currency Reporting
A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. You may want to perform currency
conversions dynamically, as well. Essbase provides this capability with the
Currency Report command. This command enables you to interactively
change the currency rates and types applied to the retrieval.

To perform an ad hoc conversion on data in the Convert.xls file:
1. From the \Essbase\client\sample directory, open Convert.xls.

The worksheet contains data that is already converted to U.S. dollars.
2. Select Essbase > Connect and connect to the Sample Interntl database.
3. Select Essbase > Retrieve.
4. Select Essbase > Currency Report.

Essbase displays the Essbase Currency Report dialog box.
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The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains
options for currency settings, names, categories, and years. For more
information on these options, see the Essbase Spreadsheet Add-in online
help.

Note: The dimension names CurName, CurType, and CurCategory are
default names for a currency database. The application designer can
use different names for any of these dimensions.

5. Select the currency settings that you want to apply.
For example, select CN$ from the CurName list box and Bud xchg from
the CurType list box.

6. Click Apply to apply the settings.
7. Select Essbase > Retrieve to refresh the data in the worksheet with the

results of the ad hoc conversion.

Figure 171. Essbase Currency Report Dialog Box

182 Spreadsheet Add-in User’s Guide for Excel



Essbase converts the New York and Germany figures to Canadian dollars
(CN$).

8. Click the Clear button in the Essbase Currency Report dialog box to
disable currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the
retrieval. Converted data values may not always balance, because
the ad hoc conversion is performed on values that were previously
calculated or previously consolidated in another currency.

If values must balance and verify, they must be converted to the target
currency in the database, calculated, and retrieved. This procedure differs
from the ad hoc currency conversion retrievals described in this section; see
the Essbase system administrator for more information.

Figure 172. Performing an Ad Hoc Currency Conversion
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Chapter 5. Using Drill-Through

Essbase Integration Services is a product that works with Essbase and Essbase
Spreadsheet Add-in for Microsoft Excel and Lotus 1-2-3. Essbase Integration
Services is a suite of tools and data integration services that serves as a bridge
between relational data sources and the Essbase server. Drill-through is one of
these tools. Drill-through enables you to view and customize spreadsheet
reports that display data retrieved from relational databases. Your
organization must license Essbase Integration Services for you to use the
drill-through tool.

This chapter provides the following information:
v A brief overview of the drill-through feature
v A description of the sample database, Microsoft Excel file, and drill-through

report used for the tutorial
v A tutorial that guides you through tasks for using drill-through

What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic
data, some data elements required for analysis are better suited to the
relational structure of a relational database. The scope of data residing in an
Essbase database is typically at a summary level, where data is summarized
and calculated for planning and analysis. Detailed, transactional data usually
is not examined during the planning and analysis of a business.

For example, say you are using Essbase to analyze retail sales for the first
quarter in the Eastern region. Detailed data, such as a list of customers who
purchased a particular product in a particular size, is not used during the
normal course of analyzing business performance. However, as you analyze
sales results, you may want to view more detailed information. Drill-through
is a tool that enables you to drill from the summarized and calculated data
stored in the Essbase server of your organization into detailed data stored in a
relational database.

The database administrator predefines a data mapping for you from Essbase
to the relational source. For example, the Essbase members East, West, South,
and Central might map to a field called Region in a relational database. As
you navigate through data in the spreadsheet, Essbase knows how the current
data maps to the relational source. For example, suppose you select cell G4 in
the following sheet:
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The dimensional attributes of the cell are as follows: Actual, Profit, New York,
Feb, and Product. The combination of one or more of these attributes becomes
the basis of a drill-through query that returns data from the relational source.

From Essbase Spreadsheet Add-in, you can access a predefined drill-through
report that is based on the dimension or member intersections of Essbase data
cells in the sheet. Using an Essbase Integration Services tool called Integration
Services Console, an administrator at your organization sets up drill-through
reports for you to access; that is, each drill-through report is already defined
in terms of what to retrieve from the relational source.

In Essbase Spreadsheet Add-in, you can access drill-through reports from the
Linked Objects Browser dialog box. When you select a drill-through cell in the
sheet and select Essbase > Linked Objects, the Linked Objects Browser dialog
box displays an entry for drill-through that you can select and launch.

Figure 173. Example of Drill-Through Sheet
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You can define a style for cells tagged as drill-through to identify which cells
in the spreadsheet are associated with drill-through reports. For more
information, see “Accessing Drill-Through from the Spreadsheet” on page 196.

What Is the Drill-Through Wizard?
An administrator at your organization can predefine drill-through reports for
you to view or customize. The person who develops a report determines
whether the report can be customized by drill-through users. If a report can
be customized, use the Drill-Through Wizard to customize it. The
Drill-Through Wizard is a graphical user interface that steps you through the
following customization tasks:
v Selecting columns to retrieve from the relational data source

Decide which columns from the predefined report you need to see.
v Selecting the display order for columns

Change the default display order of columns across the sheet.
v Selecting a sort order for data

Select an ascending or descending sort order for a particular column; for
example, sort a list of store managers in alphabetical order.

v Selecting data filters
Define a filter on a column so that only data meeting certain criteria is
retrieved.

Figure 174. Linked Objects Browser Dialog Box with Drill-Through Entry
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Before You Start

Before starting the tutorial, you should have a working familiarity with the
Essbase product through the use of the Essbase Spreadsheet Add-in interface.
Review in this guide Chapter 3, “A Basic Essbase Tutorial” on page 11 and
Chapter 4, “An Advanced Essbase Tutorial” on page 97 as prerequisite
reading.

A sample Essbase database is the basis for the examples in this tutorial. The
database administrator creates this sample Essbase database using the sample
metaoutline supplied with Essbase Integration Services. For more information,
see the OLAP Metaoutline User’s Guide. A sample Microsoft Excel file,
Essdt.xls, contains a sheet with the appropriate member intersections for the
sample drill-through report. For more information on the sample database,
Microsoft Excel file, and drill-through report, see “About the Samples Used in
This Tutorial” on page 194.

If you plan to follow the examples in a live working session, check with the
person at your organization who installs the Essbase Integration Services
product family for information on the sample database you need for
drill-through, and to which Essbase server you should connect.

Note: The Essdt.xls file also contains sample results of the drill-through
reports when you run them without customizing the reports. The
results are provided in separate sheets in the workbook so that you can
see the sample report results without working through the tutorial For
more information about the sample reports, see “About the Samples
Used in This Tutorial” on page 194.

Before starting the tutorial, make sure you meet the following requirements:
v You must install the following components on your client PC:

– A 32-bit version of Excel (for example, Excel 97, Excel 2000, or Excel XP)
– Essbase Spreadsheet Add-in for Excel
– Drill-through

The drill-through module is installed automatically when you install
Essbase Spreadsheet Add-in. This module is transparent until you invoke
it from the Linked Objects Browser. For more information on installation,
contact the Essbase system administrator.

v The Essbase system administrator must install the Essbase server.
v You must have access to Essbase Integration Services and to the Essbase

server. For more information, contact the Essbase system administrator or
the person who administers Essbase Integration Services at your
organization.
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v You must have access to the underlying relational database (typically using
a user name and password that are different from those you use for
Essbase). For more information, contact the Essbase system administrator or
the person who administers Essbase Integration Services at your
organization.

v Make sure that the sample Excel file, Essdt.xls, is available in the
\Essbase\client\sample directory.

v In order to use the sample drill-through report, Essdt.xls, you need to
login to a machine that has both the Essbase server and Essbase Integration
Services installed. You must run member and data load and calculate the
data for the sample Essbase Integration Services database that you will
access from Essbase Spreadsheet Add-in.

v The sample database that contains the drill-through report must be set up
and running. The sample drill-through reports used in this tutorial (called
“Market Detail,” “Measures Detail,” and “Product Detail”) are available
with the sample database. Contact the person at your organization who
installs Essbase Integration Services to find out the name of the sample
database needed for drill-through.

Note: For more information on Essbase Integration Services installations, see
the Installation Guide. For more information on Essbase installations, see
the Installation Guide.

Keep in mind the following guidelines during the tutorial:
v Each tutorial task builds upon the previous one, and tasks must be

followed in succession.
v Tasks that should not be performed as part of the tutorial are displayed in

gray boxes. These tasks are included for your reference. You can find more
information on these tasks in the Drill-Through online help.

v The examples used in this tutorial are based on the sample database that is
included with the Essbase Integration Services installation. Contact the
person at your organization who installs Essbase Integration Services for
information about accessing the sample database.

v Set the options in the Essbase Options dialog box as described in the
following section, “Setting Essbase Options” on page 190. If the option
settings are different, the illustrations presented in this chapter may not
match the spreadsheet view.

v If you make a mistake during the tutorial, select Essbase > FlashBack to
return to the previous spreadsheet view.
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Setting Essbase Options
Before you begin the tutorial, make sure that the spreadsheet options are set
to the initial settings, as illustrated in Figure 175 through Figure 179. If your
option settings are different, the illustrations presented in this chapter may
not match the spreadsheet view.

Note: For information about each option in the Essbase Options dialog box,
click Help to see the Essbase Spreadsheet Add-in online help.

To set Essbase options:
1. From the spreadsheet menu, select Essbase > Options.
2. In the Essbase Options dialog box, select the Display tab.
3. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

4. Select the Zoom tab.

Figure 175. Initial Settings for Display Options
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5. Select the appropriate check boxes and option buttons so that your
display matches the following illustration:

6. Select the Mode tab.
7. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 176. Initial Settings for Zoom Options
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8. Select the Style tab.
9. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 177. Initial Settings for Mode Options
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10. Select the Global tab.
11. Select the appropriate check boxes and option buttons so that your

display matches the following illustration:

Figure 178. Initial Settings for Style Options

Chapter 5. Using Drill-Through 193



12. Click OK to save the settings for this session and close the Essbase
Options dialog box.

About the Samples Used in This Tutorial
The sample database used for this tutorial contains the following dimensions:
Scenario, Product, Market, Measures, and Year. The sample Excel file shown in
Figure 180 provides a particular view from this database:

Figure 179. Initial Settings for Global Options
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For this spreadsheet view, detail-level data exists in a relational data
source—data that is not available from Essbase. For example, the relational
source contains columns of data for market detail, measures detail, and
product detail. This tutorial walks you through a sample drill-through session,
where you will drill down from the data shown in Figure 180 into the detail
data from the relational source.

This tutorial uses two sample drill-through reports, “Measures Detail” and
“Market Detail.” As with all drill-through reports, these reports have been
predefined to retrieve specific columns from the relational source. You will use
the Drill-Through Wizard to customize the report, “Measures Detail.”

Note: The sample file also contains two more sample reports called “Product
Detail” and “Two reports” that you can use for drill-through practice.
In “Two reports,” select the drill-through cell B3 to select from two
drill-through reports, “Product Detail” and Market Detail, select cell B6
to view “Market Detail,” and cell G3 to view “Product Detail.”

In addition to the sample drill-through reports, Essdt.xls provides sample
results of the drill-through reports. The following list describes the
drill-through results that are provided:
v The Market Detail drill tab displays the results for Market Detail when you

run a drill-through report on cell G4 without customizing the report.
v The Measures Detail drill1 tab displays the results for Measures Detail

when you run a drill-through report on cell C4 without customizing the
report.

v The Measures Detail drill2 tab displays the results for Measures Detail
when you run a drill-through report on cell G6 without customizing the
report.

v The Product Detail drill tab displays the results for Product Detail when
you run a drill-through report on cell D5.

Figure 180. View from Sample Database
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Using Drill-Through

Drill-through consists of the following tasks:
v Accessing Drill-Through from Essbase Spreadsheet Add-in
v Selecting Drill-Through Reports to View or Customize
v Selecting and Ordering Columns
v Sorting Data
v Filtering Data

The following sections describe each of these tasks and step you through a
live working drill-through session.

Accessing Drill-Through from the Spreadsheet
From Essbase Spreadsheet Add-in, you can access detail-level drill-through
reports that are based on the member intersections of Essbase data cells in the
sheet. Each drill-through report has been predefined by an administrator at
your organization; that is, each drill-through report is already set up to
retrieve specific columns from the relational source, to sort data in these
columns in specific ways, and so forth. Using the Drill-Through Wizard, you
can customize these predefined drill-through reports to retrieve only the data
you want, displayed in a specific way.

To access the predefined drill-through report, double-click a drill-through cell
in the spreadsheet (or select a range of cells and select Essbase > Linked
Objects). You can set styles for cells tagged as drill-through to help identify
which cells in the sheet are associated with drill-through reports. When you
double-click a drill-through cell, Essbase displays the Linked Objects Browser
dialog box, which displays an drill-through report entry. A single cell can
have multiple reports associated with it. The Linked Objects Browser dialog
box also displays entries for linked partitions and other linked object types,
such as cell notes, URLs, and application files. After you view or customize
the drill-through report, Essbase Integration Services retrieves data from the
relational source and displays the results in a new spreadsheet.

Before starting the drill-through tutorial, perform the following tasks:
1. Open a sample Excel file that contains the appropriate member

intersections from the sample database for the drill-through report. This
file, Essdt.xls, is provided as part of the default Essbase installation.

2. Set a style for data cells that are associated with drill-through reports.

To access the sample file and sample database:
1. Start Excel.
2. Select File > Open and open the Essdt.xls file from the

Essbase\client\sample directory.
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The sample file should look like the following screen. Note that the
Market Detail tab is selected in this example. The default tab that is
selected when you first open the file may be different.

The sample file shows data for specific members of an Essbase database.
This sample file contains the following three predefined drill-through
reports, indicated by the tabs of the spreadsheet: “Market Detail,”
“Measures Detail,” and “Product Detail.” Using drill-through, you can
access these reports and customize them so that Essbase Integration
Services retrieves only the data you need and displays it in the desired
format.

3. Select the Market Detail tab on the spreadsheet.
4. Select Essbase > Connect and connect to the appropriate sample

database.

Note: A specific sample database for drill-through is not automatically
provided with Essbase Integration Services. For information on the
sample database, contact the person at your organization who
installs Essbase Integration Services to set up a database for you.

5. Select Essbase > Options and select the Style tab.
6. In the Data Cells option group, select the Integration Server

Drill-Through check box and click Format.
Essbase displays the Font dialog box.

7. Select Bold Italic from the Font style list box.
8. Select Blue from the Color drop-down list, and click OK to return to the

Essbase Options dialog box.

Figure 181. Sample Excel File for Drill-Through
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Note: In the Essbase Options dialog box, Essbase displays an example of
the selected style in the Sample box.

The following screen shows how the Essbase Options Style tab looks
with the style for drill-through cells defined:

Figure 182. Font Dialog Box Selection
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9. In the Essbase Options dialog box, select the Display tab, and then select
the Use Styles check box.

Figure 183. Sample Style for Drill-Through Data Cells
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10. Click OK to close the Essbase Options dialog box.
11. Select Essbase > Retrieve to display the new style in the spreadsheet.

In Figure 185, the sample drill-through report is associated with the data
cells for Actual, Profit, and Product at the month and Eastern state levels,
so that these data cells are displayed in blue, bold, italic font.

To access the sample drill-through report from Essbase Spreadsheet Add-in:
1. Select any drill-through cell; for example, cell G4.

Figure 184. Setting the Use Styles Option

Figure 185. Sample Excel File with Drill-Through Style Applied
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Note: You can also select a continuous range of cells in the sheet to
display all drill-through reports associated with cells you select. In
this example, we have only one drill-through report attached to the
range of cells.

2. Select Essbase > Linked Objects to open the Linked Objects Browser
dialog box.
Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to
double-click a linked object cell to open the Linked Objects Browser
dialog box. This option works only with single-cell selection. If you select
a range of cells, use the Essbase > Linked Objects menu command.

3. Select the drill-through report entry and click View/Launch.
4. In the Select Drill-Through Report dialog box, select Market detail and

click Execute.
The results of the drill-through report are displayed in a spreadsheet.The
results of the Market Detail report shows that the regional director for the

Figure 186. Selecting a Drill-Through Cell

Figure 187. Linked Objects Browser Dialog Box with Drill-Through Entry Selected
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East region is John West and that the population for New York is between
18,000,001-21,000,000.

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized,
drill-through generates the report and immediately displays the
results in the spreadsheet. The person at your organization who
develops drill-through reports specifies whether you can customize
a report and whether you need to log in to drill-through and the
relational data source.

5. Follow the steps in the next section, “Selecting Drill-Through Reports to
View or Customize” on page 202 to select a report to customize.

Selecting Drill-Through Reports to View or Customize
After you launch drill-through from the Linked Objects Browser dialog box,
Essbase Integration Services displays the Select Drill-Through Report dialog
box under the following conditions:
v More than one drill-through report exists for the cell or cell range that you

select in the spreadsheet, or
v Only one report exists, but you have the option of customizing it using the

Drill-Through Wizard.

The Select Drill-Through Report dialog box displays the list of drill-through
reports available for the cells you select in the spreadsheet. Depending on
how a report is defined in Integration Services Console, you may have access
only to view, not customize, the report.

Note: Tasks that you should not perform as part of the tutorial are shown in
light colored boxes.

The sample report used for this tutorial is the Measures Detail report. You will use
the Drill-Through Wizard to customize this sample report. To execute a predefined
drill-through report without customizing it, perform these tasks:

1. Select the report that you want to view from the Available Reports list box.

2. Click Execute.

Essbase Integration Services retrieves the data from the relational source and displays
the results in a new spreadsheet. The new sheet is added before the current sheet.

Figure 188. Results of Market Detail Drill-Through Report
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To customize the sample drill-through report:
1. In Essdt.xls, select the Measures Detail tab.
2. Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically
provided with Essbase Integration Services. For information on the
sample database, contact the person at your organization who
installs Essbase Integration Services to set up a database for you.

3. Select Essbase > Options and select the Style tab to define styles for this
sheet.

4. In the Data Cells option group, select the Integration Server
Drill-Through check box and click Format.
Essbase displays the Font dialog box.

Note: The style for drill-through cells may already be set as blue, bold,
italic font because you set the style in the previous exercise. If this is
the case, then go to Step 7.

5. Select Bold Italic from the Font style list box.
6. Select Blue from the Color drop-down list, and click OK to return to the

Essbase Options dialog box.

Figure 189. Font Dialog Box Selection
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Note: In the Essbase Options dialog box, Essbase displays an example of
the selected style in the Sample box.

7. In the Essbase Options dialog box, select the Display tab and select the
Use Styles check box.

Figure 190. Sample Style for Drill-Through Data Cells
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8. Click OK to close the Essbase Options dialog box.
9. Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample drill-through report is associated with every
member intersection at the state level in the East region, so that all data
cells associated with an Eastern state and children of Cola are now
displayed in blue, bold, italic font.

To access the sample drill-through report from the Essbase Spreadsheet
Add-in:
1. Select any drill-through cell; for example, cell G6.

Figure 191. Setting the Use Styles Option

Figure 192. Sample File with Drill-Through Style Applied
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Note: If Essbase Integration Services is not running, drill-through does not
launch properly. For more information, contact the Essbase system
administrator.

Note: If you are prompted with the Drill-Through Login dialog box to
connect to Essbase Integration Services and the relational data
source, enter the appropriate connection information. The person at
your organization who administers Essbase Integration Services and
develops drill-through reports should provide you with this
information.

2. Select Essbase > Linked Objects to open the Linked Objects Browser
dialog box.
Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to
double-click a linked object cell to open the Linked Objects Browser
dialog box. This option works only with single-cell selection. If you select
a range of cells, use the Essbase > Linked Objects menu command.

3. Select the drill-through report entry and click View/Launch.

Figure 193. Selecting the Drill-Through Cell for the Measures Detail Report

Figure 194. Linked Objects Browser Dialog Box with Drill-Through Entry Selected
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The Select Drill Through Report dialog box is displayed.

Note: In the Select Drill Through Report dialog box, if the Customize
button is selectable, then you can customize the report. If more than
one drill-through report is displayed, then you can select from the
different drill-through reports. In this tutorial, only one report,
“Measures detail,” is displayed and customizable.

4. Select the Measures detail report from the Available Reports list box.

5. Click Customize.

Note: The Customize button may be selectable or not selectable for any
given report, depending on how the report was defined in
Integration Services Console.

Essbase Integration Services displays the first screen of the Drill-Through
Wizard.

Figure 195. Selecting the Sample Drill-Through Report
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6. Click Next to display the Select Columns and Display Order dialog box.

7. Follow the steps in the next section, “Selecting and Ordering Columns” on
page 208, to select and order rows for the customized report.

Selecting and Ordering Columns
Using the Drill-Through Wizard, you can customize predefined drill-through
reports. The first task in the Drill-Through Wizard is selecting and ordering
columns to retrieve from the relational database. These columns contain
detailed information that is not available in the Essbase database.

Figure 196. Drill-Through Wizard Dialog Box, Introductory Screen

Figure 197. Select Columns and Display Order Dialog Box
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In the Select Columns and Display Order dialog box, you can select which
columns you want Essbase Integration Services to retrieve from the relational
data source. From this dialog box, you can also specify how the columns are
displayed in the resulting report.

The Available Columns list box displays a list of columns available from the
relational data source for this report (as defined in Integration Services
Console). The Selected Columns list box displays the columns from the
Available Columns list box in expanded form. You can remove columns from
the Selected Columns list box to exclude them from the drill-through report.

In this example, the columns from the Available Columns list box are selected
for inclusion in the sample Measures detail report. These columns are
displayed in expanded form in the Selected Columns list box.

To remove one of the selected columns from the drill-through report:
1. In the Selected Columns list box, select the MARKET.STATE column.

Note: To select multiple columns in the list that are not adjacent to each
other, hold down the Ctrl key and select each column. To select a
range of columns, hold down the Shift key and click the first and
last columns in the list, which also selects all columns in between
them.

2. Click to move the selected column from the Selected Columns list
box back to the Available Columns list box.

Figure 198. Selecting Columns to Remove From the Drill-Through Report
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Note: To move a column from one list box to another, click or .

To move all columns from one list box to another, click or

.
3. Click Next to display the Select Data Sort Order dialog box, and follow

the steps in the following section, “Ordering Data” on page 210 to further
customize the report.

Note: When you finish customizing the report, click Finish at any time to
generate the report and view the results in a new sheet. The new
sheet is placed before the current sheet.

Ordering Data
In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the data in a column. Sort order determines the
order in which rows will be displayed in the drill-through report. For
example, you can sort the contents of the Time.TRANSDATE column, which
represents the transaction dates, in ascending order in the drill-through report.

To define the sort order of rows in the drill-through report:
1. In the Available Columns list box, select the Time.TRANSDATE column.

The columns in the Available Columns list box are those that you selected
in “Selecting and Ordering Columns” on page 208. The columns in the
Column list box are those for which a sort order has already been defined
in Integration Services Console.
If a data sort order was selected when the report was created in Essbase
Integration Services Console, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.

2. Click to move the Time.TRANSDATE column to the Column list box
so that you can define a sort order for the column.

Note: To move a column from one list box to another, click or .

To move all columns from one list box to another, click or

.
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3. In the Column list box, double-click the Time.TRANSDATE column to
change the data sort order from Ascending to Descending so that
transaction date values are displayed in reverse chronological order in the
drill-through report.

4. Click Next to display the Select Data Filters dialog box, and follow the
steps in the following section, “Filtering Data” on page 212 to further
customize the report.

Figure 199. Moving a Column to the Column List Box for Sorting

Figure 200. Selecting the Data Sort Order
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Note: Tasks that you should not perform as part of the tutorial are shown
in light-shaded boxes.

To change the data sort order for multiple columns at one time, perform these tasks:

1. Hold down the Ctrl key and select the desired columns from the Column list box.

2. Click Order By.

Essbase Integration Services displays the Order By dialog box.

Figure 201. Order By Dialog Box

3. Select Ascending or Descending and click OK to return to the Selecting Data Sort Order dialog
box.

Filtering Data
You can apply filters to determine what Essbase Integration Services retrieves
for the drill-through report. For any given column, you may want to retrieve
only data that meets certain conditions. For example, the MEASURES.CHILD
column in the sample database contains all children of the Measures
dimension. In the sample drill-through report, if you did not apply a filter to
this list of measures, Essbase Integration Services would retrieve all children
from the relational source, because the sample drill-through report applies to
all children of Measures. In this section, you will apply a filter to the
MEASURES.CHILD column so that all children of Measures, except Misc, are
included in the report.

Note: When you apply a filter on a non-level 0 member using Essbase
Integration Services, the filter may return more members than expected.
To work around this problem, use the Drill-Through Wizard.
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To define a filter:
1. Select the MEASURES.CHILD column from the Column list box.

The columns in the Column list box are those that you selected in
“Selecting and Ordering Columns” on page 208.

Note: If there is a filter already attached to the column, it is displayed in
the Condition list box. The full string of the filter is displayed in the
lower Condition text box.

2. With the MEASURES.CHILD column selected, click Add.
The Set Filter on Column dialog box is displayed.

Figure 202. Select Data Filters Dialog Box
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3. Select CHILD from the Column drop-down list box.
The column displayed in the Column drop-down list box is the one that
you selected in “Filtering Data” on page 212.

4. Select the < > operator, which represents not equal to, from the Operator
drop-down list box.

Note: You can select multiple values at one time only if you have selected
In or Not In as the filter operator. For more information on filter
operators, see the Drill-Through online help.

5. Click the Browse button to open the Select Filter Values from the
List dialog box, which lists all possible values for that column.
The Select Filter Values from the List dialog box is displayed.

Note: Essbase Integration Services retrieves these values directly from the
relational data source. If the relational data source contains many
values, Essbase Integration Services confirms if you want to view
them all before it retrieves them from the data source.

6. In the Select Filter Values from the List dialog box, select Misc and click
OK. The Set Filter On Column dialog box is displayed.

Figure 203. Set Filter on Column Dialog Box
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7. Click Add to add the condition to the Filters list box.

Note: For information on using multiple filter conditions, see the
Integration Server Drill-Through online help.

The Set Filter on Column dialog box should now look like Figure 205:

Figure 204. Selecting Filter Values from the List
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The filter defined above causes all children of Measures, except Misc data,
to show in the drill-through report.

Note: The Add button becomes unselectable after creating the first filter,
but becomes selectable when you create another filter. In this
tutorial, you are creating only one filter. The And and Or options
are used when combining multiple filters. The default value is Or,
which means that Essbase Integration Services applies the filter if
any of the conditions you specify are met. If you select And,
Essbase Integration Services applies the filter only if all the
conditions are met.

8. Click OK to return to the Select Data Filters dialog box. Notice that the
filter defined in the Set Filter on Column dialog box is displayed in the
Condition list box and text box of the Select Data Filters dialog box.

Figure 205. Defining a Filter for a Column
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Note: You can also create a filter by typing the filter conditions directly
into the Filters list box of the Set Filter on Column dialog box. For
more information, see the Drill-Through online help.

To delete a filter, select the filter and click Clear. To delete all filters,
click Clear All.

9. Click Finish.
Essbase Integration Services generates the customized drill-through report
and displays the results in a new spreadsheet. The new spreadsheet is
added to the workbook before the current spreadsheet.

Figure 206. Result of Defining a Filter for a Column
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In this sample, the customized drill-through report reflects the specifications
that you set using the Drill-Through Wizard:
v The Time.TRANSDATE column is sorted in descending order, displaying

the transaction dates in reverse chronological order.
v All children of Measures, Additions, COGS, Marketing, Payroll, Sales, and

Opening Inventory, except Misc, are displayed as you specified in the
filtering part of the Drill-Through Wizard.

Disconnecting from Essbase

When you finish using drill-through, disconnect from the Essbase server to
free up a port on the server for other Essbase Spreadsheet Add-in users.

To disconnect from the server:
1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can
disconnect any spreadsheet that is connected to a database.

Figure 207. Customized Drill-Through Report
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Note: Essbase may return an error message when you attempt to
disconnect after using drill-through. If an error message is returned,
select Essbase > Retrieve from the sheet and then disconnect.

2. Select a sheet name from the list and click Disconnect.
3. Repeat Step 2 until you have disconnected from all active sheets.
4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing Excel. An
abnormal termination of ana Excel session, such as a power loss or
system failure, does not disconnect your server connection.

Figure 208. Essbase Disconnect Dialog Box
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Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.
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be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for
this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM Corporation
J74/G4
555 Bailey Avenue,
P.O. Box 49023
San Jose, CA 95161-9023
U.S.A

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.
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available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
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Information concerning non-IBM products was obtained from the suppliers of
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of performance, compatibility or any other claims related to non-IBM
products. Questions on the capabilities of non-IBM products should be
addressed to the suppliers of those products.
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OpenEdition OS/400

The following terms are trademarks or registered trademarks of other
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1-2-3, Notes, and Lotus are registered trademarks of Lotus Development
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UNIX is a registered trademark of The Open Group in the United States and
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Other company, product or service names may be the trademarks or service
marks of others.
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Glossary

This glossary defines terms that are used in
this book and throughout the IBM DB2
OLAP Server library.

accounts dimension. A dimension type that
makes accounting intelligence available. You can
tag one dimension as an accounts dimension, but
an accounts dimension is not required.

administrator. A person who is responsible for
installing and maintaining DB2 OLAP Server and
for setting up user accounts and security.

agent. A process that starts and stops
applications and databases, manages connections
from users, and handles user-access security.

alias ID table. A table created by DB2 OLAP
Server in your relational database that contains a
mapping of multidimensional alias table names
to ID numbers allocated by DB2 OLAP Server.

alias ID view. A view created by DB2 OLAP
Server in your relational database that contains
one row for each multidimensional alias table
used with a relational cube. There is one alias ID
view for each relational cube.

alias name. An alternate name for a dimension
or member.

anchor dimension. A dense dimension that is
specified as the dimension that DB2 OLAP
Server uses to help define the structure of the
fact table it creates in the relational cube for a
multidimensional database.

API. Application programming interface. The
DB2 OLAP Server API is a library of functions
that you can use in a custom C or Visual Basic
program to access DB2 OLAP Server.

Application Manager. A tool that you can use
to create and maintain OLAP applications.

block. A string of data elements recorded or
transmitted as a unit.

cache. A component of memory. Each
multidimensional database contains a data cache
and an index cache.

calculation. An equation within a database
outline, a calculation script, or a report script
that calculates a value for a particular member or
point in a report.

calculation script. A text file that contains
instructions to perform calculations within a
multidimensional database. Also called a calc
script.

Commit Block parameter. A parameter on the
Transaction page of the Database Settings
notebook in the Application Manager that you
use to set the number of blocks that can be
changed before DB2 OLAP Server commits the
blocks.

cube catalog table. A table that DB2 OLAP
Server creates in your relational database that
contains a list of all the multidimensional
databases that are stored in your relational
database. The cube catalog table also shows the
application with which each cube is associated.
Each time that you create a multidimensional
database, DB2 OLAP Server creates a new row in
this table.

cube catalog view. A view that DB2 OLAP
Server creates in your relational database that
allows an SQL user to access a list of OLAP
applications and relational cubes.

cube table. A table that DB2 OLAP Server
creates in your relational database that contains a
list of dimensions in a relational cube and
information about each dimension.

cube view. A view that DB2 OLAP Server
creates in your relational database that allows an
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SQL user to access the names of all dimensions
in a relational cube and associated information
for each dimension. There is one cube view for
each relational cube in your relational database.

data load. The process of populating a
multidimensional database with data. Loading
data establishes actual values for the values of
the cells defined in the database outline for the
database.

data load rules. A set of operations that DB2
OLAP Server performs on data as it is loaded
from an external source file.

database administrator. A person responsible
for administering a relational database.

database log file. A set of primary and
secondary log files consisting of log records that
record all changes to a database. The database
log file is used to roll back changes for units of
work that are not committed and to recover a
database to a consistent state.

database managed space (DMS). Space in a
table that is managed by the database.

database name. The name of the relational
database where you want DB2 OLAP Server to
store your multidimensional data.

database outline. The structure that defines all
elements of a database within DB2 OLAP Server.
It contains definitions of dimensions and
members, dense or sparse dimension tags and
attributes, the anchor dimension attribute,
calculations, shared members, and alternations to
the basic roll-up structure of the database.

database password. The password for the user
ID that you want DB2 OLAP Server to use to log
on to your relational database.

database section. A section in the Relational
Storage Manager configuration file that contains
values for parameters that override the values
for the same parameters for the current
application.

database settings. Settings that you can modify
to improve performance and space utilization for

your relational database. You can change
database settings by using utilities or commands
supplied with your relational database
management system.

database user ID. The user ID that you want
DB2 OLAP Server to use to log on to your
relational database. The default is the supervisor
ID that you specify when you start DB2 OLAP
Server for the first time.

dense dimension. A dimension with a high
probability for occupying one or more data
points in every combination of dimensions that
occurs.

dimension. A data category, such as time,
accounts, products, or markets. In a
multidimensional database outline, the
dimensions represent the highest consolidation
level.

dimension table. A table that DB2 OLAP Server
creates in your relational database that contains
detailed information about the members in a
dimension. There is one dimension table for each
dimension in an outline.

dimension view. A view that DB2 OLAP Server
creates in your relational database that allows an
SQL user to access information about members
contained in a dimension.

ESSCMD. A command-line interface used to
perform server operations interactively or
through a batch file.

generation name. A unique name that describes
a generation in a database outline.

generation table. A table that DB2 OLAP Server
creates in your relational database that contains
generation numbers and names for each named
generation specified when you created the
outline. There is one generation table for each
dimension in an outline.

level name. A unique name that describes a
level in a database outline.
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member. A discrete component within a
dimension. For example, January 1997 or 1Qtr97
are typical members of a Time dimension.

metaoutline. A template containing the
structure and rules for creating a database
outline from an OLAP model. Using the
metaoutline, you can create a database outline
and load data into it. The DB2 OLAP Integration
Server desktop includes a tool called OLAP
Metaoutline that you can use to create one or
more metaoutlines from an OLAP model.

model. A logical model (star schema) that you
create from tables and columns in a relational
database. You can use the OLAP model to create
a metaoutline that generates the structure of a
multidimensional database. The DB2 OLAP
Integration Server desktop includes a tool called
OLAP Metaoutline that you can use to design
and create an OLAP model based on a relational
data source.

multidimensional data. The data in a
multidimensional database. Data can include
basic data values (loaded from an external
source) that represent combinations of the lowest
level of members in the dimensions of the
database; data values that are calculated from the
base data values; and rolled up data values that
are created by combining values for members in
dimension hierarchies.

multidimensional database. An OLAP database
that you create using the Application Manager or
ESSCMD commands (in DB2 OLAP Server) or
with the DB2 OLAP Integration Server desktop,
which is in the Starter Kit. An OLAP database
includes a database outline, data, associated
optional calculation scripts, optional report
scripts, and data load rules. DB2 OLAP Server
stores the actual data and a shadow of the
database outline in tables in a relational
database.

named pipes. An API used for special
node-to-node applications and particularly for
access to communications and database servers.

OLAP application. An application that you
create using the Application Manager or the

ESSCMD commands (in DB2 OLAP Server) or
with the DB2 OLAP Integration Server desktop,
which is in the Starter Kit. An OLAP application
can contain one or more multidimensional
databases and any associated calculation scripts,
report scripts, and data load rules.

OLAP metaoutline. See metaoutline.

OLAP model. See model.

online analytical processing (OLAP). A
multidimensional, multi-user, client server
computing environment for users who need to
analyze consolidated enterprise data in real time.
OLAP systems feature zooming, data pivoting,
complex calculations, trend analyses, and
modeling.

outline. See database outline.

RDBMS. Relational database management
system. A database that can be perceived as a set
of tables and manipulated in accordance with the
relational model of data.

relational attribute. A characteristic of a
dimension table, represented by a column. You
can run SQL statements against the data in
relational attribute columns.

relational database. A database that is
organized and accessed according to
relationships between data items. A relational
database contains a collection of relational tables,
views, and indexes.

report script. An ASCII file that contains Report
Writer commands that generate one or more
production reports. Report scripts can be run in
batch mode, using the ESSCMD command-line
interface, or through the Application Manager.
The script is a text file that contains data
retrieval, formatting, and output instructions.

restructure. An operation to regenerate or
rebuild the tables and views that DB2 OLAP
Server created in your relational database.

shadow. Information stored in relational tables
that shadows the information stored in a
multidimensional database outline.
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shared member. A member that explicitly
shares storage space with another member of the
same name. This member has an attribute that
designates it as shared. Shared members prevent
making extra calculations on a member that
appears in more than one location in a database
outline.

sibling. A child member at the same branch
level.

sparse dimension. A dimension with a low
percentage of available data positions filled. For
example, a product that is not sold in all of a
company’s available markets would be a good
sparse candidate.

Spreadsheet Add-in. Software that merges with
Microsoft Excel and Lotus 1-2-3 to enable
analysis of multidimensional databases. The
software library appears as a menu Add-In to the
spreadsheet and provides such features as
connect, zoom-in, and calculate.

SQL application. An application that uses SQL
statements. You can use SQL applications to
access data in a relational cube.

SQL. Structured Query Language. A
standardized language for defining and
manipulating data in a relational database.

star schema. The type of relational database
schema used by DB2 OLAP Server. When you
use the Application Manager to create a
multidimensional database, DB2 OLAP Server
creates a main fact table and a set of dimension
tables. The fact table holds the actual data values
for the database, and the dimension tables hold
data about members and their relationships.

star view. A relation view that DB2 OLAP
Server creates in your relational database that
allows an SQL user to access data from the star
schema in a single view with the JOIN already
done.

table space. An abstraction of a collection of
containers into which database objects are stored.
A table space provides a level of indirection
between a database and the tables stored within
the database. A table space:

v Has space on media storage devices assigned
to it.

v Has tables created within it. These tables will
consume space in the containers that belong to
the table space. The data, index, long field,
and LOB portions of a table can be stored in
the same table space, or can be individually
broken out into separate table spaces.

time dimension. A dimension type that defines
how often you collect and update data. You can
tag only one dimension as Time, although you
do not need to have a Time dimension.
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Index

Special Characters
? wildcard character 87
* wildcard character 87
#Missing strings, suppressing 51
#NoAccess strings, suppressing 51

A
access

to databases 26, 97
to Essbase data 26, 97
to linked partitions 166
to linked reporting objects 156
to multiple databases 164
to online help 18
using Essbase commands 25
with drill-through 196

Acrobat Reader
See Adobe Acrobat Reader

ad hoc reports 3, 28, 118, 181
Add button 213
Add-in Manager 12
adding members

See members, adding
adjusting columns

See columns, adjusting width
administrators 3
Adobe Acrobat Reader vi
advanced interpretation engine 137
Advanced Interpretation mode 137,

144
aliases

definition of 62
displaying

process of 62
with member names 64
with Query Designer

results 83
in tables 62

alternate dimensions
See dimensions, alternate

alternate names
See aliases

ancestors, definition of 10
AND operators 84
API 5
application designer 4

application partitions
See linked partitions

application programming
interface 5

applications/databases
Sample Basic 11, 25, 27, 98
sample for drill-through 194
Sample Interntl 178
Sample Xchgrate 178

ascending sort order
with drill-through 210
with Query Designer 110

asymmetric reports
definition of 112
pivoting 114
retrieving data into 112

Attach Linked Object dialog
box 149, 152, 154

attaching reporting objects to cells
See linking

attaching to databases
See connecting

attributes, drill down 33
auditing updates 170
auto logouts 94
Auto Sort Rows option 140

B
blank

columns 114
rows 114

blocks, locking data 168
Boolean operators 84, 88

C
Calculation command 170
Calculation dialog box 170
calculations

database status 171
databases 130, 170
dynamic 130
reducing calculation time 130
scripts 171
specifying latest time period 132
substitution variables 135
with Dynamic Time Series 132

canceling data retrievals 30
Cascade command 172
Cascade Information page 172
Cascade Options dialog box 172

cascading sheets
creating table of contents 175
destination 173
format 175
level of detail 172
names 174
output type 173

cell notes
accessing linked 158
linking to cells 152

cell ranges
keeping 43
removing 46
retrieving 123
selecting nonadjacent 44
with drill-through 201

cells
accessing linked partitions 166
applying styles 53, 59
attaching reports

See linking
attaching URLs

See linking
EssCell function in 126
formatting 53, 59, 151

in data cells 59
of dimension members 57
of Dynamic Calculation

members 130
of parent members 54

formulas in 115, 116, 119, 126
linked reporting objects 148, 154
linking files to 148
linking notes to 152
linking URLs to 154
retrieving a range 123
retrieving single values 126
selecting nonadjacent 44
with nondatabase values 114

Change Password dialog box 28
changing

passwords 28
row and column orientation 38
spreadsheet format 53
styles 53

children (defined) 9
Clear All button 217
Clear button 217
Clear command 31
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clearing styles 61
click (defined) 19
client

components 4
software 11
upgrading with server 1

client-server environment 4
collapsing data views

See drill
colors, setting 53
columns

adjusting width 25, 116
blank 114
displaying as rows 38
displaying selected 43
filtering by 105
keeping selected 43
nested 32
pivoting 38
removing selected 46
retrieving into 33

columns, drill-through
choosing 209
selecting display order 209
selecting for retrieval from

relational source 209
sorting 210

commands
Calculation 170
Cascade 172
Clear 31
Connect 26, 97, 164
Currency Report 178, 181
Disconnect 93
FlashBack 30
Keep Only 43
Linked Objects 148, 154
Lock 168
Member Selection 85
Navigate Without Data 47, 50
Pivot 38
Remove Only 46
Retrieve 29
Retrieve & Lock 168
Send 168
Undo 30
Unlock 168
Zoom In 31
Zoom Out 35

comparison operators 84, 105
computing environment v
concurrent

database access 27, 164
updates to server 168

conditional retrievals 104

Connect command 26, 97, 164
connecting

See also disconnecting
to a database 26, 97
to a relational data source 185,

196, 206
to Essbase 27, 98
to Essbase Integration

Server 196, 206
to multiple databases 164
viewing current connections 165

Connection Information text
box 165, 171

consolidations (defined) 10
conversions, currency 177
creating queries 69
creating reports

See reports, creating
Currency Conversion product 6
currency conversions

modifying exchange rates 182
reporting 181
sample databases 178
settings 182

Currency Report command 178,
181

Currency Report dialog box 182
current time period

See Dynamic Time Series
cursors (Essbase) 29
custom applications 5, 6
Customize button 207
customizing drill-through

reports 203

D
data

calculating 170
changing orientation 38
comparison operators 105
displaying 7, 29
dynamically calculating 130
filtering 104
filtering, with drill-through 217
formatting 53
locking 168
missing 51
modifying 168
navigating 10, 47
pivoting 38
relational, with

drill-through 185
removing subsets 46
retaining subsets 43

data (continued)
retrieving

See retrieving
sorting 104
unlocking 168
updating 168, 170

data sort order, with
drill-through 210

data source, relational 206
databases

calculating
See calculations

connecting
See connecting

consolidations 10
defined 6
dimensions 9
disconnecting from 93
linked

See linked partitions
loading 28, 99
locking 168
members 9
organization 7
outlines 10
queries

See queries
restoring previous views 30
rules 7
sample 25, 178, 194
selecting

See connecting
switching 164
viewing connections 165

deleting
filters, drill-through 217
selected members 46
styles 61

descendants (defined) 10
descending sort order

with drill-through 210
with Query Designer 110

Destination Options page 173
destinations

cascaded sheets 173
Query Designer queries 76

detaching
See disconnecting

dialog boxes, Help buttons 18
dimensions

alternate 6
applying styles 57
currency conversion and 178
described 6, 9
drilling down on 31, 33
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dimensions (continued)
drilling up on 35
naming elements 9
pivoting 38

disabling data retrieval
See navigating without data

Disconnect
command 93
dialog box 93

disconnecting
forced logouts 94
from Essbase 93
from Essbase Integration

Server 218
discontinuous rows and

columns 44
disk space, effect on Dynamic

Calculation 130
display

options 53
order of columns,

drill-through 209
Display page (Essbase Options

dialog box) 21, 190
Display Unknown Member

option 116, 119
displaying data 7, 29
distributed sheets

See cascading sheets
double-clicking

defined 19
enabling

for drilling 19
for linked object

browsing 157, 166, 201, 206
downloading Acrobat Reader vi
drag-and-drop operations 39
drag, defined 19
drill

by double-clicking 19
down on attributes 33, 34
down on consolidations 10
Formula Fill 119
retain formulas during 119
to less detail 35

drill-through
accessing 186, 196
cells, defining styles for 196
described 185
installing 188
multiple reports 186
requirements 188
sample

database 194
drill-through report 195

drill-through (continued)
sample (continued)

file 196, 197
styles for cells 187
tutorial guidelines 189

Drill-Through Wizard
dialog box 207
introductory screen 207

duplicating sheets
See cascading sheets

Dynamic Calculation members,
applying styles to 130, 131

Dynamic Time Series
defined 132
specifying latest time

period 133, 135

E
Edit Cell Note dialog box 159
Edit menu 31
Edit URL dialog box 162
editing

cell notes 158
linked files 158
URLs 160, 162

editing in cells 19
Enable Hybrid Analysis option in

Zoom page (Essbase Options
dialog box) 22

enabling
FlashBack setting 31
mouse actions 19, 157, 166
Navigate Without Data 47

environment (computing) v
Essbase

API 5
architecture 4
Cascade Options dialog box 172
computing environment v
connecting to

See connecting
Disconnect dialog box 93
disconnecting from. See

disconnecting 93
Member Selection dialog

box 85, 91
Member Selection dialog box,

from Query Designer 71
menu 13
migration information 1
Options dialog box 21, 99, 190
starting a session 13
System Login dialog box 26, 97
upgrades 1

Essbase Integration Server 6, 185

Essbase Integration Server
drill-through

See drill-through
EssCell function 126

error messages 129
syntax 127

exchange rates 178
Execute button 207
executing drill-through reports 202
expanding data views

See drill down
expanding formulas when

drilling 120
external files 147

F
files

accessing linked 157
destinations

cascaded sheets 173
linking to data cells 148
sample for tutorial vii, 97

filtering data 104
filters

operators 214
with drill-through 217

Find Member dialog box 87
finding members 84, 87
FlashBack command 30
font

formats 55
style list 56

Font dialog box 55
forced logouts 94
formatted sheets

pivoting in 118
retrieving data into 114

formatting
data cells

linked objects 151, 166
read-only 59
read/write 59

dimension members 57
displaying aliases 62
displaying aliases and names 64
Dynamic Calculation

members 130
enabling styles 56
linked object cells 151, 166
options for cascaded sheets 175
parent members 54
repeating member labels 65
spreadsheets 53
text and cell styles 60

Formula Fill option 120, 122
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Formula Preservation mode
Formula Fill 119
pivoting in 118
restrictions with 118, 119
Retain on Keep and Remove

Only 119
Retain on Retrieval 116, 119

formulas
EssCell 126
expanding when drilling 120
in cells 115, 119
preservation

effects on other
operations 119

enabling 116, 119
restrictions with 118

free-form reporting
entering generation and level

names in 144
in Advanced Interpretation

mode 137
in Free-Form mode 139
retrieving data 136

Free-Form retrieval mode 139
guidelines 140

functions
See macro functions

G
generations

defined 10
entering names in

spreadsheet 144
Global page (Essbase Options dialog

box) 19

H
Help buttons 18
Help, accessing 18
Hybrid Analysis

Enabling in the Zoom page
(Essbase Options dialog
box) 22

Hyperion Essbase
intended audience 3
products of 5

Hyperion Essbase Spreadsheet
Add-in

accessing drill-through from 196
logging data updates 170
retrieval cursors 29
starting 13
users, described 4

I
in-cell editing 19
installation, drill-through 188
Integration Server drill-through

See drill-through
Internet, linking cells to URLs 154
Interntl sample database 178

K
Keep Only command

described 43
in Formula Preservation

mode 119

L
labels

applying styles 57
displaying with aliases 64
entering in spreadsheet 137, 140
member names

See member names
repeating 65

LAN
See networks

Latest Time Period option 133
latest time period, specifying 132
levels

cascading by 172
defined 10
drilling down 36
drilling in 36
entering names 144

linked objects
partitions

See linked partitions
reporting objects

See linked reporting objects
Linked Objects Browser dialog

box 164, 166, 201, 206
LROs 148

Linked Objects command 148, 152,
154

linked partitions
access privileges 167
accessing from spreadsheet 166
cells, applying styles 166

Linked Reporting Objects
accessing from spreadsheet 156
applying styles 151
cell notes 152
creating 147
external files 148
URLs 154

linking
cell notes 152

linking (continued)
external files 148
partitions 166
URLs to data cells 154

list, cascaded sheets 175
local area network

See networks
Lock command 168
locking data blocks, with multiple

users 168
logging

off of Essbase
See disconnecting

on to a relational data
source 206

on to Essbase
See connecting

on to Essbase Integration
Server 206

logging data updates from
spreadsheet 170

logical operators 88
logouts, forced or auto 94
Lotus 1-2-3

mouse actions 19

M
macro functions

EssCell 126
Spreadsheet Toolkit vi, 5, 18

main menu (Essbase) 13
manual calculation mode 129
Member Information dialog box 86
member names

aliases for 62
alternate

See aliases
applying styles 54
displaying with aliases 64
entering in spreadsheet 137, 140
formatted sheets 114
indenting 10
repeating 65
with EssCell function 127

Member Preview dialog box 90
Member Retention option 36
Member Selection command 85
Member Selection dialog box 85
Member Selection Preview dialog

box 74
Member Selection, with Query

Designer 71
members

adding 71
aliases for 62
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members (continued)
ancestors 10
applying styles 54, 57
children 9
collapsing 35
defined 9
deleting 46
descendants 10
deselecting 92
drilling down on 32, 33
drilling up on 35
Dynamic Calculation 130
Dynamic Time Series 132
finding 84, 87
generations 10
levels 10
names

See member names
parents 9
retaining 43
selecting 71, 84
siblings 9

menu, Essbase 13
messages (Essbase)

database calculation status 171
display options 119
EssCell 129
unknown member 116

migrating to release 6 1
missing values

suppressing 51
suppressing disabled 120

missing values, suppressing
in cascaded sheets 175
unavailable 120

Mode page (Essbase Options dialog
box) 22, 102, 119

money
See currency conversions

mouse actions, enabling 18
moving

rows and columns
See pivot

through worksheets 47
multidimensional databases

See databases
multiple filter conditions, with

drill-through 215

N
Named Pipes protocol 5
names

alternate
See aliases

applying styles 54

names (continued)
displaying with aliases 64
entering generation 144
entering level 144
repeating 65

Navigate Without Data
command 47, 50

nested columns or rows 32
networks 5
Next Level option 36, 172
nonadjacent cells 44
notes, linking to data cells 152
null values 127
numeric values, preserving 115

O
Objects product 6
ODBC clients 5
OLAP

defined 3
server

See server
online analytical processing 3
online help

displaying for spreadsheet 18
opening

Essbase 13
operating systems 4
operators, comparison 84, 105
options

Cascade 172
Display 21, 99, 190
Global 19, 23, 102, 193
Mode 22, 101, 119, 191
settings for advanced tutorial 99
settings for basic tutorial 21
settings for drill-through

tutorial 190
Style 54
Zoom 22, 36, 100, 190

Options dialog box 21, 190
OR operators 84
Order By dialog box 212
ordering

columns, drill-through 209
rows, drill-through 210

outlines
consolidations 10
described 7
dimensions 9
Dynamic Calculation

members 130
Dynamic Time Series

members 132
members 9

output, cascaded sheets 172
overlapping styles 60

P
parent members

applying styles to 54
defined 9

Partitioning product
See linked partitions

partitions
See linked partitions

passwords
changing 28
entering 98

pattern matching 88
pivot

asymmetric reports and 114
by dragging 39
described 19, 38
effect on text 115
formatted sheets and 118
formula preservation and 118
rows or columns 38, 114
unavailable 115
without retrieving data 48

Pivot command 38
power loss 94
preferences

See options
preserving formulas 116, 123
primary mouse button 18
printer destination, cascaded

sheets 173
programming interface 5

Q
queries

applying styles 80
creating 69
defining 68
deleting 80
retrieving 68
saving 76

Query Designer
applying option settings 83
connecting to multiple

databases 82
creating queries 70
data filtering panel 105
data sorting panel 109
filtering data 104
hint panel 68
layout panel 70
messages 112
messages and confirmations 80
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Query Designer (continued)
navigation panel 68
properties panel 68
save as query dialog box 76
sorting data 109

R
read-only cells 60
read/write cells 60
relational data source 206
relational databases, accessing with

drill-through 185
remote databases

See linked partitions
Remove Only command

described 46
in Formula Preservation

mode 119
Remove Unselected Groups

option 120
removing

See deleting
Repeat Member Labels option 65
report script commands 140, 142
reports

ad hoc 28, 118
ad hoc currency 181
asymmetric 112
creating multiple 172
formatted 114
free-form 136
methods of generating v
saving 93

reports, creating
ad hoc 28, 181
Cascade 172
Member Selection 84
methods v
Query Designer 68

reports, drill-through
accessing 196
customizing 187, 203
disconnecting from 218
executing 202
selecting to view or

customize 202
restoring database views 30
restrictions, with Formula

Preservation 119
Retain on Keep and Remove Only

option 120
Retain on Retrieval option

disabled 120
enabled 116, 119

Retain on Zooms option 120, 122

retaining
data subsets 43
formulas 115

when drilling 119
when retaining data 119
when retrieving 116, 119

selected members 43
Retrieve & Lock command 168
Retrieve command 29
retrieving

Advanced Interpretation mode
and 137

canceling 30
conditional 104
currency conversion 178
cursors 29
data 26
Dynamic Calculation

members 130
formula preservation and 119
Free-Form mode and 140
functions 126
increasing speed 61, 113, 123,

130
into asymmetric reports 112
into columns 33
into formatted sheets 114

rules for 115
into rows 33
less detail 35
modes 137
more detail 31
performance impact 61, 113, 130
range of cells 123
retaining formulas and 116, 119
selected cells 123
starting process and 28
suppressing data and 47

reverting to previous database
view 30

rows
blank 114
deleting during pivot 114
displaying as columns 38
displaying selected 43
filtering by 105
keeping discontinuous 44
nested 32
pivoting 38
removing selected 46
retrieving into 33
sorting within 110
suppressing values in 51, 175

S
sample

databases
connecting to 27, 178
described vi, 25, 178

databases, in drill-through 194
files for tutorial, location 97

Sample Basic
connecting to 27
described 25

Sample directory 97
Save As command 93
Save command 93
saving

queries 76
worksheets 93

secondary mouse button 18
select (defined) 19
Select Calc Script option 171
Select Columns and Display Order

dialog box 209
Select Data Filters dialog box 213
Select Data Sort Order dialog

box 210
Select Drill-Through Report dialog

box 202, 207
Select Filter Values from the List

dialog box 214, 215
selecting

cells to keep 43
cells to remove 46
latest time period 132
members 84
nonadjacent cells 44
range of cells for retrieval 123

Send command 168
sending

data to server 168
log file 170

server
changing password 28
client-server environment 4
connecting to 27, 98
described 4
disconnecting from 93
Essbase Integration Server 6,

185
Essbase OLAP, described 4
logging updates to 168
migrating to release 5, with

client 1
name 27, 98
on network 5
sending data to 168
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Set Filter on Column dialog
box 213

shared members, applying styles
to 55

sheet destination, Cascade
option 173

sheets
See worksheets

shortcuts, mouse actions 19
siblings (defined) 9
sort order

with drill-through 210
with Query Designer 109

sorting criteria 104
Spreadsheet Toolkit product 5
spreadsheets

applying styles 53
cascading 172
creating multiple 172
data update log file 170
described 6
displaying aliases 62, 64
displaying member names 64
distributing 172
drilling options 36
global options 19, 31, 119
mode options 119, 137
preserving formulas 119
repeating member labels 65
retrieving data 26
saving 93
setting options 21
style options 53
suppressing missing and zero

values 51
zoom options 36

SQL Interface 5
starting

data retrieval 29
drill-through 196
Hyperion Essbase 13
Hyperion Essbase Spreadsheet

Add-in 13
status of database connections 165
Style page (Essbase Options dialog

box) 54
styles

applying
to data cells 59
to dimension members 57
to dimensions 57
to drill-through cells 196
to linked partition cells 166
to linked reporting object

cells 151

styles (continued)
applying (continued)

to members 54
to parent members 54
to Query Designer results 83
to shared members 55

clearing 61
defining 54
hierarchy of 60
overlapping 60
removing 61
selecting members 55
stored in ESSBASE.INI 59
turning off 61
turning on 56

Subset dialog box 88, 89
subsets

defining members 88
removing 46
retaining 43

substitution variables 135, 136
suppressing

data retrieval 47
disabled 120
missing and zero values 51
underscore characters 51

symmetric reports 112
system administrator 3
system failure 94

T
table of contents, with Cascade 175
TCP/IP protocol 5
terminating database connections

See disconnecting
termination, abnormal 94
text

entering free-form 137
formatting 55
hierarchy of styles 60
pivoting

See pivot
preserving formatted 115

time periods 132
title members, with drill-down 33
to-date calculations, specifying 132
tracking data updates 170
transaction-level data, accessing with

drill-through 185
transparent partitions

See linked partitions
transport protocol 5
tutorial

basic tasks 11
guidelines 24

tutorial (continued)
preparing for 20

U
UDA

See user-defined attributes
underscore characters,

suppressing 53
Undo command

See FlashBack command
undoing actions 30
Unlock command 168
unlocking data blocks 168
up-to-date calculations 132
Update Mode 168
updating

data 168
log file 170

upgrading 1
URLs

accessing linked 160
editing 162
length limits 156
linking to data cells 154

Use Aliases option 62
Use Both Member Names and

Aliases option 64
Use Sheet Options with Query

Designer option 83
Use Styles option 56
User-Defined Attributes 88
username, entering 98
users 4

V
V2.x mode 140
VBA functions vi
viewing

active connections 165
aliases 62
aliases and names 64
data in spreadsheet 28
Dynamic Calculation

members 130
Essbase menu 13
fewer members

See drill
linked partitions 166
linked reporting objects 156
more members

See drill
multidimensional data 7
online help 18
repeated member labels 65
spreadsheet without data 47
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viewing (continued)
styles 56

views, restoring 30
Visual Basic for Applications

See VBA functions
visual cues

See styles

W
Web resources, linking to data

cells 154
wildcard characters 87
Within Selected Group option 37,

113
worksheets

formatting 53
navigating without data in 47

World Wide Web, linking to data
cells 154

X
Xchgrate sample database 178

Z
zero values

suppressing 51, 53
suppressing disabled 120

Zoom commands, customizing 36
Zoom In command

drilling down options 31
selecting levels 36

Zoom Out command, drilling up
options 35

Zoom page (Essbase Options dialog
box) 22, 36

Enable Hybrid Analysis
option 22
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Contacting IBM

If you have a technical problem, please review and carry out the actions
suggested by the product documentation before contacting DB2 OLAP Server
Customer Support. This guide suggests information that you can gather to
help DB2 OLAP Server Customer Support to serve you better.

For information or to order any of the DB2 OLAP Server products, contact an
IBM representative at a local branch office or contact any authorized IBM
software remarketer.

If you live in the U.S.A., you can call one of the following numbers:
v 1-800-237-5511 for customer support
v 1-888-426-4343 to learn about available service options

Product Information

If you live in the U.S.A., then you can call one of the following numbers:
v 1-800-IBM-CALL (1-800-426-2255) or 1-800-3IBM-OS2 (1-800-342-6672) to

order products or get general information.
v 1-800-879-2755 to order publications.

http://www.ibm.com/software/data/db2/db2olap/
The DB2 OLAP Server World Wide Web pages provide current DB2
OLAP Server information about news, product descriptions, education
schedules, and more.

http://www.ibm.com/software/data/db2/db2olap/library.html
The DB2 OLAP Server Technical Library provides access to frequently
asked questions, fixes, books, and up-to-date DB2 technical
information.

Note: This information may be in English only.

http://www.elink.ibmlink.ibm.com/public/applications/
publications/cgibin/pbi.cgi The International Publications ordering
Web site provides information about how to order books.

http://www.ibm.com/education/certify/
The Professional Certification Program from the IBM Web site
provides certification test information for a variety of IBM products.

Note: In some countries, IBM-authorized dealers should contact their dealer
support structure instead of the IBM Support Center.
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