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Preface

Purpose
This guide provides you with instructions for installing Essbase Spreadsheet 
Services and deploying the Essbase Spreadsheet Services client add-in. 

This book supplements the information provided in the Essbase Deployment 
Services Installation Guide. That guide, used in conjunction with this guide, gives 
you the concepts, processes, and procedures that you need to install, configure and 
use the software. 

Audience
This guide is for system administrators and software developers who are 
responsible for installing Essbase Spreadsheet Services, configuring it, and 
building client programs for use with the product.

Document Structure
This document contains the following information: 

● Chapter 1, “Installing Essbase Spreadsheet Services,” describes how to install 
Essbase Spreadsheet Services on Windows systems.

● Chapter 2, “Advanced Installation Topics,” covers deployment of the Essbase 
Spreadsheet Services to client machines and the necessary installation and 
configuration of associated software products. 

● Index contains a list of Essbase Spreadsheet Services terms and their page 
references.
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Related Documentation
Hyperion provides the following documentation for this product:

● The Essbase Deployment Services Installation Guide, for more information 
about configuring and using Essbase Spreadsheet Services.

● The Essbase Spreadsheet Services Add-In Help is accessed by clients for 
assistance with the operation of the Essbase Spreadsheet Services Spreadsheet 
Add-In. 

Online Help

➤ To access the Spreadsheet Services online help:

In Excel, select Help > Essbase Spreadsheet Services Help.

If you are prompted that the help cannot be located, follow the instructions in 
“Accessing Spreadsheet Services Add-In Online Help” on page 33.

➤ To print an online help topic, display the topic and select File > Print. 

Conventions
The following table shows the conventions used in this document:

Table i: Conventions Used in This Document 

Item Meaning

➤  Arrows indicate the beginning of a procedure consisting 
of sequential steps.

Brackets [] In examples, brackets indicate that the enclosed 
elements are optional.

Bold Bold text indicates words or characters that you type 
exactly as they appear on the page. Bold in procedural 
steps highlights major interface elements.

CAPITAL LETTERS Capital letters denote commands and various IDs. 
(Example: CLEARBLOCK command)
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Ctrl + 0 Keystroke combinations shown with the plus sign (+) 
indicate that you should press the first key and hold it 
while you press the next key. Do not type the plus sign.

Example text Courier font indicates that the example text is code or 
syntax.

Courier italics Courier italic text indicates a variable field in command 
syntax. Substitute a value in place of the variable shown 
in Courier italics.

Italics Italics in a product-related term in the body of a book 
indicates that the term is also included in the glossary of 
the book.

n, x Italic n stands for a variable number; italic x can stand 
for a variable number or an alphabet. These variables 
are sometimes found in formulas.

Ellipses (...) Ellipsis points indicate that text has been omitted from 
an example.

Mouse orientation This document provides examples and procedures using 
a right-handed mouse. If you use a left-handed mouse, 
adjust the procedures accordingly.

Menu options Options in menus are shown in the following format. 
Substitute the appropriate option names in the 
placeholders, as indicated.

Menu name > Menu command > Extended menu 
command 

For example: 1. Select File > Desktop > Accounts. 

Table i: Conventions Used in This Document (Continued)

Item Meaning
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Additional Support
In addition to providing the documentation and online help, Hyperion offers the 
following support for product information.

Education Services
Hyperion offers instructor-led training, custom training, and eTraining covering all 
Hyperion applications and technologies. Training is geared to administrators, end 
users, and information systems (IS) professionals. 

Consulting Services
Experienced Hyperion consultants and partners implement software solutions 
tailored to clients’ particular reporting, analysis, modeling, and planning 
requirements. Hyperion also offers specialized consulting packages, technical 
assessments, and integration solutions.

Technical Support
Hyperion provides enhanced electronic-based and telephone support to clients to 
resolve product issues quickly and accurately. This support is available for all 
Hyperion products at no additional cost to clients with current maintenance 
agreements.

Documentation Feedback
Hyperion strives to provide complete and accurate documentation. We value your 
opinions on this documentation and want to hear from you. Send us your 
comments by clicking the link for the Documentation Survey, which is located on 
the Information Map for your product.
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1

Chapter

1
Installing Essbase 
Spreadsheet Services

This chapter describes the installation procedures for Essbase Spreadsheet 
Services software on Windows and UNIX systems. 

The default installation of Spreadsheet Services includes a full installation of 
Essbase Deployment Services as well as Spreadsheet Services. Spreadsheet 
Services is designed to work with Essbase Deployment Services, which provides 
the connections to Hyperion Essbase Analytic Servers.

Spreadsheet Services requires that the Analytic Server components be installed 
and configured separately. The Deployment Services components can be installed 
and configured as part of the Spreadsheet Services installation. For complete 
information on Analytic Services and Deployment Services products, refer to their 
respective documentation sets. 

Note: This book supplements the information provided in the Essbase Deployment 
Services Installation Guide. That guide, used in conjunction with this guide, gives you 
the concepts, processes, and procedures that you need to install, configure and use the 
software. 

Installation Overview
The process of installing Essbase Spreadsheet Services and deploying it to client 
computers consists of the following tasks:

1. Run the Essbase Spreadsheet Services installation program. This process is 
covered in “Installing on Windows Systems” on page 10 and “Installing on 
UNIX Systems” on page 13.

2. Configure the web application server environment. This process is covered in 
“Before Deploying on an Application Server” on page 20.
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3. Deploy the Spreadsheet Services files as a servlet in the web application 
server. This process is covered in Chapter 2, “Advanced Installation Topics”. 
See the instructions for your specific application server.

4. Deploy the Essbase Spreadsheet Services Excel Add-In component to client 
computers. This process is described in “Deploying to Client Machines” on 
page 29. 

Note: When the installer is started, it extracts the necessary files to a temp directory 
(/tmp in UNIX). Make sure the user has sufficient access privileges to read/write files to 
this location. 

Installing on Windows Systems

Windows System Requirements
Essbase Spreadsheet Services for Windows needs a system that meets specific 
requirements. These requirements are described in Table 1.

Table 1: Essbase Deployment Services Server Windows System Requirements

Component Requirements

Microprocessor Pentium or higher

RAM 128 MB

Windows version Windows 2000 SP3 or Windows XP Professional

Disk space 70 MB:

• 15 MB for the server software, API, sample 
applications, and documentation

• 12 MB for the Essbase libraries

• 40 MB for the Java Runtime Environment

Essbase Release 7.0 or later

Java™ platform Java Runtime Environment version 1.4.1

Spreadsheet Support Excel 2000, Excel XP, Excel 2003
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The default Essbase Spreadsheet Services installation program performs the 
following operations:

● Copies Essbase Deployment Services files to the\HYPERION_HOME\eds
\7.1.0.0\ directory (or to the directory you specify) on your hard disk

● Installs  the Java Runtime Environment to the \HYPERION_HOME\common
\jre directory

● Copies the Essbase Deployment Services sample application files to 
the\HYPERION_HOME\eds\7.1.0.0\samples directory on your hard disk

● Copies the Essbase Deployment Services documentation files to 
the\HYPERION_HOME\eds\7.1.0.0\docs directory on your hard disk

● Copies the Essbase Spreadsheet Services client files to the 
\HYPERION_HOME\ess\7.1.0.0\ directory on your hard disk

● Copies the Essbase Spreadsheet Services documentation files to 
the\HYPERION_HOME\ess\7.1.0.0\docs directory on your hard disk

● Updates existing directories if you have a previous release of Deployment 
Services or Spreadsheet Services installed. 

● Creates the initial default user account with name=system and 
password=password. This account is used to build additional user accounts. 
The password of the system account can be changed.

Installation Procedure for Windows Systems
Install Essbase Spreadsheet Services software on Windows platforms by running 
the self-extracting installation program that you downloaded from the Hyperion 
Download Center or by using the product CD.

This installation procedure installs both Essbase Deployment Services and 
Essbase Spreadsheet Services. Deployment Services components are required for 
Spreadsheet Services, so the default installation program installs both.

➤ To install Essbase Spreadsheet Services software to a Windows computer:

1. Start the installation program by double-clicking on setup.exe. 

The InstallShield installation program displays the startup screen with a 
progress bar for loading the setup executable. 

2. The first dialog specifies the language to be used for the installation. Select a 
language and click OK to continue. 
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3. The installation program displays an Essbase Spreadsheet Services banner and 
launches the installation wizard. The first wizard screen displays some 
instructions for completing the installation process. Read the short list and 
click Next. 

4. The next dialog displays the location for the Hyperion Home directory. If this 
location is already in the environment variables of your system, then it cannot 
be modified. If it is not already in your environment variables, customize the 
location of your HYPERION_HOME directory or accept the default location, then 
click Next. 

Hyperion Home contains elements that are common to several Hyperion 
products. This Hyperion Home folder contains the application server, the 
Hyperion security platform components, the MySQL database, and the JDK 
Java Runtime Environment components. 

5. If a previous installation of Essbase Deployment Services and Spreadsheet 
Services is found, the installation program gives you a choice of whether to 
continue or cancel the new installation. You should uninstall previous versions 
before continuing. If you are going to install in a different directory you can 
continue. 

See “Uninstalling Essbase Spreadsheet Services” on page 37 for information 
on uninstalling Spreadsheet Services. 

6. The next dialog displays the location for the Deployment Services and 
Spreadsheet Services files. This is the recommended location for all the 
installed files. Click Next. 

7. The next dialog displays a choice of either the Typical or Custom installation. 
The Typical installation installs all Deployment Services and Spreadsheet 
Services files and is strongly recommended. A custom-designed installation is 
outside the scope of these steps. Click Next. 

8. The next dialog assigns ports for the default application server, Apache 
Tomcat. The assignments can be changed later. Spreadsheet Services installs 
Jakarta Tomcat Application Server and by default configures Tomcat with port 
numbers 8080 for startup and 8085 for shutdown. If you have already installed 
Jakarta Apache Tomcat and know the port assignments are different from 
those shown here, type those port numbers in the text boxes. In other cases, 
leave these default port assignments and click Next. Make sure that 
subsequent installations of Apache Tomcat associated with other software use 
different port assignments.
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9. The next dialog assigns the port and location of the MySQL database. The port 
assignment can be changed later if needed. By default, Spreadsheet Services 
installs MySQL as the domain storage database. The default path to the 
MySQL files (HYPERION_HOME\common) is a directory of files that are 
commonly needed by Hyperion programs. A previous installation of 
Spreadsheet Services or any of the other Hyperion products that use the 
common folder will have established the HYPERION_HOME\common path and 
the Spreadsheet Services installation program will recognize that path. A 
first-time installation will not have that path set. By default, the port number 
for MySQL is 3306 and the database name is Essbase. It is recommended that 
you accept the default settings. Click Next.

10. The next dialog displays all the Deployment Services and Spreadsheet 
Services components that will be installed and their locations. Click Next to 
continue the installation. 

11. The installation program next displays a series of screens with a progress bar 
that indicates the percentage completion of the installation process. Wait until 
the process is complete and the final screen is displayed. Click Finish to end 
the installation. 

12. To start the server, select Start > Programs > Hyperion Solutions > Essbase 
Deployment Services > Start Essbase Deployment Server - HTTP or 
Start > Programs > Hyperion Solutions > Essbase Deployment Services > 
Start Essbase Deployment Server - TCPIP. 

Installing on UNIX Systems
Install Essbase Spreadsheet Services server software on UNIX platforms by 
running the self-extracting installation program that you downloaded from the 
Hyperion Download Center or by using the product CD. See “Installation 
Procedure for UNIX Systems” on page 15 for more information.

The default installation installs the server component of Spreadsheet Services and 
the server and client components Deployment Services.
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UNIX System Requirements
Essbase Spreadsheet Services for UNIX requires a system that meets minimal 
hardware and software requirements. However, Essbase Spreadsheet Services for 
Solaris requires a system with the following minimal hardware and software 
requirements:

Depending on the type of client programs you use with the Essbase Deployment 
Services component, additional system and software resources may be required. 
For more information on the types of client programs you can use with Essbase 
Deployment Services, see the Essbase Deployment Services Installation Guide.

The Essbase Spreadsheet Services installation program performs the following 
operations:

● Copies Essbase Deployment Services files to the /HYPERION_HOME/eds 
directory (or to the directory you specify) on your hard disk. 

● Installs the Java Runtime Environment to the /HYPERION_HOME/common
/jre directory. 

● Copies the Essbase Deployment Services sample application files to 
the/HYPERION_HOME/eds/samples directory on your hard disk. 

Table 2: Essbase Deployment Services Solaris System Requirements 

Component Requirements

Server platform Sun SPARC or ULTRASPARC machines

Solaris version 8 or 9

Physical memory 128 MB RAM

Disk space 50 MB:

• 15 MB for the server software, API, sample 
applications, and documentation

• 9 MB for the Essbase libraries

• 26 MB for the Java Runtime Environment

Essbase Release 7.0 or later

Java™ platform Java Runtime Environment version 1.4.1
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● Copies the Essbase Deployment Services documentation files to 
the/HYPERION_HOME/eds/docs directory on your hard disk. 

● Creates the initial default user account with name=system and password=
password. This account is used to build additional user accounts. The 
password of the system account can be changed. 

● Copies the Essbase Spreadsheet Services server files to the 
/HYPERION_HOME/ess/7.1.0.0 directory on your hard disk

● Copies the Essbase Spreadsheet Services documentation files to 
the/HYPERION_HOME/ess/7.1.0.0/docs directory on your hard disk

● Updates existing directories if you have a previous release of Essbase 
Deployment Services or Spreadsheet Services installed. 

Installation Procedure for UNIX Systems

➤ To install Essbase Spreadsheet Services software on a computer running a UNIX 
operating system:

1. Start the installation program by double-clicking on setup.bin. The 
installation program displays the startup screen with a progress bar for loading 
the setup executable. 

2. The first dialog specifies the language to be used for the installation. Select a 
language and Click OK to continue. 

Note: The language selection dialog box only displays in Solaris installations. 
Other UNIX system installations do not include this dialog box. 

3. The installation program displays an Essbase Spreadsheet Services banner and 
launches the installation wizard. The first wizard screen displays some 
instructions for completing the installation process. Read the short list and 
click Next. 

4. The next dialog displays the location for the Hyperion Home Directory. In 
addition to Deployment Services and Spreadsheet Services, this directory 
contains elements that are common to several Hyperion products. The 
HYPERION_HOME/common folder contains the application server, the Hyperion 
Common Security System components, the MySQL database, and the JDK 
Java Runtime Environment components. If this location is already in the 
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environment variables of your system, then it can not be modified. If it is not 
already in your environment variables, customize the location of your 
HYPERION_HOME directory, then click Next. 

5. If a previous installation of Essbase Spreadsheet Services is found, the 
installation program will give you a choice of whether to continue or cancel 
the new installation. You should uninstall previous versions before continuing. 
If you are going to install in a different directory you can continue. 

6. The next dialog displays the location for the Spreadsheet Services files. The 
default location for the installed files is HYPERION_HOME/ess/7.1.0.0 for 
the Spreadsheet Services components.  Deployment Services components are 
installed to HYPERION_HOME/eds/7.1.0.0. To change the location, either 
browse to a directory or type in the path. Click Next. 

7. The next dialog displays a choice of either the Typical or Custom installation. 
The Typical installation installs all Spreadsheet Services server files and all 
Deployment Services files and is strongly recommended. A custom-designed 
installation is outside the scope of these steps. Click Next. 

8. The next dialog assigns ports for the default application server, Apache 
Tomcat. The assignments can be changed later through the Tomcat user 
interface. Spreadsheet Services installs Jakarta Tomcat Application Server and 
by default configures Tomcat with port numbers 8080 for startup and 8085 for 
shutdown. Make sure that any other instances of Tomcat on this machine use 
different port assignments. If you have already installed Jakarta Apache 
Tomcat and know the port assignments are different from the defaults, type 
those port numbers in the text boxes. In other cases, leave the default port 
assignments and click Next.

9. The next dialog assigns the port and location of the MySQL database. The port 
assignment can be changed later if needed. By default, Spreadsheet Services 
installs MySQL as the domain storage database. The default path to the 
MySQL files (HYPERION_HOME/common) is a directory of files that are 
commonly needed by Hyperion programs. A previous installation of 
Spreadsheet Services or any of the other Hyperion products that use the 
common folder will have established the HYPERION_HOME/common/ path 
and the Spreadsheet Services installation program will recognize that path. A 
first-time installation will not have that path set. By default, the port number 
for MySQL is 3306 and the database name is Essbase. It is recommended that 
you accept the default settings. Click Next. 
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10. The next dialog displays the all the Deployment Services and Spreadsheet 
Services components (and locations) that will be installed. Click Next to 
continue the installation. 

11. The installation program next displays a series of screens with a progress bar 
that indicates the percentage completion of the installation process. Wait until 
the process is complete and the final screen is displayed. Click Finish to end 
the installation. 

Note: The Essbase Deployment Services installer requires a system with the JAVA 
1.4.1 Runtime environment installed.
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2

Chapter

2
Advanced Installation Topics

This chapter provides instructions for deploying the Essbase Web Service for 
Spreadsheet Services, deploying Essbase Spreadsheet Services to client 
computers, and uninstalling Essbase Spreadsheet Services.

This chapter contains the following topics:

● “Deploying Spreadsheet Services on Application Servers” on page 20

● “Deploying to Client Machines” on page 29

● “Uninstalling Essbase Spreadsheet Services” on page 37

Before you begin the deployment of the Essbase Web Service to your application 
server and the deployment of the Spreadsheet Services client to your user 
community, you must first configure Deployment Services and deploy it to an 
application server. For more information on Deployment Services topics, refer to 
the Essbase Deployment Services Installation Guide. 

Note: This book supplements the information provided in the Essbase Deployment 
Services Installation Guide. That guide, used in conjunction with this guide, gives you 
the concepts, processes, and procedures that you need to install, configure and deploy 
the software. 
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Deploying Spreadsheet Services on Application 
Servers

This section describes what you need to do to deploy an Essbase Web Service for 
Spreadsheet Services within the Apache Tomcat application server or other 
supported application servers. 

Note: The procedures in this section assume that you have already configured and 
deployed Deployment Services on an application server. Refer to the Essbase 
Deployment Services Installation Guide for the deployment procedures.

There are two steps to the deployment:

1. Configure Essbase Spreadsheet Services, as described in “Before Deploying 
on an Application Server” on page 20.

2. Deploy the Essbase Web Service for Spreadsheet Services on an application 
server.

See the section appropriate to your application server for deployment 
instructions.

Before Deploying on an Application Server
Before you begin deploying Essbase Spreadsheet Services on an application 
server, you must complete the procedure in this section. This procedure consists of 
the following tasks:

● Extracting the contents of the Spreadsheet Services .war file

● Editing the web.xml file to specify the location of the Spreadsheet Services 
installation and customize the Spreadsheet Services options that you require

● Repacking the .war file

These tasks assume that you have already done the following:

● Installed Deployment Services and an application server

● Configured Deployment Services, and deployed it on your application server

● Installed Spreadsheet Services 
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➤ To extract the .war file, edit the web.xml file, and repack the .war file:

1. Copy the ess_webservice.war file, located by default in 
HYPERION_HOME\ess\7.1.0.0\redist, to a temporary directory 
and unpack it using the following command: 

jar -xvf ess_webservice.war 

Note: It is recommended that you make a backup of the ess_webservice.war 
file.

2. Delete the .war file that was copied into the temporary directory.

3. Edit the WEB-INF\web.xml file that was unpacked into the temporary 
directory to verify the port number on which the application server listens is 
correct.

The following is an example from the web.xml file with the port number on 
which the Apache Tomcat Server listens added as a servlet parameter using the 
URL of the application server.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.
//DTD Web Application 2.2
//EN" "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">>

<web-app id="WebApp_ID">
<display-name>EssWebModule</display-name>
<servlet id="Servlet_1">
<servlet-name>EssbaseWebService</servlet-name>
<servlet-class>com.essbase.webservices.EssbaseWebService
</servlet-class>

<init-param id="InitParam_1051163241625">

<param-name>webservice.request.redirect.enterpriseServer.url
</param-name>
<param-value>http://localhost:8080/eds/EssbaseEnterprise 
</param-value>

</init-param>

</servlet>
<servlet-mapping id="ServletMapping_1">

<servlet-name>EssbaseWebService</servlet-name>
<url-pattern>/EssbaseWebService</url-pattern>
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</servlet-mapping>
</web-app>

4. Save the web.xml file.

5. Repack the ess_webservice.war file using the following command: 

jar -cvf ess_webservice.war . 

6. Optional. Copy the ess_webservice.war file back to the original location; 
typically the HYPERION_HOME\ess\7.1.0.0\redist folder.

7. If not already started, start the application server program.

After you complete this procedure, you are ready to begin deploying Spreadsheet 
Services on your application server. 

Deploying on Apache Tomcat Server
Apache Tomcat 4.1.30 is installed with Essbase Spreadsheet Services and the 
Essbase Web Service for Spreadsheet Services is configured and deployed by 
default. If you are using the default Apache Tomcat 4.1.30, you can use the 
procedure in this section to validate the installation. 

If you have an existing installation of Apache Tomcat that want to deploy and 
configure for use with Deployment Services, complete the steps in “Before 
Deploying on an Application Server” on page 20, and then perform the following 
steps.

Note: If you are also deploying Deployment Services on Apache Tomcat, refer to the 
Essbase Deployment Services Installation Guide for the deployment procedure.

1. If Apache Tomcat is already running, stop the application server. 

2. Copy C:\Hyperion\ess\7.1.0.0\redist\ess_webservice.war file 
to the \tomcat\4.1.x\webapps directory. 

3. Start the Apache Tomcat server.
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4. Open the web.xml file located in 
\tomcat\4.1.x\webapps\ess_webservice\WEB-INF\ and verify that 
the port number on which the Tomcat server listens is correct, then take one of 
the following actions:

● If you make changes to the web.xml file, stop and restart the Apache 
Tomcat server, then proceed to step 5.

● If you do not need to make changes to the web.xml file, proceed to step 5.

5. To validate that you have successfully deployed the Essbase Web Service for 
Spreadsheet Services, launch a browser and go to http://<hostname>:
<port number>/ess_webservice/EssbaseWebService to verify that 
the Essbase Web Service is up and running.

Running Multiple Instances of Apache Tomcat Server
Deployment Services and Spreadsheet Services share the same port assignment for 
Apache Tomcat. This port assignment may or may not conflict with the port 
assignments used by other software. To avoid conflicts, make sure that subsequent 
installations of Apache Tomcat associated with other software use different port 
assignments. 

If you want to run Deployment Services and Spreadsheet Services on separate 
instances of Apache Tomcat application servers, the port assignments for each 
instance of Tomcat must be different.

To change the port where the Tomcat application server is running, edit the 
appropriate server.xml file in the /conf directory. The /conf directory is 
installed by default in the following locations: 

For Spreadsheet Services: 
ess_home\7.1.0.0\deployments\Tomcat\4.1.30\conf

For Deployment Services: 
eds_home\7.1.0.0\deployments\Tomcat\4.1.30\conf

Search for the Connector className definition and change the port assignment. 
The default is 8080. 

For example: 

Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
port="8080" 



24 ■

Advanced Installation Topics

Essbase Spreadsheet Services Installation Guide

Deploying on BEA WebLogic Server 7.x 
If you plan to use the BEA WebLogic 7.x application server with Essbase 
Spreadsheet Services, complete the steps in “Before Deploying on an Application 
Server” on page 20, start the WebLogic server and perform the following steps. 

Note: If you are also deploying Deployment Services on WebLogic 7.x, refer to the 
Essbase Deployment Services Installation Guide for the deployment procedure.

➤ To deploy the Essbase Web Service for Spreadsheet Services to WebLogic Server 
7.x:

1. In the WebLogic navigation frame, click mydomain, then click Applications. 

2. From the menu displayed, select Configure a New Application. 

3. On the Locate Application or Component to Configure page of the 
configuration wizard, select upload it through your browser. This will 
enable you to upload the ess_webservice.war file and deploy to the 
WebLogic server. 

4. On the Install or Update an Application page of the configuration 
wizard, click Browse to navigate to the .war file. 

5. Navigate to $HYPERION_HOME\ess\7.1.0.0\redist
\ess_webservice.war.

6. The installation process returns you to the Locate Application or 
Component to Configure page of the configuration wizard, and the 
ess_webservice.war file is displayed in the list of the WebLogic 
...\server\bin files. 

7. Click Select next to the ess_webservice.war file to select it from the list. 
This displays the Configure Application or Component to Configure page 
of the configuration wizard. 

8. In the Available Servers list box, select the server to configure, then enter a 
name for the application in the Target Servers text box to the right, and click 
Configure and Deploy. 

9. In the left frame, select Deployments > Web Applications, then select 
ess_webservice and click the Edit Web Application Deployment 
Descriptors link.

10. In the left frame, select Servlets > EssbaseWebService > Parameters.
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11. In the Parameter Name list, verify that the parameters are correct.

To edit parameters, click the parameter name and make changes in the 
Configuration page. Then click Apply.

12. Select the EssWebModule link and click Persist.

13. Stop and restart the WebLogic server.

14. To validate that you have successfully deployed the Essbase Web Service for 
Spreadsheet Services, launch a browser and go to http://<hostname>:
<port number>/ess_webservice/EssbaseWebService to verify that 
the Essbase Web Service is up and running.

Deploying on BEA WebLogic Server 8.x 
If you plan to use the BEA WebLogic 8.x application server with Essbase 
Spreadsheet Services, complete the steps in “Before Deploying on an Application 
Server” on page 20, start the WebLogic server and perform the following steps. 

Note: If you are also deploying Deployment Services on WebLogic 8.x, refer to the 
Essbase Deployment Services Installation Guide for the deployment procedure.

➤ To deploy the Essbase Web Service for Spreadsheet Services to WebLogic Server 
8.x:

1. Start Weblogic Server 8.1 and sign on to the WebLogic Server console.

2. In the WebLogic navigation frame, select mydomain, then select 
Deployments > Web Application Modules.

3. On the Web Applications page, ensure that the Configuration tab is selected 
and click the Deploy a new Web Application Module link to deploy a new 
web module.

4. On the Deploy a Web Application Module page, click the myserver 
folder link to select the myserver domain.

5. Click the upload link to upload the ess_webservice.war file.

6. On the Upload and Install an Application or Module page, click the 
Browse button to navigate to the location of the redist folder 
containing the ess_webservice.war file; for example, 
C:\Hyperion\ess\7.1.0.0\redist\ess_webservice.war, 
and then click the Upload button.
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7. In Select the archive for this Web application module, click the Myserver 
folder, then click the upload folder link.

8. Select the radio button for the ess_webservice.war file and click the 
Target Module button.

9. In Review your choices and deploy, verify that the information under 
Deployment Targets, Source Accessibility, and Identify is correct and click 
Deploy.

A “Success” status is displayed on the message page. 

10. Log out from the WebLogic Server console and restart the WebLogic Server.

11. To validate that you have successfully deployed the Essbase Web Service for 
Spreadsheet Services, launch a browser and go to http://<hostname>:
<port number>/ess_webservice/EssbaseWebService to verify that 
the Essbase Web Service is up and running.

Deploying on IBM WebSphere Enterprise Server 
5.0.x or 5.1

If you plan to use the WebSphere Enterprise Server 5.0.x or 5.1application server 
with Essbase Spreadsheet Services, complete the steps in “Before Deploying on an 
Application Server” on page 20, start the WebSphere server, and perform the 
following steps.

Note: If you are also deploying Deployment Services on WebSphere 5.0.x or 5.1, refer 
to the Essbase Deployment Services Installation Guide for the deployment procedure.

➤ To deploy the Essbase Web Service for Spreadsheet Services to WebSphere 
Enterprise Server 5.0.x or 5.1:

1. Bring the up the WebSphere Administrative Console by typing the following 
URL in a browser. For example:

http://<hostname>:<port number>/admin

2. In the Login window, type your user ID in the text box and click OK.

3. In the left frame of the Administrative Console, select Applications > Install 
New Application.

4. On the Preparing for the application installation page, click Browse 
and navigate to the $HYPERION_HOME\ess\7.1.0.0\redist\
ess_webservice.war file. 
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5. In the Context Root text box, type /ess_webservice and click Next. 

Note: If you do not want any context root, you must stop all the default applications 
except the adminstrative application because “/” is used by one of the applications.

6. In the Generate Default Bindings box, click Next to accept the default 
values. 

7. In the Step 1 Provide options to perform the installation box, click Next to 
accept the default values shown in the AppDeployment Options box. 

8. In the Step 2 Map virtual hosts for web modules box, click 
ESSWebModule to select it as the default host, then click Next. 

9. In the Step 3 Map modules to application servers box, check 
ESSWebModule, to indicate ess_webservice.war is the module to map 
to the WebSphere server, and then click Next. 

10. In the Step 4 Summary box, click Finish to initiate the installation. When the 
installation is completed, a message advises you that the 
ess_webservice_war application is successfully installed. 

11. Click the Save to Master Configuration option to enable startup of 
Deployment Server, then click the Save button. 

12. In the left frame, select Applications > Enterprise Applications. 

13. When the Enterprise Applications page is displayed, select the check box 
next to ess_webservice.war, and then click Start to start the Essbase Web 
Service for Spreadsheet Services. 

14. To validate that you have successfully installed and deployed the Essbase Web 
Service for Spreadsheet Services, go to http://<hostname>:<port 
number>/ess_webservice/EssbaseWebService to verify that the 
Essbase Web Service is up and running.

Deploying on Sun ONE Application Server
If you plan to use the Sun™ ONE application server 7.0 with Essbase Spreadsheet 
Services, complete the steps in “Before Deploying on an Application Server” on 
page 20, then start Sun ONE, and perform the procedures in this section. 

Note: If you are also deploying Deployment Services on Sun ONE, refer to the Essbase 
Deployment Services Installation Guide for the deployment procedure.
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Before you begin the deployment process, you must modify the policy of your 
virtual server to allow reading and writing of properties.

➤ To modify the policy of the virtual server to allow reading and writing of 
properties:

1. Open the server.policy file located in the 
AppServer\domains\domain1\server1\config folder 

2. Search for the string permission java.util.PropertyPermission 
"*", "read ";. 

3. Change string to permission java.util.PropertyPermission "*", 
"read,write";. 

4. Restart the Sun ONE application server.

Now you are ready to begin the deployment process.

➤ To deploy the Essbase Web Service for Spreadsheet Services to Sun ONE 7.0:

1. In the navigation frame of the Sun ONE Administrative Console, navigate to 
Web Apps under server1->applications. 

2. On the Applications page, click Deploy. 

3. On the Upload WAR File page, click Browse and navigate to the 
$HYPERION_HOME\ess\redist\ess_webservice.war file. Click OK. 

4. In the Server1:Applications:Web:Deploy page, click OK accept the default 
values. 

5. Restart the Sun ONE application server for the settings to take effect. 

6. To validate that you have successfully deployed the Essbase Web 
Service for Spreadsheet Services, launch a browser and go to 
http://<hostname>:<port number>/ess_webservice
/EssbaseWebService to verify that the Essbase Web Service is up 
and running. 
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Deploying to Client Machines
The deployment of the Essbase Spreadsheet Services Excel Add-In component to 
client computer is a separate process from the installation of Spreadsheet Services 
and the deployment of the Essbase Web Service for Spreadsheet Services to 
application servers. 

Two methods for automatically deploying the Essbase Spreadsheet Services client 
are available, CAB file and MSI installer. These methods are described in the 
following sections:

● “Deployment Through the CAB File” on page 29

● “Deployment Through the MSI File” on page 34

The deployment can also be done manually, as described in “Alternate CAB 
Deployment” on page 33.

Deployment Through the CAB File
Deployment of Essbase Spreadsheet Services client through the CAB file is 
supported for client computers running Windows 2000 SP3 and above, including 
Windows 2003; and Windows XP Professional. The supported browser for 
launching the CAB file is Internet Explorer 5.5 and later. 

Required Files
The following files are included with Essbase Spreadsheet Services and are 
automatically deployed for CAB file installation the first time you start 
Deployment Server or Spreadsheet Server, if you only installed Spreadsheet 
Services. 

● esswebcomponent.cab—the signed CAB file containing the installer 
package

● esswebcomponent.htm—the HTML file containing code used to deploy the 
CAB installation

● launchpage.htm—the HTML file that you can direct users to. The launch 
page contains links to the CAB installation and links to other Spreadsheet 
Services documentation components.
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Deployment Instructions
After you configure your application server and you start Deployment Server or 
Spreadsheet Server (if you only installed Spreadsheet Services), the required files 
for the CAB installation, including an HTML-based launch page, are 
automatically placed in your web application server folder.

For example, if you use the default Apache Tomcat server included with the 
Spreadsheet Services installation, the necessary components for deploying the 
CAB installation to your users are placed in the appropriate web application 
folders. The folder location depends on whether you only installed the Spreadsheet 
Services release or the combined Deployment Services-Spreadsheet Services 
release, as described in the following topics.

Spreadsheet Services-only Installation

For the Spreadsheet Services-only installation, the CAB file installation 
components are placed in the following folder

ESS_HOME\deployments\Tomcat\4.1.30\webapps\ess_webservice\redist

In the above path, ESS_HOME is the location where you installed Spreadsheet 
Services. 

The launch page is installed in the following location:

ESS_HOME\deployments\Tomcat\4.1.30\webapps\ess_webservice\launchpage

Combined Deployment Services and Spreadsheet Services 
Installation

For the combined Deployment Services and Spreadsheet Services installation, the 
CAB file installation components are placed in the following folder

EDS_HOME\deployments\Tomcat\4.1.30\webapps\ess_webservice\redist

In the above path, EDS_HOME is the location where you installed Deployment 
Services.

The launch page is installed in the following location:

EDS_HOME\deployments\Tomcat\4.1.30\webapps\ess_webservice\launchpage
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➤ To automatically deploy Essbase Spreadsheet Services to client computers:

1. Configure your application server.

See the Essbase Deployment Services Installation Guide for information on 
configuring the application server for your system.

2. Start the Spreadsheet Server or Deployment Server. 

Depending on whether you installed the Spreadsheet Services release or the 
combined Deployment Services-Spreadsheet Services release, start the 
appropriate server.

3. Verify that the required CAB installation files are in the appropriate locations.

Check the webapps\ess_webservice\redist folder for the CAB 
components and the webapps\ess_webservice\launchpage folder for the 
launchpage.htm file. 

See “Spreadsheet Services-only Installation” on page 30 and “Combined 
Deployment Services and Spreadsheet Services Installation” on page 30 for 
an example listing of the appropriate locations. 

4. Optional: Edit the launch page as required.

The launch page provides links to the Spreadsheet Services documentation 
and the Hyperion Developer Network. If you need to limit the links available 
on this page or you want to add links of your own, edit the launchpage.htm 
file.

5. Provide the URL of the launchpage.htm file to your users in the following 
format:

http://hostname:port_number/ess_webservice/launchpage/launchpage.htm

In the syntax above, hostname is the name of the computer where Deployment 
Server (or Spreadsheet Server) in installed and running; port_number is the 
port on which the application server is listening.
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When users access the launchpage.htm file and click on the CAB 
installation link, the CAB installer displays the first screen of the Essbase 
Spreadsheet Services client installer, labeled “Security Warning.” Users then 
complete the following steps:

a. In the Security Warning page, click Yes to continue the Spreadsheet 
Services client installation.

The browser displays a blank page as the program is loaded. When 
finished loading, the Essbase Spreadsheet Services splash screen is 
displayed, and then the Excel spreadsheet program is launched. Excel 
should contain an Essbase menu, along with the standard Excel menus.

b. To locate the online help, select Help > Essbase Spreadsheet Services 
Help.

A prompt is displayed stating that the online help files cannot be found.

c. Click OK at the prompt to locate the online help files.

The help files, ssclient.hlp and ssclient.cnt, are placed in the 
Windows system32 folder.

d. Navigate to the Windows system32 folder and select the 
ssclient.hlp file.

The help is displayed. Spreadsheet Services remembers the location of the 
help and will automatically display the help next time you access it.

Possible Conflict Between Standard Spreadsheet Add-In and 
Spreadsheet Services Add-in

The Excel Add-In for Essbase Spreadsheet Services can conflict with the standard 
Spreadsheet Add-in for Essbase Analytic Services. To eliminate that possible 
conflict, perform the following tasks before you begin the Spreadsheet Services 
Add-in installation:

1. In Excel, select the Tools menu and choose Add-Ins. 

2. Uncheck the Hyperion Essbase OLAP Server add-in, and click OK. 

3. Proceed with the installation process as described in the substeps of step 5 in 
Deployment Instructions. 



Deploying to Client Machines

2

■ 33Essbase Spreadsheet Services Installation Guide

Alternate CAB Deployment

➤ To manually deploy Essbase Spreadsheet Services to client computers:

1. Put the required CAB files on your web server. 

2. Provide users with a URL to access the file esswebcomponent.htm 
from their computer through a web browser, such as Internet Explorer. 
That file contains code that will download the CAB file and install it on 
the client desktop. In most cases the installation can be done by launching 
this file. 

3. Depending on the permissions set on the browser, during installation 
process the users will be prompted with a dialog asking permission to 
install the Excel Add-in. Selecting “Yes” will install the Excel Add-in on 
the client desktop. 

Note: If you experience a conflict between the Standard Spreadsheet Add-In and 
the Spreadsheet Services Add-in, see “Possible Conflict Between Standard 
Spreadsheet Add-In and Spreadsheet Services Add-in” on page 32.

Files Installed
The CAB file installs the following Spreadsheet Services file in the Windows 
Downloaded Program Files folder:

EssWebComponent.EssWebWrapper

Accessing Spreadsheet Services Add-In Online Help
The client online help cannot be installed in a standard location on every client 
machine. When the user first attempts to access the Essbase Spreadsheet Services 
Online Help from Excel Help > Essbase Spreadsheet Services Help, the user will 
be prompted to find the help file. The user should navigate to the 
$WINDIR\SYSTEM32 (for example, c:\windows\system32) and select the 
ssclient.hlp file. After this first access, the online help can be launched by 
navigating to Excel Help > Essbase Spreadsheet Services Help. 
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Uninstalling the Spreadsheet Services Client
You uninstall the Spreadsheet Services client by deleting the 
EssWebComponent.EssWebWrapper from the Windows Downloaded 
Program Files folder. You should also delete all ssclient.* files 
(ssclient.hlp, ssclient.cnt and other files generated when you use the 
help, such as the ssclient.gid file) from the Windows system32 folder.

Deployment Through the MSI File
Deployment of the Essbase Spreadsheet Services client through the MSI file is 
supported for computers running Windows 2000 SP3 and above, including 
Windows 2003; and Windows XP Professional. The supported browser for 
launching an MSI file is Internet Explorer 5.5 and later.

Required Files
The EssbaseSpreadsheetServices.msi file contains the Essbase 
Spreadsheet Services client installer.

Deployment Instructions

➤ To deploy Essbase Spreadsheet Services to the client computer: 

1. Access the MSI installation file on the product CD or download the MSI 
installation zip file from the Hyperion Download Center.

2. Copy the EssbaseSpreadsheetServices.msi file from the product CD 
(or extract it from the ZIP file you downloaded in step 1) to a location on your 
web server. 

3. Notify your users of the availability of the MSI file, whether you are 
distributing the MSI file through the launch page or distributing using another 
method, such as a shared drive.

If you choose, you can edit the launchpage.htm file that is included in the 
HYPERION_HOME\eds\7.1.0.0\deployments\Tomcat\4.1.30\
webapps\ess_webservice\launchpage folder to provide a link to the 
location of the MSI installer.
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When users launch the EssbaseSpreadsheetServices.msi file, the 
installer displays the first screen of the Essbase Spreadsheet Services client 
installer. Users then complete the following steps:

a. In the installer launch page, click Next to view the Welcome to the 
Essbase Spreadsheet Services screen, and click Next.

b. In the Select Installation Folder screen, perform one of the following 
tasks:

● Accept the default installation location shown in the Folder text box 
and click Next. 

● Click Browse and in the Browse for Folder dialog box, navigate to 
the location where you want to install Essbase Spreadsheet Services, 
and then click OK. In the Select Installation Folder screen, click 
Next. 

You can also click Disk Cost to view the drives on which you can install 
Essbase Spreadsheet Services, the amount of space available on each 
drive, and the space required to install Spreadsheet Services.

c. You are prompted that Essbase Spreadsheet Services is ready to install in 
the Confirm Installation screen. Click Next to begin the installation.

d. A progress bar is displayed in the Installing Essbase Spreadsheet 
Services screen. When it is enabled, click the Next button. 

e. In the Installation Complete screen, a message is displayed stating that, 
Essbase Spreadsheet Services has been successfully installed. Click Close 
to exit the installer.

Note: If you experience a conflict between the Standard Spreadsheet Add-In and 
the Spreadsheet Services Add-in, see “Possible Conflict Between Standard 
Spreadsheet Add-In and Spreadsheet Services Add-in” on page 32.
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Files Installed
The MSI file installs the following Spreadsheet Services client files in the 
Essbase Spreadsheet Services folder:

bin
eesaddin.xll //Spreadsheet Services Add-in file
esstolbar.xla //Spreadsheet Services toolbar file
msxml4.dll // {Microsoft XML
msxml4a.dll // {parser files used by
msxml4r.dll // {Spreadsheet Services

docs
ssclient.hlp //Spreadsheet Services online help
ssclient.cnt //Spreadsheet Services online help contents
roboex32.dll //Required for viewing the online help
inetwh32.dll //Required for launch web pages from 

//online help

Adding the Spreadsheet Services Add-in to Excel

➤ To add the Spreadsheet Services Add-in to Excel:

1. In Excel, select Tools > Add-Ins.

Excel displays the Add-Ins dialog box.

2. Click the Browse button.

Excel displays the Browse dialog box.

3. Select the eesaddin.xll file.

The file is located in the bin directory where you installed Spreadsheet 
Services Add-in on your PC hard disk drive (if you installed Spreadsheet 
Services there) or in the bin directory on a network drive (if you set up your 
PC operating environment to run Spreadsheet Services Add-in there).

4. Click OK twice to close the dialog boxes.

The Essbase Spreadsheet Services startup screen is displayed automatically. If 
you do not see the Essbase startup screen or if you do not see an Essbase menu 
in Excel, exit and then restart Excel. If the problem persists, see your system 
administrator.

Note: Adding Spreadsheet Services Add-in to Excel modifies the Windows 
Registry to point to where the Spreadsheet Services Add-in file is installed.
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Accessing Spreadsheet Services Add-In Online Help
The Spreadsheet Services Add-In Online Help is installed automatically in the 
Essbase Spreadsheet Services\docs directory as indicated in “Files 
Installed” on page 36.

➤ To access the Spreadsheet Services Add-In Online Help in Excel, select Help > 
Essbase Spreadsheet Services Help.

Uninstalling the Spreadsheet Services Client
You uninstall the Spreadsheet Services product using Windows Add/Remove 
Programs.

➤ To remove the Spreadsheet Services client program from your computer:

1. In the Windows Control panel, select Add/Remove Programs. 

2. In the Currently installed programs list, select Essbase Spreadsheet 
Services, and click the Remove button.

The program is uninstalled automatically and Essbase Spreadsheet Services is 
removed from the list of currently installed program.

Uninstalling Essbase Spreadsheet Services
You can uninstall Essbase Spreadsheet Services from Windows systems and UNIX 
systems. This section shows you how to uninstall Essbase Spreadsheet Services 
software from your computer or from a network drive.

Instructions for Uninstalling from Windows Systems
To uninstall Essbase Spreadsheet Services, use the Windows Add/Remove 
Programs icon in the Control Panel.

➤ To uninstall Essbase Spreadsheet Services from Windows:

1. Select Start > Settings > Control Panel > Add/Remove Programs.

2. Select Change/Remove Programs, select the Essbase Spreadsheet Services 
software you want to remove, and click Change/Remove.
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3. Click Yes to confirm that you want to remove the program.

An uninstallation wizard is launched. Follow the prompts in the wizard.

4. If a Remove Shared File? prompt appears, click Yes To All.

Windows removes the program and associated files. If some elements of the 
program could not be removed, click Details for more information.

5. Click OK. 

Instructions for Uninstalling from UNIX Systems
To uninstall Essbase Spreadsheet Services, use the uninstaller program created by 
the Essbase Spreadsheet Services installation program. The uninstaller program 
requires a supported version of the Java Runtime Environment to be in the path.

➤ To uninstall Essbase Spreadsheet Services from UNIX systems:

1. Log on to the computer with Essbase Spreadsheet Services using the same 
user account that installed the software.

2. Move to the HYPERION_HOME/eds/Uninstall/ directory.

3. Execute the uninstallEssbaseSpreadsheetServices.exe file; for 
example, at the command prompt, type the following command:

>./uninstallEssbaseSpreadsheetServices 

The uninstaller program removes the program and associated files.
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