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Client Overview

IBM WebSphere® Data Interchange V3.3

This presentation will give an overview for the WebSphere Data Interchange (WDI) Client.
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Agenda

� Overview

� WDI Client security

� Audit Trail

� Record identifier

� List windows

� Editors

� Document Store

� Functional areas

� Submitting work to WDI Server

� Preferences and database options

� Object properties

� Other features

� Summary

The presentation will review Client security, audit trails, list windows and editors, and functional 
areas.
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Overview

�Access and manage Administrative functions

�Navigation bar and menu 

�Online Help

�Database System selection

�Microsoft Windows graphical environment

You use the WebSphere Data Interchange Client main application window to access and 
manage all functions that can be performed in the Client. It contains a navigation bar and a 
menu. The navigator bar consists of a series of buttons that open the functional areas of 
WebSphere Data Interchange Client. The help button opens the online help for WebSphere Data 
Interchange Client. You can also select the system you want to work with from the System drop-
down menu on the Navigator bar.

WebSphere Data Interchange Client includes online, context-sensitive Help that permits you to 
display information about virtually any aspect of the program. In most cases, getting the help you 
need is as easy as clicking a Help button or pressing the F1 key. The Help system contains 
information about each WebSphere Data Interchange Client screen and field and explains how 
to use the operations presented to you. You also have access to the WebSphere Data 
Interchange Client glossary of terms, error messages, and WebSphere Data Interchange 
reference material. 

WebSphere Data Interchange Client is designed to make setup, maintenance, and management 
of WebSphere Data Interchange easier by using the Microsoft Windows graphical environment. 
Through the WebSphere Data Interchange Client interface you can create, update, and manage 
the WebSphere Data Interchange components. 



IBM Software Group

4

Client  Overview © 2007 IBM Corporation

Envelope
Profiles

Trading 
Partner

Standards

XML

Data
Formats

Mapping

Rules and 
Usages

Server 
Commands

Help

Document Store

Adapters

Processing

Environment

WDI Client Main Window

This is the main window of WDI Client.  This is a standard Windows 
screen configuration with the addition of the WDI navigation bar. Each of 
the buttons on the Menu Bar identify a Functional Area of WDI. The 
System dropdown identifies the database being accessed when a 
Functional Area button is clicked.
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System editor

List of Systems – databases accessible

Using WDI Client you can view the database systems available for the development and runtime 
environments.  To view a list of database systems available go to View, Administration, and 
select Systems.  To view the details of the database, select the system from the list and double 
click. 
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Using Windows

� List Windows

�Editor Windows 

� Informational dialogs

WebSphere Data Interchange Client displays information in three types of windows:

List windows, which display in either a multi-column or tree format.  

Editor windows, which allow you to create or edit objects.  

Informational dialogs, which may contain user prompts or warnings. 
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� List Windows

Using Windows

The purpose of a list window is to display a list of items of a given type, such as a list of Trading 
Partners. List windows permit you to choose items on which you want to perform such actions 
as editing, printing, deleting, and renaming. You can also view WebSphere Data Interchange 
data in a tree view, rather than in the tabbed list window. 
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List windows

� List view

�Right click popup menu

�Sort by clicking on a column header

�Reorder columns by dragging column headers

�Show and hide columns by right clicking on a column 
header

�Export list window contents

�Folder column

� Tree view

�Selected objects can group into “folders”

�Also supports the right click popup menu

For international characters, the following features are available in the list windows:

•Right clicking on the list window will display a popup menu. The popup menu will contain 
actions that can be taken against objects selected in the list window, actions that can be taken 
against the object type, and actions that can be taken against the list window. Which actions are 
available depend on the object type, whether objects are selected, and security settings.

•Rows in a list window can be sorted by clicking on the header of the column you wish to sort by. 
The sort alternates between ascending and descending.

•Column can be reordered by dragging the column header to the desired position.

•You can right click on a column header to display a popup menu that allows you to display and 
hide columns.

•The contents of a list window can be exported. The export is in a delimited format and you can 
export all rows in the list window or just selected rows.

•Most objects support a “folder” column. The “folder” can be used to group objects into logical 
groups. The groups can be used for searches in Queries and for sorting in a list window. The 
tree view version of the list window will group objects into folders when the folder is included in 
the Query.
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�Editor Windows

Using Windows

Editors display when you open an object in a list window. They feature tabs that contain fields, 
lists, check boxes, and other Windows controls.
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Editors

� Data Formats
�Details tab page

�Record ID

� Standards
�Details tab page

�Notes

� Application Defaults profile
�Event handling

�Document Store

� Trading Partner profile
�Contacts tab page 

� Send Maps and Receive Maps
�Details tab page

•The Data Format related editors contain. 

•The Details tab page provides functions similar to the list window. Details are maintained using a dialog 

similar to the existing Code List Editor, Translation Table Editors, and Business IDs on the Trading Partner 

Profile Editor.

•The Data Format Editor displays information from the selected Record ID Information object. This is 

informational only.

•Options are provided on the Record Editor to indicate whether the Record will use the Record ID 

Information object specified in the Data Format, whether an alternate Record ID Information object will be 

used, or whether the fields making up the Record Identifier will be identified on the Details tab page. If a 

Record ID Information object is selected, information from the selected Record ID Information object will be 
displayed for informational purposes only.

•The standards related editors contain.

•The Details tab page provides functions similar to the list window. Details are maintained using a dialog 

similar to the existing Code List Editor, Translation Table Editors, and Business IDs on the Trading Partner 

Profile Editor.

•The standard notes are directly maintained in the related parent editor. Notes appear on a separate tab 

page and are maintained similar to details. For instance, instead of have a Segment Editor and a Segment 

Notes Editor, the Segment Notes Editor is a tab page on the Segment Editor.

•The Application Defaults Profile Editor includes support for the Document Store and WDI Server’s event handling.

•The Trading Partner Profile Editor contains a Contacts tab page.

•The Send Map Editor and Receive Map Editor contains a Details tab page which includes support for standard 

functions, including “find” and popup menus. 
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Selecting Commands

�Menu

� Tool Bar

�Navigator bar

�List Window tool bar

�Editor tool bar

�Shortcuts

WebSphere Data Interchange Client offers three different methods of selecting commands. 

You can perform an action by selecting its command from a menu using the mouse or keyboard.  

You can perform an action by clicking its button using the mouse.  

You can perform an action using keyboard or mouse shortcuts.

Menu options offer the most comprehensive method of performing common WebSphere Data 
Interchange functions. Using the menu options you can: open new and existing items; create a 
query or a report; import and export components; save, close, preview, and print items; navigate 
through lists of items; set viewing preferences; access help; and exit WebSphere Data 
Interchange Client. 

You can use tool bar buttons as shortcuts to perform most of the frequently used WebSphere 
Data Interchange Client menu commands. The three WebSphere Data Interchange Client tool 
bars are  Navigator bar, List Window tool bar, and Editor tool bar. the Navigator bar at the top of 
the WebSphere Data Interchange main screen, ensure it is checked in the View menu. 
Navigator bar buttons open WebSphere Data Interchange Client’s functional areas. Each work 
area in WebSphere Data Interchange Client contains lists of items, which display in list windows. 
Each list window contains a tool bar. Each list window contains a list of components that you 
create and maintain using editors. Each editor contains a tool bar. 

WebSphere Data Interchange Client permits you to select menu commands using standard 
Windows keyboard or mouse shortcuts. You can also use the keyboard to select items in list and 
editors, as well as navigate through fields in editors and grids.    
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Client FeaturesClient Features

Proceed to the next slide
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Client Features

�Security and Audit Trail

�Record Identifier

�Document Store

� Functional Areas

�Submitting work to WDI Server

� International character sets

�List window and some editors

�WDI Server event handling

�Usability features for reporting

•The Security and Audit Trail features are optional. Security can be used to prevent access to 
certain object types or to specific objects within an object type.

•Record identifiers in Data Formats provide greater flexibility in identifying records in a 
proprietary document. 

•The “Document Store” was previously known as the “Transaction Store”. It provides all of the 
function formally provided by the WDI Transaction Store Facility, including functions that submit 
a document to the Server for processing. The Document Store also can include XML and Data 
Format documents involved in translation using Data Transformation Maps. 

•The Setup Functional Area profiles have been divided into multiple Functional Areas, called 
Envelopes, Adapters, Environment, and Processing,

• PERFORM commands can also be submitted to the WDI Server.

•The WDI Client supports international character sets. 

•New Profiles add support for the WDI Server event handling features. 

•Reports are provided for each window shown. These are now in HTML format and can be 
manipulated by the local browser..
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WDI Client Security

�Optional Role Based Access Control

�Restricts what object types a user can view

�Restricts what functions a user can perform

�System specific

�Supported in the Configuration database

�Use System Editor or Configuration database 

options to enable or disable

�Applies to all users of the System

WDI Client provides security. There are two independent components used to implement 
security on WDI Client. Neither of these components is used by the WDI Server. 

•The first component is called “role based access control”. This optional component is used to 
restrict what objects types a user can access, and what functions the user can perform on an 
object type. “Role based access control” is System specific; meaning you can enable it on one 
System and disable it on another System. A user’s access can be different on each System. 
“Role based access control” is also supported on the Configuration database when the 
Configuration database is shared by users.

•The System Editor and the Configuration database options are used to enable and disable “role 
based access control” and specify options related to “role based access control”.

•Role based access control options apply to all users of the System or Configuration database.



*IBM Confidential*

IBM Software Group Page 15 of 14

IBM Software Group

15

Client  Overview © 2007 IBM Corporation

WDI Client Security (continued)

�Optional Access Group support

�Restricts which specific objects a user can see in list 
windows

�System specific

�Not available in the Configuration database

�Use System Editor to enable or disable

�Applies to all users of the System

•The second component of security is “Access Groups”. “Access Groups” are used to restrict 
which specific objects a user can see in a list window. For instance, you may want to allow to 
see all Trading Partner profiles related to Asia business, but no others. “Access Groups” are 
System specific; meaning you can enable it on one system and disable it on another system. A 
user’s access can be different on each System. “Access Groups” are not supported on the 
Configuration database.

•The System Editor is used to enable and disable Access Groups and specify options related to 
“Access Groups”.

•Access Groups options apply to all users of the System.
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WDI Client Security (continued)

�Object types to support security

�Roles

�Access Groups

�User ID Definitions

� &WDIUSER

� Located in Security Functional Area

�View->Administration->Security

�View->Administration->Configuration Database->Security

�Assign objects to an Access Group using Object 

Properties

•There are three object types to support security.  They are Roles, Access Groups, and User ID Definitions.

•A Role defines a specific job responsibility, such as “mapper”, “trading partner administrator”, or 

“administrator”. Each Role identifies a set of object types that can be accessed by users assigned to the 

Role. A Role also indicates what type of actions a user can perform against an object type. For instance, a 

Role may specify that users can update existing Trading Partner profiles but cannot create new Trading 
Partner profiles. Roles can be imbedded within other Roles. When this occurs, the access privileges are 

merged.

•An Access Group simply defines the name of an Access Group.

•A User ID Definition identifies a user on a System or the Configuration database. Any number of Access 

Groups and Roles can be assigned to the user ID Definition. In addition, specific access privileges can be 
assigned to the user. Specific access privileges override those specified in Roles.

•Any user that does not have a User ID Definition will be assigned the access privileges granted to 

the default &WDIUSER User ID Definition. If &WDIUSER does not exist then the unknown user will 
have no access privileges.

•The security related objects are located in the Security Functional Area.

•Access the Security Functional Area by selecting Administration and then Security from the View menu. 

This displays the Security Functional Area for the System selected on the navigator bar. The Security 

Functional Area for a System can also be displayed by selecting Open Functional Area from the File menu.

•Access the Security Functional Area for the Configuration database by selecting Administration, 

Configuration Database, and then Security from the View menu.

•Objects are assigned to a single Access Group by selecting the object in a list window and then selecting Object 

Properties from the Actions menu. An Access Group can also be assigned to objects during import.
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Audit Trail

� Optional Audit Trail support

�Documents change events

� Does not document the changes themselves

�System specific

�Supported in the Configuration database

� Use System Editor or Configuration database options to 
enable or disable

� Applies to all users of the System

� Located in Audit Trail Functional Area

�View->Audit Trail

�View->Administration->Configuration Database->Audit Trail

•WDI Client supports an optional Audit Trail. The Audit Trail documents change events on a 
System or on the Configuration database. It does not document the changes themselves. The 
Audit Trail is System specific; meaning you can enable it on one System and disable it on 
another System.

•The System Editor and the Configuration database options are used to enable and disable the 
Audit Trail and specify options related to the Audit Trail.

•Audit Trail options apply to all users of the System or Configuration database.

•The Audit Trail for a System can be viewed by selecting Audit Trail from the View menu. This 
displays the Audit Trail for the System selected on the navigator bar. The Audit Trail for a 
System can also be displayed by selecting Open Functional Area from the File menu.

•Access the Audit Trail for the Configuration database by selecting Administration, Configuration 
Database, and then Audit Trail from the View menu.
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Record identifier

�Supports:

�Control and Data (C&D) Record format

�Raw data with record ID in same position and length

�Raw data with different record ID positions and length

�Raw data with multiple fields used for the record ID

WDI Client allows you to have record identifiers in different positions within a record and with 
different field lengths. A record identifier can also be specified using multiple fields.
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Document Store

� Formally called the “Transaction Store”

� Includes the existing “Transaction Store” objects

� Includes XML and Data Format documents

�Existing WDI Server functions…

�Moved to WDI Client

�Includes list window to view results

� “Document Store” disabled on default System

The “Document Store” includes the existing “Transaction Store” objects plus XML and Data 
Format documents involved in translation using Data Transformation Maps. List windows are 
provided in the Document Store Functional Area to view XML documents and Data Format 
documents.

Previously existing WDI Transaction Store Utility functions have been moved to the WDI Client 
Document Store. This means you can submit documents in the Document Store to the WDI 
Server for processing. A list window to view the status and results of submissions is included in 
the Document Store Functional Area.

The Document Store Functional Area is disabled on the default System provided with WDI Client 
since the WDI Server cannot place document information into that System.
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Functional areas

� Setup Functional Area divided into:

�Adapters 

�Environment

�Processing

�Envelope Profiles

� Server Commands Functional Area

� Document Store

� Mapping Functional Area

�Code Lists included here and in EDI Standards

� CICS Performance and Activity Log profiles deleted

� Event Destination and Data Reference profiles 

•The Setup Functional Area has been divided into the Adapters Functional Area, Environment 
Functional Area, Processing Functional Area, and Envelope Profiles Functional Area.

•There are also functional areas for Server Commands and the Document Store.

•Code Lists are available in the Mapping Functional Area and the EDI Standards Functional 
Area.

•The CICS Performance profile and the Activity Log profile used in prior WDI Client releases 
have been deleted in WDI 3.3.

•WDI Client also includes the Event Destination profile and the Data Reference profile.
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Functional areas: Adapters Functional Area

�Mailbox profile

�Network profile

�Network Commands profiles

�Network Security profile

�Queue profile

�Formally known as MQSeries Queue profile

�Continuous Receive profile

�fields – for common error handling

The Adapters Function Area contains profiles related to sending and receiving documents. It 
includes the existing Mailbox profile, Network profile, Network Commands profile, Network 
Security profile, Queue profile, and Continuous Receive profile.

The Queue profile was previously known as the MQSeries Queue profile.

The Continuous Receive profile provides support for the WDI Server’s common error handling.
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Functional areas: Environment Functional Area

�Application Defaults Profile

�New fields – for WDI Server’s event handling

�New tab pages “Error Handling”, “Associated Error 
Messages” – for common event handling

�More options for Document Store support

� Language Profile

The Environment Functional Area contains profiles related to the processing environment 
established for the WDI Server. The Application Defaults profile and Language profile are 
contained in this area.

More Document Store related options appear on the General tab page of the Application 
Defaults Profile Editor. There are also new fields related to event handling on WDI Server. The 
Application Defaults Profile Editor also contains two tab pages; “Error Handling” and “Associated 
Error Messages”. The tab pages support event handling on the WDI Server. 
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Functional areas: Processing Functional Area

�Service Profile

�Restructured

�File references replaced by Data References

�Can be submitted to WDI Server for processing

�Message Content Descriptor (MCD) Profile

�User Exits

�Event Destination

�Part of common error handling

�Data References

�Identifies a logical file used by WDI Server

The Processing Functional Area contains profiles that are used during WDI Server processing. These include the 

existing Service profile, Message Content Descriptor MCD profile, and User Exit profile and the new Event 
Destination profile and Data Reference profile.

The Service profile has been restructured to remove the limitations on number of files. File references have been 

replaced by Data References. Each Data Reference identifies a file used by WDI Server when processing the 

Service profile. Data References are listed and maintained on the  “Associated Data References” tab page.  Service 
profiles can be submitted to the WDI Server to execute the PERFORM command contained within the Service 

profile. Results from each submission can be viewed on the new “Associated Submissions” tab page.

The Event Destination profile defines “events” that will be recognized by the WDI Server. The profile also indicates 

how the event will be handled by the WDI Server. This profile can be used to cause the print file to be routed to 

another destination when a specific event occurs. The print file can be in human readable or machine readable 
format.

WebSphere Data Interchange uses Data Reference profiles to identify and define files used in a PERFORM 

command. Data Reference profiles define the logical-to-physical file relationships, and include common files, input 

files, output files, network files, and export and import files. Data Reference profiles are only used to supply file 
information that is not otherwise provided.
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Functional areas: Envelope Profiles

�Envelope Profiles 

�All Envelope Profile Editors  

�Include EDI standard envelope fields

�More information about each field

�Named according to the EDI Standard

�Includes only fields that WDI Server will use a value from

Envelope profiles are located in the Envelope Profiles Functional Area. The editors only include 
the data elements that the use can provide a value for. 
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Functional areas: Commands Functional Area

�Command Dictionary

�Used to group Commands

�Server Command objects

�Contains a PERFORM command

�Submissions

�Used to view results from submitted Command objects, 

Service Profiles, Document Store items

The Commands Functional Area is used to maintain objects used to submit PERFORM 
commands to the WDI Server.

•The Commands Dictionary object is similar to other “dictionaries” in WDI Client. It is used to 
group Command objects in any way you desire.

•Command Objects contain a WDI Server PERFORM command. Command objects can be 
submitted to the WDI Server for processing.

•Use the Submissions List window to view the status and results of commands that have been 
submitted to the WDI Server. The Submissions List window can also show the results of Service 
profile submissions and Document Store submissions. The Submissions List window is not 
displayed for a System supplied by WDI Client since the WDI Server does not interact with that 
System.
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Submitting work to WDI Server

� The WDI Client can submit work to WDI Server

�Document Store

�Service Profiles

�Server Command objects

� Disabled when using any WDI Client supplied database

� Viewing Results

�List window in the Commands Functional Area

�List window in the Document Store Functional Area

�In the Service Profile Editor

�Will not see the list windows in any WDI Client supplied database

Work can be submitted to the WDI Server. This includes submitting documents from the 
Document Store to the WDI Server for processing and also submitting PERFORM commands. 
PERFORM commands can be submitted to the WDI Server using Service profiles or Command 
objects. You cannot submit work when the System is the default System provided by WDI Client. 
This is because WDI Server does not interact with the default System.

Results from the various submissions can be viewed in a list window in the Commands 
Functional Area or in the Document Store Functional Area. PERFORM commands submitted 
using a Service Profile can be viewed on a tab page in the Service Profile Editor.
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Preferences and database options

� Preferences contain only user specific application options

� Configuration database

�Configuration Database Options

� User specific options

� System options

� Audit Trail

� Security

� System Editor

�User specific options

�System options

�Audit Trail

�Security

•Preferences used to contain global options related to Systems, options specific to the current 
System, and user specific application options. User specific application options are located in 
Preferences. All other options are available using the System Editor. The user can set user 
specific System options, but should be done in the System Editor.

•The Configuration database contains a submenu called “Configuration Database” within the 
View menu. It is used to access the Configuration database’s Audit Trail and Security Functional 
Area. The submenu is also used to display the new Configuration database options. The options 
are used to enable or disable security and the Audit Trail on the Configuration database, as well 
as set other options related to the Configuration database.

•The System Editor includes all System options, as well as user specific options pertaining to the 
System. The options are used to enable or disable security and the Audit Trail on the System.
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Object properties

�Contains Folder name and/or Access Group

�Available for most objects

�Accessed using Object Properties on View menu

�Can be set in list window or editor

Most objects support object properties. Object properties include a “folder” name and an Access 
Group. Object properties are available only when folders or Access Groups are enabled on the 
System. Object properties are displayed and set using the Object Properties function on the 
Action menu. The properties can be set from a list window or from an editor.
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Other features

� “Event Log” disabled on default System

� Import window

�Identifies specific objects

� System Open and Close

� Data manipulation command - SetElementAttribute()

� Mapping commands

�ErrorContext()

�FAErrorPath()

� Reports display to a browser

•The Event Log is disabled on the default System provided with WDI Client since the WDI 
Server does not write to that System.

•The import window breaks all objects types into their specific object types. In the past, all maps 
were grouped into the type “Maps” regardless of the actual map type. This affects maps and a 
few other object types.

•Functions are provided to specifically open and close a System. These are found under the File 
menu.

•The SetElementAttribute command allows additional field editing. In WDI 3.3, attributes have 
been added to the SetElementAttribute() mapping command.

•The mapping commands ErrorContext() and FAErrorPath() are available to Validation Maps.

•All formatted reports of list and editor windows display in a browser. From there they can be 
printed or saved to disk.
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Summary

� Improved security options

�Role Based Access Control, Access Groups, Audit Trail

� Improvements in usability 

�List window, preferences, Systems, functional areas, new 
WDI Server functions supported by WDI Client

� Increased Document Store function

�Data Formats, XML Documents, Submitting

� Interaction with the WDI Server

�Commands, Service Profiles, Document Store

To conclude, WDI Client supports reasonable security features that can be used to limit what 
objects types a user can access, what functions can be performed against objects within an 
object type, and even which objects within an object type a user can access. An Audit Trail is 
available to track who is changing what.

Enhancements have been made to WDI Client to make the application more usable. These 
include updates to functional areas, list windows, editors, reporting, submitting work to the WDI 
Server, and more…

All WDI Transaction Store features have been moved to the Document Store. XML and Data 
Format documents can be saved in the Document Store. Documents in the Document Store can 
be submitted to the WDI Server from the WDI Client.
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